Форматы графических файлов

GIF
JPEG
 PNG
 TIFF
 PostScript
 EPS
 PDF
 Scitex CT
 Adobe Photoshop Document
 Adobe Illustrator Document
 Macromedia FreeHand Document
 CorelDRAW Document
 PICT
 WMF
 BMP
 RTF

Методы сжатия

LZW
 JPEG
 Huffman
 CCITT
 RLE (Run Length)

Знание файловых форматов и их возможностей является одним из ключевых факторов в допечатной подготовке изданий, подготовке изображений для web и в компьютерной графике вообще. Да, сегодня нет такого калейдоскопа расширений, как в начале 90-х, когда каждая компания-производитель редакторов изображений считала своим долгом создать свой файловый тип, а то и не один, однако это не означает, что "все нужно сохранять в TIFF, а сжимать JPEG'ом". Каждый, из утвердившихся сегодня форматов, прошел естественный отбор, доказал свою жизнеспособность и нужность. Все они имеют какие-то характерные особенности и возможности, делающие их незаменимыми в работе. Знание особенностей, тонкостей технологии важно для современного дизайнера так же, как для художника необходимо разбираться в различиях химического состава красок, свойствах грунтов, типов металлов и породах дерева.

Основное назначение Знания, по большому счету, это расширение возможностей человека, увеличение степени его свободы, когда человек поступает так, как считает нужным, а не так, как вынуждают его обстоятельства.

* * *

Все графические данные в компьютере можно разделить на на две большие ветви: растровую и векторную. Векторы представляют из себя математическое описание объектов относительно точки начала координат. Проще говоря, чтобы компьютер нарисовал прямую нужны координаты двух точек, которые связываются по кратчайшей, для дуги задается радиус и т.д. Таким образом, векторная иллюстрация это набор геометрических примитивов. Большинство векторных форматов могут так же содержать внедрённые в файл растровые объекты или ссылку на растровый файл (технология OPI). Сложность при передаче данных из одного векторного формата в другой заключается в использовании программами различных алгоритмов, разной математики при построении векторных и описании растровых объектов.

OPI (Open Prepress Interface) — технология, разработанная фирмой Aldus, позволяющая импортировать не оригинальные файлы, а их образы, создавая в программе лишь копию низкого разрешения (эскиз) и ссылку на оригинал. В процессе печати на принтер, эскизы подменяются на оригинальные файлы. Применение OPI, вместо простого внедрения, (embedding) дает возможность экономить ресурсы компьютера (прежде всего, память), заметно повышая его производительность. OPI является основной работы с импортированными графическими файлами в таких программах, как FreeHand и QuarkXPress, широко применяется в других продуктах.

Растровый файл устроен проще (для понимания, по крайней мере). Он представляет из себя прямоугольную матрицу (bitmap), разделенную на маленькие квадратики - пикселы (pixel - picture element). Растровые файлы можно разделить на два типа: предназначенные для вывода на экран и для печати.

Разрешение файлов таких форматов как GIF, JPEG, BMP зависит от видеосистемы компьютера. В старых Маках на квадратный дюйм экрана приходилось 72 пиксела (экранное разрешение), на Windows единого стандарта не сложилось, но сегодня чаще всего употребляется значение 96 пикселов на квадратный дюйм экрана. Реально, однако, эти параметры теперь стали довольно условными, так как почти все видеосистемы современных компьютеров позволяют изменять количество отображаемых на экране пикселов. Растровые форматы, предназначенные исключительно для вывода на экран, имеют только экранное разрешение, то есть один пиксел в файле соответствует одному экранному пикселу. На печать они выводятся так же с экранным разрешением.

Растровые файлы, предназначенные для допечатной подготовки изданий имеют, подобно большинству векторных форматов, параметр Print Size - печатный размер. С ним связано понятие печатного разрешения, которое представляет из себя соотношение количества пикселов на один квадратный дюйм страницы (ppi, pixels per inch или dpi - dots per inch, - термин не совсем верный, но часто употребимый). Печатное разрешение может быть от 130 dpi (для газеты) до 300 (высококачественная печать), больше почти никогда не нужно.

Растровые форматы, так же отличаются друг от друга способностью нести дополнительную информацию: различные цветовые модели, вектора, Альфа-каналы или каналы плашковых (spot)-цветов, слои различных типов, интерлиньяж (черезстрочная подгрузка), анимация, возможности сжатия и другое.

оглавление

GIF (CompuServe Graphics Interchange Format)

Независящий от аппаратного обеспечения формат GIF был разработан в 1987 году (GIF87a) фирмой CompuServe для передачи растровых изображений по сетям. В 1989-м формат был модифицирован (GIF89a), были добавлены поддержка прозрачности и анимации. GIF использует LZW-компрессию, что позволяет неплохо сжимать файлы, в которых много однородных заливок (логотипы, надписи, схемы).

Метод сжатия LZW (Lempel-Ziv-Welch) разработан в 1978 году израильтянами Лемпелом и Зивом и доработан позднее в США. Сжимает данные путем поиска одинаковых последовательностей (они называются фразы) во всем файле. Выявленные последовательности сохраняются в таблице, им присваиваются более короткие маркеры (ключи). Так, если в изображении имеются наборы из розового, оранжевого и зеленого пикселов, повторяющиеся 50 раз, LZW выявляет это, присваивает данному набору отдельное число (например, 7) и затем сохраняет эти данные 50 раз в виде числа 7. Метод LZW, так же, как и RLE, лучше действует на участках однородных, свободных от шума цветов, он действует гораздо лучше, чем RLE, при сжатии произвольных графических данных, но процесс кодирования и распаковки происходит медленнее.

GIF позволяет записывать изображение "через строчку" (Interlaced), благодаря чему, имея только часть файла, можно увидеть изображение целиком, но с меньшим разрешением. Это достигается за счет записи, а затем подгрузки, сначала 1, 5, 10 и т.д. строчек пикселов и растягивания данных между ними, вторым проходом следуют 2, 6, 11 строчки, разрешение изображения в интернетовском браузере увеличивается. Таким образом, задолго до окончания загрузки файла пользователь может понять, что внутри и решить, стоит ли ждать, когда файл поднимется весь. Черезстрочная запись незначительно увеличивает размер файла, но это, как правило, оправдывается приобретаемым свойством.

В GIF’e можно назначить один или более цветов прозрачными, они станут невидимыми в интернетовских браузерах и некоторых других программах. Прозрачность обеспечивается за счет дополнительного Alpha-канала, сохраняемого вместе с файлом. Кроме того файл GIF может содержать не одну, а несколько растровых картинок, которые браузеры могут подгружать одну за другой с указанной в файле частотой. Так достигается иллюзия движения (GIF-анимация).

Основное ограничение формата GIF состоит в том, что цветное изображение может быть записано только в режиме 256 цветов. Для полиграфии этого явно недостаточно.

оглавление

JPEG (Joint Photographic Experts Group)

Строго говоря JPEG’ом называется не формат, а алгоритм сжатия, основанный не на поиске одинаковых элементов, как в RLE и LZW, а на разнице между пикселами. Кодирование данных происходит в несколько этапов. Сначала графические данные конвертируются в цветовое пространство типа LAB, затем отбрасывается половина или три четверти информации о цвете (в зависимости от реализации алгоритма). Далее анализируются блоки 8х8 пикселов. Для каждого блока формируется набор чисел. Первые несколько чисел представляют цвет блока в целом, в то время, как последующие числа отражают тонкие делали. Спектр деталей базируется на зрительном восприятии человека, поэтому крупные детали более заметны.

На следующем этапе, в зависимости от выбранного вами уровня качества, отбрасывается определенная часть чисел, представляющих тонкие детали. На последнем этапе используется кодирование методом Хафмана для более эффективного сжатия конечных данных. Восстановление данных происходит в обратном порядке.

Таким образом, чем выше уровень компрессии, тем больше данных отбрасывается, тем ниже качество. Используя JPEG можно получить файл в 1-500 раз меньше, чем ВМР! Формат аппаратно независим, полностью поддерживается на РС и Macintosh, однако он относительно нов и не понимается старыми программами (до 1995 года). JPEG не поддерживает индексированные палитры цветов. Первоначально в спецификациях формата не было и CMYK, Adobe добавила поддержку цветоделения, однако CMYK JPEG во многих программах делает проблемы. Лучшим решением является использование JPEG-сжатия в Photoshop EPS-файлах, которое описывается ниже.

Существуют подформаты JPEG. Baseline Optimized - файлы несколько лучше сжимаются, но не читаются некоторыми программами. JPEG Baseline Optimized разработан специально для Интернета, все основные браузеры его поддерживают. Progressive JPEG так же разработан специально для Сети, его файлы меньше стандартных, но чуть больше Baseline Optimized. Главная особенность Progressive JPEG в поддержке аналога черезстрочного вывода.

Из сказанного можно сделать следующие выводы. JPEG’ом лучше сжимаются растровые картинки фотографического качества, чем логотипы или схемы - в них больше полутоновых переходов, среди однотонных заливок же появляются нежелательные помехи. Лучше сжимаются и с меньшими потерями большие изображения для web или с высокой печатной резолюцией (200-300 и боее dpi), чем с низкой (72-150 dpi), т.к. в каждом квадрате 8х8 пикселов переходы получаются более мягкие, за счет того, что их (квадратов) в таких файлах больше. Нежелательно сохранять с JPEG-сжатием любые изображения, где важны все нюансы цветопередачи (репродукции), так как во время сжатия происходит отбрасывание цветовой информации. В JPEG’е следует сохранять только конечный вариант работы, потому что каждое пересохранение приводит ко все новым потерям (отбрасыванию) данных и превращении исходного изображения с кашу.

Цветовое пространство LAB представляет цвет в трех каналах: один канал выделен для значений яркости (L - Lightnes) и два других - для цветовой информации (А и В). Цветовые каналы соответствуют шкале, а не какому-нибудь одному цвету. Канал А представляет непрерывный спектр от зеленого к красному, в то время как канал В - от синего к желтому. Средние значения для А и В соответствуют реальным оттенкам серого.

Существует похожая цветовая модель YCC, используемая в форматах Kodak Photo CD и FlashPix, здесь не описываемых.

Метод сжатия Хаффмана (Huffman) разработан в 1952 году и используется как составная часть в ряде других схем сжатия, таких как LZW, Дефляция, JPEG. В методе Хаффмана берется набор символов, который анализируется, чтобы определить частоту каждого символа. Затем для наиболее часто встречающихся символов используется представление в виде минимально возможного количества битов. Например, буква "е" чаще всего встречается в английских текстах. Используя кодировку Хаффмана вы можете представить "е" всего лишь двумя битами (1 и 0), вместо восьми битов, необходимых для представления буквы "е" в кодировке ASCII.

оглавление

PNG (Portable Network Graphics)

PNG - разработанный относительно недавно формат для Сети, призванный заменить собой устаревший GIF. Использует сжатие без потерь Deflate, сходное с LZW (именно из-за патентования в 1995-м году алгоритма LZW возник PNG). Сжатые индексированные файлы PNG, как правило, меньше аналогичных GIF'ов, RGB PNG меньше соответствующего файла в формате TIFF.

Глубина цвета файлах PNG может быть любой, вплоть до 48 бит. Используется двумерный interlacing (не только строк, но и столбцов), который, так же, как и в GIF'е, слегка увеличивает размер файла. В отличие от GIF'а, где прозрачность как мед - либо есть, либо нет, PNG поддерживает также полупрозрачные пикселы (то есть в диапазоне прозрачности от 0 до 99%) за счет Альфа-канала с 256 градациями серого.

В файл формата PNG записывается информация о гамма-коррекции. Гамма представляет собой некое число, характеризующее зависимость яркости свечения экрана вашего монитора от напряжения на электродах кинескопа. Это число, считанное из файла, позволяет ввести поправку яркости при отображении. Нужно оно для того, чтобы картинка, созданная на Мас’е, выглядела одинаково и на РС и на Silicon Graphics. Таким образом эта особенность помогает реализации основной идеи WWW - одинакового отображения информации независимо от аппаратуры пользователя.

PNG поддерживается в Microsoft Internet Explorer начиная с версии 4 для Windows и с версии 4.5 на Макинтош. Netscape добавила поддержку PNG для своего браузера в версиях, начиная с 4.0.4 для обеих платформ. Тем не менее до сих пор не реализована поддержка таких важных функций формата, как плавно переходящая прозрачность и гамма-коррекция.

оглавление

TIFF (Tagged Image File Format)

Аппаратно независимый формат TIFF, на сегодняшний день, является одним из самых распространенных и надежных, его поддерживают практически все программы на РС и Macintosh так или иначе связанные с графикой. TIFF является лучшим выбором при импорте растровой графики в векторные программы и издательские системы. Ему доступен весь диапазон цветовых моделей от монохромной до RGB, CMYK и дополнительных цветов Pantone. TIFF может сохранять обтравочные контуры, Альфа-каналы, другие дополнительные данные.

TIFF имеет две разновидности: для Macintosh и РС. Это связано с тем, что процессоры Motorola читают и записывают числа слева направо, а процессоры Intel - наоборот. Современные программы могут без проблем использовать оба варианта формата.

В формате TIFF может быть использована LZW-компрессия. Ряд старых программ (например, QuarkXPress 3.x, Adobe Streamline, многие программы-распознаватели текста) не умеют читать сжатые файлы TIFF, однако, если вы пользуетесь новым программным обеспечением, нет причины не использовать компрессию.

оглавление

Adobe PostScript

PostScript - язык описания страниц (язык управления лазерными принтерами) фирмы Adobe. Был создан в 80-х годах для реализации принципа WYSIWYG (What You See is What You Get). Файлы этого формата фактически представляют из себя программу с командами на выполнение для выводного устройства. Они имеют расширение .ps или, реже, .prn и получаются с помощью функции Print to File графических программ при использовании драйвера PostScript-принтера. Такие файлы содержат в себе сам документ (только то, что располагалось на страницах), все связанные файлы (как растровые, так и векторные), использованные шрифты, а так же другую информацию: цветоделение, дополнительные платы, линиатуру растра и форму растровой точки для каждой платы и другие данные для выводного устройства. Если файл закрыт правильно, не имеет значения на какой платформе он делался, были использованы шрифты True Type или Adobe Type 1 - все равно.

Растровые данные, как правило, записываются в двоичной кодировке (Binary). Бинарный код занимает вдвое меньше места, чем ASCII. Кодировка ASCII иногда требуется для передачи файлов через сети, для кроссплатформенного обмена, для печати через последовательные кабели. В приведенных случаях двоичная кодировка может исказиться (что сделает файл нечитаемым) или вызвать "странное" поведение файл-сервера. Эти проблемы давно изжиты в современных системах, но старые компьютеры и серверы бывают им подвержены. Сказанное относится ко всем форматам, основанным на языке PostScript: EPS и PDF, которые описываются ниже.

оглавление

EPS (Encapsulated PostScript)

Формат Encapsulated PostScript можно назвать самым надежным и универсальным способом сохранения данных. Он использует упрощенную версию PostScript: не может содержать в одном файле более одной страницы, не сохраняет ряд установок для принтера. Как и в файлы печати PostScript, в EPS записывают конечный вариант работы, хотя такие программы, как Adobe Illustrator и Adobe Photoshop могут использовать его как рабочий. EPS предназначен для передачи векторов и растра в издательские системы, создается почти всеми программами, работающими с графикой. Использовать его имеет смысл только тогда, когда вывод осуществляется на PostScript-устройстве. EPS поддерживает все необходимые для печати цветовые модели, среди них такая, как Duotone, может записывать, так же, данные в RGB, обтравочный контур, информацию и треппинге и растрах, внедренные шрифты. В формате EPS сохраняют данные в буфере обмена (Clipboard) программы Adobe для обмена между собой.

Вместе с файлом можно сохранить эскиз (image header, preview). Это копия низкого разрешения в формате PICT, TIFF, JPEG или WMF, которая сохраняется вместе с файлом EPS и позволяет увидеть, что внутри, поскольку открыть файл на редакцию могут только Photoshop и Illustrator. Все остальные импортируют эскиз, подменяя его при печати на PostScript-принтере оригинальной информацией. На принтере, не поддерживающем PostScript, выводится на печать сам эскиз. Если вы работаете на Photoshop для Макинтош, сохраняйте эскизы в формате JPEG, остальные маковские программы сохраняют эскизы в формате PICT. Эти и JPEG-эскизы не могут использовать Windows-приложения. Если вы работаете на PC или не знаете, где будет использоваться файл, сохраняйте эскиз в формате TIFF (когда предоставляется выбор). CorelDRAW так же предлагает для эскиза векторный формат WMF, стоит очень осторожно пользоваться этим детищем Microsoft - до добра не доведет.

Изначально EPS разрабатывался как векторный формат, позднее появилась его растровая разновидность - Photoshop EPS. Кроме типа эскиза (TIFF, PICT, JPEG) Photoshop дает возможность выбрать способ кодирования данных. ASCII, Binery и JPEG. Первые два описывались выше, на JPEG стоит остановиться.

Photoshop позволяет сжимать растровые данные с помощью алгоритма JPEG. Adobe доработала этот способ сжатия. Теперь JPEG, в исполнении Photoshop, поддерживает CMYK и сжимает лучше, чем JPEG, полностью соответствующий первоначальным спецификациям. Другими словами, EPS-файлы без эскиза с JPEG-кодированием весят меньше, чем аналогичные файлы формата JPEG! Однако обращу внимание на важную особенность в работе с JPEG-сжатием в EPS. Драйверы принтеров и фотонаборных автоматов не могут выполнять цветоделение таких файлов. То есть при выполнении цветоделения на вашем компьютере EPS-картинка с JPEG-сжатием полностью окажется на первой плате (Cyan, обычно). Тем не менее, в сервисном бюро рабочие станции Scitex (их большинство в Израиле) могут цветоделить страницы с JPEG EPS-иллюстрациями без всяких проблем. Системы других фирм, думаю, так же поддерживают JPEG EPS, в любом случае стоит поинтересоваться. В сервисных бюро и типографиях Тель-Авива мне часто рекомендовали использовать для записи растровых данных именно JPEG EPS вместо TIFF, так как он быстрее выводится.

EPS имеет много разновидностей, что зависит от программы-создателя. Самые надежные EPS создают программы производства Adobe Systems: Photoshop, Illustrator, InDesign. С 1996 года программы Adobe имеют встроенный интерпретатор PostScript, поэтому могут открывать EPS и редактировать их. Эта возможность представляется мне очень важной. Остальные графические редакторы открывать EPS не могут, мало того, создаваемые ими EPS-файлы иногда оказываются, мягко говоря, особенными. Среди самых проблемных Quark EPS, создаваемый функцией Save Page As EPS и FreeHand editable EPS, создаваемый функцией Save As. Не стоит особенно доверять Corel’овским EPS версии 6 и ниже и EPS из CorelXARA. У EPS-файлов из CorelDRAW 7 и выше сохраняется проблема добавления полей к Bounding Box (условный прямоугольник в PostScript, описывающий все объекты на странице). Прежде, чем экспортировать из CorelDRAW, CorelXARA и, в меньшей степени, из FreeHand'а EPS-файлы стоит конвертировать многие эффекты программ (полупрозрачные заливки, например) в растровые или простые векторные объекты. Толстые контуры (более 2 pt), возможно, имеет смысл конвертировать в так же объекты, когда программа дает такую возможность. Проверить EPS-файл можно Adobe Illustrator'ом, если он открывает - значит все в порядке.

оглавление

PDF (Portable Document Format)

PDF предложен фирмой Adobe как независимый от платформы формат для создания электронной документации, презентаций, передачи верстки и графики через сети.

PDF-файлы создаются путем конвертации из PostScript-файлов или функцией экспорта ряда программ. Photoshop и Illustrator могут создавать одностраничные файлы PDF. Illustrator 8, как это ни странно для программы Adobe, имеет проблему со встраиванием шрифтов. Photoshop же выпускает PDF отличного качества. Многостраничные PDF могут создавать InDesign, FreeHand 7-9, PDFWriter и Acrobat Distiller некоторые другие программы. PDFWriter работает как виртуальный принтер. Он не основан на PostScript и не может корректно обрабатывать графику, PDFWriter предназначен для быстрого изготовления простых текстовых документов. У него наблюдается та же проблема со встраиванием шрифтов, что и у Illustrator'а. FreeHand, так же, не может внедрять шрифты. Самые надежные и максимально близкие к оригиналу PDF создает из PostScript и EPS-файлов программа Acrobat Distiller, поставляемая в пакете Adobe Acrobat и вместе и PageMaker'ом.

PDF первоначально проектировался как компактный формат электронной документации. Поэтому все данные в нем могут сжиматься, причем к разного типа информации применяются разные, наиболее подходящие для них типы сжатия: JPEG, RLE, CCITT, ZIP (похожее на LZW и известное еще как Deflate). Программа Acrobat Exchange 3 (которая в 4-й версии стала называться просто Acrobat 4.0) позволяет расставлять гиперссылки, заполняемые поля, включать в файл PDF видео и звук, другие действия.

Метод сжатия CCITT (International Telegraph and Telephone Committie) был разработан для факсимильной передачи и приема. Является более узкой версией кодирования методом Хаффмана. CCITT Group 3 идентичен формату факсовых сообщений, CCITT Group 4 - формат факсов, но без специальной управляющей информации.

Файл PDF может быть оптимизирован. Из него удаляются повторяющиеся элементы, устанавливается постраничный порядок загрузки страниц через web, с приоритетом сначала для текста, потом графика, наконец шрифты. Обратите внимание, когда повторяющихся элементов нет, файл, после оптимизации, как правило, несколько увеличивается.

PDF все больше используется для передачи по сетям в компактном виде графики и верстки. Он может сохранять всю информацию для выводного устройства, которая была в исходном PostScript-файле. Это касается PDF версий 3 и 4. Однако, в 3 версия не может включать сведения о треппинге, некоторые другие специфические данные (DSC, например), не использует цветовые профили. Все это возмещено в 4-й версии, используйте ее, если есть возможность.

оглавление

Scitex CT

PostScript-файл, предназначенный для вывода проходит ряд этапов на пути к фотонаборному автомату. Важнейшим из них является растрирование - процесс конвертации PostScript-данных в битовую карту, выполняемый интерпретатором PostScript (RIP). Разработанный фирмой Scitex файловый формат Scitex CT является не чем иным как битовой картой готовой к выводу на фотонаборных автоматах Dolev этой фирмы. Формат удобен тогда, когда не требуется выполнение треппинга, электронного спуска полос (импозиции), др. операций, только вывод. Это может быть, например, плакат формата A2. Если вы сделали сложную графику с большим количеством векторных и растровых элементов и опасаетесь проблем на выводе, то, может быть, стоит попытаться растрировать работу в Photoshop'е и передать ее в сервисное бюро в виде файла Scitex CT (.sct). [Вышеприведенные данные получены в сервисном бюро "Миксам", Тель-Авив]

Scitex CT во многом похож на TIFF, но не поддерживает Indexed Color, RGB, Альфа-каналы, сжатие; может включать в себя векторные контуры. Не стоит, однако, их использовать, если работа идет прямо на фотонаборный автомат. Scitex CT поддерживается всеми основными настольными издательскими системами, программами подготовки иллюстраций. Используя в работе с ними Scitex CT вместо TIFF, можно получить некоторый прирост в скорости растрирования и другой обработке данных на рабочей станции Scitex непосредственно перед выводом.

оглавление

Adobe Photoshop Document

Внутренний формат популярного растрового редактора Photoshop в последнее время стал поддерживаться все большим количеством программ. Он позволяет записывать изображение со многими слоями, их масками, дополнительными Альфа-каналами и каналами простых (spot) цветов (начиная с версии 5), контурами и другой информацией - все, что может сделать Photoshop. В версии 3.0 появляются слои, контуры и RLE-компрессия, в 4-й версии алгоритм улучшается, файлы становятся еще меньше. В версии 5 реализован принципиально иной подход к управлению цветом. В программу была внедрена архитектура управления цветом, основанная на профилях для сканеров, мониторов и принтеров Международного консорциума по цвету (International Color Consortium, ICC).

Несмотря на то, что в 5-й версии появились новые эффекты со слоями, текстом, а так же возможность создавть дополнительные каналы для простых цветов, профили, формат Photoshop'a имеет полную совместимость от 5-й до 3-й версии. В Photoshop'e 2.5 не было слоев и контуров, поэтому он выступает, как отдельный подформат.

Однослойный Photoshop Document понимают ряд программ, многослойные могут импортировать Illustrator и InDesidn. Fractal Design Painter и Corel PHOTO-PAINT открывают на редакцию многослойные документы Photoshop, причем лишь PHOTO-PAINT 8 открывает файл Photoshop'а 100-процентно корректно.

Одной из простейших форм сжатия является метод RLE (Run Length Encoding - кодирование с переменной длиной строки). Действие метода RLE заключается в поиске одинаковых пикселов в одной строке. Если в строке, допустим, имеется 3 пиксела белого цвета, 21 - черного, затем 14 - белого, то применение RLE дает возможность не запоминать каждый из них (38 пикселов), а записать как 3 белых, 21 черный и 14 белых в первой строке.

Так же как и LZW, RLE хорошо работает с искусственными и пастеризованными картинками и плохо с фотографиями. В действительности, если фотография детализирована, RLE может даже увеличить размер файла.

оглавление

    Adobe Illustrator Document

Adobe Illustrator - самый первый продукт Adobe. Он был создан сразу же после выхода PostScript Level 1, его можно назвать интерфейсом для PostScript (многие программы даже определяют формат Adobe Illustrator Document, как Generic EPS). Формат Illustrator'а напрямую открывается Photoshop'ом, его поддерживают почти все программы Макинтош и Windows так или иначе связанные с векторной графикой и графикой вообще. Все, что создает Adobe Illustrator, поддерживается PostScript'ом (исключение составляют, разве что Gradient Meshes в 8-й версии, которые нужно растеризовать перед закрытием на печать).

Формат Illustrator’ра является наилучшим посредником при передаче векторов из одной программы в другую, с РС на Macintosh и назад. Наиболее совместимыми можо назвать 3-ю и 4-ю версии. При передаче градиентных заливок между векторными редакторами в редактируемом виде (когда они не конвертируются в последовательность фигур) нужно использовать версии формата, начиная с 6-й. Внедренные или связанные с документом растровые файлы при обмене через формат Illustrator'a теряются.

Текущая версия формата Illustrator'а (8) не может содержать внедренных шрифтов, но способна работать с такими особенными шрифтовыми форматами, как Adobe Type 3 и Adobe Multiple Master.

Illustrator не распространен в Израиле из-за отсутствия поддержки иврита в последних версиях. Русифицированные версии Adobe Illustrator for Windows могут корректно открывать файлы этой программы, содержащие русский текст с Макинтош.

оглавление

Macromedia FreeHand Document

Ничем особенным не выделяется. Формат понимает только сам FreeHand, Illustrator 7, 8 для Macintosh и парочка программ от Macromedia. 7-я и 8-я версии имеют полную кроссплатформенную совместимость. Поддерживает многостраничность. Графический язык FreeHand'a можно назвать PostScript-совместимым - он похож на него, но ряд эффектов текста, некоторые типы заливок несовместимы с PostScript. Формат программы FreeHand может содержать внедренные растровые файлы или только ссылки на них (технология OPI); внедрять файлы шрифтов не может.

FreeHand является стандартом векторной графики в Израиле, многие сервисные бюро (лишкот шерут) предпочитают принимать файлы именно в его формате.

оглавление

CorelDRAW Document

Формат известен в прошлом низкой устойчивостью, плохой совместимостью файлов, искажением цветовых характеристик внедряемых битовых карт, тем не менее пользоваться CorelDRAW чрезвычайно удобно, он имеет неоспоримое лидерство на платформе РС. Многие программы на РС (FreeHand, Illustrator, PageMaker - среди них) могут импортировать файлы CorelDRAW.

В седьмой версии многие основные проблемы были решены. Ее, 8-ю и 9-ю версии CorelDRAW можно без натяжек назвать профессиональными. В файлах этих версий применяется компрессия для векторов и растра отдельно, могут внедряться шрифты, файлы CorelDRAW имеют огромное рабочее поле 45х45 метров (этот параметр важен для наружней рекламы); начиная с 4-й версии поддерживается многостраничность, начиная с 7-й - технология OPI.

Сказанное означает, что файлы формата CorelDRAW можно применять для переноса/передачи работ на PC, но нежелательно импортировать в программы верстки. На Макинтош файлы CorelDRAW for Windows открывают версия CorelDRAW для Макинтош и Adobe Illustrator 8.

оглавление

PICT (Macintosh QuickDraw Picture Format)

PICT - собственный формат Макинтош. Стандарт для буфера обмена, использует графический язык Mac OS. PICT способен нести растровую, векторную информацию, текст и звук, использует RLE-компрессию. Поддерживается на Mac’e всеми программами. Чисто битовые PICT-файлы могут иметь любую глубину битового представления (от Lineart до CMYK). Векторные PICT-файлы, которые почти исчезли из употребления в наши дни, имели странные проблемы с толщиной линии и другими отклонениями при печати. Формат используется для потребностей Mac OS, и при создании определенных типов презентаций только для Макинтош. Вне Макинтош PICT имеет расширение .pic или .pct, читается отдельными программами, но работа с ним редко бывает простой и бесхитростной.

оглавление

WMF (Windows Metafile)

Векторный формат WMF использует графический язык Windows и, можно сказать, является ее родным форматом. Служит для передачи векторов через буфер обмена (Clipboard). Понимается практически всеми программами Windows, так или иначе связанными с векторной графикой. Однако, несмотря на кажущуюся простоту и универсальность, пользоваться форматом WMF стоит только в крайних случаях для передачи "голых" векторов. WMF искажает (!) цвет, не может сохранять ряд параметров, которые могут быть присвоены объектам в различных векторных редакторах, не может содержать растровые объекты, не понимается очень многими программами на Macintosh.

оглавление

BMP (Windows Device Independent Bitmap)

Еще один родной формат Windows. Он поддерживается всеми графическими редакторами, работающими под управлением этой операционной системы. Применяется для хранения растровых изображений, предназначенных для использования в Windows и, по сути, больше ни на что не пригоден. Способен хранить как индексированный (до 256 цветов), так и RGB-цвет (16.700.000 оттенков). Возможно применение сжатия по принципу RLE, но делать это не рекомендуется, так как очень многие программы таких файлов (они могут иметь расширение .rle) не понимают. Существует разновидность формата ВМР для операционной системы OS/2.

Использование BMP не для нужд Windows является распространенной ошибкой новичков. Я описываю здесь этот формат только для того, чтобы подчеркнуть - использовать BMP нельзя ни в web, ни для печати (особенно), ни для простого переноса и хранения информации.

оглавление

RTF (Microsoft Rich Text Format)

Текстовый формат RTF попал сюда за свои неординарные способности к переносу текстов из одной программы в другую. Он позволяет переносить форматированный текст из программ оптического распознавания символов или текстовых редакторов в графические программы или в любых других направлениях. RTF может оказаться хорошим решением (а, иногда, и единственным выходом) при переброске из программы в программу нелатинского, например, ивритского текста или русского в Windows 95/98 Hebrew Edition.

Секрет совместимости заключается в использовании специальных тегов форматирования RTF и Unicode. Именно Unicode, кстати (использованный как основа формата Microsoft Word 97/98 для Макинтош и PC), позволяет легко переносить русские тексты с PC на Мак и обратно в файлах MS Word 97/98.

На Макинтош RTF менее применим, так как у программ, работающих под управлением Mac OS, не наблюдается таких проблем с совместимостью и переносом текста, как у Windows-приложений.

Оглавление


The page of Alexey Kletsel

Цвет в компьютере: какой он бывает?

Излучаемый и отражаемый свет
Аддитивные и субтрактивные цвета
 RGB
 CMYK
 HSB/HSL
 Индексированный цвет и понятие битовой глубины
 Grayscale

Как-то холодным сибирским сентябрем, когда ночью уже замерзают лужи, а к вечеру моросящий дождь переходит в снег, на стене автобусной остановки я прочитал объявление о том, что контора по имени "Компьютерная Грамотность" обучает всех желающих работе на компьютере IBM PC. Таких мест в городе было много и везде преподавали одно и то же: DOS, Windows 3.1, Norton, Word 6 и т. п. Мое внимание привлекло обучение сканированию и лозунг: "Мы даем не корочки, а знания".

Я хочу рассказать о человеке, который научил меня включать компьютер, о своем учителе.

Это оказалась обшарпанная однокомнатная квартира советского типа, вся заваленная компьютерным хламом: дискетами, книгами, платами, шнурами, корпусами компьютеров. Среди этого "порядка" в кресле покачивался гражданин неряшливого вида, лет 35-40. Ни он, ни его "офис", положительно, доверия не вызывали. Графических программ он не знал, CorelDRAW у него не было, но мне и моему товарищу Богдану были обещаны в дополнение (и за отдельную плату) курсы борьбы с вирусами, архивации и работы с ручным сканером.

Владимир Алексеевич Русинов — техник-электронщик по образованию и педагог по призванию, мастер спорта по стоклеточным шашкам — был человеком выдающихся способностей, но совершенно неорганизованным и безалаберным. В восьмидесятых в составе бригады объездил весь Союз, настраивая телевизионные станции. В конце Перестройки приехал на Север и занялся персональными компьютерами различных типов. Все, что он знал, выучил самостоятельно. А знал учитель много и умел подать. На своих курсах преподавал внутреннее устройство IBM PC-совместимых машин, подробно описывал работу компьютера и всех основных периферийных устройств, программ, делал упор на понимание принципа работы, а не на заучивание команд. Лекции по программам и железу перемежались с беседами по психологии и истории (за счет фирмы, естественно :-); он любил Гумилева.

Как-то на занятии по мониторам учитель принялся объяснять принцип действия электронно-лучевой трубки (ЭЛТ), способ получения изображения и цвета. "Основные цвета, — сказал он, — красный, зеленый и синий, их смешением получаются все остальные". Этого мы с Богданом не поняли. Преподаватели рисования нас всегда учили (да и по опыту мы знали), что три основных цвета — это красный, синий и желтый, именно их смешением получаются все остальные. Мы даже собрались принести ему краски и продемонстрировать. Но бывший техник телевизионных студий не соглашался, он стал открывать какие-то программы (примитивные досовские и виндозные рисовалки, как выяснилось впоследствии) и стал нам показывать, как смешивается цвет. Мы стали в тупик.

оглавление

Свет излучаемый и отражаемый

Одна из наиболее важных мыслей, которую необходимо помнить, говоря о цвете, заключается в том, что некоторые предметы мы видим потому, что они излучают свет, а другие — потому, что они его отражают. Когда предметы излучают свет они приобретают тот цвет, который мы видим. Когда они отражают свет (бумага, например), их цвет определяется цветом падающего на них света и цветом, который эти объекты отражают.

Таким образом, излучаемый свет — это свет, выходящий из активного источника: солнца, лампочки, экрана монитора; отраженный свет — это свет, "отскочивший" от поверхности объекта. Именно его вы видите, когда смотрите на какой-либо предмет, не излучающий собственного света.

Излучаемый свет может содержать все цвета (белый свет), любую их комбинацию или только один цвет. Излучаемый свет, идущий непосредственно из источника к вашему глазу, сохраняет в себе все цвета, из которых он был создан. Некоторые волны излученного света поглощаются объектом, поэтому доходят до нас и воспринимаются глазом только непоглощенные, отраженные волны.

Белый листок бумаги выглядит белым потому, что он отражает все цвета в белом свете и ни один не поглощает. Если вы осветите его синим светом, бумага будет выглядеть синей. Если вы осветите белым светом листок красной бумаги, бумага будет выглядеть красной, так как она поглощает все цвета, кроме красного. Что произойдет, если осветить красную бумагу синим светом? Бумага будет выглядеть черной, потому что синий цвет, падающий на нее, она не отражает.

Отражение и излучение света оставалось не более чем любопытной темой до появления компьютерной обработки цветных изображений. Сегодня диаметрально противоположные способы генерации цвета мониторов и принтеров являются основной причиной искажения экранных цветов при печати. Для того чтобы правильно производить цветоделение нужно хорошо представлять работу двух противоположных систем описания цвета в компьютере: аддитивной и субтрактивной.

оглавление

Аддитивные и субтрактивные цвета

Аддитивный цвет (от англ. add — добавлять, складывать) получается при соединении лучей света разных цветов. В этой системе отсутствие всех цветов представляет собой черный цвет, а присутствие всех цветов — белый. Система аддитивных цветов работает с излучаемым светом, например, от монитора компьютера.

В этой системе используются три основных цвета: красный, зеленый и синий (RGB). Если их смешать друг с другом в равной пропорции, они образуют белый цвет, а при смешивании в разных пропорциях — любой другой.

В системе субтрактивных цветов (от англ. subtract — вычитать) происходит обратный процесс: вы получаете какой-либо цвет, вычитая другие цвета из общего луча отраженного света. В этой системе белый цвет появляется в результате отсутствия всех цветов, тогда как их присутствие дает черный цвет. Система субтрактивных цветов работает с отраженным светом, например, от листа бумаги. Белая бумага отражает все цвета, окрашенная — некоторые поглощает, а остальные отражает.

В системе субтрактивных цветов основными являются голубой, пурпурный и желтый цвета (CMY) — противоположные красному, зеленому и синему. Когда эти цвета смешиваются на белой бумаге в равной пропорции, получается черный цвет. Вернее, предполагается, что должен получиться черный цвет. В действительности типографские краски поглощают свет не полностью и поэтому комбинация трех основных цветов выглядит темно-коричневой. Чтобы исправить возникающую неточность, для представления тонов истинно черного принтеры добавляют немного черной краски. Систему цветов, основанную на таком процессе четырехцветной печати, принято обозначать аббревиатурой CMYK.

оглавление

Цветовая модель RGB

Монитор компьютера создает цвет непосредственно излучением света и использует, таким образом, систему цветов RGB. Поверхность монитора состоит из мельчайших точек (пикселов) красного, зеленого и синего цветов, форма точек варьируется в зависимости от типа электронно-лучевой трубки (ЭЛТ). Пушка ЭЛТ подает сигнал различной мощности на экранные пикселы. Каждая точка имеет один из трех цветов, при попадании на нее луча из пушки, она окрашивается в определенный оттенок своего цвета, в зависимости от силы сигнала. Поскольку точки маленькие, уже с небольшого расстояния они визуально смешиваются друг с другом и перестают быть различимы. Комбинируя различные значения основных цветов, можно создать любой оттенок из более чем 16 миллионов доступных в RGB.

Лампа сканера светит на поверхность захватываемого изображения (или сквозь слайд); отраженный или прошедший через слайд свет, с помощью системы зеркал, попадает на чувствительные датчики, которые передают данные в компьютер так же в системе RGB.

Система RGB адекватна цветовому восприятию человеческого глаза, рецепторы которого тоже настроены на красный, зеленый и синий цвета.

оглавление

Цветовая модель CMYK

Система цветов CMYK была широко известна задолго до того, как компьютеры стали использоваться для создания графических изображений. Триада основных печатных цветов: голубой, пурпурный и желтый (CMY, без черного) является, по сути, наследником трех основных цветов живописи (синего, красного и желтого). Изменение оттенка первых двух связано с отличным от художественных химическим составом печатных красок, но принцип смешения тот же самый. И художественные, и печатные краски, несмотря на провозглашаемую самодостаточность, не могут дать очень многих оттенков. Поэтому художники используют дополнительные краски на основе чистых пигментов, а печатники добавляют, как минимум, черную краску.

Система CMYK создана и используется для печати. Все файлы, предназначенные для вывода в типографии, должны быть конвертированы в CMYK. Этот процесс называется цветоделением.

оглавление

Цветовые модели HSB и HSL

Системы цветов RGB и CMYK базируются на ограничениях, накладываемых аппаратным обеспечением (мониторами и сканерами в случае с RGB и типографскими красками в случае с CMYK). Более интуитивным способом описания цвета является представление его в виде тона, насыщенности и яркости — система HSB. Она же известна как система HSL (тон, насыщенность, освещенность).

Тон представляет собой конкретный оттенок цвета, отличный от других: красный, зеленый, голубой и т. п. Насыщенность цвета характеризует его относительную интенсивность (или чистоту). Уменьшая насыщенность, например, красного, мы делаем его более пастельным, приближаем к серому. Яркость (или освещенность) цвета показывает величину черного оттенка, добавленного к цвету, что делает его более темным.

Система HSB имеет перед другими системами важное преимущество: она больше соответствует природе цвета, хорошо согласуется с моделью восприятия цвета человеком. Многие оттенки можно быстро и удобно получить в HSB, конвертировав затем в RGB или CMYK, доработав в последнем случае, если цвет был искажен.

оглавление

Индексированный цвет и понятие битовой глубины

Перед тем, как перейти к теме цветового формата, использующего ограниченную палитру цветов, необходимо понять, каким образом в пикселе графического файла записываются данные о цвете.

Пиксел, как и все данные в компьютере, несет в себе определенную информацию (в данном случае о цвете), выражаемую в битах. Понятно, что чем большим количеством бит описывается пиксел, тем больше информации он может в себе нести. Это обозначается понятием "битовая глубина". Битовую глубину изображения часто называют цветовой разрешающей способностью. Она измеряется в битах на пиксел (bit per pixel, bpp). Так если, к примеру, речь идет об иллюстрации, имеющей в каждом пикселе по 8 бит цветовой информации, то ее цветовая разрешающая способность будет 8 bpp. Возведя 2 (компьютер использует двоичную систему счисления) в степень битовой глубины (2 в 8-й степени) получим 256 доступных для 8-битового изображения цветов.

На принципе 8-битного цвета основана широко использовавшаяся в первой половине 90-х и применяемая в Интернете даже сегодня цветовая модель Index Color. Она работает на основе создания палитры цветов. Все оттенки в файле делятся на 256 возможных вариантов, каждому из которых присваивается номер. Далее, на основе получившейся палитры цветов, строится таблица, где каждому номеру ячейки приписывается цветовой оттенок в значениях RGB.

К форматам файлов, использующим только индексированные палитры относятся распространенный в прошлом на РС формат программы Paint — PCX, а так же, не потерявший и в наши дни своей актуальности, GIF. Некоторые форматы как, например, тот же GIF или PNG (читайте о формате PNG в статье на стр. 32), позволяют делать палитры на основе произвольного количества цветов (до 256).

До появления 8-битного цвета, из-за малых мощностей персональных компьютеров тех времен, использовались палитры из 16 цветов (4 bpp), 4 цветов (2 bpp) и самая первая компьютерная графика была однобитовая — 2 цвета. Однобитовые изображения, называемые Bitmap или, иногда, Lineart, используются и сегодня там, где не требуются цвето-тоновые переходы. Равный по размеру Bitmap-файл в 24 раза меньше, чем файл RGB, кроме того очень хорошо сжимается.

оглавление

Цветовая модель Grayscale

Цветовая модель Grayscale представляет собой ту же индексированную палитру, где вместо цвета пикселам назначена одна из 256 градаций серого. На основе Grayscale легко можно понять строение RGB- и CMYK-файлов.

В RGB для описания цвета используются 24 бита, которые делятся на три группы по 8 бит (то, что называется в Photoshop'е каналами). Одна группа используется для хранения в пикселе величины красного цвета, две другие — зеленого и синего. Они могут дать до 16 700 000 комбинаций оттенков. Аналогичным образом в CMYK существуют 4 группы, для описания цвета используются 32 bpp. Alpha-каналы, быстрая маска, маски слоев в Photoshop'е имеют совершенно сходную 8-битовую природу, но носят вспомогательный характер и не влияют на цвет. Обращу внимание, что если RGB имеет стандартные 256 градаций яркости, то в CMYK яркость измеряется в процентах (то есть до 100). Несмотря на большую, чем в RGB цветовую глубину в 32 бита на пиксел, диапазон оттенков CMYK значительно меньше, чем в RGB, так как CMYK является не более, чем имитацией на экране печатных цветов.

Цветовые пространства LAB и YCC имеют специфическое и достаточно узкое применение, поэтому здесь не рассматриваются. Если вам необходима информация, вы можете прочесть справку по ним в статье "Форматы графических файлов", моего авторства.

* * *

...Однажды, под конец курсов, я спросил у учителя, с какого типа компьютерами я могу столкнуться в Израиле (он знал, что я собрался уезжать)? Он ответил, что наиболее распространенные на сегодня, по его мнению, это IBM PC-совместимые машины, остальные платформы не выдерживают конкуренции. "Но, я слышал, — добавил он, — есть компьютеры, называемые Макинтош, сам их не видел, говорят они дороже, но мощнее IBM. Возможно, у тебя будет возможность на них поработать — их часто используют для графики".

С тех пор прошло несколько лет. Два года назад, из-за проблем с определенными структурами, учитель исчез из города. Контакт с ним потерялся.

оглавление

Оглавление


illustrator

 Box Box
Adobe Illustrator - программа, предназначенная для профессиональных художников-иллюстраторов и предоставляющая широкие возможности по созданию выскокачественных изображений для печати и публикации в Web.

Новые особенности

  • Интеграция с продуктами Adobe и другими приложениями

    • Представьте себе такую проблему: вам необходимо в кратчайшие сроки создать художественную работу, которую затем можно будет без помех редактировать или использовать в какой-либо настольной издательской программе. Какими программными средствами вам лучше всего воспользоваться? Ответ прост -наилучшим выбором будет Adobe Illustrator - полноправный представитель семейства Adobe. В процессе работы вы сможете легко экспортировать файлы Adobe Illustrator в Adobe Photoshop или Adobe ImageReady со всеми неповрежденными слоями. "Перетащить" изображение из рабочей области Adobe Illustrator в Adobe Photoshop, Adobe ImageReady, Adobe PageMaker и даже в приложения Microsoft Office также не составит большого труда. Кроме того, Adobe Illustrator поддерживает форматы файлов и для Mac, и для PC.
  • Поддержка всех основных форматов

    • Adobe Illustrator может работать с изображениями, созданными практически в любых приложениях, в том числе в Photoshop, Microsoft Office, AutoCAD, CorelDRAW, and Macromedia FreeHand. Кроме того, существует возможность сохранять файлы в таких популярных форматах, как EPS, PDF, Photoshop, TIF, GIF, JPEG, EMF/WMF, BMP, CGM, ASCII, и RTF.
  • Инструмент Карандаш

    • Пользоваться новым инструментом Карандаш в Adobe® Illustrator® 8.0 почти так же просто, как и обычным карандашом. Он позволяет рисовать и перерисовывать более естественно, упрощает и ускоряет процесс воплощения идей. Чтобы изменить какую-то часть рисунка, просто проведите новый контур около того участка, который вы хотите изменить. Illustrator автоматически преобразует фрагмент до желаемого вида, освобождая пользователя от необходимости манипулировать отдельными точками вручную.
  • Единый интерфейс

    • Illustrator использует тот же интерфейс, что и другие известные программы семейства Adobe -Adobe Photoshop®, Adobe ImageReadyTM, и Adobe PageMaker®. Если вы знакомы с особенностями хотя бы одного приложения Adobe, ваши знания будут весьма полезны и при работе с другими приложениями. Схожие инструменты, "горячие клавиши", палитры увеличивают эффективность работы и возможность переключения с одного приложения на другое.
  • Маркированные области

    • Illustrator 8.0 предлагает интуитивный подход для масштабирования объектов. Теперь вы можете быстро изменять размеры форм, текстовых блоков и контуров при помощи простой квадратной области, похожей на ту, что появляется вокруг объектов в PageMaker и Microsoft® Word. Растянуть или уменьшить элемент или группу элементов можно простым перемещением одного из маркеров области.
  • Поддержка

    • В состав Adobe Illustrator входит мультимедийный путеводитель по всей программе. Видео-ролики QuickTime демонстрируют работу отдельных инструментов. Предопределенные наборы кистей, коллекция предустановленных операций, шаблоны, изображения -все это позволяет существенно увеличить скорость создания иллюстраций. Кроме того, широкий набор обучающих программ и подсказок поможет вам быстро стать экспертом в области Adobe Illustrator.
  • Направляющие

    • Новые интерактивные направляющие в Adobe® Illustrator® 8.0 помогают выровнять формы, текстовые блоки и контуры. Эти вертикальные, горизонтальные и угловые направляющие появляются автоматически, когда вы создаете или перемещаете объект, что позволяет точнее разместить его по отношению к другим объектам на странице. Таким образом, направляющие обеспечивают необходимый уровень точности, что особенно полезно при создании технических рисунков.
  • Инструмент "пипетка" (eyedropped)

    • Этот инструмент всегда был очень полезен при преобразовании цветов и переносе атрибутов с одного объекта на другой. Теперь он также позволяет подобрать и применить нужное форматирование к текстовым объектам. Просто выберите блок текста, щелкните "пипеткой" на другом текстовом блоке - и этого будет достаточно для того, чтобы применить его атрибуты к выделенному тексту.
  • Палитра операций(Actions palette)

    • Палитра Операций, так же как в Adobe Photoshop®, позволяет автоматизировать повторяющиеся действия при помощи макросов. Если вы создаете какой-то эффект, который впоследствии хотели бы использовать повторно (например, эффект тени или трехмерные эффекты), достаточно просто записать все шаги как Операцию. Это означает, что даже довольно сложные задачи вы можете свести к выполнению одной-единственной операции. В состав Adobe Illustrator входит около ста предопределенных операций, которые позволяют сэкономить значительное количество времени.
  • Палитра связей

    • Adobe Illustrator 8.0 значительно упрощает процесс отслеживания изображений, внедренных в файл иллюстрации, а также связанных файлов. Подобно инструменту Links из Adobe PageMaker®, новая палитра связей позволяет быстро обновлять иллюстрацию - достаточно просто щелкнуть мышкой, чтобы заменить одно изображение другим.
  • Gradient Mesh Tool

    • Adobe® Illustrator® 8.0 обладает уникальным мощным инструментом Gradient Mesh, который позволяет смешивать несколько цветов в различных направлениях для создания естественных "размытий" и эффектов водяных красок. Достаточно выбрать цвет и щелкнуть на объекте инструментом Gradient Mesh, чтобы установить прозрачную для печати сетку и смешать цвета между точками сетки. При этом вы можете контролировать направление, форму и комбинации цветов.
  • Управление текстом

    • Известный своими возможностями управления текстом Adobe Illustrator предоставляет новые, более гибкие средства форматирования текста, позволяя сделать практически все, что вы только можете вообразить. Вы легко сможете разместить слова вокруг некоторого контура, в строчку или по кривой, поместить текст внутри или вне круглой области, изменить размер шрифта, кернинг, трекинг, расположить текст колонками, в виде таблицы и даже проверить орфографию.
  • "Живые" кисти (Live Brushes)

    • Illustrator 8.0 позволяет значительно расширить ваш творческий потенциал при помощи четырех "живых" кистей. Art brush дает возможность нарисовать части изображения по редактируемому контуру. Scatter brush предназначена для сглаживания границ между отдельными контурами. При помощи Calligraphic brush можно создавать изящные перьевые штрихи, являющиеся на самом деле удобными для редактирования контурами. Pattern brush помогает закрашивать области внутри контуров. А работая с библиотеками, содержащими около 400 встроенных кистей, или создавая собственные, вы сможете добиться поистине потрясающих результатов.

    Системные требования

    Windows

    • Процессор Pentium и выше
    • Microsoft Windows 95, Windows 98 или Windows NT 4.0
    • 32 MB оперативной памяти (64 MB рекомендуется)
    • 50 MB свободного дискового пространства (95 MB рекомендуется)
    Power Macintosh
    • Процессор PowerPC
    • Операционная система Apple System Software 7.5 или более поздняя
    • 32 MB оперативной памяти с 20 MB доступным для Adobe Illustrator (64 MB рекомендуется)

      • 50 MB свободного дискового пространства (95 MB рекомендуется)


index

Adobe InDesign

Adobe InDesign - это новая современная программа для верстки страниц, предоставляющая широкие творческие возможности и обеспечивающая высокую продуктивность и безошибочность в процессе интеграции с другими продуктами Adobe. Созданная для профессиональных дизайнеров высокого класса, художников, профессионалов предпечатной подготовки, Adobe InDesign раздвигает творческие границы, присущие издательским программам предыдущего поколения, предлагая новый набор средств, которые позволяют существенно сократить дистанцию между фантазией и реальностью

Ключевые особенности Тесная интеграция продуктов Adobe

  • Традиционный пользовательский интерфейс Adobe

    • Adobe InDesign, Adobe Illustrator и Adobe Photoshop имеют сходный внешний вид, поля, и ведут себя практически одинаково, так как имеют общие инструменты, команды, палитры и наборы горячих клавиш
  • Совместимость документов QuarkXPress и Adobe PageMaker

    • InDesign может одинаково легко работать с файлами QuarkXPress 3.3-4.04 и с файлами PageMaker 6.5.
  • Поддержка формата Adobe Portable Document Format (PDF)

    • публикации можно сохранять в формате PDF непосредственно в InDesign., предварительно установив опцию Set PDF для сжатия изображений, внедрения шрифтов и преобразования цветов.
  • Импорт файлов из Illustrator, Photoshop и PDF-формата

    • поместив или скопировав и вставив рабочее изображение из Illustrator или Photoshop в InDesign-публикацию, пользователь сможет в полной мере воспользоваться возможностями редактирования. Можно также вставлять страницы из PDF-файлов в качестве связанной графики
  • Объединенные технологии Adobe

    • технологии Adobe предполагают одинаковые возможности для работы со шрифтами, цветом и отображением графики на экране, а также поддержку формата PDF в InDesign, Photoshop, Illustrator и Adobe Acrobat
Свобода в выражении творческих идей
  • Вложенные текстовые и графические области

    • использование объектов (таких, как базовые формы, рисованные формы, конвертированный текст) как неких областей позволяет удержать текстовое и графическое содержимое в нужном месте. Создавая фрейм во фрейме и манипулируя вложенными объектами, можно добиться весьма впечатляющих результатов.
  • Градиентное заполнение и штрихи

    • можно создавать радиальное или линейное градиентное заполнение и заштриховывать форму или текст, изменять угол градиентного заполнения "на глаз", вручную или при помощи специальных средств, также можно редактировать текст, к которому применен градиент
  • Траектории (path)

    • при помощи Adobe's pen tool можно создавать основные элементы иллюстраций "на лету". Комбинируя несколько путей, можно получить необычную форму. Конвертируя текст в траекторию, можно впоследствии заполнить его рисунками или графиками и получить впечатляющий результат.
  • Масштабирование и сдвиг текстовых полей

    • выбирая текстовые и графические области и изменяя их взаимное расположение и размер, можно добиться создания новых эффектов. При этом текст по-прежнему остается доступным для редактирования и после произведенных трансформаций.
  • Clipping paths

    • при импортировании из Photoshop, EPS или файлов в формате TIFF объединенные траектории сохраняются, их так же можно автоматически создать и в Adobe InDesign.
  • Ненавязчивость ПО

    • не надо отвлекаться от дизайнерской работы, так как InDesign стирает грани между пользователем и программой. Например, печать маскированных TIFF-файлов становится более эффективной, так как InDesign отправляет на печать только видимые области изображения.
Более быстрая и продуктивная работа
  • Множественные откаты

    • можно бесконечно пробовать вносить новые и новые изменения, играть с эффектами, просматривать всевозможные варианты и при этом иметь возможность вернуться на любой этап работы.
  • Слои

    • располагая объекты в публикации на слоях, можно затем скрывать, реорганизовывать, показывать, перекрывать слои в соответствии с требованиями дизайна. Используя слои, можно создать несколько вариантов публикации в одном файле, таких, например, как версии брошюры на различных языках.
  • Мастер-страницы

    • создав в публикации множественные мастер-страницы, можно значительно облегчить использование ключевых элементов дизайна на отдельных страницах. Можно даже создать одну мастер-страницу на основе другой. В этом случае все изменения, сделанные на родительской мастер-странице, автоматически отразятся на всех дочерних страницах.
  • Редактор "горячих клавиш"

    • можно настроить набор "горячих клавиш" непосредственно под каждого конкретного пользователя. По умолчанию в InDesign используется такой же набор клавиш, как и в Photoshop и Illustrator, чтобы обеспечить более полную интеграцию и удобство пользователей. Как вариант, можно выбрать набор "горячих клавиш", характерный для QuarkXPress - такая возможность также предусмотрена в InDesign.
  • Стили для символов

    • можно задать набор атрибутов для символов, таких как размер, шрифт, кернинг, лигатура, цвет и т.д. Для таких специфических языков, как французский или немецкий, можно установить проверку орфографии. Есть возможность создавать стили, основанные на других стилях и задавать для них комбинацию "горячих клавиш" для более удобного применения.
  • Множественные окна для просмотра публикации

    • можно открыть сразу несколько окон для просмотра публикации в разных ракурсах. Например, в одном окне просматривать публикацию в сильно увеличенном виде, в другом - в реальном размере
  • Автоматическое преобразование разметки страницы

    • InDesign быстро делает все необходимые изменения при смене размера страницы, ориентации страницы, изменении краев и других установок при помощи инструмента Layout Adjustment. Эта возможность значительно облегчает жизнь дизайнерам в тех случаях, когда они хотят использовать ранее созданную публикацию для других целей.
  • Поддержка больших страниц и широких полос

    • размер создаваемых страниц может колебаться в пределах от 1/6 кв. дюйма до 5.48 кв.метров. Более того, страницы можно организовать в целые полосы, объемом до 10 страниц и просматривать всю публикацию целиком, оценивая, как страницы соотносятся одна с другой, или перемещать объекты между страницами.
Точность и контроль
  • Типографские средства создания композиций

    • пользователь имеет возможность выбрать между двумя высококачественными средствами создания композиций, чтобы автоматически с высокой точностью отрегулировать концы строк: многострочный редактор или однострочный редактор. Оба редактора используют встроенные линейки, чтобы обеспечить оптимальное распределение концов строк, учитывая при этом персональные установки дизайнера. Кроме того, новейший многострочный редактор рассматривает множество линий по одиночке, сравнивая каждую линию со следующей и предыдущей в абзаце для достижения оптимального результата. Однострочный редактор применяет эти правила к одной отдельно взятой строке единовременно.
  • Точность

    • Adobe InDesign предоставляет возможность выверять проекты с точностью до точки, чем не могут похвастаться другие издательские программы. Так, стало гораздо легче выдерживать стандарты выделения.
  • Расширенный контроль над кернингом

    • пользователь имеет возможность выбора между четырьмя различными опциями контроля над кернингом для установления точного интервала между символами: ручной кернинг, линейный кернинг (для преобразования просвета между линиями символов), встроенный парный кернинг (доступен для только для определенных шрифтов) и визуальный кернинг (для установления оптимального расстояния между буквами "на глазок").
  • Управление изменением масштаба просмотра

    • масштаб, в котором пользователь может отображать публикации для просмотра, колеблется в широких пределах - от 5% до 4,000%
  • Линии разметки и сетка

    • пользователь имеет возможность установить линии сетки, задать привязку к сетке, чтобы точно выровнять объекты вдоль них.
  • Настройки просмотра

    • пользователь может наиболее эффективно настроить рабочую область под свои потребности - определить линии сетки, линии разметки и отображать во врем работы только нужные инструменты.
Системные требования

Windows

  • Процессор Intel Pentium II или более быстрый (рекомендуется 300 Мгц или более быстрый)
  • Операционная система Microsoft Windows NT 4.0 Workstation с Service Pack 4, Windows 98
  • 48 MB оперативной памяти (64 MB рекомендуется)
  • 75 MB свободного дискового пространства для минимальной инсталляции
  • CD-ROM
  • Видеокарта, поддерживающая 256 цветов при разрешении монитора 800x600 (рекомендуется видеокарта с глубиной цвета 24 бита, дисплей высокого разрешения)

    • Для PostScript-принтеров: Adobe PostScript Level 2 или выше


PageMaker

Adobe PageMaker 6.5 Plus содержит:

  • 4,700 профессионально разработанных иллюстраций, сделанных при помощи Adobe Illustrator® в векторном формате. Все они могут быть легко интегрированы в документ, создаваемый в PageMaker.
  • 300 фотографий разрешения 300 dpi в формате CMYK.
  • сотни профессиональных шаблонов. Все шаблоны содержат информацию о цветах, полях отступа, шрифтах и других важных параметрах, необходимых для вывода на печать
Новшества для версии Windows:
  • Палитра Picture для просмотра и управления иллюстрациями, клипартами и фотографиями позволяет:
    • сортировать изображения по категориям,
    • отображать свернутые в пиктограммы изображения, облегчающие поиск нужной картинки
    • осуществлять поиск по ключевому слову.
    Через эту палитру пользователь может легко удалить или добавить графику, а также создать новую категорию изображений.
  • Появился специальный браузер для шаблонов, который значительно облегчает поиск и управление шаблонами PageMaker.
  • Панель инструментов Office-style с ярлыками для наиболее употребительных инструментов (таких как проверка орфографии, добавление списков, изменение опций фреймов, создание текстовых полей и задания способов обтекания текста).
  • Конвертор Publisher 97 и 98. Пользователи Microsoft Publisher теперь могут доводить свои публикации до профессионального качества - файлы этого формата могут быть конвертированы в формат PageMaker одним щелчком мыши.
Цифровая печать для Internet
    Теперь в комплект PageMaker 6.5 Plus включен Acrobat Distiller 4.0 . В связи с тем, что число сервисных служб, принимающих заказы на печать в формате PDF, неуклонно растет, большинство разработчиков предпочитают отправлять свои работы по электронной почте или на сменных носителях. Acrobat Distiller 4.0 обеспечивает ряд новых возможностей, которые позволяют оптимизировать процесс вывода на печать файлов формата PDF и значительно упрощают процесс приведения других форматов к формату PDF.
Специальная редакция Photoshop

В комплект PageMaker 6.5 Plus включен Adobe Photoshop 5.0 LE (Limited Edition), который позволяет упростить процесс внедрения фотоизображений в публикации посредством сканера или цифровой камеры. Его ключевыми возможностями являются:

  • возможность изменения цветовых параметров изображения, яркости и контраста и предварительный просмотр внесенных изменений.
  • Отдельные элементы в фотографиях могут быть автоматически выделены при помощи инструмента Magnetic Lasso.
  • Изображение может содержать до 99 слоев.
  • Доступны более чем 95 специальных эффектов, в том числе устранение шума, стилизация и деформация.
Системные требования:

Power Macintosh

  • Power Macintosh
  • Операционная система Apple System Software 7.5.3 или выше
  • 9 Mб оперативной памяти (рекомендуется 12 Мб)
  • 26 Mб свободного дискового пространства (рекомендуется 56 Mб)
  • CD-ROM
  • принтер, поддерживающий язык PostScript® (рекомендуется)
Windows 95/98/Windows NT 4.0
  • Процессор Intel ® Pentium ®
  • операционная система Microsoft ® Windows 95, 98, Windows NT 4.0 или более поздняя
  • 16Mб оперативной памяти (рекомендуется 32 Mб) - для Windows 95/98
  • 32 Mб оперативной памяти (рекомендуется 64) Мб - для Windows NT 4.0
  • CD-ROM

    • 86 Mб свободного дискового пространства (рекомендуется 127 Mб)


index

 Box
Adobe Streamline 4.0 - продукт для конвертации растровых рисунков в штриховое изображение, сохраняющий при этом естественность цветов и четкости линий. Adobe Streamline полностью совместим с Adobe PhotoShop, Adobe PageMaker, Adobe Illustrator, Adobe Dimensions и Adobe PageMill, а также является замечательным дополнением к таким графическим программам как Adobe Illustrator и Macromedia FreeHand; при этом практически не имеет значения, кто работает с продуктом -профессиональный дизайнер или обычный пользователь графических программ. Полная совместимость программы с Macintosh, Windows 95 и Windows NT 4.0 позволяет перемещать рабочие файлы с одной платформы на другую без каких-либо трудностей.

Преимущества

  • Высококачественный контроль над процессом преобразования изображения.

    • Streamline оснащен эффективной системой контроля за автоматическим процессом преобразования изображения, которая позволяет добиться исключительной точности в преобразовании всех линий рисунка. Благодаря этому пользователю не приходится тратить лишнее время, восстанавливая утраченные при конвертации линии рисунка.
  • Великолепные цветовые эффекты.

    • Новые инструменты контроля над приданием плакатного стиля в Streamline 4.0 дают пользователю возможность четко определить нужные цветовые оттенки, контролировать процесс окрашивания, или вообще не ограничивать колорирование. Пользователь может проявить изобретательность, используя Streamline для создания условных полутонов или двухцветных репродукций.
  • Избирательность.

    • Выбор и преобразование рисунка с помощью Streamline 4.0 стали еще лучше. Появилась возможность изменять условия преобразования для различных участков рисунка, а также переключаться с изначального растрового рисунка на векторное изображение для получения нужных результатов.
  • Легкость редактирования после преобразования изображения.

    • Любое изображение после преобразования нуждается в корректировке (полировке), поэтому в Streamline имеются широкие возможности и мощный набор инструментов для редактирования (подобные тем, что уже были представлены иллюстрационными программами Adobe). Новые инструменты дают пользователю возможность подгонять линии, изгибы; изменять, добавлять, удалять, смещать точки; преобразовывать линии в изгибы, черточки, штрихи и контуры.

    Основные возможности Adobe Streamline 4.0

  • Усиленный контроль за преобразованием
    • Корректировка сложных рисунков при помощи инструментов Pencil (карандаш), Line (линия), Eraser (ластик).
    • Выбор отдельных участков рисунка для преобразования или редактирования с помощью Magic Wand (волшебная палочка), Lasso (лассо), Adjust Levels (настройка уровней), и Marquee (шатер).
    • Применение новых цветов к выбранным участкам рисунка с помощью инструментов Eyedropper ("пипетка"), диалоговых окон Paint Style (стиль рисунка) и команды Fill (заполнение).
    • Экономия времени за счет уже установленных опций преобразования логотипов, цветных фотографий, набросков и многого другого.
    • Способность различать неограниченное число цветов и до 16 оттенков серого цвета для плакатных изображений (опции Color (цвет) и Grayscale (уровни серого)). Можно изменять цвет преобразованного изображения, используя инструменты и опции диалоговых окон Paint Style (Стиль рисунка)
    • Преобразование логотипов, иллюстраций, набросков и других графических изображений путем установки растра на контур изображения для автоматической конвертации в PostScript (он поддерживает масштабируемые шрифты и высококачественную графику) при помощи опции Outline (контур)
    • Для преобразования технических иллюстраций и схем следует найти центр линии и провести вектор под определенным наклоном с помощью опции Centerline (центр линии)
    • Преобразование слегка изогнутых линии в вертикальные и горизонтальные с помощью Line Recognition (распознаватель линий) в процессе работы с формами
    • Множественные преобразования рисунков, собранных в один редактируемый векторный файл. Существует возможность выбора для конвертации отдельных частей изображения; изменения в процесс преобразования вносятся путем установления различных специальных настроек.
    • Точное удаление минимальных элементов изображения. Для более жесткого контроля над конвертацией Centerline (середины линий) используется интерактивная опция Thinning (утончение), чтобы предотвратить потерю минимальных элементов изображения в слоях линий.
    • Усовершенствованные пути сопоставления изображения для получения более точной копии. Adobe Streamline проводит каждую линию и черту дважды, чтобы обеспечить максимальную точность и аккуратность. Встроенная опция Separate Shapes (отдельные шаблоны) производит два отдельных объекта, внешние контуры которых совпадают в модуле Centerline, а смежные контуры - в модуле Outline.
  • Безукоризненность цветов
    • Естественные цвета, гарантирующие точную передачу цвета оригинального изображения. Streamline 4.0 позволяет использовать и преобразовывать безграничное число цветов, указывая степень яркости отдельных цветов, которые будут воссозданы после преобразования.
    • Возможность определения пользователем конкретных цветовых участков из различных баз данных цветов, включая PANTONE. Streamline определяет, какие именно участки изображения будут представлены в лучшем цветовом варианте из числа цветов, выбранных пользователем.
    • Возможность генерации оттенков во время процесса конвертации для достижения эффекта двухцветовой репродукции.
  • Простота редактирования после конвертации
    • Выборочное удаление "якорных" (опорных) точек при сохранении чистоты и неприкосновенности изображения.
    • Выборочное преобразование ярко выраженных углов в линии Безье. Возможен выбор трех уровней допустимости: Минимальный, Средний и Максимальный - для максимального контроля.
    • Преобразование кривых траекторий в обычные геометрические фигуры - круг, овал, квадрат или прямоугольник с помощью команды "Преобразовать" (Convert To).
    • Новые инструменты для регулирования изгибов и линий, включая возможность передвигать и регулировать точки, регулирование линий (путей) для того, чтобы нарисовать более простой изгиб, преобразование прямой линии в изогнутую, преобразование траекторий в прямую линию и перемещение сегмента в любом направлении.
    • Новые инструменты, позволяющие добавлять и удалять участки изображения
    • Возможность легко изменить цвет заполнения или штрихов в процессе преобразования, а также в процессе редактирования после преобразования изображения.
  • Совместимость Streamline 4.0 с другими программными продуктами Adobe.
    • Интерфейс Streamline оснащен стандартным меню, его сокращенная раскладка клавиатуры полностью совпадает с Adobe Illustrator, PhotoShop и PageMaker.
    • Целостная автоматизация совместной работы с программными приложениями Adobe, такими как PhotoShop, PageMaker и After Effects, как и с программами других фирм, которые обладают функцией переноса.
  • Полная поддержка Windows 95, Windows NT 4.0 и Macintosh
    • Идентичность возможностей программы в среде Windows и Macintosh.
    • Импорт файлов из PhotoShop, TIFF, Macintosh PICT, Windows Paint (PNT) и Windows Paintbrush (PCX) .
    • Экспорт (вставка) преобразованных изображений в Adobe Illustrator, Encapsulated PostScript (EPS), DXP, и Macintosh PICT.
    Минимальные требования к системе:

    Windows:

    • Процессор 486 или более быстрый (рекомендуется Pentium)
    • Операционная система Windows 95, Windows NT 4.0 или более поздняя версия
    • 20 Mб свободной памяти на жестком диске
    • CD-ROM
    • Для обеспечения возможности печати файлов Adobe Streamline необходимо наличие приложения, позволяющего печатать файлы типа EPS
    • 20 Mб оперативной памяти
    Macintosh:
    • Процессор 65030 или мощнее, включая Power Macintosh
    • Операционная система APPLE версии 7.5 или более поздняя
    • 8 Mб свободной оперативной памяти (включая 4MB свободной памяти для Adobe Streamline)
    • 20 Mб свободной памяти на жестком диске
    • CD-ROM

      • Для обеспечения возможности печати файлов Adobe Streamline необходимо наличие приложения, позволяющего печать файлов типа EPS


index

Adobe Acrobat

Adobe Acrobat - достаточно простое и удобное средство для работы с самыми различными документами. Он позволяет преобразовывать любые документы в универсальный, в смысле доступа, формат файлов - PDF (Portable Document Format), который сохраняет первоначальное оформление независимо от того, на какой платформе и каким приложением открыт файл.

Ключевые особенности Быстрое создание PDF-файлов

  • Преобразует любой документ в PDF-формат, который очень точно отображает шрифты, цвета, картинки и форматирование исходного документа.
  • Для быстрого преобразования документа достаточно просто "перетащить" его в окно Adobe Acrobat
  • Опция "Create Adobe PDF" из меню File или на панели инструментов позволяет автоматически проинсталлировать приложения Adobe Acrobat в Microsoft Word, Excel и Power Point
  • Автоматическая оптимизация документа для последующего вывода на локальный или сетевой принтер для повседневного пользования, на профессиональный принтер для получения публикаций лучшего качества или для публикации в Web
  • Средства Paper Capture позволяют преобразовывать отсканированный документ непосредственно в формат PDF
  • Включение PDF-страниц, взятых из разных источников, в один документ
  • Возможность составления краткого описания страниц с последующим редактированием
  • Возможность создать точно такую же PDF-форму, как и на бумаге, но при этом снабдить ее кнопками, текстовыми полями и всплывающими окнами. Пользователи Acrobat Reader могут заполнять такие формы и отправлять их через Internet, а пользователи Adobe Acrobat 4.0 могут сохранять их у себя на диске для последующего заполнения и отправки в удобное время
  • Со средствами Web Capture можно создать PDF-версию Web-страницы или сайта для последующего просмотра или распечатки ее в режиме off-line.
Специальные средства навигации и защиты
  • Автоматическое применение средств защиты к PDF-документам, дополнение PDF-документов информационными полями, создание краткого содержания для удобной PDF-сортировки и оптимизация директорий и поддиректорий PDF-файлов для последующего использования в Web.
  • Ввод пароля в PDF-файл для ограничения доступа к информации или запрещения внесения изменений и распечатки.
  • Специальный инструмент Acrobat SelfSign дает возможность ставить электронную подпись на документе
  • Инструмент Acrobat Catalog позволяет создавать полнотекстовые индексы, которые обеспечивают возможность поиска по документу при помощи Acrobat Search.
  • Средство Acrobat Search позволяет быстро найти необходимую информацию
  • При помощи закладок, ссылок на другие PDF-файлы или в Web, а также средств динамического контроля для включения звука, анимации и спецэффектов можно сделать PDF-файлы намного удобнее для просмотра
Средства просмотра документа
  • Быстрая разметка PDF-файла с использованием средств выделения, подчеркивания и перечеркивания текста
  • Добавление текстовой аннотации прямо в PDF-файлы или использование "приклеенных заметок" ("sticky notes") (инструмент Notes).
  • Возможность сделать заметки как бы написанными от руки при помощи инструмента Pencil
  • Объединение аннотаций в отдельный PDF-файл, чтобы облегчить ссылки или упорядочивание аннотаций по автору, дате или номерам страниц
  • Возможность распечатать PDF-файл полностью, вместе с аннотациями и "приклеенными заметками".
  • Возможность пометить PDF-документ ручными штампами типа "Approved" или "Confidential".
  • Возможность при помощи инструмента Compare открыть 2 или более PDF-файла в различных окнах для автоматического сравнения различных версий одного и того же документа
  • Открытие рисунка внутри PDF-файла для редактирования в Adobe PhotoShop одним щелчком "мыши". Импорт графики или исходной PDF-страницы в Adobe Illustrator, внесение незначительных текстовых поправок при помощи средства TouchUpText.
  • Копирование и вставка текста и таблиц из одного PDF-файла в другой. В PDF-файле сохраняется структура таблиц Microsoft Word и Excel
Быстрая печать и просмотр в режиме он-лайн
  • Возожность присоединять PDF-файлы к сообщениям электронной почты, размещать их на сетевом сервере, на Intranet-сервере или на Web-сайте, в базе данных Lotus Notes, распечатывать или помещать на CD
  • Возможность, просматривать и распечатывать PDF-файлы с любого компьютера, используя бесплатный Acrobat Reader . Небольшой размер PDF-фалов, в некоторых случаях даже меньше чем у оригинала, позволяет загружать страницы по сети достаточно быстро, что особенно важно при использовании их в Web
  • Инструмент Send Mail позволяет автоматически вставлять PDF-файл в электронное сообщение
  • Возможности нового Batch Processor позволяют подготовить большое количество PDF-файлов и оптимизировать пакеты файлов для использования в Web
  • Возможность просмотра документы на любом из 14 языков: английском, французском, немецком, японском, китайском, корейском, шведском, испанском, датском, итальянском, арабском, южно-американском испанском, бразильским португальским и еврейском, используя версии Adobe Acrobat 4.0 или Acrobat Reader на различных языках.
  • Поддержка китайского, японского и корейского шрифтов
  • PDF-файлы содержат все шрифты, форматирование и данные об изображении, необходимые для распечатывания, при этом конечному пользователю совершенно не обязательно иметь все те приложения и шрифты, при помощи которых создан PDF-файл.
Системные требования

Windows

  • 486 или Pentium
  • Microsoft Windows 95,Windows 98, Windows NT с Service Pack 3 или более поздним
  • 16 Мб оперативной памяти для Adobe Acrobat 4.0 для Windows 95/98; 24 Мб оперативной памяти для Adobe Acrobat 4.0 для Windows NT 4.0
  • 32 Мб для Paper Capture plug-in (64 Мб рекомендуется)
  • 75 Мб свободного дискового пространства ( и еще дополнительные 50 Мб для азиатских шрифтов)
  • CD-ROM
Power Macintosh
  • Power Macintosh
  • Apple System SoftWare версии 7.5.3 или более поздняя
  • 6 Мб оперативной памяти для Adobe Acrobat 4.0 ( 12 Мб рекомендуется)
  • 16 Мб для Distiller или Paper Capture plug-in (32 Мб рекомендуется)
  • 60 Мб свободного дискового пространства (дополнительные 50 Мб для азиатских шрифтов)

    • CD-ROM


Горячие клавиши - Illustrator

Горячие клавиши в Illustrator
  • Команды меню
  • Выделение
  • Контуры
  • Текст
  • Форма
  • Преобразование
  • Переход, автотрассировка, диаграммы
  • Измерение и рисование
  • Просмотр
  • Управление цветом
  • Палитры
  • Разное

Оглавление


Горячие клавиши - Illustrator - Выделение

Выделение
Скрыть/Показать палитру инструментов и все палитры | TAB
Скрыть/Показать все палитры, не показывая палитры инструментов | SHIFT+TAB
Отобразить инструменты по умолчанию | Двойной щелчок на инструменте, удерживая нажатыми клавиши CTRL+SHIFT
Selection (Выделение) | V, CTRL+TAB при переключении синструмента Direct Selection (Частичное вы деление)
Direct Selection (Частичное выделение) | A, CTRL+TAB при переключении с инструмента Selection (Выделение)
Group Selection (Выделение в группе) | A, A (если по умолчанию используется инструмент Direct Selection (Частичное выделение)), ALT при переключении с инструмента Direct Selection (Частичное выделение)
Выделение точки | Щелчок инструментом Direct Selection (Частичное выделение)
Выделение сегмента | Щелчок инструментом Direct Selection (Частичное выделение)
Выделение контура | Щелчок инструментом Group Selection (Выделение в группе)
Выделение следующей группы | Повторный щелчок инструментом Group Selection (Выделение в группе)
Выделение группы верхнего уровня | Щелчок инструментом Selection (Выделение)
Дополнительное выделение | Щелчок с нажатой клавишей SHIFT
Выделение указанных точек | Перетаскивание инструментом Direct Selection (Частичное выделение)
Выделение указанных контуров | Перетаскивание с инструментом Selection (Выделение)
Отмена выделения | Щелчок на выделенной области с нажатой клавишей SHIFT
Передвинуть выделенное | Перетаскивание
Скопировать выделенное | Перетаскивание с нажатой клавишей ALT
Ограничение перемещения углами, кратными 45 | Перетаскивание с нажатой клавишей SHIFT
Перемещение с копированием | Перетаскивание с нажатыми клавишами ALT+SHIFT
Пропорциональное изменение размера объекта | Перетаскивание ограничительной рамки с нажатой клавишей SHIFT
Изменение размера объекта от центра | Перетаскивание ограничительной рамки с нажатыми клавишами ALT+SHIFT
Выделить все | CTRL+A
Отменить выделение | CTRL+SHIFT+A


Горячие клавиши - Illustrator - Измерение и рисование

Измерение и рисование
Gradient (Градиент) | G
Gradient Mesh (Ячейка градиента) | U
Paintbucket (Заливка) | К, ALT с активным инструментом Eyedropper (Пипетка)
Eyedropper (Пипетка) | I, ALT с активным инструментом Paintbucket (Заливка)
Измерения расстояния между точками | Щелчок на начальной и конечной точках инструментом Measure (Линейка)
Ограничение движения курсора углами, кратными 45, при измерении расстояния | Щелчок на начальной и конечной точках инструментом Measure (Линейка) с нажатой клавишей SHIFT
Изменение направления и размера линейного градиента | Перетаскивание инструментом Gradient (Градиент)
Ограничение движения курсора углами, кратными 45 | Перетаскивание инструментом Gradient (Градиент) с нажатой клавишей SHIFT
Изменение направления и размера радиального градиента | Перетаскивание инструментом Gradient (Градиент)
Изменение начальной точки радиального градиента | Щелчок инструментом Gradient (Градиент)
Копирование атрибутов стиля | Щелчок на объекте с нужным стилем инструментом Eyedropper (Пипетка)
Копирование экранного цвета | Щелчок на объекте с нужным стилем инструментом Eyedropper (Пипетка) с нажатой клавишей SHIFT
Копирование атрибутов окраски в выделенный объект | Двойной щелчок на объекте с нужным стилем элементом Eyedropper (Пипетка)
Окрашивание невыделенных объектов | Щелчок на объекте элементом Paintbucket (Заливка)


Горячие клавиши - Illustrator - Команды меню

Команды меню
New (Новый) | CTRL+N
Open (Открыть) | CTRL+O
Close (Закрыть) | CTRL+W
Save (Сохранить) | CTRL+S
Save As (Сохранить как | CTRL+SHIFT+S
Save a Copy (Сохранить копию) | CTRL+ALT+S
Document Setup (Параметры документа) | CTRL+ALT+P
Print Setup (Настройка принтера) | CTRL+SHIFT+P
Print (Печать) | CTRL+P
General Preferences (Основные установки) | CTRL+K
Quit (Выход) | CTRL+Q
Undo (Отменить) | CTRL+Z
Redo (Повторить) | CTRL+SHIFT+Z
Cut (Вырезать) | CTRL+X, F2
Copy (Скопировать) | CTRL+C, F3
Paste (Вклеить) | CTRL+V, F4
Paste in Front (Вклеить вперед) | CTRL+F
Paste in Back (Вклеить назад) | CTRL+B
Clear (Очистить) | DELETE
Select All (Выделить все) | CTRL+A
Deselect All (Отменить выделение) | CTRL+SHIFT+A
Select Again (Выбрать снова) | CTRL+6
Transform Again (Преобразовать повторно) | CTRL+D
Move (Перемещение) | Двойной щелчок на инструменте Selection (Выделение)
Bring to Front (На передний план) | CTRL+SHIFT+]
Bring Forward (Сдвинуть вперед) | CTRL+]
Send Backward (Сдвинуть назад) | CTRL+[
Send to Back (На задний план) | CTRL+SHIFT+[
Group (Сгруппировать) | CTRL+G
Ungroup (Разгруппировать) | CTRL+SHIFT+G
Lock (Закрепить) | CTRL+2
Lock Unselected (Закрепить невыделенные) | CTRL+ALT+2
Unlock All (Освободить все) | CTRL+SHIFT+2
Hide Selection (Скрыть выделенные) | CTRL+3
Hide Unselected (Скрыть невыделенные) | CTRL+ALT+3
Join (Соединить) | CTRL+J
Show All (Показать все) | CTRL+SHIFT+3
Average (Усреднить) | CTRL+ALT+J
Join and Average (Соединить и усреднить) | CTRL+ALT+SHIFT+J
Make Blend (Создать переход) | CTRL+ ALT+B
Release Blend (Освободить переход) | CTRL+ALT+SHIFT+B
Make Mask (Образовать маску) | CTRL+7
Release Mask (Отменить маску) | CTRL+ALT+7
Make Compound Path (Образовать составной контур) | CTRL+8
Release Compound Path (Отменить составной контур) | CTRL+ALT+8
Font (Шрифт) | CTRL+ALT+SHIFT+M
Показать/скрыть палитру Character (Символ} | CTRL+T
Показать/скрыть палитру Paragraph (Абзац) | CTRL+M
Показать/скрыть палитру Tab Ruler (Линейка табуляции) | CTRL+SHIFT+T
Create Outlines (Преобразовать в контуры) | CTRL+SHIFT+0
Apply Last Filter (Применить последний фильтр) | CTRL+E
Last Filter (Последний фильтр) | CTRL+ALT+E
Переключение режимов Artwork/Preview (Макет/Иллюстрация) | CTRL+Y
Preview Selection (Выделенная область) | CTRL+ALT+Y
Zoom In (Увеличить) | CTRL++
Zoom Out (Уменьшить) | CTRL+-
Fit in Window (Целый документ) | Двойной щелчок на инструменте Hand (Рука)
Actual Size (Реальный размер) | CTRL+1, Двойной щелчок на инструменте Zoom (Масштаб)
Hide Edges (Скрыть границы) | CTRL+H
Hide Template (Скрыть шаблон) | CTRL+SHIFT+W
Show/Hide Rulers (Показать/Скрыть линейки) | CTRL+R
Show/Hide Guides (Показать/Скрыть направ-ляющие) | CTRL+;
Lock Guides (Закрепить направляющие) | CTRL+ALT+;
Make Guides (Образовать направляющие) | CTRL+5
Release Guides (Отменить направляющие) | CTRL+ALT+5
Show/Hide Grid (Показать/Скрыть сетку) | CTRL+'
Snap to Grid (Выровнять по сетке) | CTRL+SHIFT+'
Snap to Point (Выровнять по точкам) | CTRL+ALT+'
Smart Guides (Умные направляющие) | CTRL+U
New View 1 (Новый вид 1) | CTRL+ALT+SHIFT+1
New View 2 (Новый вид 2) | CTRL+ALT+SHIFT+2
New View 3 (Новый вид 3) | CTRL+ALT+SHIFT+3
New View 4 (Новый вид 4) | CTRL+ALT+SHIFT+4
New View 5 (Новый вид 5) | CTRL+ALT+SHIFT+5
New View 6 (Новый вид 6) | CTRL+ALT+SHIFT+6
New View 7 (Новый вид 7) | CTRL+ALT+SHIFT+7
New View 8 (Новый вид 8) | CTRL+ALT+SHIFT+8
New View 9 (Новый вид 9) | CTRL+ALT+SHIFT+9
New View 10 (Новый вид 10) | CTRL+ALT+SHIFT+0
Показать/Скрыть все палитры и инструменты | TAB
Показать/Скрыть палитру Info (Инфо) | F8
Показать/Скрыть палитру Transform (Преобразовать) | Отсутствует
Показать/Скрыть палитру Pathfinder (Исследователь) | Отсутствует
Показать/Скрыть палитру Align (Выравнивание) | Отсутствует
Показать/Скрыть палитру Color (Цвет) | F6, CTRL+I
Показать/Скрыть палитру Gradient (Градиент) | F9
Показать/Скрыть палитру Stroke (Обводка) | F10
Показать/Скрыть палитру Swatches (Образцы) | F5
Показать/Скрыть палитру Brushes (Кисти) | Отсутствует
Показать/Скрыть палитру Links (Связи) | Отсутствует
Показать/Скрыть палитру Layers (Слои) | F7
Показать/Скрыть палитру Navigator (Навигатор) | Отсутствует
Показать/Скрыть палитру Attributes (Атрибуты) | F11, CTRL+SHIFT+I
Показать/Скрыть палитру Actions (Действия) | Отсутствует


Горячие клавиши - Illustrator - Контуры

Контуры
Pen (Перо) | P, (переключается с инструментами Add Anchor Point Добавить опорную точку). Delete Anchor Point (Удалить опорную точку) и Convert Direction Point (Преобразовать опорную точку)
Add Anchor Point (Добавить опорную точку) | Anchor Point (Удалить опорную точку) и Convert Direction Point (Преобразовать опорную точку). Инструмент Delete Anchor Point (Удалить опорную точку) с нажатой клавишей ALT. Инструмент Scissors (Ножницы) с нажатой клавишей ALT
Delete Anchor Point (Удалить опорную точку) | -, (если по умолчанию используется инструмент Pen (Перо); переключается с инструментами Реп (Перо), Add Anchor Point (Добавить опорную точку) и Convert Direction Point (Преобразовать опорную точку)). Инструмент Add Anchor Point (Добавить опорную точку) с клавишей ALT
Convert Direction Point (Преобразовать опорную точку) | P, P (если по умолчанию используется инструмент Pen (Перо; переключается с инструментами Pen (Перо), Add Anchor Point (Добавить опорную точку) и Delete Anchor Point (Удалить опорную точку). Инструмент Реп (Перо) с клавишей ALT. Инструмент Direct Selection (Частичное выделение) с комбинацией клавиш CTRL+ALT. Комбинация клавиш CTRL+ALT, если последний активный инструмент Direct Selection (Частичное выделение)
Добавить опорную точку на выбранный контур | Перетащить инструмент Add Anchor Point (Добавить опорную точку) через сегмент выбранного контура
Удалить опорную точку на выбранном контуре | Перетащить инструмент Delete Anchor Point (Удалить опорную точку) через удаляемую точку на контуре
Pencil (Карандаш) | N
Smooth (Сглаживание) | Дважды нажать клавишу N (если по умолчанию используется инструмент Pencil (Карандаш))
Erase (Стирание) | Трижды нажать клавишу N (если по умолчанию используется инструмент Pencil (Карандаш))
Paintbrush (Кисть) | B
Scissors (Ножницы) | С (переключается с инструментом Knife (Нож))
Knife (Нож) | Дважды нажать клавишу С (если по умолчанию используется инструмент Scissors (Ножницы))
Создание прямолинейной угловой точки | Щелчок с активным инструментом Реп (Перо)
Создание гладкой точки | Перетаскивание с активным инструментом Реп (Перо)
Продолжение открытого контура | Щелчок и перетаскивание в следующую точку контура с активным инструментом Реп (Перо)
Закрытие открытого контура | Щелчок и перетаскивание в конечную точку контура инструментом Реп (Перо). Щелчок на начальной и конечной точках контура инструментом Реп (Перо). Выделение контура с последующей операцией Join (Соединение) CTRL+J
Ограничение углов значениями, кратными 45 | Щелчок и перетаскивание инструментом Реп (Перо) с нажатой клавишей SHIFT
Ограничение перемещения управляющей линии углами кратными 45 | Щелчок и перетаскивание инструментом Pen (Перо)
Создание контура | Щелчок и перетаскивание точек инструментом Реп (Перо)
Добавление опорных точек | Щелчок на контуре инструментом Pen (Перо)
Удаление опорных точек | Щелчок на точке контура инструментом Pen (Перо)
Преобразование опорной точки в гладкую | Перетащить через точку инструмент Convert Direction Point (Преобразовать опорную точку)
Преобразование гладкой точки в угловую | Щелчок на точке инструментом Convert Direction Point (Преобразовать опорную точку)
Преобразование гладкой точки в комбинированную | Перетаскивание управляющей точки в опорную точку инструментом Direct Selection (Частичное выделение)
Преобразование гладкой точки в криволинейную угловую | Перетаскивание управляющей точки инструментом Convert Direction Point (Преобразовать опорную точку)
Рисование произвольного контура | Перетаскивание инструментом Pencil (Карандаш)
Стирание рисуемого контура | Перетаскивание через контур инструментом Pencil (Карандаш) с нажатой клавишей CTRL
Активизация диалогового окна Paint brush options (Параметры кисти) | Двойной щелчок на инструменте Paintbrush (Кисть) (в палитре инструментов)
Разбиение контура | Щелчок инструментом Scissors (Ножницы)
Разрезание контурана несколько частей | Перетаскивание инструментом Knife (Нож)
Ограничение разрезания контура углами, кратными 45 | Перетаскивание инструментом Knife (Нож) с нажатой клавишей SHIFT
Дублирование сегмента контура | Перетаскивание инструментом Knife (Нож) с нажатой клавишей ALT
Разрезание с помощью выделенного контура | Команда Object/Path/Slice (Объект/Контур/ Отрезать)


Горячие клавиши - Illustrator - Палитры

Палитры
Показать/Скрыть содержимое палитры | Щелчок на кнопке в правом верхнем углу
Переключение способов отображения содержимого палитры | Двойной щелчок на заголовке палитры
Установка параметров | ENTER
Установка параметров с сохранением выделения последнего поля | SHIFT+ENTER
Выделение следующего поля | TAB
Выделение предыдущего поля | SHIFT+TAB
Выделение произвольного поля ввода | Щелчок на названии поля или двойной щелчок на поле
Увеличение значения на единицу | Выделение поля, а затем нажатие клавиши стрелка вверх
Уменьшение значения на единицу | Выделение поля, а затем нажатие клавиши стрелка вниз
Увеличение значения на большой шаг | Выделение поля, а затем нажатие комбинации клавиш SHIFT+стрелка вверх
Уменьшение значения на большой шаг | Выделение поля, а затем нажатие комбинации клавиш SHIFT+стрелка вниз
Комбинирование палитр | Перетаскивание заголовка палитры в другую палитру
Прикрепление одной палитры к другой | Перетаскивание заголовка палитры к нижней части другой палитры
Разделение палитр | Перетаскивание заголовка палитры за преде лы объединенной палитры
Показать/Скрыть палитру Transform (Преобразовать) | Отсутствует
Копирование объекта при преобразовании | ALT+ENTER
Сохранение пропорций объекта при изменении масштаба | CTRL+ENTER
Копирование объекта с сохранением пропорций при изменении масштаба | CTRL+ALT+ENTER
Показать/Скрыть палитру Layers (Слои) | F7
Новый слой | Щелчок на пиктограмме New Layer (Новый слой)
Новый слой с активизацией диалогового окна Layer Options (Опции слоя) | Щелчок на пиктограмме New Layer (Новый слой) с нажатой клавишей ALT
Новый слой поверх активного слоя | Щелчок на пиктограмме New Layer (Новый слой)с нажатыми клавишами CTRL+ALT
Новый слой под активным слоем | Щелчок на пиктограмме New Layer (Новый слой) с нажатой клавишей CTRL
Копирование слоев | Перетаскивание слоев на пиктограмму New Layer (Новый слой)
Изменение порядка слоев | Перетаскивание слоев выше или ниже в списке слоев
Выделение всех объектов слоя | Щелчок на слое с нажатой клавишей ALT
Выделение всех объектов нескольких слоев | Щелчок на слое с нажатыми клавишами SHIFT+ALT
Выделение последовательности слоев | Щелчок на слое с нажатой клавишей SHIFT
Выделение произвольных слоев | Щелчок на слое с нажатой клавишей CTRL
Перемещение объектов в другой слой | Перетаскивание пиктограммы цветного квадрата на другой слой
Копирование объектов в другой слой | Перетаскивание пиктограммы цветного квадрата на другой слой с нажатой клавишей ALT
Показать/Скрыть слой | Щелчок на пиктограмме Eyeball (Отображение слоя) (изображение глаза слева от названия слоя)
Просмотр одного слоя | Щелчок на пиктограмме Eyeball (Отображение слоя) с нажатой клавишей ALT
Просмотр макета слоя | Щелчок на пиктограмме Eyeball (Отображение слоя) с нажатой клавишей CTRL
Просмотр иллюстраций слоя с одновременным просмотром макетов прочих слоев | Щелчок на пиктограмме Eyeball (Отображение слоя) с нажатыми клавишами CTRL+ALT
Закрепить/Освободить слой | Щелчок на пиктограмме пера справа от названия слоя
Освобождение слоя с одновременным закреплением остальных слоев | Щелчок на пиктограмме пера с нажатой клавишей ALT
Удаление слоя | Перетаскивание слоя на пиктограмму Trash (Удалить слои). Выделение слоя и щелчок на пиктограмме Trash (Удалить слои)
Удаление слоя без отображения предупреждающего сообщения | Перетаскивание слоя на пиктограмму Trash (Удалить слои) с нажатой клавишей ALT. Выделение слоя и щелчок на пиктограмме Trash (Удалить слои) с нажатой клавишей ALT


Горячие клавиши - Illustrator - Переход, автотрассировка, диаграммы

Переход, автотрассировка, диаграммы
Blend (Переход) | W (переключение с инструментом Auto Trace (Автотрассировка))
Auto Trace (Автотрассировка) | Дважды нажать клавишу W (если по умолчанию используется инструмент Blend (Переход))
Column Graph (Столбчатая диаграмма) | J (переключение с другими инструментами диаграмм)
Stacked Column Graph (Вертикальный стек) | Дважды нажать клавишу J (если по умолчанию используется инструмент Column Graph (Столбчатая диаграмма))
Bar Graph (Горизонтальные полосы) | Трижды нажать клавишу J (если по умолчанию используется инструмент Column Graph (Столбчатая диаграмма))
Stacked Bar Graph (Горизонтальный стек) | Четыре раза нажать клавишу J (если по умолчанию используется инструмент Column Graph (Столбчатая диаграмма))
Line Graph (Линейный график) | Пять раз нажать клавишу J (если по умолчанию используется инструмент Column Graph (Столбчатая диаграмма))
Area Graph (Аддитивный график) | Шесть раз нажать клавишу J (если по умолчанию используется инструмент Column Grap (Столбчатая диаграмма))
Scatter Graph (Точечная диаграмма) | Семь раз нажать клавишу J (если по умолчанию используется инструмент Column Graph (Столбчатая диаграмма))
Pie Graph (Круговая диаграмма) | Восемь раз нажать клавишу (если по умолчанию используется инструмент Column Graph (Столбчатая диаграмма))
Radar Graph (Радар) | Девять раз нажать клавишу J (если по умолчанию используется инструмент Column Graph (Столбчатая диаграмма))
Создание перехода между двумя контурами | Щелчок на соответствующих выделенных точках каждого из контуров инструментом Blend (Переход)
Автотрассировка изображения | Щелчок на трассируемом объекте инструментом Auto Trace (Автотрассировка)
Создание диаграммы с размерами, определяемыми числами | Щелчок любым инструментом-диаграммой
Создание диаграммы с размерами, определяемыми перетаскиванием | Перетаскивание инструментом-диаграммой


Горячие клавиши - Illustrator - Преобразование

Преобразование
Rotate (Поворот) | R (переключение с инструментом Twirl (Скрутка))
Twirl (Скрутка) | Дважды нажать клавишу R (если по умолчанию используется инструмент Rotate (Поворот))
Scale (Размер) | S (переключение с инструментом Reshape (Изменение формы))
Reshape (Изменение формы) | Дважды нажать клавишу S (если по умолчанию используется инструмент Scale (Размер))
Reflect (Зеркало) | O
Skew (Наклон) | Дважды нажать клавишу O
Free Transform (Свободное преобразование) | E
Поворот с указанными параметрами | Щелчок инструментом Rotate (Поворот) с нажатой клавишей ALT
Поворот с указанными параметрами относительно выбранного центра | Двойной щелчок инструментом Rotate (Поворот)
Свободный поворот вокруг выбранного центра | Щелчок для указания центра поворота и переаскивание инструментом Rotate (Поворот)
Свободный поворот вокруг центра объекта | Перетаскивание инструментом Rotate (Поворот)
Ограничение поворота углами, кратными 45 | Перетаскивание инструмента Rotate (Поворот) с нажатой клавишей SHIFT
Поворот с появлением копии | Перетаскивание инструмента Rotate (Поворот) с нажатой клавишей ALT
Поворот только шаблона | Перетаскивание инструмента Rotate (Поворот) с нажатой клавишей -
Скручивание с указанными параметрами | Щелчок на объекте инструментом Twirl (Скрутка) с нажатой клавишей ALT
Свободное скручивание | Перетаскивание инструмента Twirl (Скрутка)
Растягивание с указанными параметрами | Щелчок инструментом Scale (Размер) с нажатой клавишей ALT
Растягивание с указанными параметрами относительно выбранного центра | Двойной щелчок инструментом Scale (Размер)
Свободное растягивание вокруг выбранного центра | Щелчок для указания центра поворота и перетаскивание инструмента Scale (Размер)
Свободное растягивание вокруг центра объекта | Перетаскивание инструмента Scale (Размер)
Растягивание вдоль одной из осей координат | Перетаскивание инструмента Scale (Размер) с нажатой клавишей SHIFT
Растягивание с копированием | Перетаскивание инструмента Scale (Размер) с нажатой клавишей ALT
Растягивание только шаблона | Перетаскивание инструментом Scale (Размер) с нажатой клавишей -
Изменение формы контура | Перетаскивание инструментом Reshape (Изменение формы) точек, выделенных инструментом Direct Selection (Частичное выделение)
Зеркальное отображение с указанными параметрами | Щелчок инструментом Reflect (Зеркало) с нажатой клавишей ALT
Зеркальное отображение с указанными параметрами относительно выбранного центра | Двойной щелчок на инструменте Reflect (Зеркало)
Свободное зеркальное отображение вокруг выбранного центра | Щелчок для указания центра поворота и перетаскивание инструмента Reflect (Зеркало)
Свободное зеркальное отображение вокруг центра объекта | Перетаскивание инструмента Reflect (Зеркало)
Ограничение поворота оси углами, кратными 45 | Перетаскивание инструмента Reflect (Зеркало) с нажатой клавишей SHIFT
Зеркальное отображение с появлением копии | Перетаскивание инструмента Reflect (Зеркало)с нажатой клавишей ALT
Зеркальное отображение шаблона | Перетаскивание инструмента Reflect (Зеркало) с нажатой клавишей -
Наклон с указанными параметрами | Щелчок инструментом Skew (Наклон) с нажатой клавишей ALT
Наклон с указанными параметрами относительно выбранного центра | Двойной щелчок инструментом Skew (Наклон)
Свободный наклон вокруг выбранного центра | Щелчок для указания центра поворота и перетаскивание инструмента Skew (Наклон)
Свободный наклон вокруг центра объекта | Перетаскивание инструмента Skew (Наклон)
Ограничение поворота оси углами, кратными 45 | Перетаскивание инструмента Skew (Наклон) с нажатой клавишей SHIFT
Наклон с копированием | Перетаскивание инструмента Skew (Наклон) с нажатой клавишей ALT
Наклон шаблона | Перетаскивание инструмента Skew (Наклон) с нажатой клавишей -


Горячие клавиши - Illustrator - Просмотр

Просмотр
Hand (Рука) | Н (переключается с инструментом Page (Страница)}, Пробел (если при этом не вводится текст)
Page (Страница) | Дважды нажать клавишу Н (если по умолчанию используется инструмент Hand (Рука))
Zoom (Масштаб) | Z, CTRL+пробел
Zoom Out (Уменьшение масштаба) | Щелчок инструментом Zoom (Масштаб) с нажатой клавишей ALT
Увеличение масштаба | Щелчок на объекте инструментом Zoom (Масштаб). CTRL++
Уменьшение масштаба | Щелчок на объекте инструментом Zoom (Масштаб) с клавишей ALT, CTRL+-
Увеличение масштаба указанной области | Перетаскивание инструмента Zoom (Масштаб)
Перемещение границ масштабируемой области | Перетаскивание инструментом Zoom (Масштаб) с нажатой клавишей пробел
Рисование границ масштабируемой области от выбранного центра | Перетаскивание инструментом Zoom (Масштаб) с нажатой клавишей CTRL
Увеличение масштаба | CTRL++, щелчок инструментом Zoom (Масштаб)
Уменьшение масштаба | Уменьшение масштаба CTRL+-, щелчок инструментом Zoom (Масштаб) с нажатой клавишей ALT
Масштабирование изображения по размеру окна | CTRL+0, двойной щелчок на инструменте Hand (Рука)
Восстановление масштаба 100% | CTRL+1, двойной щелчок на инструменте Zoom (Масштаб)
Переключение режимов Artwork/Preview (Макет/Иллюстрация) | CTRL+Y
Просмотр пользовательских видов | От CTRL+SHIFT+ALT+1 до CTRL+ALT+SHIFT+0
Показать/Скрыть границы | CTRL+H
Показать/Скрыть направляющие | CTRL+;
Показать/Скрыть сетку | CTRL+'
Показать/Скрыть линейки | CTRL+R
Спрятать выделенные объекты | CTRL+3
Спрятать невыделенные объекты | CTRL+ALT+3
Показать все спрятанные объекты | F (из полного экрана)
Полный экран с меню | F (из обычного режима экрана)
Полный экран без меню | F (из режима полного экрана без меню)


Горячие клавиши - Illustrator - Разное

Разное
Пошаговое перемещение объекта (шаг усанавливается в диалоговом окне Preferences (Установки)) | Стрелки управления курсором
Выбор вида информации о состоянии | Щелчок на строке состояния с нажатой клавишей ALT
Просмотр заставки Illustrator | Щелчок на пиктограмме заставки в палитре инструментов
Ускорить просмотр информации в заставке | ALT
Вызов контекстно-зависимого меню | Щелчок правой кнопкой мыши
Выделение последнего активного поля | CTRL+-
Отменить | ESC
OK (Да) | ENTER
Выделение следующего поля | TAB
Выделение предыдущего поля | SHIFT+TAB
Выделение произвольного поля | Щелчок на заголовке поля или двоиной щелчок на текущем значении


Горячие клавиши - Illustrator - Текст

Текст
Type (Текст) | T, (переключается с остальными инструментами текста). Инструмент Vertical Type (Вертикальный текст) с клавишей SHIFT
Area Type (Текст в области) | Дважды нажать клавишу Т (если по умолчанию используется инструмент Type (Текст)). Инструмент Path Type (Текст вдоль контура) с клавишей ALT. Инструмент Vertical Area Type (Вертикальный текст в области) с клавишей SHIFT. Инструмент Vertical Path Type (Вертикальный текст вдольконтура) с клавишами ALT+SHIFT
Path Type (Текст вдоль контура) | Трижды нажать клавишу Т (если по умолчанию используется инструмент Path (Текст)). Инструмент Area Type (Текст в области) с клавишей ALT. Инструмент Vertical Path Type (Вертикальный текст вдоль контура) с клавишей SHIFT. Инструмент Vertical Area Туре (Вертикальный текст в области) с клавишей ALT+SHIFT
Vertical Type (Вертикальный текст) | Четыре раза нажать клавишу Т (если по умолчанию используется инструмент Type (Текст)). Инструмент Type (Текст) с клавишей SHIFT
Vertical Area Туре (Вертикальный текст в области) | Пять раз нажать клавишу Т (если по умолчанию используется инструмент Type (Текст)). Инструмент Vertical Path Туре (Вертикальный текст вдоль контура) с клавишей ALT. Инструмент Area Type (Текст в области) с клавишей SHIFT. Инструмент Туре (Текст) с клавишами ALT+SHIFT
Vertical Path Type (Вертикальный текст вдоль контура) | Шесть раз нажать клавишу Т (если по умолчанию используется инструмент Type (Текст)). Инструмент Vertical Area Type (Вертикальный текст в области) с клавишей ALT. Инструмент Path Type (Текст вдоль контура) с клавишей SHIFT. Инструмент Area Туре (Текст в области) с клавишами ALT+SHIFT
Создание текста | Щелчок инструментом Type (Текст)
Создание блока текста | Перетаскивание инструмента Туре (Текст)
Размещение текста на замкнутом контуре | Щелчок на контуре инструментом Path Type (Текст вдоль контура). Щелчок на контуре инструментом Type (Текст) с нажатой клавишей ALT. Щелчок на контуре инструментом Area Type (Текст в области) с нажатой клавишей ALT
Размещение текста на открытом контуре | Щелчок на контуре инструментом Path Type (Текст вдоль контура). Щелчок на контуре инструментом Type (Текст). Щелчок на контуре инструментом Area Type (Текст в области) с клавишей ALT
Размещение текста в области на замкнутом контуре | Щелчок на контуре инструментом Area Type (Текст в области). Щелчок на контуре инструментом Type (Текст). Щелчок на контуре инструментом Path Туре (Текст вдоль контура) с клавишей ALT
Размещение текста в области на открытом контуре | Щелчок на контуре инструментом Area Type (Текст в области). Щелчок на контуре инструментом Type (Текст) с клавишей ALT. Щелчок на контуре инструментом Path Type (Текст вдоль контура) с клавишей ALT
Изменения типа текста с вертикального на горизонтальный | Команда Type/Orientation/Horizontal (Текст/0риентация/Горизонтальная)
Изменение типа текста с горизонтального на вертикальный | Команда Type/Orientation/ Vertical (Текст/Ориентация/Вертикальная)
Выделение целого текстового блока | Щелчок на текстовом блоке инструментом Selection (Выделение)
Выделение одного символа | Перетаскивание по символу любым активным инструментом Type (Текст)
Выделение слова | Двойной щелчок на слове любым активным инструментом Type (Текст)
Выделение абзаца | Тройной щелчок на абзаце любым активным инструментом Type (Текст)
Выделение всего текста в блоке | Щелчок на текстовом блоке любым активным инструментом Туре (Текст) с последующим нажатием комбинации клавиш CTRL+A
Перевернуть текст на контуре | Дважды щелкнуть на I-образном маркере текста любым инструментом выделения или просто перетащить текст на противоположную сторону контура инструментом выделения
Копирование текста на контур | Перетаскивание текстового курсора любым инструментом выделения с нажатой клавишей ALT
Перевернуть текст на контуре | Дважды щелкнуть любым инструментом выделения на I-образном маркере текста или просто перетащить текст на другую сторону контура
Перемещение на один символ вправо | Стрелка вправо
Перемещение на один символ влево | Стрелка влево
Перемещение на одну строку вниз | Стрелка вниз
Перемещение на одну строку вверх | Стрелка вверз
Перемещение на одно слово вправо | CTRL+стрелка вправо
Перемещение на одно слово влево | CTRL+стрелка влево
Перемещение на один абзац вниз | CTRL+стрелка вниз
Перемещение на один абзац вверх | CTRL+стрелка вверх
Выделение всего текста документа | CTRL+A (если точка ввода находится в пределах документа)
Выделение всего текста в документе | CTRL+A (если инструмент Type (Текст) не активный)
Выделение следующего символа | SHIFT+стрелка вправо
Выделение предыдущего символа | SHIFT+стрелка влево
Выделение следующей строки | SHIFT+стрелка вниз
Выделение предыдущей строки | SHIFT+стрелка вверх
Выделение следующего слова | CTRL+SHIFT+стрелка вправо
Выделение предыдущего слова | CTRL+SHIFT+стрелка влево
Выделение следующего абзаца | CTRL+SHIFT+стрелка вниз
Выделение предыдущего абзаца | CTRL+SHIFT+стрелка вверх
Выделение слова | Двойной щелчок на слове
Выделение абзаца | Тройной щелчок на абзаце
Отмена выделения всего текста | CTRL+SHIFT+A
Копирование и перемещение текста | Перетаскивание инструментом Direct Selection (Частичное выделение) с нажатой коавишей ALT
Перено, задаваемый пользователем | CTRL+SHIFT+-
Возврат каретки | ENTER
Отобразить палитру Paragraph (Абзац) | CTRL+SHIFT+M
Выровнять влево | CTRL+SHIFT+L
Выровнять вправо | CTRL+SHIFT+R
Выровнять по центру | CTRL+SHIFT+C
Выровнять по обоим краям | CTRL+SHIFT+J
Полная выключка (включая последнюю строку) | CTRL+SHIFT+F
Отобразить палитру Tab Ruler (Линейка табуляции) | CTRL+SHIFT+T
Выровнять палитру Tab Ruler (Линейка табуляции) по выделенному абзацу | Щелчок на рамке палитры Tab Ruler (Линейка табуляции)
Смена видов табуляции | Щелчок на табуляторе с нажатой клавишей ALT
Перемещение нескольких табуляторов | Перетаскивание табулятора с нажатой клавишей SHIFT
Отобразить палитру Character (Символ) | CTRL+T
Выделить в палитре Character (Символ) гарнитуру (шрифт) | CTRL+ALT+SHIFT+M
Увеличить кегль шрифта | CTRL+SHIFT+>
Уменьшить кегль шрифта | CTRL+SHIFT+<
Увеличение интерлиньяжа | ALT+стрелка вниз
Уменьшение интерлиньяжа | ALT+стрелка вверх
Сброс интерлиньяжа в значение по умолчанию | Двойной щелчок на символе интерлиньяжа в палитре Character (Символ)
Сдвиг базовой линии вверх | ALT+SHIFT+стрелка вверх
Сдвиг базовой линии вниз | ALT+SHIFT+стрелка вниз
Сдвиг базовой линии вверх на 10 пунктов | CTRL+SHIFT+ALT+стрелка вверх
Сдвиг базовой линии вниз на 10 пунктов | CTRL+SHIFT+ALT+стрелка вниз
Уменьшение кернинга/трекинга | ALT+стрелка влево
Увеличение кернинга/трекинга | ALT+стрелка вправо
Уменьшение кернинга/трекинга в пятикратном размере | CTRL+ALT+стрелка влево
Увеличение кернинга/трекинга в пятикратном размере | CTRL+ALT+стрелка вправо
Уменьшение кернинга до нуля | CTRL+SHIFT+Q
Выделение кернинга в палитре Character (Символ) | CTRL+ALT+K
Сброс параметра Horizontal Scale (Ширина символов) до значения 100% | CTRL+SHIFT+X


Горячие клавиши - Illustrator - Управление цветом

Управление цветом
Показать/Скрыть палитру Color (Цвет) | F6 (переключение), CTRL+l
Переход к цветам по умолчанию (заполнение белым, черная обводка) | D
Переключение между заполнением и обводкой | X
Выбор текущего цвета палитры | ,
Отмена заполнения контура цветом | /
Изменение цвета заполнения, если активна обводка, и цвета обводки, если активно заполнение | Щелчок на окне отображения текущего цвета в палитре с нажатой клавишей ALT
Заливка невыделенного объекта требуемым цветом | Перетаскивание цвета из палитры на объект
Заливка выделенных объектов требуемым цветом | Щелчок на образце цвета
Заливка объекта текущим цветом | Щелчок на невыделенных объектах с активным инструментом Paintbucket (Заливка)
Копирование цвета объекта в выделенные объекты | Щелчок на объекте, цвет которого следует скопировать, активным инструментом Eyedropper (Пипетка)
Одновременное изменение цветов | Перемещение одного из бегунков палитры с нажатой клавишей SHIFT
Переключение между цветовыми моделями (Градации серого, RGB, CMYK) | Щелчок на окне отображения текущего цвета в палитре с нажатой клавишей SHIFT
Показать/Скрыть палитру Swatches (Образцы) | F5
Переключение между заполнением и обводкой | X
Добавление образца | Щелчок на пиктограмме New Swatch (Новый образец). Перетаскивание из палитры Color (Цвет) Gradient (Градиент) в палитру Swatches (Образцы)
Замена образца | Перетаскивание образца из палитра Color (Цвет) Gradient (Градиент) в палитру Swatches (Образцы) с нажатой клавишей ALT
Копирование образца | Перетаскивание образца на пиктограмму New Swatch (Новый образец) в палитре Swatches (Образцы) с нажатой клавишей ALT
Удаление образца | Перетаскивание образца на пиктограмму Trash (Удалить образец) в палитре Swatches (Образцы). Выделение образца и щелчок на пиктограмме Trash (Удалить образец)
Выделение последовательности образцов | Щелчок на первом и последнем образцах с нажатой клавишей SHIFT
Выделение нескольких образцов в произвольном порядке | Щелчок на каждом образце с нажатой клавишей CTRL
Переключение клавиатурного ввода на палитру Swatches (Образцы) | Щелчок на палитре Swatches (Образцы) с нажатыми клавишами CTRL+ALT
Присвоить цвет невыделенному объекту | Перетаскивание цвета из палитры Swatches (Образцы) на объект
Присвоить цвет выделенному объекту | Щелчок на образце палитры Swatches (Образцы)
Выбор градиента в палитре Gradient (Градиент) | .
Показать/Скрыть палитру Gradient (Градиент) | F9
Присвоение значение образца выделенной опорной точке градиента | Щелчок на образце с нажатой клавишей ALT
Добавление опорной точки градиента | Щелчок под шкалой градиента
Копирование опорной точки | Перетаскивание опорной точки градиента с нажатой клавишей ALT
Перестановка опорных точек | Перетаскивание одной опорной точки градиента на другую с нажатой клавишей ALT
Присвоение цвета опорной точке инструментом Eyedropper (Пипетка) | Щелчок инструментом Eyedropper (Пипетка) с нажатой клавишей SHIFT
Сброс градиента в значение по умолчанию (от черного к белому) | Щелчок на образце градиента с нажатой клавишей CTRL
Присвоить значение градиента невыделенному объекту | Перетаскивание образца градиента из палитры Gradient (Градиент) на объект
Присвоить значение градиента выделенному объекту | Щелчок на образце палитры Gradient (Градиент)
Показать/Скрыть палитру Stroke (Обводка) | F10
Увеличение/уменьшение толщины линии | Выделить поле Weight (Вес), установить нужное значение клавишами стрелка вверх или стрелка вниз, а затем нажать клавишу ENTER
Увеличение/уменьшение срезания | Выделить поле Milter (Предел), установить нужное значение клавишами стрелка вверх или стрелка вниз, а затем нажать клавишу ENTER


Горячие клавиши - Illustrator - Форма

Форма
Ellipse (Эллипс) | L (переключение между инструментами Polygon (Многоугольник), Star (Звезда) и Spiral (Спираль))
Polygon (Многоугольник) | Дважды нажать клавишу L (если по умолчанию используется инструмент Ellipse (Эллипс))
Star (Звезда) | Трижды нажать клавишу L (если по умолчанию используется инструмент Ellipse (Эллипс))
Spiral (Спираль) | Четыре раза нажать клавишу L (если по умолчанию используется инструмент Ellipse (Эллипс))
Rectangle (Прямоугольник) | M (переключение с инструментом Rounded Rectangle (Скругленный прямоугольник))
Rounded Rectangle (Скругленный прямоугольник) | Дважды нажать клавишу М (если по умолчанию используется инструмент Rectangle (Прямоугольник))
Создание эллипса с указанными параметрами | Щелчок инструментом Ellipse (Эллипс)
Рисование эллипса | Перетаскивание инструмента Ellipse (Эллипс)
Рисование окружности | Перетаскивание инструмента Ellipse (Эллипс) с нажатой клавишей SHIFT
Создание эллипса от центра с указанными параметрами | Щелчок инструментом Ellipse (Эллипс) с нажатой кла вишей ALT
Рисование эллипса от центра | Перетаскивание инструмента Ellipse (Эллипс) с нажатой клавишей ALT
Создание многоугольника с указанными параметрами | Щелчок инструментом Polygon (Многоугольник)
Рисование многоугольника | Перетаскивание инструмента Polygon (Многоугольник)
Рисование многоугольника с ограничением поворота | Перетаскивание инструмента Polygon (Многоугольник) с клавишей SHIFT
Перемещение многоугольника при рисовании | Перетаскивание инструмента Polygon (Многоугольник) с нажатой клавишей пробел
Создание нескольких многоугольников с общим центром | Перетаскивание инструмента Polygon (Многоугольник) с нажатой клавишей -
Увеличение числа сторон многоугольника | Перетаскивание инструмента Polygon (Многоугольник) с нажатой клавишей стрелка вверх
Уменьшение числа сторон многоугольника | Перетаскивание инструмента Многоугольник с нажатой клавишей стрелка вниз
Рисование звезды | Перетаскивание инструмента Star (Звезда)
Рисование звезды с ограничением поворота | Перетаскивание инструмента Star (Звезда) с нажатой клавишей SHIFT
Создание звезды с указанными параметрами | Щелчок инструментом Star (Звезда)
Перемещение звезды при рисовании | Перетаскивание инструмента Star (Звезда) с нажатой клавишей пробел
Создание нескольких звезд с общим центром | Перетаскивание инструмента Star (Звезда) с нажатой клавишей -
Рисование "правильной" звезды | Перетаскивание инструмента Star (Звезда) с нажатой клавишей ALT
Изменение размера звезды | Перетаскивание инструмента Star (Звезда) с нажатой клавишей CTRL
Увеличение числа лучей звезды | Перетаскивание инструмента Star (Звезда} с нажатой клавишей стрелка вверх
Уменьшение числа лучей звезды | Перетаскивание инструмента Star (Звезда} с нажатой клавишей стрелка вниз
Создание спирали с указанными параметрами | Щелчок инструментом Spiral (Спираль)
Рисование спирали | Перетаскивание инструмента Spiral (Спираль)
Рисование спирали с ограничением поворота | Перетаскивание инструмента Spiral (Спираль) с нажатой клавишей SHIFT
Передвижение спирали при рисовании | Перетаскивание инструмента Spiral (Спираль) с нажатой клавишей пробел
Создание нескольких спиралей с общим центром | Перетаскивание инструмента Spiral (Спираль) с нажатой клавишей -
Уменьшение шага спирали | Перетаскивание инструмента Spiral (Спираль) с нажатой клавишей CTRL
Увеличение размера спирали и количества витков | Перетаскивание инструмента Spiral (Спираль) с нажатой клавишей ALT
Добавление витков | Перетаскивание инструмента Spiral (Спираль) с нажатой клавишей стрелка вверх
Уменьшение числа витков | Перетаскивание инструмента Spiral (Спираль) с нажатой клавишей стрелка вниз
Создание прямоугольника с указанными параметрами | Щелчок инструментом Rectangle (Прямоугольник)
Рисование прямоугольника | Перетаскивание инструмента Rectangle (Прямоугольник)
Рисование квадрата | Перетаскивание инструментом Rectangle (Прямоугольник) с нажатой клавишей SHIFT
Создание скругленного прямоугольника с указанными параметрами | Щелчок инструментом Rectangle (Прямоугольник) или Rounded Rectangle (Скругленный прямоугольник)
Рисование скругленного прямоугольника | Перетаскивание инструментом Rounded Rectangle (Скругленный прямоугольник)
Создание прямоугольника от центра с указанными параметрами | Щелчок инструментом Rectangle (Прямоугольник) с нажатой клавишей ALT
Рисование прямоугольника от центра | Перетаскивание инструмента Rectangle (Прямоугольник) с нажатой клавишей ALT
Создание скругленного прямоугольника от центра с указанными параметрами | Щелчок инструментом Rectangle (Прямоугольник) или Rounded Rectangle (Скругленный прямоугольник) с нажатой клавишей ALT
Рисование скругленного прямоугольника от центра | Перетаскивание инструмента Rounded Rectangle (Скругленный прямоугольник) с нажатой клавишей ALT


Untitled

Приемы работы в Illustrator

  • Введение
  • Рисование
  • Работа с текстом
  • Модификация фигур

Оглавление


Введение в Adobe Illustrotor

Введение

Adobe Illustrator - это пакет для работы с векторной графикой, в отличае от Adobe Photoshop, который работает с растровой графикой.

Интерфейс этого пакета похож на интерфейс Photoshop, о котором, я надеюсь, вы уже прочитали на этом сайте. Поэтому отдельно рассказывать об интерфейсе я не буду. Приемы махания мышкой и даже некоторые палитры здесь такие же, как в Photoshop.

На первый взгляд Adobe Illustrator предоставляет не так уж много возможностей для рисования, но, на самом деле, это только с первого взгляда так кажется. Вот самые основные возможности:

  • Рисование линий и кривых произвольной формы, можно замкнутой формы.
  • Заливка внутренностей нарисованной фигуры цветом, текстурой или градиентом.
  • Работа с текстом различной формы.
  • Операции по созданию и преобразованию фигур.
  • Работа с растровыми фрагментами изображения.

После того как вы нарисуете изображение в Adobe Illustrator, вам понадобится его конвертировать в растровый формат (GIF или JPEG), чтобы разместить его на сайте. Если потребуется, его можно даже доработать в Photoshop, но обратное преобразование, естественно, уже невозможно.


Модификация фигур в Adobe Illustrotor

Модификация фигур

Кое-как модифицировать фигуры мы научились в предыдущем разделе. Продолжим рассмотрение этого вопроса. Как копировать, двигать и удалять фигуры я рассказывать не буду, это и так очевидно. Давайте лучше рассмотрим меню Object:

Меню Object

Следующие пункты отвечают за изменение формы фигуры

  • Transform > Move - Перемещение фигуры
  • Transform > Scale - Изменение масштабов
  • Transform > Rotate - Вращение
  • Transform > Reflect - Зеркальное отражение
  • Transform > Shear - Наклон

Если у вас несколько закрашенных фигур налезают друг на друга, то какая из них будет сверху, а какая снизу? Для установки этого можно воспользоваться следующими пунктами, которые задают порядок фигур.

  • Arrange > Bring to Front
  • Arrange > Bring Forward
  • Arrange > Send Backward
  • Arrange > Send to Back

Представите себе, что вы нарисовали машинку из нескольких фигур. Потом подвинули эту машинку, а ее колеса остались на месте. Еще бы, ведь колеса - это отдельные фигуры. Чтобы этого не произошло, надо сгруппировать фигуры в один объект. Затем вы можете работать с этой машинкой, как с единым объектом.

  • Group - сгруппировать все выделенные фигуры в один объект
  • Ungroup - разгруппировать объект

Можно растрировать какой-то фрагмент рисунка, т.е. превратить его в точечный. Пункт меню Rasterize... Зачем это нужно, ведь такой рисунок потом почти не отредактировать? Но к точечному рисунку можно применять растровые фильтры, как в Photoshop (пункт меню Filter). Для векторных рисунков тоже есть набор векторных фильтров, которые недоступны для растровых фрагментов.

Палитра Pathfinder

Палитра Pathfinder Представьте себе, что вы нарисовали квадрат, а теперь хотите отрезать от него кружок. Или вам надо разрезать фигуру по какой-то хитрой кривой.

Для подобных операций над фигурами как раз и предназначена палитра Pathfinder. Чтобы воспользоваться этой палитрой, отметьте одновременно несколько необходимых фигур и нажмите нужную кнопку на палитре. Что делает какая кнопка, можно разобраться по ее внешнему виду.

Учтите, что часто имеет значение, какая фигура выше, а какая ниже (см. выше). В результате операции могут получаться несколько разных фигур, с которыми можно работать по отдельности. Иногда, в результате получается сгруппированная фигура, если вас это не устраивает, то придется ее разгруппировать.


Работа с текстом в Adobe Illustrotor

Работа с текстом

С текстом в Adobe Illustrator можно работать именно как с текстом, а не как с кривыми Безье. Но, если вы захотите, текст можно будет преобразовать в обыкновенные фигуры.

Пример работы с текстом Для написания текста на панели инструментов есть несколько инструментов. На всех них написана большая буква "T". Вот эти инструменты:

  • Type Tool - Написание горизонтального текста
  • Area Type Tool - Написание текста, вписанного в произвольную фигуру
  • Path Type Tool - Написание текста вдоль произвольной кривой

Следующие инструменты действуют аналогично, но пишут вертикальный текст (следующая буква под предыдущей).

  • Vertical Type Tool
  • Vertical Area Type Tool
  • Vertical Path Type Tool

Когда вы собираетесь писать обычный текст, то вам надо выбрать инструмент типа ...Type Tool, щелкнуть им на нужном месте и начать набирать текст. Когда вам надо вписать текст в фигуру, сначала надо будет выбрать инструмент типа ...Area Type Tool, щелкнуть им на нужной фигуре, и затем начать набирать текст. Если вы собираетесь писать текст вдоль кривой, то выбираете инструмент типа ...Path Type Tool, и щелкаете им на кривой.

При изменении несущих фигур или кривых, будет изменяться форма самого текста. Естественно, что несущие фигуры можно сделать нулевой толщины, чтобы они не были видны на рисунке. Вы можете выделить фрагмент текста при помощи текстового курсора, и задать его шрифт при помощи палитры Character. Выравнивание текста можно задать палитрой Paragraph. Еще для работы с текстом есть целое меню Type.


Рисование в Adobe Illustrotor

Рисование

В основном, все фигуры в Adobe Illustrotor состоят из кривых Безье. Если непонятно, что это такое, то возьмите упругую металлическую линейку за концы и начинайте ее изгибать. Линейка будет принимать форму кривой Безье. Короче, у этой кривой задаются начало, конец и углы, под которыми кривые исходят из начала и конца. Естественно, что такая кривая может стать прямой, если ей не "выкручивать концы".

Illustrotor может работать в двух режимах:

  • Preview (Меню View > Preview)
  • Artwork (Меню View > Artwork)

В одном из них вы видете "скелет" рисунка, а в другом - настоящий полноценный рисунок. Режим "скелета" показывает все фигуры, даже если они нулевой толщины, а в обычном режиме некоторые фигуры можно и не увидеть. Редактировать можно в обоих режимах. Какой из них выбрать в настоящий момент, зависит от обстоятельств.

Панель инструментов Итак, давайте нарисуем какую-нибудь фигуру:

  • Выберете на панели инструментов Pen Tool (перо).
  • Пощелкайте им на рисунке. Как видите, получилась ломаная линия.
  • Теперь не щелкайте мышью, а нажимайте, тяните и отпускайте мышь. Как видите, получается кривая с плавными углами.

Чтобы добавить точку излома на линию, воспользуйтесь инструментом Add Anchor Point Toll (Перо с "+").

Что бы убрать точку излома воспользуйтесь инструментом Delete Anchor Point Toll (Перо с "-").

Чтобы отрегулировать углы вхождения и выхождения кривой в точку излома, используйте иструмент Correct Direction Point (Уголок). После того, как щелкните этим инструментом на точке, появятся направляющие, которые позволят отрегулировать углы.

Допустим, нарисовали вы какую-то кривую. Как ее перемещать? Для этого воспользуйтесь Selection Tool (Черная стрелка). Этот инструмент позволяет выделять и двигать всю фигуру целиком.

А если надо поработать с отдельными точками (точками излома)? Тогда используйте Direct Selection Tool (Белая стрелка). Этим инструментом можно выделять и перемещать отдельные точки излома у фигуры.

Что бы упростить вам работу, на панели есть инструменты для рисование всяких кружков, звездочек, квадратиков. Эти фигуры тоже будут состоять из кривых Безье. Если вас не устраивает, какие звезды или круги получаются по умолчанию, то выберете инструмент и один раз щелкните на рисунке. При этом появится диалог, который запросит параметры объекта (например: диаметр и число концов у звезды).

Внизу палитры находятся кнопки для переключения трех режимов закраски фигур:

  • Color - Заливка сплошным цветом
  • Gradient - Заливка градиентом
  • None - Без заливки. Просто линии.

Еще на панели есть большая штука, которая указывает, что сейчас задается: цвет линии или цвет заливки, и отображает их. Цвета кривых или заливки можно задать на палитре Color или Swatches. Толщину линии на палитре Stroke. Если заливка градиентная, то воспользуйтесь палитрой Gradient.

В инструментах есть Карандаш и Кисть, они тоже работают с кривыми Безье, но только немного с другими начальными настройками.


illustrator

Illustrator 9.0

Adobe(R) Illustrator(R)9.0 - программа, которая является промышленным стандартом в создании графики для печати и для Web.

- Девятая версия этой программы, является мощным инструментом для создания растровой и векторной графики для Интернет.

- Поддержка форматов Flash Shockwave (SWF), SVG (масштабируемая векторная графика), и конечно же GIF, JPEG, PNG со всеми возможностями.

- Возможность отимизации графики для Web и предварительный просмотр различных вариантов оптимизированной графики (функция Save For Web).

- Ориентация цветовых режимов: RGB - для Web, CMYK - для печати.

- Анимация графики.

- Инструменты быстрого создания рамок и теней для элементов управления в Web (элементы меню, кнопки, и т.д.).

- Автоматическое подстраивание размеров обьекта (элементы меню, кнопки, и т.д.) в зависимости от вводимого текста, наложенного сверху.

- Полная интеграция с другими форматами и программами (Adobe GoLive, Adobe Photoshop 5.5, Adobe LiveMotion)

- Прекрасная поддержка прозрачности как слоев, так и отдельных обьектов (полная поддержка прозрачности формата PSD - Adobe Photoshop).

- Различные режимы наложения (аналог. Adobe Photoshop). Функции вырезать, совместить.

- Прозрачный текст.

- Слоевые маски.

- Сглаживание и размытие векторной графики (аналог. Adobe Photoshop - Feather).

- Предварительный просмотр установок трэппинга.

- Поддержка и редактирования текста в формате PSD (Adobe Photoshop).

- Эффекты слоев (Layer Effects).

- Эффекты текста.

- Создание стилей на графику.

- Просмотр содержимого каждого слоя.

- Полная поддержка формата PDF (одно ядро AI/PDF).

- Улучшенное управление цветом, используя Adobe Color Engine (ACE).

- Инструмент Лассо (Lasso).

- Import: EPS, PDF, SVG, Photoshop 2.5-5.5, FreeHand 5.0-8.0, CorelDraw 5.0-8.0, Amiga IFF, BMP, CGM 1/2/3, DWG, DXF, EMF, WMF, GIF, JPEG, PNG, KODAK Photo CD, PICT, PCX, PXR, TGA, TIFF.

- Export: AI, EPS, PDF, SVG, Flash (SWF), Photoshop 2.5-5.5, Amiga IFF, BMP, CGM 1/2/3, DWG, DXF, EMF, WMF, GIF, JPEG, PNG, PICT, PCX, PXR, TGA, TIFF. Простое перетаскивание (dragand drop) в программы InDesign, Photoshop, PageMaker, Microsoft Word.

Оглавление


Обмен опытом | Вопросы по продуктам Adobe

Вопросы по Adobe Illustrator
Adobe Magazine пишет: как создавать текстовые стили в Illustrator.

Ни для кого не секрет, что в Adobe Illustrator 8.x нет палитры текстовых стилей и вы не можете сохранить тщательное форматирование параграфа текста так, как это делается в любой программе верстки или текстовом процессоре.
Однако решить задачу можно, причем несколькими способами.
Один из них - использование палитры Brushes и инструмента "пипетка" (eyedropper). В палитре сохраняются текстовые настройки, а "пипетка" позволяет сохранять только текстовые атрибуты (при соответствующей настройке инструмента). Но сейчас мы поговорим о другом способе создания текстовых стилей.
Используйте для этого палитру Actions. Создавая скрипты форматирования текста, вы впоследствии можете легко их применять: необходимо выделить текст и запустить соответствующий скрипт. Более того, вы можете назначить "горячую клавишу" для скрипта, и форматирование сведется к простому нажатию кнопки.
Вот как это сделать.
1. Откройте новый файл в Illustrator и выберите Window > Show Actions чтобы показать палитру Actions.
2. Создайте отдельный набор для "текстовых" скриптов. Для этого выберите New Set из меню палитры или щелкните кнопку Create New Set в нижней части палитры. Введите соответствующее имя, например "текстовые стили", затем нажмите ОК.
3. Удостоверьтесь, что все новые текстовые скрипты будут записываться в этот набор: папка этого набора должна быть активной.
4. Запустите New Action из меню палитры. Введите имя для создаваемого стиля, например, "Заголовок" или "Основной текст". Если нужно, выберите "горячую клавишу" для скрипта, затем нажмите Record.
5. Возьмите инструмент "текст" и наберите пробный текст на странице. Подсветите его, чтобы будущий скрипт работал именно с выделенным текстом.
6. Выберите Type > Character или Type > Paragraph чтобы открыть палитру Character и Paragraph. В палитре Character выберите нужные атрибуты, такие как гарнитура, начертание, кегль, интерлиньяж и др. В палитре Paragraph настройте параметры параграфа, такие как выравнивание, левый и правый отступ, красную строку и отбивку перед параграфом. Вы можете даже настроить табуляторы, а также использовать для настройки любые другие палитры (Stroke, Color).
7. Когда текст будет отформатирован так, как вам надо, нажмите кнопку Stop Playing/Recording в нижней части палитры Actions.
8. Повторите эти пункты для создания других текстовых стилей. Если в процессе создания вы не присвоили скрипту "горячую клавишу", вы всегда сможете сделать это позже. Для этого:
1. В палитре Actions дважды щелкните на нужном скрипте.
2. В диалоговом окне настройки скрипта выберите "горячую клавишу" и нажмите ОК.
Для того, чтобы форматировать текст с помощью текстового скрипта просто выделите нужный текст и запустите скрипт из палитры Actions или нажмите соответствующую ему "горячую клавишу".

По материалам Adobe Systems Inc.

Adobe Magazine пишет: как подготовить пунктирные линии к нарезке на каттере.

Если вы сделаете обводку пунктиром, пользуясь палитрой Stroke, то режущий плоттер не распознает этой затеи, поскольку требует, чтобы каждая линия пунктира была отдельным объектом. Команда Outline Path в этом случае не помогает, поскольку превращает пунктирную обводку в обычную линию. Чтобы побороть глупое устройство, надо сделать пунктир с помощью "узора". Создайте из одной линии pattern brush, примените его к нужному контуру, затем используйте команду Expand, чтобы превратить узор в серию объектов. Теперь подробнее:
1. Выберите инструмент "текст", очертите небольшой текстовый блок и напечатайте один дефис. Используйте палитру Character, чтобы форматировать дефис нужным шрифтовым начертанием и кеглем. В частности, можете подстроить параметры так, чтобы линия получилась похожей на стандартный пунктир палитры Stroke.
2. Выделите дефис с помощью инструмента выделения объектов. Затем конвертируйте его в объект командой Type > Create Outlines.
3. При выделенном дефисе выберите New Brush из палитры Brushes (если палитры нет, откройте ее командой Window > Show Brushes). Затем выберите New Pattern Brush из списка Select A Brush Type и нажмите ОК.
4. Если хотите, чтобы пробельные элементы в пунктире были равны длине "дефиса", то установите Spacing в 100%. Если пробелы надо уменьшить, уменьшите эту величину. Если нужно подогнать величину пробелов под конкретный контур, выберите Add Space To Fit или Approximate Path. Затем нажмите ОК и новая кисть появится в палитре Brushes.
5. Выделите контур, из которого хотите сделать пунктир, и щелкните вновь созданный узор в палитре, чтобы применить его.
6. Не снимая выделения с контура выберите Object > Expand. Удостоверьтесь, что опции Object, Fill и Stroke включены и нажмите ОК. Теперь каждая черточка в пунктире является отдельным объектом и распознается режущим плоттером. Если вас не сразу устроил получившийся пунктир, то можете подобрать параметры пробельных элементов и заполнения у зором контура просто дважды щелкнув на пиктограмме узора в палитре Brushes. И еще одна маленькая хитрость: если ваш пунктирный контур содержит углы, то сначала "перетащите" вашу линию (см. пункт 2) в палитру Swatches. Затем, в пункте 4 выберите необходимую опцию для отрисовки углов.

По материалам Adobe Systems Inc.

Почему один и тот же цвет воспроизводится и печатается в Photoshop и Illustrator по-разному?

Чтобы побороть проблему, надо тщательно настроить параметры элементов управления цветом и выбрать одинаковые профили монитора и принтера в Adobe Photoshop 5.0.x и Adobe Illustrator 8.0.x.
1. Установите профиль монитора:
Заметка: если у вас нет профиля монитора, создайте его сами с помощью Adobe Gamma.
- в системе Mac OS 8.0 или 8.1 выберите ColorSync System Profile из меню Apple, затем выберите нужный профиль монитора из папки профилей ColorSync Profiles
- в системе Mac OS 8.5 и выше, выберите контрольную панель ColorSync и выберите профиль из выпадающего списка
- в Windows 95, Windows 98, или Windows NT выберите профиль в утилите Adobe Gamma и пересохраните его.
2. В Photoshop выберите File > Color Settings > RGB Setup.
3. Выберите Monitor RGB из выпадающего списка RGB.
4. Включите опцию Display Using Monitor Compensation, затем нажмите OK.
5. Выберите File > Color Settings > CMYK Setup.
6. Установите в ICC CMYK-режим.
7. Выберите нужный профиль для конечного выходного устройства из выпадающего меню Profile. Если у вас нет профиля, свяжитесь с типографией, где будете печатать работу, или создайте профиль в Photoshop. Для этого сначала, пользуясь руководством Photoshop надо откалибровать монитор под свое выходное устройство, затем:
А. В Photoshop выберите File > Color Settings > CMYK Setup, затем выберите Tables в секции CMYK Model и нажмите Save.
В. В диалоговом окне Save назовите профиль и сохраните его соответственно:
-- System Folder:Preferences:ColorSync Profiles (Mac OS)
-- Windows\System\Color (Windows 95 или Windows 98)
-- Windows\System32\Color (Windows NT)
С. Перезапустите Photoshop.
Заметка: если вы используете собственные настройки краски, CMYK-таблицы или другие возможности диалогового окна CMYK Setup в Photoshop, то единственной возможностью добиться одинакового цвета в нем и в Illustrator - это создать ICC-профиль в Photoshop 5.0 и использовать его в пунктах 7 и 13 этой инструкции.
8. Выберите Built-in из выпадающего меню Engine.
9. Выберите Perceptual (Images) из выпадающего меню Intent, затем включите Black Point Compensation и нажмите OK.
10. Выберите View > Preview > CMYK и выйдите из Photoshop.
Заметка: если вы будете печатать из Photoshop, отключите опцию PostScript Color Management в диалоговом окне Print.
11. В Illustrator выберите File > Color Settings.
12. В выпадающем меню Monitor (RGB) выберите тот же профиль монитора, что и в пункте 1 инструкции.
13. В выпадающем меню Printer (CMYK) выберите тот же профиль выходногоустройства, что и в пункте 7 инструкции.
14. Выберите Adobe CMS из выпадающего меню Engine.
15. Выберите Perceptual (Images) из выпадающего меню Intent.
16. Включите опцию Simulate Print Colors в Display и нажмите OK.

По материалам Adobe Systems Inc.

Что делать, если при запуске Иллюстратора вы получаете отлуп "Adobe Illustrator cannot run."?

Попробуйте один из вариантов:
1. Удалите Illustrator 8.0.x, а затем установите его вновь. Следите за тем, чтобы серийный номер в точности соответствовал нанесенному на регистрационную карточку или маркировку диска. Не добавляйте в номер пробелы, ни перед ним, ни после. Не используйте серийные номера бета-версий (они начинаются с EXX). Дело в том, что при установке Иллюстратора его серийный номер заносится в специальный файл Adobe Registration Database. Этот файл содержит регистрационную информацию обо всех продуктах Adobe, установленных в системе. Когда вы запускаете Иллюстратор, он проверяет с помощью этого файла правильность вашего серийного номера. Если файл регистрационной базы данных уже содержит некорректный серийный номер, Иллюстратор возвращает ошибку "Adobe Illustrator cannot run.". Некорректный номер может появиться как следствие просроченных бета-версий, либо как содержащий пробелы. Возможно и повреждение самого файла базы.
2. Если вы используете не североамериканскую версию МакОС, проделайте следующее:
сгрузите Adobe Illustrator 8.0 Update for International English (Serial Fixer) c cайта Adobe по адресу www.adobe.com/support/downloads/5292.htm.
Впрочем, можете просто установить дату 31 Октября 1998 года на своем компьютере и жить спокойно (если получится).
Эта странность обусловлена тем, что в системах МакОС не для северной америки английские версии Иллюстратора запоминают в файле Adobe Registration Database не тот серийный номер, который вы ввели, а просроченный. Апдейт для международной английской версии устраняет эту проблему.
3. Удалите Иллюстратор и файл Adobe Registration Database а затем проделайте следующее:
-уберите все не относящиеся к программе файлы (такие, как файлы, созданные вами или подключаемые модули третьих фирм) из папки Illustrator и всех вложенных папок.
-удалите папку Illustrator (Mac OS) или выберите Start > Settings > Control Panels затем используйте опцию Add/Remove Programs чтобы удалить Illustrator (Windows).
-Вручную удалите следующие файлы Иллюстратор:
В Mac OS, уберите файлы Adobe Registration Database и Adobe Illustrator 7.0.x Prefs из System Folder: Preferences folder в корзину. С помощью команды Find File (Mac OS 8.1 и более ранние версии) или Sherlock (Mac OS 8.5 и последующие версии) найдите все файлы Adobefnt.lst и перенесите их в корзину.
В Windows, удалите файл Adobereg.db из папки Windows. С помощью Start > Find > Files and Folders, найдите все файлы adobefnt.lst и удалите их.
Переустановите Иллюстратор (при этом возникнет новый файл Adobe Registration Database)
Примечание:
Североамериканские версии МакОС включают в себя U.S., Canada-English, и Canada-French-версии. Для того, чтобы определить, какая система стоит у вас, откройте Apple System Profiler из меню Apple (яблочко). В секции Mac OS Overview посмотрите на строку System. Если там нет слов "US" или "Canada", то у вас не североамериканская версия системы.

По материалам Adobe Systems Inc.

Как сделать многоцветные обводки текста?

Простой и быстрый способ сделать двухцветную обводку вокруг текста в Иллюстраторе.
Вариант 1. Просто сделайте текстовую обводку нужного цвета, затем скопируйте текст и поместите его точно над оригиналом (Command(Ctrl)+C, Command(Ctrl)+F), аналог команды Paste in Front. После этого уменьшите толщину обводки и закрасьте ее другим цветом.
Вариант 2. Переведите текст в кривые (Convert to Outlines), затем compound path, затем операция offset path над копией текста и, вуаля - раскрашивайте контуры в разные цвета.

По материалам www.adobe.com

Борьба с изменением цвета при импорте из Иллюстратора в Фотошоп.

Проблема: В RGB файлах Illustrator 8.0 и выше при импорте или открытии их в Photoshop 5.0 и выше происходит цветовой сдвиг.
Решение: как всегда, простое. Экспортируйте файл из Illustrator в одном из растровых форматов (tiff, psd, gif). Если хотите сохранить векторные слои Иллюстратора, то экспортируйте только в родной формат Фотошопа - PSD.
Комментарии: Все проблемы исходят от EPS-интерпретатора в Фотошопе, который обрабатывает родные файлы Иллюстратора, а также файлы EPS. При открытии растровых файлов этот интерпретатор попросту не используется.

Оглавление


photoshop

Новое в Adobe InDesign 1.5

- Тесная интеграция программ
Общий интерфейс пользователя Adobe. InDesign имеет аналогичные инструменты, команды, палитры, и клавиатурные сокращения (shortcuts) с Illustrator и Photoshop. В InDesign 1.5 добавлены, новые инструменты стандарта Adobe типа пипетки (eyedropper), произвольное преобразование (free transform), карандаш (pencil), инструменты сглаживания (smooth), возможность позиционирования палитр и другие элементы интерфейса, создают единый интерфейс.
Вообще-то логично, гораздо легче применять программный код, который уже используется и отлажен, чем писать под каждую программу свой, индивидуальный.

- Расширенные возможности импорта
Размещение "родных" файлов Illustrator или Photoshop в документах InDesign, а также размещение страниц PDF файлов (Adobe PDF: Portable Document Format) как файлы связанной графики (linked graphics). Достаточно ценная функция, которую многие ждали уже давно: начиная с этой версии (InDesign 1.5), при импорте файлов Photoshop сохраняется информация альфа-канала, это дает вам возможность использовать маскирование изображений или управлять текстом вокруг графики.

- Текст вдоль кривых
Размещение текста вдоль любого пути в InDesign 1.5. (Интересно, сольются ли InDesign и Illustrator в будущем?). Плюс расширенные средства управления типографскими параметрами как трэккинг (tracking) и кернинг (kerning); выравнивние текста вдоль кривой; применение специальных эффектов типа Gravity (наклон текста в разные стороны) или 3-х мерная лента (3D Ribbon).

- Новые инструменты для рисования
Карандаш (pencil), для рисования произвольных кривых, новый ластик (erase) и инструменты сглаживания (smooth). Для модификации кривых вы можете использовать инструменты ножницы (scissors) и ручка (pen).

- Преобразование объекта
Инструмент вращение, масштабирование и т.д. работают точно также, как в Photoshop и Illustrator. Есть возможность ввода числовых значений для более точной трансформации.

- Редактирование кривых
Можно выбирать и преобразовывть сразу несколько точек, выравнивать сегменты, также растягивать и рисовать из центра.

- Улучшенный цветовой интерфейс
Несколько изменений достаточно удобны: функция "перенести и применить" цвет (drag and drop color), редактирование импортированных цветов, а также то, что при редактировании цвета у вас автоматически обновляется его имя - все это облегчит работу.

- Обтекание текстом
Файлы EPS и PDF в InDesign 1.5 теперь можно обтекать текстом, указав либо видимый контур EPS файла, либо включеный обтравочный контур (clipping path), или квадрат ограничивающего контура рисунка.

- Обтравочный контур
Теперь вы можете создать обтравочный контур (clipping path) в InDesign 1.5:
1. или используя информацию альфа-канала изображения;
2. или встроенный обтравочный контур сохраненный в импортируемом изображении Photoshop;
3. и если изображение содержит несколько обтравочных контуров выбрать тот, который захотите (включая, конечно, родные файлы Photoshop).

- Новый инструмент - пипетка
Вы можете взять пробу текста (параметры стиля) и применить их к другому тексту - действительно ценная возможность, неговоря уж о том, что можно взять пробу цвета импортированного изображения (!!!) и применить его к какому-либо объекту.

- Принтерные стили и стили экспорта PDF
Стили печати - этим пожалуй не удивишь.
А вот стили экспорта PDF файлов - помогут вам создать более правильный и корректный PDF файл с нужными установками (как говорится: на все случаи жизни).

Скрипты (scripting)
Скрипты дополнены сценариями создания PDF файлов.

Plug-ins
Появились команды управления Plug-ins - вы можете включить или выключить некоторые из них.

Палитра Страниц (Palette Page)
Новая палитра Страниц позволяет управлять видом страниц и их размещением на рабочем столе.

- Новые редакционные возможности
- Хочется отметить вертикальную выключку текста.
Т.е. при задании вертикальной выключки во фрейме, текста заполнит этот фрейм - увеличивая интерлиньяж автоматически.
- Встроенные технологии трэппинга
- Показ используемых щрифтов
- Выравнивание объектов
- Оптимизация preview. (Разрешения изображений)
- Появилась реальная возможность заставить говорить InDesign по-русски (!!!): встроенный пользовательский словарь переносов и проверки орфографии.

И многое другое.

Итог такой. Все более и более стираются границы между Adobe-программами (хотя бы интерфейсно).

Illustrator и InDesign - близнецы-братья.
Мы говорим Illustrator, подразумеваем InDesign
Мы говорим InDesign, подразумеваем Illustrator

Хотя, эту версию уже можно начинать использовать "промышленно".
Но...
если вы обладаете мощностями ниже 64Mb RAM / 300MHz CPU, то вам не придется вкусить все прелести этой программы. Даже то что заявлено - явно маловато. 128RAM / 350-400 MHz CPU - это пожалуй более реальные цифры.

InDesign подробно

Построенный на современном коде, InDesign представляет гибкую, расширяемую архитектуру, которая может легко поддерживать широкий диапазон публикации и графических потребностей. Что это означает для Вас?

Начинающие, сторонние разработчики и группы ИТ могут легко расширять богатые функциональные возможности в Adobe InDesign, написав дополнения к программе, которые добавят новые возможности, и это приспосабливает программу для выполнения определенных задач. Кроме того, эта расширяемость кладет сильную основу для вашего будущего: поскольку следующие версии программы InDesign быстро приспособятся к вашим дополнениям, гарантируя доступ к инструментальным средствам, в которых Вы будете нуждаться в течение последующих лет.

Также, Adobe InDesign, включает богатую поддержку создания сценария - любой, кто работает с AppleScript или Visual Basic Microsoft может легко автоматизировать утомительные промышленные и творческие задачи. Для быстрого введения в программу и дизайн, разработчики и проектировщики могут обратиться к Adobe InDesign in Depth: Architecture and Extensibility.

    В традиционных приложениях, дополнения к программе имеют доступ только к явному API. Открытая архитектура API InDesign позволяет дополнениям к программе легко связываться друг с другом.

Оглавление


The page of Alexey Kletsel

Светлое будущее верстки

Toolbox Программы как люди - бывает, встречаешь и не нравится, на подсознательном уровне происходит какое-то неприятие. Таковой, в свое время, была моя встреча с QuarkXPress. Хорошая программа, простая, удобная, мощная, но нет в ней какой-то теплоты и человечности, свойственных для Photoshop и Illustrator. Стал я оглядываться: отжившая свой век Ventura Publisher в исполнении Corel, слишком сложный FrameMaker, наконец PageMaker, "ветеран верстки", как его называют. "Ветеран" когда-то помогал специалистам ручного монтажа пересаживаться за компьютер. Монтажный стол, линейки, гранки - все это имитировал Aldus PageMaker. Adobe купила Aldus со всеми потрохами; среди них был PageMaker. Он уже терял позиции, QuarkXPress подавила "ветерана" в области профессионального издательского рынка на Макинтош - основной платформе в настольных издательских системах (НИС). Adobe попыталась что-то сделать: в PageMaker добавили Photoshop'овские модули, расширенную поддержку PDF, сменили интерфейс, приблизили по стилю работы к другим продуктам Adobe, но ничего не помогало. QuarkXPress хоть и капризен, но проще устроен и гораздо пласичнее, с его помощью значительно легче делать сложную верстку.

Понятно, что Adobe, лидер в области технологий компьютерной графики и допечатных процессов, не могла смириться с такой ситуацией. Она поставила себе целью предложить пользователю законченный технологический процесс на основе собственных разработок.

Чтобы заполнить пробел в линии продуктов для профессиональной подготовки изданий в Web, Adobe приобрела пакет CyberStudio компании GoLive Systems, переименовав его по имени прежнего владельца. На основе Photoshop в компании разработали редактор web-графики ImageReady. Наконец, нужно было представить достойного "компаньона" Photoshop'у, Illustrator'у, PostScript'у и PDF в области допечатной подготовки изданий - на смену PageMaker'у пришла новая программа - InDesign.

В стратегии разработки InDesign'а Adobe пошла новой для нее дорожкой, хорошо протоптанной до этого... Microsoft. Зачем придумывать принципиально новый броузер, когда можно перенять все лучшее у преуспевающего конкурента, добавить своего, развить старое? Adobe не опустилась до подражания QuarkXPress'у, InDesign лишь несколько напоминает его. Гораздо сильнее он похож на Illustrator. Как ImageReady можно назвать Photoshop'ом для Web, так и InDesign я бы назвал Illustrator'ом для верстки. Зная QuarkXPress и Illustrator мне не потребовалось времени на изучение InDesign'а вообще.

Открывая впервые программу сразу бросается в глаза логичность и простота палитр и меню InDesign. Это выгодно отличает InDesign от PageMaker'а, с другой стороны от Illustrator'а InDesign унаследовал перегруженность пользовательского интерфейса палитрами, их не так много, как в Illustrator'е, но и не 2-3, как в Quark'е. Подобно Illustrator'у InDesign требует достаточно мощной видеокарты. На моем Macintosh PowerBook G3 с 4 Mb видеопамяти он заметно тормозил перерисовывая сверстанный разворот газеты iNTERface. Надо сказать, Illustrator 8 на этой же машине работает значительно быстрее. С другой стороны, реализована такая необходимая функция как неограниченное количество уровней отмены и возврата, масштабирование от 5 до 4000%, работа со слоями и ICC-профилями. InDesign отлично справляется с открытием файлового формата QuarkXPress, может использовать горячие клавиши конкурента, а так же любые другие, назначенные пользователем.

Использование шрифтов

О родстве с Illustrator'ом напоминают, так же, проблемы со шрифтами. Программа делит их на три группы. В первую вошли все чисто латинские и несколько русифицированных. Русифицированным шрифтам этой группы InDesign позволяет писать по-русски. Во вторую группу выделены ивритские шрифты. InDesign пока не имеет поддержки написания справа налево, поэтому ивритские шрифты в ней только для красоты. Наконец, в третьей группе находятся все остальные русифицированные шрифты. InDesign рассматривает их как шрифты "второго сорта". Вместо русского языка выходят пробелы и какие-то отдельные символы без всякой связи с набираемым текстом. Таким образом, русский язык и иврит практически недоступны, из-за чего программа теряет для нас всякую практическую ценность.

Многоязычная поддержка

Такая ситуация возникла, возможно, из-за того, что в InDesign'е реализован метод многоязычной поддержки, напоминающий применяемый в Microsoft Word. Программа "знает", на каком языке набран данный текст, и использует словари переносов и прочие установки, предназначенные для языка, на котором этот текст написан. Поскольку про русский разработчики, как обычно, забыли, а об иврите и вообще говорить не приходиться, в InDesign'е нет соответствующей поддержки, и, как следствие, возникают проблемы.

Импорт текста и графики

Тем не менее, выжать из программы кое-что удалось. InDesign импортировал документ Microsoft Word 98 for Macintosh сохранив полностью стили, цвета, шрифты, форматирование, переносы, показав, тем самым, блестящие способности к импорту текстов. Так получилось добиться от него работы со шрифтами "второго сорта". Аналогичным образом сработал фильтр импорта RTF. Импорт графики так же работает безупречно. Для TIFF-изображений программа генерирует эскиз (preview) с указанным пользователем разрешением, вставленные EPS, PDF и Illustrator-файлы, благодаря встроенному интерпретатору PostScript, показываются программой с оригинальной резолюцией. Таким образом Adobe подталкивает к использованию только ее технологий. Кроме того, InDesign позволяет редактировать встроенные в TIFF и EPS-файлы обтравочные контуры.

Однако многие мелкие объекты оформления, созданные в Illustrator'е, неудобно содержать как внедренные файлы или в виде внешней графики. InDesign, подобно другим программам Adobe, поддерживает передачу данных через буфер обмена в формате PostScript. Это означает, что построенные в Illustrator'е объекты можно вставить в InDesign в векторном представлении, как если бы они были нарисованы средствами самого InDesign'а. Таким образом, осуществляется быстрый обмен элементами оформления между Photoshop'ом, Illustrator'ом, InDesign'ом, PageMaker'ом и рядом других программ Adobe. Альтернативой буферу обмена служит простое перетаскивание объектов из среды одной программы в другую. Этот способ лучше тем, что не забивает память, занимая буфер, но разработанный для Макинтош его неудобно применять на Windows, почти все программы которой стремятся занимать полный экран.

Инструменты рисования

Wrap InDesign располагает базовым набором инструментов для создания и редактирования векторной графики. Прямо в среде программы можно создавать кривые Безье, правильные многоугольники и звезды. Существует функция конвертации текста в кривые, она совсем не такая грубая, как в QuarkXPress. По качеству ничем не уступает аналогичной возможности иллюстративных программ.

Функция обтекания текстом (Text Wrap) решена так же в форме векторной линии, отстоящей от контура объекта на некотором расстоянии. Она редактируется пустой стрелкой (Direct Selection Tool) и уголком (Convert Point Direction Tool) точно так же, как и обычные векторные построения.

Палитра Links

Links Paletta Все вставленные файлы InDesign показывает в палитре Links. Так же, как и ее аналог в Illustrator'е, палитра позволяет легко заменять, обновлять, внедрять, искать файлы в верстке, вызывать внешний редактор. Кроме графических файлов палитра Links показывает так же текстовые. InDesign умеет не только импортировать тексты, но и делать ссылку на оригинальные файлы, чего так не хватает в Quark'е и PageMaker'е. Палитра Links позволяет вызывать программу, которая редактирует данный текстовый формат. После редакции и сохранения текстового файла, перейдя в InDesign вы увидите в палитре Links сообщение, что файл был изменен.

Рамочный метод работы с объектами

InDesign, подобно QuarkXPress, использует рамочный (фреймовый) метод работы с объектами. Однако, для вставки текста или графики не нужно предварительно создавать рамку. По окончании операции импорта появляется курсор, с помощью которого можно обозначить (растянуть) прямоугольную область, где будет создана рамка, в которую тут же вставится объект, либо просто ткнуть в левый верхний угол будущей рамки, она будет создана по форме вставленного объекта. Мало того, в InDesign'е есть только один универсальный тип рамок как для текста, так и для графики. Кроме упрощения работы по вставкам различных внешних элементов, новый подход к использованию рамок позволяет с их помощью быстро создавать эскизы верстки до того, как будет решено, какого рода объект: текст или иллюстрация будет вставлен в каждую конкретную рамку.

Рамки можно помещать одна в другую, с помощью пустой стрелки легко изменять форму рамки, применять к ним все типы заливок, включая градиенты. Градиентная заливка применима, так же, к линиям и тексту, даже одновременно к нескольким объектам.

Части большого изображения, выходящие за края рамки и маскируемые ею InDesign не посылает на принтер, чем достигается не только увеличение скорости вывода, но и большая свобода в работе - не нужно тратить время на обрезку невидимых краев картинки.

В Quark'е и PageMaker'е существует ограничение при работе с монтажным столом разворота (pasteboard) не позволяющее разворачивать большие картинки, когда они буквально цепляются за края монтажного стола. В InDesign'е нет и этой проблемы. Непомещающиеся части слишком большого объекта просто скрываются за краями монтажного стола. Размеры невидимой рабочей области за пределами монтажного стола не ограничены.

Работа с цветом

Способ работы с цветом идентичен применяемому в Illustrator'е. В палитре Color можно создать необходимый оттенок и сохранить его простым перетаскиванием в палитре Swatches. Так же, как в Illustrator'е для получения оттенка какого-либо цвета в палитре Color можно тянуть один из движков с нажатой клавишей Shift – все движки будут плавно уходить вслед за курсором. При импорте EPS- и Illustrator-графики, содержащей простые (spot) цвета, они немедленно добавляются в палитру Swatches. На любом этапе можно конвертировать простые цвета в составные и наоборот.

Форматирование текста

Среди всех мощных инструментов управления типографикой в InDesign, одной из самых интересных является функция настраивания разгонки слов внутри строк (spacing). Работая совместно с таблицами переноса и выравнивания, механизм формирования строк может настроить разгон набора с учетом одной или нескольких строк, по выбору верстальщика. При помощи многострочного метода InDesign анализирует плотность заполнения заданного количества строк выше и ниже текущей. Например, перед выполнением перехода на следующую строку InDesign проанализирует ближайшие несколько строк и оценит, как данный переход строки повлияет на них. Если в одной из этих строк переход приведет к нарушению визуального баланса, функция многострочной композиции пересмотрит исходный переход строки и подберет для всех строк оптимальное расстояние между словами.

Межбуквенные интервалы можно настраивать вручную, задавая при этом программе один из двух методов работы: с соблюдением встроенных в шрифт кернинговых пар или с применением так называемого оптического кернинга. Метод оптического кернинга устанавливает для межбуквенных интервалов (даже для символов разных шрифтов или кеглей!) значения, оптимальные для визуального восприятия.

Шаблонные страницы

Одной из самых сильных сторон QuarkXPress всегда была система работы с шаблонными страницами (Master pages). Именно свободное манипулирование на листе объектами, попавшими на него с шаблона позволяло заметно быстрее и проще, чем в PageMaker'е делать в Quark'е сложную верстку. Создатели InDesign'а, реализовав функцию конкурента, пошли дальше. Объект шаблона, измененный на рабочей странице не теряет с ним связь, как в QuarkXPress. Теряется связь только в той характеристике, которая была изменена. Так, если вы переместили на рабочей странице какую-либо надпись, относящуюся к странице-шаблону, а затем перекрасили ее прототип на шаблоне, то передвинутая надпись так же изменит свой цвет.

Pages Paletta К шаблонным страницам Adobe применила подход работы со стилями. Программа дает возможность создавать шаблонные страницы из рабочих путем простого перетаскивания в палитре Pages рабочей страницы в зону шаблонных, при этом, если исходная рабочая страница относилась к какому-либо шаблону, то созданный на ее основе шаблон сохраняет связь с предыдущим. Таким образом, в InDesign'е можно создавать многоступенчатую систему шаблонных страниц, когда одна шаблонная страница строится на основе другой и зависит от нее.

Автоматическая перенастойка макета

Поскольку многие работы выполняются с расчетом на несколько типов носителей информации, в InDesign'е реализована функция автоматической перенастойки макета. В диалоговом окне Layout > Layout Ajustment... вы можете определить, с какими параметрами производить переформатирование страницы (с вертикального листа на горизонтальный, например) и в Page Setup установить новый формат листа. Результат требует некоторой доводки, но в целом функция, безусловно, заслуживает внимания.

Предварительная проверка документа

InDesign предоставляет важную возможность проверки документа на этапе разработки. В окне Preflight показывается информация об отсутствующих шрифтах и разорванных ссылках, так же отображаются используемые в документе цвета, шрифты и страницы, где они применяются, заданные параметры печати. Уникальная опция вывода позволяет генерировать PostScript-файл без информации об устройствах вывода и драйверах, часто являющейся причиной сбоев RIP. Функция Collect for Output Quark'а так же получила свой аналог в InDesign'е.

* * *

Традиционная консервативность издательской области и "сырость" первой версии "убийцы QuarkXPress", думаю, не позволят InDesign быстро занять значительную долю рынка, но мощность и удобство использования программы, модульная архитектура, а так же, что главное, ее беспрецедентная интеграция с другими программами и технологиями Adobe, на мой взгляд, дают ей все шансы вырваться вперед.

Оглавление


Adobe Illustrator 9.0

Adobe Illustrator

Adobe Illustrator - программа, предназначенная для профессиональных художников-иллюстраторов и предоставляющая широкие возможности по созданию выскокачественных изображений для печати и публикации в Web.

Новые особенности

Illustrator 9.0 предоставляет полностью интегрированные инструменты для создания высококачественной векторной и растровой графики для web. Эти инструменты позволяют создавать графические объекты, которые легко редактировать и экспортировать в формат SWF (Flash Shockwave Format) или SVG (scalable vector graphics), а также оптимизировать графические файлы форматов GIF, JPEG и PNG.

Illustrator 9.0 содержит ряд новых возможностей, которые облегчают процесс создания графики для Web. Встроенный режим Pixel Preview позволяет увидеть, как будет выглядеть векторная графика в браузере после преобразования ее в растровую. Кроме того, Illustrator 9.0 тесно интегрирован с другими профессиональными продуктами для Web-дизайна, в том числе с Adobe Photoshop 5.5, Adobe GoLive и Adobe LiveMotion.

Экспорт во Flash и формат SVG

Web-дизайнеры постоянно ищут реальные возможности сделать свои сайты как можно более запоминающимися и эффектными. Использование векторных форматов в Web, таких как Flash и SVG, открывает огромные возможности в этом направлении. Эти форматы позволяют создавать высококачественные работы, в том числе и с художественной точки зрения, помещающиеся в файлах маленького размера, которые быстро загружаются по сети. Это означает, что можно встраивать больше анимации и графику в web-страницы, не опасаясь, что от этого они будут дольше грузиться.

Кратко о Flash:
Flash - это одновременно название программы для создания так называемых Web-анимаций и специального формата файлов. Впервые это было введено в 1996, и за последний год программа сделала огромный шаг вперед благодаря широкому распространению браузеров, поддерживающих эту технологию, однако, одновременно повысились требования к подобным страницам. Flash создает "родные" файлы собственного формата FLA. Macromedia сделала небольшой шаг по пути к открытию этого формата и возможности экспорта в формат SWF (Flash Shockwave Format), позволяющий таким программам, как Illustrator 9.0, также осуществлять экспорт своих файлов во Flash. Однако, Flash (SWF) все еще остается полуоткрытым стандартом, он контролируется компанией Macromedia больше, чем любым комитетом стандартов, таким, например, как World Wide Web Consortium (W3C) или ISO. Плюс к этому, документация по Flash обновляется не часто.

Но, несмотря на все эти недостатки, формат Flash предлагает ряд неоспоримых преимуществ:

  • На основе этого формата дизайнеры могут создавать реалистичные Web-страницы
  • Страницы на Flash и графика скалируемы и могут быть воспроизведены на экране любого размера и на любой платформе, а также они хорошо адаптированы для огромного разнообразия пользовательский интерфейсов.
  • Flash-файлы также могут быть распечатаны с оптимальным качеством (хотя эти файлы не используют ICC-профили для максимально правильной передачи цветов)
О формате SVG:
Формат SVG - наиболее полный, открытый стандарт, разработанный W3C. Рабочая группа, отвечающая за разработку спецификаций, состоит из большого числа представителей ведущих производителей ПО в этой области, в том числе Apple, Autodesk, BitFlash, Corel, Hewlett Packard, IBM, ILOG, INSO, Macromedia, Microsoft, Netscape, OASIS, OpenText, Quark, RAL (CCLRC), Sun, Visio, Xerox и представителей самого W3C.

Стандарт SVG также предоставляет дизайнерам ряд преимуществ. Во-первых, в отличие от формата Flash (SWF), SVG пишется на основе открытых стандартов XML (Extensible Markup Language) и CSS (Cascading Style Sheets). Таким образом, SVG-страницы органично интегрируются с базами данных, которые также построены на этих стандартах.

Используя XML, легче манипулировать графическими объектами: вы можете сохранить различные изображения в базе данных и динамически строить web-сраницы, разные для разных платформ, приложений, персональных настроек и других критериев. Например, web-дизайнер может создать кнопку с одним только текстом. Локализованные текстовые строки хранятся в базе данных, и кнопки создаются динамически, в зависимости от того, какие языковые настройки установлены у конечного пользователя.

Использование стандартов CSS означает, что проще построить web-сайт и управлять графикой и другими элементами, изменяя только лишь определения стилей. SVG-файлы могут быть самостоятельными, содержащими графику или могут появляться внутри XHTML или любой другой XML-страницы. SVG также поддерживает элементы интерактивности (например, при наведении "мыши" на объект), кроме того, некоторые реалистичные возможности анимации являются составной частью языка SVG. Чтобы упрочить позиции стандарта SVG в среде Web, консорциум W3C сделал его совместимым с DOM1, DOM2, CSS, XML, XPointer, XSLT, XSL, SMIL, HTML, XHTML, а также с прочими стандартными технологиями (ICC, URI, UNICODE, sRGB, ECMA Script/JavaScript и Java).

Кроме вышеописанных преимуществ на уровне данных, SVG-файлы, как правило, имеют довольно маленькие размеры, что самым положительным образом отражается на времени загрузки. Также они обеспечивают высококачественный вывод на печать в любом выбранном масштабе, поддержку различных видов заливок, градиентов и фильтров, которые могут быть анимированы и применены как к растровым изображениям, так и к SVG (vector) формату. Кроме того, они поддерживает возможность полнотекстового поиска. Когда Adobe Illustrator 9.0 осуществляет экспорт в SVG-файлы, то информация из шрифтов Type 1 и TrueType, используемая в документе, может быть выделена. Это позволяет программам для просмотра SVG, которые поддерживают это подмножество шрифтов, правильно передать информацию, даже если она введена при помощи шрифтов Type 1.

Как Illustrator поддерживает вывод в форматы Flash (SWF) и SVG

При экспорте графики из Illustrator'a в формат Flash (SWF) пользователь имеет возможность выбрать несколько вариантов экспорта: экспортировать файл в один SWF-файл, экспортировать каждый слой в отдельный фрейм внутри SWF-файла или экспортировать каждый слой в отдельные SWF-файлы. Экспорт слоев в отдельные фреймы - это самый быстрый и простой путь для создания анимаций во Flash. Пользователь может даже задать темп анимации в процессе экспорта. Плюс есть возможность сделать так, чтобы Illustrator автоматически преобразовывал объекты в символы для использования во Flash 4.0.

Во время подготовки к выводу в формат SVG пользователь может определить процедуру JavaScript для объекта при помощи специальной интерактивной палитры и впоследствии экспортировать все в файл. Например, можно связать запуск и выполнение скрипта с действиями "мыши", что придаст web-странице некую интерактивность. Вместе с Illustrator'ом также устанавливается специальная свободно распространяемая программа для просмотра SVG. Для получения дополнительной информации обращайтесь на http://www.adobe.com/svg.

Окно Save for Web

В то время как векторные форматы обладают неоспоримыми преимуществами (маленькие файлы и быстрая загрузка по сети), растровые форматы (такие, как GIF, JPEG и PNG) продолжают господствовать в Internet. Даже несмотря на то, что чаша весов все же сдвинулась с мертвой точки благодаря сайтам, активно использующим Flash и SVG, растровые форматы продолжают играть важную роль в разработке графики. Вот почему Adobe Illustrator 9.0 содержит всеобъемлющие возможности управления процессами оптимизации этого вида графических изображений: помогает в поиске копромисса между качеством изображения и размером файла и гарантирует, что графика будет нормально выглядеть в web-браузере.

Illustrator 9.0 предоставляет полный контроль над всеми этими операциями посредством специального диалогового окна Save For Web ( File > Save For Web). Это окно выглядит и работает точно так же, как аналогичное окно в Adobe Photoshop 5.5, то есть все, что вы умеете делать в одной программе, вы с успехом можете делать и в другой (любимый принцип компании Adobe).

Мы не будем здесь подробно останавливаться на том, что и как можно сделать, используя это окно, ибо все это уже описывалось в статье про Adobe Photoshop 5.5

Режим Pixel Preview

Часто при разработке web-графики и web-страниц может оказаться намного эффективнее работать в векторном формате, однако это вызывает другие проблемы. Например, в том случае, когда необходимо, чтобы не зависящая от разрешения векторная графика выглядела также и после растеризации в web-браузере (а кто бы захотел, чтобы его работа, на которую были потрачены несколько часов жизни, выглядела кое-как, да еще и лежала у всех на виду во всемирной паутине). Illustrator 9.0 облегчает эту задачу при помощи нового режима просмотра Pixel Preview. Прежде чем экспортировать изображение в растровый формат для web, откройте его в любом браузере, посмотрите, как оно выглядит, вернитесь в Illustrator и внесите необходимые изменения.

Web-safe RGB Color Workflow

Illustrator 9.0 поддерживает работу в палитре так называемых безопасных web-цветов.

Он имеет два запускающих файла - один для рабочего пространства в режиме RGB и один для работы в режиме CMYK. Пользователю достаточно просто выбрать опцию RGB в диалоговом окне New Document (File > New), чтобы по умолчанию установить Illustrator в режим RGB и открыть установки для RGB (кисти, образцы, градиенты, шаблоны и стили). Если последнее выделение на палитре Color было в режиме CMYK, то палитра по-прежнему будет выводиться для CMYK. Однако, Illustrator будет преобразовывать все выбранные цвета в RGB, что называется, "на лету" (можно переключить и палитру Color в режим RGB, выбрав соответствующую команду в меню этой палитры).

Если пользователь готовит изображения как для печати, так и для Интернет, то можно по умолчанию установить режим CMYK, и затем индивидуально для нужных документов преобразовать цветовой режим в RGB (File > Document Color Mode > RGB Color).

Палитра Web-safe Swatches существует в Illustrator'е начиная с 7-ой версии. Однако теперь можно также настроить палитру Color на работу в режиме "безопасных web-цветов", выбирая в ее меню пункт Web-Safe RGB. Тогда только такие цвета будут появляться на цветовой панели внизу палитры, и для выбранных цветов будут сразу выводиться значения в шестнадцатеричной системе счисления. Палитра Info также будет показывать значения цветов в шестнадцатеричной системе.

Команда Release To Layers

Illustrator 9.0 подходит также и для создания анимированной web-графики. При помощи команды Release To Layers можно переместить все объекты с одного слоя на индивидуальные слои и экспортировать их в индивидуальные фреймы во Flash-файле или для анимации при помощи других программ (например, Adobe Photoshop 5.5).

Контролируя то, как объекты появляются на слоях, пользователь может определять, как они будут появляться в анимации - как ряд независимых объектов, которые последовательно появляются или исчезают или как ряд, который строится из одного единственного объекта для создания оригинальной работы.

Создание теней и свечений

Illustrator 9.0 вводит новые возможности для создания прозрачности. Можно, например, применить эффект тени или свечения к web-графике и впоследствии редактировать. При этом весь процесс займет всего несколько минут. Настройки тени включают установки для значений смещения по оси X и Y, яркости, размытия, цвета. Настройки свечения позволяют определить, с какой стороны от объекта должно появляться свечение - с внешней (outer glows) или с внутренней (inner glows). Все эти тени и свечения поддерживают свойство прозрачности. И даже после применения этих эффектов можно свободно редактировать основной слой (изменять форму объекта, текст и т.д.).

Формы

Новые возможности "живых" форм в Illustrator 9.0 представляют другой яркий пример того, как "живые" объекты и эффекты слоев поддерживают процесс создания графики для Web. При помощи этих возможностей можно привязать прямоугольник, прямоугольник со скругленными углами или эллипс к выбранному тексту или другому объекту, задавая динамические связи между ними. Создавая форму, вы определяете, будет ли ее размер абсолютным или относительным. Форма с относительными размерами будет автоматически увеличиваться или уменьшаться, приспосабливаясь к изменениям, произведенным в другом объекте. Например, можно привязать форму к тексту для создания кнопки для Web. Когда изменяется текст, соответствующим образом изменятся и размер формы.

Интеграция с другими продуктами Adobe

Illustrator 9.0 тесно интегрирован со всем набором средств компании Adobe, в том числе и с Adobe Photoshop, Adobe LiveMotion и Adobe GoLive. Illustrator 9.0 и Photoshop 5.5 имеют одинаковые подходы к управлению процессом оптимизации графики для Web. То же касается и других стандартных возможностей Adobe: инструменты, палитры и элементы интерфейса - все они идентичны.

Свобода творчества

Illustrator 9.0 стирает физические барьеры между тем, что вы можете себе вообразить и тем, что вы можете нарисовать на экране, предоставляя неограниченные возможности для быстрой разработки "бестелесных, прозрачных" субстанций, размытых объектов, мягких теней и других реалистичных эффектов.

Прозрачность

Новые возможности прозрачности в Illustrator 9.0 являются на сегодняшний день наиболее гибкими, многогранными и предоставляющими наиболее полный контроль над объектами среди всех программ векторной графики.

При помощи Illustrator 9.0, можно задать прозрачность для любого слоя, группы или объекта, в том числе и для растровых рисунков и заливок. Установить уровень прозрачности очень легко - достаточно выделить группу объектов и настроить требуемый уровень прозрачности в новой палитре Transparency.

Чтобы задать уровень прозрачности целому слою, нужно просто щелкнуть по кружочку справа от названия слоя в палитре Layers и изменить свойство прозрачности в палитре Transparency. Эти установки будут касаться всего слоя как единого объекта - любая графика на слое, даже если она добавляется позже, немедленно приобретает тот же уровень прозрачности, что и весь слой.

По умолчанию установки прозрачности затрагивают весь объект в целом. Однако, можно воспользоваться возможностями палитры Appearance, чтобы задать прозрачность только лишь заливке или обводке объекта. Кроме того, опция Knockout Group на палитре Transparency управляет взаимодействием различных уровней прозрачности для различных объектов в группе:

* когда опция выбрана, верхний объект в группе вытесняет те, что находятся ниже

* когда опция отключена, все нижние объекты видны сквозь верхний наряду со всеми объектами, расположенными ниже заданной группы

Прозрачность для текстовых объектов

В Illustrator 9.0 так же легко задать свойство прозрачности для текста, как и для любого другого объекта. Можно варьировать настройки прозрачности для каждой буквы, для каждого слова или абзаца текстового блока, а также создавать общий эффект, применяя индивидуальные настройки к отдельным буквам и затем применяя их к целому текстовому блоку. При этом текст остается полностью редактируемым (можно изменить шрифт, проверить орфографию, изменить фразу и т.д.)

Поддержка режима смешивания [image] Режим смешивания помогает изменять то, как цвет, примененный к выбранному объекту или группе, взаимодействует (смешивается) с цветами нижележащих объектов. Illustrator 9.0 предоставляет все самые основные режимы смешивания из Photoshop'а, включая Multiply, Screen, Overlay, Soft Light, Hard Light, Color Dodge, Color Burn, Darken, Lighten, Difference, Exclusion, Hue, Saturation, Color и Luminosity. Комбинируя режимы смешивания цветов с установками прозрачности, можно создать удивительные спецэффекты.

Поддержка свойства прозрачности в файлах Photoshop

Illustrator полностью поддерживает существующие свойства прозрачности в файлах формата PSD (Photoshop). При открытии такого файла в Illustrator'е, можно видеть все оригинальные слои и маски как объекты Illustrator'а с масками и с полной поддержкой прозрачности. Далее все установки можно редактировать прямо в Illustrator'е.

Кроме того, прозрачность автоматически сохраняется при экспорте файлов в формат PSD (фактически, это единственный путь для экспорта файлов с сохранением прозрачности для последующего использования).

Прозрачость и слой-маска

В Illustrator'е 9.0, можно добиться необычных эффектов, создавая непрозрачные маски. Создать маску можно путем наслаивания двух или нескольких объектов один поверх другого, выбирая их и отмечая опцию Mask на палитре Transparency.Самый верхний объект становится маской, и его значение в режиме оттенков серого (яркость) оказывает влияние на то, какая именно область нижележащего объекта будет видна. Например, если сделать маску из полностью белого объекта, то маскированные объекты будут полностью видимыми. Если маска была черной, то нижележащие объекты будут вообще не видны в той части, где маска их перекрывает. При помощи черно-белого градиента можно сделать так, что маскированные объекты будут появляться там, где начинается белая область и постепенно исчезать там, где градиент становится черным. Из любого объекта можно сделать непрозрачную маску. Используя различные шаблоны и градиенты, а также применяя градиенты для непрозрачных масок, можно добиться очень необычных эффектов. Текст также можно сохранить как непрозрачную маску, что помогает быстро создавать нестандартные текстовые эффекты (при этом текст остается редактируемым).

Непрозрачные маски просты в использовании. Палитра Transparency выводит уменьшенные картинки оригинальных изображений и маску рядом со значком связи. Если щелкнуть по уменьшенной картинке маски, можно двигать или редактировать ее независимо от нижележащих слоев. Можно даже временно отключать маску, чтобы преобразовать ее компоненты. Если отметить опцию Invert Mask на палитре Transparency, то нижележащие объекты вырезаются до маскирующего объекта, а черно-белый эффект инвертируется. Черные области становятся прозрачными, а белые - наоборот непрозрачными. Ну и, наконец, можно отменить любую маску, отключив опцию Mask на палитре Transparency.

Создание слоя-маски осуществляется в несколько этапов. Сначала надо удостовериться, что тот контур, который предполагается использовать как маску, находится на вершине слоя. Затем нажать кнопку Make/Release Clipping Mask на палитре Layers. Все, что оказывается внутри формы, остается видимым, все остальное оказывается скрытым. Любые объекты, которые впоследствии добавляются на слой, также обрезаются по маске. Нажатие на кнопку Clicking the Make/Release Clipping Mask автоматически отменяет маску.

Размытие

Live feathering смягчает переход между объектами, расположенными на переднем и заднем планах. Предварительный просмотр результатов изменения радиуса размытия позволяет пользоваться этой возможностью. И даже после применения этого эффекта нижележащие объекты остаются редактируемыми. Также легко можно убрать этот эффект, не перерисовывая все заново.

Экспорт текста в формат PSD

Усилена интеграция между Illustrator'ом и Photoshop'ом. Теперь можно создать текст в Illustrator'е, экспортировать его в Photoshop, и он останется редактируемым. Если текст расположен на отдельном слое в Illustrator'е, то и в Photoshop'е он будет располагаться на отдельном текстовом редактируемом слое.

Эффекты объекта и слоя

Одной из новых интересных особенностей Illustrator 9.0 являются эффекты объектов и слоев. Теперь можно трансформировать, применить фильтр, исказить любой объект, группу объектов или слой, и все это будет оформлено как серия "живых" эффектов. Что делает эти возможности еще более передовыми и новаторскими, так это то, что эти эффекты влияют только на выбранные объекты, но не сами на себя. Это означает, что можно редактировать нижележащие объекты или любой этап в серии эффектов, которые были применены.

Графические стили

Illustrator 9.0 вводит новое понятие графического стиля. В Illustrator 9.0 появилась возможность изменять вид объекта, не меняя самого объекта. Одним из основных способов изменения объектов, как правило, является применение к ним различных эффектов. Любые комбинации эффектов, заливок, обводок и различных степеней прозрачности могут составить внешний вид объекта. Когда пользователь применяет эти свойства к выбранному объекту, все они попадают в специальный список на новой палитре Appearances и могут быть реорганизованы, удалены, отредактированы и т.д. Что особенно важно: полученный вид объекта (appearance) может быть сохранен для последующего использования как именованный графический стиль в новой палитре Styles.

Графические стили могут быть применены к любым выделенным объектам, в том числе контурам, текстам, рисункам и даже группам, составленным из нескольких слоев. Так как стили изменяют только внешний вид объекта, а не саму сущностью объекта, то последний остается свободно редактируемым.

Illustrator предлагает пользователям ряд предустановленных графических стилей. Чтобы просмотреть композицию предустановленного стиля, надо щелкнуть на его обозначении в палитре Styles и просмотреть атрибуты, представленные в специальном списке на палитре Appearance. Чтобы создать новый стиль, можно начать работать с одним из существующих стилей и внести изменения или провести различные манипуляции с объектом и затем, пока объект все еще выделен, выбрать опцию New Style из меню палитры Styles. Переименовать, сделать копию, объединить или удалить стили очень просто. Например, можно использовать инструмент "пипетка" (eyedropper), чтобы применить стиль одного объекта к другому объекту или стилю.

Графические стили реорганизовываются в зависимости от того, как вы сохраняете документ. Можно, например, определить набор графических стилей для использования в специальном приложении или в особой области web-сайта. Можно также сохранить эти стили в отдельном документе Illustrator'а для последующего использования его в качестве библиотеки стилей (подобно тому, как сохраняются библиотеки кистей).

Управление слоями

Некоторые изображения содержат множество слоев, управлять которыми подчас бывает очень сложно. Illustrator 9.0 помогает упростить процесс организации слоев, компонуя связанные слои. Любой слой может содержать подслои, которые в свою очередь так же могут содержать слои.

Возможность просмотра содержимого слоя

Палитра Layers в Illustrator 9.0 теперь может показывать уменьшенные изображения объектов, которые расположены на каждом слое, что позволяет быстро ориентироваться среди слоев, не перебирая их все по очереди в поисках нужного слоя. Если открыть в этой палитре слой, то появятся уже отдельные уменьшенные изображения для каждого объекта или группы, расположенного на слое. Плюс к этому можно открыть каждую группу, чтобы увидеть объекты, которые ее составляют. Пользуясь этой палитрой можно переименовать, продублировать, объединить или реорганизовать любой слой, подслой, группу или объект.

Кроме того, Illustrator предоставляет больше возможностей для контроля за той информацией, которая выводится в палитре Layers. Можно показать все слои, объекты и группы или только слои верхнего уровня. Можно установить минимальный размер строки, тогда за один раз в одном окне можно будет увидеть больше слоев, или, наоборот, увеличить размер строки, тогда лучше будут видны уменьшенные изображения. В общем, вариантов настройки палитры достаточно для того, чтобы удовлетворить даже самых взыскательных пользователей.

Интегрированная поддержка Adobe PDF

Теперь файлы Illustrator'a содержат в своем ядре Adobe PDF, что значительно упрощает процесс подготовки компактного файла PDF для публикации. Эти изменения в файловом формате довольно прозрачны и незаметны для неопытного пользователя, так как расширения для файлов Illustrator 9.0 по-прежнему ".ai", и в этой новой редакции можно свободно открывать и сохранять файлы в форматах предыдущих версий (вплоть до версии 1.0). Однако, с другой стороны, можно не только экспортировать в этот формат, но и работать с PDF-файлами, сохраненными через Illustrator, без потери специфических особенностей, таких как шрифты, заливки, вертикальные текстовые блоки. В распоряжении пользователя в этом случае оказывается целый набор установок компрессии, внедренных шрифтов, управление цветами, возможность защиты файла от несанкционированного доступа и другие возможности, доступные при быстрой подготовке PDF-файлов для высококачественной печати. Будущие версии Acrobat Reader смогут открывать, просматривать и печатать файлы Illustrator'а, так как они основаны на формате PDF.

Управление цветами

Adobe Illustrator 9.0 поддерживает аппаратно-независимую технологию управления цветом, основанную на Adobe Color Engine (ACE). В Illustrator 9.0 можно определить цветовое пространство RGB или CMYK для документа. Объекты в цветовых режимах RGB и CMYK не могут сосуществовать в одном и том же документе во избежание неожиданных цветовых результатов при печати файлов.

Можно также добавить ICC профиль, чтобы определить цветовое пространство конкретного документа, определить цветовое пространство устройства вывода и задать, как Illustrator будет импортировать графику: будет ли он ориентироваться на какое-то особое цветовое пространство или нет. В качестве альтернативы можно выбрать опцию, которая предпишет Illustrator 9.0 руководствоваться теми же настройками, что использовались в Illustrator 8.0.

Illustrator 9.0 также поддерживает гибкую настройку цветов, видимых на экране. Proof Setup позволяет определить, как цветовая гамма должна отображаться на экране (нужно переназначать цвета или конвертировать). Proof Colors затем имитирует цвета на экране в соответствии с заданными установками.

Упрощение путей (Simplify Path)

Возможность упрощения путей нужна для удаления ненужных узловых точек с выбранной траектории без деформации контура (Object > Path > Simplify). Эта функция позволяет сгладить путь и уменьшить размер файла. Пользователь может задать точность кривой и предельный угол, чтобы определить, как должен соотносится новый путь со старым. Опция предварительного просмотра позволяет увидеть результат преобразования еще до того, как будет закрыто соответствующее диалоговое окно. Опция просмотра оригинального пути служит для того, чтобы выявить отличия.

Инструмент Lasso

Illustrator 9.0 предлагает два инструмента для выделения сложных неправильных областей изображения: lasso и direct-select lasso. Инструмент lasso используется для выделения целый объектов или путей в областях неправильной формы, а инструмент direct-select lasso - для выделения отдельных частей объекта.

Расширенная поддержка других форматов файлов.

Adobe Illustrator 9.0 может открыть любой файл Adobe Illustrator (вплоть до версии 1.0). Кроме того, Illustrator 9.0 может открыть и вставить в изображение файлы форматов EPS, PDF (одна страница за раз), SVG и Photoshop 2.5, 3.0, 4.0, 5.0 и 5.5, а также Macromedia FreeHand 5.0, 5.5, 7.0, 8.0, CorelDRAW 5.0, 6.0, 7.0, 8.0, Amiga IFF, BMP, CGM 1/2/3, DWG, DXF, EMF/WMF, GIF, JPEG, PNG, KODAK ® Photo CD ™ , PICT, PCX, PXR, TGA и TIFF.

Adobe Illustrator 9.0 сохраняет файлы в форматах Adobe Illustrator (AI), EPS и PDF, а также экспортирует графику в форматы Flash (SWF), SVG, GIF, JPEG, PNG, PSD (со всеми слоями), Amiga IFF, BMP, CGM 1, EMF/WMF, DWG, DXF, PICT, PCX, PXR, TGA и TIFF. Существует возможность просто "перетащить" графику из Illustrator в другие программы Adobe, такие как InDesign, Photoshop, или PageMaker или в приложения других производителей, например, в Microsoft Word. Adobe Illustrator 9.0 может импортировать текст из следующих форматов: ASCII, Microsoft RTF (Microsoft Office 97, 98, и 2000) и Microsoft Word (Office 97, 98 и 2000), а также импортировать и экспортировать текстовые файлы (TXT).

Системные требования

Power Macintosh

  • любой процессор PowerPC®
  • Операционная система Mac OS 8.5, 8.6 или 9.0
  • 64 Mб оперативной памяти
  • 105 Mб свободного дискового пространства
  • привод CD-ROM
  • разрешение монитора 800x600
  • если используется принтер Adobe PostScript® printers: Adobe PostScript Level или более поздний
Windows 98/Windows NT 4.0/Windows 2000
  • Процессор Intel® Pentium® или более быстрый
  • Microsoft® Windows® 98, Windows NT® 4.0, Windows 2000
  • 64 Mб оперативной памяти
  • 105 Mб свободного дискового пространства
  • привод CD-ROM
  • видео-карта с поддержкой разрешения монитора 800x600 или более высокого
  • если используется принтер Adobe PostScript® printers: Adobe PostScript Level или более поздний


Creature House Expression 2

Какие редакторы обычно подразумевают, когда говорят о серьезных графических пакетах? Из растровых – это конечно же Adobe Photoshop, из векторных – CorelDRAW и Illustrator. Они прекрасно себя зарекомендовали среди профессионалов, а их последние версии обладают таким набором инструментов, который позволяет выполнять графические работы любой степени сложности. Однако в последнее время все больше начинают заявлять о себе «альтернативные» редакторы, построенные на несколько иных принципах. Эти программы, несмотря на свой «детский» возраст, обладают внушительным спектром возможностей, которые именно в силу иных принципов, заложенных в эти разработки, просто недоступны «мэтрам». Второе преимущество «молодежи» – они не обременены наследием от предыдущих версий, и поэтому буквально «летают» даже на относительно слабых компьютерах.

Кроме компании Xara, создавшей Xara X, довольно мощный продукт с размером дистрибутива всего 6,5 Мбайт, к этой же плеяде молодых, но многообещающих можно отнести гонконгскую компанию Creature House. Несколько лет назад она разработала Expression – программу, предназначенную главным образом для тех, кто любит и умеет рисовать руками. И вот недавно компания объявила о выпуске второй версии Expression с расширенным набором возможностей, имеющей поэтому все шансы стать более распространенной, нежели первенец. Этот редактор в своем роде уникален, поскольку в «смешном» объеме 6 Мбайт умещается замечательный мастер-на-все-руки. Конечно, равняться с такими монстрами, как CorelDRAW или Adobe Illustrator ему не под силу, зато он может похвастать такими возможностями, которых в них нет.

Эффект полупрозрачной тени и выдавленности

Главный «конек» Expression 2 – работа с векторными объектами как с растровыми изображениями, более привычными для художников. Программа построена на применении окантовки («stroke» в терминологии Expression) для создания уникальных эффектов (например, изменение формы объекта согласно некоторой направляющей). В редакторе существуют мощные инструменты по коррекции самой формы кисти вдоль всего контура (причем в качестве кисти может быть растровая картинка), он поддерживает прозрачность, и все это при достаточно быстрой работе со сложными объектами на любых компьютерах. Приятной неожиданностью стало и автосохранение, происходящее в фоновом режиме (его прелесть я ощутил на собственном опыте). Итак, давайте познакомимся с программой поближе.

Векторные возможности

По своим векторным возможностям программа очень похожа на Illustrator (Make Compound Object, Make Clipper, Text on Path, логические операции с объектами, работа со слоями). Заливка в Expression может быть однородной, градиентной и типа PostScript. Как и в Illustrator 9, объекты могут иметь либо растушеванный край, создавая эффект полупрозрачной тени, либо наоборот, эффект выдавленности. Последний эффект дает очень хорошие результаты с буквами, делая их по-настоящему объемными. Для быстрого копирования свойств объекта, а также определения цвета в любом его месте предусмотрен Color Dropper, а с помощью Gradient Vector задаются разные углы градиентной заливки.

В Expression есть все, что необходимо для эффективной работы мастера. Небольшой набор инструментов на палитре Tools обманчив: под каждым из них прячется набор дополнительных инструментов, расширяющих возможности основного. Самый уникальный инструмент программы – кисть (Brush), которой можно рисовать в свободной манере, создавая векторный рисунок при помощи привычного художнику набора функций кисти. Для определения формы следа, оставляемого кистью, служит отдельный инструмент Stroke Def Box.

Небольшой набор инструментов в палитре Tools обманчив

В редакторе предусмотрен набор геометрических примитивов (овал, прямоугольник, линия, а также многоугольник и B-spline – когда сегмент кривой строится на основании взаимного расположения трех опорных точек). В случае необходимости траекторию движения кисти можно всегда подправить при помощи стандартных приемов (редактирование узелков и контрольных точек, изменение типа сглаживания – Symmetrical, Smooth, Free, имеется даже экзотический Angle Locked, когда при редактировании сохраняется угол между направляющими). Различные стили рисования (Sausage, Ribbon, Elliptical) предоставляют художнику дополнительную гибкость в работе, облегчая получение требуемого результата.

Использование абриса

Ну а теперь перейдем к «коньку» программы – возможностям при работе с окантовкой. Все они построены на применении в качестве формы следа от кисти (stroke) различных фигур. В зависимости от установок, эти фигуры могут либо повторяться по всему пути, пройденному кистью (Make repeating), либо, деформируясь, растягиваться вдоль него (Do not repeat). При необходимости, можно предохранять форму некоторых элементов рисунка от искажений (anchoring), привязывая их к начальной или конечной точкам пути. Сама форма кисти задается при помощи специального инструмента Def Stroke, причем существующий в программе арсенал средств для создания и последующего ее редактирования дает неограниченный простор фантазии художников. Для особо сложных случаев предусмотрена панель Variable width, обеспечивающая регулировку толщины мазка вдоль пройденного пути. Результаты, получаемые с помощью программы, очень выразительны и будут по достоинству оценены настоящими художниками – особенно кисти, рисующие изображениями, которые, будучи полупрозрачными, дают имитацию акварели (они расположены в папке Water).

Работа с растровыми изображениями

Самый уникальный инструмент программы – кисть (Brush)

Expression 2 имеет уникальные для векторных редакторов возможности по созданию и редактированию растровых изображений – таким образом, программа представляет собой эдакий симбиоз редакторов обоих направлений. Например, в ней можно превратить любой участок векторного изображения в картинку и продолжить работу с ним, как с обычным растровым изображением. Для этого предназначен инструмент Bitmap Pen, который имеет два режима: обычного рисования на полотне (Draw on Image) и создания мягких масок прозрачности (Draw on Mask). Сближает Expression с Photoshop полная идентичность параметров кисти: размер, жесткость (hardness), spacing и прозрачность. Кроме того, в Expression можно выбирать разную фактуру бумаги и, таким образом, получать изображения, практически неотличимые от обычных, рисованных на бумаге.

Изображение (кстати, не только растровое, но и векторное) можно «морфировать» – т. е. на нем появляется сетка из кривых, в местах пересечения которых находятся управляющие точки. Их можно смещать в том или ином направлении, вращать, масштабировать определенные области изображения, видоизменяя весь рисунок. Кроме того, если вам понадобится подрисовать картинку, то накладываемые кистью мазки будут искажаться согласно этим «силовым линиям» – в общем, простор для вашей фантазии огромен. При необходимости лишнее можно либо стереть ластиком (Eraser mode), либо скрыть за маской прозрачности (если выбран режим Draw on Mask).

Но этим способности шестимегабайтного редактора не исчерпываются.

Анимация

Техника рисования, используемая в Expression (Skeleton Stroke), прекрасно подходит для создания анимации. Допустим, вы нарисовали рыбу и вам требуется воссоздать ее движение в воде или показать, что она сердится и т. п. Что делают в таком случае обычно? Рисуют всю рыбу заново, изменяя лишь некоторые ее части. В отличие от этого метода, техника Skeleton Stroke позволяет добиться похожего результата простым воздействием на «остов» рыбы (изображение любого объекта формируется следом кисти определенной формы – в нашем случае, с формой рыбы – проведенной в определенном направлении). Поэтому, например, чтобы повернуть хвост вверх, нужно изменить путь кисти, приходящийся на область хвоста – т. е. потянуть вверх узелок, находящийся в хвосте рыбы – и программа автоматически изогнет ее спину и живот. Не правда ли, оригинальное решение?

Техника Sceletoh Stroke позволяет добиваться удивительных результатов

Учитывая все возрастающую популярность векторной анимации в Интернете, вполне логичным является решение разработчиков включить в Expression инструменты для создания анимированных роликов, ну и, разумеется, сохранение их в формате Flash. Для удобства управления различными фазами движения в программе предусмотрен известный по Macromedia Flash режим Onion Skin. Более того, в программе существует свой собственный набор команд (правда, довольно ограниченный), которым можно пользоваться для придания анимации интерактивности.

Выводы

Несмотря на свой довольно юный возраст, Expression 2 выглядит вполне зрело. Причем это касается как творческой стороны вопроса, так и сугубо технической: программа может работать с полиграфическими цветами CMYK, поддерживает экспорт в формате Encapsulated PostScript (EPS), что позволяет использовать ее без каких-либо ограничений в допечатной подготовке. При этом нужно иметь в виду, что наибольший интерес редактор будет представлять для художников, которым широта творческих возможностей важнее сухости работы через диалоговые окна и многочисленные настройки.

Creature House Expression 2

Рейтинг: ****1/2
Системные требования:
Macintosh: PowerPC, MacOS 8.0,
64 Mбайт оперативной памяти,
64 Mбайт свободного места на жестком диске.
Windows: Pentium от 166 MГц,
64 Mбайт оперативной памяти,
64 Mбайт свободного места на жестком диске; Windows 95/98/Me, NT4/2000.
Заключение: программа представляет собой уникальный симбиоз растрового (наложение мягких масок, полупрозрачные кисти) и векторного (работа с кривыми) редакторов, хотя ей и не хватает некоторых специфических возможностей профессиональных графических приложений.


Untitled Document

Adobe Illustrator 10

Типичный представитель векторных пакетов, ориентированных на создание художественных иллюстраций. Базируется строго на PostScript, что влечет как преимущества, так и ограничения. Прежде всего, в Illlustrator просто невозможно не получить корректный PostScript код. А это важно, так как PostScript очень широко применяется в полиграфии. Illustrator хорошо интегрируется с другими продуктами Adobe: Photoshop, PageMaker, InDesign. Его файловый формат практически идеален для обмена с пользователями MAC. Поддерживается чтение и запись PDF файлов. Поддерживает печать с цветоделением. Очень высокое качество преобразования RGB/CMYK. Немаловажно и то, что данный продукт официально локализован.

Вместе с тем, разработчики Illustrator не стали эмулировать функции, которые не поддерживаются спецификацией PostScript, например, прозрачность заливок. Есть проблемы с русскими TrueType шрифтами. Вообще работа с русскими надписями без установки Adobe Type Manager (ATM) практически невозможна, а это влечет множество проблем, особенно в NT и Windows 2000, которые с ATM не дружат. Кроме того, Illustrator работает очень медленно и имеет самые высокие системные требования среди всех векторных пакетов для Windows. Поддерживается работа только с одностраничными изображениями формата не более чем A1 (594Y 840 миллиметров). Есть трудности с вводом русского (и не только русского) текста: Illustrator путает кодовые страницы в UNICODE шрифтах.

Кроме того, работа в Illustrator чрезвычайно трудоемка. Например, чтобы нарисовать радугу в Corel Draw или FreeHand надо всего лишь 5 щелчков мышью, а в Illustrator почти 70. Затраты времени будут еще больше, так как последний работает по крайней мере в 5 раз медленнее. Так что во многих странах Illustrator заметно сдал позиции. Точнее, на первых ролях данный продукт лишь в США и России. В целом программа не для рядового домашнего пользователя. Но для тех, кто занимается профессионально полиграфией, выбор состоит лишь между Illustrator, Canvas и FreeHand.

Adobe Illustrator 10 (текст Романа Митрохина) : "Существенно видоизменен интерфейс, конечно в пределах стиля Adobe - обновлены палитры, основная панель инструментов стала плоской и цветной. Инструменты и команды в меню скомпонованы несколько иначе, например star, ellipse и rectangle теперь в одной группе, в отдельное меню select выделены все соответствующие команды.

Появилось более десятка принципиально новых инструментов и возможностей: magic wand, polar grid, arc segment, slice, twirl, pucker, bloat, scallop, crystallize... список весьма внушителен. Появился набор эффектов warp - аналогичный есть в Photoshop 6. Операции из палитры pathfinder теперь оставляют прооперированные кривульки в неприкосновенности до специальной команды. Появилась палитра и инструментарий для работы с символами - дань flash-аниматорам. Если вы работаете с большим количеством файлов схожего вида - к вашим услугам палитра variables - нечто вроде шаблонов в программах верстки. Вообще возможности нового инструментария впечатляют - традиционно Illustrator был лишен подобных, прошу извинить, извращений, поскольку они слабо вписывались в спецификацию PostScript. Они и сейчас не лучше вписываются, так что если будете рисовать солнечный блик инструментом flare - будьте готовы к экстренному выходу из программы. К сожалению, подобные навороты не лучшим образом сказываются на стабильности. Впрочем - она все еще на высоком уровне. Требования к ресурсам - серьезные, однако если вы комфортно работали с версией 9, десятая скоростью не разочарует.

Резюме: программа на "пять с минусом" - великолепный интерфейс, теперь еще более богатый инструментарий, традиционно качественный вывод результата. Недостатки не существенны и могут быть исправлены одним-двумя сервис-паками. Похоже, в недрах Adobe родился достойный брат Photoshop 6."


За границами страны Photoshop

Существует несколько программ, которые могут выполнять определенные задачи лучше и быстрее, чем рыночный лидер

Не секрет, что подавляющее большинство профессиональных издателей использует пакет Adobe Photoshop. Новые функции Photoshop 5, такие как редактируемый текст, палитра History, поддержка 48- и 64-разрядного цвета, управление цветом, автоматизация и эффекты "живого" слоя только укрепили позицию продукта, как бесспорного лидера в издательской области.

Но конкуренты Photoshop не дремлют. Другие программы удерживают определенную долю рынка благодаря тому, что могут хорошо выполнять некоторые специфические задачи - причем иногда делают это лучше, чем Photoshop. Хотя Photoshop является инструментом, необходимым каждому профессионалу, он не единственный. Мы провели исследование некоторых других приложений, которые дизайнеры используют в своей работе для расширения собственных творческих возможностей и повышения производительности. Чтобы подробнее рассмотреть эти приложения, мы ограничились лишь программами для редактирования растровой графики.

Хотя непосредственное взаимодействие с Photoshop не является обязательным свойством для рассматриваемых программ, весьма желательна совместимость с файловыми форматами Photoshop. Поскольку в файлах Photoshop 5 могут сохраняться новые разнообразные эффекты, а компания Adobe не торопится раскрывать свои карты, найти другие приложения, импортирующие или экспортирующие подобные эффекты, нелегко. Большинство описанных в данном обзоре приложений поддерживают слои Photoshop 3 и в той или иной степени - маски слоев, контуры, множественные альфа-каналы, режимы переходов и цветовые модели.

Начнем мы с четырех полномасштабных растровых редакторов, являющихся прямыми конкурентами Photoshop. (Информация о данных продуктах приводится во врезке "Источники" на стр. 61.)

Corel Photo-Paint

Пакет Photo-Paint 8 (495 долл., Macintosh и Windows) обладает во многом аналогичными функциям Photoshop возможностями. Программа очень хорошо интегрирована с главным продуктом компании - CorelDraw - в комплекте с которым поставляется. В дополнение к Photo-Paint, набор приложений CorelDraw 8 (695 долл.) включает CorelDream 3D и множество готовых иллюстраций, фотографий и шрифтов.

Photo-Paint обладает уникальными инструментами рисования, такими как кисти Symmetry и Orbit, а некоторые его функции, типа непосредственного редактирования прозрачности и градиентов, реализованы в программе более интуитивно, чем в Photoshop. Идеальный для работы в Web пакет Photo-Paint может создавать анимированные файлы GIF и содержит средства для предварительного просмотра параметров сжатия и размеров файлов JPEG и GIF. Функции пакетной обработки, ориентированные на списки файлов, также обладают большей гибкостью, чем палитра Actions пакета Photoshop. Кроме того, Photo-Paint может создавать общие для нескольких изображений палитры и смещать цвета по направлению к определенным оттенкам, например, телесным тонам. Общие палитры особенно полезны при разработке дисков CD-ROM и для дизайна в Web.

Настраиваемые рабочие среды в стиле Corel позволяют располагать инструменты таким образом, чтобы имитировать знакомое рабочее окружение пакета Photoshop. Photo-Paint (а также CorelDraw) может импортировать и экспортировать обычные слои Photoshop, альфа-каналы и некоторые настроечные слои. Однако программа не поддерживает контуры или режимы слоев с переходами Photoshop.

Live Picture

Не обязательно быть особенно нетерпеливым человеком, чтобы заметить все еще недостаточно высокую производительность работы пакета Photoshop. Программа Live Picture 2.6 (349 долл.) разрабатывалась именно с целью опередить Photoshop с точки зрения производительности операций при обработке пикселов. В начале каждого сеанса редактирования в Live Picture карты битов преобразуются в собственный файловый формат IVUE (или изображение сканируется непосредственно в IVUE). Формат IVUE (предшественник формата FlashPix, также разработанного Live Picture) содержит множественные итерации изображения с различными разрешениями, что позволяет пользователю отображать картинку с дискретными коэффициентами масштабирования.

Вместо того, чтобы вносить изменения в оригинальную карту битов, Live Picture отслеживает все операции по редактированию изображений алгоритмически, а затем сохраняет их в пакетном файле (под названием FITS). После завершения редактирования Live Picture строит окончательное изображение, применяя файл FITS к исходному изображению. (Обратите внимание, что, хотя вы и можете просматривать и создавать файлы в режиме CMYK, по-настоящему работать в этом режиме нельзя.)

Такой подход позволяет пакету Live Picture открывать, манипулировать и сохранять результаты работы в почти реальном масштабе времени - незаменимое качество для выполнения больших объемов работ в сжатые сроки. Хотя Live Picture имеет только один уровень отмены операций, это ограничение можно обойти, создавая отдельный слой для каждого действия - вплоть до мазка кисти - практически без какого-либо замедления работы. Файлы FITS достаточно малы, чтобы их можно было посылать по модему в сервисные бюро или другие места, где их можно применить к исходным изображениям IVUE. Можно также конвертировать один мастер-файл последовательно в несколько различных разрешений без кумулятивного нарастания искажений, что неминуемо при выполнении подобных операций в Photoshop.

Главный "конек" Live Picture - создание больших коллажей: использование кисти для маскирования и клонирования элементов из различных изображений в одну композицию. В то время, как в Photoshop размер кисти ограничен 999 пикселами, кисти Live Picture могут быть любого размера. Сочетание большой кисти с мягким размытием краев позволяет выполнять такие операции, как копирование облака, одним движением мыши - подобные действия в Photoshop могут занять минуты и даже часы вашего рабочего времени. В Live Picture существует еще кисть Distorto, которая довольно полезна для выполнения таких специфических задач, как доведение до блеска улыбки фотомодели или выравнивание краев двух элементов.

Не все идеально и в Live Picture. Платой за молниеносную скорость выполнения операций редактирования является необходимость конвертировать карты битов в IVUE в начале каждого сеанса редактирования, а затем обратного конвертирования в карту битов в конце. Кроме того, разработчики Live Picture рекомендуют выделять для программы объем оперативной памяти, эквивалентный размеру изображения, плюс удвоенное количество памяти - на жестком диске для своппинга.

Live Picture не поддерживает слои Photoshop, поэтому перед переносом файлов в Live Picture все их слои следует слить. Кроме того, в программе нет эквивалентов режимам слоев с переходами Photoshop, за исключением уровня прозрачности. Архитектура фильтров Adobe не поддерживается: фильтры, которые выполняют операции на уровне пикселов, несколько расходятся с идеологией алгоритмического редактирования Live Picture.

Macromedia XRes

В пакете XRes 3.0 (399 долл., Macintosh и Windows) реализован иной подход к обработке больших файлов. XRes имеет два режима работы: непосредственный (Direct) - стандартный подход к редактированию пикселов; и режим XRes, который, подобно Live Picture, откладывает операции, требующие больших вычислений, до того момента, когда вы готовы применить их к файлу с картой битов. В этом режиме редактирование происходит практически в реальном времени, кроме того, снижаются требования к объему оперативной памяти, хотя компания Macromedia рекомендует выделять для хранения временных файлов на диске колоссальный объем в 500 Мбайт.

Режим постобработки XRes обладает интересными достоинствами. К примеру, вы масштабируете изображение, задав для него 10% от первоначального размера, выполняете цветокоррекцию, а затем решаете, что, в действительности, вам нужна картинка размером 20% от исходной. В пакете Photoshop вы либо получите дополнительные искажения после увеличения предварительно уменьшенного изображения, либо будете вынуждены вернуться назад и загрузить оригинал, масштабировать его до 20% от исходного размера и повторно выполнить цветокоррекцию. В XRes вы сможете менять свои решения так часто, как вам это заблагорассудится, до того момента, пока все изменения не будут реально внесены в файл с картой битов.

Своей скоростью XRes частично обязан файловому формату LRG компании Macromedia, который в том, что он хранит отдельно фрагменты изображения с несколькими разрешениями, похож на IVUE пакета Live Picture: обрабатываются только отображаемые в данный момент на экране фрагменты. Хотя это примерно на треть увеличивает размер мастер-файла, такой подход обычно позволяет работать значительно быстрее, чем в Photoshop. Данная технология оказывается предпочтительнее и других вариантов, таких как реализованный в Specular Collages, где используются фрагменты-заменители с низким разрешением, содержащие слишком мало информации для высококачественного маскирования и других операций с пикселами.

Пакет XRes обладает многими функциями, которые содержит Photoshop. Он поддерживает слои Photoshop 3 (преобразуя слои маскирования в альфа-каналы), контуры, альфа-каналы, дополнительные модули и некоторые режимы переходов. К сожалению, компания Macromedia больше не планирует выпускать следующие версии этого продукта.

Micrografx Picture Publisher

Прямой конкурент Photoshop, пакет Picture Publisher 8 (149 долл., только для Windows) обладает множеством достоинств. Среди его возможностей - сворачивание изображений, "заменители" низкого разрешения, контактные листы и функция создания уменьшенных копий, для реализации которых пользователи Photoshop вынуждены приобретать дополнительные модули или приложения. К тому же, некоторые операции маскирования и создания коллажей работают в Picture Publisher быстрее, а такие эффекты, как выдавливание и блики на объективе, обладают гораздо большей гибкостью. Picture Publisher включает также 55 фильтров, с которыми можно экспериментировать, накапливая изменения и не выходя из Браузера эффектов (Effects Brauser) программы.

Программа обладает значительно более широкими, чем Photoshop, возможностями по созданию графики для Web, включая поддержку GIF-анимаций. Можно выбрать фрагмент изображения и просмотреть, как он будет выглядеть в качестве мозаичной заливки Web-страницы. Функция Web Styles создает стилизованные наборы кнопок (со сглаженным текстом), разделителей и других элементов, с помощью которых можно легко сформировать графический шаблон для будущих страниц Web. Интерактивные режимы предварительного просмотра с использованием различных схем сжатия позволяют заранее оценивать размеры файлов и возможное времея их загрузки еще до сохранения изображений.

Пакет, разработанный для работы на системах, обладающих всего 16 Мбайт оперативной памяти, и использующий встроенную в Windows систему своппинга, Picture Publisher ориентирован на не самые мощные машины и не очень требовательного пользователя. (Для достижения оптимальной производительности компания Micrografx рекомендует, чтобы объем оперативной памяти был равен удвоенному размеру самых больших из обрабатываемых вами файлов.) По заверениям разработчиков, файл TIFF размером 4 байт открывается в программе в 5-6 раз быстрее, чем в Photoshop. Пакет Picture Publisher прост в освоении, частично благодаря "мастерам", которые даже неопытным пользователям позволяют выполнять сложные операции и достигать профессиональных результатов. Подводя итог, можно заключить, что набор функций и стоимость Picture Publisher могут оказаться идеальным сочетанием для рабочих мест, на которых менее опытные помощники смогут подготавливать для Web изображения, созданные в Photoshop профессиональными художниками.

Picture Publisher импортирует только файлы с объединенными слоями, такие как изображения TIFF; вы не сможете перенести в программу альфа-каналы или слои Photoshop. Пакет стоимостью 149 долл. поставляется в комплекте с 10 000 изображений, свободных от отчислений. За 199 долл. вы сможете приобрести Micrografx Webtricity, который включает - в дополнение к Picture Publisher - 80 000 изображений и Simply 3D - инструмент для создания быстрых и простых трехмерных анимаций.

Некоторые приложения вместо того, чтобы сражаться с Photoshop на всех фронтах, ориентированы на выполнение отдельных задач обработки изображений. Среди излюбленных дизайнерами инструментов мы обнаружили четыре таких приложения.

Equilibrium DeBabelizer

DeBabelizer 3 (399 долл., только для Macintosh) - это своеобразный "швейцарский армейский нож" для пакетных преобразований. (DeBabelizer Pro 4.5, 399 долл. - это сходный продукт для Windows). Хотя программу не раз критиковали за недружественный интерфейс, ее текущая версия позволяет выполнять интуитивно понятные операции в стиле drag-and-drop и создавать сценарии обработки без программирования. Пакет поддерживает поражающее воображение количество типов файлов - более 100, включая мультимедийный форматы, такие как цифровое видео. Несмотря на очевидную переориентацию DeBabelizer в сферу производства дисков CD-ROM, для чего в программу введены такие функции, как создание общих 8-разрядных суперпалитр для серий изображений, поддержка форматов Web сделала ее весьма ценным инструментом и для массовой разработки содержимого Web.

Для сравнения, в Photoshop поддержка пакетной обработки относится лишь к второстепенным функциям. Photoshop может делать простые процедуры, такие как изменение размеров изображений, но не в состоянии, например, добавить рамку толщиной 1 см ко всем картинкам в папке. Разработчики Equilibrium реализовали принципиально иной подход: они изначально построили свой продукт на основе технологии пакетной обработки, а затем добавили в него различные эффекты, включая поддержку дополнительных модулей Photoshop.

Еще одна область применений DeBabelizer - подготовка публикаций для различных носителей. Предположим, вы разрабатываете печатную версию ежегодного отчета, графика из которого будет использоваться в рекламном диске CD-ROM и на страницах узла Web. Для этого вы создаете новые файлы, сохраняя оригиналы и выполняя несколько операций над каждым изображением. Например, можно конвертировать файлы в CMYK и поместить их в папку для печати, затем масштабировать, сжать и сохранить их снова как изображения JPEG в папке для Web. Затем можно изменить их разрешения для экрана, создать и применить ко всем изображениям 8-разрядную суперпалитру, и, наконец, сохранить в папке для CD-ROM. В каждом примере можно описать правила автоматического присваивания новых имен. Версия Macintosh поддерживает также условные сценарии, которые позволяют принимать решения типа "Если ширина больше 200 пикселов, изменить ее на 200 пикселов". (CMYK и ColorSync в настоящее время поддерживаются только на Macintosh.)

Пакетные операции могут выполняться применением сценариев к спискам обработки, перетаскиванием палитр на изображения или перетаскиванием файлов и папок на сценарии (и наоборот). Вы можете даже перетаскивать файл HTML или текст URL в список пакетной обработки, а DeBabelizer включит в процесс пакетной обработки выбранные по ссылкам файлы изображений. (Однако программа не позволяет обращаться к удаленному серверу при помощи FTP.) Списки файлов для пакетной обработки могут сохраняться и использоваться повторно, что придает программе исключительную гибкость. Один из немногочисленных недостатков DeBabelizer - он может импортировать только файлы Photoshop без слоев.

Jasc Paint Shop Pro

Paint Shop Pro 5 (99 долл., только для Windows) - это очень недорогой набор инструментов для автоматизации работы. Хотя он не обладает полной функциональностью Photoshop, Paint Shop Pro ускоряет выполнение таких операций как открытие, обрезка, вращение и масштабирование. И использовать его часто проще, чем Photoshop.

Две самых сильных функции Paint Shop Pro, ради которых программу стоит включить в свой набор рабочих инструментов, - это создание уменьшенных набросков и возможности пакетной обработки, для чего пакет собственно и разрабатывался изначально еще в те времена, когда он распространялся как условно-бесплатная программа. Paint Shop Pro поддерживает 44 формата графических файлов, включая FlashPix и несколько форматов цифровых фотокамер. Уже один Browser программы - подобный Extensis Portfolio (бывший Aldus Fetch) - стоит уплаченных за программу денег. Щелкните правой кнопкой мыши по любой папке на рабочем столе - и Browser тотчас построит, а затем сохранит уменьшенные наброски всех изображений в этой папке. Это эффективный способ поиска и предварительного просмотра изображений для пользователей Photoshop.

MetaCreations Painter

Painter 5 (449 долл., Macintosh и Windows) занимает уникальную нишу на рынке графического дизайна. Технология "естественных инструментов", которая является ядром программы, позволяет художникам рисовать на экране также, как они привыкли это делать на холсте. Painter обладает практически бесконечным разнообразием кистей для имитация различных техник рисования, таких как гуашь и масло, на виртуальных поверхностях, также имитирующих различные бумаги и полотна. Для получения лучших результатов с программой следует работать при помощи графического планшета. Возможности Painter позволяют талантливому художнику создавать поразительно похожие на обычные картины цифровые изображения.

Но Painter не остался в стороне и от новейших технологий - он обладает множеством специальных эффектов. Инструменты клонирования, подобные Van Gog Cloner, позволяют применять стили великих мастеров к вашим собственным цифровым произведениям. Инструмент Image Hose дает возможность "разбрызгивать" элементы из библиотеки, такие как лиственный орнамент, на создание которых вручную потребовались бы многие часы. В этих библиотеках можно сохранять также ваши собственные изображения и использовать их позднее.

Painter содержит многочисленные функции обработки изображений, близкие функциям Photoshop, а также допускает подключение дополнительных модулей Photoshop 3. (Некоторые новейшие дополнительные модули, такие как Eye Candy компании Alien Skin, не работают с Painter.) Хотя Painter может импортировать и экспортировать файлы Photoshop вместе со слоями, каналами и контурами, режимы переходов слоев поддерживаются только для версии Photoshop 3. В добавок к этому, слои Photoshop преобразуются в "плоты" Painter, а маски слоев преобразуются в маски видимости "плотов". При обратном преобразовании в Photoshop, оригинальные маски слоев совмещаются с нередактируемыми масками прозрачности слоев.

Нужны ли вам обе эти программы? Ответ прост - да. Painter - единственный серьезный выбор для тех, кто уверенно себя чувствует с кистью в руках. И, хотя наличие Painter делает практически бесполезными все кисти Photoshop, последний все же обладает преимуществом в области работы с текстом и при необходимости выполнения сложных операций обработки изображений. Более того, Painter не поддерживает непосредственно режим CMYK, программа опирается на возможности механизма управления цветом компании Kodak и стандартные профили ICC.

Источники

Adobe Systems, http://www.adobe.com/.

Corel, http://www.corel.com/.

Equilibrium, http://www.equilibrium.com/.

Jasc Software, http://www.jasc.com/.

Live Picture, http://www.livepicture.com/.

Macromedia, http://www.macromedia.com/.

MetaCreations, http://www.metacreations.com/.

Micrografx, http://www.micrografx.com/.

Новички

В дополнение к уже рассмотренным давно известным приложениям, недавно на рынке появились и совершенно новые "игроки": Adobe ImageReady и Macromedia Fireworks. Компания Adobe использовала в ImageReady 1.0 отработанную технологию Photoshop, ограничив ее поддержкой только режима RGB для создания и оптимизации графики Web. А пакет Fireworks 1.0 - это полный набор графических инструментов для Web компании Macromedia. Он включает в себя самые современные инструменты редактирования растровых, векторных и текстовых объектов - и все это только в режиме RGB и с экранным разрешением. Вполне вероятно, что одна из этих программ войдет в комплект инструментов, которые профессионалы в области компьютерной графики используют для разработки содержимого Web.

Редактирование растровых изображений: каждой операции - свой инструмент

Выбор продукта, который займет свое место в вашем арсенале помимо вездесущего Photoshop, зависит прежде всего от того, чем вы занимаетесь. Если вы готовите изображения для широкоформатной печати, то выкройте время освоить Live Picture или XRes. Удивительная скорость работы Live Picture делает его идеальным инструментом для создания композиций из больших файлов изображений, а почти столь же быстрый XRes обладает более близким к Photoshop пользовательским интерфейсом. А если вы обладаете хотя бы небольшим талантом художника, то просто обязаны познакомиться с пакетом Painter.

Тщательно подобранная комбинация программ Paint Shop Pro, Photo-Paint и Picture Publisher хорошо подойдет дизайн-студиям с Windows-машинами, где нужны быстрая или более гибкая пакетная обработка, а также функции оптимизации графики и анимации для Web - и все это за цену ниже, чем Photoshop. (К моменту опубликования этой статьи должна появиться версия Photo-Paint для Macintosh.) Если вы уделяете серьезное внимание пакетной обработке изображений - для печати, мультимедиа или Web - то не пропустите DeBabelizer. Весьма привлекательными альтернативами для разработчиков содержимого Web являются программы ImageReady и Fireworks. Какие бы задачи не стояли перед вами, среди многочисленных "помощников" Photoshop всегда можно найти инструменты, которые облегчат вам жизнь.


Коллекция Picture Man

На домашнюю страницу KOI - 8
ЛУЧШЕЕ РОССИЙСКОЕ ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ

Дела в порядке

Коллекция Picture Man

Возрат в Главное меню

Коллекция “Picture Man”

В коллекцию входят:
  • ArtGallery v.1.0
  • Rubber v.1.0
  • MorphMan v.1.0

ArtGallery v. 1.0. Средство редактирования изображений и генерации уникальных художественных эффектов.

Добавьте “изюминку” вашим изображениям при помощи 18-ти новых инструментов галереи художественных эффектов ArtGallery! Придайте Ваш собственный, оригинальный стиль документам и презентациям, используя различные стилизации, от масляной или пастельной кисти до трехмерной мозаики или цветного рельефа.

Все основные возможности обработки изображений, простой, дружественный интерфейс, возможности сканирования и печати, и т.п.

18 эффектов для обработки изображений:

  • стандартные - Emboss, Faceted Glass, Scatter, Mosaic.
  • и уникальные - Hand Drawing, color Graphic Pen, Oil Paint, Automatic Brush, Patches, Strokes, Note Paper, Engrave, Old Paint, Padding, Canvas, Color Relief, Random Mosaic, 3D Mosaic.

art_gal.gif (130980 bytes)

Rubber v. 1.0. Редактирование изображений при помощи уникальных средств деформаций.

Станьте Мастером Деформаций! Используйте в вашем творчестве силы разрушителя и карикатуриста.

Эта доступная программа обеспечит Вас 22 инструментальными средствами, которые позволяют: “покоробить” (Warp), “закрутить” (Whirl), создать на изображении “вихри” (Page Curl), различные “взрывы” и так далее. Rubber позволит Вам обрезать изображение, изменить его размеры, сделать его светлее, темнее, преобразовать в негатив, изменить контраст, сделать его более размытым или четким, выделить область с произвольным контуром для обработки только части изображения.

22 инструментальных средства для создания деформаций:

  • стандартные - Warp, Whirl, Pinch, Punch, Perspective, Wind, Page Curl и пр.
  • и уникальные - Explosions: Burst, Blot, Splash; Collapses: EarthQuake, QuickSands, Black Hole; Rubber, Free Warp, Gravity, Random Deformations.

rubber.gif (100492 bytes)

MorphMan v. 1.0. Мощная программа для создания уникального эффекта “морфинг”.

Вы любите морфировать? Используя MorphMan 95, Вы можете включить в свои работы профессиональный эффект “морфинг” высокого качества. Кроме этого, Вы легко сможете редактировать видео.

MorphMan позволяет сделать не только обычный статический морфинг из двух изображений, но также и динамический морфинг - преобразование от одной видео последовательности к другой. MorphMan обеспечивает Вас тремя алгоритмами морфинга. Чтобы добавить созданные морфированные последовательности к вашим видео-роликам, Вы можете использовать встроенные в MorphMan средства редактирования видео.

Средства морфинга:

  • Три алгоритма морфинга
  • Статический и динамический морфинг
  • Простота размещения управляющих точек и линий
  • Линии управления перемещением цветов и точек
  • Полное управление масштабом
  • Копирование настроек между разными проектами

Средства обработки видео

morphman.gif (108860 bytes)

Все программы поддерживают:

  • интерфейс TWAIN
  • Форматы изображений: TIFF 6.0, JPEG, PCX, BMP, TARGA, GIF, PCD, EPS

Тех. требования:

Windows 95,
8 Мб памяти,
12 Мб свободного места на диске.

На Домашнюю страницу
Copyright © 1997 Арсеналъ
E-mail: arsenal@ars.ru 		Последнее обновление - 12.03.98 телефон 7 (095) 974 7989
факс 7 (095) 974 7991


"Смотрелки" графических файлов

Что наша жизнь? Просмотр картинок… Бытовые сцены и пейзажи, фантастические явления природы и виды из окна в разное время года, образы и видения - все это, если разобраться, преследует человека днем и ночью. Но ему, ненасытному, мало: как только у него выдается свободная минутка, он норовит прильнуть к телевизору или отправиться в кино, чтобы терпеливо, секунда за секундой, наблюдать мелькание десятков и сотен изображений.

Кроме кинематографа и телевидения, "человек смотрящий" изобрел еще целую кучу приспособлений для того, чтобы на досуге предаться любимому занятию. Технический парк человечества пополнили специально предназначенные для просмотра картинок фильмоскопы, диапроекторы и эпидиаскопы. И конечно же просто грех было бы не использовать для этих целей компьютер, способный хранить в своей памяти огромное количество фотографий, рисунков, графиков и диаграмм - все то, что способно радовать глаз своими линиями, цветом и формой.

Но человек всегда стремится к комфорту. Принцип "лучше один раз увидеть, чем сто раз услышать" хочется заменить правилом типа "лучше сто раз увидеть, чем все это время заниматься поиском нужного файла на жестком диске". И это, оказывается, можно сделать с помощью специальных программ для просмотра графических изображений, о которых мы вам сегодня и расскажем.

ACDSee

Самая известная и популярная на сегодняшний день программа от компании ACD Systems уже давно переросла из обычной "смотрелки" графических файлов в нечто сравнимое с неплохим графическим редактором. В своей последней, на момент написания статьи, версии 3.0 программа предоставляла пользователю возможности, которые мы опишем довольно сжато и кратко, потому что если вдаваться в подробности описания всех поддерживаемых графических форматов и т. п., не хватит целого журнала:

  • Очень быстрая, оптимизированная по специальному алгоритму загрузка и просмотр более чем 30 графических форматов файлов.
  • Оптимизация картинки по двухпроходному алгоритму, коррекция гаммы, увеличение и уменьшение изображения, просмотр в полный экран.
  • Распечатка картинок, автоматическое создание "обоев" для Windows.
  • Проигрывание различных мультимедийных файлов (звук и видео).
  • Быстрый и удобный просмотр каталогов из оболочки, подобной Проводнику Windows, с показом preview-картинки.
  • Возможность просматривать файлы в архивах (ZIP и LHA).
  • Возможность создать файл-лист всех картинок, находящихся в директории, с их подробным описанием.
  • Встроенная программа Photo Enhancer.
  • Конвертирование файлов в 6 самых популярных форматов (BMP, GIF, JPEG, PCX, TIFF, TGS), причем имеется batch-конвертер для обработки большого количества файлов одновременно.
  • Автоматическое создание HTML-фотоальбома.
  • Поддержка цифровых камер и сканеров.
  • Различные операции с JPEG-файлами (например, поворот, зеркальное отображение).
  • Возможность записи части графического файла.
  • Мощная система "горячих клавиш", подсказок и советов.

Продукт этот состоит как бы из двух программ. Первая - это ACDSee Browser, которая позволяет вам быстро просматривать директории для того, чтобы найти картинки, если таковые там имеются. При обнаружении в какой-нибудь папке графических изображений, программа автоматически выделяет их цветом и показывает параметры - размер и глубину цвета. После этого, нажав на соответствующую строчку, вы можете посмотреть картинку в уменьшенном варианте (упомянутая мной ранее функция preview). В последующем навигацию по директории удобно осуществлять клавишами-стрелками.

ACDSee Browser в действии. В правом окне осуществляется удобная навигация по дискам. Если в директории найдены картинки, они отображаются в левом окне и выделяются цветом.

Двойной щелчок на картинке или нажатие клавиши Enter переводят нас в другую программу - ACDSee Viewer, где мы наблюдаем интересующее нас графическое изображение в его реальном размере или в том, какое сами задаем в опциях. Так, можно любоваться картинками в полный экран, можно подстраивать их размер оптимальным образом под разрешение Рабочего стола или же, если картинка меньше, растягивать ее до нужного размера. Панель инструментов этой программы практически повторяет предыдущую, что довольно разумно и удобно.

Настройки ACDSee позволяют прекрасно настроить программу под свои предпочтения.

ACDSee предоставляет различные удобства не только обычным пользователям, вооруженным цифровыми фотоаппаратами и желающим сделать свой домашний фотоальбом, но и серьезным профессионалам, занимающимся компьютерной графикой. В частности, для последних предусмотрена возможность задавать фоновое изображение, чтобы потом на нем смотреть другие картинки. Это весьма полезно при подборе текстур или в каких-либо дизайнерских решениях.

IrfanView

Еще одна популярная программа, на сей раз - от австрийского студента Irfan Skiljan. Она в первую очередь интересна сочетанием широких возможностей с бесплатным распространением. Итак, вот основные функции программы IrfanView.

  • Просмотр около 35 графических форматов, а также видео трех самых популярных форматов.
  • Предварительный просмотра картинок в директории (Thumbnail option).
  • Возможность редактирования изображений.
  • Поддержка технологии drag'n'drop.
  • Воспроизведение аудио- и видео-CD.
  • Настройка размера видео и проигрывания музыки.
  • "Захват" как отдельных окон приложений, так и экрана в целом с помощью встроенного Grabber-экрана.
  • Поддержка сканеров и печати изображений.
  • Экспортирование иконок из EXE- и DLL-файлов.
  • Работа с удобными "горячими клавишами" и опциями запуска из командной строки.

IrfanView: просмотр с подстройкой под размер экрана. Картина известного художника в стиле fantasy Ройо.

Интерфейс IrfanView, пожалуй, менее привлекательный, чем у ACDSee, хотя в целом сильно на него похож. Панель инструментов здесь несколько меньше, поэтому большинство эффектов и других интересных функций доступны только через соответствующие меню. Вообще говоря, программа очень шустрая, но узнать время загрузки изображения можно только одним способом - вызвав из панели инструментов информацию о картинке. Это не очень удобно по сравнению с ACDSee.

Настройки IrfanView по отображаемым файлам. Как видите, количество поддерживаемых форматов весьма внушительно и способно удовлетворить даже самого требовательного пользователя.

В IrfanView хорошо реализована обработка большого числа операций по шаблону. Это касается не только конвертирования файлов, но также и сканирования. При открытии файлов в программе вызывается стандартный диалог работы с файлами, но при этом можно посмотреть миниатюрное изображение открываемого файла, причем не только статической картинки, но и видео. Единственное, что несколько режет глаз: при открытии изображений в исходном размере они зачастую оказываются расположенными на не особо симпатичном сером фоне, причем картинка не центрируется, а выравнивается по левому краю, так что справа остается неприятная полоса того самого серого цвета, которая никак не ликвидируется.

Окошко открытия файлов в IrfanView весьма информативно, и, кроме уменьшенного варианта картинки, вы можете видеть также основную информацию по файлу.

IrfanView: возможности редактирования изображений
  • Изменение размера/разрешения картинки
  • Поворот, отображение, изменение глубины цвета
  • Стандартные эффекты: негатив, sharpen, blur, emboss
  • 3D Button — изображение как бы становится трехмерной кнопкой
  • Oil paint — рисунок масляными красками
  • Fine rotation — поворот картинки на определенный угол с сохранением фона от предыдущего положения
  • Pixelize — пикселизация изображения
  • Интересные эффекты Median Filter, Explosion и Edge Detection

Много функций продукта реализуются также с помощью plug-in'ов, которые можно взять на домашней странице автора. Там же с гордостью указывается, что IrfanView - это первый "просмотрщик", который стал поддерживать GIF-анимацию (чрезвычайно популярную в Internet). Программа периодически обновляется (мы работали с версией 3.15) и выглядит весьма перспективной, не говоря уже о том, что и сейчас IrfanView стоит практически на одном уровне с лучшими коммерческими продуктами этой категории.

Sea и CompuPic

CompuPic - это сравнительно новая разработка корпорации Photodex, которая, наверное, гораздо больше известна у нас в стране, да, наверное, и в мире, по другому своему продукту подобной категории - Sea Graphics Viewer.

В CompuPic есть прекрасная возможность настроить размер предварительного просмотра картинок и варианты их отображения.

Эта программа, славно закончившая свое существование в 1997 г., была ужасно популярна в свое время, да и сейчас она не потеряла привлекательности, так что стоит несколько заострить ваше внимание на ней. Особенно это касается людей, которые имеют "слабые" компьютеры и еще не забыли, что такое DOS. Все дело в том, что, по сути дела, это единственная нормальная программа для просмотра графических изображений и некоторых форматов видео под MS DOS. Вот ее основные возможности:

  • Поддержка форматов JPG, TGA, BMP и RLE, TIFF, PCX, GIF, LBM (IFF), PSD, CEL, Dp2e-LBM, BBM и PCC, PNM (PBM, PGM, PPM) и PNG.
  • Очень быстрый вывод картинок.
  • Конвертация во все поддерживаемые форматы в любой цветности.
  • Поддержка видео форматов FLI, FLC и AVI.
  • Переключаемое разрешение интерфейса и preview-опция как для графики, так и для видео.
  • Проигрывание звуковых WAV- и VOC-файлов.
  • Различные эффекты типа resample, invert, smoothen, blur.
  • Другие полезные опции.

Конечно, вы не найдете здесь возможностей работы со сканером, поддержку многочисленных эффектов и редких форматов графики; но для такой операционной системы, как DOS, это просто замечательная программа, которая без проблем работает с любой старой видеокартой, поддерживающей режим VESA.

Сайт Photodex/CompuPic, где вы всегда можете найти свежие shareware-версии продуктов этой компании.

Понятно, что имея такие наработки в данной области, Photodex не могла остаться в стороне на рынке программ для Windows 9x. В результате был создан очень мощный продукт - CompuPic Digital Content Manager, представляющий собой не просто "просмотрщик" с расширенными функциями, каким был Sea, и являются сейчас ACDSee и IrfanView, а нечто большее. Вот основные возможности этого продукта:

  • Просмотр 45 форматов файлов.
  • Простой и красочный интерфейс наподобие Internet Explorer с поддержкой функции Drag'n'Drop.
  • Копирование, переименование, перенос, поиск и сортировка файлов.
  • Четыре варианта просмотра списка файлов в директории, с меньшим или большим удобством и соответствующей информативностью.
  • Отличный режим thumbnail preview (маленькие картинки), причем размер preview-изображения можно регулировать.
  • Создание баз данных по картинкам с теми же preview.
  • Графические эффекты.
  • Изменение глубины цвета, разрешения и размера картинок.
  • Операции: поворот, отображение, вырезание.
  • Установка цвета прозрачности для GIF-файлов.
  • Конвертация и запись в различные форматы.
  • Автоматическое создание HTML-страниц с картинками.
  • Просмотр текстовых файлов с помощью thumbnails и наложение текста и других объектов на изображение.
  • Создание поздравительных карточек, которые затем можно посылать через Internet.
  • Другие интересные функции.

Данная программа по сравнению с двумя другими участниками нашего тестирования дольше всех грузится и без конца выдает при этом окошко, в котором любезно сообщается, сколько дней вам осталось ею пользоваться, после чего предлагается приобрести сей очень полезный продукт. Честно говоря, после десятка раз это порядком надоедает, хотя, конечно, желание разработчиков продать свое произведение тоже вполне понятно.

Настройки CompuPic выполнены весьма красочно и позволяют быстро получить доступ к интересуемым параметрам, т. к. последние сгруппированы в тематические категории.

По умолчанию рабочее окно программы разбивается на три части: справа показываются различные, в зависимости от настройки, виды preview-изображений (это окно занимает большую часть экрана), слева вверху находится проводник по дискам и директориям, а ниже маленькое окно для preview-картинки. К просмотру картинки можно перейти как оттуда, так и выбрав соответствующее изображение в правом окне путем двойного щелчка мышкой на нем. Картинка выводится уже в другое окно поверх основного, причем по умолчанию - в реальном размере. Если изображение большое, вы увидите лишь его часть, после чего придется таскать по Рабочему столу это окно и в его меню выбирать опцию уменьшения картинки. Стоит отметить, что это делать весьма удобно: уменьшение картинки - клавиша "-", а увеличение - "+" на клавиатуре. При этом скорость обработки картинки просто поразительна, а цифры уменьшения и увеличения изображения в процентах практически не имеют никаких ограничений, в отличие от описанного выше ACDSee.

Из этого же окна просмотра изображений можно перейти к обработке картинки, создавая самые разнообразные варианты изображения. В частности, предусмотрено уменьшение эффекта "красных глаз", наблюдающегося на цветных фотографиях при использовании вспышки. Эти и другие опции вызываются только через меню, никакой панели инструментов нет, и в настройках этого изменить нельзя. Кстати, настроек в программе бесчисленное множество, они удобно организованы по разделам и выполнены весьма красочно. В них можно поставить пароль на программу, правда, сразу же следует предупреждение, что умный пользователь его все равно обойдет. Честно говоря, не очень понятно, зачем вообще ставить пароль на подобную программу, а если уж и ставить, то зачем делать это так, что обойти его не составляет особого труда. Ну да ладно.

Программа также поддерживает создание из картинок screensaver'а, но этот последний будет работать только при запущенной программе CompuPic. Помощь и подробное описание программы выполнены в удобном и красочном html-виде и рекомендуются к прочтению тем, кто хочет серьезно работать с этой программой.

Из явных недостатков (хотя, возможно, это всего лишь какая-то проблема, возникшая при тестировании) хочется отметить такое неприятное обстоятельство, как некое разбиение изображения горизонтальными полосами, при этом по краям заметна своеобразная бахрома. Подобный эффект наблюдался далеко не на всех картинках, но особенно ярко проявлялся при уменьшении картинки (функция Zoom out). Возможно, просто не очень оптимизирован алгоритм декодирования JPEG-изображений, или же имеет место какая-то схожая проблема.

Компания Photodex выпускает еще и программу CompuPic Pro. Ее отличия от обычной версии состоят в следующем:

  • Возможно создание специальных CD-дисков с изображениями по технологии Photodex.
  • Предусмотрены более обширные функции по работе с HTML-страницами - просмотр, редактирование, создание.
  • Реализовано сканирование Web-сайтов и автоматическое скачивание с них картинок и целых страниц.
  • Имеются расширенные функции наложения текста.
CompuPic: графические эффекты
  • Яркость, контрастность, цветность
  • Sharpen, blur, noise (добавление шума)
  • Инвертирование, sepia, отображение картинки в одном цвете
  • Vignettes (fuzzy borders) — создание рамок овальной и прямоугольной формы с эффектом, подобным портретному объективу у фотоаппарата, с заданием цвета рамки и степени прозрачности

При этом увеличивается и цена - Pro-версия стоит целых $100. Впрочем, ее ограниченная по времени версия также доступна для скачивания, так что вы можете без проблем ее посмотреть. Стоят ли вышеуказанные возможности $60 - решать вам. Впрочем, даже беглого знакомства с описанными программами вполне достаточно для того, чтобы понять, насколько та или иная из них вам необходима, и сделать свой выбор.

Название программы | ACDSee 3.0 | CompuPic 5.0 | IrfanView 3.15
Время загрузки картинки в формате JPEG (1600x1100x24), с | 1,0 | 1,2 | 0,7
Количество поддерживаемых графических форматов, шт. | 30 | 28 | 35 (7 из них с соответствующими plug-in’ами)
Количество поддерживаемых видео/аудио форматов и другие мультимедиа-возможности | 3/3 + 2 архивных формата | 6/6 + еще 5 форматов | 3/8 (проигрывание аудио- и видео-CD)
Условия распространения, цена | 30 дней, потом $50 | 15 дней, потом $40 | Бесплатно или $10 по желанию


-= Мой Компьютер Weekly :: Графика в стиле GIF =-

Графика в стиле GIF

Вот уже тринадцать лет, как файлы с расширением GIF занимают свое законное место на наших винчестерах, а изображения, сжатые при помощи этого формата, то и дело мелькают на экранах наших мониторов. Постепенно «мигрировав» из любительских и полупрофессиональных графических программ в окна современных браузеров и мощные графические пакеты, этот формат стал одним из основных, если не сказать больше, — основным стандартом сжатия и передачи графических изображений в сети Интернет.

И несмотря на то, что уже давно существуют намного более гибкие и функциональные форматы, он не собирается уступать «пальму первенства». Объяснить причины его высокой популярности не составит никакого труда: при всей простоте реализации GIF сочетает в себе набор таких функциональных возможностей, переоценить которые в плане сетевого обмена информацией очень и очень трудно. Ну и, кроме того, не зря же говорят: старый друг — лучше новых двух.

Начать свое знакомство с этим, не побоюсь таких слов, замечательным во всех отношениях форматом, логично будет с его истории. Тем более что у GIF’а она самая что ни есть настоящая: в меру длинная, со множеством интересных и неожиданных поворотов, к тому же местами обросшая таким количеством слухов и пересудов, что напоминает скорее детективный роман, чем обыкновенный рассказ о развитии очередного графического стандарта. Вот ее сокращенный вариант.

Истоки

Лет 15 назад было несколько крупных коммерческих on-line сетей, предоставлявших своим пользователям множество различных сервисов. В числе прочих ресурсов крупнейшей американской сети, принадлежавшей фирме CompuServe, была и громадная библиотека разнообразных изображений, открытая для публичного доступа (клиентам CompuServe, разумеется), и привлекавшая к себе большое количество пользователей. Читателей наверняка заинтересует, что же так привлекало пользователей к этой «свалке» картинок и фотографий?

В этом явлении нет ни капли загадочности или сверхъестественности — это была обыкновенная «клубничка», развязные изображения полуголых, голых, и «»совсем голых» девиц и особей противоположного пола. И хотя качество этих рисунков сравнимо скорее с фотографией из дешевой пятнадцатикопеечной газеты (для примера на рис. 1 представлен типичный образец компьютерной графики того времени, правда, с намного более «мягким» содержанием), чем даже с сильно компрессированным JPEG’ом наших дней, пользователи сети CompuServe посещали библиотеку изображений с завидным упорством и регулярностью. Но время, проведенное в сети, было далеко не бесплатно, и поэтому все графические файлы, находящиеся в этом «скопище», были сжаты архиватором; и каждый раз, перед тем как просмотреть новые рисунки, их приходилось распаковывать, что, естественно, положительных эмоций ни у кого не вызывало. Ситуацию мог поправить только принципиально новый графический формат, реализующий эффективную схему сжатия.

Программисты из CompuServe трудились вовсю, и в мае 1987 года была представлена первая спецификация под названием Graphics Interchange Format (формат для обмена графической информацией), которая впоследствии была названа GIF87a. Новый формат использовал «настоящий» алгоритм сжатия LZW, поддерживал 256-цветную графику и не был привязан ни к какой определенной платформе. А самое главное, это был формат, спроектированный для межсетевого взаимодействия, и наконец-то стала доступной возможность плавного появления изображения на экране по мере его загрузки из сети! Метод LZW позволял преобразовать цепочки повторяющихся байтов в специальные кодовые слова и таким образом уменьшить размер 8-битовых данных, полученных «естественным» путем (фотографии, сканированные рисунки) на Рис. 1 40% и более.

Новинку оценили по достоинству — вскоре было очень нелегко найти не только приложение, обрабатывающее графические файлы и не поддерживающие GIF, но и изображения, не закодированные при помощи нового формата. Количество GIF-программ росло, как грибы в дождливую погоду, а пользователи сетей (сначала CompuServe, а затем и других — America Online, Prodigy) были столь довольны, что уже в 1989, то есть через два года, программисты CompuServe предприняли попытку усовершенствования формата. Он был основательно доработан, и позволял теперь создавать «прозрачные» изображения и простенькие мультяшки. Добавилась поддержка несложных анимационных последовательностей, появилась возможность хранения прозрачных областей изображения. И хотя в то время такие нововведения были поистине революционными, широкое распространение новая версия формата, именующаяся GIF89a, получила только в период бурного развития Интернета.

В 1993 году фирма Unisys, обладавшая патентом на алгоритм сжатия LZW, обратилась к руководству CompuServe с предложением заключить лицензионное соглашение, и начать отчисления авторских гонораров (royalty). И хотя шаг этот был весьма логичен — ничем до сих пор не примечательный формат, популярный разве что у относительно небольшого количества художников и программистов, прямо на глазах превращался в неисчерпаемую «золотую жилу» — он не вызвал ничего, кроме гневных упреков и возмущений как со стороны пользователей CompuServe, так и весьма небольшой, но уже хорошо сплоченной интернет-общественности. Тогда против разработчика GIF’а был инициирован судебный процесс, в конце концов, все же проигранный им.

28 декабря 1994 года (а по некоторым источникам — 22 декабря) было заключено лицензионное соглашение, которое обязывало всех разработчиков, использующих в своем ПО GIF, выплачивать фирме Unisys авторские отчисления с каждого экземпляра проданного продукта. Кстати, это соглашение действительно и по сей день. Так ошибка программистов, которые в обязательном порядке должны были проверить патентную чистоту своих решений, но не сделали этого, чуть было не стала причиной гибели этого удивительного стандарта. К счастью, этого не случилось, даже наоборот, данная ошибка послужила толчком для создания нового, качественного, функционального и совершенного свободного графического формата — PNG. Но несмотря ни на отличную документированность, ни на ряд несомненных достоинств, ни даже на его полную свободу от каких-либо отчислений, PNG до сих пор так и не удалось получить такое же широкое распространение и признание, как бессменному и всегда популярному GIF’у.

О том, что внутри

Файлы формата GIF используются для хранения одного или нескольких изображений. В отличие от большинства растровых форматов, которые представляют все данные изображения одним непрерывным блоком, GIF использует потоки. Данные, представленные в этом формате, хранятся в виде небольших (порядка 256 байт) последовательностей, которые могут быть обработаны после того, как поступят из Сети. Такая организация дает неоспоримое преимущество: если изображения, сохраненные в других форматах, могут быть отображены только после полной их загрузки, то рисунки в формате GIF выводятся на экран по мере докачки.

Кроме собственно данных изображения в файле хранится много другой информации, взгляните на его структуру (рис. 2). Как и любой другой файл, в котором находятся данные (не обязательно графические), он начинается с заголовка. Заголовок в формате GIF очень компактен и занимает всего 6 байт. Единственное его предназначение — указать программе тип файла, а также его версию. Кстати, если у вас возникнет необходимость самостоятельно проверить версию или формат файла, имеющего расширение GIF, то сделать это очень просто. Необходимо только открыть его любым текстовым редактором, и в Рис. 2 начале документа вы увидите GIF87a или GIF89a.

В большинстве растровых форматов, таких, например, как BMP или PCX, заголовок содержит также размеры изображения. Стандарт GIF определяет для них другое местоположение — специальный блок информации под названием дескриптор логического экрана, следом за которым расположна глобальная цветовая таблица — не что иное, как палитра используемых цветов. Учитывая то, что в одном файле может храниться более одного изображения, и палитры их могут различаться, существуют также и необязательные локальные цветовые таблицы, в которых хранятся палитры вместе с данными соответствующих кадров.

В каждом отдельном кадре может быть использовано не более 256 различных цветов. Количество кадров также ограничено, но это связано уже не с особенностями формата, а с возможностями файловой системы (ФС) той или иной ОС. К примеру, в среде Windows 9x OSR2 и выше, где используется 32-разрядная ФС, максимальный размер файла составляет 4 Гб, и чтобы преодолеть этот рубеж, необходимо использовать другие ОС, например, BeOS. Но создание громадных GIF-роликов с трехчасовым видеофильмом или любимым телесериалом лишено всякого смысла — для этого существует множество других, более подходящих форматов, таких как QuickTime, MPEG или Intel DVI.

В GIF’ах также существуют блоки специальной информации — так называемые управляющие расширения или фреймы. Сведения, в них заложенные, определяют время демонстрации каждого кадра, наличие и размер локальных цветовых палитр, методы удаления изображения с экрана и другие параметры. Кроме того, в управляющем фрейме «Расширение комментариев» можно разместить произвольный текст, состоящий из символов первой половины таблицы ASCII (управляющие, псевдографика и символы английского алфавита). Чаще всего комментарии используються для указания имени автора и даты создания файла — довольно примитивный, но хоть какой-то способ защитить свои творения от несанкционированного копирования. С управляющими расширениями сталкивался, вероятно, каждый, кто хоть раз создавал новый или редактировал уже существующий анимированный GIF; только вот знакомство это происходило неявно, в виде передвижения ползунков и «кликов» мышью, а не в редактировании шестнадцатеричного кода.

Одной из особенностей формата GIF является и то, что размеры и места различных блоков информации, будь-то данные изображения или управляющие расширения, не поддаются никакому предварительному вычислению. Это в значительной мере усложняет реализацию алгоритмов просмотра GIF-изображений. Кроме того, такая «блочность» делает невозможной «перемотку» — определить заранее, не прочитав полностью весь поток данных, количество кадров в файле, или переместиться на несколько кадров вперед не получится при всем желании.


S U B M A R I N E . R U

Тестирование бесплатных графических программ

Для редактирования фотографий или графических изображений не всегда обязательно использовать большие программы Adobe Photoshop или Corel Photo Paint, за которые к тому же надо платить деньги. Существует ряд программ, доступных через Internet, гораздо меньших по размеру, но от этого не менее эффективных и удобных. Но главное их достоинство заключается в том, что они бесплатны и не имеют ограниченной лицензии.

VCW VicMan’s Photo Editor

Производитель: VCW
Домашняя страничка: http://www.vcw.ru/
Размеры: до установки — 820 Кбайт, после установки — 1,27 Мбайт
Язык: русский, английский

Форматы и Web

Какие же форматы поддерживает Photo Editor? Открывать файлы можно в BMP, PCX, JPEG, GIF, PNG, сохранять - в JPEG, BMP. Не густо… Существенный недостаток - отсутствие такого распространенного в Internet формата, как GIF. Это накладывает определенные ограничения на возможности создания графики для Web.

Так выглядит программа с загруженным изображением. Навигация производится на левом изображении, а редактирование — на правом, что достаточно удобно, т. к. можно видеть результат на всем рисунке.

Фотографии

Теперь рассмотрим программу как средство редактирования фотографий. Такое действие, как сканирование изображения, "отторжения" у нее не вызовет: программа свободно работает с TWAIN-интерфейсом (стандартный программный интерфейс для сканеров). А вот попытка одновременного сканирования больше двух фотографий будет обречена на неудачу, т. к. Photo Editor способен работать только с двумя документами. Причем один из них может оказаться новым изображением, созданным при загрузке программы. Средств для редактирования фотографий достаточно много, например разнообразные эффекты и инструменты.

Эффекты

Набор заложенных в программу эффектов можно пополнять самому, используя соответствующий пункт в меню: "Стилизация", "Освещение", "Деформации", "Трилинейные фильтры" и "Цветокоррекция". Первая группа применяется для создания Web-графики. Вторая и третья - для искажения изображения. При помощи четвертой обрабатывают отсканированные фотографии и редактируют изображение, делая его более реалистичным. Все эти опции находятся в меню "Эффекты". Узнав же VCW VicMan's Photo Editor поближе, вы сможете работать с ними, не открывая меню, используя для этого верхнюю панель программы.

Диалоговое окно создания нового эффекта деформации. Стоит только задать параметры (предварительно заглянув в помощь), и готово!

Меню и инструменты

Работать с меню программы легко и приятно. Русскоязычный интерфейс VCW VicMan's Photo Editor облегчает задачу поиска нужного пункта или эффекта. Набор необходимых инструментов редактирования выполнен в виде кнопок на Панели инструментов, находящейся слева.

Диалоговое окно создания нового фильтра. Заполняйте матрицу, вводите делитель и не забудьте название вашего нового эффекта.

Таким образом, сравнивая VCW VicMan's Photo Editor с нашими эталонами, приходим к выводу, что эта программа не может конкурировать с ними по количеству поддерживаемых форматов, некоторые просто необходимы для рассматриваемых задач. По другим параметрам программа довольно близка к Photoshop и Photo Paint. Например, в ней присутствуют все основные эффекты и инструменты, необходимые для редактирования фотографий, так что VCW VicMan's Photo Editor в простейших операциях можно использовать вместо профессиональных программ.

Применение VCW VicMan’s Photo Editor

  • Данная программа может быть использована для создания и редактирования небольших картинок, размеры которых не превышают 1000x1000 точек, а также для изменения фотографий при помощи эффектов. Рекомендуется начинающим пользователям с плохим знанием английского языка.
  • В Photo Editor в левом нижнем углу, под надписью «Допуск», имеются три регулятора. Манипулируя ими, можно добиться интересных результатов, т. к. они позволяют осуществлять гамма-коррекцию по цветам RGB.
  • Среди инструментов в этой программе есть два, свойственных только ей: один меняет цвет выбранной точки на цвет фона, другой — все остальные цвета.

При сравнении с предыдущей картинкой очевидно, насколько сильно можно изменить изображение, регулируя только три параметра «Допуск».

20/20

Производитель: byLight Technologies
Домашняя страничка: www.hotfreeware.com/2020/2020wh.htm
Размеры: до установки — 3,5 Мбайт, после установки — 6,1 Мбайт
Язык: английский

Форматы и Web

В отличие от предыдущей программы, в этой количество поддерживаемых форматов ощутимо выросло: GIF, JPEG, BMP, BIF, DIB, WMF, PCX, DCX, PNG, PCD, TGA, TIF, CMS и ICO. Ну а сохранять можно в GIF, JPEG, BMP, BIF, DIB, PCX, DCX, PNG, PCD, TGA, TIF и CMS. Данного диапазона форматов достаточно для того, чтобы работать и с созданием графики для Web, и с редактированием фотографий.

Программа 20/20 после загрузки. Возможности программы вы поймете, путешествуя по закладкам.

Фотографии

Как и в предыдущей программе, в 20/20 присутствует режим сканирования. Но здесь, в отличие от VCW VicMan's Photo Editor, мы можем сканировать столько картинок, сколько нам нужно (главное, чтобы хватило памяти).

Один из режимов редактирования. В нем одну и ту же открытую картинку можно редактировать как две независимые (нужную сохранить), а делается это при помощи кнопки Split Vertical на основной панели.

Эффекты

В этой программе около сорока эффектов и разобраться, какой из них что делает, достаточно просто. Для этого нужно открыть окно предпросмотра и нажать кнопку Preview. В этом же диалоге можно выделить область, к которой и будет применяться эффект. В отличие от предыдущей программы, здесь нельзя самому создавать новые эффекты.

Как вы сами видите, картинка на предпросмотре искажена, и достаточно сложно понять, как сработает тот или иной эффект.

Меню и инструменты

Меню этой программы интересно тем, что при работе с изображением обращаться к нему можно только в случае крайней необходимости, т. к. почти все его пункты находятся на панелях или вызываются щелчком правой кнопки мыши на изображении. Редактирование же картинки при помощи имеющихся в программе инструментов проблематично: 20/20 имеет только один растровый инструмент для редактирования - заливку. Другие инструменты являются векторными и позволяют лишь накладывать поверх самой картинки различного вида фигуры, стрелки и надписи. Так что с точки зрения изменения растровых картинок при помощи инструментов редактирования программа несостоятельна. Утешает то, что и векторными инструментами в 20/20 можно создавать неплохие картинки.

Подведем итоги. На первый взгляд широкий спектр поддерживаемых программой форматов делает ее вполне конкурентоспособной. Но слабые возможности редактирования растрового изображения свидетельствуют о том, что эта программа не годится для серьезной обработки фотографий. В этом плане предыдущая программа гораздо лучше.

Применение программы 20/20

  • Данная программа может неплохо показать себя при создании различного вида презентаций и обработке изображений эффектами. Набор функций и инструментов позволяет создавать картинки с надписями, стрелками и другими атрибутами презентаций. Имеются и развитые средства захвата изображений.
  • Программа при работе с картинками не ограничивает рабочую область. Для этого вы можете использовать размер собственного Desktop. Ну, а в свернутом состоянии программа находится среди маленьких иконок рядом с часами в System tray.

Ultimate FX

Производитель: Light Technique Ltd.
Домашняя страничка: http://www.ultimatepaint.com/ufx/
Размеры: до установки — 2 Мбайт, после установки — 3,29 Мбайт
Язык: английский

Форматы и Web

Количество поддерживаемых форматов здесь настолько обширно, что перечислять их не имеет смысла. Кроме того, в Ultimate FX можно открывать видеофайлы и сохранять рисунки в векторном виде (WMF).

Ultimate FX после загрузки. Похоже, подобный интерфейс входит в моду.

Фотографии

Функции сканера в Ultimate FX ни на йоту не отличаются от двух предыдущих программ. Поддержка множества картинок обеспечивает удобство работы с фотоальбомами, тем более что предусмотрена навигация по открытым картинкам.

Эффекты

Тут есть, где развернуться! Помимо собственных эффектов и фильтров, программа может подключить фильтры и Plug-ins от Adobe Photoshop, что значительно расширяет ее возможности. Но и это не все! Ultimate FX имеет очень интересную функцию: если вы не знаете, как выбранные вами эффекты повлияют на редактируемую картинку, то можете предварительно посмотреть их действие. Для этого выберите в меню Image в пункте эффектов подпункт Browse, и перед вами возникнет окно, где их действие можно увидеть. После выбора нужного эффекта, при помощи двойного щелчка мыши, вы можете настраивать эффект по вашему вкусу.

Окно выбора эффектов. Так гораздо проще выбрать нужный.

Меню и инструменты

Содержание меню достаточно скудное, за исключением Image, в котором находятся все эффекты, применимые к картинке. Инструменты в программе попросту отсутствуют. Вывод: программа не предназначена для создания какой-либо графики вообще.

При сравнении с эталонами эта программа продемонстрировала себя с неплохой стороны относительно поддерживаемых форматов и просто отлично со стороны эффектов. Но Ultimate FX не выдерживает никакого сравнения с другими графическими редакторами в плане "ручной" обработки изображений из-за отсутствия необходимых инструментов. Таким образом, Ultimate FX применима в рассматриваемых нами областях только для обработки изображений эффектами.

Применение Ultimate FX

  • Эта программа предназначена для того, чтобы с максимальными удобствами применять различные фильтры и эффекты, находить нужные картинки на дисках и преобразовывать из одного формата в другой.

ArcSoft PhotoStudio

Производитель: ArcSoft, Inc.
Домашняя страничка: http://www.arcsoft.com/products/software/en/photostudio2000.html
Размеры: до установки — 1,9 Мбайт, после установки — 1,55 Мбайт
Язык: английский

Форматы и Web

Данная программа вряд ли поразит вас чем-то новеньким. Она поддерживает только основные форматы. Причем они относятся не только к Web, но и к фотографиям, т. е. поддерживается формат TIFF, являющийся стандартом для сохранения снимков в хорошем качестве.

Фотографии

Сделанная нами героическая попытка отсканировать изображение привела к печальному результату: на экране проступило нечто размазанное, отдаленно напоминающее оригинал (в отличие от ArcSoft PhotoStudio другие программы выдержали этот тест достойно). Однако при желании данного эффекта можно избежать, уменьшив разрешение с 300 dpi до 150 dpi. Таким образом, при помощи этой программы сканирование фотографий в высоком разрешении невозможно. Но не будем отчаиваться, посмотрим, что же дальше.

В результате сканирования фотографии мы получаем наклонную фотографию со смещением. А если уменьшить разрешение, то мы получим нормальную картинку (справа внизу).

Эффекты

Применение эффектов в ArcSoft PhotoStudio ничем особенным не отличается, а количество покажется достаточным почти любому пользователю, тем более что можно подключить Plug-ins из Photoshop. Для этого нужно указать в файле PSTUDIO.INI соотвествующий путь.

Меню и инструменты

Если вы когда-нибудь работали с Adobe Photoshop, то интерфейс и меню покажутся вам знакомыми, но, конечно, они не повторяют его, а всего лишь похожи. Найти в меню нужное вам действие не составит труда, т. к. все достаточно грамотно сгруппировано по опциям. Набор инструментов такой же, как и в Adobe Photoshop, и действия они выполняют не хуже, но вот настроить их должным образом вам не удастся, если только не догадаетесь дважды щелкнуть на иконки инструментов. Интересен инструмент Stamp Tool, который позволяет изображать различные штампы в виде выбранной фигуры.

Такую картинку можно получить меньше чем за минуту при помощи инструмента Stamp Tool.

Делая вывод относительно ArcSoft PhotoStudio, можно сказать, что он был создан по образу Adobe Photoshop с урезанными возможностями, проигрывая ему по двум параметрам. Первый - это отсутствие возможности работы со слоями. Второй - не очень хорошая работа со сканером. Хотя, может быть, в следующей версии этот небольшой недостаток будет устранен (или здесь имеет место несовместимость с данным оборудованием драйвера или сканера этой модели), т. к. в самой программе утверждается, что она спокойно должна работать на нем. Если бы не этот недостаток, то среди протестированных нами редакторов ArcSoft PhotoStudio был бы признан самым универсальным.

Применение ArcSoft PhotoStudio

  • Если применять эту программу по назначению, она вполне может заменить Adobe Photoshop. Однако различия между ними все-таки есть. И нешуточные. Например, отсутствие работы со слоями. Так что для профессионалов эта программа не годится, а вот создать картинку и отредактировать ее особых проблем не составит.

Подведение итогов

Рассмотрев четыре бесплатные программы, мы убедились в том, что, не имея большого количества функций и не обладая универсальностью дорогих профессиональных пакетов, они в чем-то могут даже превосходить их. Например, в программе Ultimate FX отличные спецэффекты и фильтры. А в программе VCW VicMan’s Photo Editor вы можете применять свои собственные эффекты, где их создание достаточно просто. Ну, а как это сделать, довольно подробно описано в «помощи» на русском языке. Таким образом, используя эти программы по назначению, можно добиться превосходных результатов в редактировании фотографий и создании графики для Web (Internet). Но не забывайте, что эти программы поставляются бесплатно, а на халяву и уксус сладок…


S U B M A R I N E . R U

на 1-ю страницуна 1-ю страницу

назад

Старое новое фото - подарок века
Сергей Марей

Рубеж веков и тысячелетий внес в "поздравительные" изыски моих знакомых явственную ретроспективную ноту. Многих посетила идея использовать для изготовления подарков или поздравительных открыток оригиналы едва ли не вековой давности. Работа с такими вещами весьма специфична: они требуют особо бережного обращения; почти всегда приходится ретушировать полученный после сканирования образ и т. д.

Эта статья - рассказ об одном из таких подарков, некогда изготовленных по странному, но действенному рецепту. Вот этот рецепт: возьмите современный компьютер, сканер, принтер; соедините их между собой; а теперь добавьте старый, очень старый оригинал и - побольше фантазии…

Оригинал: фотография 1908 г. Размер: 125 x 107 мм. Основа: плотный картон.

Идея: портрет, увеличенный до размеров формата А4 (примерно в 2 раза).

Выбор инструментов

Начнем с устройства вывода - с принтера. Портрет будем печатать на обычной офисной бумаге формата А4 (она имеет плотность около 80 кг/м3), при необходимости мы сможем потом наклеить лист на более плотную основу либо поместить в рамку под стекло. Поскольку оригинал - черно-белая фотография, печатать будем в полутоновом (Grayscale, 256 градаций серого) формате, т. е. только одним из четырех цветов CMYK - черным. Значит, нам подойдет монохромный (черно-белый) принтер формата А4. Требования по качеству вывода получаем из простого предположения: портреты такого формата обычно либо вешают на стену, либо ставят на стол, следовательно, отпечаток должен выглядеть прилично при рассматривании с расстояния около метра... Cкорее всего, линиатуры 72...75 lpi (так печатается большинство газет) окажется достаточно.

Осталось определить разрешение принтера, необходимое для вывода образа с линиатурой 72 lpi при условии сохранения непрерывности тоновых переходов. Максимальное число тонов на каждый цвет печатной краски Nт, которые могут быть выведены при заданных линиатуре L (lpi) и разрешении принтера R (dpi), определяется по формуле:

Отсюда несложно рассчитать:

Подставив Nт = 256 и L = 72, получаем R = 16 x 72 = 1152. Ближайшее большее значение стандартного ряда - 1200. Итак, нам потребуется лазерный либо струйный монохромный принтер формата А4 с разрешением 1200 dpi. В рассматриваемом случае использовался принтер Minolta-QMS Page Pro 1100 (разрешение 1200 dpi, формат А4, подключен по локальной сети).

Теперь выберем сканер, при помощи которого будем оцифровывать фотографию. Основные параметры, подлежащие определению, - оптическое разрешение и глубина цвета. Глубина цвета, требуемая для оцифровки черно-белого изображения, составляет 24 бит (по 8 бит на каждый из RGB-каналов, чтобы все 256 оттенков Grayscale были восприняты без потерь). Оптическое разрешение сканера не должно быть меньше выходного разрешения образа Rout (разрешения картинки перед отправкой на печать). Последнее может быть легко определено, если известны требуемая линиатура L (в нашем случае L = 75) и технология растрирования (в нашем случае - амплитудная модуляция):

Здесь К = 1,5...2 - коэффициент растрирования (называемый также коэффициентом качества). Задав К = 2, получаем Rout: 2 x 75 = 150 ppi. Следовательно, нам подойдет сканер, имеющий оптическое разрешение выше 150 dpi и глубину цвета не менее 24 бит, т. е. практически любой. У всех современных моделей параметры лучшие, нежели только что рассчитанные нами.

Итак, нам потребуется сканер с оптическим разрешением не менее 150 dpi и глубиной цвета не менее 24 бит. В нашем случае использовался аппарат Relisys (Teco) Episode (оптическое разрешение 600 dpi, глубина цвета 36 бит, интерфейс USB).

Осмотр и первичная подготовка оригинала

Фотография, служащая нам оригиналом, заметно пострадала от времени и неосторожного обращения (рис. 1). Картон, на который наклеен снимок, несколько изогнут вдоль длинной стороны, по краям и в углах "разлохмачен"; на поле снимка имеются три глубокие трещины с выступающими над плоскостью фотографии краями; фотоэмульсионный слой вокруг трещин поврежден и выглядит весьма хрупким.

Рис. 1. Оригинал (фотография 1908 г.).

Очевидно, что такой оригинал ни в коем случае нельзя плотно прижимать к планшетному стеклу сканера - так мы рискуем причинить фотокарточке еще большие повреждения. Однако некоторые участки неприжатой фотографии окажутся в нескольких миллиметрах от поверхности планшета, и это в отдельных случаях может привести к искажению образа (потере резкости на тех самых "некоторых участках"). Чтобы избежать данного эффекта, для оцифровки следует использовать только сканер, выполненный по технологии CCD.

Технология CCD долгое время была единственной, применявшейся при разработке сканеров класса SOHO. Относительно недавно появившаяся CIS-технология позволила производителям выпускать более простые и дешевые сканеры. Эти компактные, плоские аппараты неплохо справляются с подавляющим большинством "домашних" и "офисных" задач, поэтому их нередко можно встретить как среди офисной оргтехники, так и в настольной лаборатории сканировщика-любителя. Но для наших целей подобный сканер никак не подойдет: слишком мала глубина резкости (расстояние от оригинала до планшетного стекла, при котором мелкие детали оригинала передаются без искажений). Для CIS-сканера эта величина имеет порядок долей миллиметра, поэтому края фотографии неизбежно будут размыты. Это дополнительное условие обязательно следует учитывать при выборе аппарата для оцифровки ветхих или покоробленных оригиналов. Выбранный нами Relisys Episode работает с использованием CCD-технологии, так что дополнительное условие оказывается выполненным.

Дальнейший осмотр показал, что состояние поверхности фотографии можно без преувеличения назвать плачевным: помимо трех больших трещин имеется множество мелких, в некоторых местах поверхность истерта вплоть до утраты фрагментов изображения (как, например, на жилетке мужчины, стоящего слева). Кое-где на эмульсионном слое фотографии оказались прилипшие частицы пыли (снимок, похоже, хранился "в прохладном пыльном месте" без каких-либо мер предосторожности). Пыль эту можно и нужно удалить, ведь каждая пылинка после сканирования окажется на образе в качестве лишнего дефекта изображения. Для удаления пыли мы использовали мягкую кисточку и сухую безворсовую салфетку (такие салфетки иногда продаются как средство ухода за офисной оргтехникой или оптикой). Профессионалы в подобных случаях нередко используют также сжатый обеспыленный воздух (продается в баллончиках наподобие аэрозольных). Применение сжатого воздуха, конечно, предпочтительнее, но его у нас под руками не оказалось.

Устранение прочих дефектов на самом оригинале (ретушь фотографии) для неспециалиста крайне сложно, если возможно вообще, но, к счастью, от нас подобного и не требуется. Наша цель - избавиться от дефектов подготавливаемого для печати цифрового образа фотографии, а это куда проще, благо программ для обработки сканированных изображений существует достаточно. Поэтому мы возьмем оригинал "как есть" и начнем со сканирования. Затем проведем дополнительную обработку полученного образа (цифровую ретушь), после чего займемся созданием твердой копии отретушированного портрета - распечатаем откорректированный образ.

Проводить какие-либо "восстановительные работы" на этапе сканирования нереально: драйверы сканеров класса SOHO не предназначены для выполнения столь сложных задач. Тот минимум типовых операций (фильтров), который предусмотрен драйвером используемого нами сканера (размытие, повышение резкости, инверсия, внесение цветового сдвига), хорошо подходит для работ попроще - для сканирования всевозможных фотографий, визиток, иллюстраций с целью просмотра на экране без увеличения. В нашем случае задача осложнена как необходимостью увеличения оригинального изображения (с фотографии 10 x 12 см до листа формата А4, 21 x 29 см), так и большим количеством дефектов оригинала. Поэтому нам потребуется инструментарий посерьезнее: мощный графический редактор.

Сканирование

Мы должны оцифровать снимок без автоматической коррекции, без наложения каких-либо фильтров - с тем, чтобы получить с оригинала максимальное количество неискаженной информации. Следовательно, всевозможные "скан-менеджеры" и "программы быстрого сканирования", поставляемые в комплекте программного обеспечения современных SOHO-аппаратов и позволяющие "скани-ровать в одно касание", нам не подходят. Практически все эти "менеджеры" проводят оцифровку с жестко заданными параметрами, не позволяя пользователю вмешиваться в процесс. А нам требуется обратное: полный контроль над процессом, учет и, возможно, коррекция установок драйвера сканера. Поэтому начинаем сканирование с загрузки графического редактора, в котором будем работать с полученным образом. Затем вызываем драйвер (интерфейсную программу) сканера. В описываемом случае мы использовали Adobe Photoshop v.4.0. В этом редакторе драйвер сканера вызывается командой "Файл" - "Импортировать" - TWAIN32... и вот перед нами основное диалоговое окно драйвера.

Начиная с этого момента, оцифровка старых, плохо сохранившихся фотографий ничем принципиально не отличается от сканирования позавчерашних "поляроидных" снимков или офисной документации: размещаете оригинал на планшете, выполняете предварительное сканирование, выделяете мышкой нужную область (это называется "кадрирование"), выставляете в окне драйвера требуемые параметры (режим и разрешение сканирования), нажимаете Scan - и готово...

Конечно, потребуется учесть также некоторые дополнительные факторы, связанные с вышеописанными свойствами оригинала. Описание всех этих факторов в обобщенном виде заняло бы слишком много места, поэтому ограничимся рассказом о том, что и как мы делали, чтобы получить цифровую копию фотографии. Фотография была размещена примерно посередине короткой стороны планшетного стекла, ближе к началу планшета сканера. Такой выбор расположения оригинала был обусловлен стремлением поместить снимок в зонe наименьших искажений.

Крышку сканера сняли (снимок, как мы помним, нельзя было прижимать к стеклу), вместо нее планшет вместе с оригиналом аккуратно накрыли темной плотной тканью - во избежание влияния комнатного освещения. Это влияние оказалось бы нечувствительным, если бы речь шла об оцифровке офисной документации или иллюстрации из журнала, но со старой, покоробленной фотокарточкой мы предпочли перестраховаться. После выполнения предварительного сканирования мы кадрировали снимок, стараясь как можно меньше захватывать темный фон (форма оригинала отличалась от правильного прямоугольника, поэтому выбрать область сканирования точно по контуру оригинала не представлялось возможным).

Автоматическая коррекция изображения средствами драйвера сканера, как уже говорилось, в рассматриваемом случае нежелательна: вовсе не факт, что внесенные драйвером изменения улучшат изображение, а сделать его более похожим на оригинал без повторного сканирования не удастся.

Рис. 2. Полутоновые образы R-, G-, B-каналов (могут служить источником дополнительной информации об изображении).

Режим сканирования на первый взгляд логично установить в соответствии с требуемым форматом образа - Grayscale, 8 бит. Однако это было бы не совсем правильно: существует одна тонкость... Изображение, как известно, считывается сканером в формате RGB (Red, Green, Blue), при этом в каждом из трех цветовых каналов содержится полутоновый образ (рис. 2A, B, C соответственно). Если установить в драйвере сканера режим Grayscale (иногда он еще называется B/W Photo или Gray 8bit), то изображение, переданное драйвером, будет содержать образ из какого-то одного канала, а вся информация из двух остальных будет утеряна. Когда вы работаете с текстовыми документами в программе распознавания, безразлично, из какого канала "распознавалка" получит полутоновое изображение, но если речь идет о качественном воспроизведении, предпочтительно использовать максимум доступной информации об оригинале. Поэтому мы установили цветной режим сканирования (True Color, 24 бит).

Кстати, о количестве бит... Многие современные сканеры позволяют передавать в приложение картинку в 36-бит формате. Стоит ли пользоваться этой возможностью? Далеко не всегда... Прежде всего стоит задаться вопросом: для чего это нужно? 36-бит изображение может понадобиться, когда вы планируете перед выводом на печать выполнять цветоделение образа, преобразование его в формат CMYK... В нашем же случае изображение будет преобразовано в Grayscale и отпечатано одной черной краской, преобразование в CMYK не потребуется. А значит, не нужен и 36-бит образ, вполне достаточно стандартных 24 бит.

Разрешение сканирования сначала выставили равным оптическому разрешению сканера - 600 ppi... что поделать, стереотипы живучи. "Чем выше разрешение - тем лучше" - этот стереотип существует, кажется, со времен продажи первого сканера. Ну в самом деле, что с того, что файл получится объемом 20 Мбайт? Зато качественно... наверное. Потом все же опомнились, решили пересканировать на разных разрешениях и сравнить результаты. Сперва отсканировали на 400 ppi, потом на 300, потом на 225 и 150... затем преобразовали в формат Grayscale и распечатали все пять изображений с увеличением до размеров формата А4 без какой-либо дополнительной коррекции. Поскольку разрешение сканирования по сути определяет степень детализации получаемого образа, при сравнении в первую очередь обращали внимание на мелкие детали изображения (букет и бантики девочки, орнамент на поясе мальчика).

Рис. 3. Влияние выбора разрешения сканирования на воспроизведение мелких деталей. (A) разрешение 300 ppi, (B) - 150 ppi.

Понятно, что именно эти фрагменты должны были пострадать от недостаточного разрешения прежде всего (рис. 3A, B). Оказалось, что 300 ppi вполне достаточно для получения качественного изображения. Объем образа при этом составил примерно 5 Мбайт.

Ретушь

Теперь нам предстоит, пожалуй, самое сложное: удалить с изображения следы трещин, царапин и потертостей, восстановив тот вид, который должна была иметь свежеотпечатанная фотография. Но прежде чем переходить к описанию использовавшихся нами методов и приемов восстановления электронного изображения, остановимся на одной любопытной возможности.

Мы желаем получить увеличенную копию поврежденной фотографии, на которой бы отсутствовали дефекты, имеющиеся изначально на оригинале. Допустим, что приемами ретуши фотоснимков мы не владеем, поэтому восстановить оригинал, а затем заниматься сканированием и увеличением не можем. На первый взгляд единственно правильным кажется выбранный нами способ: отсканировать, отретушировать электронный образ, затем распечатать с увеличением. При этом ретушь оказывается самым трудоемким этапом работы, особенно для человека, впервые столкнувшегося с подобной задачей. Но что делать, если времени в обрез? Или, скажем, слово "Photoshop" у вас ассоциируется исключительно с магазином фототоваров, и ни о каких слоях, масках и палитрах вы слыхом не слыхивали? Все пропало? Отнюдь. Для начала увеличьте образ до требуемого размера и распечатайте без какой-либо дополнительной обработки (о том, как выбрать правильные размеры и подготовить образ для печати, речь пойдет ниже).

Вариант первый. И вот портрет перед вами. Трещины, царапины, потертости и пятна, конечно, никуда не делись - они увеличены и перенесены на бумагу вместе с прочими деталями изображения. Нам понадобится самый обычный простой карандаш... да-да, совершенно верно. Мы будем ретушировать не фотографию и не электронную картинку, а готовый отпечаток. Поверьте, это окажется значительно легче и быстрее, чем любой другой способ.

Преимущества этого метода очевидны: вы работаете с удобно увеличенной картинкой, используя только один, привычный каждому инструмент - карандаш; если вдруг в результате ошибки портрет оказывается безнадежно испорчен - ничего страшного, всегда можно начать сначала, распечатав еще одну копию...

Этот метод, правда, имеет и одно существенное ограничение: если на фотографии есть дефекты в виде темных пятен, избавиться от них уже не удастся. Такие повреждения в любом случае потребуют цифровой обработки отсканированного образа. Однако если большинство дефектов изображения имеют вид светлых пятен или полос (как на нашем снимке), то шансы на успех заметно возрастут. Чтобы сделать их (шансы) еще выше, постарайтесь использовать для распечатки бумагу с максимально гладкой поверхностью.

Если на фотографии присутствуют ярко-белые участки (в нашем случае - широкие трещины в нижней и средней частях снимка), попробуйте слегка затемнить их. Это удобно сделать в Photoshop, прокрасив черным цветом при помощи инструмента "кисть" (диаметр кисти выберите в палитре "Кисти" примерно вдвое больше ширины трещины, в палитре "Свойства" установите режим наложения "Замена темным" и непрозрачность - примерно 2-5%). Смысл этой операции становится понятен, если попробовать нанести карандашную штриховку на чистый участок листа и на участок, запечатанный принтером, пусть даже с небольшой плотностью краски. Вы заметите, что карандашный грифель ложится на эти участки по-разному, и, если пренебречь вышеописанной коррекцией, вам придется в процессе ретуши заново приноравливаться к каждому незапечатанному участку портрета.

Если же используемый вами графический редактор не позволяет наносить мазки регулируемой прозрачности, лучше вместо прокрашивания белых участков немного (на 3-4 пункта) уменьшить яркость всего изображения.

Карандаш желательно взять не очень твердый, но и не слишком мягкий ("ТМ" или "М" по российской классификации), и можно начинать аккуратно править отпечаток. Проще говоря, закрашивать те места снимка, которые из-за дефектов оказались светлее, чем должны были быть.

Начните с верхней части листа. Тон штриховки подбирайте постепенно, начиная с наиболее светлого. Избегайте сильного нажима; если требуется получить интенсивный черный цвет, лучше несколько раз прокрасить нужный фрагмент с умеренным нажимом (в противном случае вы рискуете получить излишне темный тон, а то и просто оцарапать бумагу). Направление штриховки желательно время от времени менять, во избежание неприятного эффекта: при рассмотрении листа под небольшим углом одинаково заштрихованные участки будут бросаться в глаза. Если есть такая возможность, все время, пока вы работаете над отпечатком, держите на виду оригинал фотографии: лишний раз свериться с оригиналом никогда не помешает.

Наиболее сложные фрагменты нашего снимка - нижняя часть лица девочки (изображение утрачено на значительной площади, кое-что пришлось просто рисовать заново), верхняя часть рубашки и пояс мальчика (широкие трещины пересекают изображение, изобилующее мелкими деталями), а также полностью утраченный треугольный фрагмент посередине нижнего края фотографии (помимо куска пола понадобилось дорисовать часть сапожка). На восстановление этих участков у нас ушло примерно 30-35 мин. Еще столько же на ретушь всего остального изображения. Итого: примерно 1 ч 10 мин - 1 ч 15 мин. Сравните это время с приведенными ниже цифрами для ретуши средствами графического редактора. Портрет, восстановленный вышеописанным способом, вы можете видеть на рис. 4.

Рис. 4. Портрет, отретушированный при помощи простого карандаша.

Вариант второй. Безусловно, качество портрета оказалось далеко не идеальным. Повернув лист под определенным углом, можно заметить отретушированные участки, ведь нанесенный на бумагу грифель простого карандаша (графит) отражает свет. Рассмотренный способ имеет и другие недостатки, например упомянутую выше принципиальную невозможность устранения темных пятен. Имеется способ, лишенный всех этих недостатков, позволяющий получить полноценное цифровое изображение, годное как для печати, так и для просмотра на экране. Способ, требующий определенных познаний и навыков, несколько более трудоемкий, зато дающий значительно лучший результат. Мы говорим о цифровой ретуши.

В качестве основного набора инструментов мы решили использовать такой мощный графический редактор, как Adobe Photoshop. Этот редактор (один из самых популярных среди специалистов цифровой обработки изображений) имеет великолепные возможности, в т. ч. ряд функций, специально разработанных для ретуши. На наш взгляд, это самый удобный из специализированных инструментов такого рода, однако он не является единственной подходящей программой. Если у вас в аналогичном случае нет Photoshop, можно воспользоваться и другим редактором, хотя вероятно, что трудозатраты при этом заметно возрастут.

Мы провели следующий эксперимент: были подвергнуты ретуши две цифровые копии снимка. Одна обрабатывалась при помощи Adobe Photoshop v.4.0, другая - Ulead PhotoImpact SE v.3.0 (графический редактор "домашнего" уровня, свободно доступен на сайте производителя: http://www.ulead.com.tw/). В обоих случаях удалось получить приемлемые, на наш взгляд, результаты; вот только время обработки оказалось различным: 4-5 ч с использованием Photoshop и около трех рабочих дней - с использованием PhotoImpact (оператор, работавший с нашей фотографией, не был специалистом по ретуши и никогда ранее не занимался подобными задачами - профессионалу потребовалось бы значительно меньшее время).

Приступаем к работе

Начнем с преобразования цветного изображения в полутоновое. Наша задача при этом - проследить, чтобы снимок не утратил контрастности, не допустить возможной потери деталей в теневых областях и в световых (областях высокой яркости). Для начала проведем преобразование средствами Photoshop, оценим результат; затем при необходимости проведем коррекцию, извлекая недостающую информацию из образов, содержащихся в каналах R, G, B (рис. 2A, B, C... ради этой возможности, как мы помним, и проводилось сканирование в цветном режиме).

После преобразования ("Изображение" - "Режим" - Grayscale) получаем вполне приемлемый на вид полутоновый образ. Слегка заниженную контрастность можно увеличить вручную ("Изображение" - "Коррекция" - "Яркость/Контраст") либо воспользоваться функцией автоматической настройки, имеющейся в Photoshop ("Изображение" - "Коррекция" - "Автоматическая тоновая коррекция"). Сохраним образ в отдельном файле ("Файл" - "СохранитьКак"). Затем вновь откроем исходный файл с цветным образом и, нажимая поочередно "Ctrl+1", "Ctrl+2", "Ctrl+3", просмотрим образы R-, G-, B-каналов, сравнивая их с только что полученным. Убедившись в корректности проведенного преобразования и отсутствии потерянных деталей изображения, закроем файл с цветным образом - больше для работы он нам не потребуется. Но не спешите удалять первую копию! Всегда полезно иметь "неприкосновенный запас" информации на случай, если рабочий образ почему-либо будет утерян или испорчен.

Рис. 5. Дефекты исходной фотографии весьма разнообразны: от мелких царапин, точек и потертостей (вверху, (A) до крупных трещин с отшелушившейся по краям фотоэмульсией (внизу, B).

Теперь о ретуши как таковой. Повреждения на нашем снимке имеют вид мелких царапин и пятен, есть также несколько широких полос с рваными краями (трещины на фотографии). Эти виды повреждений требуют различного подхода: если с мелкими дефектами (рис. 5A) можно справиться при помощи специализированного фильтра Photoshop ("Пыль и царапины"), то для больших по площади дефектов (рис. 5B) такой метод не подойдет, и, скорее всего, их придется "заштамповывать" (инструмент "Штамп" стандартного набора Photoshop).

Начнем с мелких дефектов. Применение специализированного фильтра ("Фильтры" - "Шум" - "Пыль и царапины") ко всему образу (первое, что пришло нам в голову) действительно убирает практически все лишние точки и черточки... зато образ оказывается настолько размыт, что о дальнейшей работе с ним можно и не помышлять. Вместе с мелкими царапинами теряются вообще все мелкие детали изображения. Несколько лучший эффект достигается, если сначала выделить все области вокруг дефектов и применить фильтр только к ним, но при этом размытые фильтром области начинают довольно заметно выделяться на общем фоне.

Оптимальное решение заключается в создании дополнительного слоя, подготовке на нем корректирующих фрагментов и перенесении их на оригинальное изображение. Общий смысл идеи таков: создадим еще один слой, содержащий изначально точную копию нашего изображения. На нем выделим и обработаем фильтром поврежденные участки. А затем перенесем эти участки на первый слой, но не целиком, а только те пикселы, которые необходимы для перекрытия точек и царапин. Тогда на первом слое царапины исчезнут, а области вокруг них останутся неискаженными.

Создаем слой-копию: в палитре "Слои" щелкаем по иконке первого (и пока единственного) слоя правой кнопкой мыши и во всплывшем меню выбираем "Создать копию слоя". Появится окошко запроса, в котором укажем, что копию слоя необходимо создать в этом же файле. Готово. Переходим на этот слой, щелкнув по его иконке, и приступаем к выделению областей, содержащих дефекты.

Приемы создания выделений могут быть различными, это зависит в первую очередь от характера, количества и расположения дефектов на изображении. В рассматриваемом случае мы воспользовались режимом быстрой маски. Переключившись в этот режим, можно как бы "рисовать" по изображению любыми инструментами основной палитры Photoshop. Затем переключаемся в обычный режим, и все пространство, кроме "закрашенных" нами областей, оказывается выделенным. Теперь выбираем команду "Выделение" - "Инверсия" и получаем набор выделенных областей, содержащих дефекты. Можно применять фильтр "Пыль и царапины".

Из-за большого количества и разнородности повреждений на нашем снимке эту операцию пришлось повторить несколько раз, выделяя перед каждым применением фильтра группы похожих между собой дефектов, - тогда эффективность всей операции заметно возрастает. Дело в том, что "Пыль и царапины" - настраиваемый фильтр: задавая различный радиус размытия и порог срабатывания, можно подбирать оптимальное воздействие для каждой группы повреждений.

Кстати, просмотровое окошко в меню выбора параметров фильтра при подобном подходе не обязательно "гонять" по всему полю образа, оценивая действие фильтра на различные участки, достаточно установить окошко так, чтобы видеть любую из выделенных областей. Если были выделены похожие между собой дефекты, то и размытие на них подействует примерно одинаково.

Когда со всеми мелкими точками и царапинами удалось справиться (до широких царапин, как помним, дело дойдет позже), мы приступили к выборочному переносу исправленных пикселов на первый, чистовой слой. Для этого как нельзя лучше подходит "Штамп". Обычно он применяется для переноса пикселов в пределах одной картинки, но мы используем его иначе. Выбрав команду "Редактирование" - "Сделать снимок", поместим в буфер копию исправленного нами слоя. Теперь выберем инструмент "Штамп" из основной палитры, а в палитре "Свойства" зададим требуемый режим наложения - "Замена темным".

Работает настроенный нами инструмент следующим образом: поставив "штамп" в любом месте чистового слоя, мы перенесем на него не все пикселы из соответствующего фрагмента буфера, а только те, что темнее находящихся на оригинале. Получился... уничтожитель светлых царапин! Выбрав подходящую форму и размер кисти в одноименной палитре (кисть должна быть в полтора-два раза толще удаляемой царапины), приступаем к очистке изображения. С темными дефектами поступаем так же, как и со светлыми, перед началом удаления следует только изменить режим наложения в палитре "Свойства" (вместо "Замена темным" установить "Замена светлым").

Если вы работаете не в Photoshop, а в каком-либо графическом редакторе, не позволяющем построить "уничтожитель царапин", придется действовать иначе. Мелкие царапины придется уничтожать размытием (Blur), выделяя небольшую область вокруг поврежденного участка. Мелкие пятнышки (светлые или темные - безразлично) лучше всего закрывать небольшим фрагментом изображения, похожим по тону и фактуре на оригинальный фон в месте дефекта. В Ulead PhotoImpact SE это удобно делать при помощи инструмента Clone Tool, аналогичного "Штампу" Photoshop. При работе с ним старайтесь наносить как можно меньшие по размеру "отпечатки", тогда при воспроизведении портрета в полную величину места исправлений будут не так заметны. Желательно также избегать нанесения Clone Tool линий или длинных штрихов - периодически повторяющийся фрагмент - отпечаток будет бросаться в глаза.

Но вот (так или иначе) мелкие дефекты удалены. Теперь нам предстоит самое сложное: убрать с изображения широкие белые линии, возникшие из-за крупных трещин в фотоэмульсионном слое оригинала. Справиться с ними при помощи "уничтожителя царапин" не получится, поскольку площадь повреждений слишком велика и широкие размытые полосы будут хорошо заметны.

Дать какие-то универсальные советы в данном случае непросто. Восстановление утраченных фрагментов большой площади - работа более творческая, нежели механическая. Мы перепробовали несколько способов инструментальной коррекции, пока не остановились все на том же "Штампе" Photoshop (Clone Tool в PhotoImpact). Оба инструмента работают по одному принципу: сначала вы намечаете положение участка, откуда будет взят образец (щелкнув по образцу левой кнопкой мыши при нажатой клавише Alt для "Штампа" Photoshop или Shift для Clone Tool PhotoImpact), а затем наносите "отпечатки" (по сути - копии фрагмента-образца) на корректируемые участки. Форму кисти, режим наложения и степень непрозрачности, скорее всего, придется не раз и не два менять в процессе работы, поэтому данные о предпочтительных установках мы сознательно опускаем.

Рис. 6. Образ, восстановленный средствами Adobe Photoshop.

И вот последний штрих наложен, образ признан готовым для печати и сохранен как окончательный результат (рис. 6). Командой "Изображение" - "Размер изображения" вызываем меню для увеличения образа до нужного нам размера. В окошке "Размер печатного оттиска" выставляем ширину 20 см (убедившись предварительно, что флажок "Сохранить пропорции" взведен), "Разрешение" оставляем равным 300 ppi, интерполяцию лучше использовать бикубическую. После нажатия кнопки "Да" образ будет увеличен до требуемого размера. Осталось послать образ на печать: "Файл" - "Печатать" - "Да"...

Рассмотренный в статье процесс обработки старинной фотографии заинтересовал нас прежде всего необычностью поставленной задачи. Откровенно признаемся: задача была решена непрофессионально. Не исключено, что профессионалы от ретуши найдут в статье и методологические, и технические ошибки... Мы не претендуем на непогрешимость, однако в одном уверены твердо: описанная методика позволит вам добиться неплохих результатов, не имея глубоких познаний в специальных областях. Надеемся, изготовленные вами подарки порадуют ваших близких...

назад

Пишите нам!
zagruz@submarine.ru
Полное или частичное воспроизведение любых материалов, содержащихся на этом сайте, допускается только с письменного разрешения редакции.
TopList
Copyright © 1999-2000
Фантазия


S U B M A R I N E . R U

FAQ: Работа с графикой

Хочу приобщить своего ребенка к работе с графикой. Но пребываю в некоторой растерянности. С одной стороны, желательно показать ему максимум возможного, а с другой - это не должно быть чересчур сложно. Посоветуйте, с какой программы лучше всего начать.

Трудно назвать одну-единственную графическую программу, которая затмевала бы все остальные. Хотя бы за счет того, что часть из них предназначена для работы исключительно с векторной графикой, а другие - растровой.

Вообще, все вокруг на работе только и говорят: Photoshop, Photoshop…

Вы правы, среди редакторов растровых изображений наибольшей популярностью пользуется Adobe Photoshop, очень мощная и непростая программа. Благодаря огромному количеству инструментов, заложенных в нее авторами, а также возможности подключать модули расширения сторонних разработчиков, Photoshop превратился в своего рода промышленный стандарт. Впрочем, собственно рисовать в этой программе не так удобно, ее основная сфера применения относится к области ретуширования, композиции и предпечатной подготовки. А вот если вы хотите почувствовать себя настоящим художником, то стоит познакомиться поближе с замечательной программой Fractal Design Painter (после приобретения прав на нее компанией Corel название поменялось на Corel Painter). Здесь упор делается на имитирование естественных средств рисования - кистей, мелков, карандашей, а также различных сортов бумаги, холста и т. п. Для того чтобы создавать рисунки в Painter, неплохо было бы иметь базовые познания в технике живописи.

Среди векторных редакторов самыми мощными и удобными остаются Adobe Illustrator и Macromedia Freehand. Обе программы обладают совершенно несхожими пользовательскими интерфейсами, и переключаться с одной на другую непросто. Но в функциональном отношении и Illustrator, и Freehand практически равны. С их помощью создаются сложные многослойные документы с мультиязыковой поддержкой, возможностью инкапсуляции растровых фрагментов, а также широкой поддержкой выходных форматов, в т. ч. ориентированных на конкретные устройства печати.

Все это замечательно, но не тяжеловато ли для ребенка?

Вероятно, ребенку на первых порах и в самом деле будет непросто овладеть всеми тонкостями работы в указанных редакторах. Поэтому, для того чтобы познакомить его с миром компьютерной графики, мы рекомендуем обратиться к компакт-диску, прилагаемому к нашему журналу. Там рассказывается о программе Paint Shop Pro - идеальном выборе для начинающих.

При создании нового изображения программа предлагает мне установить его разрешение, а я не совсем понимаю, что это такое и как сделать правильный выбор.

Принципы, заложенные в архитектуру современных вычислительных машин, в т. ч. и персонального компьютера, предполагают работу с цифровым представлением информации на всех этапах ее получения, обработки и хранения. Поэтому компьютерная графика во всех ее разновидностях тоже сводится в итоге к манипуляциям над двоичными данными. Все устройства отображения графической информации представляют ее в виде двухмерной матрицы, состоящей из большого количества ячеек-точек, называемых пикселами. Чем больше пикселов помещается на одном и том же отрезке строки этой матрицы, тем более естественным и плавным кажется глазу вся картинка. Различные устройства имеют свои ограничения по плотности выводящихся пикселов, и именно этот параметр и называется разрешением. Однако заметьте, что, хотя каждый файл сохраняется с заданной плотностью, он может быть отображен в любом разрешении (поэтому, например, современные языки программирования абстрагируют средства вывода, подменяя их неким отвлеченным понятием - "контекстное устройство"). Просто в таком случае будут нарушены авторские масштабы картинки.

Все процессы, связанные с обработкой изображений, так или иначе манипулируют с массивом пикселов. Поэтому вы всегда ограничены минимальным участком картинки, который поддается редактированию. Об этом важно помнить при сканировании: чем выше разрешение у сканера, тем более детальные изменения вы сможете внести при работе с файлом. То же справедливо и для печати: еще на этапе подготовки нового документа бывает разумным задать ему разрешение выше того, на которое способен ваш принтер.

Теперь понятно. А какой формат лучше всего при сохранении файла? Их там так много…

Действительно, на сегодняшний день количество разнообразных форматов графических файлов уже перевалило за сотню. Некоторые из них применяются повсеместно, другие специфичны для какой-то одной программы. Вместе с тем такое разнообразие вызвано не объективными причинами, а происходит во многом по вине компаний-разработчиков, которые очень любят "облагодетельствовать" пользователя своей собственной разработкой.

Но определенные форматы являются фактически стандартными, и такие файлы, скорее всего, сможет открыть на своем компьютере любой пользователь. В первую очередь к ним относятся форматы GIF, BMP и JPEG. Из "серьезных" форматов выделяются TIFF и EPS. TIFF хранит графическую информацию без потери качества (опционально она может быть сохранена с применением стандартной LZW-компрессии, но это не влечет за собой ухудшения визуального представления). EPS основан на описании изображения при помощи специального языка PostScript и инкапсуляции этого описания внутрь файла. Также широко распространен "родной" формат программы Adobe Photoshop - PSD, который оптимальным образом сохраняет документы любой сложности, не изменяя их внутренней структуры. Так что, выбор разрешения и формата, в котором создается и сохраняется картинка, зависит исключительно от цели ее дальнейшего использования.

Здравствуйте! Я отредактировал картинку в Photoshop, однако при распечатке цвета оказались совсем не такие, как были на экране!

В принципе при печати картинки вы можете быть уверены только в одном: за редактируемым на экране файлом и отправляемой на печать информацией стоит один и тот же набор двоичных данных. Конечно, иногда документ содержит не только матрицу пикселов, составляющих картинку, но и служебную информацию, зачастую довольно развернутую (например, определенный шрифт или другие параметрические директивы для аппаратного растеризатора). Однако это не должно нас волновать: мы работаем непосредственно с рисунком, и именно его номинальная идентичность на экране и бумаге является необходимым условием хорошего результата.

Визуальное отличие экранной картинки от ее отпечатка вызвано совершенно различной природой отображения монитором и принтером. Каждому пикселу рисунка присваивается свой цвет; его глубина, т. е. количество возможных оттенков, зависит, по большому счету, только от используемого формата и желания пользователя - эталонного качества достичь все равно не удастся.

Электронно-лучевая трубка монитора (ЭЛТ остается единственно приемлемой технологией для работы с графикой - жидкокристаллическим экранам пока недоступна точная цветопередача) при помощи маскируемого луча эмиттера воспроизводит ту самую матрицу пикселов. При этом все точки получаются одинакового размера и отстоят друг от друга на одно и то же расстояние. В результате изображение получается равномерно насыщенным, хотя при низком разрешении иногда появляются дефекты в виде "ступенчатости", неровных краев у отдельных деталей и т. п. Зато с цветопередачей все в порядке: компьютер честно старается установить именно тот цвет, который был задан для каждой точки. Конечный результат, правда, зависит от качества монитора и видеокарты.

Ну а почему же принтеры так не могут?

С принтерами все обстоит иначе. Здесь пикселы воспроизводятся путем нанесения на бумагу (пленку, ткань и т. д.) красящего пигмента, и результат такой операции во многом носит недетерминированный характер. Например, в наиболее распространенных струйных принтерах изображение получается путем разбрызгивания на носитель микроскопических капель краски. Несмотря на все старания производителей, размеры двух соседних "клякс" могут различаться; если они не успеют мгновенно подсохнуть, то велика вероятность их размывания. Наконец, со временем изменяются физические и химические характеристики самого пигмента и один и тот же файл будет распечатан в разных оттенках.

Ясно. А откуда тогда берутся цвета пикселов?

Передать цвет отдельного пиксела изображения в цифровой форме можно несколькими способами. Не придумано еще единой "глобальной системы", где каждому оттенку соответствовало бы некое число. На практике все множество передается через комбинацию определенных базовых цветов, и сосуществование нескольких альтернативных схем объясняется тем, что ни одна из них не в силах описать всю палитру.

Две наиболее часто применяемые в компьютерной графике цветовые модели - это CMY(K) и RGB. Первая схема имеет под собой многовековую историю и использовалась художниками, которые выделяли во всем множестве цветов три так называемых "первичных" - пурпурный, желтый и голубой. Путем их смешивания можно добиться практически любого оттенка; однако, CMY изначально ориентировалась на использование настоящих красок, поэтому в компьютерной области она применяется в основном на этапе печати. Часто к трем базовым оттенкам добавляют черный, который обозначается буквой К. RGB, напротив, описывает не цвет пигмента, а комбинации частей спектра отраженного света, и в его основе лежат красный, зеленый и синий. Существуют и более специфические схемы, например HSV и Lab.

Большинство графических редакторов позволяет выбирать, в какой из цветовых моделей будет представлено изображение, а также переводить его из одной схемы в другую.

У нас с приятелем вышел спор: что же лучше - растр или вектор? Рассудите нас, пожалуйста.

Попробуем. Растровое и векторное представление графической информации - это два принципиально различных подхода, используемых на этапах редактирования и хранения. Нельзя сказать, что один из них лучше другого - просто сферы их применения сильно отличаются. Бывает, что для достижения требуемого эффекта в одном и том же документе используются оба метода. В то же время на экран монитора и на печать принтера будет выводиться всегда точечное изображение, т. е. битовая матрица.

Растровые изображения - это те самые матрицы пикселов. По сути, каждая точка сама по себе обладает одной-единственной характеристикой - цветом. В сложных, "многослойных" рисунках пикселам могут присваиваться и дополнительные значения, например степень прозрачности, но делается это фактически в виде таких же цветовых градаций, просто скрытых от глаз пользователя. Поэтому и все допустимые в растровой графике операции сводятся к изменению цвета отдельных точек или их групп. Конечно, зачастую это происходит путем использования специальных процедурных функций, облегчающих работу (например, превращение изображения в его негативный отпечаток нажатием одной-единственной кнопки), но характерных растру ограничений избежать не удастся все равно.

Парадигма векторной графики разительно отличается от концепции растрового изображения. В этом случае в формировании картинки вообще нет описаний отдельных пикселов. Создаваемый пользователем документ представляет собой координатную сетку, по точкам которой строятся кривые и прямые линии, описываемые сложными системами уравнений. Замкнутая линия становится фигурой, которая в последствии заполняется каким-либо цветом (или градиентной заливкой, или параметрическими текстурами). Фигуры независимы друг от друга: можно изменять их координаты, вращать, деформировать или выстраивать по Z-оси. Главное достоинство векторных изображений - неограниченное масштабирование по отношению к базовому рисунку.

Но ведь и точечный рисунок тоже поддается масштабированию. Вот только качество при этом - явно не на высоте…

Абсолютно верно, масштабирование растровых изображений невозможно без снижения качества. Однако существует один прием, позволяющий сократить подобные потери. Предположим, у вас имеется фотография, отсканированная с разрешением 72 точки на дюйм, а вам хочется распечатать ее на струйном принтере, но в натуральный размер. Рабочее же разрешение принтера составляет 600 точек. Что делать? Есть только один выход - интерполяция. Графический редактор "растягивает" пикселы исходного изображения, пытаясь заполнить образовавшиеся между ними разрывы новыми точками. Сложность кроется в том, как определить цвет добавленных точек. Самый простой и грубый метод - повторять окраску находящейся, скажем, слева или сверху точки. В этом случае вся картинка покроется отвратительными квадратиками, похожими на смотрящего в глаза какодемона.

Более сложные механизмы рассчитывают для каждой "лишней" точки среднее значение цвета на основе соседних пикселов. Чем больше зона охвата, тем более плавным получается переход. Правда, при такой интерполяции страдает резкость изображения, которую приходится потом восстанавливать дополнительными средствами.

Да еще и размер увеличивается…

Еще бы! Растровые и векторные файлы довольно сильно отличаются по размерам. Поскольку битовая карта должна содержать полную информацию о каждой точке, объем растрового изображения часто достигает нескольких мегабайтов. Векторный же рисунок, имеющий ту же площадь, почти всегда оказывается во много раз компактнее, ведь он хранит только список линий функций, использованных для построения фигуры, да еще параметры отдельных объектов.

Здравствуйте. Скажите, пожалуйста, существуют ли какие-либо ограничения на картинки, публикуемые в Internet?

Использование графики в Internet обусловлено рядом правил. В первую очередь это связано с допустимыми объемами файлов. Никто не помешает разместить на Web-сайте полноценные рисунки объемом в несколько сотен килобайт и выше, но вряд ли кто из посетителей дождется, когда они загрузятся. Второе условие - это доступность формата файла. Поскольку удаленный пользователь будет просматривать изображение в окне своего браузера, то необходимо, чтобы программа располагала средствами для работы с такими файлами.

На сегодняшний день форматами, принятыми в качестве стандартных во Всемирной сети, считаются JPEG, GIF и PNG. Все эти три типа относятся к категории так называемых "сжатых": теми или иными способами хранящееся в них изображение упаковывается, зачастую - за счет потери качества. Так, например, JPEG укрупняет соседние пикселы картинки в блоки и рассчитывает усредненное значение цвета для них. Два других формата позволяют сократить число используемых в файле цветов до одного из стандартных уровней или же точно индексировать их количество.

Частичная потеря качества - неизбежная жертва, на которую приходится идти при оптимизации изображений для WWW.

Подскажите, что означает слово "полигон" и на что влияет их количество?

"Полигон" в переводе с греческого означает "многоугольник", а в области компьютерной графики под ним понимается базовый участок поверхности трехмерной модели. Несмотря на название, в качестве таких участков практически всегда используются треугольники, т. е. фигуры с наименее возможным количеством вершин. На то есть несколько причин.

Вообще, вся компьютерная трехмерная графика опирается на создание моделей и их последующую визуализацию (так называемый "рендеринг"). Модель представляет собой совокупность разнесенных в пространстве точек: две соседние из них задают грань объекта, а три - часть плоскости, т. е. тот самый полигон. Само собой, чем мельче будет выглядеть каждый полигон в отдельности и чем больше их вместит в себя создаваемая модель, тем более красивыми и естественными будут казаться его очертания на экране. Однако добавление лишних вершин к уже существующим усложняет обработку объекта: даже при создании статического "снимка" компьютеру приходится рассчитывать наложение текстуры (двухмерного рисунка или узора, имитирующего какой-либо материал или поверхность) на каждый из полигонов, освещение, взаимодействие теней и др. В том же случае, когда готовится анимационный ролик, для каждого кадра приходится определять новые координаты всех вершин, а соответственно и характеристики задаваемых ими полигонов.

В инженерном и художественном моделировании на количество создаваемых полигонов скупиться не принято, а вот в области компьютерных игр с этим пока сложнее.

Насколько сложно овладеть навыками мультипликации, по крайней мере такими, которых хватило бы на создание баннеров?

Существует несколько способов создания двухмерной анимации, например от той же Adobe, не говоря уже о получившем всемирную популярность Flash. В основе анимационных файлов лежат как векторные, так и растровые технологии; иногда для их просмотра пользователю требуется установить у себя на компьютере специальные программы или плагины.

Однако в данном случае речь идет о наиболее распространенном в Internet формате - GIF-анимации. Эта технология лежит в основе всего множества "мультипликационных" баннеров благодаря простоте изготовления и поддержке со стороны практически любого современного браузера.

Многие графические редакторы позволяют сохранять последовательность рисунков в виде анимированного GIF-файла. Принцип действия GIF-анимации предельно прост и напоминает классический способ создания рисованных мультфильмов. GIF-файл содержит несколько картинок, каждая из которых представляет собой один кадр анимации. Они выводятся на экран один за другим со скоростью, задаваемой автором (он, в свою очередь, рассчитывает ее, исходя из желаемой продолжительности "ролика"). Каждая следующая картинка заменяет собой предыдущую, поэтому общий размер файла прямо пропорционален количеству кадров. Как показывает практика, достаточно ограничиться 10-12 фрагментами - более длинные анимационные последовательности задерживают загрузку всего баннера. По этой причине вы практически не встретите в Сети "полнометражных" мультфильмов, выполненных по GIF-технологии. Для их создания используются уже совсем другие средства, в первую очередь - Flash.

И чем он так хорош, этот Flash?

Flash-технология принадлежит компании Macromedia (хотя она и не создавала ее самостоятельно, а приобрела и постепенно развивала). Она основана на векторной графике, хотя допускает использование и отдельных растровых фрагментов. Если вы знакомы с созданием векторных рисунков в любой другой программе, то освоить эту технологию не составит труда. Ключевыми ее понятиями являются объекты с наборами присущих им атрибутов и временные шкалы. Последние - не что иное, как последовательности воспроизводимых друг за другом кадров, некоторые из которых объявляются ключевыми. В них создатель анимации вводит новые объекты или удаляет существующие, а также изменяет характеристики различных элементов, например цвет, размеры, положение на экране и т. д. Все последовательности кадров между ключевыми рассчитываются программой самостоятельно. Внутри одного фильма можно определить набор сцен, каждая из которых имеет свою временную шкалу, а также организовать переходы между ними.

Высокий уровень интерактивности достигается при помощи встроенного языка описания сценариев Active Script. Его возможностей хватает даже для того, чтобы создавать не только Flash-фильмы, но и самые настоящие Flash-игры! Кроме того, технология позволяет добавлять в анимацию звуковое сопровождение и прочие атрибуты для взаимодействия с внешней средой. Поэтому Flash все чаще применяется для оформления Web-сайтов вместо традиционного HTML.

Я заметил, что в ряде программ встречаются какие-то Watermarks. Зачем они нужны?

Watermarks - водяные знаки. Точно так же, как с их помощью защищаются деньги, ценные бумаги и различные официальные документы, вы можете оградить создаваемые вами графические файлы от кражи или подделки. Вставка водяных знаков реализована во многих популярных программах, а вот способ их действия иногда различается. Зачастую содержащаяся в них информация о правах собственности на изображение "прошивается" в документ таким образом, что видна всегда (избавиться от нее традиционными методами не удастся). В другом случае водяные знаки проявляются только при попытке распечатать файл, или же при его просмотре через Internet. Во избежание подделок процедура внедрения водяного знака подразумевает уникальную идентификацию пользователя, а для этого нужно пройти регистрацию у изготовителя этой программы. Как правило, эта услуга является платной.

Здравствуйте, я собираюсь заняться 3D-анимацией. Помню, как в институте нас учили проектировать в Autocad. Могут ли мне пригодиться навыки работы в этой среде?

То, что у вас есть опыт работы в такой серьезной среде 3D-моделирования, как Autocad, просто замечательно. В принципе подавляющее большинство методов, используемых при построении как простых, так и сложных композитных объектов в любом трехмерном редакторе так или иначе будут походить на то, что вам уже известно. Однако, анимация сцен - отдельная история. Многие популярные программы год от года все больше ориентируются именно на создание мультипликационных роликов; как следствие, растет количество специализированных инструментов.

Каковы же особенности мультипликационных роликов?

Предположим, вы создали трехмерную модель. Теперь давайте посмотрим, на чем же основывается ее "оживление". Возьмем, к примеру, фигуру идущего человека. В статичном положении тело может быть описано одной монолитной моделью, при этом весьма детальной. Но имитация движения потребует серьезных изменений во многих его узловых участках, поэтому при анимации зачастую приходится жертвовать точностью модели в пользу реалистичности поведения. Первый "слой" анимации в нашем случае - это перемещение человека в пространстве. Для этого используется привязка движущегося объекта к определяемым автором "путям" - невидимым сложным кривым, контур которых будет повторять точка привязки объекта. Однако этого мало, и модель человека должна повторять движения - поднимать согнутые в коленях ноги, раскачиваться из стороны в сторону и балансировать, как это делают живые люди. Поэтому настоящая модель будет состоять из нескольких фрагментов, положение которых относительно друг друга поддается регулированию (с учетом взаимодействий, или "инверсной кинематики"). Таков второй "слой" анимации, но на этом дело не заканчивается - ведь при ходьбе растягиваются и сокращаются мышцы, перекатываясь под кожей; и это тоже следует отразить в нашей сцене. Таким образом, мы получим третий "слой" - изменение, или морфинг, самих объектов.

Получается, что вся анимация построена на изменении параметров объектов?

В основном да, но бывают и другие варианты. Представьте себе, что вам надо смоделировать катящийся по траве футбольный мяч. Конечно, можно создать его модель, затем натянуть соответствующую текстуру и заставить его вертеться вокруг своей оси. Но есть и иной путь - использовать анимированную текстуру, которая будет создавать иллюзию мелькающих черных и белых пятен. Таким образом можно сэкономить достаточное количество ресурсов компьютера, которые иначе ушли бы на сложный рендеринг объекта. Вообще текстуры - поистине бездонный источник решений для автора; с их помощью решаются вопросы хроматических свойств моделей, создаются карты прозрачности и рефлекции и даже имитируется топология поверхности.


Графику на диету!

Изображение стоит тысячи слов. Кто из выдающихся старых гуру сказал это?

Не сомневаюсь, кто-нибудь напишет мне и скажет кто это был, но звучит эта фраза для меня также как "мой старый друг - Билл Шекспир".

Кто бы это ни был, мне интересно не забыл ли он о Сети тогда. Возможно нет, но знаете почему? Ну наверняка в наши дни вы не найдете в Сети большого количества картинок эквивалентных тысяче слов.

Хватит гадать, давайте для разнообразия взглянем на некоторые реальные цифры.

Текстовый файл из тысячи слов равняется примерно 25 строкам обычного текста на веб-странице. Размер этого текста в формате txt около 5,767 байт. Очень незамысловатый и простой 16-тицветный GIF, оптимизированный по максимуму, даст нам одно изображением размером 150х150 пикселей. Не много же мы имеем, чтобы изобразить Бруклинский мост, или даже качественную репродукцию почтовой марки в данном случае! Размер этого графического файла будет примерно 5,746 байт.

Это реальные цифры - я проверил.

Таким образом, Вы имеете выбор: либо текст в 25 строк, либо не очень хорошего качества изображение почтовой марки или чего-либо еще, занимающее то же пространство на экране.

ОК, я знаю, графика несет в себе гораздо больше, чем просто изображение. С ней "место" приобретает симпатичный вид, она дает глазам желанный отдых после всех усилий с каракулями как буквы и слова. Это несомненно так, но за счет некоторых жертв.

Слишком много графики = слишком большой размер файла = большое время загрузки = слишком мало заинтересованных посетителей - терпеливых, готовых дождаться наших невиданных произведений искусства. Что же делать? Без графики наши страницы будут унылыми

Легко! Графика - на диету! Вот дюжина советов как это делается.

1. Обрезка изображений.

Это может показаться очевидным, но самый эффективный путь ускорить загрузку графических файлов - это использовать изображения меньшего размера. Обрезайте изображения для фокусировки на важном, или уменьшайте размер пропорционально, при этом ненужные детали не будут различимы.

2. Снижение цветности.

Если Вы используете формат GIF для изображений, простой путь сократить размер файла - использование графического редактора для сокращения глубины цвета. Параметр "Глубина цвета" определяет количество цветов доступных в цветовой палитре изображения. Максимальная глубина цвета для GIF - это 8 бит, что означает палитру из 256 цветов. Я стараюсь сократить цветность настолько сильно насколько это возможно, часто до 4 бит (16 цветов), если изображение по прежнему выглядит хорошо.

3. Использование формата JPEG для фотографий.

Несмотря на то, что GIF - дедушка форматов изображений используемых в Интернет, JPEG стал лидирущим форматом для фотографий. Оба и GIF и JPEG сжимают изображения, но JPEG более эффективен для изображений с множеством цветов, особенно фотографий. Другое преимущество формата JPEG - глубина цвета - формат GIF не может иметь больше 256 цветов, а JPEG может использовать полную 24-х битную цветовую палитру для создания миллионов цветов и оттенков.

Часто изображения в формате GIF имеют больший размер, но худшее качество изображения, чем формат JPEG. Так не будет всегда - в определенных обстоятельствах таких как изображение имеющее всего несколько цветов, GIF будут равнозначны или даже превосходит качество JPEG при меньшем размере файла. Но для фотографий формат JPEG - наилучший выбор.

4. Использование изображений с низкой четкостью в процессе загрузки.

Если Вы не можете уменьшить скорость загрузки вашего сайте, интересным приемом будет создание видимости быстрой загрузки. Это использование параметра lowsrc, предложенного фирмой Netscape во 2-ой версии браузера Netscape Navigator и ныне поддерживаемого также браузерами Internet Explorer версий 3.0 и выше. Использование этого параметра приведет к тому, что браузер будет показывать изображение пониженного качества в процессе загрузки обычного изображения. Эта техника позволяет создать видимость того, что увидит после полной загрузки посетитель. Это крайне важно для image maps, поскольку это позволит пользователю увидеть активные области и перейти по ним на другие страницы еще до того как полное изображение загрузится целиком.

Параметр lowsrc в теге <IMG> выглядит так:

<IMG src="highres.gif" lowsrc="lowres.gif">

Конечно, это Ваш выбор сравнивать размер этих двух файлов или нет. Обычно используют или меньшее по размеру изображение, или черно-белое как промежуточное изображение. Если Вы предопределили размер изображения, браузеры растянут меньшее изображение до указанных размеров.

На заметку: Этот прием в действительности не делает время загрузки меньше. В действительности это увеличивает общее время загрузки, добавляя дополнительное изображение. Но, если все сделано верно, впечатление от страницы улучшится поскольку пользователь увидит результат гораздо быстрей.

5. Используйте чересстрочный gif-формат (interlaced)

Для быстрой загрузки с целью предварительного просмотра изображений удобно пользоваться их копиями с низким разрешением. Копия с низким разрешением может быть в jpeg-формате, а полное изображение - в gif и наоборот. Но если вы не хотите для каждой своей картинки создавать две копии - с низким и высоким разрешением, - лучше всего применить чересстрочный gif-формат.

Чересстрочные гифы появляются на экране быстро в виде картинки с низким разрешением и постепенно перерисовываются в высококачественное изображение. Пользователь сам может решить, дожидаться ли конца загрузки или нет. Это очень удобно. Большинство графических редакторов позволяют преобразовать любое изображение в чересстрочный gif-формат.

6. Указание высоты и ширины изображения в теге <IMG>

Не ленитесь, везде где Вы используете тег <IMG> всегда включайте параметры "height" (высота) и "width" (ширина). Это позволит браузеру сразу определить сколько места потребуется под изображение, что приведет к тому, что браузер сможет загружать текст вокруг графики, без ожидания полной загрузки изображения. Большинство графических редакторов имеют функцию определения размеров для любого поддерживаемого графического формата.

Например, если Ваше изображение находится в файле image.gif и имеет размер 50 пикселов на 100 пикселов, тег <IMG> должен выглядеть так

<IMG src="image.gif" height="50" width="100">

7. Не используйте масштабирование изображений

Вы можете быть поражены простым способом изменения размеров изображения в виде изменения параметров высоты и ширины изображения в теге <IMG> вместо обрезки изображения или изменения его размеров в графическом редакторе. Это не самая лучшая идея...

Во-первых, Вы потратите чудовищное количество времени, корректируя числовые значения для того, чтобы избежать искажения изображений. Во-вторых, масштабирование изображений впустую увеличивает общий траффик - Вы пересылаете изображения большего размера, чем это нужно. Также Вы требуете браузер пользователя выполнить работу, которая приведет к задержкам, так браузер масштабирует изображения перед тем как показать. В общем, самый лучший путь - это использование графического редактора для корректировки изображения к нужному размеру.

8. Масштабирование одноцветных изображений для создания полос.

Даже хотя Вы не должны масштабировать изображение, есть один случай когда этот прием будет Вам полезен. Если Вам нужны одноцветные полосы на странице, Вы можете сократить время загрузки, заменив использование полноразмерного GIF созданием изображения размером 1 на 1 пиксель и установив атрибуты height и width под нужный размер для каждой полосы.

Хотя возможность задержки все же существует, это должно быть быстрей, чем загружать полноразмерное изображение.

9. Обрезка анимированных GIF.

Анимированные GIF'ы представляют из себя серию изображений - одна над другой, - для того, чтобы создать эффект движения. В зависимости от применяемой техники, анимированные GIF могут быть меньшими, чем равнозначные ява-апплеты. Но реальное преимущество состоит в том, что браузеру не нужно запускать консоль языка Ява, чтобы показать апплет.

Проблема состоит в том, что так как анимированные GIF - просто серия обычных GIF, файл может разрастись до неприемлемого размера. Один способ проконтролировать этот рост - начать с GIF c фоновым рисунком, и затем создавать анимацию, помещая изображения меньшего размера на первое изображение. Большинство современных GIF-аниматоров поддерживают эту функцию, которая называется "leave in place", давая Вам возможность нарисовать серию GIF меньшего размера вместо использования полноразмерных GIF для каждой ячейки анимации.

10. Использование предпросмотра.

Другой достаточно простой путь минимизировать обьем графики на Вашей странице - использование предпросмотра. Суть заключается в следующем: создаются изображения меньшего размера, и связываются ссылкой со страницей с большим изображением.

Посетители сайта кто не хочет смотреть полноразмерные изображения избежат загрузки больших и неинтересных для них изображений. Кто хочет - нажмет ссылку на картинке и увидит полное изображение.

Большое количество программ могут создавать такие галереи изображений, как, например, FrontPage 98.

11. Разбивка изображений на части используемые на других страницах

Если Вы используете изображения или его части в других местах Вашего сайта, Вы можете увеличить скорость загрузки разбивая их на меньшие фрагменты. Например, большинство больших изображений на сайтах в действительности набор небольших GIF, а не один большой GIF. Таким образом браузеру нужно будет загрузить только небольшой новый фрагмент при нажатии или наведении мышкой на меню на Вашем сайте.

Такое изображение может даже быть набором GIF и JPEG файлов - каждый формат используется если дает лучшее качество при наименьшем размере файла. Это достигается разрезкой и оптимизацией выбранных областей изображения. Если Вы уже задумались над этими словами - Вам нужен хороший графический редактор, например PhotoShop.

Не усердствуйте - Вам придется иметь дело с созданием таблицы которая свяжет все части в единое целое. Чем больше частей, тем сложней структура этой таблицы. Вы нужно соблюдать разумное соотношение между сложностью единой таблицы и размером экономии в процессе подобной оптимизации.

Природа используемых протоколов используемых в WWW заставляет обратить внимание на один момент. Например браузеры и веб-сервера использующие ранние версии HTTP вынуждены каждый раз получать изображение снова. Это значит, что загрузка большого изображения возможно будет происходить быстрее, чем в случае набора меньших изображений. Вы должны иметь это ввиду, используя вышеописанную
технику.

12. Текстовая версия сайта или альтернативный текст

Конечно, лучший путь увеличить скорость загрузки сайта - убрать графику вообще. Если Ваш сайт относительно небольшой, Вы можете подумать о создании текстовой версии сайта, чтобы посетители с небольшой скоростью соединения или с отключенной графикой могли просматривать Ваш сайт

Если Вы не хотите делать текстовую версию сайта, включите параметр ALT в код описывающий изображение. Большинство браузеров показывают его содержание на месте изображение, если показ графики отключен в браузере посетителя Вашего сайта. Использованием этого параметра Вы покажете такому пользователю, что он теряет.

Например, если у Вас есть изображение моста размером 100 на 250 пикселей, тег <IMG> при использовании параметра ALT может выглядеть так:

<IMG src="bridge.gif" height="100" width="250" ALT="Мост">

Использование графики всегда будет предполагать больший обьем Ваших страниц, чем при использовании простого текста, - вы вынуждены оптимизировать графику по максимуму.

Но без использования графики также обойтись нельзя - она добавляет стиль и цвет на Ваши страницы, делая их более приятными для глаза. Уменьшите ее обьем до минимально возможного размера и посетители скажут Вам спасибо за Ваше время.


Как работает формат JPEG?

Знание некоторых принципов возмещает незнание многих фактов. Сегодня мы поговорим о технологии сжатия JPEG и о том, за счет чего достигаются столь сильные степени сжатия.

Процесс сжатия по схеме JPEG состоит из нескольких шагов. На первом шаге производится преобразование изображения из цветового пространства RGB в пространство YUV, основанное на характеристиках яркости и цветности. Вся дальнейшая работа производится именно с этим цветовым пространством, которое благодаря некоторым своим характеристикам позволяет получать нам столь большие степени сжатия.

Что же такого необычного в YUV представлении цвета по сравнению с RGB? А то, что оно наиболее близко к "естественному", тому, которое неосознанно выполняет человек. Y-компонента, или яркость, тесно связана с качеством картинки. Точнее сказать Y - это и есть картинка, только черно-белая. Компоненты U и V содержат информацию о цвете и позволяют нам раскрашивать Y-картинку.

На следующем после преобразования шаге изображение разделяется на квадратные участки размером 8х8 пикселей. После этого над каждым участком производится т.н. дискретное косинус-преобразование (ДКП). При этом выполняется анализ каждого блока, разложение его на составляющие цвета и подсчет частоты появления каждого цвета.

Человеческий глаз устроен таким образом, что наиболее чувствителен именно к яркостной составляющей изображения (Y-компонента) и наименее к цветовым. Причина этого феномена лежит в физиологии. Вы, наверно, помните, что зрачок состоит из т.н. палочек и колбочек. Ну так вот, палочки - это сенсоры, воспринимающие именно яркостную составляющую, а колбочки - цветовую. Причем палочек на порядок больше, чем колбочек, и они гораздо более чувствительны к свету. Вспомните поговорку "Ночью все кошки серы". Почему так? Почему вечером все теряет цвет? Именно из-за того, что количества падающего на зрачок света не хватает для того, чтобы вызвать реакцию колбочки. Но и чувствительность человеческого глаза к разным цветам тоже величина не постоянная. Зрачок более чувствителен к нижней части цветового спектра, нежели к верхней. Формат JPG как раз и учитывает эти особенности.

Анализируя частотную информацию о появлении цветов, удается избавиться от части информации уже в процессе квантования. При этом цвета в верхней части спектра исключаются, что практически не сказывается на зрительном восприятии образа. Также исключается часть яркостной информации. Грубо говоря, JPG просто отбрасывает от яркостной составляющей половину полезного сигнала, а от цветовой 3/4. Это, конечно, примерно, т.к. существуют градации и более сложные схемы сжатия.

Количество информации, исключаемой при сжатии, зависит от требуемого качества изображения. При максимально-высоких уровнях сжатия детали полностью стираются, и блок становится серым. При средних и низких уровнях сжатия в файле сохраняется _примерная_ информация о цвете данного участка. Величина этой "примерности" напрямую зависит от степени сжатия. И это нужно понять, что в отличие от обычных форматов, сохраняющих изображение поточечно, JPG сохраняет примерные цвета. Если говорить научным языком, то JPG использует для сохранения ряды Фурье и при больших степенях сжатия просто отбрасывает члены ряда высшего порядка. И каждый раз при воспроизведении изображения на экране компьютер производит синтез. Причем, достаточно ресурсоемкий и заметный на медленных компьютерах. Из этого следует одно замечание - если Вы сохранили какой-нибудь рисунок в формате JPG, то восстановить его обратно до последнего пикселя невозможно! Именно из-за этого формат называется "форматом с потерями", и именно поэтому не рекомендуется пересжимать JPG-изображения, т.к. они обязательно станут хуже. А если это сделать 10 раз?

Информация о яркости и цвете затем кодируется так, что сохраняются только отличия между соседними блоками. В результате блоки представляются строками чисел, которые можно сжимать дальше. Поскольку в результате обработки блоки содержат много нулей, последняя стадия кодирования (выполняемая по алгоритму Хаффмана - подобного тому, что применяется в архиваторах) дает хорошие результаты. Отсюда еще небольшое замечание - сжимать JPG-файл архиватором не имеет никакого смысла, ведь он уже сжат. Полученный архив наверняка будет больше по размеру, чем исходная фотография.

Таким образом, первоначальные 24 бита на элемент изображения или 1536 бит (192 байта) на блок превращаются в горстку бит, которые описывают зрительные характеристики всего участка изображения.


КОМПЬЮТЕРНАЯ ГАЗЕТА

Чайнику: сканирование и коррекция изображений.

После сканирования мы, как правило, сталкиваемся с тремя основными задачами, решение которых строго обязательно. Это:
Цветокоррекция. Практически ни одна модель сканера, даже за 50 000 долларов, не даст вам стабильно хороший цвет. Слава богу, цветокоррекция в современных программах не сложна и освоить ее может каждый за несколько часов (разумеется, на любительско-полупрофессиональном уровне).
Ретуширование. Так как сканируем мы с реальных объектов, то не стоит удивляться необходимости последующего удаления царапин, пыли и тому подобного — эти картинки подвержены всем видам деформации.
Формокоррекция. Наш собственный термин, означающий необходимость выправлять геометрические контуры изображения. Возникает в основном из-за того, что практически невозможно абсолютно ровно положить фотографию на сканер.
Именно исходя из этих трех задач и будет построена данная статья.

Цветокоррекция
Самая важная и сложная задача для пользователя после сканирования. И проблема совсем не в том, что цветокоррекция сложна по технике исполнения. Дело совсем в другом. Очень трудно, глядя на изображение после сканирования, определить, что именно в нем плохо, что именно нуждается в изменении.
Некоторые подходят к решению попроще и приводят сканированное изображение в полное соответствие с оригиналом. Это также очень плохо — кто сказал, что, например, ваша фотография имеет достаточно хорошие цвета? Даже профессиональные фотографы тратят огромное количество времени в процессе исправления цветов своих работ, что же говорить, к примеру, о фотографиях, полученных при помощи "мыльницы".
Кроме того, для нормального определения цвета у вас должен быть откалиброванный монитор. Калибровка это сама по себе сложная и тонкая задача, достойная отдельной статьи.

Также применяется следующий вариант настройки сканера. В цивилизованных странах и в Сети можно купить небольшие брошюрки, которые разбиты на цветные квадраты. И под каждым квадратом подписан RGB или CMYK код данного цвета. Вы сканируете этот лист и в PhotoShop при помощи палитры Info проверяете качество сканирования. Если результаты расходятся, то проводится коррекция входных параметров в программе-оболочке сканирования.
Но, повторимся, это сделать желательно, однако не обязательно. Можно корректировать каждую отдельную фотографию вручную. Но монитор все же должен быть откалиброван.
Итак, перейдем от лирического вступления непосредственно к описанию основных приемов цветокоррекции в PhotoShop.
Практически весь инструментарий, применяемый при цветокоррекции, находится по пути Image->Adjust (Изображение->Настройка). Опишем кратко все.

Levels (Уровни). Неплохой инструмент для тонкой настройки цвета. Но сразу же советуем забыть его и не вспоминать. Причина проста. Он не является уникальным по возможностям, а всего лишь копирует возможности Curves (Кривые), при этом сильно их ухудшая (правда, это мысль очень авторско-субъективна). Все, что вы можете сделать с помощью Levels, вы сделаете Кривыми, но гораздо качественнее. А зачем овладевать двумя инструментами, если достаточно одного?

Auto Levels (Авто уровни). Автоматически настраивает изображение. Во многих книгах вы можете прочитать, что это ерунда и никакого выигрыша ни в чем дать не может. Это спорно. Авторы, к примеру, сперва всегда запускают этот инструмент. И довольно часто он предлагает очень качественные цветовые решения, прийти к которым самостоятельно не так просто. Но в большинстве случаев, конечно, автоматика предлагает не лучший вариант. Тогда приходится нажимать Ctrl+Z (Отмена).

Auto Contrast (Авто контраст). А вот этим лучше не пользоваться вообще — никакого нормального контраста вы не получите (за очень редким исключением).

Curves (Кривые). Самый лучший инструмент для цветокоррекции из всех когда-либо созданных. До невероятности продуманный и между тем очень простой механизм делает Кривые единственным незаменимым инструментом этой группы. Почти вся профессиональная работа по коррекции делается при помощи Curves, за очень редким исключением (иногда, например, куда удобнее использовать Selective color (Выбранный цвет)).

Color Balance (Цветовой баланс). Инструмент, позволяющий изменять соотношение между основными цветами. Функционально он является калькой с Кривых, однако молодым пользователям куда легче осваивать его, чем решать аналогичные задачи при помощи Curves.

Brightness/Contrast (Яркость/Контраст). Как и предыдущий, повторяет возможности кривых. Используется в основном из-за простоты.

Hue/Saturation (Цвет/Насыщение). Инструмент похож на предыдущий. Позволят настраивать цвет, насыщение, освещенность. Лучше то же самое делать Кривыми.

Desaturate (Обесцветить). "Убирает" из картинки информацию о цвете. Взято в кавычки, потому что эта фраза подойдет только для перевода изображения в Grayscale формат, а в данном случае ничего подобного не делается. Файл только внешне становится черно-белым, его цветовой режим при этом не меняется.

Replace Color (Заменить цвет). Крайне полезный по жизни инструмент. Позволяет заменять один или несколько цветов на другие.

Selective Color (Выбранный цвет). Достаточно удобный и тонкий инструмент настройки цветовой составляющей изображения при помощи бегунков. Во многом он даже удобнее Кривых, однако все его возможности лишь повторяют аналогичные в Кривых.

Variations (Варианты). Немного любительский по форме инструмент, однако не стоит его недооценивать. Он позволяет настроить цвет, видя предварительно, что даст то или иное изменение. А так как пользователь зачастую конкретно не знает, что именно ему нужно, то это неплохая подмога.
Итак, уже понятно, что лучше всего настраивать изображение при помощи Кривых. Именно поэтому подробно опишем только его.
Кривые (curves) предназначены для работы с яркостью. При необходимости заменить на всем изображении одно значение яркости на другое, не влияя при этом на остальные, вам никак не обойтись без кривых. Изменять яркость изображения можно как в целом, так и для отдельных цветовых составляющих.

Чтобы открыть этот инструмент, выполните команду Image->Adjust->Curves (Изображение->Настройки->Кривые) или нажмите сочетание клавиш Ctrl+М. После этого перед вами появится диалоговое окно Curves (Кривые). Сейчас мы предлагаем вам ознакомиться с основными настройками, расположенными в этом окне.

— Channel (Канал). Выбор канала, с которым вы будете работать. Изображение может быть отредактировано как целиком, так и по отдельным каналам. Причем кривые для разных цветовых составляющих могут сильно различаться. Гораздо чаще приходится корректировать одновременно и кривые каналов, и общую кривую изображения.
СОВЕТ
Если вы редактируете старую либо не совсем удачную фотографию и вам необходимо изменить яркость только одного цвета, то просто выберите канал, на котором располагается его большая составляющая, и измените настройки при помощи кривых только в нем.

— Brightness graph (Поле кривых). В этом поле изображается сама кривая, которая обуславливает конечный результат вашей работы. Линия, которую вы видите на этом поле, является графиком зависимости выходной яркости от входной, причем этот график вы можете изменять так, как вам заблагорассудится. На горизонтальной шкале, расположенной под полем кривых, есть входящие яркости. На вертикальной — выходящие. Для удобства пользователей все поле разбито на 4 квадранта. Если вам необходимо построить более точную кривую, то вы можете увеличить число квадрантов с 4 до 10. Для этого нужно щелкнуть мышью внутри поля кривых при нажатой клавише Alt.

— Brightness bar (Шкала яркости). По умолчанию (если вы работаете с RGB-изображением) темный конец данной шкалы расположен слева и цвета измеряются значением яркости, и именно по этому значению и производится воздействие на них при использовании кривых. Если вы щелкнете мышью по горизонтальной шкале, то темная и светлая часть поменяются местами. В таком виде перед вами появится данная настройка, если вы работаете в черно-белом режиме либо режиме CMYK. Тогда цвета будут измеряться так, как принято в типографской печати, от 0 до 100%.

— Curve tools (Инструменты кривой). Данные инструменты применяются для создания кривой. Всего существует 2 инструмента: Карандаш и Гладкая кривая. Инструмент Гладкая кривая активен по умолчанию. С его помощью вы можете добавлять новые точки на вашу кривую, передвигать которые можно мышью. Если вам необходимо удалить точку, то щелкните по ней мышью при нажатой клавише Ctrl. Второй инструмент — Карандаш. Он работает так же, как и инструмент рисования с аналогичным названием, расположенный в основной палитре: вы можете рисовать кривые по любому пути.

— Input/Output (Входные/Выходные значения). Здесь отображаются значения яркости или интенсивности (в зависимости от установки шкалы яркости, см. пункт "Шкала яркости"), соответствующие текущему положению курсора.

— Load/Save (Загрузить/Сохранить). Вы можете сохранить любую из созданных вами кривых или загрузить готовую из файла с расширением .amp.

— Smooth (Сглаживание). Щелкните по этой кнопке после применения инструмента Карандаш — и ваша кривая станет плавной, после чего будет можно редактировать ее по точкам при помощи инструмента Гладкая кривая.

— Auto (Авто). Благодаря этому параметру программа автоматически отображает самые темные пиксели на изображении в черные, а самые светлые — в белые.

— Eyedroppers (Пипетки). Позволяет выбирать на изображении пиксели, значения яркости которых принимаются за крайние точки шкалы.

Когда вы открываете диалоговое окно Curves (Кривые), то перед вами появляется прямая линия, в которой все входные значения равны выходным. Если вы впервые столкнулись с кривыми, то попробуйте изменить настройки при помощи инструмента Гладкая кривая, после этого вам станет понятно, как создавать более сложные зависимости и по какому принципу они будут работать.
Изогните кривую вверх — и все изображение осветлится, вниз — и оно станет темнее.
Если у вас возникла потребность изменить яркость пикселей неодинаково, то вам необходимо построить кривую с несколькими перегибами. Наиболее простой пример — это увеличение и уменьшение контрастности. Если точки перегиба будут расположены близко друг к другу, а отрезок между ними образует горизонталь, то контрастность уменьшится. Это следует из того, что яркость пикселей на данном отрезке после преобразования станет примерно одинаковой. Если же линия будет близка к вертикали, то контрастность, наоборот, сильно увеличится из-за того, что близкие по яркости пиксели приобретут большой разрыв яркости.
И, наконец, несколько слов о кривых произвольной формы. Самый простой способ задать такую линию — воспользоваться Карандашом. Сразу после его применения у вас получится довольно грубый эффект. Существует несколько способов смягчить его.
Воспользоваться кнопкой Smooth (Сглаживание). После того как вы щелкнете по ней мышью, все разрозненные кусочки вашей кривой соберутся в единое целое. Данной командой можно пользоваться неоднократно, до тех пор, пока вы не добьетесь желаемого результата.

ВНИМАНИЕ
Не переусердствуйте со сглаживанием кривой, так как многократное его применение приведет к тому, что ваша кривая, в конце концов, приобретет свою первоначальную форму, то есть ту, которая была установлена по умолчанию.
Сразу после применения Карандаша воспользуйтесь вторым основным инструментом создания кривой, а именно Гладкая кривая. В итоге ваша кривая представится в виде линии, на месте точек перегиба которой будут стоять маркеры, которые можно передвигать, увеличивая либо ослабляя тем самым эффект сглаживания.
Таким образом, кривые — инструмент просто уникальный по своим цветокорректирующим возможностям, и владение им значительно расширяет возможности пользователя. На иллюстрации вы можете увидеть, как улучшился вид неудачно отсканированной фотографии после обработки Кривыми (надеемся, что в газетной печати это будет видно).

Ретуширование
Еще одна задача, с которой приходится сталкиваться всем, кто имеет отношение к сканированию. Под ретушированием понимается исправление отснятых физических недостатков, которые были на сканируемом материале.
Чтобы внести некоторую ясность в ретуширование, систематизируем проблемы:
Крупные дефекты: оторванные края у фотографий, следы помятостей, царапины, стертости.
Мелкие дефекты: следы въевшейся пыли, небольшие царапины.
Начнем описание решения с последнего.
Почти на каждой старой фотографии можно найти немало следов времени. В основном это мелкие царапины и своеобразный шум, появившейся в результате въедания пыли в поверхности.
PhotoShop 6.0 предлагает для этого использовать фильтр Dust& Scratches: Filter->Noise->Dust&Scrat-ches (Фильтр->Шум->Пыль и Царапины). По сути, это просто размывающий фильтр, мало чем отличающийся от Gaussian Blur (Размытие по гауссу). Мелкие дефекты исчезают благодаря сглаживанию разницы между смежными пикселями, своеобразному размытию.
Однако стоит ли использовать этот фильтр? В большинстве случаев несомненно стоит. Он позволяет просто и качественно исправить недостаток изображения. Но при этом уменьшается контрастность, особенно это заметно на мелких деталях. Что делать?
Прежде всего, лучше эту операцию производить с разрешением минимум 300 PPI (Pixel Per Inch). Почему? Все очень просто. Минимальное значение сглаживания составляет 1 Pixel. Если у вас низкое разрешение, то можно очень сильно испортить картинку — мелкие детали полностью исчезнут.
Во-вторых, применяйте фильтр Dust&Scratches в максимально маленькой степени. То есть, Radius берите таким, чтобы большая часть дефектов исчезла, а контрастность не слишком уменьшилась. Не стоит добиваться полного исчезновения царапин — это вряд ли получится, некоторые нужно будет отнести к крупным и удалять вручную. После применения Dust&Scratches можно несколько восстановить контрастность фильтром Sharpen More: Filter->Sharpen->Sharpen More. Однако, бывают случаи, когда применение этого фильтра, наоборот, испортит изображение, так что используйте его осторожно.

Несколько более сложно обстоят дела с крупными повреждениями. Их природа может быть самой разной, и поэтому самой разной может быть и техника "лечения". Но в основном можно выделить два приема.
Как правило, практически невозможно найти абсолютно уникальное место на фотографии. Любой фрагмент можно восстановить, скопировав что-то подобное. К таким местам можно отнести снег, траву, небо, кожу и многое другое. Легче назвать то, что невозможно скопировать. Почти всегда это глаза — их редко можно передать копированием, нужно дорисовывать.
В качестве инструмента копирования используется, как можно догадаться, Clone Stamp. Никаких конкретных рекомендаций в общем нельзя определить, так как каждый отдельный случай сильно разнится от другого. Вы со временем сами научитесь определять, какую область можно использовать в качестве источника для копирования, а какую нет. Это совсем не сложно.
Зачастую лучше использовать не Clone Stamp (Штамп), а Pattern Stamp. К таким случаям можно отнести работу с текстурными, ярко выраженными поверхностями. Это снег, песок, иногда кожа, облака, лед и тому подобное. Вы должны найти достаточно большую область хорошего качества и определить ее как пример текстуры Edit->Define Pattern (Правка->Определить образец).

Разумеется, и этой возможностью необходимо пользоваться с умом. К примеру, кожа очень редко имеет одинаковую освещенность на большой площади, поэтому использование Pattern Stamp сильно затруднено.
Также иногда можно просто дорисовывать фрагменты при помощи кисти (Art Brush). Это самый простой способ, но, увы, он встречается не так часто.
Постарайтесь определиться, что именно необходимо вашему изображению. Иногда никакая ретушь не нужна — достаточно цветокоррекции. Но, как правило, применяется и то и другое. Начинать, конечно, стоит с ретуши, а цветокоррекцией только, что говорится, наводить лоск.
На второй иллюстрации к статье показан результат ретуши ну очень старой фотографии из семейного альбома.

Формокоррекция
Отсканировать прямоугольную фотографию абсолютно ровно проблематично — мало кто может так удачно положить ее на сканер. Поэтому возникает необходимость выровнять ее.
Всегда старайтесь сканировать несколько больше площади, чем занимает необходимый объект. Причина вот в чем.
После сканирования сразу возьмите инструмент "Crop". Захватите рамкой отсканированное изображение. Если оно вошло хорошо, ничего не обрезается и не захватывается ничего лишнего, то можно сразу обрезать и не делать лишней работы.
А вот если угол линии контура изображения явно не равен прямому, то придется это исправлять. В шестом PhotoShop это совсем не сложно.
Возьмите инструмент Measure Tool (Линейка) и примените его к одной из боковых сторон. В панели состояния инструмента высветится вся необходимая информация, в том числе и угол наклона линии. Запомните это значение.

Возьмите инструмент Polygonal Lasso и при помощи четырех прямых линий выделите изображение. Затем нажмите горячее сочетание клавиш Ctrl+T (Free Transform). Обратите внимание на панель состояния. В ней отобразится ряд возможных к изменению параметров. Среди них будет и угол. Введите значение, которое запомнили. При введении цифры с "-" поворот осуществляется против часовой стрелки.
Вот и все, быстро и просто.
В заключение хотелось бы сказать, что описанное — это очень поверхностная информация. Одна цветокоррекция стоит целой серии статей. Однако для непрофессиональной работы описанного, надеемся, хватит.


КОМПЬЮТЕРНАЯ ГАЗЕТА

Основные типы графических файлов

Вы обратите внимание, что эта статья несколько привязана к PhotoShop. Причина этому ясна — этим пакетом в той или иной степени успешно умеют пользоваться практически все, кто хоть как-то связан с графикой.
Серия же про Photo-Paint 10 будет продолжена без каких-либо изменений. Мне кажется, что эту статью будет полезно прочитать всем молодым в графике пользователям, вне зависимости от предпочитаемой программы.
В настоящее время существует огромнейшее количество различных графических форматов. Причина этому кроется в начале 90-х годов, когда еще на рынке компьютерных графических программ не сложилось положение однозначного лидерства нескольких пакетов.
В те уже весьма отдаленные годы практически каждая фирма-разработчик создавала свой собственный формат.
Сейчас ситуация сильно изменилась. Вряд ли можно назвать и десяток форматов, использующихся действительно повсеместно. Но представители этой небольшой группы являются лучшими в своем роде, являются стандартами.
Так чем отличаются различные форматы растровых графических файлов? Прежде всего, назначением, а уже потом из этого вытекают другие свойства. Условно все типы можно поделить на две большие группы по назначению:
1. Для отображения на экране монитора (чаще всего использования в Интернет).
2. Для последующей печати.
Кроме непосредственно графической информации, то есть информации о пикселях, некоторые графические файлы могут хранить еще много другого. Это дополнительные каналы, комментарии, векторные элементы и так далее. Разумеется, хранение информации, кроме графической, делает размеры файлов несколько больше.
PhotoShop 6.0 и Photo-Paint 10 поддерживают подавляющее большинство современных растровых графических форматов. И это неудивительно — пользователям часто приходится в качестве ресурсов использовать самые разные источники. Поэтому знание форматов, поддерживаемых изучаемой программой, есть неотъемлемая часть эффективной работы в ней.
Также стоит помнить, что каждый тип файлов обладает присущими только ему достоинствами, иначе он не выдержал бы конкуренции и отбора. Следовательно, знание этих свойств может сильно облегчить работу, так как в определенных обстоятельствах могут быть затребованы узко определенные свойства, которые может дать только один формат.
В этом пункте мы уделим несколько больше внимания одним форматам и несколько меньше другим. Причина этому проста и банальна — частота использования и полезность.

PSD (Photoshop document)
Собственный формат PhotoShop. Основное достоинство — позволяет сохранять абсолютно все, что можно создать в данной программе: слои, дополнительные каналы, комментарии, пути и так далее. Разумеется, это очень полезное свойство — зачастую работа над одним изображением ведется в течение нескольких дней, и если бы не было таких возможностей в формате PSD, возник бы целый ряд проблем.
ВНИМАНИЕ
С каждой новой версией PhotoShop изменяется и формат PSD. Поэтому если вы хотите сделать свое изображение в этом формате доступным более ранним версиям, то выполните следующее: Edit (Preferences->Saving files->Maximize backwards compatibility in Photoshop format (Правка->Предпочтения->Максимальная совместимость PhotoShop формата).
В настоящее время данный формат файлов поддерживают практически все более или менее приличные программы редактирования растровой графики, поэтому сохранение изображений в этом формате делает их доступными и другим программам.
В PSD используется стандарт сжатия RLE, что делает его размеры несколько меньше без потери качества.
ПРИМЕЧАНИЕ
RLE (Run Length Encoding) — один из методов компрессии графических файлов. Основан на поиске совпадений в строках изображений. То есть, если у вас подряд идет 40 черных пикселей, то записаны они будут не как черный, черный, черный..., а 40 черных. Этот метод эффективен далеко не всегда, а только в случае достаточной повторяемости, то есть одноцветности областей изображения. Однако, при использовании RLE не ухудшается, в отличие от JPEG, качество самого изображения.
Таким образом, PSD идеальный формат для промежуточного и последующего качественного хранения изображений.

BMP (Windows Device Independent Bitmap)
Собственный формат операционной системы Windows. Разрабатывался в свое время специально для нее программистами компании Microsoft. Поддерживает индексированный (256 цветов) и RGB цвет. Данный формат понимают абсолютно все графические и не только редакторы, работающие под Windows. На этом немногочисленные достоинства BMP заканчиваются, и начинаются многочисленные недостатки:
1. BMP абсолютно не подходит для Интернет.
2. BMP это крайне неудачный выбор для последующей распечатки.
3. BMP аппаратно зависимый формат.
4. Он некорректно использует RLE сжатие.
5. Этот формат занимает неоправданно много места.
Таким образом, можно сделать вполне определенный вывод — использование BMP будет ошибкой практически в любом случае за исключением дальнейшего использования в программах, которые никаких других форматов не понимают.

GIF (CompuServe Graphics Interchange Format)
Один из самых известных форматов файлов, на сегодняшний день в основном используется для нужд Интернет.
Этот формат, как можно понять из названия, был разработан компанией CompuServe для более скоростной передачи изображений по своим одноименным сетям в 1987 году.
Первоначально это был формат, поддерживающий 256 индексированных цветов и больше ничего. Но вскоре один программист обнаружил неиспользованную возможность GIF — записывать в один файл несколько картинок и проигрывать их с определенным прерыванием.
Это, а еще поддержка прозрачности, стало основой обновления формата, который произошел в 1989 году, и отсюда название использующегося сейчас GIF — Gif89a.
Как вы уже смогли прочитать выше, GIF поддерживает прозрачность, причем прозрачными можно назначить несколько цветов. Реализуется это весьма несложно — за счет дополнительного альфа-канала, сохраняемого в файле.
В Gif используется LZW компрессия, что в сочетании с индексированными цветами делает этот формат почти идеальным для хранения и передачи малоцветных, с отсутствием сложного перехода цветов, изображений, к примеру, логотипов.
ПРИМЕЧАНИЕ
LZW компрессия — еще один вид сжатия изображений, идейно близкий к RLE. Идет поиск так называемых фраз (повторяющихся комбинаций разных цветов), и они записываются в виде ключей. В дальнейшем во всем изображении используются уже созданные ключи. Как можно понять, этот метод гораздо совершеннее RLE для областей с переходами цветов, однако кодировка в него требует больше системных ресурсов.
Также еще одно достоинство GIF — возможность использования Interlaced разверстки.
ПРИМЕЧАНИЕ
Interlaced — черезстрочные запись и чтение изображения. В результате сначала файл подгружается через строку, то есть в меньшем разрешении, а затем догружаются и остальные строки. Основное применение — Интернет, так как появляется возможность оценить содержимое изображения еще до его полной загрузки, а следовательно, и сэкономить время.
Все эти условия, а именно анимация, прозрачность, черезстрочная разверстка сделали GIF одним из использующихся во всемирной сети форматов. Но, повторимся, основной его недостаток — отображение только 256 цветов.

EPS (Encapsulated PostScript)
Один из лучших форматов для хранения информации для последующей распечатки. Использует облегченный вариант PostScript, а именно сохранение только одной станицы.
ПРИМЕЧАНИЕ
PostScript — одно из важнейших понятий в современной компьютерной графике. Это язык описания страниц для PostScript принтеров, к которым относится большинство современных профессиональных устройств. Его разработала компания Adobe, реализуя важнейший принцип WYSIWYG (What You See is What You Get), то есть "что вижу, то и имею". PostScript файлы содержат в себе графические изображения, шрифты, информацию о каналах и другое. Данный формат может хранить в себе информацию об абсолютно любых цветовых моделях, включая Duotone. Обычно этот формат используют в том случае, если информация в дальнейшем будет распечатана на PostScript-овском принтере.

JPEG (Joint Photographic Experts Group)
Несмотря на то, что мы рассматриваем Jpeg как графический формат, на самом деле это прежде всего принцип сжатия, один из самых распространенный в настоящее время.
Jpeg реализуется следующим образом. Если несколько упрощать, то сначала изображение разбивается на блоки 8*8 пикселей. Затем записываются два типа информации — усредненная информация о блоке и информация о его деталях. А далее, в зависимости от выбранной степени сжатия, выкидывается то или иное количество дополнительной информации. Понятно, что чем меньше будет файл по размерам, тем хуже будет его качество.
ВНИМАНИЕ
JPEG далеко не лучший формат для хранения ваших иллюстраций с целью дальнейшего редактирования. При каждом открытии и дальнейшем закрытии файла он переписывается заново, а следовательно, качество еще больше падает. Через некоторое время изображение может стать совершенно непригодным. Метод JPEG гораздо эффективнее, чем LZW или RLE. Можно добиться сжатия и в 100 раз, однако это происходит со значительным ухудшением качества, а LZW и RLE не меняют изображения, а сжимают на основе повторений уже имеющегося.
JPEG лучше всего использовать для фотографий, картинок и прочего, где можно допустить нечеткость краев и наличие небольшого "болота". Однако для хранения, к примеру, графиков лучше отдать предпочтение другим форматам, вроде PSD или Tiff. Большим недостатком JPEG является отсутствие возможности сохранять индексированные цвета. Можно сохранять в CMYK, но во многих программах появляются проблемы при чтении таких файлов.
В настоящее время JPEG — основной формат передачи изображений во Всемирной паутине. Причина этому ясна — ни один другой формат не может дать такого качества, а следовательно, и скорости загрузки файлов.
В PhotoShop при сохранении в этом формате вы можете выбрать один из трех вариантов JPEG:
1. Standard. Обычный вышеописанный JPEG.
2. Baseline. Улучшенный формат. Файлы занимают меньше места при том же качестве, но есть программы, которые некорректно отображают такие Jpeg. В основном применяется для Интернет.
3. Progressive. Кроме достоинств Baseline, добавлена еще Interlaced (черезстрочная) разверстка. Незаменимое свойство для использования файлов в Internet.

PDF (Portable Document Format)
PDF это формат, разработанный для быстрой передачи по сетям информации разного типа, в основном верстанных документов. На сегодняшний день в PDF могут входить графика, текст, гиперссылки, звук, видео и другое.
Все данные в PDF могут подвергаться компрессии, причем, что самое интересное, данные разного типа сжимаются разными методами, наиболее эффективными по отношению к ним.
PhotoShop 6.0 умеет сохранять как одностраничные, так и многостраничные PDF документы. Учитывая то, что этот формат на сегодняшний день все шире и шире применяется в Интернет, ему стоит уделить повышенное внимание.

PCX
Один из тех форматов, которые неплохи сами по себе, но вытесняются другими. PCX это формат, существующий только на PC (Personal Computer) совместимых компьютерах. Он может поддерживать цветовые модели Bitmap, Grayscale, Indexed color, RGB. Как видно из этого списка, PCX не поддерживает CMYK, что на сегодняшний день не очень хорошо.
Также этот формат не умеет в себе хранить дополнительные каналы.
PCX может использовать RLE компрессию, что делает его несколько более привлекательным для пользователей.
Вывод таков — лучше этот формат не использовать. Его прекрасно заменит куда более распространенный и надежный Tiff.

Pict file (Macintosh QuickDraw Picture Format)
Формат, использующийся в основном под управлением MacOs компьютеров Macintosh. Поддерживается всеми программами на этих компьютерах и даже служит стандартом буфера обмена. При сохранении в этом формате вы можете использовать цветовые режимы Bitmap, Grayscale, Indexed colors, RGB, CMYK. При сохранении в RGB можно сохранить еще один альфа-канал, а в остальных режимах — несколько.
Кроме того, Pict способен хранить векторную информацию и даже текст и (!) звук, правда, корректно только на Macintosh.
Этот формат имеет достаточно неплохие возможности для сжатия при условии наличия больших областей одного цвета (RLE).

Pixar
Формат, служащий специально для обмена с графическими станциями Pixar (рабочие станции профессионального hi-end уровня). На машинах Pixar в основном решаются задачи трехмерной графики и обработки видео. Очень сомнительно, что у нас это может оказаться кому-либо полезным.

PNG (Portable Network Graphics)
Третий кит (первые два — это JPEG и GIF), на котором держится графика в Интернет. Самый перспективный формат для развития всемирной сети.
PNG это молодой формат, специально разработанный в качестве замены для уже не отвечающего потребностям времени Gif.
PNG, в отличие от Gif, использует любое количество цветов, даже 48-битный цвет. Сжатие происходит по принципу, сходному с LZW, но несколько более совершенному, что дает неплохие результаты. PNG имеет возможность загружаться с черезстрочной разверсткой, причем двойной — по горизонтали и вертикали одновременно.
PNG также поддерживает прозрачность. И даже не просто прозрачность, а в разной степени, то есть могут сохраняться полупрозрачные (1-99%) пиксели. Это, конечно, расширяет возможности web-дизайна и делает этот формат весьма привлекательным.
Встроенная гамма-коррекция позволяет правильно отображать цвета на всех компьютерах, независимо от платформы.
Таким образом, PNG формат заслуживает внимания прежде всего людей, чьи работы направлены на дальнейшее использование во Всемирной сети. Кстати, мне кажется, что web-мастера незаслуженно мало используют PNG. Не так уж часто его встретишь, несмотря на широкие возможности. Может быть, причина такой ситуации — традиционализм старых мастеров и обучение на их опыте и книгах новых. Даже в лучших изданиях по дизайну в сети PNG почему-то незаслуженно мало описывают.

RAW
Самый гибкий формат для обмена изображениями между компьютерами разных платформ. Можно сохранять изображения в любой цветовой модели, включая Lab и мультиканальный, альфа-каналы.
Работа с этим форматом достаточно сложна, и поэтому если нет острой необходимости, его лучше не использовать вообще.

Tiff (Tagged Image File Format)
Самый распространенный на сегодняшний день в издательском деле графический растровый формат. Основные его достоинства:
1. Tiff аппаратно независим. Многие поэтому специально используют его для переноса изображений с PC на Macintosh и наоборот.
2. Tiff очень надежный формат. Практически все программы понимают его без проблем.
3. Этот формат поддерживает все цветовые модели, включая CMYK и PANTONE.
4. Tiff может нести в себе дополнительную информацию, к примеру, о контурах или альфа-каналах.
5. Tiff может использовать LZW компрессию, что делает его приемлемым для хранения файлов. Как вы знаете, LZW сжатие не изменяет качества изображения.
Таким образом, Tiff лучший выбор для тех, чьи работы предназначаются в будущем для распечатки.

В этой статье я не коснулась векторных форматов, так как считаю, что не стоит загонять в одно стадо овец и кур. Если читатели выскажут желание узнать побольше и о векторных, то я напишу такую статью. Хотя не уверена, что это будет кому-то необходимо — векторная графика ставит куда меньше вопросов, чем растровая. Возможно, из-за более узкой области применения.
В следующей статье мы вернемся к серии, посвященной эффектам в Photo-Paint 10. Если у вас есть какие-то вопросы или предложения, то, как говорил один литературный герой, пишите письма.


КОМПЬЮТЕРНАЯ ГАЗЕТА

Цвет и цветовые модели

Для чего нужен цвет
Большинство людей различают цвета, а те, кто занимается компьютерной графикой, должны четко чувствовать разницу не только в цветах, но и в тончайших оттенках. Это очень важно, так как именно цвет несет в себе большое количество информации, которая ничуть не уступает в важности ни форме, ни массе, ни другим параметрам, определяющим каждое тело.
Правильно подобранные цвета могут как привлечь внимание к желаемому изображению, так и оттолкнуть от него. Это объясняется тем, что в зависимости от того, какой цвет видит человек, у него возникают различные эмоции, которые подсознательно формируют первое впечатление от видимого объекта. Существует целая наука, изучающая влияние цвета на человека, но так как этот вопрос является достаточно спорным, то здесь его касаться не будем.
Итак, для чего же все-таки нужен цвет в компьютерной графике:
— Во-первых, конечно же, он несет в себе определенную информацию об объектах. Например, летом деревья зеленые, осенью — желтые. На черно-белой фотографии определить пору года практически невозможно, если на это не указывают какие-либо другие дополнительные факты.
— Цвет необходим также для того, чтобы различать объекты.
— С его помощью можно вывести одни части изображения на первый план, другие же увести в фон, то есть акцентировать внимание на важном — композиционном — центре.
— Без увеличения размера при помощи цвета можно передать некоторые детали изображения.
— В двумерной графике, а именно таковую мы видим на мониторе, так как он не обладает третьим измерением, именно при помощи цвета, точнее оттенков, имитируется (передается) объем.
— И, наконец, цвет используется для привлечения внимания зрителя, создания красочного и интересного изображения.
Конечно же, можно и даже создаются великолепные черно-белые творения, но так как мы живем в цветном мире, то намного привычнее видеть предметы, обладающие такой характеристикой, как цвет.

Что такое цвет
Что же такое цвет? Мы смотрим на предметы и, характеризуя их, говорим примерно следующее: он большой, мягкий, светло-голубого цвета. При описании чего-либо в большинстве случаев упоминается цвет, так как он несет огромное количество информации. На самом деле тело не имеет определенного цвета.
Если говорить о дневном освещении, то это белый свет. Попадая на предмет, он частично поглощается, а частично отражается, так вот именно отраженный спектр и видит человек.
Видимыми являются волны, лежащие в диапазоне от 760 до 380 миллимикрон, хотя некоторые животные видят и в областях ультрафиолетовых и ультракрасных волн. Зависимость цвета от длины волны представлена в таблице 1.
Первый, кто сумел разложить свет на различные составляющие, был Ньютон. Он заметил, что при пропускании света через призму он раскладывается на лучи разных цветов, после чего снова собирается воедино.
Основным заблуждением человека является то, что он видит то, что привык видеть, а именно если смотреть на хорошо знакомый красно-белый объект, освященный лишь зеленым светом, то мы все равно увидим два цвета — красный и белый, — хотя в мозг через глаз поступает иной сигнал, который игнорируется, точнее, преобразовывается в соответствии с тем, что он знает, а не с тем, что видит.
Дело в том, что зеленый свет не содержит красных лучей, следовательно, и отразить их предмет не может, а поэтому он поглощает весь спектр лучей, и оттого приобретает темный, близкий к черному, цвет. Что же касается белого, то он полностью отражает все падающие на него лучи и потому будет выглядеть зеленым.

Цветовой круг
Наука о цвете — это довольно сложная и широкомасштабная наука, поэтому в ней время от времени создаются различные цветовые модели, применяемые в той либо иной области. Одной из таких моделей и является цветовой круг, о котором уже неоднократно упоминалось в статьях, опубликованных ранее, и принцип которого заложен в таких операциях, как Invert — инвертировать (все цвета заменяются на те, которые находятся напротив в цветовом круге), Hue/Saturation — Цвет/Насыщенность (вращение происходит все по тому же кругу) и другие.
Многим известно о том, что существует 3 первичных цвета, которые невозможно получить и которые образуют все остальные. Основные цвета — это желтый, красный и синий. При смешивании желтого с красным получается оранжевый, синего с желтым — зеленый, а красного с синим — фиолетовый. Таким образом, можно составить круг, который будет содержать все цвета. Он представлен на рис. 1 и называется большим кругом Освальда.
Наряду с кругом Освальда есть еще и круг Гете, в котором основные цвета расположены в углах равностороннего треугольника, а дополнительные — в углах перевернутого треугольника. Схема такого круга представлена на рис. 2.
Друг напротив друга расположены контрастные цвета.
Как же образуются цвета в машинной графике? Ответить на этот вопрос однозначно невозможно, так как все зависит от того, какую цветовую модель использовать. Каждая из них хороша в определенной области, поэтому однозначного предпочтения отдать нельзя, да и не стоит, так как лучшего результата можно добиться, комбинируя различные возможности, предоставляемые программой.

Цветовая модель RGB
Это одна из наиболее распространенных и часто используемых моделей. Она применяется в приборах, излучающих свет, таких, например, как мониторы, прожекторы, фильтры и другие подобные устройства.
Данная цветовая модель базируется на трех основных цветах: Red — красном, Green — зеленом и Blue — синем. Каждая из вышеперечисленных составляющих может варьироваться в пределах от 0 до 255, образовывая разные цвета и обеспечивая, таким образом, доступ ко всем 16 миллионам. При работе с графическим редактором Adobe PhotoShop можно выбирать цвет, полагаясь не только на тот, что мы видим, но при необходимости указывать и цифровое значение, тем самым иногда, особенно при цветокоррекции, контролируя процесс работы.
Данная цветовая модель считается аддитивной, то есть при увеличении яркости отдельных составляющих будет увеличиваться и яркость результирующего цвета: если смешать все три цвета с максимальной интенсивностью, то результатом будет белый цвет; напротив, при отсутствии всех цветов получается черный.
При наложении отдельных каналов результат получается не совсем такой, как если бы смешивались краски, поэтому для того, чтобы внести ясность, остановимся на каждом из сочетаний подробнее.
При смешении красного и зеленого результатом будет желтый. Зеленого и синего — голубой, что ближе результату, получаемому на палитре. Синего и красного — фиолетовый, причем при изменении пропорций смешиваемых цветов можно получать как розовые, так и пурпурные оттенки.
Несомненными достоинствами данного режима является то, что он позволяет работать со всеми 16 миллионами цветов, а недостаток состоит в том, что при выводе изображения на печать часть из этих цветов теряется, в основном самые яркие и насыщенные, также возникает проблема с синими цветами.

Цветовая модель HSB
Здесь заглавные буквы не соответствуют никаким цветам, а символизируют цвет, насыщенность и яркость. Все цвета располагаются по кругу, и каждому соответствует свой градус, то есть всего насчитывается 360 вариантов (красный — 0, желтый — 60, зеленый — 120 градусов и так далее).
Насыщенность определяет, насколько ярко выраженным будет выбранный цвет. 0 — серый, 100 — самый яркий и чистый из возможных вариантов.
Параметр яркости соответствует общепризнанному, то есть 0 — это черный цвет.
Такая цветовая модель намного беднее рассмотренной ранее RGB, так как позволяет работать всего лишь с 3 миллионами цветов.

Цветовая модель CMYK
Это еще одна из наиболее часто используемых цветовых моделей, нашедших широкое применение. Она, в отличие от аддитивной RGB, является субтрактивной моделью. Работа ее основана на том, как раскладывается на составляющие и видится нами свет и цвет. Как уже говорилось ранее, видимым является отраженный спектр, остальные же составляющие поглощаются. Аналогично образовываются цвета на бумаге при рисовании красками. То есть, проведя красную полосу, мы сделаем синюю и зеленую составляющие поглощенными. Если поверху наложить зеленую краску, то результат будет грязным (из-за того, что цвета не совершенны, то есть несколько отличаются от эталонных красного и зеленого) и очень близким к черному.
Основные цвета в субтрактивной модели отличаются от цветов аддитивной. Cyan — голубой, Magenta — пурпурный, Yellow — желтый. Так как при смешении всех вышеперечисленных цветов идеального черного не получится, то вводится еще один дополнительный цвет — черный, который позволяет добиваться большей глубины и используется при печати прочих черных (как, например, обычный текст) объектов.
Цвета в рассматриваемой цветовой модели были выбраны такими не случайно, а из-за того, что голубой поглощает лишь красный, пурпурный — зеленый, желтый — синий.
В отличие от аддитивной модели, где отсутствие цветовых составляющих образует черный цвет, в субтрактивной все наоборот: если нет отдельных компонентов, то цвет белый, если они все присутствуют, то образуется грязно-коричневый, который делается более темным при добавлении черной краски, которая используется для затемнения и других получаемых цветов. При смешивании отдельных цветовых составляющих можно получить следующие результаты:
Голубой + Пурпурный = Синий с оттенком фиолетового, который можно усилить, изменив пропорции смешиваемых цветов.
Пурпурный + Желтый = Красный. В зависимости от соотношения входящих в него составляющих он может быть преобразован в оранжевый или розовый.
Желтый + Голубой = Зеленый, который может быть преобразован при использовании тех же первичных цветов как в салатовый, так и в изумрудный.
Несмотря на большие различия в цветовых моделях RGB и CMYK, следует освоить обе, так как каждая применяется в своей области, и если вы занимаетесь графикой, то столкновения с ними вам не избежать. Следует помнить, что если вы готовите изображение к печати, то следует все-таки работать с CMYK, потому что в противном случае то, что вы увидите на мониторе, и то, что получите на бумаге, будет отличаться настолько сильно, что вся работа может пойти насмарку.

Цветовая модель Lab
Такую модель предпочитают в основном профессионалы, так как он совмещает достоинства как CMYK, так и RGB, а именно обеспечивает доступ ко всем цветам, работая с достаточно большой скоростью.
На вопрос, почему же такой моделью пользуются в основном профессионалы, можно ответить лишь то, что она отличается несколько необычным и непривычным построением, и понять принцип ее действия порой несколько сложнее описанных ранее.
Построение цветов здесь, так же как и в RGB, базируется на слиянии трех каналов. На этом, правда, все сходство заканчивается.
Начнем по порядку, а именно с канала Luminosity — здесь осуществляется контроль за яркостью цветов, образованных двумя другими, а именно a и b составляющими. Белый цвет сопоставляется с максимальной интенсивностью.
Построение других каналов выглядит несколько более запутанным.
A — содержит цвета от темно-зеленого через серый к розовому.
B — светло-синий, серый, ярко-желтый.
При смешении двух цветов результирующий будет более ярким, что является еще одним сходством с цветовой моделью RGB.

Режим Grayscale
Это обычный черно-белый режим, который полностью лишен цвета, в нем есть только белый, черный и градации серого. Ничего особенно нового сказать о данной цветовой модели невозможно, так как она состоит из одного канала, который полностью соответствует изображению и выглядит как обычная черно-белая фотография.
Наряду с перечисленными существуют и другие модели, которые хороши в тех либо иных случаях. Здесь были рассмотрены лишь основные и наиболее часто используемые. Об остальных же речь пойдет в одной из следующих статей.


КОМПЬЮТЕРНАЯ ГАЗЕТА

Кривые Безье — основа основ

Сегодня мы поговорим о кривых, или, как их еще иначе называют, о путях. Эта тема была выбрана не случайно. Мы не раз уже обращали ваше внимание на то, что Flash — это программа, в большей степени работающая с векторными элементами, а пути являются основой практически любого вектора. Следует также отметить, что раньше мы рассматривали программы, предназначенные для обработки растровых изображений, такие как Adobe PhotoShop, Corel Photo-Paint, поэтому о векторах говорили лишь обзорно, но пришло время это исправить.

Вспомним отличия между растровой и векторной графиками. Растр — это массив элементарных точек, пикселей, из которых составляется изображение. Векторная графика основана на математических формулах, описывающих неровности контуров и способ заливки.
В PhotoShop, например, есть целая группа инструментов для работы с путями, основой которой является Pen. Подобные инструменты вы можете встретить в любом редакторе векторной графики и в большинстве хороших растровых программ.
Причина этому проста — во всех продуктах пути создаются и редактируются по одному принципу, так как в их основе лежит одно понятие — кривые Безье.
Создателем их еще в 68 году стал французский ученый, математик и инженер Пьер Безье. Тогда это все делалось для необходимости тяжелой промышленности. Пьеру была поставлена задача: научиться минимальными машинными ресурсами максимально просто и обобщенно описывать любые сложные плоскостные формы. Это нужно было для машин по обработке листового металла, которые вырезали из него необходимые детали.
Безье справился не просто хорошо, а гениально. Его система кривых, основанная на тригонометрических формулах, оказалась настолько простой и удачной, что легла в основу не только графических, но и многих других программ.
В компьютерной графике кривые Безье занимают чуть ли не главное место. Это не только основа векторной графики, но и способ описания шрифтов, универсальный способ передачи выделения. Научившись работать с ними в одной программе, вы не будете иметь никаких затруднений при работе с множеством других — повторимся, принцип везде одинаков.
Прежде, чем что-то изучать, нужно понять, какую функцию выполняет этот инструмент, средство.
Самая главная функция контуров, которая была и остается основной причиной их использования, — рисование различных геометрических фигур разной степени точности.
Согласитесь, создать правильные с точки зрения геометрии, ровные фигуры при помощи инструментов рисования не просто сложно, а фантастически сложно. Для этого нужно было бы обладать хорошими художественными способностями, серьезными навыками работы и профессиональными манипуляторами. Эти условия противоречат основной концепции практически любого графического редактора — в программе хорошие работы может делать человек, который руками рисовать совершенно не умеет.
А при помощи кривых создание сложных фигур сводится к очень простым и интуитивно понятным манипуляциям.
Кроме того, фигуры, нарисованные при помощи контуров, можно трансформировать и масштабировать без потери качества (в этом одно из главных достоинств векторной графики вообще).
Именно благодаря существованию контуров в растровой графике возможно качественное создание логотипов и тому подобных работ (хотя чаще все же используются специальные программы, предназначенные для работы с векторами).
Второе основное значение путей — выделение. Если обратиться вновь ко всеми уважаемой и любимой программе PhotoShop, то в ранних версия, например в 3, большая часть работы с выделением никак не могла обойтись без этого столь замечательного инструмента. С развитием программы появились и другие способы маскирования, однако пути не утратили своей актуальности и в данный момент, и иногда все же удобнее выделять при помощи инструментов группы Pen (Перо). Кроме того, контуры сохраняются во многих типах файлов, в отличие от чистого выделения и Альфа каналов. И при хранении размер файла от добавления в него контура почти не увеличивается, что нельзя сказать про другие способы выделения. Именно поэтому довольно часто в коммерческих библиотеках изображений, которые можно купить на CD носителях, изображения поставляются с обтравочными контурами.
Пути применяются и при создании множества эффектов, и для треппинга, и во множестве других случаев, перечислить которые просто не представляется возможным.
Рассмотрим несколько подробнее путь, из чего он состоит и как с ним работать.

Структура контура
Самое тяжелое в работе с контурами — научиться ими пользоваться сознательно. А это, наверное, наиболее тяжелый момент в изучении программы, если раньше вы не сталкивались с данным инструментом. Конечно, есть определенные правила, которые мы изложим чуть ниже, но все же успех в основном зависит не от этого.
В контурах, как нигде, нужно интуитивно чувствовать, к чему приведет то или иное изменение. А достигается это только одним способом — в ходе собственной практики.
Посмотрите на рисунок. На нем показана структура контура.
Как видно, контур состоит из четырех основных элементов.
1. Непосредственно кривая Безье. То, ради чего все и делается. Именно она называется контуром и является объектом нашей деятельности. Все остальные элементы служат только для того, чтобы придать кривой нужную форму. То есть, этот элемент можно назвать основополагающим, все остальные — вспомогательными.
2. Якорная точка (Anchor Point). Кривая Безье с двух сторон ограничена именно этими линиями, они во многом определят ее форму. В случае, если в контуре больше двух якорных точек, то, следовательно, он состоит из множества кривых Безье. Якорные точки можно передвигать относительно друг друга, настраивая вид пути.
3. Направляющая линия (Control Handle). Эта линия выходит из якорной точки. Она является касательной к кривой Безье. Для тех, кто не очень помнит математику, объясним — это значит, что эта линия касается прямой только в одной точке и что любые изменения, которые вы будете производить с направляющей линией, будут самым прямым образом отражаться и на кривой. Направляющих может быть одна или две.
4. Маркер. Именно так называется этот фрагмент, которым заканчивается направляющая линия. Служит маркер для одной цели — изменения длины и положения направляющих. С положением все ясно — уже было сказано, что это касательная к кривой Безье, поэтому, меняя положение, мы меняем ее форму. Такое же важное значение имеет и длина направляющих. Она определяет амплитуду кривой, или, если проще, — степень "выгнутости".
Таким образом, первый вывод относительно контуров — залог качественной работы с ними скрывается в умении пользоваться, прежде всего, направляющими.

Виды якорных точек
Во Flash существует два типа якорных точек. Разработчики назвали их Smooth (Гладкие) и Corner (Острые). Эта тонкость очень повышает удобство работы с контурами, но новичкам осваивать гораздо сложнее, чем если бы был один тип.
Сначала поговорим про более простые, гладкие якорные точки. Гладкий угол всегда имеет две направляющие с разных сторон. Они взаимосвязаны — при повороте одной на определенный градус точно так же поворачивается вторая. Лучше всего воспринимайте их как одну линию — это наиболее прямая аналогия.
При повороте направляющих линий кривая тоже как бы оборачивается. Внешний вид при этом зависит еще и от длины направляющих линий. Данный режим в основном используется для создания плавных, обтекаемых фигур.
Другой тип якорных точек — острые якорные точки. Они отличаются от гладких тем, что у них может быть три варианта наличия вспомогательных линий (в противовес гладким, у которых только один тип — две направляющие линии):
1. Вообще без вспомогательных линий. Да, такое возможно и предназначается для рисования, к примеру, треугольников и им подобных фигур. Работать с таким типом острых якорных точек проще всего.
2. Одна вспомогательная линия. Так как вспомогательные линии в этом режиме, в отличие от режима гладких якорных точек, не связаны, то объект можно трансформировать и при помощи одной линии.
3. Острая якорная точка с двумя направляющими. Наиболее сложный режим. Позволяет создавать действительно сложные формы, не обладающие симметрией.

ВНИМАНИЕ
Одним из основных заблуждений начинающих пользователей является то, что они склонны считать пути частью изображения. Это совсем не так. Путь — это вспомогательный элемент, он не несет в себе графической информации в растровом смысле этого слова. Но когда путь создан, его можно или залить пикселями (в растре), или прорисовать линией, или превратить в выделение.
Еще раз повторимся, что, в принципе, при помощи контуров можно передать абсолютно любую форму — все зависит от навыков и таланта. У авторов был знакомый, который умел контурами имитировать подчерк (!) человека. Конечно, это уникальный случай, но про возможности инструментов говорит много.
Рассмотрим основные инструменты работы с путями, которые встречаются практически в каждом графическом редакторе.

Инструменты группы Pen и методы создания контуров при помощи них

Pen Tool (Перо)
Главный инструмент для работы с контурами. Нельзя сказать, что при помощи его выполняется больше работы, чем при помощи других. Дело не в этом. Просто Pen Tool обычно создает основу, путь, почти все другие — только редактируют его.
Есть два основных способа работы с Pen — создание прямоугольных, острых контуров и более сложных, плавных.
Начнем с более простого, с прямоугольных форм. Создайте новый документ. Запустите указанный инструмент. Кликните левой клавишей мыши. Появится первая якорная точка. Отведите курсор немного в сторону и снова кликните. Появится вторая якорная точка и тотчас соединится с первой кривой Безье.
Пользуясь точно такой же технологией и дальше, можно создать достаточно сложный контур.
Если же вы возвращаете курсор к точке начала создания контура, то он приобретает своеобразный вид, что значит, что при клике в эту точку контур будет закончен и превратится в так называемый замкнутый тип контура. Такой контур обладает рядом свойств, в частности, возможностью превращения в выделение.
Несколько сложнее обстоит дело с созданием плавных, обтекаемых форм.
Начинать нужно точно так же, как и при создании прямых узлов. Кликните, поставьте первую оперную точку. Отнесите курсор мыши на достаточное расстояние и снова кликните левой клавишей мыши для того, чтобы поставить вторую якорную точку. Но кнопку мыши после этого не отпускайте и начинайте передвигать курсор, при этом удерживая кнопку мыши.
Сразу появятся направляющие линии, и кривая начнет плавно изгибаться. Один маркер будет располагаться ровно под вашим курсором, то есть с этого момента вы редактируете вид кривой уже при помощи направляющих.
Далее можно преобразовывать полученную кривую, редактируя направляющие.
Примерно по такому же принципу создаются все, даже самые сложные контуры. Конечно, работу облегчают инструменты редактирования контуров, с которыми мы познакомимся чуть ниже, но основу вы уже знаете.

Freeform Pen Tool (Свободное перо)
По своему действию Freeform Pen очень похож на лассо, только создает не выделение, а контур.
Предназначен этот инструмент для создания абсолютно свободных по форме путей. Правда, действительно хорошо с Freeform Lasso работать только при наличии дигитайзера, мышью почти ничего толкового не сделать.
Пользоваться Свободным пером очень просто: зажимаете левую клавишу мыши и двигаете саму мышь. Вся траектория курсора до отпускания клавиши станет контуром.

Magnetic Pen
Этот инструмент встречается не во всех программах, но упомянуть все же стоит. Пользоваться им чрезвычайно просто. Вы кликаете левой клавишей мыши и ставите первую якорную точку. Дальше ведете вдоль объекта, вокруг которого необходимо создать путь, — и компьютер сам определяет, как располагать кривые.
Программа сама расставляет якорные точки в зависимости от перепадов яркости, то есть, сложности контура и своих собственных, определенных пользователем, параметров. Но и вы при создании пути этим способом можете определять места для якорных точек. Это необходимо в случае, когда перепад яркости в этом месте недостаточен для правильного определения программой нужного пути.

Add Anchor Point Tool (Добавить якорную точку)
Этот инструмент не умеет сам создавать пути, однако имеющиеся преобразовывает очень хорошо.
Рассмотрим это на примере. Создайте путь в виде прямоугольника.
Затем возьмите изучаемый инструмент. Кликните по одной стороне прямоугольника. Появится новая якорная точка. Вытяните ее в сторону. В результате одна сторона прямоугольника оказалась как бы раздута.
Точно таким же способом пофантазируйте с контуром и в других местах. Не забывайте о том, что можно настраивать длину направляющих линий и, как следствие, степень влияния перемещения якорной точки на кривую Безье.

Delete Anchor Point Tool (Удалить якорную точку)
Этот инструмент не столь впечатляющ, как предыдущие, и рассматривать его стоит лишь как очень редко полезное дополнение к Add Anchor Point.
При помощи него можно удалять опорные точки из контуров. Это бывает полезно, если, например, какая-либо из них мешает правильной трансформации пути.

Convert Point Tool (Изменить якорную точку)
Относительно сложный в работе инструмент. Служит для редактирования пути через изменение свойств якорных точек и положения направляющих. Сформулируем основные принципы работы этого инструмента.
1. Клик по существующей якорной точке позволяет вытянуть из нее новые направляющие линии гладкого типа.
2. Если линии уже вытянуты, то манипуляции с маркером любой из них превращает якорную точку в острую.
3. Клик по якорной точке с выдвинутыми направляющими убирает их. При этом данный фрагмент пути приобретает "прямой" вид.
Основываясь на этих трех правилах, потренируйтесь немного — и вы научитесь вполне сносно обращаться с этим инструментом.
Здесь рассмотрены не все, но основные инструменты группы Pen (Перо), так как программ достаточно много и в каждой есть свои особенности, связанные с применением данных инструментов, свои дополнительные настройки, клавиатурные эквиваленты, поэтому мы посчитали, что наиболее важным является понять общий принцип работы с данными элементами.


ArTreat | Paint Shop Pro |

Формат *gif . Прозрачный цвет в Paint Shop Pro 5.х
Ещё один способ отличающийся от предыдущего установками при уменьшении цвета до 256 ( 8 bit ). На мой взгляд эти установки в большинстве случаев самые оптимальные, но как говорится, раз на раз... и они не являются эталоном.

Итак, перед вами картинка в которой нужно сделать прозрачным какой - либо цвет. Идём в Colors | Set Palette Transparency или клавиши Shift + Ctrl + V, на вопрос о переходе в 256 цветов ответьте Да. В появившемся окне сделайте следующие установки, как на рисунке1.

рис.1
рисунок 1

После открывается другое окно (рис.2). Сдвиньте курсор на картинку и он станет как инструмент Dropper - пипетка. Теперь укажите какой цвет должен быть прозрачным (рис.3). После этого нажмите кнопку Proof (рис.2) чтобы посмотреть как это выглядит (рис.4), а потом кнопка ОК.

рис.2
рисунок 2

рис.3
рисунок 3
рис.4
рисунок 4

Теперь осталось только записать картинку как *gif. File | Save As в строке Тип файла выберите CompuServe Graphics Interchange (*.gif), а в Options обязательно отметьте 'Version 89a' и 'Interlaced'.
как бы back

содержание


ArTreat | Paint Shop Pro |

Рамка - бордюр в Paint Shop Pro 5.х
[1] go | [2] go
[3] go | [4] go

содержание


ArTreat | Paint Shop Pro | 5 Sec

За пять секунд
Даные примеры описываются коротко и здесь не рассказывается подробно каждый шаг. То есть подразумивается, что Вы хотя бы немного знакомы с Paint Shop Pro или читали другие примеры на этом сайте.
Эти примеры показывают некоторые способы, которые в дальнейшем могут послужить шаблоном для создания более сложных вариантов.

*jpg В палитре возьмите тёмный и светлый цвета. Откройте новый имидж, сделайте выделение окружностью, залейте его из Flood Fill стиль Linear Gradient. Потом сожмите выделение Selections | Modify | Contract. И снова залейте, но теперь светлым. А теперь вставляйте нужный рисунок или букву, отбросьте тень или примените фитьтр.

Ну, а эта кнопка делается ещё проще. Открываете new image и создаёте нужное *jpg вам выделение. Отбрасываете тень и в принципе всё, кнопка готова. Если Вы хотите её приукрасить, то раскрасьте её по вашему желанию. Используйте эффекты и фильтры или почитайте другие примеры на сайте.

*jpg Эта кнопка тоже делается довольно просто. Откройте небольшой файл примерно 50 х 50. Залейте его как в первом примере из Flood Fill... Выделите всё, Selection | SelectAll. Деформируйте его Image | Deformations | Circle, скопируйте выделение и выложите как новый имидж - Ctrl + C , Ctrl + V . А теперь используйте Deformations | Circle столько, сколько Вам нужно, также поиграйте и с другими эффектами, а в конце уменьшите размер в два раза.

Нарисовать разделительную линию которая лежит - весит сверху, тоже можно за 5 сек. Откройте новый имидж, подлинее. Выделите полоску примерно 200 х 10 пикселей. Залейте из Flood Fill как и в первом примере. Затем Selections | Float. Возьмите инструмент Deformation и тяните, искривляйте её как хотите, а потом можете отбросить [image] .

на вторую страницу

содержание


ArTreat | Paint Shop Pro | Bordered Text

Создаём текст с окантовкой в Paint Shop Pro 5.х

Создайте New image, фон белый (white background color).
Добавьте новый слой, Layers | New, назавите его 'Снаружи' и напишите текст, Antialias отмечено и Floating не отмечено.
Сохраните выделение в Selection | Save to Alpha Channel под именем 'оригинал'. Теперь нужно сделать выделение немного пошире - Selection | Modify | Expand в 2 пикселя и снова сохраните в Альфа канал Selection | Save to Alpha Channel под именем 'край'. Заполните выделение нужным цветом используя инструмент Flood fill.

рис.1
рисунок 1

Теперь всё готово для создания текста внутри. Добавьте новый слой Layers | New назaвите его 'Внутри'.
Загрузите выделение 'оригинал' из альфа канала, Selection | Load from Alpha Channel. Всё что теперь нужно, это залить выделение нужным цветом.

рис.2
рисунок 2

Вы можете теперь применить любой эффект или фильтр по вашему выбору.
Я здесь, не снимая выделения, создал новый слой. Передвинул его в самый низ Layers | Arrange | Send to Bottom и добавил чёрную тень. Вот, что из этого получилось.

Осталось только сохранить картинку в нужном формате - gif или jpg. Если же вы думаете, что в дальнейшем вам понадобится что - нибудь заменить, например фон, то сохраните её в psp. Таким образом у вас сохранятся все слои и альфа каналы. И вы всегда сможете открыть картинку, активизировать нужный слой, загрузить выделение, если это нужно и произвести изменения.

ещё один способ

содержание


ArTreat | Paint Shop Pro | Текст с оконтовкой 2

Текст с окантовкой в Paint Shop Pro 5.х
Этот пример отличается от предыдущего тем, что бортик (оконтовка) будет всегда одного и того - же цвета, чёрного. А это не так уж и плохо, потому что чёрный сочетается практически с любым цветом. И с 'ядовитыми' и со 'спокойными'.
Этот способ хорошо работает с любым шрифтом и с широким и с узким, под наклоном или с засечками и т.д. Конечно все шрифты Я перепробовать не мог.

Создайте новый имидж Ctrl + N, фон белый (Вackground color = white). Установите в палитре цветов, передний тот цвет которым вы хотите написать текст, а вторым белый. Теперь инструментом Text создайте текст. Antialias и Floating отметьте.
На панели меню Selections | Invert или Shift + Ctrl + I. У вас может бать похоже на рисунок 1.

рис.1
рисунок 1

Теперь делаем оконтовку. В цветовой палитре поменяйте местами цвета, (просто кликните на стрелки около цветовых окошек). Затем, Image | Other | Hot Wax Coating. Появилась чёрная оконтовка, (рис.2). Если вам нужно сделать её побольше, тогда примените фильтр Hot Wax Coating ещё раз (рис.3).

рис.2 рисунок 2 | рис.3 рисунок 3
После применения фильтра, бэкграунд слегка потемнел. Чтобы вернуть прежний цвет, снимите выделение - Ctrl + D. Инструментом Magic Wand; Match Mode = RGB, Tolerance = 0 кликните на фон. Появилось обратное выделение. Воьмите лейку - Flood Fill и залейте фон белым цветом. И ещё один пример с другим шрифтом и с кричащим цветом. Сам по себе этот цвет не очень приятен для глаза (рис.4), но после применения этого способа текст становится более приемлимым (рис.5).
рис.4 рисунок 4 | рис.5 рисунок 5

[1] [2]

содержание


Artreat | Paint Shop Pro | Burn

Огонь в Paint Shop Pro 6

Эффект огня получается с помощью искажения и смазывания изображения в одном направлении. В пятой версии PSP, его также можно получить штатными средствами, только это займёт больше времени из-за отсутсвия нужных фильтров.

Начните с белого текста на чёрном фоне. Выберите шрифт (толщина может быть любой, а размер желательно побольше) и наберите нужный текст, отметив Floating. Затем снимите выделение - Ctrl + D.

рис.1
рисунок 1

  • Image | Deformations | Wave. Попробуйте поиграть с установками фильтра, в зависимосьте от изображения. Я же использовал следующии...

рис.2
рисунок 2

Поворачиваем изображение в право на 90 градусов

  • Image | Rotate (Ctrl + R)
  • Direction = Right
  • Degrees = 90

рис.3
рисунок 3

Смажим его с помощью "ветра"

  • Image | Deformations | Wind
  • Strenth = 17, From Left

И поварачиваем картинку обратно в горизонтальное положение.

  • Image | Rotate (Ctrl + R)
  • Direction = Left (90 градусов)

А теперь это действительно станет огнём.

  • Colors | Colorize
  • Hue = 21 (или на ваш выбор)
  • Saturation = 135 (или на ваш выбор)

рис.4
рисунок 4

Деформируйте изображение ещё раз, уменьшив горизонтальное смищение. Это придаст языкам пламяни реалистичности. Установки выбирите на ваше усматрение. Поиграв с движками, вы найдёте то что вам нужно. Я использовал следующии...

  • Image | Deformations | Wave
  • Horizontal displacement; Amplitude = 1, Wavelength = 25
  • Vertical displacement - Я не изменял

И под конец добавим резкости: Image | Sharpen | Sharpen More. Возмозно вам понадобится повторить это действие несколько раз. Конечный результат, ниже.

рис.5
рисунок 5

Так же попробуйте поочерёдно, совмещать Wave с Twirl и Mosaic - Antique или Ripple. Возможно вы найдёте в этом дополнительный эффект.

содержание


Artreat | Paint Shop Pro | Stamp

Тиснение в Paint Shop Pro

Создайте новый имидж (Ctrl + N) и вставьте ваш логотип. Если его нет, нацарапайте что-нибудь в чёрно белом варианте. У меня вот, завалялось...

рис.1
рисунок 1

  • Image | Other | Emboss

рис.2
рисунок 2

Теперь, сделайте картинку посветлее или темнее, в зависимости от того что вам нужно.

  • Colors | Adjust | Brightness/Contrast
  • Brightness = 25
  • Contrast = -80

И добавьте немного шума

  • Image | Noise | Add
  • Noise = 6
  • Uniform = отмечено

рис.3
рисунок 3

Выверните картинку в другую сторону.

  • Colors | Solarize
  • Threshold = 68

И сделайте ещё раз посветлей.

  • Colors | Adjust | Gamma Correction (в этом примере Я отметил Link и выставил все движки на 1.20)

рис.4
рисунок 4

  • Colors | Colorize
  • H = 16, S = 125

И применил два эффекта, Weave и Texture

Weave

  • Gap size = 1
  • Width = 130
  • Opacity = 100
  • Weave color = чёрный

Texture

  • Текстура седьмая, размер 73
  • В колонке Image, всё по нулям
  • В колонке Light; цвет белый, Angle = 315, Int. = 50, Elev. = 30

Вот что получается (пришлось сделать border вокруг картинки, потому что на чёрном, это смотрится выразительней).

рис.5
рисунок 5

содержание


Artreat | Paint Shop Pro | Горячие клавиши

Горячие клавиши Paint Shop Pro 5.х Так называемые "Горячие клавиши", клавиши которые заменяют кликанье по панели меню. Эти клавиши ускорят вашу работу и сохранят вам время. Специально их заучивать наверно не надо. Со временем они cами запомнятся. Поизучайте панель меню там их гораздо больше, здесь только те которые чаще всего используются в процессе (моём). И ещё от себя добавлю, что пробелом можно листать панель инструментов, а клавишей Tab прятать летучии панели Сontrols, Colors, Layers, Histogram.
Ctrl + A | Выделить всё | Select All
Ctrl + C | Копировать | Copy
Ctrl + D | Снять выделение | Deselect
Shift +D | Дублировать всю картинку | Duplicate
Ctrl + Е | Вставить как новое выделение | Paste as New Selectction
Сtrl + L | Вставить как новый слой | Paste as New Layer
Сtrl + N | Создать новый файл | New...
Сtrl + O | Открыть сохранёную картинку | Open...
Сtrl + V | Выложить как новую картинку | Paste as New Image
Сtrl + Z | Один шаг назад | Undo...
Сtrl + Alt + G | Решётка | Grid
Сtrl + Alt + Z | Вперед после отката | Redo
Прошло немного времени и Я решил выложить полный список Горячих клавиш. Может кому надо...
КЛАВИШИ | КОМАНДА
File Menu
Ctrl + N | New
Ctrl + O | Open
Ctrl + B | Browse
Ctrl + S | Save
F12 | Save - As
Ctrl + Del | Delete
Ctrl + P | Print
Edit Menu
Ctrl + Z | Undo
Shift + Ctrl + Z | Undo History
Ctrl + X | Cut
Ctrl + C | Copy
Ctrl + V | Paste As New Image
Ctrl + L | Paste As New Layer
Ctrl + E | Paste As New Selection
Shift + Ctrl + E | As Transparent Selection
Shift + Ctrl + L | Into Selection
View Menu
Shift + A | Full Screen Edit
Shift + Ctrl + A | Full Screen Preview
Ctrl + Alt + N | Normal Viewing
Shift + I | Image Information
Ctrl + Alt + G | Grid
Image Menu
Ctrl + I | Flip
Ctrl + M | Mirror
Ctrl + R | Rotate
Shift + S | Resize
Colors Menu
Shift + B | Brightness/ Contrast
Shift + G | Gamma Correction
Shift + M | Highlight/ Midtone/Shadow
Shift + H | Hue/Saturation/ Luminance
Shift + U | Red/Green/Blue
Shift + L | Colorize
Shift + Z | Posterize
Shift + P | Edit Palette
Shift + O | Load Palette
Layers Menu
Ctrl + layer number | Select Current Layer
Selections Menu
Ctrl + A | Select All
Ctrl + D | Select None
Shift + Ctrl + S | From Mask
Shift + Ctrl + M | Hide Selection Marquee
Shift + Ctrl + I | Inverse
Shift + Ctrl + P | Promote Layer
Ctrl + F | Float
Shift + Ctrl + F | Defloat
Masks Menu
Shift + Y | Hide All
Shift + K | Invert
Ctrl + K | Edit
Ctrl + Alt + V | View Mask
Capture Menu
Shift + C | Start
Window Menu
Shift + W | New Window
Shift + D | Duplicate
Ctrl + W | Fit To Window
Горячие клавиши Animation Shop 1.х
КЛАВИШИ | КОМАНДА
File Menu
Ctrl + N | New
Ctrl + O | Open
Ctrl + S | Save
F12 | Save As
Edit Menu
Ctrl + Z | Undo
Ctrl + X | Cut
Ctrl + C | Copy
Ctrl + V | As New Frames
Ctrl + E | Into Selected Frames
Window Menu
Shift + D | Duplicate

содержание


ArTreat | Paint Shop Pro | Заметки

Заметки
  • Не работать с оригиналом. Если вы работаете с готовой картинкой и вам не хочется её потерять, то просто дублируйте её (Shift + D) а оригинал с глаз долой.
  • Tень. Если вы добавляете к какому - нибудь объекту эффект тень или Cutout, то чащё всего это лучше делать в новом слое. Таким образом вы всегда сможете изменить затемнёность (Layer Opacity) передвигая движок на панели слоёв.

    Я например добавляя эффект Cutout или тень, значение Opacity устанавливаю максимально (100 %), а потом на панели слоёв пермещая движок подбираю нужную затемнёность.

  • Antialias. Когда вы создаёте объекты под наклоном или пишите текст, то чаще всего лучше отметить свойство antialias.Это свойство сглаживает края объектов, тем самым они не будут выглядеть угловатыми.

    Но antialias также может вызывать некоторые проблемы. Например очень мелкие контуры и тексты с antialias очень плохо читаются. Во-вторых при сглаживании краёв создаются промежуточные цвета, а чем больше в картинке цветов, тем больше она "весит". Опять же это зависит от того в каком формате вы её сохраните.

  • Не слушать ни чьих советов, а всему учиться на своих ошибках. Через терни к звёздам. Методом проб и ошибок. Или так, выслушать все советы и сделать посвоему.
  • Выделение элемента. Если у вас есть объект который находится на прозрачном слое и вам нужно его или фрагмент быстренько выделить, то это не сложно. Возьмите инструмент для выделения (selection) и объведите вокруг элемента. А потом кликните левой кнопкой внутри выделения.
  • Новый файл. Когда вы создаёте новый файл в PSP, установите колличество отображаемых цветов 16,7 млн. (24 Bit). Это позволит вам использовать все возможности редактора - фильтры, маски, палитру цветов и т.д. И пусть эта установка будет у вас по умолчанию всегда. Снизить же колличество цветов вы всегда сможете воспользовавшись опцией Colors | Decrease Color Depth | ...

    Если вы открыли файл с расширением *gif, то прежде чем работать с ним переведите его в 16 млн. цветов, просто выбрав Colors | Increase Color Depth | 16 Million Colors.

  • Если вы заливаете картинку c плавным перехом от цвета к цвету установив Gradient то очень часто заливка получается ступеньчатая (рисунок слева). Это можно скрыть добавив "шум" - Image | Noise | Add от 2 до 7 % отметив Uniform (рисунок с права).

    Однако конечный результат во многом будет зависить от того в каком формате вы запишите картинку и каким будет процент компрессии (сжатия). Потом не все браузеры, мониторы и компьютеры передают один и тот же цвет одинаково.
    Есть так сказать безопасные цвета для web, об этом поподробней вы можете узнать на страницах студии А. Лебедева все цвета интернета.

  • Новый файл. Я обычно открываю новай файл с размером окна больше, чем будет предполагаемая картинка. В таком окне удобней работать, а потом когда всё закончено, отрезаю лишние края инструментом Crop. Или если объект выделен Image | Crop to Selection.
продолжение

содержание


ArTreat | Paint Shop Pro | Заметки

Заметки
  • Имейте в виду, что Internet Explorer очень явно, не умеет правильно отображать белый цвет в файлах с расширением .jpg. Он подменяет его (белый) на поросячий - розовый цвет. Это особено заметно на картинках с белым фоном. Так что будьте внимательны, если вы готовите картинку для web.
  • Размеры картинок. Если вы готовите картинку для web, то совершенно случайно может произойти так, что ваша картинка не будет показываться (видна). Это может быть связано с программами - баннерорезками, типа AtGuard. Вообщем со мной это и произошло.
    Вы наверняка видели (или не видели) на предыдущей странице две картинки - примеры. Когда Я залил страницу, Я пошёл посмотреть всё ли на ней работает. И вот как раз они, эти две картинки и не показывались. Я давай ламать голову в чём дело и туда залез и сюда посмотрел. И так и сяк, всё на месте а картинок не видно. Но не долго мучалась старушка... и к вечеру меня осенило, Я ж пару дней назад сменил выше обозначеный guard на WebWasher и у него оказывается помимо ампутации рекламы на корню, стоят фильтры на графику определённых размеров. Баннерных стандартов, например 250х50. А эти картинки таковыми и оказались. Я эту опцию отключил, всё заработало и включил обратно.
    Так что готовтись к тому, что графика в сети скоро умрёт. И останутся только баннеры.
    А потом и текст умрёт, потому что баннеры станут не эффективным способом рекламы и они превратятся в текст. А разработчики этих guard'ов и washer'ов придумают soft отлавливающий рекламу в тексте. А рекламщики придумают...и тут Остапа понесло...
    • Вот распрастранённые размеры баннеров на август 1999г.
    • 88х31
    • 250х50
    • 80х340
    • 60х52
    • 554х90
    • 486х60
    • 472х64
    • 468х70
    • 468х68
    • 468х64
    • 468х60
    • 468х55
    • 466х54
    • 460х60
    • 460х55
    • 450х75
    • 432х50
    • 420х80
    • 400х68
    • 400х64
    • 400х62
    • 400х60
    • 400х50
    • 400х40
    • 392х72
    • 370х50
    • 357х40
    • 300х60
    • 300х130
    • 275х80
    • 240х160
    • 234х60
    • 220х40
    • 196х46
    • 175х45
    • 156х60
    • 155х40
    • 150х74
    • 140х40
    • 137х60
    • 130х80
    • 125х90
    • 125х125
    • 120х90
    • 120х60
    • 120х240
    • 100х100
    • 100х70

содержание


Artreat | Paint Shop Pro | Заметки

Заметки
  • Новостная группа comp.graphics.apps.paint-shop-pro. Если ваш провайдер не поддерживает эту группу, то читать её и посылать в неё сообщения можно с News Server'ов nnca-gtso-2.news.mediaways.net или news.rz.ru. Добавьте этот сервер в ваш ньюсридер и подпишитесь на группу comp.graphics.apps.paint-shop-pro.
  • Как добавить свою текстуру в эффекты Texture. Откройте файл из которого вы хотите сделать текстуру. Далее запишите его как *.bmp.
    • File | Save as | выберите тип Windows or OS/2 Bitmap (*.bmp).
    • Укажите папку, \Program Files\Paint Shop Pro 6\Textures\ нажимаем Save. На вопрос програмы кликните Yes (Да).
    • Теперь найдите этот файл в Проводнике и переименуйте в .tex
    • Текстура готова и ей можно пользоваться. Image | Effects | Texture... в открывшемся, окне в колонке тектуры, ваша будет находится скорее всего в самом конце.

содержание


ArTreat | Paint Shop Pro | Оборванные края

[4] Оборванные края в Paint Shop Pro 5.x

Для получения этого спецэффекта существует довольно много фильтров - плагинов (plug in filters), например Xenofex 1.0. Но если по каким - то причинам у вас нет возможности воспользоваться ими, или вам интересней научиться это делать самим, то вы можете скачать .gif'ы которые вы найдёте ниже, преобразовать их в маски и создать собственные "Причудливые края".

На этих двух рисунках использовалась одна и тажe маска. На примере слева, применён эффект тень (Drop Shadow), background color был залит под цвет странички и сохранён как .gif c прозрачным фоном. Бэкграунд на примере справа залит текстурой - дерево, применён эффект тень, а так же добавлена белая тень на обе стороны (как бы рваная бумага).

Для получения этого эффекта, вам нужно создать маску из готового шаблона, либо нарисовть его самим. Инструментом Freehand, вдоль края сделайте выделение от точки к точке. Потом invert selection и залейте чёрным. Но удобней и быстрей будет скачать уже готовые.
Эти шаблоны размером 600х400 пикселей, и когда вы загрузите маску, она всё равно будет соответствовать размеру вашей картинки.

go to full size
go to full size
go to full size
go to full size
go to full size
go to full size
go to full size
go to full size
go to full size
go to full size
go to full size
go to full size
go to full size
go to full size
go to full size
go to full size
go to full size
go to full size
go to full size
go to full size

• Откройте графику - маску. Если она в формате .gif, как здесь, то сначала переведите её в 16 млн. цветов, Соlors | Increase Color Depth | (24 bit).

• Откройте вашу картинку. Добавьте новый слой, Layers New и заполните его цветом или текстурой, на которых будет картинка. Назовите его "край"

• В этом - же слое (край) идите в Мascs | New | From image. У вас появилось окно опций. Выберете в строке 'Источник' (Source window) имя файла маска, а остальные значения как на рисунке 1.

рис.1
рисунок 1

У вас должна появиться картинка, по краям окрашеная в цвет выбраный на слое "край".
• Сохраните маску в альфа канал, Mascs | Save to Alpha Channel.

• Удалите маску Masks | Delete и в окне запроса о соединении со слоем ответьте "Yes"

• Теперь Selections | Load from Alpha Channel, загрузите выделение маски и сделайте его обратным Selections | Invert. У вас должна быть выделена теперь тоько картинка.

• Добавьте новый слой.
Ужмите выделение на две единицы Selections | Modify | Contract = 2.

• Oтбросьте тень. Image | Effects | Drop Shadow. Сделайте её больше, чем обычно это бывает. Потом на контрастах это компенсируется. Значение Opacity установите 100%

• Теперь если бэкграунд вашей картинки окрашен не в белый цвет, то можно добавить к ней немного реалистичности.
Создайте новый слой.

  • Selections | Load from Alpha Channel
  • Selections | Modify | Contract = 1
  • Добавьте белую тень, Opacity = 100%, Blur = от 0.5 до 1, Offset; 1, 1.
  • Создайте ещё один слой.
  • Повторите белую тень, только Offset установите V = -1, H = -1.

Теперь отрегулируйте затемненость слоёв на ваш выбор и сохраните в нужном формате.

Вы свободно можете изменять размер графической маски до её применения. Тоесть, любым способом можно подгонять её размер под вашу картинку. Но если вы будете изменять размер после наложения маски, то эффект оборванных краёв - смажется.

Все [1] [2] [3] [4]

содержание


ArTreat | Paint Shop Pro | Рамка - бордюр

[1] Paмка - бордюр в Paint Shop Pro 5.х
Примеры эти очень просты в исполнении. Я сначала думал поместить их в раздел За 5 сек. Но они что - то не захотели и Я решил их разместить здесь - отдельно. Так что можно считать, что это продолжение За 5 сек.
Картинку с крокодилами Я нарыл где - то в недрах Art Today

Исходная картинка
original image

Если ваша картинка сохранена в формате .gif, то сначала переведите её в 16 млн. цветов Colors | Increase Color Depth | 16 Million Colors. Основной элемент в этой технике - добавление бордюра и эффект Cutout.
Откройте вашу картинку, в цветовой палитре установите background color тот цвет, котоым будет окрашен бордюр (здесь слегка зеленоватый, вот его HTML код - #C8C8AB).
Добавте бордюр - Image | Add Borders. Отметьте Symmetric = 15. У вас появился бордюр. Теперь выделите его с помощью инструмента Magic Wand, на панели Controls установите Match Mode = RGB Value, а остальные зачения = 0. Кликните на бордюр, получится что - то вроде рис.1.

рис.1
рисунок 1

Затем Selections | Modify | Feather = от 2 до 7 (Я установил 4). Выделение в центре немного сократилось.
Теперь Image | Effects | Cutout. Установки: Shadow color = black, Opacity = 82, Blur = 5, Offset - V = 2, H = 1. Может получится подобно рис.2

рис.2
рисунок 2

Если вам нужно положить картинку на какую - нибудь определёную текстуру, то это очень просто. Откройте файл с текстурой. Выберете инструмент Flood Fill на панели Controls щёлкните кнопку Options и установите Fill Style = Pattern, Pattern source = имя файла.
Проделайте начальные, выше описаные шаги. После того как вы выделили бордюр с помощью Magic Wand, возьмите Flood Fill и залейте фон нужной текстурой. А далее по накатаной. Установки Cutout изменять не запрещается, а даже наооборот.

Все [1] [2] [3] [4] След.

содержание


ArTreat | Paint Shop Pro | Рамка - бордюр

[2.1] Paмка - бордюр в Paint Shop Pro 5.х

Это способ плавного - блёклого перехода картинки в бэкграунд без использования текстуры. Картинка взята из коллекции бесплатных фотографий.

Установите в цветовой палитре второй цвет (background color) с которым будет сливаться ваша картинка.
Сделайте выделение нужной вам формы (круг, квадрат и т.п.). Если оно получилось не в том месте где вы хотели, используйте инструмент Moover. Правый клик на выделение и удерживая клавишу мыши передвиньте его куда вам нужно.
Затем

  • Selections | Modify | Feather
  • Feather Selection = 10 (или на ваш выбор)
  • Selections | Invert
  • Edit | Clear (или клавиша Delete)

Все [1] [2] [3] [4] След.

содержание


ArTreat | Paint Shop Pro | Рамка - бордюр

[3] Paмка - бордюр в Paint Shop Pro 5.х

Ещё один простой способ изготовления рамки с добавлением бордюра и эффектом Cutout.
Где Я взял эту фотографию уже и не помню (где -то в Инете), но помоему она принадлежит какому - то "крутому", толи журналу, толи календарю, который даже купить нельзя. Он вроде только высылается, причём бесплатно и это надо "заслужть".
Так что если кто знает чья она, или если найдётся хозяин, с привеликим удовольствием поставлю линк и т.п. на владельца. Или уберу её, если он это захочет.

исходная картинка
original image

Откройте фото. Установите в цветовой палитре Background Color тот в который будет окрашен бардюр (Я использовал песочный, его HTML код #FCE9D2). Добавьте бордюр Image | Add Borders. Отметьте Simmetric = 10.

Теперь выделите всё. Selections | Select All (или Сtrl + A). Затем Selections | Modify | Contract = 10. У вас может походить на рисунок 1 (уменьшен).

рис.1(-)
рисунок 1

Добавьте новый слой, Layers | New, назовите его 'Cotout'.
Идите в Image | Effects | Cutout. Установите Shadow color = Black, Opacity = 100, Blur = от 3 до 4 (здесь 3.3), Offset: V = 2, H = 2.
Добавьте ещё один слой (Shift клик на иконку в левом нижнем углу, на панели слоёв) и отбросьте тень. Image | Effects | Drop Shadow. Установки: Color = White, Opacity = 100, Blur = 1, Offset: V =1, H = 1.

Поскольку здесь фото на белом фоне, то белая тень не очень заметна и нужно будет её слегка подчеркнуть. Но если ваша картинка с другим фоном (например у вас пейзаж), то вам это делать не нужно.
Итак, добавьте ещё один слой. Image | Effects | Cutout. Установите Shadow color = Background Color, Opacity = 100, Blur = 1, Offset: V = -1, H = -1.
Теперь, если есть надобность отрегулируйте затемнёность на панели слоёв (Я в слое 'Cutuot' сделал 80%). Получится примерно как на рисунке 2.

рис 2.
рисунок 2

Далее, таким способом вы можете наслаивать так называемые паспарту сколько угодно. Мы здесь этого делать не будем.

Мы будем заканчивать с рамкой.
Перейдите в слой Background (выделение должно быть активным). Сделайте обратное выделение Selectiоns | Invert. Возьмите инструмент Retouch. Установите: в Tool Controls - Retouch mode = Darken RGB, Paper texture = None.
В Brush Tip - Shape = Round, Opacity = 70, Density = 64, Step = 19.
Затемните слегка бордер, (примерно по три движения на каждую сторону). Затем Image | Edge | Enhance.
Добавьте ещё один слой, назовите его Cutout2. И снова примените эффект Cutout для объемности бордюра. Image | Effects | Cutout. Установки: Shadow color = Black, Opacity = 100, Blur = от 3 до 15 (здесь 11.4), Offset: V = -1, H = -1.
Теперь переместите этот слой на самый верх - Layers | Arrange | Bring to Top. И отрегулируйте затемнёность на слоях. У вас может быть похоже на рисунок 3.

рис.3
рисунок 3

Вам может показаться этот способ каким - то сложным и запутаным. Но на самом деле здесь можно дать разгуляться фантазии и перепробовать всевозможные установки. Например с Retouch, Cutout или фильтрами и т.д. Попробуйте повертеть слои - вы увидите совсем другую рамку.
В принципе все эти примеры схожи и построены на одной схеме. И появились они в процессе экспериментов.

Все [1] [2] [3] [4] Cлед.

содержание


ArTreat | Paint Shop Pro | Шар

Светящийся шар в Painт Shop Pro 5.х

Откройте new image 175 х 175 пикселей. Добавьте новый слой и залейте его чёрным цветом. Foreground Color установите тот цвет в который будет окрашен ваш шар (лучше всего использовать светлые тона). Возьмите инструмент Airbrush, на панели Controls установите Texture = none, Shape = round, Size = 200, Opacity и Density = 100, Hardness = 0. Поставте курсор приблизительно на 70,70 и щёлкните левой кнопкой один раз. У Вас может быть похоже на рисунок 1 (уменьшен).

рис.1 (-)
рисунок 1

Теперь сделайте выделение окружностью установив курсор приблизительно 100 на 100, инструмент Selection; type = Circle, Antialias отмечено. Также Вы можете передвинуть выделеную часть при помощи инструмента Mover щёлкнув правой кнопкой.

рис.2 (-)
рисунок 2

Собствено на этом можно и законьчить - шар готов. Но также можно добавить более чёткий блик, проявляйте фантазию.
Selections | Invert, нажмите клавишу Delete и обратно Selections | Invert. Запишите выделение в альфа канал Selections | Save to Alpha Channel. Поверните шар на 30-40 градусов в право Image | Rotate и All Laers не отмечайте. Снимите выделение. Добавьте новый слой - удерживая Shift на панели слоёв щёлкните на кнопку Add new Layer. Инструментом Selection; type = Elipse, Feather = 3 cделайте небольшое выделение вокруг самой светлой точки вашего шара. И залейте более светлым цветом, чем основной.

рис3 (-)
рисунок 3

Затем Image | Blur | Blur more a потом Image | Blur | Soften more. Теперь на панели слоёв перемещая движок установите непрозрачность (Я сделал 10).
Здесь же отключите видимость слоя Background и соедените два видимых - Layers | Merge | Merge Visible. Загрузите выделение из альфа канала и поверните шар обратно. Получается неплохой шарик, конечный результат ниже.

Теперь Вы можете залить бэкграунд нужным фоном и сохранить как jpg или gif. Отбросить тень или изменить размер (Resize), поработать с цветом в Colors и также использовать как декорацию.

ещё один способ кoторый нужно знать

содержание


ArTreat | Paint Shop Pro | Шар

Шар в PSP 5.х

Для создания сферы или подобного эффекта, также можно использовать инструмент Flood Fill, установив на панели Controls: Fill Style = Sunburst Gradient. В цветовой палитре нужно использовать foreground белый или близкий к нему, а в dackground более тёмный. А величины наклона солнечного луча по вашему желанию.

как бы back

содержание


ArTreat | Paint Shop Pro 5 | 3 Dimension

Трёхмерный текст в Paint Shop Pro 5.х

Создайте New image фон чёрный и напишите текст. Лучше всего для этого эффекта подходит широкий шрифт. Я использовал Tahoma х 72, Antialias отмечено, а Floating не отмечено.
Теперь инструментом Flood Fill залейте выделеный текст от белого к чёрному. B Controls -Fill Options установите Linear Gradient 180 градусов. У Вас может быть похоже на рисунок нижe.

рис.1
рисунок 1

Теперь для получения нужного эффекта идём в Selection | Float и нажав клавишу Shift, стрелками сдвигаем выделеный текст. Осталось только залить его как и раньше, тем же инструментом, только теперь от чёрного цвета к белому. Ниже вы видете, что получилось.

рис.2
рисунок 2

содержание


ArTreat | Paint Shop Pro 5 | 3D Эффект

Трёхмерные кнопки и фигуры в Paint Shop Pro 5.х

В этом примере рассказывается как создать кнопку 3D - стиля. Этот способ Я узнал на домашней странице Paint Shop Pro и здесь он с незначительными изменениями.

В этом примере основной злемент для создания трёхмерного эффекта - свойство Mascs в Paint Shop Pro 5.
Cначала сделаем форму кнопки. Создайте новый имидж File | New или Ctrl + N Чаще всего удобней работать в окне которое больше самой картинки - где есть свободное поле, а потом отрезать лишние края до нужного размера. Если хотите, то вы можете так и поступить. Я здесь работал в окне размером W = 168, H = 128 Background color = White, Image type = 16 Мillion colors.

Теперь используем инструмент Selection для изготовления формы кнопки. Добавляя новое выделение, удерживаем клавишу Shift. Также вы можете удерживать клавишу Ctrl что бы удалить из выделения.
Итак, инструментом Selection с установками Selection type = Elipse, Antialias отмечено, сделайте горизонтальное выделение. Затем удерживая Shift добавьте вертикальное. И в конце сделайте квадратное, Selection type = Square. У вас может быть похоже на рисунок 1.

рис.1
рисунок 1

Залейте выделение чёрным цветом используя инструмент Flood Fill. Установки: Fill Style = Solid Color, Match mode = None, Tolerance = 0, Opacity = 100.

рис. 2
рисунок 2

Снимите выделение, Selections | Select None или Ctrl + D. Теперь создайте маску, Mascs | New | From Image. В открывшемся окне отметьте Source Luminance и Invert Mask Data.
Cохраните маску в альфа канал, Mascs | Save to Alpha Channel. Теперь нужно удалить маску не соединяя с текущим слоем. Mascs | Delete и в открывшемся окне запроса нажмите No.

Залейте картинку белым цветом, инструментом Flood Fill.
Добавьте новый слой, щёлкнув на панели слоев в левом нижнем углу на кнопку Add New Layer ужерживая при этом клавишу Shift. Залейте новый слой чёрным цветом.
Теперь загрузите выделение созданое из маски и сохранёное в альфа канал, Selection | Load From Alpha Channel.
Залейте выделение, от белого к чёрному, используя утановки Fill Style = Sunburst Gradient. Кликните на кнопку Options и установите наклон солнечного луча: Blend Mode = Normal, V = 24, Н = 22. У вас может быть похоже на рисунок 3.

рис.3
рисунок 3

Снимите выделение - Ctrl + D и затем сделайте картинку расплывчатой.
Image | Blur |Gaussian Blur. Установите радиус между 4 и 8, Я здесь использовал 6.

рис.4
рисунок 4

Теперь загрузите маску созданую ранее, Mascs | Load From Alpha Channel и удалите её соединив с текущим слоем, Mascs | Delete. B открывшемся окне запроса нажмите Yes.
Теперь идите в меню Colors | Colorize и установите желаемый цвет. Значение Saturation поставьте примерно 124, а Hue то которое вам нужно.

Теперь добавьте к вашей кнопке тень и текст.
Создайте новый слой и отбросьте тень. Значение Opacity установите 100, а потом на панели слоёв перемещая движок отрегулируйте затемнёность. Остальные значения сделайте на свой вкус.
Для текста добавьте ещё два слоя. В одном напишите текст белым цветом, а в другом чёрным. Удерживая Shift, стрелками сдвиньте немного чёрный текст, как бы создав эффект высеченых букв.
А на второй кнопке на белый текст и указатели наложен эффект Cutout. Конечный резултат - ниже.
кнопка 1
кнопка 2

Вы можете распаковать архив двух этих кнопок (56,7 кб). Они сохранены в файл формате .psp и соответственно слои, маски, выделения вы сможете увидеть и потрогать.

содержание


ArTreat | Paint Shop Pro 5 | Закругленые углы

Закруглёные углы в Paint Shop Pro 5.х

Здесь мы рассмотрим один из способов, как фигуру c острыми, развёрнутыми, прямыми углами сделать без углов. Для примера возьмём прямоугольник из которого нужно сделать кнопку.
Откройте new image 150 х 100 фон белый. В палитре Foreground чёрный Background белый. Инструментом Shapes с установками на панели Controls: Shape = Rectangle, Style = Filled, нарисуйте свою кнопку.

рис.1
рисунок 1

Теперь "размажем" изображение Image | Blur | Gaussian Blur, Radius установите 8 (рис.2). Чем больше Вы установите радиус, тем больше будет закругление, но лучше это не делать, потому что потом картинка получается не совсем чёткая. Лучше после повторить всю операцию ещё раз.

рис.2
рисунок 2

Теперь Colors | Adjust | Brightness/Contrast, Brightness = 10, Contrast = 92. У Вас может быть похоже на рисунок 3.

рис.3

Вот теперь если вам нужна более закруглёная кнопка, повторите все шаги начиная с Gaussian Blur.

После того как Вы получили нужную кнопку Вам наверняка нужно изменить её цвет. Почёму мы сразу не работали с нужным цветом - потому что вокруг кнопки остается сильно заметный ореол или ещё что - нибудь не нужное (в этом примере), но попробовать это можно, иногда получаются забавные вещи.

Итак изменяем цвет. Для этого нужно отделить кнопку от фона. Если сразу использовать Magic Wand или что - нибудь другое, то точного выделения не получится. Оно будет рваным или опять с ореолом.
Идём в Masks | New - From Image. В появившемся окне отметьте Sourse luminance и Invert masc data. Затем Masks | Save to Alpha Channel. Теперь Masks | Delete и в появившемся окне ответьте No.
Добавьте новый слой и залейте цветом, например белым. Теперь Selections | Load from Alpha Channel - у вас появилось чёткое выделение кнопки которое Вы можете теперь закрыть любым цветом.

содержание


ArTreat | Paint Shop Pro 5 | Прозрачный GIF

Прозрачный *Gif в Paint Shop Pro 5.х

Иногда бывает так, что нужно сохранить картинку с прозрачным фоном. В PSP 5 это несложно сделать используя графический формат *gif. Допустим, что картинка которую нужно сделать прозрачной лежит на белом фоне. Выберите его с помощью инструмента Dropper, щёлкнув правой кнопкой на белый цвет. Теперь в Selections | Select All и затем Selections | Modify | Transparent Color установите Background Color и Tolerance = 0. У вас может получится как на рис.1.

рис.1
рисунок 1

Теперь придётся пожертвовать цветом, изменив его на 256 цветов - Colors | Decrease Color Depth | 256 Colors. Я использовал установки показаные ниже.

рис.2
рисунок 2

Затем идём в Сolors и отмечаем View Palette Transparency и снова в Сolors | Set Palette Transparency, в появившемся окне отмечаем background color как на рис.3

рис.3
рисунок 3

Сейчас вы может видеть картинку с прозрачным фоном, примерно как на рис.4

рис.4
рисунок 4

Осталось теперь записать файл в *gif фотмате. File | Save As в строке Тип файла выберите CompuServe Graphics Interchange (*.gif), а в Options обязательно отметьте 'Version 89a' и 'Interlaced'.
На этом всё, картинка с прозрачным фоном готова. Конечный результат на рис.5

рис.5
рисунок 5

Второй оптимальный способ

содержание


Artreat | Perspective Shadow

Эффект перспективной тени в Paint Shop Pro 6

Эта техника может быть использована не только с текстом, но и с другими объектами.

Для пользователей Paint Shop Pro 5.x
В пятой версии данный эффект достигается с помощью инструмента Deformation или Image | Deformations | Skew и т. д. То есть все векторные дела из шестой версии, в пятой, заменяйте функцией Deformations.

Создайте New Image. В этом примере Background color = White, размер окна W = 200, H = 100.

Кликните на инструмент Text, а затем на будущею картинку. В открывшемся окне выберите тёмный цвет текста, а также отметьте Vector и Antialias, как на рисунке 1. Наберите тект и нажмите OK.

рис.1
рисунок 1

У вас появился текст, а на панели слоёв (Layer Palette) добавился векторный слой. Кликните правой кнопкой мыши на этот слой и в открывшемся меню выберите Duplicate, как на рисунке 2.

рис.2
рисунок 2

Первый слой, это будет "Перспективная тень" а его копия, сам "Текст". Для удобства, чтобы не путаться со слоями дадим им имена. Кликнув два раза на слой, открывается окно свойств. В поле Name, впишите "Тень" и "Текст" соответственно.

Сейчас у вас активны оба слоя. Раскройте слой "Тень" кликнув на крестик и сделайте активным векторный объект (он там один), рисунок 3.

рис.3
рисунок 3

Теперь на картинке, взяв за верхний край рамки, удерживая кливишу Shift перетените её в право, на нужное вам расстояние. Затем отпустив Shift, перетените верхний край рамки немного вниз. У вас должно получится, примерно как на рисунке 4.

рис.4
рисунок 4

Кликните на инструмент Selection Selection tool

  • Selection Type = Rectangle
  • Feather = 0

Сделайте прямоугольное выделение вокруг объекта, а затем кликните внутри него. У вас получится как на рисунке 5.

рис.5
рисунок 5

Тут надо сказать про слой Background и сделаное выделение. После того как вы получили Floating Selection, с ним можно работать как с растровым слоем (использовать кисти, фильтры и т.д.). Но когда вы его снимите, то все что вы сделали в этом выделении, свалится на ближайший растровый слой. В этом примере таковым окажется Background.

Если вы потом будете перекрашивать этот слой, ну скажем в зеленый, то соответственно всё что вы сделали закрасится. Поэтому нужен ещё один растровый слой который можно будет редактировать не затрагивая Background.

Добавим новый растровый слой.

Кликните на панели слоёв правой кнопкой в Background и выбирете в меню New Raster Layer. Назовём его "Тень 2" и вернёмся обратно к выделению кликнув на Floating Selection.

Активна Floating Selection. Возьмите инструмент Flood Fill Flood Fill

  • Закладка Flood Fill
  • Fill Style = Solid Color
  • Blend mode = Normal
  • Paper texture и Match mode = None
  • Opacity = 100
Залейте выделение цветом, светлее чем чёрный (здесь #B8B8B8). На рисунке 6 выделение спрятано, но активно.

рис.6
рисунок 6

Снимите выделение, Ctrl + D и на вопрос программы, кликните Yes. На панели слоёв отключите видимость, слоя "Тень" и перейдите в слой "Тень 2".

рис.7
рисунок 7

Затем, Image | Blur | Soften (рисунок 8).

рис.8
рисунок 8

Теперь у вас есть текст от которого падает перспективная тень. Его осталось только раскрасить или наложить нужный эффект. например так.

Приведеные в этом примере цвет тени, наклон или размытость вы можете изменять по своему желанию/вкусу.

содержание


Artreat | Perspective Shadow

Эффект перспективной тени в Paint Shop Pro 6

Преобразуйте слой "Текст" в растровый, кликнув на нём правой кнопкой мыши. В открывшемся меню выберите Convert to Raster.

Инструментом Selection выделите текст (рис.1) и кликните внутри выделения (рис.2).

рис.1
рисунок 1
рис.2
рисунок 2
  • Selections | Defloat (Shift + Ctrl + F)
  • Selections | Float (Ctrl + F)

Удерживая Shift, стрелками на клавиатуре сдвиньте выделение. По одному разу, влево и вниз.

Примените эффект

  • Image | Effects | Sculpture с уcтановками как на рисунке 3 (Pattern 30).

рис.3
рисунок 3

Снимите выделение Ctrl + D и соедините слои, Layers | Merge | Merge Visible. Конечный результат на рисунке 4.

рис.4
рисунок 4

на предыдущую страницу

содержание


ArTreat | Панель инструментов в Paint Shop Pro 5

Панель инструментов Paint Shop Pro 5.x
Eсли Вы только начинаете знакомиться с Paint Shop Pro 5.x то это страничка может Вам пригодиться. По себе знаю, на первых порах, методом тыка долго и упорно соображаешь что для чего. Но теперь всё, конец моим страданиям. Вот оно, описание панели инструментов, краткое объяснение основ каждого инструмента. Также смотри Горячие клавиши
Инструменты PSP 5.x
Arrow | Moover | Dropper | Retouch | Flood Fill
Zoom | Selection | Paint Brushes | Eraser | Text
Deformation | Freehand | Clone Brush | Picture Tube | Line
Crop | Magic Wand | Color Replacer | Airbrush | Shapes

Arrow Этот инструмент пригодится вам в работе когда ваша картинка увеличина - расширена. Кликнув левой кнопкой и удерживая её на рисунке вы прокручиваете изображение в этом окне. Другими словами выполняет функцию scrolling.

Zoom Инструмент лупа используется для увеличения или уменьшения окна. Щёлкнув левой кнопкой в окне с графикой вы увеличиваете масштаб изображения, а правой кнопкой уменьшаете. Также можно использовать клавиши "+" и "-".

Deformation Этот инструмент позволяет вращать или перекашивать, расширять и сокращать, сдигать или искажать рисунок слой или выделеную область. Можно задавать координаты кликнув два раза на инструмент.

Crop Используя этот инструмент вы отрезаете на картинке лишние края. Действует как резак. Всё что находится за выделением обрубается двойным щелчком. Можно задавать координаты кликнув два раза на инструмент. Как раз этим способом я и резал панель на мелкие кусочки, таким образом они все получились одного размера.

Moover Позволяет сдвигать текст, слой или выделение. Щёлкнув левой кнопкой вы сдвигаете картинку, а правой выделение в отдельном слое.

Selection С помощью этого инструмента вы можете сделать выделение в виде квадрата, прямоугольника, круга или элипса. Для окружностей лучше отмечать Antialias на панели Controls - сглаживает края. Щёлкнув два раза на панели инструментов вы можете установить координаты выделения квадрата и прямоугольника.

Freehand Инструмент лассо, позволяет сделать свободное выделение, от точки к точке и Smart Edge. Не знаю как точно первести, но что - то вроде интеллектуалного края. Создает выделение на гранинице между двумя областями контрастирующих по цвету или освещёности. Полезно для предварительного выделения.

Magic Wand Еще один удобный инструмент для выделения, волшебная палочка. Когда вы кликаете на цвет, выделяются все прилегающие одноцветные точки. Удерживая клавишу Shift и кликнув в другое место графики, к старому добавляется новое выделение. Удерживая клавишу Ctrl и щёлкнув на выделеную часть, выделение снимается. Настройки инструмента задаются на панели Controls.

Dropper Инструментом пипетка вы определяете цвет в цветовой палитре. Щёлкнув на цвет левой кнопкой мыши вы устанавливаете передний (foreground) цвет и соответствено правой, противоположный (background) цвет.

Paint Brushes Инструмент кисть имеет много характеристик. Позволяет регулировать размер кисти, прозрачность, форму, структуру, плотность и т. д. Все эти значения устанавливаются на панели Controls. Вы также можете создавать свои кисти используя графику и даже шрифты.

Clone Brush Это весьма забавный инструмент, позволяет клонировать (дублировать) изображение или его часть. Как и предыдущий имеет массу особенностей. Щёлкнув правой кнопкой на оригинал, левой вы уже дублируете картинку здесь же или на другой слой, или в другом окне.

Color Replacer Этот инструмент даёт возможность заменить один цвет на другой. Для выполнения этого, установите нужный передний цвет, а вторым тот, который вы хотите заменить. Затем кликните два раза на картинку.

Retouch Ретушь. Довольно запутаныный инструмент позволяющий создавать эффекты, подобно фото ретуши. Имеет массу настроек - кисти, структуру, прозрачность и т. д. всё это на панели Controls. Некоторые способы ретуши заменяют команду Adjust Color.

Eraser Инструмент ластик. В сущности и действует соответсвенно, стирает изображение. Но также можно стирать, нужным цветом и фактурой. Стиреть цвет на каком - нибудь уровне, сделав его прозрачным. Или левой кнопкой стереть а правой востановить.

Picture Tube Этот инструмент использует готовые картинки, заранее вложенные в него. Как тюбик - надавил и он тебе картинку, он так и называется тюбик с картинками. Можно менять размер "выдавливаемой" картинки а также добавлять в Tube свои.

Airbrush Распылитель хороший инструмент, много возможностей, но в чём отличие от Paint Brushes Я не разобрался. Почитайте Help файл может у вас получится.

Flood Fill Заливка, мой любимый инструмент в смысле использую чаще других. Позволяет заливать ровным цветом, готовым шаблоном или под наклоном, комбинируя цвета foreground и background. Эти и другие значения задаются на панели Controls.

Text Используется, что бы написать текст на картинке или как самостаятельная картинка в виде текста. Имеет своё собственное окно настроек.При написании лучше отметить опцию Antialias - это сгладит неровности на краях буквы. Опция Floating даёт возможность писать без цвета создавая только выделение. Прекрасно понимает русский язык.

Line Этот инструмент чаще всего используется для того что бы нарисовать прямую линию. Нажмите клавишу Shift и проведите линию курсор может гулять, но линия будет прямой. Удерживая Alt линия соединится с точкой где курсор был в последний раз.Также есть функция позволяющая искривить линию два раза. Если вы рисуете линию под углом то лучше отметить Antialias. Можно задать ширину линии.

Shapes Этим инструментом можно создавать контурные и заполненые цветом фигуры. Для закруглёных форм лучше отмечать Antialias что бы сгладить края.

наверх

содержание


Artret | Paint Shop Pro 5.x |

Текстура дерево в PaintShop Pro 5.x

Не самая сложная текстура в PSP, дерево. Делается достаточно просто с помощью соответствующей структуры кисти, текстуры Woodgrain и фильтра Hot Wax Coating. Более всего эта текстура походит на старое высохшее дерево.

Все установки и характеристики не являются обязательными и могут свободо менятся. Вы можете пробовать и эксперементировать добовляя свои установки, меняя цвет, изменяя тени корректируя цвета на слоях и т.п. Пробуйте и вы найдёте свою, оригинальную текстуру.

Начните с того, что создайте новый имидж с белым фоном и сделайте выделение - Selection Tool.

рис.1
рисунок 1

Возьмите инструмент Airbrush и установите background color тёмно коричневый.
Я использовал с таким HTML кодом #804F08. А foreground поставьте белый #FFFFFF Расписывать здесь каждый цвет очень долго, если у вас есть PSP то вставьте этот код в окно Color и вы всё увидите. Вызывается это окно щелчком в цветовые окошки.

Теперь опредeлите структуру кисти, на панели Controls

  • Tool Controls
    Woodgrain
  • Brush Tip
Shape = Round
Size = 37
Opacity =
        83
Density = 100
Step = 25
Hardness = 0

А теперь закрасьте выделение удерживая правую кнопку мыши.

рис. 2
рисунок 2

Раздвиньте немного выделение Selections | Modify | Expand от 2 до 6, (здесь 2) и закрасьте белый край, рисунок 2.

Теперь примените фильтры,

  • Image | Other | Hot Wax Coating а затем
  • Image | Sharpen | Sharpen

У вас может быть похоже на рисунок 3

рис.3
рисунок 3

Собственно всё. Дальше пойдет полёт фантазии.

Слегка отрегулируем цвета и добавим тени

  • Colors | Adjust | Gamma Correction = отметьте Link; R, G, B = 0.80
  • Создайте новый слой, Layers | New или на панели слоёв кнопочка Add New Laeyr
  • Image | Effects | Cutout;
    Shadow color = Black
    Opacity = 100
    Blur = 57
    Offset; V = 2, H = 1
  • Добавьте ещё один слой
  • Image | Effects | Drop Shadow
    Color = Black
    Opacity = 100
    Blur = 4.7
    Offset; V = 2, H = -2
  • Перейдите в слой Background (самый нижний) и добавьте ещё один слой
  • Cожмите выделение
    Selections | Modify | Contract = 2
  • Повторите эффект тень, только белого цвета и Blur = 0

Теперь на панели слоёв, передвигая движки отрегулируйте затемнёность на слоях как вам нравится. А под конец зайдите в Colors | Adjust | Brightness/Contrast и подкрутите яркость на слое бэкграунд (если нужно). Конечный результат ниже.

содержание


Artret | Paint Shop Pro 5.x |

Zoom Картинка в картинке

Этот эффект скорее всего пригодится только для анимированых картинок, хотя вы может быть найдёте и другое применение.
В Animation Shop 1.03 входящий в пакет Paint Shop Pro такой эффект встроен в функцию Transition, называется Zoom, но только в нём есть недостаток. Он не удерживает (запоминает) предыдущие кадры.

Original
Zoom PiP
картинка взята с www.webshots.com

Откройте вашу картикнку, если это Gif, то переведите её для начала в 16 млн. цветов. Если вы расщитываете ещё попользоваться оригиналом, то продублируйте её, Shift + D, и закройте оригинал.

  • Скопируйте слой (background) Ctrl + C и вставьте как новый слой, Ctrl + L.

Теперь осталось только изменить размер слоя, до нужных вам размеров. Щёлкните кнопку Resize в Tool bar, если у вас её там ещё нет тогда, Image | Resize.

  • В открывшемся окне отметьте Maintain aspect ratio
  • Опцию Resize All Layers не отмечайте
  • Resize Type на ваш выбор
  • И отметьте Percentage of Original
    (в этих полях вводится процентное отношение изменений от оригинала. Я здесь использовал 85).

Теперь повторите эти же шаги столько, сколько вам нужно. Тоесть копируете активный слой. Вставляте как новый. Изменяете размер. И так далее.

Диалоговое окно Rеsize для этого примера
dialog box Resize

О том, как сделать из получившейся картинки анимированый *gif, расскажется в следующий раз. Если Вам не терпится, скажу что в Anim. Shop'е в предпочтениях нужно отметить Keep each layеr as separate frame.

как бы back

содержание


Arтreat | Paint Shop Pro 5 | Beveled Text

Текст с закруглёными краями в Paint Shop Pro 5.х

Здесь мы рассмотрим эффект создающий ощущение выдавленых (выпуклых) букв. Также его можно использовать и с любым другим рисунком, не обязательно текстом.
Итак, открываю New image и заливаю нужный фон. Добавляю новый слой, Layers | New и размещаю текст, Floating не отмечено. Сохраняю выбраный текст в альфа канал Selections | Save to Alpha Channel (это пригодится если вы потом решите что-нибудь изменить).

рис.1
рисунок 1

Теперь применяю эффект.

  • Image | Effects | Cutout и устанавливаю
    Shadow color = Black
    Opacity = 83
    Blur = 5-7
    Offset = V -3, H -3.
  • Добавьте новый слой и снова примените эффект Cutout, только на этот раз
    Shadow color = White
    Offset = 3; 3
У вас может быть похоже на рис.2. Если желаете, то добавьте тень Image | Effects | DropShadow, рисунок 3. Не забывайте что вы можете корректировать применёные эффекты на панели уровней - Layer Palette, передвигая движки.
рис.2
рисунок 2

(рис.3)
рисунок 3

содержание


Paint Shop Pro index

Уроки работы в Paint Shop Pro

Панель инструментов
Горячие клавиши
Трёхмерный текст
Текст с окантовкой
Текст с закругленными краями
Округлые формы
За 5 сек
3D кнопка
Рамка-бордюр
Эффект перспективной тени
Тиснение
Текстура Дерево
Прозрачный gif
Светящийся шар
Огонь в Paint Shop Pro
Так... о разном


Adobe Photoshop 6.0 - полное описание новых функций

Как водится, в новой версии монстра Adobe Photoshop 6.0 присутствуют и новые инструменты и функции работы с графикой, и ряд новых возможностей для Веб и существенные изменения интерфейса и организации рабочих процессов. Начнем с первого:

Поддержка работы с векторами

Теперь Photoshop содержит полный набор инструментов для работы с векторной графикой и текстом, позволяя сохранять в одном файле векторный, не зависящий от разрешения, дизайн и текст совместно с растровыми элементами.

Набор содержит инструменты "прямоугольник", "скругленный прямоугольник", "эллипс", "полигон" и "линия". С их помощью в документе создаются слои нового типа - векторные. Кроме того, по аналогии с Adobe Illustrator, продукт может осуществлять операции разделения, слияния, наложения и пр. векторных объектов.

Теперь с помощью Photoshop 6.0 можно создавать четкую, не зависящую от разрешения графику и текст и комбинировать их с растровыми слоями для получения в результате четких краев. Новые возможности по форматированию и работе с текстом включают в себя возможности искажения блоков текста с целью достижения различных эффектов. При этом текст поддается редактированию вне зависимости от того, какие эффекты и как были к нему приложены.

Расширенные возможности экспорта в PDF

 Продукт продолжил процесс интеграции с линейкой Adobe и теперь может сохранять в PDF-формате слои, прозрачные участки и векторную графику. Любое сервис-бюро, работающее с таким инструментом допечатной подготовки, как Adobe Acrobat InProduction или аналогичным подключаемым модулем к Acrobat может принимать такие файлы и готовить их к высококачественной печати.

Работа со слоями

 Photoshop 6.0 представил новый интуитивный интерфейс работы со слоями эффектов, набор новых эффектов и поддержку создания библиотеки стилей, содержащих различные эффекты, для дальнейшего использования. Новое диалоговое окно Layer Styles показывает список всех эффектов, примененных к конкретному слою и позволяет манипулировать ими. При сохранении нового стиля он появляется в новой палитре Styles.

Чтобы применить стиль к слою, нужно создать графику, набрать текст и графические элементы в слое и щелкнуть на стиле, который хочется применить. Можно, однако, выбрав инструмент Shape, выбрать стиль слоя в контекстно-зависимой панели настроек инструментов и начать рисовать: Photoshop будет накладывать стиль по мере создания рисунка. Комбинация стилей слоев и новый набор векторных инструментов рисования создают новые творческие возможности для полиграфического и Веб-дизайна.
Вписывание графики

Новый инструмент позволяет искажать или вписывать графику непосредственно вытягивая, вдавливая, разворачивая или увеличивая участки изображения. Такое управление искажениями необходимо в самых разных сферах дизайна. При открытии диалогового окна Liquify можно увидеть тонкую сетку, позволяющую точно настроить деформации различных участков. Для предотвращения от порчи можно заблокировать отдельные части изображения. Для переключения с масштабных работ к мелким детальным изменениями достаточно изменить размер используемой кисти. Кроме того, всегда имеется возможность реконструировать исходное изображение.

Инструменты нарезки изображения
С помощью новых инструментов нарезки вы можете нарезать Веб-графику прямо в Photoshop 6.0. Пользовательскую нарезку можно осуществить простым перетягиванием инструмента в нужной части изображения. "Недорезанные" участки режутся автоматически, позволяя генерировать HTML-таблицу при экспорте графики. Многочисленные настройки позволяют управлять размером, положением, порядком и отображением кусочков.

Вы можете выделить отдельные кусочки и установить для них специфические параметры оптимизации с помощью диалогового окна Save for Web. К примеру, использовать настройки GIF для участков, содержащих текст, и JPEG-установки для графики. Кроме того, можно установить различные имена файлов, ссылки и пр. для каждого кусочка.

Взвешенное управление оптимизацией
Что это значит? Всего-навсего, что с помощью 8-битной маски вы можете задать установки компресси для разных участков изображения! Эта технология позволяет добиться качественных результатов сжатия в критических, изобилующих деталями, частях изображения при сжатии, не прибегая к нарезке его на куски. В отличие от технологий нарезки, где все кусочки являются прямоугольными, вы можете использовать естественные контуры частей изображения, нуждающиеся в доп. настройках сжатия. Настройки участков позволяют управлять параметрами GIF- и JPEG-сжатия и количеством индексированных цветов в пользовательских палитрах.

Динамическая послоевая нарезка
Photoshop 6.0 предлагает новый способ нарезки изображений: выберите эффекты для выделенных слоев и позвольте продукту самому создать нарезку на базе слоев. Если вы нарежете изображение таким способом, каждый рез будет проходить по границе изображения в слое. Если в последствии вы передвинете или измените содержимое слоя, нарезка автоматически отразит эти изменения. Такая технология очень подходит для точных нарезок для ролловеров.

Более тесная интеграция с Adobe ImageReady 3.0
Теперь Photoshop 6.0 содержит собственные инструменты нарезки, позволяющие прибегать к ImageReady только в особых случаях. Оба продукта поддерживают динамическую послоевую нарезку, позволяющую автоматически строить резы по границами изображений в слоях. Новые стили ролловеров, расширенная поддержка мапов и взвешенное управление оптимизацией направлены на ускорение рабочих процессов веб-дизайна. Встроенные векторные инструменты и слоевые стили тоже служат этому.

Расширенное управление слоями
Теперь можно создавать сотни слоев с вспомогательными элементами для удобства работы. Кроме того, можно пользоваться массой новых возможностей по организации и управлению слоями. К примеру, можно собирать слои в наборы для облегчения просмотра нужных частей графики. Можно помечать слой цветом для облегчения идентификации и блокировать редактирование слоев, установки прозрачности и их расположение. Можно даже натаскивать иконки стилей на слои для копирования. Палитра Layers содержит новое меню для управления слоями с динамической заливкой. Вы можете сохранять слои при создании PDF- и TIFF-файлов.
Новые возможности работы с текстом

 Photoshop 6.0 предлагает расширенный набор функций форматирования как европейских, так и азиатских текстов. Теперь можно вводить, форматировать и редактировать текст непосредственно на изображении, без переключений в диалоговое окно. Можно назначать цвет и стиль каждой букве текста независимо. Текст остается редактируемым даже после поворотов, масштабирования и искажения. К тому же можно пользоваться новыми эффектами вписывания текстов без потери редактируемости.

Форматировать текст можно с помощью двух новых палитр: Paragraph и Character, которые выглядят и работают так же, как в продуктах Adobe Illustrator и Adobe InDesign. Новые возможности включают выключку и растяжку абзацев, авто-интерлиньяж и пр. возможности, базирующиеся на параграфах. Англоязычная версия предлагает профессиональные установки по переносу текстов с контролем минимальных размеров слов, минимальным количеством букв до и после переноса, управлением "лесенками"(ограничением количества последовательно идущих строк, заканчивающися переносом) и зоной переноса.

Photoshop 6.0 располагает и элементами форматирования иероглифических текстов. Нам это не интересно.

Рационализированный интерфейс
Ряд изменений интерфейса призван облегчить и ускорить использование мощного инструментария продукта. Новая контекстно-зависимая панель установок инструментов интуитивно-понятна и дает быстрый доступ к настройкам каждого активного инструмента. Можно создавать стек часто используемых палитр, для того, чтобы они были под рукой. Новое контекстное меню позволяет переключать единицы измерения линеек "на лету". В Windows в меню Open вы можете просмотреть миниатюры файлов, чтобы выбрать именно тот, который хотите открыть.


"Publish/Дизайн, Верстка, Печать" (Издательство "Открытые Системы")

Новости

Power Mac G4
Фильтры и модули на любой вкус
Естественность Painter 6
Допечатные технологические процессы: Heidelberg и Creo делают ставку на PDF
Рынок перезаписываемых DVD требует стандарта
Кино
Чернила с плюсом
Машины RYOBI разгоняются
Xerox приобретает отделение цветной печати Tektronix
Yam идет на Восток 		Заверните
Heidelberg расширяется
«Графитек» снижает цены...
...и открывает Web-узлы
Canon авторизует партнеров
Инсталляция
Imacon снова в СНГ
Nikon — профессионализм растет
2560 на четыре
МВ: хороших и разных принтеров и копиров должно быть много
NT завоевывает рынок Macintosh

Power Mac G4

Apple выпустила Power Mac G4 — первый представитель нового поколения настольных компьютеров, разработанных для профессиональных пользователей. Модель, обладающую уровнем производительности суперкомпьютера.

Power Mac G4 оснащен принципиально новым процессором PowerPC G4, разработанным совместно Apple, Motorola и IBM, и является первым в истории персональным компьютером, обеспечивающим производительность более 1 млрд. операций с плавающей точкой в секунду (пиковая производительность процессора PowerPC G4 достигает 4 млрд. в секунду).

Отличительная особенность нового процессора — встроенный SIMD-модуль (под названием Velocity Engine), позволяющий с большой скоростью параллельно обрабатывать векторные данные и обладающий дополнительными 162 процессорными инструкциями и 32 регистрами разрядностью в 128 бит. Новая линейка Power Mac G4 представлена тремя моделями, снабженными 400 МГц, 450 МГц и 500 МГц процессорами. Корпус Power Mac G4 сделан из полупрозрачного светлого пластика, окрашенного в цвета серебра и графита. Более подробную информацию о новых компьютерах Apple можно получить на узлах www.apple.com и www.apple.ru.

Фильтры и модули на любой вкус

Программы редактирования изображений обладают обилием возможностей, но дизайнеры всегда находятся в поиске новых фильтров и эффектов. Разработчики дополнительных модулей для Adobe Photoshop с удовольствием удовлетворяют эти желания. Все упомянутые ниже продукты выпускаются в версиях для Macintosh и Windows.

Новая версия PhotoFrame компании Extensis позволяет создавать эффектные рамки и контуры для изображений. В версии 2 за 199,95 долл. вы получите более 1000 настраиваемых рамок, а с добавлением эффектов, таких как текстуры, размытие и тени, общее количество эффектов увеличивается еще больше.

С Web-узла MetaCreations можно загрузить отдельные дополнительные модули, начиная с KPT Equalizer (29 долл.) и KPT Gel (49 долл., включая Equilizer). Фильтры Bounded Sharpen и Contrast Sharpen, которые входят в KPT Equlizer, содержать девять движков для настройки частоты повторения изображений. KPT Gel создает трехмерные эффекты с металлическими, пластиковыми и жидкими текстурами.

Еще один набор трехмерных фильтров — BladePro (49 долл.) компании CommUnique. В него входит 100 заранее заданных наборов параметров для имитации объемных поверхностей — от грязной травы до смятой золотой фольги — которые можно применять к изображениям или тексту. Можно также создавать собственные текстуры с нуля или настраивать любые наборы заданных параметров, редактируя их характеристики, такие как высота, глянец, отражение и освещение.

Компания Andromeda Software представила пакет Cutline Filter (69 долл.), который придает изображениям вид барельефов или резьбы по дереву, заменяя тона в изображении с градациями серого на черно-белые линии или точки. Инструмент под названием Stamper изменяет видимое направление барельефа.

Источники: Extensis, www.extensis.com;
MetaCreations, www.metacreations.com;
CommUnique Software, www.comm-unique.com;
Andromeda Software, www.andromeda.com.

Естественность Painter 6

В то время как в версии 5.5 пакета Painter компании MetaCreations улучшения были сосредоточены, в основном, в функциях для Web, в новейшей реализации разработчики вернулись к основам. Painter 6, который поддерживает как Mac OS 8, так и Windows 95/98/2000 и NT 4, не только наполнен множеством гибких инструментов и естественных кистей, но и обеспечивает удобный доступ к параметрам кисти, а также включает давно ожидавшуюся возможность открывать и сохранять файлы CMYK TIFF.

В Painter 6 компании MetaCreations реализованы новые и улучшенные кисти, такие как «ворсистый» аэрограф, при помощи которого создан этот рисунок.

Painter 6 полностью поддерживает технологии Wacom Intuos, такие как Airbrush и Fingerwheel, обеспечивающие более естественную прорисовку линий кистями и распределение заливок при помощи «аэрозолей». Режим Impasto теперь работает с большинством кистей, а слой impasto теперь обладает глубиной, которую можно комбинировать с глубинами других слоев. Количество слоев в изображении не ограничено, а для каждого слоя задается собственный режим перехода и уровень прозрачности; кроме того слои можно группировать. С помощью инструмента Безье можно расположить вдоль кривой динамический текст, а функция загрузки кистей позволяет выбирать для кисти другой цвета, что придаст изображению большую естественность.

В комплекте с программой теперь поставляется множество полезных вещей, включая три фильтра KPT 5: Noize, FlaxFrame и RadWarp.

Ориентировочная розничная цена Painter 6, начало поставок которого запланировано на конец сентября, составляет 399 долл.; стоимость обновления — 149 долл.

Источник: MetaCreations, www.metacreation.com.

Допечатные технологические процессы: Heidelberg и Creo делают ставку на PDF

Желая упростить допечатный технологический процесс, компании Creo и Heidelberg организовали совместное предприятие по продвижению на рынок PDF-ориентированного инструмента под названием Prinergy. Представление продукта состоялось на сентябрьской конференции Seybold Seminars в Сан-Франциско.

Prinergy преобразует файлы допечатного процесса в формат Portable Document Format, PDF (переносимый формат документов) компании Adobe. По мнению разработчиков Creo, профессионалы в области допечатной подготовки за счет меньших размеров файлов PDF сэкономят время на их обработке и переносе. Prinergy поставляется с заранее описанными сценариями ручного треппинга, управления цветом, спуском полос, цветопробой и изготовлением печатных форм.

В Prinergy используется технология Adobe PostScript Extreme — коллекция программных компонентов для построения технологического процесса на основе PDF.

«Полный переход на этот допечатный процесс должен быть совершен за пару лет. Специализированные системы конечно хороши, но мы хотим поднять их планку до уровня, когда большинство людей смогут строить технологические процессы с использованием PostScript или PDF.», — рассказывает Дэвид Кауфман, руководитель направления разработки продуктов для технологических процессов.

По словам Кауфмана, компании Creo и Heidelberg решили начать разработку открытого технологического процесса после того, как обнаружили, что причиной ограничений производительности в устройствах прямого вывода форм являются не приводы, а RIP и другие компоненты сервера печати. В качестве базиса технологии они выбрали открытый формат файла, что позволит обрабатывать генерируемые данный при помощи инструментов третьих фирм.

Prinergy поставляется как базовая система, в которую входит сервер для платформы Windows NT плюс приложение-клиент на основе Java; в дальнейшем к этому набору могут быть добавлены дополнительные компоненты. К моменту сдачи публикации в печать стоимость продукта еще не была определена, хотя по информации Creo, стоимость Prinergy будет сопоставима с другими существующими цифровыми системами для организации технологического процесса.

«Управление технологическим процессом традиционно строилось при помощи обычных досок для демонстрации или баз данных на FileMaker, — говорит Кауффман. — Создание Prinergy — это попытка перенести управление технологическим процессом с демонстрационных досок и баз данных на компьютерных экранах».

Источники: Creo, www.creo.com; Heidelberg, www.heidelbergusa.com.

Рынок перезаписываемых DVD требует стандарта

Новая спецификация должна быть объявлена до конца года. В ближайшее время запутанная ситуация на рынке перезаписываемых DVD должна несколько проясниться. Ассоциация по технологиям оптических накопителей (Optical Storage Technology Association, OSTA) напряженно работает над новым стандартом DVD — MultyRead 2000 — который должен быть опубликован в декабре текущего года. По информации OSTA, этот стандарт позволит производителям выпускать дисководы, которые смогут читать все типы перезаписываемых и записываемых дисков DVD, а также CD.

«Мы не сможем совместить в одном формате все варианты перезаписываемых DVD, поэтому пытаемся добиться совместимости среди различных форматов», — сказал один из координаторов OSTA Рей Фриман.

Этот случай не первый, когда расположенная в Санта-Барбаре (шт. Калифорния) группа по стандартам, призвана навести порядок на рынке оптических накопителей. Когда четыре-пять лет назад носители CD начали наводнять рынок, количество разнообразных форматов стало быстро расти. Производители выпускали собственные версии носителей CD-ROM, записываемых CD-R и перезаписываемых CD-RW, не говоря уж об стандартных аудио-CD и новейших DVD. Покупателям приходилось делать выбор, не зная, какому из стандартов достанется львиная доля рынка. Спецификация MultiRead, разработанная OSTA и ратифицированная в 1997 году, содержала три основных требования для оптических запоминающих устройств и носителей: они должны работать в широком диапазоне волн лазерного излучения (в DVD используются более короткие волны, которые позволяют записывать большее количество данных на той же площади); отражающая способность перезаписываемых CD должна быть повышена (поскольку лазер расправляет записывающую поверхность этого типа CD при каждой перезаписи, каждый раз диск отражает все меньше и меньше света); и, наконец, они должны поддерживать запись пакетов (наборов данных, записываемых на диск в течение одного сеанса) фиксированной и переменной длины.

Спецификация MultiRead была одобрена примерно двадцатью производителями оптических накопителей, «владеющих подавляющей долей рынка CD-ROM, — отметил Фриман. — Накопители DVD-ROM и версии DVD с однократной записью в настоящее время полностью совместимы с MultiRead. Я не думаю, что сегодня можно приобрести дисковод CD-ROM, не отвечающий спецификации MulriRead».

Однако с появлением на рынке новых перезаписываемых DVD-дисководов и носителей, необходимость в выработке стандарта возникла снова. Любой человек, который собирается записать DVD, находится в некотором замешательстве из-за большого количества возможных опций. Можно выбрать между DVD-ROM или DVD-RAM (последний, не смотря на вторую часть названия, не имеет никакого отношения к памяти произвольного доступа), записываемым DVD-R и двумя перезаписываемыми форматами: DVD+RW и DVD-RW. В настоящее время DVD-RAM и DVD+RW, первые перезаписываемые форматы, появившиеся на рынке, не совместимы друг с другом.

«Мы надеемся, что MultiRead 2000 будет одобрен примерно также, как и принятая раньше спецификация MultiRead, и это позволит читать на совместимых с MultiRead 2000 дисководах носители DVD-RAM, DVD-RW, DVD+RW и DVD-R», — предполагает Фриман.

Хотя MultiRead 2000, в случае его одобрения производителями, позволит читать на оптических дисководах CD и DVD любые типы перезаписываемых носителей DVD, это не окажет никакого влияния на существующие накопители. Итак, тем, кто подумывает о покупке одного из существующих дисководов DVD до Рождества, лучше всего один-два месяца выждать.

Подробнее об OSTA и стандарта MultiRead 2000 можно почитать в Web: www.osta.org.

Кино

Компания Apple представила новый плоский монитор Apple Cinema Display с диагональю 22 дюйма — самый большой из существующих на рынке LCD-дисплеев.

Cinema Display обеспечивает такую же видимую область изображения, как и CRT дисплей c диагональю 24 дюйма. Он поддерживает разрешение до 1600 x 1024 пикселов и отображает 16,7 миллионов цветов.

Информация предоставлена компанией DPI, www.dpi.ru.

Чернила с плюсом

Компания ENCAD объявила о начале поставок новых чернил GS PLUS. Так же как и чернила GS (Graphic Standard), они предназначены для помещений и имеют те же спектральные характеристики.

Их основным достоинством является значительно более высокая скорость высыхания и затвердевания, чем у чернил GS, что позволяет сократить срок просушки отпечатков перед их ламинированием. Наиболее заметен выигрыш при их применении в сочетании с оригинальными носителями фирмы ENCAD Photo Gloss PLUS (глянцевыми) и Photo Semi+Gloss PLUS (полуматовыми) а также новейшей технологией печати MicroBurst+, используемой в последних плоттерах ENCAD NovaJet 700/630. Так, отпечаток с 200% заливкой может быть заламинирован не позднее, чем через 6 часов после печати и просушки в нормальных условиях. Это вдвое меньше, чем при работе с чернилами GS.

Новое поколение чернил GS в том же цветовом пространстве позволяет получить визуально более яркие отпечатки при изготовлении различной продукции, включая фоторепродукции, витражи, внутреннюю рекламу, постеры и баннеры. Высокое качество печати гарантируется и на других 9 типах оригинальных носителей ENCAD для помещений.

Цена новых чернил GS PLUS не превышает стоимости чернил GS.

Машины RYOBI разгоняются

Компания RYOBI начала серийное производство листовых печатных машин новой серии RYOBI 680 формата А2 (686 х 508 мм) со скоростью печати до 15 000 оттисков в час. Машины обладают широким набором средств автоматизации, сокращающих время приладки и позволяющих осуществлять многокрасочную печать с простым нетрудоемким управлением, не требующим высокой квалификации печатника.

Красочные секции машин RYOBI серии 680 оснащены печатными и передаточными цилиндрами двойного диаметра. Перехват листа между печатным и передаточным цилиндрами происходит уже после завершения печати в каждой секции, что обеспечивает более стабильную транспортировку листа и высокую степень цветосовмещения.

В стандартной комплектации все машины новой серии оборудованы полуавтоматическим устройством смены печатных форм RYOBI Semi-Automatic Plate Changer (Semi-RPC), позволяющим работать как с металлическими, так и с полиэстровыми формами. Установка формы производится автоматически без загиба края, что допускает повторное использование форм.

Стол самонаклада с вакуумной лентой гарантирует стабильную подачу бумаги в очень широком диапазоне толщины. Предустановка формата и толщины бумаги, регулировка стола самонаклада, боковых упоров, приемного стола и давления печати при смене бумаги производится оператором автоматически с дистанционного пульта. Система перекоса формного цилиндра позволяет производить диагональную приводку и микрорегулировки непосредственно во время работы пресса.

Красочный аппарат печатных машин RYOBI серии 680 содержит 19 валиков (из них 4 — накатных). Автоматически управляемые сегментные красочные ножи и непрерывное пленочное увлажнение RYOBI-Matic c системой автоматического поддержания толщины водной пленки на форме RYOBI AAC легко обеспечивает стабильное качество печати. По желанию заказчика возможна комплектация печатной машины устройством автоматической смывки валиков красочного аппарата, а также автоматической очистки офсетного полотна и печатного цилиндра.

Новая система управления печатью RYOBI PCS-G с встроенной программой RYOBI Program Inking позволяет осуществлять автоматическую предустановку зональной подачи краски в каждой секции, используя параметры формы, измеренные сканером форм DEMIA (опция) или рассчитанные программой RYOBI Ink Volume Setter по данным допечатной подготовки. Система контроля плотности RYOBI DPS (опция) выполняет замеры плотности красочного слоя на выходе из печати, их результаты затем используются в PCS-G для автоматической корректировки зазоров сегментных ножей в процессе печати.

Печатные машины RYOBI серии 680 могут быть оборудованы поточной системой лакирования, включающей две системы сушки — инфракрасную для лаков на водной основе и ультрафиолетовую для УФ-лаков.

Российские полиграфические предприятия смогут приобрести печатные машины RYOBI 684/ 685/686 уже в начале 2000 года.

Дистрибьюторы RYOBI в России — компании «Вариант» (www.variant.ru) и PrintHouse (www.printhouse.ru).

Xerox приобретает отделение цветной печати Tektronix

Компания Xerox объявила о покупке за 950 млн. долл. наличными Отделения цветной печати (CPID) компании Tektronix. По словам Рика Томана, президента и исполнительного директора Xerox, это приобретение — самое большое в своем роде в истории Xerox — сочетает в себе известность торговой марки, широту продуктовой линии и глобальную распространенность компании Xerox с технологическим первенством и дистрибуторскими возможностями компании Tektronix. Добавляя семейство цветных лазерных и твердочернильных принтеров Phaser компании Tektronix, продажи которых составили за последний год около 725 млн. долл., Xerox станет единственным мощным конкурентом Hewlett-Packard в области цветной офисной печати. По словам Джерри Мейера, главы и исполнительного директора Tektronix , дистрибуторские возможности Xerox вырастут почти вдвое и составят более 16 000 реселлеров и дилеров по всему миру. «Это тот случай, когда работает концепция один+один=три. Наша апробированная продуктовая линия и выверенный временем канал доставки, рассматриваемые сегодня в контексте глубины истории и известности торговой марки Xerox, представляет серьезную силу на мировом рынке цветных принтеров». Новый бизнес Xerox по офисной печати будет охватывать более 30% рынка цветной офисной печати, ежегодный рост которого составляет около 23% и сохранится на таком уровне вплоть до 2003 года (по данным IDC). Соглашение о покупке является предметом переговоров и предположительно, окончательно будет заключено в течение 60 дней. Название Tektronix Inc. сохранится за отделением измерительных приборов компании. Джерри Перкель, президент отделения цветной печати Tektronix, станет президентом подразделения компании Xerox по офисной печати.

Yam идет на Восток

В Узбекистане во время выставки O’ZBEKinPRINT-99 компания YAM International объявила об открытии офиса в Ташкенте. YAM International Central Asia будет работать не только в Узбекистане, но и в соседних с ним странах, входивших в состав бывшего СССР. Задачи, которые стоят перед новым представительством - это маркетинг, оперативное решение вопросов, связанных с продажей оборудования и расходных материалов, техническая поддержка клиентов. Пока штат представительства состоит из двух человек, но в ближайшее время планируется его расширение.

Адрес компании Yam в Internet — www.yam.ru.

Заверните

В середине августа компания «Апостроф» запустила Web-узел виртуального магазина по адресу: www.apostrof.ru. Посетитель может ознакомиться с текущими ценами на оборудование, подготовить и отправить заявку на покупку (для оплаты и получения товара, пока требуется менее виртуальный контакт). В дальнейшем планируется предлагать услуги по приобретению оборудования в режиме on-line при помощи кредитных карт. По словам генерального директора компании «Апостроф» Ф. В. Смирнова, «сайт является первым этапом в программе компании, направленной на освоение Internet-пространства, и это позволит покупателям, имеющим доступ в Internet, быстрее ориентироваться в многообразии издательско-полиграфического оборудования. Пока говорить об эффективности виртуального магазина рано, но в первый же день работы сайта мы обработали три запроса. К концу года компания «Апостроф» планирует также открыть второй, «корпоративный» сайт, где посетители смогут подробно ознакомиться с «тяжелым» допечатным и печатным оборудованием».

Адрес компании «Апостроф» в сети Internet — http://www.apostrof.ru.

Heidelberg расширяется

Фирма Heidelberg приобрела группу компаний Stahl и машиностроительный завод Brehmer в Лейпциге. Отныне, производимые в Лейпциге подборочные проволокошвейные машины и машины для скрепления термонитью будут продаваться под маркой Heidelberg. Завод сохранит свое прежнее название Brehmer Buchbindereimaschinen GmbH.

Лейпцигскую фирму основали в 1879 году братья Бремер из Филадельфии. Ими же был построен машиностроительный завод Братьев Бремер, который в 20-е и 30-е годы стал лидером по производству переплетных машин. После ряда преобразований и продаж, фирма Stahl в 1994 году купила этот завод. В 1999 году Heidelberg приобрел Stahl-Gruppe, в результате чего образовалось направление Finishing.

«Графитек» снижает цены...

Компания «Графитек» — официальный дистрибьютор Mitsubishi Electric в России — объявила об осеннем снижении дилерских и рекомендованных розничных цен на мониторы Mitsubishi. Эта инициатива коснулась всех серий мониторов Mitsubishi Electric: DiamondScan, DiamondPlus, DiamondPro. В среднем снижение составило от 7% до 25%. Так, например, рекомендованная розничная цена на популярный профессиональный 19-дюймовый монитор Mitsubishi DiamondPro 900u теперь составляет 750 долл. (ранее 810 долл.). Наиболее значительное понижение рекомендованной розничной цены произошло в отношении 17-дюймового монитора DiamondPlus 71 - 295 долл. (ранее 395 долл.). Стоит заметить, что монитор DiamondPlus 71 изготовлен на кинескопе DiamondTron —- никогда ранее мониторы Mitsubishi Electric с кинескопами DiamondTron не были так доступны обычным пользователям!

...и открывает Web-узлы

Начинает работу официальный российский узел Web по поддержке мониторов Mitsubishi Electric: www.mitsubishi-electric.ru. Планируется активное использование этого сайта в маркетинговых акциях Mitsubishi Electric Europe B.V. в России, в частности проведение лотерей между зарегистрированными пользователями мониторов Mitsubishi, рассылка новостей.

Также благодаря усилиям компании Графитек — официального дистрибьютора Heidelberg CPS в России — открылся новый русскоязычный узел www.heidelberg.ru. По этому адресу можно найти массу информации об оборудовании знаменитого производителя планшетных сканеров и уникального программного обеспечения по управлению цветом — Linocolor Elite. Кроме настольных сканеров, на сервере представлена информация о напольных плоскостных и барабанных сканерах, фотонаборных аппаратах, цветопробных устройствах, растровых процессорах, офсетных машинах и многом другом. Все вопросы, связанные с получением дополнительной информации, можно посылать по адресу: info@heidelberg.ru.

Адрес компании «Графитек» в Internet — www.graphitek.ru

Canon авторизует партнеров

Официальный статус «Авторизованных оптовых центров» по дистрибуции расходных материалов Canon получили шесть московских компаний: «Роско», «Имидж», «НАК Микроваре», «Эргодата», «Ресурс-Медиа», «Квис» и одна петербургская — «Эврика».

Новые дилерские центры появились в Новосибирске — «Квеста», Ставрополе - «Телемир», Волгограде — «ПКФ Система-Плюс», Челябинске — «Энергосервис» и «Мост-С», Ашхабаде — «Софт Лтд.», Астрахани — «Реал Астрахань», Санкт Петербурге — «Битал—Мир копирования».

Инсталляция

В начале сентября в типографии фирмы «Сервис-Плюс» (г. С.-Петербург) установлена и запущена в эксплуатацию флексографская машина Mark Andy 2200. Она укомплектована четырьмя красочными секциями, а также секциями УФ-лакирования, высечки и горячего тиснения. Поставка машины осуществлена компанией «Вариант» (www.variant.ru), эксклюзивным дистрибьютором Mark Andy в России.

Imacon снова в СНГ

В сентябре 1999 года компания «Апостроф» получила статус официального представителя в странах СНГ продукции Imacon.

FlexTight Photo фирмы Imacon

Компания Imacon, представившая первый сканер FlexTight Precision в 1996 году, старается совместить в своих продуктах профессиональное качество сканирования, присущее барабанным устройствам, со скоростью и простотой работы планшетных сканеров. В настоящее время компания выпускает три модели сканеров на основе уникальной технологии FlexTight, исключающей использование стекла и зеркал между оригиналом и объективом. Сканеры отличаются друг от друга форматом — Precision формата А4, Progression формата А3 — а также ориентацией на определенные сектора потребительского рынка — модель Photo предназначена для в основном для расширения «цифровых возможностей» традиционных фотографов. Модели Progression и Precision позволяют сканировать прозрачные и непрозрачные оригиналы с максимальным оптическим разрешением до 5760 dpi и 42-разрядным цветом в диапазоне плотностей до 4,1D; FlexTight Photo сканирует с аналогичным качеством, но только на просвет с максимальным оптическим разрешением до 3200 dpi.

Широкомасштабное продвижение сканеров Imacon начнется уже с ноября этого года. Несколько специалистов по маркетингу, продажам и сервису компании «Апостроф» уже прошли стажировку на предприятиях Imacon в Дании, что должно гарантировать профессиональные консультации и качественный сервис российским клиентам.

Информация предоставлена компанией «Апостроф», www.apostrof.ru.

Nikon — профессионализм растет

Компания Nikon выпустила новую профессиональную цифровую зеркальную фотокамеру D1. В ней D1 используется 2,74-мегапиксельная матрица ПЗС размером 23,7 х 15,6 мм, позволяющая делать изображения размером 2012 х 1,324 пикселов. Для оптимизации получаемых изображений в D1 применяются технологии «отрезания» инфракрасных лучей (IR) сверхтонким фильтром, расположенным непосредственно перед матрицей ПЗС, и оптимальной обработки информации, достигаемой при помощи оригинальных алгоритмов Nikon.

Несжатое изображение может быть записано в трех форматах: Raw (12 бит), TIFF YcbCr (8 бит), TIFF RGB (8 бит). Режим «Сжатого Изображения» на основе JPEG-алгоритма позволяет получать сжатие в 1/4, 1/8, 1/16, а также монохромные (черно-белые) изображения.

Кроме того, имеется четыре градации чувствительности (эквивалент ISO 200, 400, 800, 1600). Сверхбыстрая обработка данных стала возможной благодаря новым алгоритмам ASIC, позволяющим производить непрерывную съемку со скоростью 4,5 кадра в секунда сериями до 21 кадра. К достоинствам D1 также можно отнести выдержку до 1/16 000 с и синхронизацию до 1/500 с. Ожидаемая цена камеры в России 6000 долл.

Информация предоставлена компанией «Терем» (www.terem.ru).

2560 на четыре

Компания QMS выпустила новую серию принтеров 2560, состоящую из четырех стандартных конфигураций. Модель QMS 2560 BX предназначена для бизнес-групп и печатает документы формата A4 при разрешении 1200 x 1200 dpi со скоростью 25 страниц в минуту. Она снабжена контроллером на базе процессора PowerPC с тактовой частотой 80 МГц, 8 Мбайт оперативной памяти, сетевым интерфейсом CrownNet Ethernet 10/100Base-T, двумя входными лотками, которые могут содержать до 750 листов, многофункциональным устройством подачи листов и выходным лотком, который вмещает до 500 листов.

Рекомендованная розничная цена в Москве — 2718 долл.

Модель 2560 GX, в дополнение к стандартным возможностям 2560 BX, имеет 32 Мбайт оперативной памяти, позволяющей печатать документы формата A3 при разрешении 1200 x 1200 dpi. Кроме того на принтере установлен внутренний жесткий диск для электронной подборки копий, хранения шрифтов и макросов.

Рекомендованная розничная цена в Москве — 3105 долл.

Основное отличие модели 2560 EX —функция дуплекса и подающий лоток большой емкости, повышающий входную вместительность 2560 EX до 3250 листов и превращающий принтер из настольного в напольный. Наконец, конфигурация QMS 2560 EXS позволила оснастить 2560 EX дополнительным лотком на 500 листов, и комбинированным семисекционным выходным лотком со степлером — теперь заключительное оформление документа становится частью печатного процесса.

Рекомендованные розничные цены в Москве — 4647 долл. и 7615 долл. соответственно.

Одной из сильных сторон серии QMS 2560 является возможность постепенного и значительного расширения возможностей принтера, что позволит удовлетворить увеличивающиеся запросы растущей рабочей группы.

Дистрибьюторы QMS в России — компании DPI (www.dpi.ru) и Mas Elektronikhandels (www.mas.ru).

МВ: хороших и разных принтеров и копиров должно быть много

МВ 4815: цветная лазерная печать дешевле 2000 долл.

После выхода на рынок модели МВ 4815 цветные лазерные принтеры стоимостью более 2000 долл. можно считать неоправданно дорогими. Новый аппарат компании МВ способен составить серьезную конкуренцию в своем классе, поскольку аналогов — аппаратов с такими же характеристиками и стоимостью менее 2000 долл. на российском рынке просто нет. МВ 4815 — полноцветный лазерный принтер со встроенным контроллером Fiery X2e и максимальным разрешением 600 х 600 dpi. Скорость печати — 3 страницы в цветном и 15 в черно-белом режимах. В стандартную поставку также входит 16 Мбайт оперативной памяти (с возможностью расширения до 80 Мбайт), поддерживаются языки PCL 5e/5c и PostScript 3.

MB 4815

МВ 320: самый маленький и экономичный в классе А3

Лазерный принтер МВ 320 компактен и экономичен во всех отношениях — при возможности печати на бумаге формата А3, размеры аппарата - 450 х 420 х 270 мм — что не превышает габаритов многих лазерных принтеров формата А4.

MB 320

Высокую скорость печати обеспечивают хороший баланс между «мозгами» (процессор RISC 133 МГц NEC R4300 и встроенная память объемом 8 Мбайт,с возможностью увеличения до 40 Мбайт) — и приводом, обеспечивающим печать 20 страниц А4 в минуту при максимальном разрешении 1200х1200 dpi — неплохая экономия времени.

И еще экономия времени обслуживания получается благодаря утилитарной конструкции принтера. Подача бумаги, замена картриджа и вывод отпечатков осуществляется с передней стороны аппарата. А значит, для работы и обслуживания МВ 320 требуется небольшое пространство, что, подчас, становится немаловажным фактором. МВ 320 универсален: он поддерживает языки PostScript Level 2 и PCL 5е/6.

МВ 8876: все необходимое для цветного копирования

MB 8876

Цифровой копировальный аппарат модели МВ 8876 позволяет получать 6 цветных и 21 черно-белую копии в минуту. Установив компьютерный интерфейс, аппарат можно превратить в принтер высокой производительности и сканер, тем самым, сэкономив место и средства, которые пришлось бы потратить на приобретение трех отдельных устройств. МВ 8876 обеспечивает автоматическую настройку оттенков.

Специально разработанная конструкция МВ 8876 (бумага имеет прямой путь прохождения) дает возможность использовать бумагу различной толщины, типа и размера для цветного и черно-белого копирования. Максимальный размер бумаги 305 х 457 мм, то есть формат А3 без полей, что подчас немаловажно при печати документов с цветным фоном.

МВ 8876 обладает всеми стандартными возможностями автонастройки, а также функцией автоматической калибровки цветного баланса и плотности цвета, которая нужна для сохранения стабильного качества печати в течение всего срока службы аппарата.

Среди дополнительных возможностей — компьютерный интерфейс с процессором RISC 200 МГц, памятью 160 Мб и жестким диском размером 3,2 Гбайт, а также увеличение разрешения печати с технологией сглаживания до 4800х600 dpi.

МВ 8810: больше, чем можно себе представить

MB 8810

Помимо стандартных режимов, присущих «серьезным» цветным цифровым моделям, аппарат МВ 8810 обладает рядом новых интересных функций.

Прежде всего — это возможность передавать 16 миллионов оттенков при разрешении 400 dpi. Функция печати образцов цветового баланса способствует более точному регулированию цветовой гаммы и одновременно — экономии расходных средств. Работа по редактированию документа на аппарате 8810 ведется с помощью специального цветного сенсорного жидкокристаллического экрана. Кроме того, аппарат оснащен встроенным дуплексом, который обеспечивает одинаковые параметры одновременного копирования обеих сторон.

Скорость печати МВ 8810 — 10 цветных или 40 черно-белых копий в минуту — позволяет отнести его к разряду скоростных, при этом время выхода первой копии рекордно низкое — 16,5 с.

Информация предоставлена компанией «МВ», www.MB.ru.

NT завоевывает рынок Macintosh

Grand Vitess Systems выпустила свои первые графические станции для Windows NT
Windows продолжает постепенно захватывать территорию, традиционно занимаемую Macintosh — два крупных поставщика выпускают графические станции NT для профессионалов в области графики. Постоянный системный интегратор Macintosh компания Grand Vitess Systems (GVS), которая наконец выпустила кросс-платформу с современной конфигурируемой системой NT и компания IBM, усовершенствовавшая некоторые из своих существующих моделей.

Система GVS 9000N, поставляемая как в одно-, так и в двухпроцессорном варианте на базе Xeon 550 МГц, может быть сконфигурирована с оперативной памятью до 2 Гбайт и модернизирована до гигабитного Ethernet. Цена варьируется от 3 995 до 9 995 долл.

Компания IBM добавила мощные графические 2D и 3D компоненты к своим рабочим станциям IntelliStation E Pro, M Pro и Z Pro, в комплект поставки которых входит либо графическая плата Matrox Millennium G400, либо графический ускоритель Fire GL1 компании IBM. Кроме того, E Pro и M Pro содержат процессоры с тактовой частотой 600 МГц. Цена за E Pro составляет 1 829 долл., за M Pro — 2 799 долл. и за Z Pro — 4 039 долл.

Источник: Grand Vitess Systems, www.gvsnet.com; IBM, www.ibm.com
Ваше имя: E-mail:
Оценка интересности и/или полезности статьи:
интересно и/или полезно
мало интересно или полезно
вредная статья
 Стиль изложения
читается легко
несколько трудна для чтения
очень трудно читать
Ваш комментарий:

<< ПРЕДЫДУЩАЯ СТАТЬЯ ] [ ОГЛАВЛЕНИЕ ] [ СЛЕДУЮЩАЯ СТАТЬЯ >>


Digital Art

Данный вопрос я намерен ограничить рамками цифровой обработки фотографий в Photoshop. Реально на ранг достойной имитации живописи или графики претендуют несколько программ (из известных мне) - сам Photoshop, Fractal Design Painter, Corel PhotoPaint, Image Composer из комплекта Front Page и еще несколько. Во всех более-менее известных пакетах для работы с битовой графикой присутствуют фильтры для разовой и ступенчатой обработки изображений, имитации некоторых изобразительных техник.

Многие из этих фильтров имеют достаточно широкие возможности настроек и достаточно широкую гамму исполнительских техник. Основная часть фильтров ориентирована на работу с планшетами типа Vacom.

Рисунок обычными графическими средствами

Чаще всего это наброски, скетчи, предварительные эскизы к композициям в большинстве случаев вспомогательного порядка, служащие для поиска формы, композиции, движения, выразительности (т.е. решающий одну или несколько вспомогательных задач). Часто у талантливых художников даже очень быстрые наброски с натуры имеют самостоятельную художественную ценность.

Но существует достаточно много художников, выбравших рисунок как основное средство для творческого самовыражения. В качестве инструмента может использоваться практически все, что оставляет след на бумаге, но обычно художники предпочитают использовать достаточно традиционные средства - карандаш, пастель, сангину, уголь древесный и прессованный, различные чернильные перовые, шариковые и гелевые ручки, фломастеры и многое другое из обычных канцелярских средств.

В зависимости от инструмента и бумаги линия также может менять свой вид. Серебристая карандашная значительно отличается от перьевой, и уж совсем не похожа на линию, выполненную сангиной или углем. Да и рука художника значительно разнообразит технику рисунка. Мягкие плавные линии, резкие угловатые, или бепорядочно импульсивные - все это зависит как от характера художника, его манеры рисунка, применяемых им средств. От тонкой и едва заметной линия может перерастать в максимально возможную для того или иного инструмента.

Средством передачи тона в рисунке в основном служат штрих и растушевка. Материал в бумагу может втираться как просто пальцами, так и специальными «растирками- растушевками» из замши, ткани или других материалов. Пальцами пользуются обычно начинающие либо очень неряшливые художники, ибо жир, пот и грязь могут превратить рисунок в полное безобразие. Использование специальных растушевок из замши часто позволяет сохранить в рисунке иногда даже очень мелкую фактуру бумаги.

Имитация рисунка на компьютере.

Средства рисования на компьютере в различных графических пакетах во многом зависят от позиции разработчиков этих пакетов и в разных программах могут различаться достаточно кардинально. В принципе, рисунок с помощью дигитайзера (особенно чувствительного к нажиму пера) может считаться рисунком как таковым, сохраняя живость движения руки и мысли художника. При этом средства графических пакетов превращают дигитайзер в достаточно многогранный инструмент с огромным набором средств. Обычная мышь в этом случае совершенно не способна заменить или хоть как-то имитировать обычную работу художника (положение руки, свободу движений, наклон инструмента и др.)

Второй вариант - имитация рисунка с помощью графических фильтров, когда вы пытаетесь имитировать рисунок, используя готовую фотографию. Как раз в этом варианте художниками могут почувствовать себя практически все, кому не лень возиться с компьютером. Вот об этом варианте мы и будем в дальнейшем говорить.

Живопись традиционными средствами

Техника живописи по своим возможностям настолько многогранна, что только общее рассмотрение этого вопроса может вылиться в целый сайт, но помня о задачах, я постараюсь ограничиться очень общими моментами. И сразу о тонкостях - акварель по стандартным определениям относится к графике, но по возможностям и задачам - это больше живопись, поэтому и рассматривать этот вопрос мы будем в разделе о живописи.

Живопись масляными красками.

Наиболее традиционный вид живописи - масляными красками по холсту. Техника обладает определенными характерными признаками, несмотря на бесконечное обилие манер работы художников. В данном случае эти признаки определяются материалами работы - фактурой холста, свойствами масляной краски (определенные цветовые гаммы, пастозность, наличие следов кисти или мастихина в характере мазка).

Живопись темперой, гуашью и акварелью.

Это краски на клеевой основе, предназначены в основном для работы по бумаге (хотя часто используются и другие основы). Характерые признаки мы рассмотрим в конкретной статье о имитации каждой из этих техник.

Имитация живописи компьютерными средствами.

Существует несколько выразительных фильтров, в готовом виде имитирующих традиционную живопись и графику. Мне очень нравится комплект готовых плугинов из Image Composer. При некотором терпении можно добиться результатов с фильтрами из CorelPhotoPaint. Но в конечном итоге я остановился на стандартном наборе Photoshop. Несмотря на то, что сами по себе фильтры достаточно слабы в плане имитации, их совместное использование друг с другом и в сотрудничестве с корректирующими слоями имеет огромный потенциал творческих возможностей.

О статьях на эту тему.

Проще всего, конечно, было бы дать образцы и готовые экшны. Но на самом деле цель этих статей несколько иная - показать и объяснить возможности не столько фильтров, сколько корректирующих слоев. Поэтому весь процесс будет разбит на отдельные операции типа "получение графических линий", "построение теней" и тому подобное. С одной и той же последовательностью операций, но при разном включении слоев получаются совершенно самостоятельные творческие результаты.


FAQ for comp.graphics.apps.paint-shop-pro

PAINT-SHOP-PRO FREQUENTLY ASKED QUESTIONS

0. What is comp.graphics.apps.paint-shop-pro?

0.1 Where can I get a copy of the group charter?
0.1.1 What is appropriate to post to the group?
0.1.2 What is "netiquette"?
0.1.3 This is really important, but it's not technically on-topic! What do I do?
0.1.4 Why shouldn't I post binaries to the group?

0.2 What is a FAQ?
0.2.1 What does this FAQ cover?
0.2.2 Who decides what goes in the FAQ?
0.2.3 How can I contribute to the FAQ?
0.2.4 Where can I find the latest version of the FAQ?

1. What is Paint Shop Pro?

1.1 What is Shareware?
1.1.1 What is a Nag Screen, and how do I make it go away?
1.1.2 Why should I pay for shareware?
1.1.3 Are there any other benefits to paying for PSP?
1.1.4 Where can I get cracks for PSP?

1.2 Where can I get PSP?
1.2.1 Can I register PSP 5.01 for less than $99?
1.2.2 How much does PSP 5.0 cost? Will I get if free/at a discount if I have PSP 4?
1.2.3 How much will PSP 6 cost? Will I get if free/at a discount if I have PSP 5?

1.3 What new features are in version 5?
1.3.1 How do layers work?
1.3.2 What is CMYK color?
1.3.3 What is the PSP (.psp) file format?
1.3.4 What is "Animation Shop"?
1.3.5 How do I get a transparent background in PSP 5?
1.3.6 How does multiple undo work in PSP 5?

1.4 What new features will be in version 6?

2. What are all those different image formats for?

2.1 What is the difference between "vector" and "raster" images?
2.1.1 Why can't PSP save in CDR or DXF (or CGM, DRW, GEM, HGL, PIC, WPG) formats?
2.1.2What is the .psp image format?
2.1.3 What good is it?
2.1.4 How does PSP 5 use CMYK color?

2.2 Which image format is the best for my image?
2.2.1 Which image formats work in web-browsers?
2.2.2 Which format should I use for works-in-progress and "masters"?

2.3 What is a GIF (.gif)?
2.3.1 How do I get transparency in a .gif?
2.3.2 How do I animate .gifs?
2.3.3 How do I use filters on .gifs?
2.3.4 How do save true color (24-bit) .gifs?
2.3.5 My scan looks terrible after I save it as a .gif. Why?
2.3.6 What is the difference between interlaced and non-interlaced .gifs?
2.3.7 What is the difference between GIF 87a and GIF 89a?
2.3.8 What is this Unisys licensing thing I hear about? Does it affect me?

2.4 What is a JPEG/JFIF (.jpg)?
2.4.1 How do I get transparency in a .jpg
2.4.2 How do I animate .jpgs?
2.4.3 What is "lossy" compression?
2.4.4 How do I save the palette from a .jpg?
2.4.5 My drawing looks terrible after I save it as a .jpg. Why?
2.4.6 What is a "progressive" .jpg?

2.5 What is a MSWindows/OS/2 Bitmap (.bmp)?
2.5.1 Why are my .bmp files so BIG?
2.5.2 How do I make images for the Windows95 boot and shutdown screens?
2.5.3 How do I get that scrolling bar on the bottom of the Windows95 boot screen?

2.6 What is a TIFF (.tif)?
2.6.1 What do the different types of compression do?
2.6.2 Why do people recommend saving works-in-progress as TIFFs?
2.6.3 Why do people still use TIFFs?
2.6.4 What is this Unisys licensing thing I hear about? Does it affect me?

2.7 What is a PNG (.png)?
2.7.1 How do I get transparency in a .png?
2.7.2 How do I animate .pngs?
2.7.3 What is the "alpha channel", and how do I use it?
2.7.4 My (transparent) .png looks terrible in Netscape Navigator. Why?

3. What OSs does PSP run on?

3.1 What versions of PSP are available, and which run on which OS?

3.2 What known bugs are there in PSP?
3.2.1 How do I fix the Linear Gradient Fill Bug?
3.2.2 How do I fix the msvcrt10.dll bug?
3.2.3 How do I fix the Kernel32.dll bug?
3.2.4 How do I fix the Adobe Type Manager bug?
3.2.5 What happened to my scanner with PSP 5?
3.2.6 What is the "Multiple Instances" bug, and how do I fix it?
3.2.7 Help! Upgrading to 5.01 screwed things up!!!
3.2.8 Help! Where did my toolbar go?
3.2.9 How do I report bugs?

3.3 What other Jasc software works with PSP?

3.4 What third party software works with PSP?
3.4.1 Which Adobe Photoshop plugins work with PSP?
3.4.2 How do I make x plugin work with PSP?
3.4.3

4 Where can I get help with drawing technique?
4.1 My scanned images look bad. Why? What can I do about this?
4.1.1 What dpi setting should I use for scanning?
4.1.2 What is "interpolated" resolution on a scanner?
4.1.3 What good is 30-bit color scanning if PSP (and most other programs) only use 24-bit color?

4.2.1 How do I get text to follow a curve in PSP?
4.2.2 How do I make GIFs (and PNGs) with transparent backgrounds?
4.2.3

FREQUENTLY GIVEN ANSWERS:

0. What is comp.graphics.apps.paint-shop-pro?

comp.graphics.apps.paint-shop-pro is a Usenet newsgroup for discussion of all issues regarding Paint Shop Pro. It is sometimes abbreviated c.g.a.psp

0.1 Where can I get a copy of the group charter?

It's been posted recently to c.g.a.psp. It may find a web home near this FAQ. If I find other addresses with it, I'll add them.

0.1.1 What is appropriate to post to the group?

Quoting the charter:

Paint Shop Pro topics in question would include, but are not limited to:

  • General program usage and questions
  • Technical issues or problems
  • Tips, suggestions and techniques
  • Current product versions or patches
  • 3rd party plugins or add-ons
  • 3rd party Paint Shop Pro related Web sites and groups
  • and any other Paint Shop Pro related topics.

0.1.2 What is "netiquette"?

This is a broad topic, but it can be summed up as "Don't make life difficult for other readers of the group". There are numerous places where guides to basic netiquette are posted, including newsgroups news.answers and news.announce.newusers, someplace on AOL (try keyword:Netiquette - if this doesn't work, please let me know.) and in many books and websites. Try http://www.albion.com/netiquette/

Some additional advice, mostly cribbed from comp.os.ms-windows.win95.moderated:

  • Don't use HTML postings - most of us don't use Netscape or Outlook for newsgroups.
  • Refrain from using all-uppercase subject lines.
  • Use informative subject lines - "PSP problem" doesn't tell anything useful.
  • Only quote the part of a previous post you're replying to.
  • Change subject line if the topic has strayed.
  • Make your post readable - in particular, breaking it up into paragraphs with a blank line between each helps a lot.
  • Run a spelling check on your post.
  • Re-read your post before sending it out, to make sure it says what you want it to say.
  • Don't ask for replies by e-mail only. Your problem probably isn't unique, and others may want to hear the answer. (It is ok to ask for e-mail replies in addition to posting - newsfeeds aren't always reliable)

0.1.3 This is really important, but it's not technically on-topic! What do I do?

If your posting isn't SPAM, advertising, etc., but will be of interest to most readers of the group, please begin your subject line with "OT" to signify off-topic.

0.1.4 Why shouldn't I post binaries to the group?

There are several reasons to not post binaries (encoded non-text files, like images) to this group. Binaries usually take up a lot of space, and take a while to download. Many News administrators treat groups with binaries and groups without differently - mainly by expiring articles in binaries groups much more quickly. Also, people will frequently set their newsreader to download all messages in a non-binaries group, and then waste a lot of time (and money in many places!) downloading a large image file.

0.2 What is a FAQ?

Cribbing again from the comp.os.ms-windows.win95.moderated FAQ:

FAQ stands for Frequently Asked Questions. The list of frequently asked questions with answers is called 'the FAQ list', or 'the FAQ' for short. You can pronounce it as separate letters ('eff ay cue'), or as one word ('fack').

Certain questions are asked again and again on newsgroups. They may be perfectly sensible questions, but each time they are asked, the same answers are given - both right and wrong.

To save on bandwidth and reader time, not to mention annoyance to regular readers, these common questions (and the definitive answers given) are put in the FAQ for the group, so that discussion can move on to more constructive topics without continual regression to first principles. Often, reading the FAQ before posting a question will save you and other people time!

0.2.1 What does this FAQ cover? It covers mainly those questions which get asked a lot with which the FAQ author is familiar. Currently, there are 5 main sections:

  • About the FAQ and the newsgroup. Pretty self-referential, but useful.
  • About the program - What is it, information about obtaining the program, information about shareware, and general information about changes from version 4 to version 5, and new features in version 6.
  • File Format information - how PSP handles various image file formats, basics of various image file formats, and achieving certain goals (ie transparency) using different formats.
  • Program operation - bugs, plugins, interactions with other software.
  • Technique - currently the most limited section of the FAQ, because the author isn't really a graphic artist. Includes some advice about scanning.

0.2.2 Who decides what goes in the FAQ?

The author (Anthony Argyriou). This FAQ is my creation, and I am sole judge of what goes in. That said, however, I'm kind of desperate for more material, especially in the last section.

0.2.3 How can I contribute to the FAQ?

Send me an e-mail. Give me a question and an answer. I'll check it to the best of my ability, then, in my copious free time, I'll add it.

0.2.4 Where can I find the latest version of the FAQ?

At http://www.alphageo.com/psp/faq.html. The other address is still working, but it may not always get updated right away. I may take it down, one of these days. Eventually, the FAQ may end up on the RTFM server and faqs.org. Right now, only the FAQ pointer message is in those archives.

1. What is Paint Shop Pro?

Paint Shop Pro is a raster image editing program. Examples of other raster image editing programs include MS Paint (which comes with Windows), Corel PhotoPaint, MacPaint (for Macintoshes), etc. Paint Shop Pro is available as shareware, so you can use it for evaluation before purchasing.

Paint Shop Pro allows you to edit images on a pixel-by-pixel level or by applying transformations to a region or an entire image. Paint Shop Pro also has extensive file format support.

1.1 What is Shareware?

Shareware gives users the opportunity to try a program before buying it. The user is supposed to determine within a limited time period whether to keep the program and register it, or to uninstall the program, and not use it. If the user keeps the program, s/he should register it properly (including paying for it). In addition to the warm and fuzzy feeling you get from doing the right thing by registering, most shareware developers only provide support to registered (paying!) customers.

Technically, PSP 4.14 and 5.0x are "trialware", since they will stop working after a fixed period of time (30 to 90 days), but the concept is similar.

While PSP 4.14 does stop working after the trial period, it does not uninstall itself, so it will continue to take up space on your hard-drive and in your registry. If you aren't going to buy it, uninstall it after it expires. PSP 5 exhibits the same behavior.

PSP 6 is currently in "beta", and the downloads are time-limited to prevent people from keeping old, buggy, betas on their system.

1.1.1 What is a Nag Screen, and how do I make it go away?

The "nag" screen is a screen which pops up when starting an unregistered version of PSP which reminds you that you have been using the program for X days out of your Y day free trial, and encourage you to register the program. PSP colors that bar red when X > Y. PSP 5 will generally keep working for 30 days after the evaluation "expires". The PSP nag screen gives you the choice of starting the program or registering. To make it go away, buy the program.

The only real problem I've encountered with the nag screen before I bought PSP was that if I wanted to fax an image using MSFax (part of MS Exchange in Windows 95), and PSP was not already open, MSFax would return an error, or hang. If PSP is open before trying to send the fax, MSFax would work as well as MSFax ever does.

1.1.2 Why should I pay for shareware?

There are several reasons to pay for shareware. The first is that it is the right thing to do. If you decide you don't like PSP, and delete it from your system, don't pay; but if you continue to use it, you really ought to reward the folks who put together such a great program. Second is enlightened self-interest: if people keep paying for shareware they use, developers will continue to make good programs available cheaply. By going the shareware route, the folks at Jasc have reached many more of us, for less money, than if they had done an advertising blitz in the trade press. More units sold means a lower price for the product.

1.1.3 Are there any other benefits to paying for PSP?

If you buy the program from Jasc, you get their manual, which is very helpful, and a CD with the program, so you don't have to go through a long download if you wipe out critical files. Also, if you have PSP 4.14 or 5.0, which is "trialware", it will expire after 30 to 90 days.

1.1.4 Where can I get cracks for PSP?

Even though I don't work for Jasc, I'm NOT going to help you with this. Many cracks available on Usenet or the web are virus-infected, and some supposed cracks are just viri. If you ask for a crack on c.g.a.psp, expect to get flamed by the regulars, and maybe have someone tell Jasc about you. If you don't know where to look, you're not trying.

1.2 Where can I get PSP?

  • From the Jasc web-site (http://www.jasc.com/pspdl.html)
  • From C|Net's download.com (http://www.download.com/pc/software/0,332,0-69885-s,1000.html)
  • From Simtelnet mirrors (ftp://ftp.simtel.net/pub/simtelnet/win95/graphics/psp501ev.zip
  • From Tucows (http://www.tucows.com/) This site directs you to a local mirror first, look under image editors. This site also supports resumable downloads, so if you get cut off in the middle of a multi-megabyte download, you can pick up where you left off.
You can also search ftp sites using ftp-search at http://ftpsearch.lycos.com/ , searching for psp501ev.zip. You may want to look for *psp501.*, as some sites rename files. Older versions of PSP may be found using this also - look for psp414*.exe or .zip

You can mail-order from Jasc at POBox 44997, Eden Prairie, MN 55344, call toll-free (within US and Canada?) at 800-622-2793, or order from their website.

1.2.1 Can I register PSP 5.03 for less than $99?

Check messages posted in c.g.a.psp, there are plenty of places which buy in bulk from Jasc then pass on their savings to their customers. Try any on-line software store, or your local computer discount warehouse.

1.2.2 How much does PSP 5.0 cost? Will I get if free/at a discount if I have PSP 4?

PSP 5.0 is $99 (US) if purchased from Jasc. The upgrade price for people who already have PSP (4.14 or earlier) is $39. These prices are for people buying directly from Jasc, and don't include shipping & handling. You may want to try the sites in the question above for deals on PSP 5. Many have a rebate setup for owners of earlier versions of PSP.

1.2.3 How much will PSP 6.0 cost? Will I get if free/at a discount if I have PSP 5?

PSP 6.0 is US$109 (Can$169) for the box if purchased from Jasc, US$99 for the download. Jasc is offering a deal where if you buy PSP 5 now, they'll send you PSP 6 for free. These prices are for people buying directly from Jasc, and don't include shipping & handling. If you're a registered user of PSP 5, you can get PSP 6 direct from Jasc for $49 (Can$79). There will also be a $30 mail-in rebate available from JASC if you buy PSP 6 in a store and are a registered user of PSP 5.

1.3 What new features are in version 5?

In addition to incorporating a number of bug fixes, version 5 has the capability of working with layers, working with CMYK color separations, a new (.psp) file format, and Animation Shop. There are also more options for some effects and operations, multiple undo, and far superior transparency support.

1.3.1 How do layers work?

If you are familiar with Photoshop or CorelDRAW!, PSP's layer support is very similar. Each layer contains images, and may have a transparent background. The sample "Timber Wolf.psp" file demonstrates the use of layers - there is a background, and several layers with different elements of the final image. If you want to remove part of the image, you can turn off or delete that layer. If you want to experiment with placement of an object on a background, you can place it in its own layer, so you can move it around without damaging the background image.

When an image is saved in a format which doesn't support layers (all of them except PSD and PSP), the layers are "flattened" and only the final image is saved.

1.3.2 What is CMYK color?

CMYK stands for Cyan, Magenta, Yellow and blacK, which are the common ink colors in 4-color printing processes. In a pure CMYK system, the black is unnecessary, and the other three colors are the exact inverse of Red, Green and Blue. Since real inks never quite work this way, some adjustments have to be made. The main one is adding black, since mixing cyan, magenta and yellow inks usually results in a muddy brown rather than a black.

PSP 5 can perform CMYK separations, which give 4 grayscale images which correspond to the four ink colors. Details of the separation process can be controlled through the File/Preferences/CMYK Conversion Preferences dialogs.

For colorizing pictures, if you need the Hue, Saturation and Luminance values for Cyan, Magenta, and Yellow, Mark S. Ransom reported that:

  • For PSP 4.12, Cyan H=123, Magenta H=205, Yellow H=41.
  • For PSP 5 beta 2.5, Cyan H=128, Magenta H=212, Yellow H=43.
  • For Saturation use 240 on PSP 4, 255 on PSP 5.

1.3.3 What is the .psp file format?

The PSP (.psp) file format is Jasc's special format for saving all the information in an image without any loss. PSP files include each layer and all transparency information (including masks) that is generated while working on an image. They can optionally be compressed via run-length encoding or LZ77 encoding. While PSP files are ideal for saving complex images, they can only be viewed by PSP 5, so you'll have to convert your images to put them up on the web or share them with people who don't have Paint Shop Pro 5.

A recent discussion regarding the layout of the PSP file format included a statement from Jasc that they are considering releasing the specs of the format, to allow other developers to write programs which will view .psp files.

1.3.4 What is "Animation Shop"?

Animation Shop is Jasc's latest product, which comes bundled with PSP 5. It is a program which can create animated images in both GIF and a specialized form of MNG formats. It contains tools for making transitions from one frame of an animation to another, and allows setting of transparency and frame delays.

The MNG format which PSP saves animations in preserves 24-bit color, which GIF does not. However, Animation Shop doesn't view all MNG animations, nor are there many Windows or Macintosh based full-featured MNG viewers. So, like the PSP format, MNG is best used for saving "masters" from which derivatives (GIFs) are created.

1.3.5 How do I get a transparent background in PSP 5?

To start a new image with a transparent background, go to File/New, and make sure you're creating an image with 16.7 Million Colors (24 bit) or Grayscale (8 bit). For creating transparency with palettized images (GIFs, 256-color PNGs and TIFFs, etc.), see question 2.3.1. For creating transparency with 16.7-million-color images (PNGs and TIFFs, etc.), using masks, see question 2.7.1.

1.4 What new features will be in version 6?

The top 5 new features (as listed on the Jasc website) are:

  • Editable Text with character level formatting
  • Vector Drawing Tools
  • Object Manipulation & Node Editing
  • Text on a Path
  • Multiple Color Gradients
There are also many, many more new features, in addition to lots of new stuff in Animation Shop 2

2. What are all those different image formats for?

Many image formats were developed before transmission of images via the internet became commonplace. Many are proprietary formats meaning that only software made by a particular company can read or write that format. Corel, Claris, Adobe, Aldus and Targa all came out with their own image formats. The variety of images also reflects a variety of different compromises made for different audiences. The Autocad formats are designed to do those things which drafters like to do, namely allow unlimited scaling, layers, and represent geometric objects easily. The GIF format developed by Compuserve was a good compromise when most people had monitors which couldn't support very high color depth. JPEG is a good compromise for "natural" or photographic images, where a slight blurring and slight loss of red and blue data in exchange for substantially smaller files is acceptable.

A number of formats, like Autodesk's DWG, Corel's CDR, DXF, and CGM are "vector" formats which allow for easy scaling, but make it nearly impossible to render things in photographic detail. Some formats support both vector and raster data. Most vector formats are proprietary, which is why there are so many of them.

2.1 What is the difference between "vector" and "raster" images?

A vector image is constructed as a collection of abstract mathematical shapes, and these shapes preserve their identity when you scale the image or add or delete a shape. So, a vector image is resolution-independent. But rendering the image on a screen or a raster printer (both laser printers and ink-jet printers are raster printers) requires calculating an equivalent bitmap, which is slow. Vector images are usually easier for pen plotters to work with, though, and it's much easier to find a pen plotter which can handle a 24" x 36" sheet than a laser-printer of the same size.

A raster image is an array of color values, one for each pixel (dot) in the image, so it can be displayed or printed directly on a screen or raster printer that has a corresponding dot spacing. But scaling the image to a different dot spacing (resolution) requires a lot of calculation and is inherently inaccurate: you have to interpolate between existing dot values. If you scale up enough to see the original dots clearly, the image will generally not look good. The MSWindows/OS2 and X Window (UNIX-based) bitmaps (and pixelmaps) are uncompressed, and contain image size (in pixels) and a description of each pixel. Most other raster image types perform some kind of compression to minimize file size, since most image data is fairly repetitive (it takes far fewer bytes to describe a one-color border as "10 rows all yellow, then first 10 and last 10 of each row yellow down to last 10 rows all yellow" than is would to repeat the code for yellow for each and every pixel).

The MS "Windows MetaFile" (.wmf), Apple PICT, and CorelDraw (.cdr) formats can contain both vector and raster data.

2.1.1 Why can't PSP save in CDR or DXF (or CGM, DRW, GEM, HPGL, WPG) formats?

These formats are vector-based, and several are proprietary. Paint Shop Pro is a raster-based program, and stores images that way. PSP can open these files, because it is relatively easier to read such a file and translate it into a raster image than it is to translate raster images into vector formats. When PSP saves into WMF or PIC formats, it uses only the raster capabilities of those formats, even if the original data was vector-based from one of these formats.

2.1.2 What is the PSP (.psp) image format?

The PSP (.psp)image format is Jasc's special format for saving all the information in an image without any loss. PSP files include each layer and all transparency information (including masks) that is generated while working on an image. They can optionally be compressed via run-length encoding or LZ77 encoding. While PSP files are ideal for saving complex images, they can only be viewed by PSP 5, so you'll have to convert your images, or use the File/Save Copy As to put them up on the web or share them with people who don't have Paint Shop Pro 5.

Images saved in PSP format by PSP 6 will not be fully readable in PSP 5 if they contain features not found in PSP 5 (mainly vector stuff).

2.1.3 What good is it?

The main advantage to the new PSP format is that it keeps all your layer data, which most other common formats (except Photoshop .psd) do not. It also allows from lossless compression using the LZ77 method, which can significantly compress images. (Or run-length encoding, which is useful if you have big areas of solid color, and almost useless otherwise.) Saving files as PSP is ideal for saving "masters" or works-in-progress which don't need to be shared with non-PSP5 users.

2.1.4 How does PSP 5 use CMYK color?

CMYK color is unavailable in PSP through version 4.14. Version 5 has some support for CMYK color, including:

  • CMYK separations
  • CMYK channel combining
  • Saving TIFFs with CMYK channels (instead of RGB)
  • Adjusting the separations
  • Printing CMYK separations
CMYK is almost useless for video/monitor display, and isn't likely to be used by people primarily interested in web graphics. CMYK color is mainly useful for print work, since traditional printers inks are in those colors.

2.2 Which image format is the best for my image?

This depends on what the image is, and where and when it will be used. You may need one format for web use, another for a "master image" for future editing, and another for dropping into an OCR program.

For saving works in progress, you should always save in a 24-color format with lossless (or no) compression. These include Windows bitmap (.bmp), TIFF (.tif), PNG (.png), and PSP (.psp) in Paint Shop Pro 5. Saving in GIF format before a project is complete will cause loss of color depth, and should only be done if the image has few colors. Saving in JPEG format will cause minor errors from the lossy compression, which will be compounded every time the file is resaved.

If you're working with PSP 5 and using layers, you should save masters as PSP images, to preserve your layers. (You should use LZ77 compression, to minimize file-size, too.)

For web use, overall file size is usually the overriding concern, since most of the world is connected at 28.8 to 33.6 kbps. JPEG almost always gives smaller file sizes, but doesn't support transparency, and some graphics may compress better as GIF or PNG. Almost all browsers will display GIF and JPEG. Netscape 4.0 and MS Internet Explorer 4.0 display PNG, but not everyone has the 4.0 versions yet. (And won't for a while - they're huge memory hogs!)

For use with other programs, check compatibility. Some OCR programs will only take certain kinds of TIFF files as inputs. Windows requires Windows Bitmaps for desktop tiles and wallpaper. Other programs may have other limitations.

The first thing to determine is the required color depth. Black and white "line drawing" type images only require 2 colors. Logos may only require 16 colors, and many created images only require 256 colors. Black and white "grayscale" images require "256 grays". Many black and white images can be reduced to 16 colors, which will save a lot of space. Lifelike images or images with many continuously varying colors or shadings require 15-bit, 16-bit, or 24-bit color to look good. Many monitors don't display 24-bit color, but PSP can't save as 15-bit or 16-bit color. GIFs are limited to no more than 256 colors (or grays) on a palette, while JPEGs can be 24-bit color or 256 grays. TIFFs can be 24-bit color, 256 grays,or 2 to 256 colors using a palette. PNGs can be 24-bit color or 256 grays, or 2 to 256 colors, using a palette. (PNGs are capable of greater color and grayscale depth, but PSP can't save them.)

Another factor to consider is where the image will be used, and how often. Most compressed file types require a bit of computation time to render properly, but for Web use, the download time is usually much higher. For Web use, minimizing file size is usually the overriding consideration. For other uses, different considerations may apply.

JPEG usually gives the smallest file size for photos and other truecolor graphics, but GIF or PNG will usually beat JPEG for images with few colors and relatively simple layouts, like buttons or logos. PNG outperforms GIF for most 256-or-fewer-color images, and can also store truecolor (though truecolor PNGs are likely to be much larger than JPEGs or 256-color PNGs, and somewhat larger than 256-color GIFs ). TIFF creates somewhat larger files than PNG for full-depth color, but TIFF files can be used by many other applications, including faxing and OCR software. However, the TIFF standard allows for lots of extensions, and many programs only support a few of these, and almost none support all of them. (Even Adobe Photoshop can't handle everything that qualifies as a TIFF!) If you are creating "wallpaper" or icons for your Windows system, or images (buttons, dialog boxes, etc.) for Windows programs, you must use Windows bitmaps.

The third factor is the type of image and transparency. Images with lots of sharp edges or borders will lose some of that sharpness if saved as a JPEG, due to the nature of JPEGs compression. Some images require "transparency", where the computer rendering them will allow some background to show through parts of the image. Transparency is not available in the JPEG or Windows BMP format, limited (all-or-nothing) transparency is available in GIFs and palettized PNGs and TIFFs, and PNG and TIFF support "alpha channel", or varying levels of transparency (which almost no web browsers render properly).

2.2.1 Which image formats work in web browsers?

There is no standard which says "Browsers must support image type X". There are official "Internet Media Type" specifications, which state how various image formats are supposed to behave . Almost all browsers (except Lynx) can render GIFs and JPEGs. Netscape Navigator 3.01 can view X bitmaps (.xbm) natively as well. Netscape Communicator 4.04 and later is able to view PNGs in-line as well. MS Internet Explorer 3 can view MS bitmaps (.bmp) in addition to GIF and JPEG images, and Internet Explorer 4 is supposed to be able to view PNGs, too.

Until 4.0 browsers become common, you may want to stick with JPEGs and GIFs, or at least provide alternate GIF or JPEG images for people who can't view PNGs. See any good HTML reference for how to do this.

2.2.2 Which format should I use for works-in-progress and "masters"?

For saving works in progress, you should always save in a 24-color format with lossless (or no) compression. These include Windows bitmap (.bmp), TIFF (.tif), PNG (.png), and PSP (.psp). Saving in GIF format before a project is complete will cause loss of color depth, and should only be done if the image has few colors. Saving in JPEG format will cause minor errors from the lossy compression, which will be compounded every time the file is resaved.

Windows Bitmaps and uncompressed TIFFs are the largest for any given file. TIFFs can be set up with several different compression options, but some aspects of some TIFFs aren't readable by other software. TIFFs can be saved in CMYK color format in PSP 5. PNGs have fewer options, and the PNG standard doesn't allow developers to pick and choose which features will work, therefore, any feature usable in PNG should be readable by any program which can render or edit PNGs. The one feature of PNG which is not supported by many applications is 48-bit color (and 16-bit grayscale). PSP format allows 24-bit color, transparency, and allows you to preserve multiple layers, but is only viewable by PSP 5.

2.3 What is a GIF (.gif)?

GIF stands for Graphic Interchange Format, and was developed by/for Compuserve for compact storage of images. As most Compuserve customers didn't have very fancy screens in the early days of the service, the developers decided to use a "palette" of up to 256 colors for each image, which allows an image to take up one-third as much space. They also used a compression algorithm to further reduce the size of image files. GIFS are excellent for storing created images with 256 or fewer colors, especially if there are large regions of solid color and sharp borders between colors.

GIFs also support transparency and animation. Transparency requires choosing a "transparent color" - a color which will be rendered transparent anywhere it appears in the image. Animation consists of storing multiple frames in the same file, along with time-delay information and repeat information.

2.3.1 How do I get transparency in a .gif?

If you are creating a brand-new .gif, start with a background color not likely to appear anywhere else in the image, and preferrably very distinct from the image, draw your image, and when saving it, select the option to "set transparent color" to your background color. If you are editing an existing image, you will have to be careful about selecting a color, and finding all occurences of it, or you may get holes in your image.

Things are different in PSP 5. From Jasc's PSP 5 readme.doc file:

The method used to create Transparent GIF files has changed considerably from version 4. To set the transparent color, known and referred to in Paint Shop Pro 5 as "Palette Transparency," choose Set Palette Transparency from the Colors menu. If the image you are working on is currently not paletted, you will be prompted to convert the image to 256 colors. After conversion (if needed), a dialog box that allows you to set the transparent color will open. Simply move the cursor to the desired color in the image (you will notice your cursor changes to an eye dropper) and click the left mouse button to set the color underneath the dropper to transparent. To see the effect before committing to the change, click the Proof button. Click OK to set the selected color to transparent. If the image needs some touching up, you can actually edit the image with transparency enabled by choosing View Palette Transparency from the Colors menu. Once you are satisfied with the image, open the File menu and choose Save As. In the file type drop-down list, select "CompuServe GIF" and click the OK button.
Save GIFs with transparency as one of the 89a subtypes - the 87 subtype reportedly does not support transparency, or makes black the transparent color.

2.3.2 How do I animate .gifs?

You can't do all of this with Paint Shop Pro. However, you can do this with Animation Shop, which comes bundled with PSP 5. If you don't yet have this, you can start by creating each frame of the animation in PSP. Use identical sizes identical palettes and the same transparent color for each frame. Then use another GIF Animator program (Microsoft used to give one away. In a fit of originality, it was called MS Gif Animator) to assemble the frames and set the timing.

Jasc's Animation shop allows you to perform transformations on existing frames to develop new frames, like fades, blends, etc., a feature not available in some other programs.

2.3.3 How do I use filters on .gifs?

Many of PSPs effects, including the filters, only work on images with a color depth of 16 million colors (24-bit color), or occasionally, 256-grays. If you open a GIF, it will have a palette with up to 256 colors. To fix this, go to Colors / Increase Color Depth / 16 Million Colors (24 bit), then try using the filters. Unfortunately, most filters will leave you with more than the 256 colors your image started with, and you will have to reduce the color depth to resave the image as a GIF. This may partially undo the effect you were trying to achieve, or otherwise damage the image. Save your master in a safe place before you try this.

2.3.4 How do save true color (24-bit) .gifs?

You can't. The format doesn't allow it. If you want to keep the lossless compression, you can save as a PNG or TIF file, both of which support 24-bit color. The newer versions (4.0) of Netscape Navigator and MS Internet Explorer both support inline PNG images, though both don't support everything that PNGs can do. There may be plugins available for version 3 of both browsers. However, if you are web publishing, be aware that many people don't have the 4.0 versions. (And many refuse to get MSIE 4 - it's an OS upgrade as well as a browser.)

2.3.5 My scan looks terrible after I save it as a .gif. Why?

Probably because of the 256 color limitation. You can make this worse by forcing PSP to use a specific palette when decreasing the color depth. A photo of say, a person, will have many intermediate shades, which grade smoothly from one to the next. By reducing the color depth to 256, that smoothness is lost, and you can get "contour patterns". If your picture is, for example, of a person's face against a plain background, you can get reasonable results when reducing color depth by selecting "optimized palette" instead of "standard palette". However, you are probably better off using JPG or PNG for photographic scans.

2.3.6 What is the difference between interlaced and non-interlaced .gifs?

An interlaced GIF is one which has been saved in a way which has rough image data at the beginning of the file, so that a blurry, grainy version of the entire image loads first, coming progressively into focus. This is useful for people with slow internet connections (especially with large images), to allow them to get an idea of what the image is about without waiting for the entire download. However, for small images, most people won't see the difference.

2.3.7 What is the difference between GIF 87a and GIF 89a?

GIF 87a is the original production GIF format, and doesn't support many of the features of GIF 89a. Particularly, GIF 87a does not support transparency, interlacing, or animation. The only advantage to GIF 87a is a marginally smaller file size for some images.

2.6.4 What is this Unisys licensing thing I hear about? Does it affect me?

Unisys developed a compression algorithm called LZW, which is used in GIF files and in some TIFF files. They patented it, but did not enforce their patent for several years. Essentially, the patent covers software which produces LZW-compressed data. Unisys is licensing software to use this compression technique for a fee. Unisys does not collect royalties on GIF or TIFF images.

More information from the file-format FAQ:

In 1995, America Online Services and Prodigy Services Company also entered
license agreements with Unisys for the utilization of LZW. Published
information indicates that Unisys' licensing policies are as follows:

1) Unisys considers all software created or modified before January 1,
1995 that supports the GIF and/or TIFF-LZW formats to be
inadvertently infringing upon its patent; Unisys will therefore not
require a license for GIF software products delivered before January
1, 1995. Unisys will therefore not pursue legal actions against such
pre-1995 software products.

2) However, Unisys expects developers of commercial or for-profit
software to obtain a GIF-LZW license agreement from Unisys if, after
December 31, 1994, the developer creates new software or updates or
modifies existing software, or issues a new release of software that
supports the GIF file format.

3) Unisys does not require licensing of non-commercial, not-for-profit
software applications that support the GIF file format.

4) With respect to TIFF, if a license is entered before July 1, 1995,
there will be no liability for pre-1995 software with respect to
that software's support of TIFF which uses LZW.

Unisys has drafted licenses for several different applications of the LZW
algorithm. The two license agreements of most interest in this FAQ are
applicable to software supporting the GIF file format alone and the
agreement applicable to software supporting both GIF and the TIFF file
format's LZW compression feature.

What this appears to mean, is that producing GIF and LZW-compressed TIFF images is ok, and royalty-free, provided that the program is properly licensed, or exempt. Creating your own program to make LZW-compressed images requires payment of a license fee.

2.4 What is a JPEG/JFIF (.jpg)?

JPEG is the "Joint Photographic Experts Group", which has developed a format called JFIF (JPEG File Interchange Format), which is usually saved as .jpg (or sometimes .jpeg on systems which support long filenames). The format allows for 24-bit color, but trades off a bit of accuracy to achieve compact file sizes. The JPEG studied what the eye actually sees in photographic images, and created the format to be more sensitive to those things to which the eye is more sensitive. The eye is most sensitive in the green region of the spectrum, and is more sensitive to small brightness chnges than to small color changes, so the JPEG standard keeps more of the green information and brightness level information, while skimping on the red and blue information. Also, since most natural scenes have many smooth transitions and few sharp edges, the format allows a little blurring to compress the data as efficiently as possible. Finally, the JPEG standard allows for varying compression levels, so that you can select your own tradeoff between filesize and image quality. Tom Lane has prepared a FAQ for JPEGs, available at http://www.faqs.org/faqs/jpeg-faq/ (and has contributed a lot to this FAQ. Thanks, Tom!).

Technically, the image format is "JFIF", but almost everyone calls it JPEG. There is a proposed standard coming from the TIFF people which would allow JPEG compression in a TIFF (TIFF-JPEG). This will serve to expand the range of things which some TIFF applications won't support, and to confuse lots of people.

2.4.1 How do I get transparency in a .jpg?

You don't. The standard does not support transparency at all. To get transparent 24-bit color images, you need to use PNG (or TIFF).

2.4.2 How do I animate .jpgs?

You don't. There is a standard called MPEG (Motion Picture Expert Group) which does this. MPEG uses JPEG-like compression, but also save about 3/4 of all frames as "difference frames", only storing the change from the previous frame. MPEG also supports sound in its newer incarnations. See the MPEG FAQ at http://www.faqs.org/faqs/mpeg-faq/part0/for more information about MPEG.

2.4.3 What is "lossy" compression?

As described above, the JPEG standard allows some minor blurring and loss of color detail in order to obtain smaller file sizes. When an image is converted to JPEG, it is scanned in 8x8 (or 16x16) blocks, and a function is developed which approximately describes the pixels in that block. If changing the color values of some pixels slightly makes the function much simpler, then the pixel is changed. Different compression levels control how much the pixels may be changed during the compression process.

2.4.4 How do I save the palette from a .jpg?

There is no palette in a .jpg. If you have an image with relatively few colors which has been saved as a .jpg, you can decrease color depth to 256 (or 16 or 4), and save the resulting palette.

2.4.5 My drawing looks terrible after I save it as a .jpg. Why?

There are two easy mistakes with .jpgs - too much compression and using images which don't do JPEG well. Images with sharp edges, or large blocks of solid color, or text, do poorly with .jpg compression, because it wasn't designed to handle abrupt changes in color values.

You can either resave the original image again with lower compression, or use a different format (PNG or TIFF). Once you've saved an image as a .jpg, with a specific "compression level", resaving it at any other compression level, even a lower one, will degrade the image further.

2.4.6 What is a "progressive" JPEG?

A progressive JPEG is not a JPEG from Berkeley. It is a JPEG image which has been saved in a way which has rough image data at the beginning of the file, so that a blurry, grainy version of the entire image loads first, coming progressively into focus. This is useful for people with slow internet connections (especially with large images), to allow them to get an idea of what the image is about without waiting for the entire download.

2.5 What is a MSWindows/OS/2 Bitmap (.bmp)?

A BMP file has a complete description of the color at each pixel in an image. As a result, Windows (and OS/2) require almost no computation to display these files. A bitmap can be either 256 colors, with a palette, or truecolor, with 24-bit color (16.7 million colors).

2.5.1 Why are my .bmp files so BIG?

A .bmp uses one or three bytes per pixel, with no compression. Most images have lots of redundant information, which any compression scheme can use to significantly reduce the file size. Bitmaps don't even bother. Images can be saved with "Run-length encoding", a very simple compression scheme, to reduce file size. Run-length encoding works best with large blocks or long rows of identical color.

2.5.2 How do I make images for the Windows95 boot and shutdown screens?

See http://www.annoyances.org/win95/win95ann2.html#03for this information. It's pretty easy, you just need to create 256-color bitmaps of a specific size, and give them specific names.

2.5.3 How do I get that scrolling bar on the bottom of the Windows95 boot screen?

This is another one of those Microsoft undocumented features - MS Bitmaps aren't supposed to be able to do that. There was an answer posted either in this group or in comp.os.windows.win95.moderated, but I've lost the reference. If you have it, please e-mail me with it.

2.6 What is a TIFF (.tif)?

According to the folks at Adobe:

TIFF is a tag-based image file format that is designed to promote the interchange of digital image data. The TIFF format originated in 1986 when Aldus Corporation and leading scanner vendors worked together to create a standard file format for images used in desktop publishing. The first version of the specification was published in July, 1986. Version 5.0 of the specification was completed in August, 1988.
TIFF supports color depths up to 24-bit, or 32-bit CMYK color, allows transparency in some color depths, supports a variety of compression schemes, and allows for thumbnail images and indexing text. TIFF tries to do just about everything you, or anyone else, could want an image format to do. As a result, the spec is very complex, and many programs will render only some TIFFs successfully. Even Adobe Photoshop can't read TIFF images which use a particular type of compression (group 4 compression).

2.6.1 What do the different types of compression do?

I don't really know. LZW is a pretty efficient compression algorithm, but there are better ones available now. The FAX-CCITT compression is the same as used by fax machines, and only works on one-bit images (black and white with no gray). Your faxing program and OCR programs should be happiest with fax-compressed images, but most recent ones can handle many kinds of TIFF files. If you really need to know, look in the comp.compression FAQ at http://www.faqs.org/faqs/by-newsgroup/comp/comp.compression.html, or find a textbook on data compression.

2.6.2 Why do people recommend saving works-in-progress as TIFFs?

Because TIFF allows saving 24-bit color with lossless compression. Before PNG was developed, TIFF was pretty much the only way to do this, as .bmp doesn't compress, GIF only keeps 256 colors, and JPEG is lossy. TIFF also allows various blocks of non-image information (like copyright notices) to be stored.

2.6.3 Why do people still use TIFFs?

TIFF has been around a long time, and as a result, there are lots of TIFF images, and lots of programs which work with or depend on TIFF images. The developers of PNG hope to replace GIF and many applications of TIFF, but there are some uses where TIFF is probably superior. I don't know what they are, but they do exist.

2.6.4 What is this Unisys licensing thing I hear about? Does it affect me?

Unisys developed a compression algorithm called LZW, which is used in GIF files and in some TIFF files. They patented it, but did not enforce their patent for several years. Essentially, the patent covers software which produces LZW-compressed data. Unisys is licensing software to use this compression technique for a fee. Unisys does not collect royalties on GIF or TIFF images. See the GIF section for more information.

2.7 What is a PNG (.png)?

According to the official PNG home page (http://www.cdrom.com/pub/png/):

PNG (pronounced ``ping'') is the Portable Network Graphics format, a format for storing images on computers. Unofficially its acronym stands for ``PNG's Not GIF.'' PNG was designed to be the successor to the once-popular GIF format, which became decidedly less popular right around New Year's Day 1995 when Unisys and CompuServe suddenly announced that programs implementing GIF would require royalties, because of Unisys' patent on the LZW compression method used in GIF. Since GIF had been showing its age in a number of ways even prior to that, the announcement only catalyzed the development of a new and much-improved replacement format. PNG is the result.
PNG has a variety of features. Once again, quoting the PNG home page:
  • unambiguous pronunciation (ooo, baby!)
  • multiple CRCs so that file integrity can be checked without viewing
  • ultra-clever magic signature that can detect the most common types of file corruption
  • better compression than GIF, typically 10% to 30% (still working on those statistics)
  • non-patented (you betcha!), completely lossless compression
  • majorly gnarly two-dimensional interlacing scheme
  • 1-, 2-, 4- and 8-bit palette support (like GIF)
  • 1-, 2-, 4-, 8- and 16-bit grayscale support
  • 8- and 16-bit-per-channel (that is, 24- and 48-bit) truecolor support
  • full alpha blending in 8- and 16-bit modes, not just simple on-off transparency like GIF
  • gamma correction for cross-platform ``brightness'' control
  • full Year 2000 (Y2K) support (good for at least 8 millenia! yowza!)
  • free and complete reference implementation with full source code
2.7.1 How do I get transparency in a .png?

PNG transparency is a bit more complicated than GIF transparency. PNG can use a transparent color in images with no more than 256 colors (palette images), and it supports an "alpha channel", which specifies how transparent each pixel is supposed to be. Possible values range from 0 (opaque) to 255 (completely transparent). PNG can also assign a different transparency value to each color in a palette, but PSP does not appear to be able to take advantage of that.

For a palette (256 or fewer colors) PNG, transparency consists of selecting a transparent color, and saving it, just like in GIFs.

For a 16.7-million (24-bit) color PNG, transparency comes from an alpha channel. This works like a mask in Paint Shop Pro, and PSP uses masks to do this job with PNGs. To save an alpha channel with a 16.7-million color PNG, create a mask that gives you the desired transparency, and save the file. If you open a PNG with alpha channel information, PSP converts this to a mask.

2.7.2 How do I animate .pngs?

You don't. There is a developing standard for "MNG", Multi-image Network Graphics, with a release version now out. (The MNG homepage is at http://www.cdrom.com/pub/mng/) PSP does not support it,just like they don't support GIF animation, but Animation Shop (which comes with PSP 5) gives it partial support. In fact, Animation Shop uses a subset of MNG for its default file type. Unfortunately, Animation Shop does not support everything that MNG does, and cannot render some of the sample MNG images available at the MNG homepage.

2.7.3 What is the "alpha channel", and how do I use it?

An alpha channel is like a mask. It describes the transparency of the image, on a scale of 0 (opaque) to 255 (completely transparent). PSP 4 doesn't show transparency, except with the "preview" option, but PSP 5 does have ways to show transparency, and many other programs do, especially web browsers.

To use an alpha channel with a PNG (and TIFF and TGA image), create a mask in PSP to do the transparency you want, then save the image. The mask will automatically be saved as an alpha channel.

2.7.4 My (transparent) .png looks terrible in Netscape Navigator. Why?

Because Netscape's PNG support is broken, and doesn't render alpha channels (transparency) properly. This is supposed to be fixed in Mozilla 5, but hasn't been yet.

3. What OSs does PSP run on?

PSP has versions which run on Windows 3.x, Windows 95, Windows 98, Windows NT 3.51, NT 4.0, and NT 5.0 (Assuming that NT 5.0 actually runs.)

3.1 What versions of PSP are available, and which run on which OS?

PSP Version 3.0 through 3.12 and PSP 4.10, 4.12,and 4.14 are widely used. The final version of PSP 5.0 is now available, too. Only 3.12, 4.14, and 5.01 are available from the Jasc website last time I checked.

Upgrade patches are available for registered users of 3.1 and 3.11 to upgrade to 3.12, and for registered users of 4.10 and 4.12 to upgrade to 4.14 (3.1 to 3.12 and 4.10 to 4.14 requires two patches, applied in order.)

PSP 3.x runs on Windows 3.x. and NT 3.51. (And under Win95/NT 4?) PSP 4.x runs only under Windows95 and NT 4.0 or better. PSP 5.0 runs under Windows95/98, and NT 4.0/5.0, but has features (ICM 2.0, whatever that is) which only work under Windows98 or NT 5.0. I don't know if 3.x will run under Windows 3.1 over OS/2. I also don't know if PSP 3 or 4 will run under Wine on Linux (I haven't been able to get PSP 5 to work this way).

3.2 What known bugs are there in PSP?

There are several common bugs found in PSP 4:

The Linear Gradient Fill bug - PSP crashes when you try to select options for linear gradient fill
The msvcrt10.dll bug - Certain actions trigger a crash which says something like "Page Fault in msvcrt10.dll"
The Kernel32.dll bug - Certain actions trigger a crash which says something like "Page Fault in Kernel32.dll"
The Adobe Type Manager bug - selecting a font in PSP will crash if you have Adobe Type Manager with font smoothing enabled.

PSP 5.0 seems to be nearly bug-free, except for the Adobe Type Manager bug, some flakiness with TWAIN scanners, and the "Multiple Instances" bug. Some minor bugs/features were corrected in the PSP 5.01 upgrade patch. Be sure you got the second version of the patch - there were problems with the first one. There are some conflicts with MS Internet Explorer 5 beta, but that's to be expected - it's a beta of a major OS component. Those aren't PSP bugs, they're IE 5 bugs.

3.2.1 How do I fix the Linear Gradient Fill Bug?

Get PSP v 4.14, where the bug is fixed, or upgrade to PSP 5.01. There was no fix prior to version 4.14.

3.2.2 How do I fix the msvcrt10.dll bug?

Get a copy of mscvrt10.dll from the Jasc website, and place it in the same directory as psp.exe . PSP will look for this dll there first, then in the Windows and Windows\System directories. If you replace the one you have in your Windows directory, you may adversely affect other programs.

3.2.3 How do I fix the Kernel32.dll bug?

Get a new copy of Kernel32.dll from Microsoft. Somewhere. (They keep re-doing their site, and I can't even find the Knowledge Base article about this bug any more.)

3.2.4 How do I fix the Adobe Type Manager bug?

Go into the Adobe Type Manger Control Panel, and turn off Font Smoothing.

3.2.5 What happened to my scanner with PSP 5?

Some people have reported problems with their scanner being incompatible with Paint Shop Pro 5. Sometimes, reloading or replacing the TWAIN drivers fixes this problem. Other times, it doesn't. Jasc is working on this problem, and hopes to have a fix out soon. This appears to have been fixed in 5.01.

3.2.6 What is the "Multiple Instances" bug, and how do I fix it?

If you have PSP 5 associated (in Windows95) with any image file types, and you call multiple images from another program (like a newsreader), PSP starts up multiple instances of the program, rather than opening multiple image windows in one program window.

This has been fixed in version 5.01.

In general, using PSP as an image viewer is pretty inefficient, because you have to load up all that editing power just to look at pictures. Favorite image viewers include VuePrint ( http://www.hamrick.com/), and ACDSee (http://www.acdsystems.com/products/acdsee/index.htm).

3.2.7 Help! Upgrading to 5.01 screwed things up!!!

The original patch to upgrade from version 5.00 to version 5.01 had some problems which were fixed in the 5.01 patch b. If you experienced problems with PSP during or after installing the 5.01 patch, download it again, and try again. If that doesn't work, uninstall PSP 5 completely, erase any stray copies of psp.exe on your system, turn off your virus checker, re-install PSP 5, then apply the patch. Be sure you got psp5501b.exe - if the name is a little different, it may be the bad patch.

3.2.8 Help! Where did my toolbar go?

If you are using MS Internet Explorer 5 beta, you will get some problems with PSP 5. In particular, toolbars disappear. This is an IE5 bug, not a PSP bug! It is reportedly fixed in the beta 2 of IE5. There are patches which involve hacking the registry, which is far less dangerous, IMO, than installing a beta of an operating system component.

3.2.9 How do I report bugs?

First, shut down all other programs, then try to repeat the buggy behavior. If it doesn't happen again, you have a weird interaction. If it does, try it again with different file(s) open, to make sure you're not dealing with a corrupt file. If the bug is still recurring, re-boot and try again. If it is still happening, document the error messages you get. This includes the "details" available if Windows gives you an error dialog box which lets you see the details. Next, compile a description of your system. Which processor, how much RAM, which version and sub-version of Windows, which version of PSP, exact versions of any other software that has to be running to make the bug manifest itself, and about how much HD space you have left.

Then, post to comp.graphics.apps.paint-shop-pro with a description of the behavior, what triggers it, all error messages, and your system description, and/or e-mail mailto:support@jasc.comfor help.

3.3 What other Jasc software works with PSP?

This depends on what you mean by "works with". Jasc's other programs all produce images readable by PSP, and you can use PSP's screen capture on other Jasc programs. [Anyone wishing to contribute a more specific answer to this, feel free to do so!]

Animation Shop will automatically (?) call up PSP5 if you want to edit a particular frame in ways other than offered by Animation Shop. You can also start Animation Shop from inside PSP 5.

3.4 What third party software works with PSP?

Adobe Photoshop-compatible image-processing filters (plug-ins) work with PSP, as do Aldus-compatible import filters. Someone has reported that Photoshop "brushes" work, too. Others? Let me know.

3.4.1 Which Adobe Photoshop plugins work with PSP?

All Adobe-compatible and Aldus-compatible filters/plug-ins should work with PSP, but they must be "code-compatible". This means that they must be 32-bit for PSP 4 and 5, and 16-bit for PSP 3. 32-bit filters usually have the extension ".8bf".

Certain plugins require an extra DLL file such as msvcrt10.dll which can be obtained from
http://www.jasc.com/psp4tech.html. Other plugins apparently require plugin.dll from Adobe to work, and it can make plugins work better. This .dll is not available from Jasc, and is an Adobe proprietary product. It is available in most Adobe programs, and sometimes comes bundled with scanner software.

3.4.2 How do I make x plugin work with PSP?

I don't know generally. If the plugin is an .8be or .8bf file, put it into the "plugins" directory, and try it. If you have msvcrt10.dll and plugin.dll, and it still doesn't work, I can't help you. But someone on the group probably can.

Some additional advice, from the newsgroup:

  • Make sure the color depth is 16 million. Most plugins don't work with less color depth.
  • In PSP 5 select File > Preferences > General Preferences. Then select the Plug-In tab. Here you specify upto three different folders that can contain plugins. Make sure that your folder is listed, and that you have asked for sub-folders to be searched.

3.4.3

4 Where can I get help with drawing technique?

What do I look like, an art teacher? There are several ways to get help. E-mailing me is NOT one of them. Jasc has a page on its website with links to various tutorials and to other people's tutorial pages, at http://www.jasc.com/studio.htmlMany people have put up tutorial pages which are not listed there. A partial list (which may duplicate some on the Jasc list) is included below.

http://www.scantips.com/(very useful scanning hints)
http://www.pspro.ml.org/
http://art-ifact.com/kquinn/
http://www.sumrallworks.com/freebies/buttonhole/psp/tutorials/link2g.htm
http://www.grafx-design.com/psp_tut.html
http://www.geocities.com/BourbonStreet/9584/psptutor.html
http://www.casema.net/~jbodde
http://hem1.passagen.se/grafoman/
http://mardiweb.com/web/
http://www.mccannas.com/ primarily Photoshop, but many PSP techniques, too.
http://www.webweaverxxi.com/psp40/
http://www.geocities.com/Heartland/Plains/9871/PSPlinks.html- just links to PSP tutorials
http://art-ifact.com/kquinn/

There are on-line courses. The Oxford site above is one, and Ziff-Davis University at http://www.zdu.com/ is another. ZDU is $7/month for as many courses as you'd like to take. They frequently offer PSP courses.

You can also read books. The PSP manual from Jasc is pretty basic, and concentrates on how the program works, but some understanding of what PSP does can give you ideas for how to make it do what you want it to do. There have been comments in the group that the PSP 5 manual is better in this regard. There are also several other books about PSP, including one recommended over and over:

    Paint Shop Pro Web Techniques
    by T. Michael Clark
    Published by New Riders Publishing, Indianapolis, Indiana
    ISBN 1-56205-756-1
another book sometimes mentioned is:
    Creating Your Own Web Graphics with Paint Shop Pro 2nd Edition
    by Andy Shafran
    published by QUE.
Both can be ordered from Amazon.com, or your local bookstore. Andy Shafran's book is also available through The book by Clark got many positive reviews in the group a while ago. The first edition of the book by Shafran & Oliver was the subject of some heated discussion, as many people were very dissatisfied by it. The second edition has received better reviews in the newsgroup, and Andy Shafran has stated he is much more satisfied with it than he was with the first.

4.1 My scanned images look bad. Why? What can I do about this?

There are all kinds of problems that can come up. One is a poor quality source image. All you can do for that is to try to fix it after you've scanned it. A lot also depends on your scanner software. Some scanners are known to scan too light or too dark. These are relatively easy to fix in PSP, or, you may be able to change some settings on your scanner software to fix this.

4.1.1 What dpi setting should I use for scanning?

That depends on what you are scanning. Magazine images should not be scanned at much over 100 dpi, because the ink dots used in the image are about that size (anyone know exactly?) and you will get pre-dithered images if you use a finer scanner setting. Newspapers are coarser still, and I wouldn't try anything finer than 60 dpi.

For photographs or other non-pixellated images, figure out what pixel size you want the final image to be, and set your scan to match that, or, set your scan to be an exact integer multiple of that, and resample down after you've scanned. Hint - after resampling, most images can be drastically improved by using the "sharpen" filter. Sometimes repeatedly.

It is also suggested that you use integer divisors of your scanners "optical" (not "interpolated") resolution, so if your scanner has 300x300 dpi, you should use 300, 150, 100, 75, 60, 50, etc dpi only. I use 120 dpi on a 300 dpi scanner with very little trouble, but keeping to integer, or half-integer, divisors does seem to help.

4.1.2 What is "interpolated" resolution on a scanner?

Many scanners claim things like 4800dpi "interpolated" resolution. If you didn't pay thousands of dollars, this resolution isn't really there, and isn't really that useful. Unless you're trying to get really fine details out of a small piece of a photo that's in really sharp focus, more than 300 dpi is usually a waste of time and memory. Interpolated resolution means that the scanner will scan one line 1/300th of an inch wide, then move 1/4800th of an inch, then scan the next 1/300th-inch line, then subtract the difference. This doesn't always work perfectly, and takes up lots of resources. Having said all that, there are expensive scanners, particularly "slide" scanners, which do have incredibly fine resolution. Using such fine resolution should be limited to very small images or parts of images, otherwise your file size will get huge, quickly. A scanner which does 8000dpi (they exist!), scanning an image one millimiter square, will produce a 315-by-315 pixel image, which will require 291kB memory. A one-inch-square image will be 8000x8000, and will require 183MB to store.

4.1.3 What good is 30-bit color scanning if PSP (and most other programs) only use 24-bit color?

This is actually a fairly complex question. The answer has to do with how the eye and film see light, versus how electronics see light. The eye (and film) have a "logarithmic" response. That is, the eye sees the same difference between 4 units and 8 units as between 16 units and 32 units. Electronic devices have a linear response - that is, the difference between 4 units and 8 units is the same as the difference between 16 units and 20 units. A 24-bit-color scanner detects 256 different levels each of red, blue, and green, then performing some kind of transformation to make those linear levels more closely approximate the logarithmic response we expect. By scanning an extra two bits per channel, the scanner can make finer distinctions in the dark end of each range, and deliver better scan quality. For some images, this will matter. For others, it won't. Think about what you will use your scanner for when evaluating various features and claims before you buy one.

4.2.1 How do I get text to follow a curve in PSP?

The short answer is that you don't. If all you really want is to turn the text at an angle, in PSP5, open the layer toolbox, use the text tool, enter your text, and make sure that "floating selection" checked. Then select the "Floating selection" layer in the layer toolbox, go to Image/Rotate, enter your rotation, and make sure "Rotate all Layers" is UNchecked. Then go to Selections/Select None, and your text will be set on the image. (You can also keep it as a separate layer if you wish.)

For anything more complicated, you need to either place the letters individually, placing and rotating each one at a time, or use an outside program to create the effect you're looking for, then import it into PSP. Several people on the newsgroup (including the author) favor using MS Word Art, which comes with newer versions of MS Word, for creating initial curved text. A brief run through Corel's Text Art (from the WordPerfect Suite 8) shows it to be more powerful than the WordArt which came with Office95. I haven't seen the Office 97/98 versions of WordArt yet to compare.

4.2.2 How do I make GIFs (and PNGs) with transparent backgrounds?

If you are starting a new GIF image, go to File/New, select "256 colors (8 bit)", and a background color which will stand out from the rest of your image. Click the "eyedropper" tool, and right-click on the blank image. Then go to Colors/Set Palette Transparency, and select "Set the transparency value to the current background color" and click "OK". To see the transparency, go to Colors/View Palette Transparency.

If you are starting a new PNG or TIFF image, go to File/New, select "16.7 million colors (24 bit)" or "Grayscale (8-bit)", and select "Transparent Background" in the background color selector. Before you save, go to Masks/New/From Image, select "source opacity", and uncheck "invert mask data". After you've saved your image, go to Masks/Save to Alpha Channel. This will attach the transparency information to the image file.

If you are starting with an existing non-transparent image, and want to make a transparent GIF, first, reduce the color depth to 256 colors (Colors/Decrease Color Depth/256 Colors using your preferred options), select the area you want to keep as part of the image using the lasso tool, then go to Selections/Invert Selection, then use the Flood Fill tool to fill the background with a solid color which does not occur elsewhere in your image. Using the eyedropper, right-click on the new solid-color fill, then go to Colors/Set Palette Transparency, and select "Set the transparency value to the current background color" and click "OK". To see the transparency, go to Colors/View Palette Transparency.


Macromedia FreeHand 9

Macromedia Freehand 9 Профессиональное средство для создания иллюстраций и компоновки страниц для печати и Web-дизайна

FreeHand - незаменимый инструмент для разработчиков, занятых созданием рисунков и компоновкой страниц для печати и Web-дизайна. Область применения FreeHand простирается от рекламных штриховых рисунков и газетной иллюстративной графики до сложных композиций для Интернет, в которых векторные и растровые изображения сочетаются с текстами, элементами интерфейса и анимациями.

Новые возможности FreeHand 9

Кратко перечислим некоторые из новых возможностей FreeHand 9, отмеченного наградами программного средства для профессиональной полиграфии и Web-дизайна.

Иллюстрации

Создавайте красивые рисунки и компонуйте многостраничные документы в одном и том же приложении.

  • Уникальная перспективная сетка для трехмерных рисунков
  • Функция Live enveloping (отрисовка оболочки в реальном масштабе времени)
  • Трассировка при помощи Волшебной палочки
  • Настройка масштаба и единиц измерения
  • Ювелирная точность инструмента Freehand
  • Дополнительные "рукоятки" для интерактивных трансформаций
  • Новые и улучшенные эффекты смешивания

Производительность

Экономьте время при помощи рациональных средств управления содержанием и компоновкой страницы.

  • Интуитивно ясные новые инструменты управления многостраничными документами
  • Инструмент Лассо для векторной графики
  • Быстрая и точная автотрассировка
  • Непревзойденное управление цветами, включая поддержку синхронизации цветов (Color Sync)
  • Простое управление слоями
  • Настройка размеров страниц
  • перации повторения шагов (Step and Repeat)
  • Управление связанными файлами
  • Создание и редактирование многостраничных документов в формате Acrobat PDF с примечаниями и ссылками URL
  • Интеграция с Photoshop
  • Экспорт оптимизированных GIF, JPEG, PNG и других Web-форматов

Flash

Создайте превосходные рисунки в формате Flash, стандартном формате для высококачественной векторной графики на Web.

  • Flash 4 FreeHand 9 Studio
  • Встроенные средства экспорта SWF
  • Создание анимаций для Flash при помощи команды Release to Layers (распределение по слоям)
  • Новые анимационные эффекты
  • Создание высококачественного, готового к печати информационного наполнения Flash для последней версии Flash Player
  • Библиотека символов от Macromedia
  • Предварительный просмотр в сглаженном режиме Flash
  • Защита файлов Flash (SWF) от импорта
  • Вывод текстов HTML с форматированием для Dreamweaver

Интуитивно понятные инструментальные средства

Перспективная сетка FreeHand9_pic1.gif (23449 bytes)

FreeHand 9 - наилучший инструмент для отображения трехмерного мира на плоскости. Новая перспективная сетка (Perspective Grid) придаст объем вашему рисунку за считанные секунды.

  • Перспективы с одной, двумя и тремя точками схода
    Создайте направляющие сетки перспективы, изменяя точки схода и линии горизонта для достижения трехмерных эффектов в знакомой рабочей среде.
  • Привязка объектов к сетке
    Придайте объемность любому векторному объекту, зафиксировав его на сетке. Объекты могут автоматически масштабироваться при перемещении к точкам схода, и изменять свой вид при смещении по сетке.
  • Изменение сетки и обновление изображений в реальном масштабе времени
    После привязки объектов дизайнер может изменять компоновку сетки и параметры перспективы, при этом вид объектов на сетке автоматически обновляется в соответствии с новыми параметрами.

Live enveloping FreeHand9_pic2.gif (7424 bytes)

Функция Live enveloping (отрисовка оболочки в реальном масштабе времени) позволяет вам деформировать и искажать рисунок непосредственно на странице.

Инструмент Envelope (оболочка), особенно полезный при создании надписей, упрощает выполнение трудоемких художественных приемов. Деформируйте и искажайте рисунок непосредственно на рабочем поле при помощи нового инструмента Envelope.

  • Воспользуйтесь широким выбором готовых оболочек (envelopes).
  • Создайте свои собственные фреймы-оболочки из контуров, нарисованных во FreeHand.
  • Удалите или добавьте новые точки для повышения точности преобразований.
  • Найдите все оболочки в данном документе при помощи знаменитой функции FreeHand -Графического поиска и замены.
  • Отрисовка оболочки с редактируемым текстом в реальном масштабе времени.
  • Включите опцию Show Map для более точного отображения оболочки.

Ювелирная точность инструмента Freehand

Рисуйте гладкие и зубчатые контуры при помощи нового высокоточного инструмента Freehand. Дважды щелкните по инструменту Freehand в Панели инструментов и движком установите для параметра точности максимальное значение 10 для прорисовки мельчайших деталей. При изображении гладких линий уменьшите значение этого параметра.

Инструмент Freeform FreeHand9_pic3.gif (4086 bytes)

На Панели инструментов пользователи могут найти интуитивно ясный инструмент под названием Freeform, предназначенный для работы с контурами. Это средство особенно эффективно для создания органичных форм путем свободного преобразования ("freeforming") простых фигур вроде круга или прямоугольника.

Для новичков инструмент Freeform является наиболее доступным и понятным средством освоения кривых Безье. Овладение Freeform - первый шаг на пути к творческому применению художественных приемов.

  • Freeform - Pull
    При использовании этого средства для работы с контуром пользователи могут просто указать курсором на контур. Заметьте, что при этом "интеллектуальный" курсор принимает форму стрелки с волнистой линией сбоку.
    Такой вид курсора говорит о том, что пользователь может просто потянуть за контур, чтобы изменить его форму. Если пользователь хочет уменьшить или увеличить зону воздействия на контур, следует нажать и удерживать клавишу "стрелка вправо" или "стрелка влево" на клавиатуре.
  • Freeform - Push
    Когда пользователь выбирает инструмент Freeform и помещает курсор рядом с контуром, "интеллектуальный" курсор становится стрелкой с кружочком сбоку. Теперь пользователь может "толкать" контур, чтобы изменить его форму..
    Как и в режиме Pull, пользователь, удерживая клавиши со стрелками, может увеличить или уменьшить радиус инструмента-"толкателя".
  • Freeform - Reshape Area
    Выбрав инструмент Reshape Area, пользователь может воздействовать на всю область рисунка (в отличие от других инструментов Freeform, которые предназначены для работы с отдельными областями, ограниченными единственным контуром).
  • Дополнительные возможности инструмента Freeform
    Пользователи, имеющие планшеты, чувствительные к нажиму пера, могут в интерактивном режиме модифицировать параметры Freeform, изменяя степень нажима. Двойной щелчок по значку Freeform на Панели инструментов вызывает диалоговое окно конфигурации. При всем при этом удобство редактирования по Безье не теряется - в любое время пользователь может отредактировать положение точек контура.

Интерактивные трансформации

FreeHand предлагает специальное средство для прямого, интерактивного манипулирования рисунком без необходимости выбрать свой инструмент для каждой трансформации - так называемые "рукоятки трансформации" (transform handles), зависящие от типа объекта. Выбор команды меню или просто двойной щелчок мышью по любому объекту или группе выбранных объектов включает отображение интерактивных "рукояток" вокруг объекта. (Выбор команды меню или повторный двойной щелчок отключает рукоятки трансформации.)

Пользователи могут легко изменить центральную точку трансформации, перемещая маркер в виде темного колечка. Щелчок мышью по значку "Центральная точка (center point)" при нажатой клавише "Shift" возвращает центральную точку в центр объекта.

Организация работ

Библиотека символов Macromedia

Библиотека символов позволяет хранить и модифицировать рисунки.

  • Сохраняйте рисунки для многократного использования
    Всегда имейте под рукой часто используемые эмблемы и логотипы.
  • Текущие изменения в проекте делайте централизованно
    Для быстрой замены графики дублируйте основные элементы оформления страниц. Просто отредактируйте рисунок и перетащите его мышью на тот символ в Панели символов, который надо заменить. После этого каждый экземпляр этого символа будет заменен на новую версию.
  • Сократите объем файлов
    При использовании символов хранить нужно лишь один экземпляр рисунка, даже если вы используете его 1000 раз в одном и том же документе. Кроме повышения скорости внесения изменений это означает, что ваши файлы FreeHand будут намного меньше по объему и будут занимать меньше места в памяти.
  • Создайте компактные и быстрые фильмы Flash (SWF) для загрузки через Web
    Пользователи Flash знают, что малый размер файла играет решающую роль. При помощи символов вы сможете указать FreeHand, какие из рисунков следует использовать многократно, и следовательно, создать более компактные фильмы Flash для ускорения загрузки.

Инструмент Лассо FreeHand9_pic4.gif (8500 bytes)

Быстро выберите область произвольной формы при помощи нового инструмента Лассо. Не связанные обычной прямоугольной рамкой выбора, дизайнеры получают возможность точно указать область для редактирования.

Определяемая пользователем зависимость от контекста позволяет при помощи инструментов Лассо и Указатель включить в число выбранных любой объект, которого они касаются, либо отбирать только объекты, полностью окруженные пунктирной линией выбора.

Управление связанными файлами

Функции управления ссылками облегчают поиск, редактирование и организацию повторных ссылок на внешние файлы.

  • Найдите неправильные ссылки в пределах одной папки
    Если у вас есть неверные ссылки, и вы хотите их быстро восстановить, используйте новую возможность FreeHand - поиск ссылочных файлов в текущей папке.
  • Кнопка Show в диалоговом окне Links
    Диалоговое окно Links теперь содержит кнопку Show, так что пользователи могут быстро найти конкретный файл, на который есть ссылка в документе. Просто выберите ссылочный файл в окне диалога и нажмите кнопку Show (Показать). FreeHand 9 покажет файл в текущем окне.
  • Игнорируйте все некорректные ссылки
    В следующий раз, когда вы будете редактировать файл, в котором пропущены некоторые растровые изображения, нажмите новую кнопку Ignore All (игнорировать все) и спокойно открывайте файл, не отвлекаясь на сообщения об ошибках.

Простота управления слоями

Простота управления слоями делает процесс графического дизайна более рациональным.

  • Объедините слои
    Вы можете выбрать все слои или только слои переднего плана.
  • Переключатели режимов
    Включите или выключите отображение слоев, быстро переключайтесь от режима предварительного просмотра к основному режиму (keyline mode), без труда контролируйте атрибуты блокировки слоев.
  • Индикатор активного слоя
    FreeHand 9 обозначает текущий слой рисования специальным значком с изображением пера. Функция Live enveloping позволяет вам деформировать и искажать рисунок непосредственно на странице.

Повторение шагов

Воспользуйтесь операциями повторения шагов (Step and Repeat) с опцией копирования в панели Move Transform. Комбинируйте копирование с вращением, сдвигом, изменением размеров и отражением для достижения художественных эффектов.

Усовершенствованная функция выбора

Редактируйте сложные рисунки с ювелирной точностью. Во FreeHand добавились инструменты выбора, упрощающие редактирование контуров, слоев и заблокированных объектов.

  • Новые команды выбора
    Новые команды выбора FreeHand 9 позволяют вам инвертировать ваш выбор, дополнительно отбирать объекты в группах и контурах обрезки, а также выбрать сразу все содержимое слоя.
  • Выбор при контакте
    Инструменты Указатель и Лассо могут теперь выбирать объекты при касании, либо только объекты, полностью окруженные пунктирной линией выбора.
  • Выбор и манипулирование сегментами контуров
    Выберите сегмент контура, и переместите или удалите его. При перемещении сегмента перемещаются оба его конца. Удаление уничтожает сегмент целиком, размыкая контур.
  • Малые приращения
    Установите два параметра для малых перемещений, применяемых для точного позиционирования при помощи навигационных клавиш.
  • Расширенная блокировка
    Новый флажок Edit locked object (Редактирование заблокированного объекта) позволяет выбрать "степень редактируемости" (level of editability) заблокированного объекта. Если этот флажок сброшен, атрибуты объекта изменить нельзя. Когда флажок установлен, пользователи могут изменять атрибуты заливки и штриховки точно так же, как они могли делать это в предыдущих версиях FreeHand. Независимо от состояния флажка пользователь может выбрать заблокированный объект и выравнивать по нему другие объекты.

Экспорт Flash

Экспорт в формате Flash (SWF) FreeHand9_pic5.gif (5234 bytes)

FreeHand 9 имеет функцию экспорта в формате Flash (SWF), которая позволяет вам опубликовать свой блещущий богатством анимированной векторной графики проект непосредственно на Web или импортировать его во Flash 4, чтобы еще более повысить уровень его интерактивности.

Храните гиперссылки, динамические эффекты (rollovers) и точки останова (autoplay button stops) в каждом фрейме, чтобы создать слайд-шоу, управляемое кнопками или навигационными клавишами.

  • Высококачественная печать для электронного бизнеса
  • Экспорт статических фильмов Flash
  • Послойная или постраничная анимация
  • Защита от импорта
  • Автовоспроизведение
  • Полноэкранный режим

Поддержка печати во Flash

При помощи FreeHand 9 компонуйте документы для последней версии Flash Player, чтобы создать Web-приложение с функциями печати. Например, включите в документ анимированные баннеры, которые вызывают печать купонов на приобретение манипулятора трекбол со скидкой или таблиц спецификаций, также разработанных во FreeHand.

Защита от импорта

Режим Protect from Import (защита от импорта) не допускает повторного использования файлов, защищенных авторским правом, и других важных файлов. Пользователи могут защитить фильм Flash от загрузки из сети и импорта в другой редактор.

Ссылки URL FreeHand9_pic6.gif (3265 bytes)

Используйте редактор URL для вставки гиперссылок в свои файлы. Храните гиперссылки, динамические эффекты (rollovers) и точки останова (autoplay button stops) в каждом фрейме, чтобы создать слайд-шоу, управляемое кнопками или навигационными клавишами.

Сглаженный режим отображения Flash

Новый сглаженный (anti-alias) режим отображения использует "машину сглаживания" (anti-alias engine) из Flash, чтобы показать, как ваши рисунки будут смотреться во Flash без выхода из FreeHand. Чтобы использовать сглаженное отображение, выберите "Anti-alias" в меню View или во всплывающем диалоговом окне в левом нижнем углу окна документа.


Paint Shop Pro™ 7

Paint Shop Pro™ 7.0/Animation Shop™ 3.0 Public Beta 5 (Build 20000821.14)

Release Notes

Last Revised: 9/11/00

Thank you for trying the beta version of Jasc® Paint Shop Pro™7.0 and Animation Shop™ 3.0! We are excited to release this version for public review.

Note: The Paint Shop Pro 7.0 public beta is complete. Access to the newsgroups and Web defect form will be closed on September 11, 2000. E-mails will be monitored, but we will no longer be actively responding to inquiries. If you encounter a problem with this beta version, please await the final release of the evaluation version of Paint Shop Pro 7.0 (coming soon) and check it to see if the problem remains. If you still encounter the problem, please use the Help>Jasc Software Online>Email Technical Support command in Paint Shop Pro or Animation Shop to contact our Technical Support department for assistance. The evaluation version of Paint Shop Pro 7.0 will be available before the beta expires on October 15, 2000.

Please note that this product is a pre-release version. You may encounter errors, unexpected program behavior, and other unanticipated program behavior during use.

This software is protected by copyright laws and international treaties and may only be used in accordance with the license agreement that you accepted during installation of the product. For your convenience, a copy of the license agreement is also provided in this document. Please review it if you have any questions on the legal use of this product.

This document will assist you in using this product. Please review this document completely to ensure that you understand the changes and limitations of the product in its current state of development.

CONTENTS

  • Purpose of Public Beta
  • What's New in Paint Shop Pro 7.0?
  • What's New in Animation Shop 3.0?
  • What's New in Beta 2?
  • What's New in Beta 3?
  • What's New in Beta 4?
  • What's New in Beta 5?
  • Rules for Using the Public Beta Software
  • Testing Guidelines
  • System Recommendations
  • How to Contact Us
  • Technical Support
  • Known Issues
  • Pricing, Upgrades, and Product Availability
  • License Agreement
  • Acknowledgements

Purpose of Public Beta

Although Jasc considers the features of Paint Shop Pro 7 and Animation Shop 3 to be complete, we want to ensure that the products will work optimally for our valued customers. The products are therefore being released as a Public Beta to ensure that they function properly across the widest possible array of supported system configurations.

In addition, the Public Beta Test gives you, our valued customers, a special preview of what you can expect to see in the upcoming product release.

What's New in Paint Shop Pro 7.0

Note: The Paint Shop Pro Help file and Tips of the Day are still in development. They will be completed in the final release.

Photo Enhancement Tools

  • Automatic Contrast Enhancement, Automatic Color Balance, Automatic Saturation Enhancement and Fade Correction commands provide quick, automated, and easy-to-use tools for correcting common problems with digital photos. These commands are available by selecting the desired command from the Effects>Enhance Photo menu.
  • The Manual Color Correction command provides a more powerful alternative to Automatic Color Correction. It allows for simple adjustment of even the most difficult images as well as ensuring the accuracy of critical colors such as those in corporate logos. The target color(s) for adjustment are defined in the left preview in the Manual Color Correction dialog box; the target colors are defined either by selecting the appropriate Color Category and corresponding Preset color, or by selecting a Custom Color using the Color selection square. A Custom Color can also be selected from any open image in the program by moving the cursor over the desired section and clicking the left mouse key (note that the cursor changes to a dropper when moved outside of the Manual Color Correction dialog box). This command is also accessed by selecting it from the Effects>Enhance Photo menu.
  • The flexible Histogram Adjustment feature can set the image to use the full available range of intensities, with control over the balance between shadows and highlights. A unique benefit of this feature is that it allows midtones to be balanced against both shadows and highlights. Additional controls permit low contrast versions of the image to be created for use as Web page backgrounds or watermarks. This command is available in the Colors>Histogram Functions menu.
  • New tools are also available that correct image defects associated with specific sources of digital photos. These include the Deinterlace command to eliminate missing or misaligned scan lines from video captures, JPEG Artifact Removal to reduce image damage caused by repeated re-saving or overly aggressive use of JPEG compression, and Moiré Pattern Removal to remove undesired patterns, color bands, and blobs of incorrect color in images created by scanning from a printed copy. These commands are also accessed from the Effects>Enhance Photo menu.
  • The Edge-Preserving Smooth, Texture-Preserving Smooth, Average and expanded Median commands allow removal of various types of image noise. The Edge-Preserving Smooth, Texture-Preserving Smooth and Median commands are found in the Effects>Noise menu; the Average command is found in the Effects>Blur menu.
  • The Automatic Small Scratch Removal and Salt and Pepper Filter are provided for removing dust, specks and scratches from an image. To avoid damaging important image details when using these commands, it is best to define a selection using Paint Shop Pro's selection tools before applying them. Automatic Small Scratch Removal is found on the Effects>Enhance Photo menu; the Salt and Pepper Filter is found in the Effects>Noise menu.
  • A Scratch Remover tool is also available for rapid and intelligent removal of image defects from smooth areas. Moreover, it can be used to remove arbitrary objects from an image, provided such objects are on a smooth background. The Scratch Remover can be found between the Retouch and Eraser tools on the Tool Palette, and is configured using the Tool Options Palette.
  • The Red-eye Removal command can remove the red-eye effect caused by flash from multiple eyes in the image. Additionally, it can be used to change the color of eyes even when they have no red-eye effect. This filter also offers a unique capability to correct the red-eye effect in animals. It is found on the Effects>Enhance Photo menu.
  • The Clarify command can add impact to images without introducing the artifacts that arise from excessive sharpening, and can also restore detail in old and faded photographs as well as those taken under misty or poor lighting conditions. It is also located on the Effects>Enhance Photo menu.
  • Image adjustment commands previously only available using Adjustment Layers can now be applied directly to an image without using such layers, if desired.

Web Tools

  • An Image Mapper and Image Slicer allow you to create HTML and associated graphic output directly from the program interface, including the ability to create JavaScript roll-overs
  • Preview in Web Browser will load and preview an open image in up to three user-defined Web browsers. Before the preview is displayed, you can select to display the image in Bitmap, JPEG, PNG or GIF formats. Selecting JPEG, PNG or GIF will run the appropriate Paint Shop Pro optimizer, then display the image in the selected browser. Select this command from the View menu. To define additional Web browsers, click the Edit Web Browser button after selecting the Preview in Web Browser command.
  • A PNG Optimizer has been added to the File>Export menu. This features allows you to adjust, preview, and determine download times when saving the active image in PNG format.

New Effects

  • Several great new special effects have been added to the program, including: artistic effects such as Aged Newspaper, Brush Strokes, Colored Foil, Contours, Enamel, Sepia, and Topography; Sunburst and Lights illumination effects; Polished Stone, Sandstone, Soft Plastic, Straw-wall, Fine Leather, Rough Leather, and Fur texture effects; and Page Curl. These commands can be accessed through the Effects menu, or use the new Effect Browser from this menu to preview all of the available effects quickly.

Improved Vector/Drawing Tools

  • The Draw, Text, and Preset Shapes tools can now use patterns, textures, and gradients for the Stroke and Fill Styles. Define the desired style and texture using the Color Palette when the object or line is created. If the output of these tools is created as vector, you can also change these properties using the Vector Object Properties dialog box after creation.
  • Vector objects can now be grouped for easier management. After selecting the desired objects, use the Group command on the Objects menu. All objects within a group must be on the same vector layer - however, a group can be created from objects on different vector layers. When objects on different layers are grouped, they will be moved to the same layer.
  • Lines can now be customized with the Draw and Preset shapes tools, allowing the creation of styles such as dashed or dotted lines. Customized lines can also be saved and reloaded for easy reuse. When creating the shape or line, select the desired Line Style on the Tool Options palette, or click the Custom button to define your own line style. The style can be changed after it is created (vector only) through the Vector Object Properties dialog box.
  • Vector objects can also now be aligned, distributed, arranged and resized in relation to other vector objects. These commands can be found on the new Objects menu, or by using the Tool Options palette when the Vector Object Selection tool is active and a selection containing multiple objects has been defined with it. The Arrange command only requires selection of a single object.
  • Shapes can now be exported for re-use with the Preset Shapes tool. A single object or a group can be exported in this manner using the File>Export>Shape command. Once exported, the shapes will be available through the Tool Options palette when the Preset Shapes tool is active. If you wish to retain all properties of the exported shape, be sure that the "Retain Style" checkbox in the Tool Options palette is enabled; if this box is unchecked, the shape will be created using the current settings defined in the Tool Options and Color palettes (e.g. line width, color, line style, etc.).
  • Vector information can now be read, retained and saved. The program will read supported vector information from CDR, CMX, DRW, DXF, EMF, GEM, HPGL, WMF, and WPG format files. Vector information created in Paint Shop Pro can be preserved by saving the output file in WMF or EMF format.

New Productivity Tools

  • The program now provides snap-to grids and guides for easily aligning various painting and drawing tool output. These settings are now a document-specific property, meaning that they are saved with the file when saved in PSP 7 format so they do not have to be recreated. View the grid and guides by selecting Grid or Guides from the View menu. Choosing the Snap to Grid or Snap to Guides commands from the same menu enables the guides and grid. Snap Influence, Snap Alignment, grid and guide color, spacing, and other functions of this feature are configured using the Grid and Guide Properties… command on the same menu.
  • Program workspaces can now be saved for easily restoring a desired program configuration. A workspace stores the layout of the program interface (e.g. position of toolbars, active tool, and any open images), which will be re-loaded when a saved workspace is opened. Workspaces can be saved, loaded, and deleted using the File>Workspace commands.
  • A Repeat command is now available on the Edit menu to repeat the last command used.
  • The user interface has been updated for increased productivity and power. Some of the most prominent changes are:
  • Many commands from the Image menu in previous versions have been moved to the new Effects menu to allow easier access to commonly used effects.
  • The Color Palette has been significantly enhanced to allow easy use of textures, patterns, and gradients with the program tools. The Color Palette will also now display the actual palette of an image when working on paletted images.
  • Picture Tubes, Preset Shapes, Gradients, Patterns, Textures, and Line Styles are now displayed graphically for easier recognition and selection.
  • The Capture commands have been moved to the File>Import menu to reduce menu clutter.
  • Proofing, autoproofing, and a Reset option are now offered in most program dialogs, such as Drop Shadow. This allows the changes to be tested in the image before applying them to an image, or permits the settings to be restored to its original state. Both of these functions can also be toggled on or off as desired.
  • An Effect Browser replaces the Filter and Deformations browsers in previous versions, and now supports all available effects. This feature is accessed from the Effects menu.
  • Many additional commands can now be added when customizing the toolbar. In order to support this feature, icons have been added to all menu commands. If you do not wish to see menu icons, they can be disabled using the Dialogs and Palettes tab in the General Program Preferences dialog box.
  • An Autosave option prevents the possible loss of data caused if your system encounters a problem which forces Paint Shop Pro to be shut down. Autosave can be configured in the File>Preferences menu.
  • The program allows much greater flexibility for selecting the location of resources such as Picture Tubes, Patterns, Textures, and Gradients. Multiple locations can be defined for these resources and toggled on or off as desired. Settings are accessed via File>Preferences>File Locations.
  • An Overview Window is now offered as a new palette. The Overview Window will allow you to easily navigate around an image when it is viewed at a higher zoom level.
  • The Histogram has been greatly updated to permit much greater customization of what information you wish to see about the image content. The Histogram can be toggled on/off using the "H" key on the keyboard.

Additional Enhancements

  • The brush tools now support the use of Gradients and Patterns. Use the Styles and Textures pickers in the Color Palette to select the desired gradient or pattern to use this feature.
  • A mask can now be added to an image by dragging and dropping it from the browser
  • Custom brush tips can now be resized by changing the Size value in the Tool Options Palette.
  • Retouch brushes now retain independent brush settings. This feature allows the user to define a separate brush tip, shape, size, hardness, opacity, step, density, and build-up brush state for each retouch mode.
  • When the Zoom tool is active, you can now click and drag to define a specific area of an image to magnify. The window size will be retained and the zoom level will adjust to fit the defined area within it.
  • Program warning can be toggled on or off using the Warnings tab in the General Program Preferences dialog box
  • CDR file format support has been updated to support CorelDRAW© version 9.0.

What's New in Animation Shop 3.0?

  • Integration of the Paint Shop Pro browser. This provides an intuitive manner for you to select image and animation files to include in animations and open in the application. The Browser displays thumbnails to provide you more information when searching for a file of interest.
  • A variety of frame and animation modification tools have been added, including temporary floating selections, frame rotation capabilities, and history droplists for the Undo/Redo tools.
  • Ability to open MPEG format files.
  • Greatly expanded features for optimizing and viewing animations, such as the ability to preview the current active image in your selected web browser
  • An "Onionskin Preview" mode makes frame-to-frame editing easier
  • A new toolbar containing VCR-style controls that allow you to play, fast forward and rewind your animation.
  • Enhanced integration between Animation Shop and Paint Shop Pro, including the ability to export all or part of an animation sequence as a tube to be used with Paint Shop Pro.
  • A Mover tool has been added to allow movement of the content of an animation frame within a frame. When used with the <Shift >key, movement is constrained to vertical movement only; <Control> constrains the Mover to horizontal movement.
  • Multiple frames within the same animation can be exported to Paint Shop Pro as a single, multi-layer PSP format file
  • A Morph image transition is now available in the program.
  • CDR file format support has been updated to support CorelDRAW version 9.0.

What's New in Beta 2?

Notes:

1. The fixes and enhancements cited below are not an exhaustive list. Some minor undocumented changes may occur to the product while it is still in beta.

2. IMPORTANT INFORMATION FOR USERS WHO HAVE CREATED PRESETS FOR THE BRUSH STROKES, SANDSTONE, ENAMEL, SOFT PLASTIC, POLISHED STONE, SUNBURST, LIGHTS, CONTOURS, STRAW-WALL, COLORED FOIL, ROUGH LEATHER, AND FINE LEATHER EFFECTS:

The file extensions for presets saved for these effects has changed in beta 2. You must rename the extension of any such effects in order to use them with the program. The list below indicates the effect name and the change to the corresponding preset file extension. A batch file was posted to our hosted PaintShopPro7Beta2 newsgroup to change the extensions if you have installed the program to its default location (C:\Program Files\Jasc Software Inc\Paint Shop Pro 7). You may also rename the files yourself if you have installed the product to a different location or you are familiar with renaming files.

Effect Name Old Extension New Extension

Brush Strokes ae2 pbs

Sandstone ae4 pss

Enamel ae5 pen

Soft Plastic ae6 ppf

Polished Stone ae7 pos

Sunburst aea psb

Lights aeb plh

Contours aef pcn

Straw-wall aeh psw

Colored Foil aei pcf

Rough Leather aej prl

Fine Leather aek pfl

Paint Shop Pro

Feature Changes and Enhancements

  • The Text Entry dialog box has been updated for ease of use by adding the Style and Texture swatches from the Color Palette and an antialias checkbox. A "Standard" text button has also been added that will change the current Style and Texture settings to a solid color fill based on the current Background Solid Color setting in the Color Palette. The Standard text option gives you text just like Paint Shop Pro 6. The color of the fill, as with the Style and Texture settings, can be changed directly from the Text Entry dialog as needed. When these settings are changed when entering new text, the corresponding controls in the Color Palette will reflect these modifications; when these settings are changed in text that is being edited, the changes will not affect the corresponding Color Palette controls
  • Pattern styles now support scaling of 10%-250%. After selecting the desired pattern in the Fill or Stroke Style controls, left-click on the control to display the Pattern dialog box and set the scale % as desired
  • Grid and Guide settings have been consolidated into a single dialog box, accessible from the Grid and Guide Properties… command on the View menu
  • The size of Picture Tube, Custom Brush, Texture, and Pattern thumbnail previews and the method for determining the number of thumbnails to display when selecting resources using these controls have been changed to better support the minimum monitor resolution requirement.
  • An Edit Paths… button has been added to the Custom Brush, Gradient, Texture, and Pattern dialog boxes for quicker access to File Locations preferences
  • The delay time before displaying pop-up windows and tool tips in the left pane of the Layer Palette has been increased to minimize processing demands when using this control on large images.
  • CDR file format support has been updated to support CorelDRAW version 9.0

·

Fixes

  • Palette roll-up behavior has been changed to correct problems which could cause the controls to unroll in the wrong direction or stay in a rolled-up state
  • The view state of floating toolbars and palettes is recalled when the program is shut down and restarted
  • Floating toolbars and palettes follow the state of the application window when minimized
  • The F2 key allows the user to rename the source file of a selected thumbnail in the Paint Shop Pro browser
  • The Custom brush dialog now properly supports a large number of brushes
  • The Custom Brush preview is updated properly when changing file locations and switching from a non-painting tool to a painting tool
  • Solid color tool output is mapped properly to Color Palette Solid Color and Style controls when working with paletted images
  • Gradient style output is properly updated when changing colors using the Foreground and Background Solid Color selectors
  • The Color Replacer brush updates solid color selections in the Color Palette correctly without the need to switch tools first
  • The Airbrush, Paintbrush, and Retouch brushes output foreground color properly when using in conjunction with a pressure sensitive tablet with the "Vary color" tool option enabled
  • Stroke and Fill color settings display and output properly when switching between tools if the channels in the Monitor Gamma Adjustment are set higher than 1.00
  • An issue that could cause the Autosave feature to fail when reopening the program after a critical error has been corrected
  • Selection operations work properly when the "Selection Only" option is enabled in the Histogram window.
  • Unsupported tablet pressure sensitivity options are now disabled in the Tool Options palette when the Picture Tube or Color Replacer brushes are active
  • An issue that could cause layer listings to disappear when increasing the length of the Layer Palette has been corrected
  • The default Guide Line color no longer reverts to black when the program is restarted.
  • A error that could occur when installing the product under Windows 95 on a system with a version of Internet Explorer prior to 3.0 has been corrected
  • The Windows Taskbar will no longer display in Full Screen Preview mode
  • Curves and Levels Adjustment Layers are properly applied to an image without the need to use Auto Proof
  • The Deinterlace, JPEG Artifact Removal, Clarify, and Red-eye Removal functions are now disabled when there is a selection in the active image. These commands are not supported on selections.
  • Ruler hash marks display properly when using the Freehand tool with the Smart Edge selection type
  • The "Enter text here" area of the Text Entry dialog properly displays characters entered using ALT+ number key combination to match the output of the tool

·

Animation Shop

Feature Changes and Enhancements

  • A Reset button added to Morph dialog box
  • CDR file format support has been updated to support CorelDRAW version 9.0

·

Fixes

  • When exporting an image to Paint Shop Pro, then choosing Window > New Window command and making modifications, it will no longer cause an error in Paint Shop Pro while it is saving the image.
  • Animation Shop will now properly support the Ctrl+Shift+T key combination when adding a new frame to a single-frame animation
  • Animation Shop will now process all layers regardless of their visibility state when using the CTRL key and dragging an image from a browser window in Paint Shop Pro to Animation Shop, rather than displaying non-visible layers as empty frames.
  • Using the minimum settings on the TV Scanlines effect with the "Run effect in opposite direction" option enabled will no longer cause an application error.

What's New in Beta 3?

Note: The fixes and enhancements cited below are not an exhaustive list. Some minor undocumented changes may occur to the product while it is still in beta.

Paint Shop Pro

Feature Changes and Enhancements

  • An Edit Paths… button has been added to the first page of the Frame Wizard for quicker access to File Locations preferences
  • The Sunburst effect now allows the user to define the color of the light
  • A Create Raster Selection option has been added to the Objects menu and the Vector Objects Context menu. This command creates a raster selection - indicated by a flashing, dotted marquee - from a vector object, providing a powerful new method of defining selections.
  • The Frame Wizard now supports frames containing two layers. The first layer can be used as a backdrop in the first screen of the Frame Wizard to provide a better preview of frames that have a completely white. Two new sample frames, which demonstrate photo edge effects, are included in this build to demonstrate this change and the options it provides.
  • The gradient selection pop-outs in the Gradient dialog box now display gradient transparency
  • New preset shape libraries, including a set of preset buttons, are included in this release.
  • The installer provides an option to create a desktop icon for Paint Shop Pro
  • Style changes made with the Dropper tool are now automatically carried over to the next selected tool
  • Message boxes have been added to the program to indicate when the current Color Palette settings are not supported by the active tool

Fixes

  • The Dropper tool now performs color selection properly when activated using the CTRL key; however, see the known issue list for a related problem that is not addressed in this release
  • Several fixes have been made to the Retouch tool. However, there is a still a known issue that may cause a USER.EXE error when switching modes.
  • Clicking the Delete Layer button in the Layer Palette will no longer cause an error when a grouped object is the active sub-layer
  • The Color Replacer will no longer generate an error when double-clicked on an image with one style set to "None"
  • Hitting the ESC key while in node editing mode will no longer caused the object being edited to disappear
  • Using the Vary color by pressure option with a tool set to a fill style of "None" will no longer cause an error
  • When in a roll-up state, palettes now stay within the work area of the monitor to prevent them from being lost outside the viewable monitor area.
  • The Explorer tree in the left pane of the Browser window will no longer display a "+" next to folders that do not contain subdirectories
  • A problem that caused a 1-pixel, undesirable change to an image edge when applying certain effects has been corrected
  • Custom brush sizes are now set properly after the size has been changed
  • An issue that caused a 1-pixel shift when defining a selection has been corrected
  • A problem that could cause the Tool Options palette to disable when using large text and icons in toolbars after activating the Draw tool has been addressed
  • An issue that could cause an error when attempting to use a corrupted Picture Frame has been corrected
  • Electronic registration has been moved to the end of the installation to address a problem when using the navigation (Back/Next) buttons

Animation Shop

Fixes

  • An error that could occur after exporting frames to Paint Shop Pro and closing the resulting image window after using the New Window command has been resolved
  • Saved workspace files containing a reference to an image that is no longer available will not prevent the workspace from opening
  • Non-visible layers are now processed properly when using the CTRL key and dragging them from Paint Shop Pro

What's New in Beta 4?

Notes:

1. The fixes and enhancements cited below are not an exhaustive list. Some minor undocumented changes may occur to the product while it is still in beta

2. IMPORTANT INFORMATION FOR PREVIOUS BETA USERS:

a. Please remove all program settings for previous beta versions. This task can be performed by choosing the "Remove all file associations and preferences for Paint Shop Pro 7" option when prompted during removal (uninstall) of previous versions.

b. Workspace files created in previous beta versions are not supported in this and future releases.

Paint Shop Pro

Feature Changes and Enhancements

  • An Image Mapper and Image Slicer with support for creating JavaScript rollovers has been added to this version. When the desired image is active in the program workspace, select the File>Export>Image Mapper or Image Slicer to use these features.
  • Three additional toolbars with a set of default buttons have been added to the program (Effects, Photo, and Web), and the Toolbar has now been renamed as "Standard Toolbar". The new toolbars are hidden by default. Select View>Toolbars to display the Toolbars dialog, where you can select which ones you wish to enable. You can also customize each of these toolbars by selecting it in the Toolbars dialog box and clicking the "Customize" button.
  • A "Toggle Toolbars" command has also been added for quick view/hide control of the new toolbars. The command can also by pressing the <T> hot key. It will hide all toolbars. Although this command is not accessible from a menu, it may be added to any customized toolbar. The command functions in the same manner as the <Tab> key (used to hide all floating palettes and toolbars), but is only affects the toolbars. The toolbars will only be hidden during the current program session. When the program is closed and re-opened, the toolbars will be visible again.
  • The Dropper can be used to select any color within the viewable screen area by positioning the mouse over a solid color swatch, pressing and holding down the <Ctrl> while moving the mouse over the desired color, and clicking the left mouse key. Solid color swatches are available at the top of the Color Palette and in many application effect dialogs, including the Text Entry dialog box. Note: Be sure to change the style of the desired swatch to "Solid Color" when using this method to select colors from the Active Styles panel in the Color Palette or the Text Entry dialog box.
  • Saved workspaces now store toolbar customization information
  • Several additional layer visibility options are available from the Layers>View submenu for easier management of multi-layer images. The new methods are:

Invert: Inverts the current visibility state of all layers

None: Hides all layers

Show Group: View all layers in the layer group of the active layer; all other layers are hidden This command is only available when the active layer is a member of a layer group, as defined in the Layer Groups tab of the Layer Palette.

Hide Group: Hide all layers in the layer group of the active layer; all other layers will be visible. This command is only available when the active layer is a member of a layer group.
  • The Magic Wand and Flood Fill tools now offer a new match mode named "Opacity" that will select/fill based on whether the opacity of a pixel is within the tolerance range of the current pixel. In addition, the All Pixels match mode for the Magic Wand has been renamed to "All Opaque" to provide a more accurate description, and this mode is offered with the Flood Fill tool
  • The Style and Texture Option pop-out menus now stay open for easier style type (Solid Color, Gradient, Pattern, or None) selection. Clicking a mouse key outside of the Style Options pop-outs or pressing a keyboard button will also close the menu without changing the current style.
  • The Create Raster Selection command has been moved to the Selections menu and renamed to From Vector Object. However, the Create Raster Selection command is still available from the Object Selection tool context menu.

Fixes

  • Switching to the Dropper tool using the CTRL key when another tool is active will no longer cause an application error
  • A problem switching Retouch modes with the Retouch tool has been corrected. Please report any further issues you encounter with the Retouch brush promptly using the Beta Defect form
  • A problem browsing an empty fixed disk drive has been corrected
  • Palette hot keys are now disabled when a field in the Tool Options palette is active
  • A problem using the Clone brush with the "Sample Merged" tool option enabled has been corrected
  • An issue that could cause an error when using the Drop Shadow and Chisel effects on a floating selection has been addressed
  • Gradients are now loaded properly when the application is not installed to its default directory or other gradients are defined using the File Locations dialog box.
  • Text Entry output is now corrected when the <Delete> has been used to remove content from a previous use of the tool
  • The browser now functions properly when browsing a folder containing a large volume of vector image format files
  • Color selections in the Rainbow solid color picker control on the Color Palette are now recalled in the Recent Colors dialog box

Animation Shop

Fixes

  • Animation Shop will now properly save an existing GIF file while the browser is open.
  • The print button is now active in the Animation Shop browser.
  • The Preview in Web Browser feature is now disabled if you have an empty animation as your active document.

What's New in Beta 5?

Notes: The fixes and enhancements cited below are not an exhaustive list. Some minor undocumented changes may occur to the product while it is still in beta

Paint Shop Pro

Feature Changes and Enhancements

  • The Direct Digital Camera Support Installer has been released. It is available for download at http://www.jasc.com/psp7.asp?. Additional information on installation and supported cameras is also available at this location as a downloadable Microsoft Word document.

Fixes

  • Deleting installed gradient files will no longer cause an application error
  • Pressing the shortcut key for a palette or toolbar will no longer generate an error when the Tool Options palette's Picture Tube or Preset Shapes pop-out picker is open
  • Attempting to use the Delete Layer button on the Layer Palette when a vector group is the active sub-layer will no longer cause an error
  • An issue that could cause an error when launching the GIF Optimizer from the Image Mapper/Image Slicer using the Optimize Cell/Image button has been corrected
  • An issue that could cause an application error when repeatedly changing vector object properties when opening the properties dialog from the Layer Palette has been corrected
  • Using the GIF Optimizer will the Median Cut color reduction method when the active image contains a floating selection outside of the image canvas will no longer cause a program error
  • The Draw tool now functions properly when using a Fleur de Lis Start/End cap
  • The Image Slicer will no longer cause an error by allowing the user to create invalid image slices
  • An issue with opening supported DXF format files has been corrected
  • A problem with importing gradients properly has been addressed
  • An issue that could cause an error when closing an image containing Picture Tube tool output when the tube file contained invalid data has been corrected
  • Using the lowest supported "Detail" field value with the Enamel effect will no longer cause an error
  • An issue that could cause the second page of the Picture Frame Wizard to preview the incorrect frame has been corrected
  • The option to disable blending of partially transparent pixels and use the existing image color at 100% opacity now works properly in the GIF Optimizer
  • An issue with 1-pixel image defects using several of the program effects has been corrected
  • The Page Curl effect now functions properly on the lower right corner of images
  • The Lights effect preview now functions properly after selecting a preset
  • The Text Entry dialog will no add text to the image when the text has been deleted from the "Enter text here" area of the dialog
  • The Recent Colors dialog will now display the proper colors after the active image has been converted to grey scale
  • Image display is now updated properly when dragging a raster selection that has been selected using the Selections tool in a multi-layer document
  • Documents created by pasting a new image now properly store their modification state after a command has been applied and undone
  • The Reset button now functions properly in the Guassian Blur dialog
  • The Color Replacer now properly replaces all affected image content within the brush tip when the "Show brush outlines" option is enabled
  • When selecting objects and ordering them into a vector group, the objects are now sorted by layer and index to better preserve the original object alignment
  • The "Create New Folder" button in the Browse for Folder dialog is now enabled whenever the dialog is called for browser-related functions
  • The lower scroll bar is now accessible when required after enabling Rulers
  • Cropping an image when the image window is not fully visible in the application workspace will no longer cause the resulting image to be placed outside of the workspace
  • File location preferences now recognize network shares of supported file systems
  • The browser now reads CD-ROMs with an OSTA UDF file system more rapidly

Animation Shop

Fixes

  • The Onionskin Preview now functions properly when used on two frame animations with the "Wrap" and "From left and right" direction options enabled.
  • When exporting frames with both Paint Shop Pro 6 and Paint Shop Pro 7 installed, the output is now properly directed to a single instance of Paint Shop Pro 7
  • The Frame properties command is now enabled if the first or all frames in an animation are selected

Rules for Using the Public Beta Software

The software will be available for download from the Jasc Web site beginning July 7, 2000. You may download and evaluate the products free of charge. We do require that you register before you can install the software. This will allow us to notify you of the availability of new Beta versions and the final product. An active Internet connection is required to register the Beta software online.

Note to the Press: Unfortunately, Jasc cannot provide authorization to include the Public Beta software on any special CD-ROM media you may include with your publications. Each Public Beta version is time-expired with a fixed date and will become non-functional after its predefined date, which may provide an unpleasant experience for your readers. You may encourage your readers to try the Public Beta software by providing a link to the Jasc Web site to obtain the most current version.

Testing Guidelines

System Recommendations

The minimum system requirements for Paint Shop Pro 7 and Animation Shop 3 are:

  • Pentium® or comparable processor
  • 32 MB RAM
  • 75 MB free hard disk space
  • 256-color display adapter at 800 x 600 resolution
  • Windows® 95, Windows 98, Windows NT 4.0, or Windows 2000

Although this software is designed to work under a wide variety of system configurations, we also recommend that you perform some basic system maintenance tasks in order to minimize the possibility of encountering problems arising from existing issues on your system. Such tasks include running Scandisk and the Disk Defragmenter (if applicable), obtaining and installing the latest patches and fixes for your operating system, removing unused files in your system temp directory, and updating drivers for your video card, printer and any other devices you want to use with Paint Shop Pro and Animation Shop. More information on performing these tasks can be found in the Windows Help file or through your computer vendor.

How to Contact Us

Note: The Paint Shop Pro 7.0 public beta is complete. Access to the newsgroups and Web defect form will be closed on September 11, 2000. E-mails will be monitored, but we will no longer be actively responding to inquiries. If you encounter a problem with this beta version, please await the final release of the evaluation version of Paint Shop Pro 7.0 (coming soon) and check it to see if the problem remains. If you still encounter the problem, please use the Help>Jasc Software Online>Email Technical Support command in Paint Shop Pro or Animation Shop to contact our Technical Support department for assistance. The evaluation version of Paint Shop Pro 7.0 will be available before the beta expires on October 15, 2000.

Providing Suggestions for Future Product Releases

We always enjoy receiving feature suggestions from our users. In fact, features such as Snap-to Grids and Guides were added to Paint Shop Pro 7 as a result of feedback from users just like you. This grassroots process helps us to continue to develop products that really meet the needs of our customers. We have set up mailboxes specifically for this Beta Test to collect your suggestions on other features you would like to see in future Paint Shop Pro and Animation Shop product releases.

If you'd like to submit product suggestions for future versions, send your ideas to pspideas@jasc.com (Paint Shop Pro) and asideas@jasc.com (Animation Shop).

Technical Support

Jasc is no longer supporting the beta version of Paint Shop Pro 7 and Animation Shop 3. We encourage you to use the built-in Help facility within the applications to answer any questions on using the program. If you do require assistance with the product, please await the final release of the evaluation version, then download it and check the help files to see if your question has been answered in the final version of the documentation. If you are still require help, please use the Help>Jasc Software Online>Email Technical Support command in Paint Shop Pro or Animation Shop to contact our Technical Support department for assistance.

Known Issues in Beta 5

Paint Shop Pro

  • Changing all Style and Texture settings to "Null" in the Text Entry dialog box may cause the program to become unstable
  • Some users have reported that the program toolbars appear incomplete or corrupted. This problem can typically be resolved by checking with your hardware vendor to ensure you have the latest driver. If the problem still occurs after updating the driver, experiment with different acceleration levels for your video card by proceeding as follows:

- Right-click on the My Computer icon on your Desktop

- Choose Properties from the resulting menu

- Click on the Performance tab

- Click on the Graphics button to open the Advanced Graphics Settings dialog box

- Move the Hardware acceleration setting slider to the left to "None"

- Click OK to close the Advanced Graphics Settings dialog box

- Click OK to close the System Properties dialog box

- You will be prompted to restart your machine. Allow the restart to proceed

- Check Paint Shop Pro to see if the problem still occurs. If this process corrected the problem, go back to the Advanced Graphics Settings dialog box and try moving the setting up one increment at a time and retest in Paint Shop Pro after restarting the computer to determine the maximum hardware setting to use.

  • Some users have reported installer lock-ups on systems with ATI Rage Pro Turbo 2X display adapters. There is a beta driver available from ATI and further information on the driver at http://www.ati.com/uk/pages/spdrivers/index.html. The beta driver appears to correct the problem.
  • There is an incompatibility with Nvidia GeForce 256 display drivers v. 4.12.01.0353, 4.12.01.0359 and 4.12.01.0377. The latest driver, version 4.12.01.0522, will correct the problem. An updated driver is available for download from NVIDIA at http://www.nvidia.com/Products.nsf/htmlmedia/software_drivers.html. You can determine which version of the driver you are using by following the steps below:

· - Choose Start>Settings>Control Panel

· - Open the System Control Panel application

· - Click on the Device Manager tab

· - Double-click on the Display Adapter component

· - Double-click on the adapter listed underneath Display Adapter

· - Click on the Driver tab

· - Click on the Driver File Details button

· - Note the File version information displayed in this dialog box
  • Some system configuration tools (such as TweakUI) allow the user to control the display of folders on the Start Menu. This can prevent Paint Shop Pro from displaying recently opened files on its File menu by changing a Windows registry setting used by Paint Shop Pro in accordance with the requirements of Windows 2000 certification. The relevant registry key is:

HKEY_CURRENT_USER\software\microsoft\windows\currentversion\policies\explorer

If the key value of NoRecentDocsHistory = 1, the program will not display recent files in the File menu. This value can be changed to 0 in the registry to circumvent this behavior.

Note: Editing the Windows registry can cause damage to system operation. If you are not familiar with editing the registry, we recommend disabling affected utilities or consulting your computer vendor for assistance. As program behavior is correct under this system configuration and is in accordance with certification requirements, this information is provided for customer information only and is not supported by Jasc Software. Any modifications to the system registry are the risk of the end user.

Animation Shop

No known issues

Paint Shop Pro 7 pricing, upgrades, and product availability

Please check our Web site at www.jasc.com for detailed information on these topics.

License Agreement

SOFTWARE LICENSE AND LIMITED WARRANTY

Beta Test Version

This is an agreement between you, the end user, and Jasc Software, Inc. ("Jasc"). By installing and/or using this beta version (hereinafter the "Software"), you are agreeing to become bound by the terms of this agreement.

IF YOU DO NOT AGREE TO THE TERMS OF THIS AGREEMENT, DO NOT USE THIS SOFTWARE. PROMPTLY REMOVE IT FROM YOUR COMPUTER.

This Software is protected by copyright laws and international treaties and may only be used in accordance with the license terms.

This Software is a beta version and has not been released commercially. It is available for the sole purpose of allowing users to test it. By its very nature, beta Software may contain bugs and have errors or incomplete features that may have a detrimental effect on the Software program itself, upon the files on your computer and/or upon your computer. By downloading this Software, you are assuming the risk of any bugs, errors or other effects of the Software on your computer and/or files. Do not rely upon this beta program exclusively for any reason.

Do not install or use the Software until you have read and accepted all of the warnings and license terms. Permission to use the Software is conditional upon you agreeing to the license terms. Installation or use of the Software by you will be deemed to be acceptance of the license terms. Acceptance will bind you to the license terms in a legally enforceable contract with Jasc Software, Inc.

The installation of this program will install files necessary to operate the program onto your computer. Other system files, such as .DLLs may be installed or updated and Windows registry entries will be made. Uninstalling the program will not remove all of the installed files or registry entries. As with all installations, it is recommended that you back up your hard drive before you install this program.

GRANT OF LICENSE. Jasc grants to you a non-exclusive right to use the Software during the term of the beta test evaluation period in accordance with the terms contained in this license. You agree to allow this Software to store small amounts of information necessary to protect the Software against unauthorized use, and you acknowledge that Jasc will not disclose any information related to removing or overcoming such anti-piracy information stored in your system at any time.

OWNERSHIP OF SOFTWARE. Jasc and its suppliers retain the copyright, title and ownership of the Software and the written materials.

TERM. This License commences upon the installation of the Software and is effective until terminated by Jasc. Jasc may terminate this License for any reason or for no reason. Jasc may have included code in the Software that will cause the Software to terminate automatically after a certain date or after a certain number of uses. Such termination may occur without notice to you. This License will automatically terminate, without notice, upon the commercial release of the Software program. Upon termination you shall remove the Software from your computer(s).

US GOVERNMENT RESTRICTED RIGHTS. The Software and any accompanying materials are provided with Restricted Rights. Use, duplication or disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of The Rights in Technical Data and Computer Software clause at DFARS 252.227-7013, or subparagraphs (c)(1) and (2) of the Commercial Computer Software - Restricted Rights at 48 CFR 52.227-19, as applicable. Contractor/manufacturer is Jasc Software, Inc., PO Box 44997, Eden Prairie MN 55344.

THIS SOFTWARE AND ACCOMPANYING DOCUMENTATAION (INCLUDING INSTRUCTIONS FOR USE) ARE PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, FURTHER, JASC DOES NOT WARRANT, GUARANTEE, OR MAKE ANY REPRESENTATIONS REGARDING THE USE, OR THE RESULTS OF USE, OF THE SOFTWARE OR DOCUMENTATION IN TERMS OF CORRECTNESS, ACCURACY, RELIABILITY, CURRENTNESS, OR OTHERWISE. THE ENTIRE RISK AS TO THE RESULTS AND PERFORMANCE OF THE SOFTWARE IS ASSUMED BY YOU. IF THE SOFTWARE OR WRITTEN MATERIALS ARE DEFECTIVE,YOU, AND NOT JASC OR ITS DEALERS, DISTRIBUTORS, AGENTS, OR EMPLOYEES, ASSUME THE ENTIRE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

TO THE MAXIMUM EXTENT PERMITTED BY LAW, JASC PROVIDES THIS SOFTWARE WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. NO ORAL OR WRITTEN INFORMATION OR ADVICE GIVEN BY JASC, ITS DEALERS, DISTRIBUTORS, AGENTS OR EMPLOYEES SHALL CREATE A WARRANTY OR IN ANY WAY INCREASE THE SCOPE OF THIS WARRANTY AND YOU MAY NOT RELY ON ANY SUCH INFORMATION OR ADVICE. YOU MAY HAVE OTHER RIGHTS WHICH VARY FROM STATE TO STATE.

NEITHER JASC NOR ANYONE ELSE WHO HAS BEEN INVOLVED IN THE CREATION, PRODUCTION OR DELIVERY OF THIS PRODUCT SHALL BE LIABLE FOR ANY DIRECT, INDIRECT, CONSEQUENTIAL OR INCIDENTAL DAMAGES (INCLUDING DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, AND THE LIKE) ARISING OUT OF THE USE OR INABILITY TO USE SUCH PRODUCT EVEN IF JASC HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

Should any other warranties be found to exist, such warranties shall be limited in duration to ninety (90) days following the date of delivery to you. In no event will Jasc's liability for any damages to you or any other person exceed the amount paid for the license to use the Software.

Jasc shall have no obligation to provide technical support, maintenance, updates or other support for the Software. Jasc shall have no obligation to release a commercial version of the Software.

This License shall be governed and construed in accordance with the laws of the State of Minnesota and shall benefit Jasc, its successors and assigns.

Any claim or dispute between you and Jasc or against any agent, employee, successor or assign of Jasc, whether related to this Agreement or otherwise, and any claim or dispute related to this Agreement or the relationship or duties contemplated under this Agreement, including the validity of this arbitration clause, shall be resolved by binding arbitration by the National Arbitration Forum, under the Code of Procedure then in effect. Any award of the arbitrator(s) may be entered as a judgment in any court of competent jurisdiction. Information may be obtained and claims may be filed at any office of the National Arbitration Forum or at P.O. Box 50191, Minneapolis, MN 55405. This Agreement shall be interpreted under the Federal Arbitration Act.

Acknowledgments

Microsoft and Windows are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries. Pentium is a registered trademark of Intel Corporation. Corel and CorelDRAW are registered trademarks of Corel Corporation or Corel Corporation Limited in Canada, the United States and/or other countries.

All other trademarks or registered trademarks are the property of their respective owners.


Трюки и спецэффекты в PhotoShop 6.0

Пришел новый год, а следовательно и время для того, чтобы начинать новые дела. Поэтому, а также принимая во внимание ряд других причин, перечисленных ниже, я решила заменить название серии данных статей с "Трюки и спецэффекты в PhotoShop 5.5" на "Трюки и спецэффекты в PhotoShop 6.0".

За последнее время я получила много писем с просьбой подробнее остановиться на нововведениях, которые появились в шестой версии данной программы, и рассказать о новых эффектах, реализованных при использовании именно этой версии. Не оставив без внимания просьбы читателей и учитывая появление новых возможностей, начиная с данной статьи, говорить мы будем о программе Adobe PhotoShop 6.0.
Первое нововведение — это появление автофигур. Раньше, чтобы нарисовать примитивный объект, необходимо было долго возиться с инструментами выделение, заливать их необходимым цветом, а то и того хуже — рисовать его при помощи кисточки, карандаша или аэрографа. Еще, конечно, можно было воспользоваться пером, но тут тоже возникали проблемы, особенно для тех, кто раньше не работал с векторной графикой. Теперь все стало значительно проще. Необходимо выбрать фигуру, похожую на ту, которую вы желаете получить, и потом лишь слегка отредактировать ее. Тут есть один нюанс. После того, как применен данный инструмент, создается новый слой, и именно на нем реализовывается объект. После этого можно исправлять его форму, но нельзя применять к нему никаких инструментов рисования, фильтров и много другого. Дело все в том, что данные фигуры представляют собой элемент векторной графики, и подобно шрифтам не являются растровым изображением. Чтобы это исправить, достаточно щелкнуть правой клавишею мыши по необходимому слою и из раскрывшегося меню выбрать опцию "Rasterize Layer" (Рендеринг слоя).
Следующая новинка — это появление такого инструмента, как Styles (Стиль), который чем-то похож на текстуры, но имеет некоторые принципиальные отличия. Применяется данный инструмент к любому слою, кроме фонового. Особенность его состоит в том, что используется он не только на всем формате, но и применим к отдельным объектам и автофигурам. Стили представляют собой готовые фоновые изображения, среди которых можно выбрать что-нибудь подходящее для своего изображения. Здесь есть очень много вариантов, начиная от простых градиентов и заканчивая текстурами реальных материалов и фантастическими узорами. Палитра данного инструмента входит в состав основных. Если окно "Стиль" скрыто, то открыть его можно, проделав следующее: Window –> Show Styles (Окно –> Показать Стили).
Непосредственно на самой панели находятся клавиши, позволяющие реализовывать три действия: очищать палитру (круг, перечеркнутый линией), создавать новый стиль (чистый лист) и удалять имеющийся (корзина).
Чтобы открыть дополнительные функции, необходимо щелкнуть по черному треугольнику, расположенному в верхнем правом углу палитры.
Первые два раздела похожи на стандартные, а именно те, которые есть практически во всех других палитрах.
New Styles (новый стиль). Выбор данной опции позволяет добавлять свой образец в палитру.
Reset Styles (перегрузить стили). Устанавливает набор стилей по умолчанию.
Load Styles (добавить стиль). Добавляет новый набор к уже загруженным.
Save Styles (сохранит стиль). Применяется при создании собственной палитры, которую впоследствии можно сохранить при помощи данной функции.
Replace Styles (заменить стиль). Заменяет текущие на новые.
В третьем — можно выбрать форму, в которой будут представлены образцы:
Text Only — Только Текст.
Small Thumbnail — Маленькие иконки.
Large Thumbnail — Большие иконки.
Small List — Маленький список.
Large list — Большой список.
В последнем разделе можно выбрать уже один из готовых наборов стилей, названия которых дают представление об оптимальной сфере использования.
После того как с основными функциями стало все понятно, следует разобраться, что же представляют из себя эти пресловутые стили и как их применять.
Начнем с основного. Как они работают? Создайте новое изображение с не менее чем двумя слоями. Сделайте активным слой выше первого и щелкните по любому стилю. В результате вы получите очень интересный эффект.
Теперь, что такое стили? Чтобы ответить на этот вопрос, откройте палитру Layers (Слои) после применения одного из них. Любой стиль это есть просто комбинация базовых слоевых эффектов. В этом можно еще раз убедиться, если дважды кликнуть мышкой по любому из показанных эффектов. Откроется стандартное окно настроек для данного стиля.
Вы также можете создавать собственные Styles. Для этого достаточно сгруппировать некоторые базовые эффекты и нажать кнопку "New" в палитре Styles.
Как вы могли убедиться, стили — это огромная помощь при работе с PhotoShop. Однако не стоит злоупотреблять ими в том смысле, что хорошо владеть работой только с ними, забывая остальные возможности PhotoShop 6.0.
В следующих статьях я подробнее остановлюсь и на других возможностях шестой версии программы. Здесь имеется в виду работа с текстом, новые слоевые эффекты и многое другое.
Возвращаясь непосредственно к теме цикла данных статей, вновь (как и было обещано ранее) поговорим о тексте. Сегодня я предлагаю вам еще один вариант того, как из простого текста можно создать интересную, а главное оригинальную надпись.

"Болотный" текст
Название данного эффекта говорит само за себя. Предлагаю попробовать создать нечто слизкое, водное, противное, в общем, как в американских фильмах ужасов всякую нечисть изображают. И действительно, что-то мы всякие приятные вещи рисуем, а ничего неприятного на вид не описали. А ведь это приходится применять даже чаще, чем многое из того, что описано в предыдущих статьях. Хотя, открою одну особенность данного спецэффекта, итоговый результат будет зависеть во многом от того цвета, который будет применен при создании изображения. То есть если вы выберите приятные зеленовато-изумрудный цвет, то, к сожалению, а может быть и к радости, ничего противного у вас не получится.
Итак, приступим непосредственно к работе. Какого цвета должно быть что-то очень неприятное на вид? Правильно, зеленого (болотного). Именно этот цвет ассоциируется у большинства людей с чем-то неприятным. Это известно очень давно, и поэтому в рекламе продуктов почти никогда нет зеленого цвета.
Итак, создаем новый файл и заливаем его зеленой краской. Лучше взять ее скорее темно-зеленой, чем салатовой — эффектней будет результат.
Итак, прежде всего, добавьте шум на исходное изображение. Сделать это можно при помощи фильтра Noise: Filter –> Noise –>Add Noise (Фильтр –>Шум –>Добавить Шум). Сила действия должна быть порядка 20-30.
Теперь на время оставим текстуру и перейдем к созданию заготовки для букв.
Необходимо открыть новый канал. Для этого достаточно кликнуть мышкой по кнопке "Create a new channel" (Создать новый канал) (чистый лист), расположенной в нижней части палитры каналов (Channels).
Используя инструмент "Text", напишите любое слово в новом канале. Лучше не выбирать слишком массивный или тонкий шрифт, так как в первом случае эффект будет очень грубым, а во втором — либо плохо видным, либо слишком ярко выраженным (зависит от настроек).
После выполнения последней операции можно вернуться в RGB канал и продолжить редактирование текстуры.
Для того чтобы придать ей специфический вид, воспользуемся фильтром Wind: Filter –>Stylize –>Wind (Фильтр –>Стилизация –>Ветер).
Исходную текстуру можно считать готовой. Если хотите, то примените фильтр "Ветер" вторично, возможно в вашем случае это улучшит ее вид.
Пришло время использовать заготовку в виде текста в канале. После применения следующего фильтра он проступит в канале RGB, кроме того, будет выглядеть достаточно объемным и с наложенной текстурой. Запустите фильтр Эффекты света: Filter –>Render –>Lighting Effects (Фильтр –>Рендер –>Эффекты света).
Обратите внимание на самый главный параметр — в качестве Texture Channel (Канал текстуры) мы использовали канал Alpha 1, на котором был написан текст.
Поверните полученное изображение на 90 градусов против часовой стрелки: Image –>Rotate Canvas –>90 CW (Изображение –>Вращать холст –>90 п.ч.ст.).
Примените фильтр Wind: Filter –>Stylize –>Wind (Фильтр –>Стилизация –>Ветер) для того, чтобы создать "водоросли" на тексте.
Полученные отростки напоминают намеченную цель очень и очень слабо. Для исправления этого лучше всего воспользоваться фильтром Ripple: Filter –>Distort –>Ripple.
После этого осталось вернуть изображение в нормальное состояние, то есть повернуть его в противоположную сторону и поставить буквы на ноги.
На этом работа сделана полностью. Если результат вас не вполне удовлетворяет, то, скорее всего, стоит его подкорректировать при помощи Brightness/Contrast: Image –> Adjust –> Brightness/Contrast (Изображение –> Настройка –> Яркость/Контраст). Итоговое изображение показано на рисунке. Сейчас, по сложившейся уже традиции, предлагаю вам описание еще одного творения компании, которая создает дополнительные плагины к Adobe PhotoShop, а именно фильтр KPT 5.0.

KPT 5.0 от Metacreation
В свое время самым известным дополнительным плагином был KPT 3.0. Он был своего рода стандартом, на который равнялись остальные производители программного обеспечения под PhotoShop. На сегодняшний день KPT 3.0 уже морально устарел. Однако, компания Metacreation не стояла на месте и выпустила еще два уникальных по своим возможностям набора плагинов — KPT 5.0 и KPT 6.0. Данный раздел в этой статье будет посвящен пятой версии программы.
Сразу стоит сказать, что пятая и шестая версии KPT не имеют ничего общего, и поэтому о шестой версии я расскажу в одной из следующих статей.
KPT 5.0 это один из лучших наборов плагинов, который в основном направлен на искажение изображения. Его нельзя назвать столь же полезным, как Eye Candy, но и области применения у этих программ совершенно разные. Eye Candy направлен прежде всего на прикладные цели, связанные в основном с web-дизайном. KPT 5.0 плагин скорее художественного назначения, область его применения ближе к полиграфии и искусству.
Так как дополнительные плагины мы рассматриваем исключительно обзорно, то на интерфейсе программы останавливаться не стану. Скажу только, что он достаточно удачен, но намного хуже, чем, к примеру, у Xenofex.
Перейдем к описанию входящих в данный набор плагинов.

Blurrrr
Да, именно так название и пишется, с четырьмя буквами "R". Причина, по какой создатели пакета не назвали его просто Blur (Размытие), не известна. Возможно, были проблемы с авторскими правами. Но это не имеет особого значения, так как Blurrrr это самый лучший фильтр, связанный с размытием, из всех существующих. Огромнейшее количество настроек, а следовательно и возможностей. Особенно радует то, что можно создавать впечатление фокусировки камеры, то есть, какой-то объект показывается четко, а все остальное немного размыто. Это всегда бывает в реальной фотографии, и поэтому данный фильтр незаменим в профессиональном фотомонтаже.

Noize
Великолепный фильтр. Как вы могли уже понять из названия, этот фильтр связан с созданием шума. Однако, на шуме возможности Noize не заканчиваются. При помощи него можно создавать мятую бумагу, воду, узоры на стекле, горную поверхность и многое, многое другое, главное понять принцип его работы, что совсем несложно. Учитывая то, как часто при работе с PhotoShop необходим шум, можно считать этот фильтр одним из лучших в наборе.

Radwarp
Фильтр, позволяющий имитировать целый спектр объектов, начиная от стеклянной линзы и заканчивая каплей воды. Достаточно удобен и продуман, но все же его нельзя считать лучшим в своем роде, в основном из-за интерфейса. Однако, если есть необходимость нарисовать очень правдоподобную линзу, никакого другого пути у вас нет (по крайней мере столь быстрого, эффектного и реалистичного). Также можно создавать оригинальные сюрреалистичные работы за несколько секунд.

Smoothie
Красивый и очень простой фильтр. Пожалуй, самый простой во всем наборе. Перерисовывает ваше изображение в битовых цветах. Можно добиться достаточно интересных эффектов, особенно если вам необходимо распечатать их без цвета. Описать это достаточно сложно, поэтому если заинтересовались, то посмотрите, попробуйте — и поймете.

Frax 4D
Самый оригинальный плагин в KPT 5.0. Ближе даже не к двухмерной, а трехмерной графике. По сути, это небольшая программа для генерации трехмерных тел вращения. Можно создавать различные тела через вращение плоскости, то есть конусы, цилиндры, шары и так далее. Но это еще не все. Если вы зададите сложный контур, то получите что-то очень странное, больше всего напоминающее страшно смятый кусок железа. Правда, если вы никогда не работали в программах трехмерной графики, то освоить этот плагин будет тяжело.

Fraxflame
Очень красивый эффект. При помощи его вы сможете создавать фантастические узоры, аналогичных которым нельзя увидеть больше нигде, поэтому и сравнить не с чем. Огромнейшее количество настроек и готовых вариантов делают Fraxflame незаменимым для многих фотохудожников, работающих в PhotoShop.

Flaxplorer
Все, что сказано про Flaxflame, можно повторить и по отношению к этому плагину. Внешне они сильно отличаются, но делают примерно одно и то же — фантастические узоры. При помощи данного фильтра за несколько секунд создаются великолепные работы, которые прекрасно смотрятся и сами по себе и в композиции. И, самое главное, их можно анимировать.

Fiberoptix
Оригинальный искажающий фильтр. Создает впечатление, как будто изображение состоит из сотен тонких, радиальных полос. Прост в применении и выглядит достаточно интересно, чем и может привлечь внимание.

Orb-it
Фильтр, создающий множество объемных шаров. Все необходимые настройки. Особенно радует возможность накладывать на шары собственные карты, то есть любое изображение, что позволяет рисовать действительно красивейшие изображения.
На этом обзор данного дополнительного плагина подошел к концу, а также заканчивается и статья. Если у вас есть вопросы либо предложения, то пишите.


Tucows Preview Page for Paint Shop Pro

Paint Shop Pro 7.0 Beta 2

Size: 25.6 MB
Date: July 21st, 2000

Paint Shop Pro is a well-known graphics editor in the world of computers, but have they outdone themselves this time?

In the newest beta, I think they have. And if that isn't enough, they've included a JASC Animation Shop 3.0 in the download to coax you into checking it out.

Can you say contender?

Although we have many lightweights holding up the graphics world, it's heavyweights like PSP that keep us entertained.

It's features were recently understated, because there is so much more this program has to offer.

There are 11 different categories for image effects, and excellent three-layer support (vektor, raster, adjustment) to boot.

The program also features digital camera support, screen capture support, and much, much more.

However, the most important feature in version 7.0 beta is that it's freeware. It's slam-packed with two superior programs, both worthy of five cows.

If you have the time, download this product! It's beyond worth it.

Paint Shop Pro also includes enhancements to the program's flexible painting and retouching brushes, adjustable cropping and selection tools, and image enhancements.


Untitled

Creature House Expression 2

Форматы графических файлов

Основные типы графических файлов

"Смотрелки" графических файлов

Как работает формат JPEG?

Цвет в компьютере

Цвет и цветовые модели

Графику на диету!

Кривые Безье — основа основ

Тестирование бесплатных графических программ

Чайнику: сканирование и коррекция изображений.

FAQ: Работа с графикой