Встроенные переменные Perl

Сервер поддерживается
Центром Информационных Технологий
(095) 932-9212, 932-9213, 939-0783
E-mail: info@citforum.ru
Сервер Информационных Технологий содержит море(!) аналитической информации

Встроенные переменные Perl.

Описанные в данной главе переменные имеют в Perl специальные значения. Они обозначаются несколько непривычно для "глаза" программистов, т.к. состоят обычно только из двух символов, причем первый это '$' символ, с которого начинаются имена всех переменных, и произвольный часто не буквенно-цифровой символ. Если вы хотите пользоваться их "нормальными" буквенными синонимами, то вам нужно указать в начале программы:

    use English;

Точно так же если вы захотите пользоваться переменными и методами текущего указателя файлов вы можете написать:

    use FileHandle;
после этого можно просто писать:
    метод указатель выражение
или
    указатель -> метод(выражение)

Ниже приводятся имена как в короткой, так и в длинной (словесной) форме. Некоторые из встроенных переменных имеют доступ только на чтение, поэтому изменить их значение просто невозможно.

$_
$ARG

Переменная - по умолчанию для операторов ввода и поиска. То есть если в качестве аргумента не указана никакая переменная, то используется именно эта.

$цифра

Содержит найденную подстроку в последнем поиске, когда шаблон содержит метасимволы в круглых скобках. Цифра в данном случае, это номер скобок. Первая подстрока имеет номер 1.

$&
$MATCH

Найденная подстрока в последнем поиске по шаблону.

$`

Подстрока, предшествующая найденной подстроке.

$'
$POSTMATCH

Подстрока, последующая за найденной подстрокой.

$+
$LAST_PAREN_MATCH

Подстрока, найденная в поиске с выбором по "или".

$*
$MULTILINE_MATCHING

Если значение этой переменной установить равным 1, то переменная, в которой осуществляется поиск, будет считаться многострочной, т.е. содержащей символы '\n' - перевод строки. Если значение равно 0, то переменная считается однострочной. В Perl версии 5 и выше не рекомендуется использовать эту переменную.

$.
$INPUT_LINE_NUMBER
$NR

Номер прочитанной строки последнего оператора ввода. Закрытие файла вызывает очистку значения этой переменной.

$/
$RS
$INPUT_RECORD_SEPARATOR

Символ - признак конца входной строки. По умолчанию это '\n'

$|
$OUTPUT_AUTOFLUSH

Если присвоить этой переменной ненулевое значение, то будет сброс буфера вывода после каждой операции вывода. Значение по умолчанию - 0

$,
$OFS
$OUTPUT_FIELD_SEPARATOR

Символ, добавляемый оператором print после каждого элемента из списка параметров.

$\
$ORS
$OUTPUT_RECORD_SEPARATOR

Символ, добавляемый print после вывода всех параметров.

$"
$LIST_SEPARATOR

Аналогичен "$,", но добавляется после каждого элемента массива, указанного в "....".

$;
$SUBSEP
$SUBSCRIPT_SEPARATOR

Символ - разделитель для эмуляции многомерных массивов в хеш массивах. По умолчанию '\034'.

$#
$OFMT

Формат по умолчанию для вывода чисел.

$%
$FORMAT_PAGE_NUMBER

Формат по умолчанию для вывода номеров страниц.

$=
$FORMAT_LINES_PER_PAGE

Длина одной страницы. По умолчанию 60 строк.

$-
$FORMAT_LINES_LEFT

Количество оставшихся строк на странице.

$~
$FORMAT_NAME

Имя формата текущего вывода. По умолчанию имя указателя.

$^
$FORMAT_TOP_NAME

Имя текущего формата для заголовка страницы.

$:
$FORMAT_LINE_BREAK_CHARACTERS

Символы переноса строки для многострочных полей. В строке формата такие поля начинаются символом '^'. По умолчанию '\n-'.

$^L
$FORMAT_FORMFEED

Символ перевода формата ( смены листа). По умолчанию '\f'.

$^A
$ACCUMULATOR

Текущее значение аккумулятора функции write() для format(). Значение этой переменной можно увидеть только при использовании функции formline(), т.к. write() очищает ее после каждого вывода.

$?
$CHILD_ERROR

Данная переменная содержит статус завершения таких процессов как: закрытие pipe, завершение функций system(), wait() и `...`.

$!
$ERRNO $OS_ERROR

В числовом контексте возвращает код ошибки errno. В строковом - строку сообщения об ошибке. Можно принудительно присвоить этой переменной код ошибки, что бы получить системное сообщение для данного кода или установить код завершения для функции die().

$@
$EVAL_ERROR

Сообщение об ошибке последней команды eval().

$$
$PID
$PROCESS_ID

Номер текущего процесса.

$<
$UID
$REAL_USER_ID

Реальный UID текущего процесса.

$>
$EUID
$EFFECTIVE_USER_ID

Эффективный UID текущего процесса.

$( $GID
$REAL_GROUP_ID

Реальный GID текущего процесса.

$)
$EGID
$EFFECTIVE_GROUP_ID

Эффективный GID текущего процесса.

$O
$PROGRAM_NAME

Имя файла программы. Если этой переменной присвоить какое-нибудь значение, то его можно видеть в команде ps, что удобно для контроля за состоянием программы.

$[

Номер первого элемента массива или символа строки. Значение по умолчанию - 0.

$]
$PERL_VERSION

Строка - сообщение версии Perl. Печатается по команде perl -v Применяется в программе для определения рабочей версии Perl. В числовом контексте это номер версии плюс номер модификации / 1000.

$^D
$DEBUGGING

Текущее значение ключа отладки '-D'.

$^F
$SYSTEM_FD_MAX

Номер максимального системного описателя файлов (system file descriptor). Обычно это 2.

$^I
$INPLACE_EDIT

Текущее значение inplace-edit возможности. Для отключения используйте undef.

$^P
$PERLDB

Внутренний флаг отладки. Применяется для того, чтобы отладчик не отслеживал самого себя.

$^T
$BASETIME

Время в секундах с начала 1970 года старта текущей программы.

$^W
$WARNING

Значение флага '-w'. true -если включено и false - выключено.

$^X
$EXECUTABLE_NAME

Команда запуска Perl. Аналогично argv[0] в С.

$ARGV

Имя текущего файла, читаемого оператором '<>'.

@ARGV

Массив параметров строки запуска программы. Внимание! @#ARGV - меньше количества параметров на 1, т.к. $ARGV[0] это первый параметр (не имя программы).

@INC

Список директорий диска, которые просматривает Perl для выполнения команд do, require или use.

%INC

Этот хеш содержит имена директорий для имен использованных файлов командами do или require. Ключ - имя файла, а значение - директория.

$ENV{выражение}

Хеш %ENV содержит значения переменных окружения. Изменение этих значений вызывает изменение окружения для процессов потомков.

$SIG{выражение}

Хеш %SIG содержит имена подпрограмм для таких системных сигналов как INT, QUIT, PIPE, ... Значение 'DEFAULT' - для системной обработки. 'IGNORE' - игнорировать данный сигнал.

[Назад]
[Содержание]
[Вперед]

Comments: info@citmgu.ru
Copyright © CIT


Встроенные функции

E-mail: info@citforum.ru
Сервер Информационных Технологий содержит море(!) аналитической информации

Встроенные функции.

Встроенные функции используются как термы выражений и подразделяются на две категории: списковые операторы и унарные операторы. Это влияет на их приоритет по отношению к оператору ',' - запятая. Списковые операторы могут иметь множество (список) аргументов, а унарные только один. Таким образом, запятая завершает аргументы унарного оператора и разделяет аргументы спискового. Аргумент унарного оператора воспринимается обычно в скалярном контексте, а спискового как в скалярном, так и списковом, причем скалярные аргументы идут первыми. В дальнейшем списковые аргументы мы будем обозначать словом 'LIST', это значит, что функция имеет список аргументов, разделенных запятой. Аргументы функций можно заключать в круглые скобки и таким образом обозначать, что "это функция" и приоритет не имеет значения, иначе это списковый или унарный оператор с определенным фиксированным приоритетом. Пробел после имени функции и скобкой значения не имеет. Поэтому будьте внимательны!

Пример:

     print 1 + 2 + 3; # результат 6
     print(1+2)+3;    # результат 3
     print (1+2)+3;   # опять 3
     print (1+2+3);   # 6

Если функция возвращает результат как в скалярном так и в списковом контексте, то код выхода по ошибке - скаляр c неопределенным значением или пустой список.

Запомните правило:

Не существует общего правила преобразования списка в скаляр!

Каждый оператор и функция имеют свой вид значения в скалярном контексте. Для одних это количество элементов из скалярного контекста. Для других - первый элемент списка или последний или количество успешных операций. Каждый - свое, если вы специально не указываете.

Оператор '-X', abs, accept, alarm, atan2 Y, X, bind, binmode, bless, caller, chdir, chmod, chomp, chop, chown, chr, chroot, close, closedir, connect, cos, crypt, dbmclose, dbmopen, define, delete, die, do BLOCK, do подпрограмма, do выражение, dump, each, eof, eval, exec, exists, exit, exp, fcntl, fileno, flock, fock, format, formline, getc, getlogin, getpeername, getpgrp PID, getppid, getpriority, Группа системных вызовов, getsockname, getsockopt, glob, gmtime, goto, grep, hex, import, index, int, ioctl, join, keys, kill, last, lc, lcfirst, length, link, listen, local, localtime, log, lstat, m//, map, mkdir, msgctl, msgget, msgsnd, msgrcv, my, next, no Module, oct, open, opendir, ord, pack, pipe, pop, pos, print, printf, push, q/строка/, qq/строка/, qx/строка/, qw/строка/, quotemeta, rand, read, readdir, readlink, recv, redo, ref, rename, require, reset, return, reverse, rewindir, rindex, rmdir, s///, scalar, seek, seekdir, select, select RBITS, WBITS, EBITS, TIMEOUT, semctl, semget, semop, send, setpgrp, setpriority, setsockopt, shift, shmget, shmget, shmread, shutdown, sin, sleep, soket, soketpair, sort, splice, split, sprintf, sqrt, srand, stat, study, substr, symlink, syscall, sysread, system, syswrite, tell, telldir, tie, time, times, tr///, truncate, uc, ucfirst, umask, undef, unlink, unpack, untie, unshift, use, utime, values, vec, wait, waitpid, wantarray, warn, write, y///

Оператор '-X'.

    -X указатель файла
    -X выражение
    -X

Проверка файла, где 'X' - одно из ниже описанных значений. Это унарный оператор с одним аргументом - либо именем файла, либо указателем файла. Проверяет одно из условий. Если аргумент не указан, то берется значение переменной $_. Для ключа -t - STDIN. Результат 1, если true, '', если false или неопределенное значение, если файл не найден. Несмотря на странный вид это унарный оператор с соответствующим приоритетом. Аргумент можно заключать в круглые скобки. 'X' имеет следующие значения:
-r | Файл разрешен на чтение эффективным uid/gid
-w | на запись -//-
-x | исполнение -//-
-o | принадлежит эффективному uid (идентификатор пользователя)
-R | Файл разрешен на чтение реальным uid/gid
-W | на запись -//-
-X | исполнение -//-
-O | принадлежит реальному uid
-e | файл существует
-z | пустой
-s | не пустой
-f | обычный текст
-d | директория
-l | символическая ссылка
-p | pipes (конвейер)
-S | socket (гнездо)
-b | специальное блочное устройство
-c | -//- символьное -//-
-t | указатель на уст-во tty
-u | установлен бит setuid
-g | -//- setgid
-k | -//- sticky
-T | текстовой файл
-B | двоичный
-M | "возраст" файла в днях на момент старта скрипта
-A | дней с последнего чтения
-C | дней с последней модификации inode

abs выражение

Абсолютное значение выражения

accept NEWSOCKET, GENERICSOCKET

Открыть новый сокет по внешнему запросу. Аналогично системному вызову accept(). Возвращает адрес или false в случае неудачи.

alarm секунды

Послать сигнал SIGALARM текущему процессу по истечении указанного промежутка времени. Не допустимо делать несколько вызовов одновременно в одном промежутке времени. Возвращает остаток времени предыдущего счетчика.

atan2 Y, X

Арктангенс отношения Y к X в пределах от -pi до +pi.

bind сокет, имя

Назначить сетевой адрес сокету. Подобно системному вызову bind. Возвращает true в случае успеха и false иначе. Имя - пакетный адрес сокета.

binmode файл

Открыть файл для двоичного (binary) режима доступа. В обычном режиме при вводе символы CR LF транслируются в LF, а при выводе LF транслируется в CR LF.

bless ссылка, класс
bless ссылка

Данная функция определяет что объект указанный ссылкой принадлежит классу. Если класс не указан то он относится к текущему классу. Обычно это последний оператор в конструкторе объекта. Необходимо обязательно указывать имя класса если определяемый объект может наследоваться классом-потомком.

caller выражение
caller

Возвращает контекст вызова текущей подпрограммы. В скалярном контексте true если это подпрограмма или процедура вызванная операторами eval() или require() и false - иначе. В списковом это список ($package, $filename, $line), где

  • $package - имя пакета
  • $filename - имя файла пакета
  • $line - номер строки откуда был сделан вызов.
Если указано выражение то возвращается список:
     ($package, $filename, $line, $subroutine, $hasargs, $wantargs)
Выражение определяет "глубину" вложенности просмотра стека вызовов.
  • $subroutine - имя подпрограммы
  • $hasargs - имеющиеся аргументы
  • $wantargs - необходимые аргументы
Применение данной функции в DB пакете возвращает более детальную информацию. К списку аргументов добавляется список @DB::args.

chdir выражение

Перейти в директорию указанную выражением. Если выражение отсутствует то перейти в "домашнюю" директорию. Возвращает true в случае успеха и false - неудачи.

chmod список

Изменить права доступа к файлам указанным в списке. Первый элемент в списке - числовое ,обычно восьмеричное значение прав. Возвращает количество файлов которым были изменены права.

Пример:

     chmod 0666 'f1', 'f2', 'f3';

chomp переменная
chomp список
chomp

Удаляет в конце строки символ указанный переменной $/. Обычно это 'LF'. Возвращает количество удаленных символов. Если переменная не указана то используется переменная $_. Если указан список то обрабатывается каждая строка списка и возвращается общее количество удаленных символов.

chop переменная
chop список
chop

Полностью аналогично функции chomp но всегда удаляет последний символ строки.

chown список

Изменить "владельца" и "группу" файлов списка. Первый элемент - номер нового владельца, второй номер новой группы а далее список файлов. В большинстве Unix-систем вы не сможете сменить владельца если вы не суперпользователь, но можете изменить группу если это одна из ваших "вторичных" групп.

chr число

Возвращает символ с указанным кодом кодировки.

chroot директория

Сделать "корневой" указанную директорию. "Корневая" - значит внутри программы на нее можно ссылаться как '/'.

close файл

Закрыть открытый файл или поток. Можно не использовать, если один и тот же файл открывается повторно, т.к. он будет автоматически закрываться новым вызовом open().

closedir директория

Закрыть директорию, открытую функцией opendir().

connect сокет, имя

Связаться с удаленным сокетом. Данная функция подобна системному вызову connect(). Возвращает true в случае успеха и false при ошибке.

cos выражение

Косинус выражения в радианах.

crypt текст, salt

Шифрация текста. Аналогично системному crypt().

dbmclose хеш

Закрывает связь между хеш и базой данных.

dbmopen хеш, база, режим

Ассоциировать указанный хеш и базу в определенном режиме. Дело в том, что в Perl реализован очень удобный механизм работы с базами данных типа dbm, ndbm, sbdm, gdbm и Berkeley DB. Для этого нужно связать (открыть) базу под именем хеша. Вся работа с записями базы выполняется так, будто это обычный хеш (ассоциативный массив). Более подробно смотрите описание функции AnyDBM().

define выражение

Возвращает true, если значение определено (существует) и false, если нет. Многие операции завершаются неопределенным значением, например чтение после конца файла, использование неопределенных переменных, системные ошибки и т.д. Данная функция позволяет различать нулевое и неопределенные значения, определенность или неопределенность функций или ссылок. При использовании определенности ключа в хеше она возвращает определен данный ключ или нет, но не существует он или нет.

delete выражение

Удалить значение из хеша. Возвращает удаляемое значение или неопределенность, если ничего не удаляется. Удаление из массива окружения $ENV{} - изменяет окружение. Удаление из хеша связанного с базой данных - удаляет запись в базе данных.

die список

Если программа не была запущена из eval(), данная функция выводит список в поток STDERR и завершает работу программы с кодом из переменной $!. Если $! содержит 0, то с кодом ($? >> 8). Если и это 0, то с кодом 255. При вызове из eval() сообщение об ошибке заносится в переменную $@, и eval() завершается с неопределенным значением. Это позволяет отрабатывать ошибочные ситуации, не завершая головной модуль. Если строка из списка не завершается символом '\n', то дополнительно печатается номер строки скрипта, откуда вызвана функция и номер входной строки, если таковой имеется.

do BLOCK

Это не совсем функция. Здесь возвращается значение последнего оператора блока. Когда используется циклический модификатор BLOCK исполняется перед проверкой условия цикла в отличии от обычных циклов.

do подпрограмма

Устаревший метод вызова подпрограмм.

do выражение

Значение выражения воспринимается как имя файла Perl скрипта. Изначально это применялось для включения подпрограмм библиотеки. Сейчас правильней использовать вызовы use() и require(), которые обеспечивают контроль ошибок и завершения.

dump метка

Выполнение "дампа" текущей памяти. Применялось для возможности использовать программу undump, чтобы включить текущий исполняемый код в программу после инициализации всех переменных. Выполнение этой новой программы будет начинаться оператором goto метка. Если метка опущена, то запуск сначала.

Внимание! Файлы, открытые до момента дампа, не будут открытыми в момент исполнения новой программой.

each хеш

Возвращает 2-элементный массив. Первый элемент - ключ второй - значение следующего элемента хеша. Позволяет "просматривать" все значения хеша в определенном порядке. Сброс переменной цикла происходит только после прохождения всего массива.

eof файл
eof()
eof

Возвращает 1, если выполняется чтение после конца или чтение из не открытого файла. Аргументом должно быть выражение, возвращающее существующий указатель файла. Данную функцию нельзя использовать для чтения файлов, открытых как терминалы. Если аргумент не указан, то используется последний читаемый файл. Использование в форме eof() целесообразно применять в циклах while(<>) для определения конца только последнего файла из списка. Применяйте eof(ARGV) или eof для определения конца каждого файла из списка.

eval выражение
eval блок

Выражение сканируется и выполняется как обычная Perl программа. Это делается в контексте текущей программы, поэтому можно использовать уже определенные переменные и подпрограммы. Возвращается результат последнего оператора в блоке или значение оператора return. Если обнаружится синтаксическая ошибка или выполнится оператор die, то возвращается неопределенное значение, а переменная $@ содержит сообщение об ошибке. Если ошибки не было, то $@ содержит нулевую строку. При отсутствии аргумента берется значение переменной $_.

exec список

Выполняется системная команда из списка, и выполнение программы завершается. Если вам необходимо вернуться, то лучше применяйте функцию system(). Если в списке количество аргументов больше 1 или список - это массив с количеством элементов больше 1, то выполняется системный вызов execvp() с аргументами из списка. Если один скалярный аргумент, то он сканируется на обработку метасимволов, и если они присутствуют, то полученные аргументы передаются интерпретатору /bin/sh -c для дальнейшей обработки. Если метасимволов нет, то аргумент расщепляется на слова и передается системному вызову execvp(), что более эффективно.

Внимание! exec() и system(0) не сбрасывают буфер ввода/вывода, поэтому необходимо установить переменную $| для предотвращения потери выходной информации.

exists выражение

Возвращает true, если существует указанный ключ хеша, даже если не определено его значение.

exit выражение

Выполнение программы завершается с кодом выражения.

exp выражение

Возвращает e (основание натурального логарифма) в степени выражения.

fcntl файл, функция, скаляр

Выполняет системный вызов fcntl(). Для использования обязательно выполнить use Fcntl;

fileno файл

Возвращает описатель файла для данного указателя файла.

flock файл, операция

Системный вызов flock()

fock

Системный вызов fock(). Возвращает pid потомка для родителя и 0 - для потомка в случае успеха, иначе - неопределенное значение.

format

Декларативная функция Perl. Определяет формат вывода для оператора write. Подробно смотрите главу Форматы.

formline формат, список

Внутренняя функция, используемая в format. Форматирует вывод параметров из списка. Результат помещается в переменную $^A Функция write просто выводит значение этой переменной, но ее так же можно читать, а затем обнулять. Обычно format выполняет один вызов formline для одной строки формы, но formline не разделяет строки формата. Это значит что символы '~' и '~~' рассматривают весь формат как одну строку, поэтому необходимо использовать многострочные формы для описания одной записи формата.

getc файл
getc

Читает и возвращает символ из указанного файла. Если файл не указан, то читается STDIN. После конца файла возвращает пустую строку.

getlogin

Возвращает текущий login из файла /etc/utmp Не применяйте для идентификации пользователя, он не так сильно "закрыт" как getpwuid().

getpeername сокет

Возвращает упакованный адрес удаленного сокета.

getpgrp PID

Возвращает группу процесса с указанным PID. Если аргумент отсутствует, возвращает группу текущего процесса.

getppid

Возвращает PID родительского процесса.

getpriority WHICH, WHO

Возвращает текущий приоритет процесса, группы процессов или пользователя.

Группа системных вызовов:

  • getpwnam NAME
  • getgrnam NAME
  • gethostbyname NAME
  • getnamebyname NAME
  • getprotobyname NAME
  • getpwuid UID
  • getgrid GID
  • getservbyname NAME, PROTO
  • gethostbyaddr ADDR, ADDRTYPE
  • getnetbyaddr ADDR, ADDRTYPE
  • getprotobynumber NUMBER
  • getservbyport PORT, PROTO
  • getpwent
  • gethostent
  • getnetent
  • getprotoent
  • getservent
  • setpwent
  • setgrent
  • sethostent STAYOPEN
  • setnetent STAYOPEN
  • setprotoent STAYOPEN
  • setservent STAYOPEN
  • endpwent
  • endgrent
  • endhostent
  • endnetent
  • endprotoent
  • endservent
Все эти функции аналогичны одноименным системным вызовам. В списковом контексте возвращают следующие списки:
($name, $passwd, $uid, $gid, $quota, $comment, $gcos, $dir, $shell) = getpw*
($name, $passwd, $gid, $members) = getgr*
($name, $aliases, $addrtype, $length, @addrs) = gethost*
($name, $aliases, $addrtype, $net) = getnet*
($name, $aliases, $proto) = getproto*
($name, $aliases, $port, $proto) = getserv*
В скалярном контексте возвращается имя или что-то другое, в зависимости от типа функции. Элемент $members в вызове getgr содержит разделенные пробелом имена членов группы. @addrs содержит IP адреса компьютеров в сети Интернет в упакованном виде. Для распаковки применяйте: ($a, $b, $c, $d) = unpack('C4',$addr[0]);

getsockname сокет

Возвращает упакованный адрес сокета локальной машины.

getsockopt сокет, уровень, опция

Возвращает опцию сокета.

glob выражение

Возвращает список файлов, удовлетворяющих выражению с '*', как в команде ls.

gmtime выражение

Переводит местное время, полученное функцией time(), во время по Гринвичу. Обычно используется в виде:

     ($sec,$min,$hour,$mday,$mon,$year,$wday,$yday,$isdst)=gmtime(time);

goto метка
goto выражение
goto &подпрограмма

Безусловный переход на метку. Нельзя делать переход на метку в структуру, которая должна быть инициирована, например, подпрограмму или цикл foreach и т.д. Вторая форма применяется для динамического определения перехода.

Например:

     goto ('метка1', 'метка2', 'метка3')[$i];
Здесь при $i = 0 будет переход на 'метка1', $i = 1 на 'метка2' и т.д. Третья форма (goto &подпрограмма) довольно "хитрый" метод подмены имени вызываемой подпрограммы именем текущей. Это используется в методе автозагрузки, когда нужно запустить другую процедуру, но под именем текущей, как будто та была вызвана раньше.

grep блок, список
grep выражение, список

Выполнят блок или выражение для каждого элемента списка. Переменная $_ содержит текущий элемент. Возвращает список элементов, с которыми выражение дало результат true. В скалярном контексте возвращает количество результатов true.

hex выражение

Воспринимает выражение как строку шестнадцатеричных цифр и возвращает десятичное значение.

import

В Perl нет встроенной функции import, но есть метод, с помощью которого модули могут экспортировать область имен другим модулям. Подробно смотрите функцию use().

index строка, подстрока, позиция
index строка, подстрока

Возвращает позицию первого вхождения подстроки в строке, начиная с указанной позиции. Если позиция отсутствует, то сравнение начинается с начала строки. Отсчет позиции ведется с 0, если только не изменено значение встроенной переменной $[. Если подстрока не найдена, то результат меньше первой позиции на 1. Обычно это -1.

int выражение

Возвращает целую часть выражения.

ioctl FILEHANDLE, FUNCTION, SCALAR

Выполняет системный вызов ioctl(). В начале программы необходимо указать: require "ioctl.ph";

join выражение, список

Соединяет строки списка или массива в одну строку с кодом разделителя, равному выражению.

keys хеш

Возвращает массив всех ключей хеша. В скалярном контексте - количество ключей. Порядок следования ключей аналогичен порядку в each функции.

kill список

Послать сигнал (первый элемент) указанным в списке процессам. Возвращает количество процессов которые сигнал приняли.

last метка
last

Функция аналогичная break в С. Прерывает цикл и переходит на указанную метку. Если метки нет на ближайший внешний цикл. Блок continue не выполняется.

lc выражение

Преобразовать строку в буквы нижнего регистра.

lcfirst выражение

Заменить первую букву строки на малую.

length выражение

Возвращает длину строки выражения.

link OLDFILE, NEWFILE

Создать файл NEWFILE связанный с файлом OLDFILE.

listen SOCKET, QUEUESIZE

Выполнить системный listen().

local список

Объявляет перечисленные переменные как локальные в текущем блоке или подпрограмме. Если указано два и более имени, их необходимо заключить в круглые скобки. Предпочтительней использовать функцию my().

localtime выражение

Преобразовать 9-элементный массив, возвращаемый функцией time, относительно местного времени. Употребляется как:

     ($sec,$min,$hour,$mday,$mon,$year,$wday,$yday,$isdst)=localtime(time);

log выражение

Возвращает натуральный логарифм выражения.

lstat файл
lstat выражение

То же что и системный вызов stat(), но касательно ссылки на файл, а не самого файла.

m//

Оператор совпадения. Смотри главу Операторы

map блок, список
map выражение, список

Выполняет блок или выражение для каждого элемента списка. Возвращает список результатов.

mkdir директория, права

Создать директорию с указанными правами доступа. Возвращает 1 при успехе, и 0 при неудаче.

msgctl ID, CMD, ARG

Системный вызов msgctl() System V

msgget KEY, FLAGS

Системный вызов msgget() System V

msgsnd ID, MSG, FLAGS

Системный вызов msgsnd() System V

msgrcv ID, VAR, SIZE, TYPE, FLAGS

Системный вызов msgrcv() System V

my список

Объявляет локальными переменные в списке. Если два или более имени, их необходимо заключить в круглые скобки.

next метка
next

Аналогичен continue в С. Переход к следующей итерации в цикле. Если в цикле присутствует блок continue, он так же выполняется. Если метка отсутствует - переход на ближайший внутренний цикл.

no Module список.

Исключить использование указанных модулей.

oct выражение

Возвращает десятичное число, представленное восьмеричными цифрами.

open файл, выражение
open файл

Открыть файл с указанным именем. Аргумент "файл" - это фактически указатель на блок описания файла. Если имя (выражение) файла отсутствует, то имя считается таким же как и указатель файла. Если перед именем стоит символ '<' то файл открывается только на чтение (значение по умолчанию). Если '>' - на запись. Если '>>' - на добавление записей. '+>' или '+<' - файл открыт на чтение и запись одновременно. Если имя файла начинается с символа '|', то имя считается системной командой, на вход которой выводятся данные (поток). Имя '-' - стандартный вход (STDIN), '>-' - стандартный вывод (STDOUT). Функция возвращает true при успехе и false - неудаче.

Если имя (выражение) начинается с символов ">&", то остаток имени считается именем указателя файла, который открывается повторно. Символ '&' может стоять после '<', '>>', '+>', '+>>' и '+<'. Режим повторного открытия должен соответствовать первому. Выражение вида "<&=N" где N -число, эквивалентно системному вызову fdopen(). Если имя "|-" или "-|", то происходит "расщепление" (fork) процесса на потомка и родителя. При этом возвращается номер процесса потомка (PID) внутри родительского процесса и 0 - внутри потомка. При этом запись/чтение в файл родительским процессом воспринимается как чтение/запись потомком. Для потомка это стандартный ввод/вывод. Родительский процесс ждет завершения потомка после закрытия потока и получает код завершения в переменной $?. Имя файла не должно содержать пробелов как в начале, так и в конце.

opendir указатель, выражение

Открыть директорию с именем выражения для обработки функциями readdir(), telldir(), seekdir(), rewinddir() и closedir(). Возвращает true при успехе.

ord выражение

Возвращает ascii код первого символа выражения.

pack шаблон, список

Упаковывает список в двоичную структуру по шаблону. Шаблон - это строка символов, описывающая порядок и тип упакованных значений.

  • A - текстовая строка, добавляется пробелами.
  • a - текстовая строка, добавляется 0 символом.
  • b - битовая строка (возрастающая нумерация бит)
  • B - битовая строка (убывающая нумерация бит)
  • h - шестнадцатеричная строка ( младший байт - первый)
  • H - шестнадцатеричная строка (старший байт первый)
  • c - символ со знаком
  • C - символ без знака.
  • s - короткое целое (один байт) со знаком.
  • S - короткое целое без знака.
  • i - целое (два байта) со знаком.
  • I - целое без знака.
  • l - длинное целое (4 байта) со знаком.
  • L - длинное целое без знака.
  • n - короткое в "сетевом" формате.
  • N - длинное в "сетевом" формате.
  • v - короткое в "VAX" формате.
  • V - длинное в "VAX" формате.
  • f - single float.
  • F - double float.
  • p - указатель на строку ограниченную 0.
  • P - указатель на структуру с фиксированной длиной.
  • u - упаковка uuencode.
  • x - нуль-байт
  • X - резервный байт.
  • @ - заполнить нулями позицию.
За каждой буквой может стоять число означающее количество повторов. Для всех типов за исключением 'a', 'A', 'b', 'B', 'h' и 'H', упаковывается максимально возможное количество значений из списка. Символ '*' после типа означает использовать оставшиеся параметры. Тип 'a' и 'A' использует только одно значение из списка и добавляет остаток поля либо нуль-символами, либо пробелами (при распаковке по типу 'A' пробелы и нули отбрасываются, а по 'a' - нет). Типы 'b' и 'B' упаковывают строку в указанное число бит. Так же как и 'h' и 'H' в число ниблов (байт). 'P' - упаковывает указатель на структуру с указанной длиной. Числа с плавающей запятой (floats и double) записываются в стандартном для каждой машины формате и могут быть разными для разных типов машин. Заметьте, что Perl всегда использует двойную точность (double), поэтому упаковка и распаковка по типу 'f' приведет к потере точности. Шаблоны для распаковки и упаковки совершенно одинаковы.

Примеры:

     print(pack("ccc",65,66,67));      # Результат ABC
     print(pack("A4A3","ab","cdefg")); # "ab  cde"
     print(pack("a4a3","ab","cdefg")); # "ab\0\0cde"

pipe READHANDLE, WRITEHANDLE

Аналогичен системному pipe().

pop массив

Удаляет и возвращает последний элемент массива. Длина массива уменьшается на 1. Результат не определен, если массив пустой. Если имя массива отсутствует, то извлекает из @ARGV для головной программы и @_ для подпрограммы.

pos скаляр

Возвращает смещение от последнего m//g поиска.

print файл список
print список
print

Выводит строку или список строк в файл. Возвращает true при успехе. Аргумент файл может быть скалярной переменной, содержащей имя указателя файла, если он отсутствует, то осуществляется вывод в стандартный выходной поток STDOUT (если не было вызова select()). Если список отсутствует, то выводится значение переменной $_. Для вывода по умолчанию в другой файл необходимо использовать функцию select(). Так как print работает в списковом контексте, то все элементы списка так же вычисляются в списковом контексте, т.е. функции будут возвращать списковые значения. Аргументы можно заключать в круглые скобки. Если указатель файла - элемент массива, то элемент нужно заключить в фигурные скобки для вычисления блока.

printf файл список
printf список

Аналогичен вызову "print файл sprintf(список)". Первый элемент списка должен быть форматом printf(), как и в С.

push массив, список

Добавить элементы массива значениями из списка. Длина массива увеличивается на количество элементов списка.

q/строка/
qq/строка/
qx/строка/
qw/строка/

Обычные операторы строк. Смотри главу Операторы.

quotemeta выражение

Вычисляет выражение, в котором метасимволы рассматриваются как обычные символы.

rand выражение
rand

Возвращает случайное число в диапазоне между 0 и выражением. Если выражение отсутствует - между 0 и 1. Данная псевдослучайная последовательность сбрасывается функцией srand().

read файл, скаляр, длина, смещение
read файл, скаляр, длина

Прочитать указанное число байт из файла в скалярную переменную. Возвращает количество прочитанных байт или неопределенность при ошибке. Длина скаляра станет равной количеству считанных байт. Смещение указывают, если данные нужно поместить не с самого начала строки.

readdir директория

Возвращает имя следующего файла в директории открытой командой opendir(). В скалярном контексте возвращает все оставшиеся имена файлов. Если файлов больше нет, то возвращает неопределенность в скалярном контексте и пустую строку в списковом.

readlink выражение

Возвращает значение символической ссылки. При ошибке возвращает неопределенное значение.

recv SOCKIT, SCALAR, LEN, FLAGS

Получить сообщение из сокета. Аналогичен системному recvfrom().

redo метка
redo

Перейти к началу блока, минуя вычисление условия и блока continue. Если метка отсутствует, то переход к ближайшему внешнему блоку.

ref выражение

Возвращает true, если выражение это ссылка, иначе - false. Возвращаемое значение зависит от типа ссылки. Существуют следующие типы ссылок:

     REF, SCALAR, ARRAY, HASH, CODE, GLOB
Если аргумент - ссылка на класс, то возвращается имя класса. Функция ref() аналогична функции typeof().

rename старое_имя, новое_имя_файла

Переименовать файл. Возвращает 1 в случае успеха, иначе - 0.

105require выражение
require

Если выражение - число, требует что бы текущая версия Perl была не ниже указанной. Если строка - считывает библиотечный файл с указанным именем, если он еще не прочитан. Последний оператор библиотечного файла должен возвращать true. Обычно это строка вида 1; Если расширение имени файла отсутствует, то по умолчанию принимается ".pm" В данной функции можно указывать путь расположения файла, а если библиотека расположена в стандартной системной области Perl, то вместо require предпочтительней использовать use().

reset выражение
reset

Обычно используется в блоках continue циклов для очистки переменных и поиска для повторного применения. Выражение воспринимается как список символов. Для указания диапазона можно применять символ минус '-'. Все переменные и массивы, начинающиеся с этих символов, обнуляются. Если выражение отсутствует, то обнуляется поиск ?шаблон? для повторного поиска. Сбрасываются только переменные текущего модуля.

Пример:

     reset 'a';     # очистить все переменные начинающиеся
                    # буквой 'a'
     reset 'a-z'    # все переменные с малых букв.
Выражение вида: 'A-Z' употреблять не рекомендуется, т.к. обнуляются важные массивы @ARGV и @ENV.

return список

Выход из подпрограммы с указанным кодом. Если данная функция отсутствует, то выход из подпрограммы осуществляется с кодом последнего выполненного оператора.

reverse список

В списковом контексте возвращает список с элементами в обратном порядке указанному списку. В скалярном контексте возвращает строку с переставленными символами первого элемента списка.

rewindir директория

Устанавливает указатель файлов открытой директории в начало для последующего чтения функцией readdir().

rindex строка, подстрока, позиция
rindex строка, подстрока

Подобна функции index , но возвращает позицию последнего вхождения подстроки в строку. Если указана позиция, то просмотр выполняется до нее.

rmdir директория

Удалить указанную директорию, если в ней нет никаких файлов. Возвращает 1 при успехе и 0 - при неудаче. При этом переменная $! содержит код (errno).

s///

Оператор подстановки. Смотри главу Операторы.

scalar выражение

Вычисляет выражение в скалярном контексте и возвращает результат. В Perl нет специальной функции для принудительного вычисления в списковом контексте, т.к. для достаточно заключить его в круглые скобки.

seek файл, позиция, отсчет

Установить указатель на произвольную позицию в файле. Если отсчет равен 0 - позиционировать от начала файла, если 1 - от текущего положения, 2 - от конца файла. Возвращает 1 при успехе и 0 - неудаче.

seekdir директория, позиция

Установить указатель файла в открытой директории для последующего чтения функцией readdir(). Текущая позиция может быть получена функцией telldir().

select файл
select

Возвращает текущий указатель файла- по умолчанию или делает текущим указанный. Таким образом, если в функциях print или write не указан файл вывода, то это осуществляется в файл, указанный select. Переменные, связанные с выводом, так же действуют на вывод в этот файл.

select RBITS, WBITS, EBITS, TIMEOUT

Выполняет системный select()

semctl ID, SEMNUM, CMD, ARG

Системный вызов semctl() для SYSTEM V.

semget KEY, NSEMS, FLAGS

Системный вызов semget() для SYSTEM V.

semop KEY, OPSTRING

Системный вызов semop() для SYSTEM V.

send SOCKET, MSG, FLAGS, TO
send SOCKET, MSG, FLAGS

Послать сообщение через сокет. Аналогично системному send().

setpgrp PID, PGRP

Установить номер группы PGRP процессу с номером PID, 0 - для текущего процесса.

setpriority WHICH, WHO, PRIORITY

Установить приоритет PRIORITY процессу пользователя WHO и группе WHICH.

setsockopt SOCKET, LEVEL, OPTNAME, OPTVAL

Установить параметры сокета. Возвращает неопределенность при ошибке.

shift массив
shift

Удаляет первый элемент массива и возвращает его значение. Если массив пустой, то результат - неопределенность. Если аргумент опущен - обрабатывается массив @ARGV в головной программе или @_ в подпрограмме.

shmctl ID, CMD, ARG

Системный вызов shmctl() System V

shmget KEY, SIZE, FLAGS

Системный вызов shmget() System V

shmread ID, VAR, POS, SIZE
shmread ID, STRING, POS, SIZE

Пишет или читает сегмент общедоступной памяти в System V.

shutdown SOCKET, HOW

Прекращает работу сокета методом HOW.

sin выражение

Возвращает в радианах синус выражения.

sleep выражение
sleep

Приостанавливает работу процесса на указанное число секунд или зацикливается, если аргумент отсутствует. Работа продолжается, если получен сигнал SIGALARM. Возвращает время фактической паузы.

socket SOCKET, DOMAIN, TYPE, PROTOCOL

Открывает сокет и привязывает его к указателю SOCKET.

socketpair SOCKET1, SOCKET2, DOMAIN, TYPE, PROTOCOL

Создает "безымянную" пару сокетов в указанном DOMAIN. Возвращает true при успехе и false - неудаче.

sort подпрограмма список
sort блок список
sort список

Сортирует элементы списка и возвращает полученный список. Несуществующие элементы списка отбрасываются. Если не указано имя подпрограммы или блок, то сортирует в стандартном строковом порядке. Указанная подпрограмма возвращает значения больше, меньше или равное нулю в зависимости от двух соседних элементов списка. Имя подпрограммы может быть указано переменной. Она не должна быть рекурсивной, и два сравниваемых элемента списка передаются как глобальные переменные $main::a и $main::b. Это ссылки, поэтому их изменение приводит к изменению самих элементов списка.

splice массив, смещение, длина, список
splice массив, смещение, длина
splice массив, смещение

Удаляет элементы массива, начиная со смещения и указанной длины. Заменяет их указанным списком. Возвращает удаленный список. Если длина не указана, удаляет все элементы списка, начиная со смещения.

split /шаблон/, выражение, предел
split /шаблон/, выражение
split /шаблон/
split

Разделяет строку, указанную выражением, на массив элементов и возвращает его. В скалярном контексте возвращает количество полученных элементов массива, а сам массив помещает в @_ (в списковом контексте поместить результат в @_ можно если применить ?шаблон?) Если выражение отсутствует, то обрабатывается содержимое переменной $_. Если шаблон отсутствует, то разделителем является пробел. Все, что подходит по шаблону, считается разделителем. Если указан предел, то это максимальное число разделений. Отрицательное значение предела воспринимается как неограниченно большой предел. Если пустая строка походит под шаблон разделителя, то исходное значение разделяется посимвольно. Предел удобно использовать для частичного разделения строки.

Пример:

     ($a, $b, $остаток) = split(/ /, "Один Два Три Четыре",3);
здесь $a = 'Один', $b = 'Два' и $остаток = 'Три Четыре'

Если шаблон содержит круглые скобки, то символы-разделители, указанные в них, вставляются в результирующий список как обычные элементы, причем вставляется символ, который совпал с разделителем.

Пример:

        @a = split(/([,.])/, "Один,Два.Три");
здесь @a = ("Один", "," ,"Два", ".", "Три")

sprintf формат, список

Форматирует список по указанному формату аналогично функции sprintf() языка С.

sqrt выражение

Возвращает корень квадратный выражения.

srand выражение

Задает начальное значение для генератора случайных чисел - оператора rand. Если аргумент отсутствует, то используется текущее машинное время.

stat файл
stat выражение

Возвращает 13 элементный массив параметров указанного файла или пустой список при ошибке. Применяется обычно следующим образом:

     ($dev,$ino,$mode,$nlink,$uid,$gid,$rdev,$size,$atime,$mtime,$ctime,$blksize,$blocks)
 = stat($filename);
где
  • $dev - имя устройства
  • $ino - номер i-узла
  • $mode - права доступа
  • $nlink - количество связей
  • $uid - идентификатор владельца
  • $gid - идентификатор группы
  • $rdev - тип устройства
  • $size - размер файла в байтах
  • $atime - дата последнего обращения
  • $mtime - дата последней модификации
  • $ctime - дата последнего изменения статуса
  • $blksize - размер блока на диске
  • $blocks - количество блоков в файле.
Если указан аргумент '_', то возвращается результат предыдущего вызова stat().

study скаляр
study

Включение метода частотного сравнения. Целесообразность применения зависит от количества поисков и количества констант в строке в которой ведется поиск. Функция работает следующим образом: Для указанного скаляра (если аргумент отсутствует берется значение переменной $_) строится список указателей на каждый символ строки. Затем, когда начинается поиск, первыми просматриваются символы, которые наиболее редко встречаются в английском языке. Выигрыш по времени очевиден, когда выполняется многократный поиск в одной и той же строке, и время затраченное на индексацию окупается.

substr выражение, смещение, длина
substr выражение, смещение

Возвращает подстроку выражения, начиная со смещения и заданной длины. Если смещение отрицательное, то отсчет ведется от конца строки. Если длина не указана, то берется все до конца строки.

symlink старый_файл, новый_файл

Создает новый файл, символически связанный со старым, т.е. создает ссылку на файл. Возвращает 1 при успехе и 0 - неудаче.

syscall список

Выполняет системную функцию. Первый элемент списка - это имя функции, а остальные элементы - ее аргументы. Если функция не выполнима, то возвращается фатальная ошибка. Аргументы интерпретируются следующим образом. Если аргумент число, то оно считается целым. Если не число, то аргумент считается указателем на строку. Вам необходимо обеспечить достаточную длину аргумента для подстановки значения указателя. В Perl передается максимум 14 параметров. Обычно этого достаточно.

sysread файл, скаляр, длина, смещение
sysread файл, скаляр, длина

Прочитать из файла указанное число байт в скаляр с помощью системного вызова read(). Смещение обозначает позицию в скаляре, после которой будут вставлены прочитанные байты.

system список

Делает то же самое, что и "exec список" с той лишь разницей, что вызов fork() делается первым, и родительский процесс ждет завершения потомка. Возвращает значение аналогичное функции wait(). Для получения действительного кода завершения необходимо разделить на 256.

syswrite файл, скаляр, длина, смещение
syswrite файл, скаляр, длина

Записать в файл указанное число байт скаляра с помощью системного вызова write(). Смещение указывает позицию в скаляре, откуда начинается запись.

tell файл
tell

Возвращает текущую позицию указателя в открытом файле. Если файл не указан, то последнего читаемого файла.

telldir директория

Возвращает текущую позицию указателя в открытой директории. Обычно это параметр для позиционирования указателя директории функцией seekdir().

tie переменная, класс, список

Присваивает переменную классу. Список - это аргументы new метода класса (TIESCALAR, TIEARRAY или TIEHASH). Возвращает указатель на созданный новый объект класса, который удобен для вызова других методов класса.

Внимание! Такие функции как keys() и values() могут вернуть в качестве значения огромное количество данных.

Для создания объекта ассоциативного типа необходимо определение следующих методов:

  • TIEHASH classname, LIST
  • DESTROY this
  • FETCH this, key
  • STORE this, key, value
  • DELETE this, key
  • EXISTS this, key
  • FIRSTKEY this
  • NEXTKEY this, lastkey
Обычного массива:
  • TIEHASH classname, LIST
  • DESTROY this
  • FETCH this, key
  • STORE this, key, value
  • [others TBD]
Скалярного типа:
  • TIEHASH classname, LIST
  • DESTROY this
  • FETCH this, key
  • STORE this, key, value

time

Возвращает количество секунд, начиная с 1 января 1970 г 00:00:00 UTC. Годы не разделяются на високосные.

times

Возвращает 4-х элементный массив значений:

     ($user, $system, $cuser, $csystem) = times;
где:
  • $user - пользовательское время процесса в секундах.
  • $system - системное время текущего процесса.
  • $cuser - время процесса-потомка текущего процесса.
  • $csystem - его системное время.

tr///

Оператор транслятор. Подробно смотри главу "Операторы".

truncate файл, длина
truncate выражение, длина

Усекает длину указанного файла.

uc выражение

Возвращает строку выражения, в которой малые буквы заменены на заглавные.

ucfirst выражение

Возвращает строку выражения, в которой первая буква заменена на заглавную.

umask выражение
umask

Устанавливает маску umask и возвращает старое значение. Без аргумента возвращает текущее значение.

undef выражение undef

Делает неопределенным значение выражения. Применяется только для скалярных переменных, целых массивов или подпрограмм. Всегда возвращает неопределенное значение.

unlink список

Удаляет файлы, указанные в списке. Возвращает количество удаленных файлов. Только супервизор может удалять директории с файлами, если Perl запущен с ключом -U.

unpack шаблон, выражение

Функция, обратная pack(). Распаковывает строку выражения по указанному шаблону в массив значений. В скалярном контексте возвращает значение только первого элемента. Шаблоны такие же как и в pack().

Символ '%' в шаблоне означает, что вы хотите получить вместо значения его контрольную сумму. По умолчанию - 16-битную.

untie переменная

Исключает переменную из класса указанного tie().

unshift массив, список

Противоположное shift. Помещает элементы списка в начало массива.

use модуль список
use модуль

Указывает библиотечный модуль, из которого можно вызывать подпрограммы. Список перечисляет имена подпрограмм, которые добавляются к текущей области имен. Если не указан, то все имена. Действие аналогично блоку:

     BEGIN { require модуль; import модуль список; }
Сам модуль должен располагаться в системной области Perl файлов.

utime список

Изменяет дату обращения и модификации файлов из списка. Первые два элемента списка должны указывать новое значение даты обращения и модификации. Возвращает количество измененных файлов.

values хеш

Возвращает обычный массив со всеми значениями хеша. В скалярном контексте возвращает количество значений хеша.

vec выражение, смещение, бит

Возвращает значение строки как вектор беззнаковых целых.

wait

Ожидать окончание порожденного процесса. Возвращает PID для родительского процесса или -1, если нет - процесса потомка. Код завершения записывается в переменную $?.

waitpid PID, FLAGS

Ожидать окончания процесса потомка с указанным PID. Возвращает либо PID этого процесса либо -1 если нет такого процесса. Код завершения записывается в переменную $?.

wantarray

Возвращает true, если подпрограмма вызывается в списковом контексте и false - в скалярном.

warn список

Выводит в стандартный поток ошибок STDERR сообщение аналогично die(), но не прекращает работу программы.

write файл
write выражение
write

Выводит в файл форматированные данные по оператору format. По умолчанию имя формата совпадает с именем указателя файла. Имя файла по умолчанию можно изменить функцией select(), а имя формата при этом надо присвоить переменной $~. Заголовок листа пишется автоматически. Если на листе не хватает места для вывода, то выводится "перевод формата" и специальная форма заголовка листа, затем сами записи. По умолчанию имя формата заголовка листа состоит из имени указателя файла и добавленной строки "_TOP". Динамически это можно делать, присваивая формат переменной $^. Количество оставшихся строк листа содержится в переменной $- и если присвоить ей 0, то произойдет смена листа. Подробно описание форматов смотри в главе Форматы.

y///

Оператор транслятор. Смотри главу Операторы.


Запуск интерпретатора Perl

Синтаксис:
   perl [ключи] файл аргументы
Перед стартом Perl ищет скрипт (программу) в следующем порядке:
  1. В командной строке если указан ключ '-e'
  2. Содержимое файла указанного в командной строке. В первой строке можно указывать #!/usr/bin/perl для "автоматического" запуска скрипта.
  3. Стандартный ввод/вывод, если не указан файл или аргументы, содержащие имя файла. Для передачи аргументов скрипту из стандартного потока, имя файла в командной строке обозначается символом '-'.

В методах 1 и 2 Perl сканирует строки, начиная с первой, если не указан ключ '-x', в противном случае началом программы считается строка с символами '#!' в начале и содержащая слово 'perl'. Концом программы считается строка '__END__'. В строке с '#!' можно указывать и ключи. Например '#!/bin/perl -d' для отладки программ.

После "обнаружения" скрипта Perl компилирует его целиком во внутреннее представление. Если обнаруживаются ошибки, то выполнение прекращается. Если ошибок нет, он выполняется. Если скрипт заканчивается без команд exit() или die(), то по умолчанию выполняется команда exit(0), обозначающая нормальное завершение программы.

Ключи:

  • -O цифры
    Код символа-разделителя записей. По умолчанию \0.
  • -a
    Включает режим автоматического разделения (split) переменной $_ в массив $F. Применяется с ключами -n и -p.
  • -c
    Выполняется синтаксическая проверка скрипта и выход без запуска.
  • -d
    Запуск в режиме интерактивной отладки.
  • -D число или D список
    Установить флаги отладки Perl. Например -d14 проследить как Perl исполняет вашу программу.
    1 | p | Синтаксический разбор
    2 | s | Состояние стека
    4 | l | Состояние стека имен
    8 | t | Трассировка исполнения
    16 | o | Создание оператора узла
    32 | c | Строковое/числовое преобразование
    64 | p | Вывод команды препроцессора для -P
    128 | m | Распределение памяти
    256 | f | Обработка формата
    512 | r | Синтаксический разбор регулярных выражений
    1024 | x | Дамп синтаксического дерева
    2048 | u | Проверка защиты
    4096 | L | "Утечка" памяти
    8192 | H | Дамп хеша
    16384 | X | Распределение scratchpad
    32768 | D | Очистка
  • -e команда
    Выполнение скрипта из одной строки указанного в командной строке.
  • -F шаблон
    Указывает шаблон разделения в режиме работы с ключом -a
  • -i расширение
    Применяется для резервной копии файла обрабатываемого оператором '<>'. Оригинал хранится в файле с тем же именем, что и исходный, но с указанным расширением.
    Пример:
       perl -p -i.old -e "s/рядовой/ефрейтор/" file
      Поменять все слова "рядовой" на "ефрейтор" в файле file, а оригинал записать в файле file.old
  • -I директория
    Директория includ- файлов для С препроцессора. Применяется с ключом -P по умолчанию это /usr/include и /usr/lib/perl.
  • -l число
    Автоматическая обработка символа конца строки. Работает в двух случаях.
    1. Отбрасывает последний символ читаемых строк для режимов -n и -p
    2. Присваивает указанное значение переменной $\. Таким образом к концу каждой строки выводимой оператором print добавляется этот символ.
  • -n
    Зацикливает скрипт и последовательно обрабатывает файлы указанные в командной строке. Позволяет создавать команды подобные sed или awk. Операторы BEGIN и END дают возможность делать начальные и конечные установки. Содержимое файлов не выводится.
  • -p
    То же что и -n, но печатает обрабатываемые строки файлов.
  • -P
    Предварительная обработка препроцессором языка С. Будьте внимательны и не применяйте в комментариях слова 'if', 'else' или 'define', т.к. это команды С - препроцессора.
  • -s
    Включение режима обработки ключей командной строки запуска скрипта. Все аргументы с символом '-' в начале, считаются ключом, и переменным с таким же именем присваивается значение true.
  • -S
    Использование системной переменной PATH для поиска скрипта. Данный ключ применяется в системах, невоспринимающих последовательность "#!" в начале скрипта для указания интерпретатора.
  • -T
    Режим проверки "дыр" в защите. Обычно это нужно для программ, работающих в режиме повышенной привилегии (setuid, setguid). Желательно для CGI скриптов.
  • -u
    Принудительный дамп памяти после компиляции скрипта. Этот дамп можно потом использовать для создания исполняемого файла с помощью программы undump.
  • -U
    Разрешение выполнять опасные операции. Например, стереть директорию или выполнять явно не закрытую программу.
  • -v
    Вывод номера версии Perl.
  • -w
    Вывод имен переменных, используемых только один раз, имен скаляров, используемых до их определения, имен переопределяемых подпрограмм, ссылок на неопределенные указатели файлов, попыток записи в файлы, открытых только на "чтение", употребление некорректных записей чисел, использование массивов как скаляров, рекурсия более 100 уровней.
  • -x директория
    Режим запуска скрипта, вставленного в файл, содержащий обычный текст. Началом скрипта считается строка с символами '#!' в начале и содержащая слово perl. Концом - строка с '__END__' Указанная директория становится текущей в момент исполнения. Если необходимо читать последующие строки, то это лучше делать через указатель файла DATA.


Интернет - ссылки и литература

E-mail: info@citforum.ru
Сервер Информационных Технологий содержит море(!) аналитической информации

Интернет - ссылки и литература.

Очень полезные USENET конференции:

  • comp.lang.perl.announce - Различные объявления и сообщения.
  • comp.lang.perl.misc - Место для вопросов и обсуждений.
  • comp.lang.perl.modules - Модули Perl.
  • comp.lang.perl.tk - Perl и Tcl/tk.

WWW сервера:

  • Специальный Perl-сервер
  • Книги по Unix издательства O`Reily
  • Специализированный FTP сервер
  • Список модулей

Список литературы.

При написании книги автор в основном пользовался описанием Perl "Perl Programmers Reference Guide".
Наиболее известная зарубежная литература:

  • Programming Perl (the Camel Book)
  • Learning Perl (Llama Book)

[Назад] [Содержание]


Модули (packages)

E-mail: info@citforum.ru
Сервер Информационных Технологий содержит море(!) аналитической информации

Модули (packages).

  • Таблицы имен
  • Конструкторы и деструкторы
  • Классы
  • Создание библиотеки
  • Pragma библиотеки
  • Стандартные библиотеки
  • CPAN

В Perl реализован механизм модулей. Модуль это группа подпрограмм и переменных обычно включенных в один файл. Внутри одного модуля можно определить другой модуль. Начало модуля определяется директивой:

  • packages имя_модуля;

Конец модуля это конец блока или файла. Головной модуль имеет по умолчанию имя main. На имя внутри модуля можно ссылаться, добавляя '::' после имени модуля.

Например:

    $main::var1	- переменная в головном модуле.
    ::var1		- то же самое. Имя main можно опускать.
    $модуль1::var1	- переменная в модуле 'модуль1'
    $модуль1::модуль2::var1 - Модуль2 содержится в модуле 1.

Только идентификаторы, начинающиеся с буквы или символа '_', хранятся в пространстве имен текущего модуля. Остальные хранятся в пространстве головного модуля main. Кроме этого имена STDIN, STDOUT, STDERR, ARGV, ARGVOUT, ENV, INC и SIG так же хранятся в головном модуле.

Таблицы имен.

Все имена модуля хранятся в ассоциативном массиве (хеше) с именем модуля, к которому добавлены символы "::". Таким образом имена головного модуля хранятся в %main:: , модуля 'mod1' в %mod1:: и т.д. Выражение вида *имя указывает значение элемента хеша 'имя', это удобно для определения констант.

Например:

    *pi = \3.14159;
Здесь переменная $pi - это константа пи, которую уже нельзя изменить.

Конструкторы и деструкторы.

Конструктор - это подпрограмма, которая выполняется в момент создания объекта, а деструктор - удаления объекта. Для модуля это подпрограммы с именами BEGIN и END. При определении этих подпрограмм слово sub можно опускать.

Конструктор BEGIN выполняется сразу как только возможно, т.е. как только он определен, даже не завершая дальнейший разбор программы. Можно указать несколько блоков BEGIN. Они будут выполняться один за другим в порядке определения.

Деструктор END выполняется последним как только возможно, т.е. при завершении работы интерпретатора. Можно указать несколько блоков END, при этом они будут выполняться в обратном определению порядке.

Классы.

В Perl нет специального синтаксиса для классов. Но функционально полноценными классами могут быть модули. При этом подпрограммы модуля становятся методами, а с помощью массива @ISA можно реализовать механизм наследования в классах. Более подробно классы описаны отдельно.

Создание библиотеки.

Если вы хотите создать модуль отдельным файлом и использовать как библиотеку подпрограмм, при этом вызывать подпрограммы библиотеки, не указывая имени модуля, вам необходимо оформить модуль следующим образом:

    package имя_модуля;	# Такое же как и имя этого файла без расширения '.pm'
    require Exporter;	# Обязательная строка для экспорта имен
    @ISA = qw(Exporter);	# -//-
    @EXPORT = qw(func1 func2) # Перечисляем имена функций. Внимание ! нет запятой!
    @EXPORT_OK = qw( $переменная @массив ); # Указать публичные переменные, массивы
                                и т.д. если необходимо
    {  # Начало блока модуля
    .....
    sub func1
    ........
    sub func2
    ........
    1;
    }

Данный файл с расширением ".pm" должен храниться в одной из библиотечных директорий Perl. Они перечислены в массиве @INC, одна из них обычно "/usr/local/lib/perl/".

В головной программе вы указываете:

  • use имя_модуля;
и вам становятся доступны имена подпрограмм данного модуля.

Perl библиотеки.

Стандартный набор библиотек обычно поставляется с дистрибутивом Perl, они разделяются на pragma библиотеки (работают как директивы компилятору) и стандартные библиотеки.

Pragma библиотеки.

Данные библиотеки используют как:

  • use имя;
когда хотят включить действие и
  • no имя;
когда выключить.

В стандартный набор входят следующие pragma:

diagnostics
Включить режим расширенной диагностики.

integer
Использовать целочисленную арифметику.

less
Режим минимальной загрузки компилятора.

overload
Режим переопределения операторов.

sigtrap
Режим слежения за прерываниями.

strict
Режим ограниченного использования "опасных" операторов.

subs
Режим обязательного декларирования подпрограмм.

Стандартные библиотеки.

AnyDBM_File
Возможность работы с разными типами баз данных.

AutoLoader
Загрузка в память функций только во время вызова.

AutoSplit
Разделить модуль для автозагрузки.

Benchmark
Анализ скорости исполнения программы.

Carp
Предупреждения об ошибках.

Config
Доступ к конфигурации Perl.

Cwd
Получить имя текущей рабочей директории.

DB_File
Работа с базой данных формата Berkley DB.

Devel::SelfStubber
Режим отладки автозагрузки.

DynaLoader
Динамическая загрузка библиотек C.

English
Использовать длинные имена встроенных переменных.

Env
Импортировать имена переменных окружения

Exporter
Обеспечивает экспорт/импорт для модулей.

ExtUtils::LibList
Определяет используемые библиотеки.

ExtUtils::MakeMaker
Создает файл проекта Makefile

ExtUtils::Manifest
Программы для создания и проверки файла MANIFEST

ExtUtils::Mkbootstrap
Применение файла начальной загрузки для DynaLoader.

Fcntl
Определения как и в С Fcntl.h

File::Basename
Синтаксический разбор спецификации файла.

File::CheckTree
Быстрый проход по директориям диска.

File::Find
Быстрый поиск файлов по директориям.

FileHandle
Обеспечивает объектный метод доступа к указателям файлов.

File::Path
Создание/удаление директорий.

Getopt::Long
Расширенная обработка опций.

Getopt::Std
Стандартная обработка опций.

I18N::Collate
Сравнение символов локальной кодировки.

IPC::Open2
Межпроцессорный обмен по чтению и записи.

IPC::Open3
Межпроцессорный обмен по чтению, записи, и обработки ошибок.

Net::Ping
Тест доступа к хосту.

POSIX
Стандартный интерфейс по IEEE Std 1003.1

SelfLoader
Загрузка функций только по вызову.

Socket
Определение структур и констант как и в С socket.h

Test::Harness
Стандартный тест с статистикой.

Text::Abbrev
Создание таблицы сокращений по списку.

Подробное описание каждой библиотеки записано в самом файле.

CPAN

Программисты всего мира, работающие с Perl, создали общедоступную библиотеку модулей CPAN. Она доступна через Интернет и содержит огромное количество различных по назначению модулей. К ним относятся документаторы, системные интерфейсы, интерфейсы работы с базами данных, работа в сети, с файлами, Интернет-броузеры, системы поиска, огромное количество CGI скриптов для Web серверов и многое-многое другое. Список некоторых CPAN серверов вы можете найти в приложении.


Операторы и приоритеты

E-mail: info@citforum.ru
Сервер Информационных Технологий содержит море(!) аналитической информации

Операторы и приоритеты.

  • Термы и левосторонние списковые операторы
  • Унарные операторы
  • Операторы "привязки" =~ и !=
  • Мультипликативные операторы
  • Аддитивные операторы
  • Операторы сдвига
  • Именованные унарные операторы
  • Операторы отношений
  • Операторы равенства
  • Операторы работы с битами
  • Логические операторы && (AND) и || (OR)
  • Оператор диапазона '..'
  • Условный оператор '?:'
  • Операторы присваивания
  • Оператор ',' (запятая)
  • Логические not, and, or, xor
  • Операторы ограничители строк
  • Операторы ввода-вывода
  • Слияние констант
  • Целочисленная арифметика

В Perl ассоциативность и приоритетность операторов аналогична языку С. Ниже перечислены все операторы в порядке уменьшения приоритета, в начале строки указана ассоциативность.
ассоц. | операторы
левая | термы и левосторонние списковые операторы
левая | ->
- | ++ --
правая | **
правая | ! ~ \ унарные + и -
левая | =~ !~
левая | * / % x
левая | + - .
левая | << >>
- | именованные унарные операторы
- | < > <= >= lt gt le ge
- | == != <=> eq ne cmp
левая | &
левая | | ^
левая | &&
левая | ||
- | ..
правая | ?:
правая | = += -= *= и т.д.
левая | , =>
- | правосторонние списковые операторы
левая | not
левая | and
левая | or xor

Термы и левосторонние списковые операторы.

Любой терм имеет самый высокий приоритет. К терму относятся переменные, кавычки и их операторы, арифметические и логические выражения в скобках, любые функции с параметрами в скобках. Фактически таких функций нет, так как это просто унарные и списковые операторы. Просто они ведут себя подобно функциям с параметрами в скобках. Подробно смотри главу Функции.

Если после любого спискового оператора ( print(), и т.д.) или унарного оператора (chdir(), и т.д.) следует левая круглая скобка, то операторы внутри скобок имеют наивысший приоритет. Так же как и обычные функции.

Если скобки отсутствуют, то приоритет списковых операторов или наивысший или наименьший в отношении операторов справа или слева от него.

Например:

        @i = ('a ','b ', print 'c ', 'd ');
        print "\n",@i,"\n";
Результат:
     c d
     a b 1

Здесь мы имеем списковый оператор print. Для запятых слева от него он имеет наименьший приоритет, но повышает приоритет правой запятой. Поэтому правая запятая воспринимается как параметр для print и печатается 'c d', а левая просто записывает код завершения операции в массив @i и последний print показывает это.

Оператор '->'

Так же как в С или С++ это инфиксный оператор переадресации. Если справа от него стоит [...] или {...} выражение, то правая часть может быть непосредственной или символической ссылкой на массив или хеш. В противном случае правая сторона это метод или простой скаляр, содержащий имя метода, а правая - или объект или имя класса. Подробно смотри главу Классы.

Операторы ++ (инкремент) и -- (декремент).

Эти операторы работают так же как и в С. Если оператор стоит перед переменной, то значение переменной изменяется на 1 и полученное значение используется. Если после переменной - то ее величина изменяется после применения.

Употребление инкремента к строковым переменным в Perl имеет одну особенность. Каждый символ остается в своем классе (большие, малые, цифры) и учитывается перенос предыдущего символа. Таким образом строковые переменные с цифрами работают как числовые переменные.

Пример:

     print ++($i = "09");     # Результат "10"
     print ++($i = "a9");     # "b0"
     print ++($i = "az");     # "ba"
     print ++($i = "aZ");     # "bA"

Оператор ** (возведение в степень)

Пример:

     print 4**2     # Результат 16
     print -4**2     # Результат -16 т.е. -(4**2)

Унарные операторы.

'!' | - логическое отрицание
'-' | - арифметический минус
'~' | - побитная инверсия (дополнение до 1)
'+' | - арифметический плюс
'\' | - получение ссылки на переменную (как & в С)

Операторы "привязки" =~ и != .

Эти "необычные", я бы даже сказал, оригинальные операторы имеют очень широкое применение в Perl. Можно даже назвать их "оригинальным" решением. Оператор =~ логически связывает левую часть выражения с патерном (pattern - образец, шаблон, модель) в правой. По умолчанию поиск или изменение по патерну выполняется в переменной $_ Операторы привязки позволяют делать это с любой переменной, указанной в левой части. Логическим результатом будет успех операции. Если в правой части вместо патерна присутствует выражение, то результат этого выражения воспринимается как патерн. Однако это не очень эффективно, т.к. патерн будет компилироваться во время исполнения программы, что заметно снизит быстродействие. Оператор != аналогичен =~, только результат совпадения инвертируется (логическое "нет"). Подробное применение этих операторов приводится в главе Патерны.

Мультипликативные операторы.

'*' | - арифметическое умножение
'/' | - арифметическое деление
'%' | - арифметический модуль
'x' | - оператор повторения

В скалярном контексте возвращает строку левой части, повторенную величиной, указанной в правой части. В списковом контексте, если в левой части список, то в круглых скобках - повторенный список.

Пример:

     print '*' x 5;     # Результат '*****'
     print (1,2) x 3; # Результат 121212

Аддитивные операторы.

'+' | - арифметический плюс
'-' | - арифметический минус
'.' | - конкатенация (объединение) строк

Операторы сдвига.

'<<' | - Сдвигает побитно влево значение выражения в левой части
 | на количество бит указанное в правой.
'>>' | - Сдвигает побитно вправо значение выражения в левой части
 | на количество бит указанное в правой.

Именованные унарные операторы.

Фактически это функции с одним аргументом. Круглые скобки можно опускать.

Операторы отношений.

'<' | - арифметическое меньше
'>' | - арифметическое больше
'<=' | - арифметическое меньше или равно
'>=' | - арифметическое больше или равно
'lt' | - строковое меньше
'gt' | - строковое больше
'le' | - строковое меньше или равно
'ge' | - строковое больше или равно

Операторы равенства.

'==' | результат true если левая часть равна правой (равно)
'!=' | - не равно
'<=>' | - -1 если левая часть меньше правой, 0 если равна,
 | 1 если больше.
'eq' | - строковое равно
'ne' | - строковое не равно
'cmp' | - как и '<=>' применительно к строкам

Операторы работы с битами.

'&' | - побитное AND
'|' | - побитное OR
'^' | - побитное XOR

Логические операторы && (AND) и || (OR).

'&&' | - если левое выражение возвращает false, правое не выполняется.
'||' | - если левое выражение возвращает true, правое не выполняется.

Отличие от подобных операторов в С заключается в том, что в С возвращаемое значение либо 0, либо 1, тогда как в Perl возвращается результат выражения.

Оператор диапазона '..'

Результат работы данного оператора зависит от контекста. В списковом контексте результат есть список с элементами, первый элемент которого это левое выражение и последнее - правое. Значение каждого элемента внутри списка увеличивается на 1. Данный оператор удобен для небольших циклов, т.к. память отводится для всего списка целиком. Поэтому будьте внимательны и не задавайте слишком большой диапазон.

Пример:

     for $i (1..4)
        { print "$i ";
        }
Результат: 1 2 3 4

В скалярном контексте результат - логическое значение. Каждая '..' операция устанавливает свое собственное состояние. Это false до тех пор пока левый операнд false. Как только левый операнд стал true результат - true до тех пока правый true, после чего результат опять - false. Если вы не хотите проверять правый операнд, то используйте оператор '...'.

Правый операнд не вычисляется пока результат false и левый операнд не вычисляется пока результат true. Приоритетность оператора '..' немного ниже чем '&&' и '||'. Возвращаемое значение если flase - нулевая строка, если true - порядковый номер начиная с 1. Порядковый номер обнуляется для каждого нового диапазона. Последний порядковый номер добавляется строкой "E0" которая не изменяет его значение, но позволяет фиксировать последнее значение.

Пример:

     @алфавит = ('a'..'z'); # Массив малых букв латинского алфавита
     @цифры = (0..9);     # Массив цифр

Условный оператор '?:'

Этот оператор работает так же как и в С. Если выражение перед '?' истинно, то выполняется аргумент перед ':' - иначе после ':'.

Пример:

     $i = 1;
     $i > 1 ? print "больше" : print "меньше";
Результат: меньше

Операторы присваивания.

'='- обычный оператор "присвоить" правое значение переменной слева
Вся эта группа операторов подобна операторам С, т.е.

     $i += 2;
эквивалентно
     $i = $i + 2;

Остальные операторы этой группы работают аналогично. Допустимы следующие операторы:
**=
+=, -=, .=
*=, /=, %=, x=
&=, |=, ^=
<<=, >>=
&&=, ||=

Приоритет всей этой группы операторов равен приоритету '='.

Оператор ',' (запятая)

В скалярном контексте выполняется левый аргумент, результат игнорируется, затем правый и его результат есть результат действия оператора. В списковом контексте это разделитель элементов списка, который включает указанные элементы в список.

Операторы not, and, or, xor

Оператор логическое not (отрицание).
Унарный not возвращает противоположное значение, полученное выражением справа. Он эквивалентен '!', но имеет очень низкий приоритет.

Оператор логическое and (И).
Выполняет логическую конъюнкцию двух выражений. Эквивалентен '&&', но имеет очень низкий приоритет и "краткость" действия, т. е. если левое выражение равно false - левое не выполняется.

Логическое or (ИЛИ).
Выполняет логическую дизъюнкцию двух выражений. Эквивалентен '||', но имеет очень низкий приоритет и "краткость" действия, т. е. если левое выражение равно true - левое не выполняется.

Логическое xor (исключающее ИЛИ).
Выполняет логическое исключающие или. Всегда выполняются оба правое и левое выражение.

В Perl отсутствуют операторы языка С такие как:
унарное & | - получить адрес. Для этого применяется '\'.
унарный * | - переадресация.
(TYPE) | - совмещение типов.

Операторы ограничители строк.

Обычно ограничителями строк мы считаем литералы, но в Perl это операторы выполняющие разного рода интерполяцию и поиск по шаблону. Вы можете сами задавать удобные для вас ограничители. В следующей таблице приведен полный перечень вариантов. Фигурные скобки '{}' обозначают любой символ, используемый для ограничителя. В случае использования скобок (круглых '()', квадратных '[]', фигурных '{}', угловых '<>') в начале ставится открывающаяся скобка, а в конце закрывающая.
По умолчанию | Полное | Функция | Интерполяция
'' | q{} | Literal | нет
"" | qq{} | Литерал | да
`` | qx{} | Команда | да
 | qw{} | Список слов | нет
// | m{} | Шаблон | да
 | s{}{} | Подстановка | да
 | tr{}{} | Трансляция | нет

В строках допускающих интерполяцию имена переменных, начинающиеся с символов '$' или '@' - интерполируются, т.е. в строку вставляется значение строки или массива. Данные последовательности символов имеют специальное значение:
\t | символ табуляции
\n | символ новой строки
\r | возврат
\f | перевод формата
\v | вертикальная табуляция
\b | backspace (забой)
\a | звонок
\e | escape
\034 | восьмеричный символ
\x1a | шестнадцатеричный символ
\c[ | символ управления
\l | нижний регистр следующего символа
\u | верхний регистр следующего символа
\L | нижний регистр для всех символов до \E
\U | верхний регистр для всех символов до \E
\E | ограничитель смены регистра
\Q | отмена действия метасимволов до \E

Шаблоны интерполируются как регулярные выражения. Это выполняется вторым проходом после интерполяции переменных, поэтому в шаблоны можно вставлять переменные. Для отмены интерполяции используйте '\Q'. Если вы применяете вложенные ограничители, то внутренние ограничители работать не будут.

?PATERN?

Действие этого оператора аналогично /шаблон/, но выполняется до первого совпадения. Это удобно для поиска наличия какой-нибудь строки в одном или множестве файлов. Это не очень удачный оператор, поэтому в следующих версиях Perl его возможно не будет.

m/PATERN/gimosx
/PATERN/gimosx

Поиск в строке по патерну (шаблону). В скалярном контексте возвращает логическое значение true (1) или false (''). Если строка не указана с помощью операторов '=~' или '!~', поиск ведется в строке $_ Опции:
g | - Глобальный поиск. Поиск всех вхождений.
i | - Сравнение не зависит от регистра (верхний или нижний)
m | - Строка многострочная.
o | - однопроходная компиляция
s | - однострочная строка
x | - используются расширенные регулярные выражения.

Если '/' - ограничитель, то начальное 'm' можно опустить. С помощью него в качестве ограничителя может быть любой символ кроме пробела.

PATTERN может содержать переменные, которые будут интерполироваться (перекомпилироваться) каждый раз в момент вычисления. Переменные $) и $| не интерполируются. Если вы хотите, что бы такой шаблон интерполировался один раз - добавьте /o. Это необходимо делать в циклах поиска для увеличения быстродействия, однако, если вы измените значение переменной, Perl этого даже не заметит.

Если PATERN - нулевая строка, то используется последнее регулярное выражение.

В скалярном контексте возвращается список элементы которого - результаты выполнения выражений в скобках патерна ($1, $2, $3...). Обратите внимание что первый элемент $1.

Пример:

     $a = "/usr/local/perl/perl.bin"; # Анализируемая строка
Цель: Создать массив @dirs с именами директорий.
Решение: Самый простой способ воспользоваться split('\/') но в качестве примера используем скобки.
     @dirs =~ m[/(\w*)/(\w*)/(\w*)/(\w*)]
Здесь 'm[' - использовать квадратные скобки как ограничители. (\w*)- шаблон алфавитно-цифровой последовательности.
В результате @dirs равен ('usr', 'local', 'perl')

q/строка/
'строка'

Строка литералов. Не интерполируется. Внутри строки разрешается использовать \' или \\ для обозначения символов ' и \ .

Пример:

     print q#Привет.#;     # Результат Привет.
     print 'O\'K';          # O'K

qq/строка/
"строка"

Интерполируемая строка.

Пример:

     $var = 13;
     print "\$var = $var";
Результат: $var = 13

qx/строка/
`строка`

Сначала строка интерполируется, а потом выполняется как системная команда.

Пример:

     print `date`;
Результат: Thu Nov 14 13:36:49 MSK 1996

qw/строка/

Возвращает список, элементы которого - слова строки, разделенные пробелами.

Пример:

     print qw/Построимся и спасемся!/; # ('Построимся','и','спасемся!')
Результат:
     Построимсяиспасемся!
Часто применяется как:
     use POSIX qw( setlocale localeconv )
     @EXPORT = qw( proc1 var );

s/шаблон/подстрока/egimosx

Поиск по шаблону и в случае успеха замена подстрокой. Возвращает количество произведенных подстановок, иначе false (0). Если строка в которой ведется поиск не указана (операторы =~ или != ), то используется переменная $_ . Если в качестве разделителя '/' использовать одинарную кавычку ('), то интерполяции не будет, иначе можно применять переменные в шаблоне или подстроке.

Опции:
e | - Рассматривать правую часть как выражение.
g | - Глобальный поиск.
i | - Без различия регистра букв
m | - многострочная переменная
o | - компилировать шаблон один раз
s | - однострочная переменная
x | - расширенное регулярное выражение

Разделитель '/' можно заменить на любой алфавитно-цифровой символ кроме пробела.

Пример:

     $var = "12345"; # исходная строка
     $var =~ s/1/0/; # Заменить '1' на '0'. Результат 02345
     $var =~ s(5)(.); # Заменить '5' на '.' Результат 0234.

Здесь в качестве разделителя применены скобки, поэтому подстрока взята в две скобки.

     $var =~ s/\d*/каламбур/; Заменить все цифры. Результат 'каламбур.'
     $var =~ s/а/о/g; # Заменить все 'а' на 'о'. Результат 'коломбур.'
     $var = "12 34"; # Новое значение
     $var =~ s/(\d\d) (\d\d)/$2 $1/; # Поменять местами числа. Результат '34 12'.

tr/таблица1/таблица2/cds
y/таблица1/таблица2/cds

Замена всех символов из "таблица1" на соответствующий символ из "таблица2". Результат - количество замен или стираний. Без оператора =~ или != операция выполняется со строкой $_. Для совместимости с программой sed вместо tr можно писать 'y'.

Опции:
c | - дополнение "таблица1"
d | - стереть найденные, но не замененные символы.
s | - "сжать" повторяющиеся замененные символы.

Если указана опция /d таблица2 всегда интерпретируется как положено. Другими словами, если таблица2 короче, чем таблица1, то символ из таблицы1 интерпретируется всегда. Если таблица2 - null, то все символы строки остаются неизменными. Это удобно для подсчета количества символов в строке определенного класса или для сжатия повторяющихся символов, например, пробелов.

Пример:

     $s = "hello";     # Исходная строка
     $s =~ tr/a-z/A-Z/;     # Заменить малые буквы на большие. Результат
                    # 'HELLO'
     $s = 'Hel....lo';
     $s =~ tr/a-zA-z/_/c;     # Заменить все не буквы на '_'
                    # Результат 'Hel____lo'
     $s =~ tr/_/ /s;          # Заменить '_' на ' ' и сжать.
                    # Результат 'Hel lo'
     $s =~ tr/a-zA-Z /a-zA-Z/d; # Удалить все не буквы. Результат 'Hello'

Если один и тот же символ несколько раз указан в таблице1, то применяется только первая замена.

Операторы ввода-вывода.

В Perl существует несколько операторов ввода-вывода. Первый это скобки из символа '`' - акцента. Строка в этих скобках воспринимается как системная команда и результат ее действия возвращается как "псевдо" литерал. В скалярном контексте это строка содержащая весь результат, а в списковом - список, элементы которого - строки результата. Статус выполненной команды хранится в переменной $? .

Следующая команда ввода вывода выглядит как '<файл>'. Вычисление <файл> приводит к чтению строки из файла. Обратите внимание, что 'файл' здесь не имя файла, а указатель файла, который создается функцией open(). В скалярном контексте читается одна строка вместе с символом '\n' - перевода строки, а в списковом весь файл читается в список, элементы которого суть строки файла. В случае обнаружения конца файла результат оператора не определен и воспринимается как false. Если не указана переменная результата, то по умолчанию это $_. Указатель файла по умолчанию STDIN - стандартный ввод.

Пример:

     while(<>) { print; }; # Прочитать и вывести весь файл STDIN

У оператора '<>' есть одна отличительная особенность. Если в командной строке нет никаких аргументов, то читается стандартный ввод, если есть аргументы, то они считаются именами файлов, которые последовательно читаются.

Если в угловых скобках записана переменная, то содержимое этой переменной считается именем указателя файла или ссылкой на указатель файла. Если такого указателя не существует, то содержимое переменной воспринимается как шаблон имен файлов и результат - имена файлов на диске, подходящих по шаблону.

Пример:

     while(<*.pl>) { print;}; # То же что и ls *.pl
     @files = <*>;     # Массив @files содержит имена файлов в директории
но лучше сделать: @files = glob("*"); т.к. внутри скобок можно использовать переменные.

Слияние констант.

Как и С Perl выполняет возможные вычисления в период компиляции. Так подстановка символов после '\' , операция конкатенации строк, арифметические выражения, содержащие только одни константы, все это делается в момент компиляции, что существенно увеличивает скорость выполнения программы.

Целочисленная арифметика.

По умолчанию Perl выполняет арифметику с плавающей запятой, но если вы укажете:

     use integer;
то компилятор будет использовать целочисленную арифметику до конца текущего блока, хотя вложенный блок может это и отменить в своих пределах с помощью:
     no integer;


От простого к сложному

Прежде чем приступить к последовательному ознакомлению с не знакомым для вас языком, должен оговориться и сказать, что все примеры да и сам язык описанию которого посвящена эта книга это Perl версии 5.003 для операционной системы FreeBSD версии 2.01. Существуют реализации этого языка для операционных систем OS/2 , MS-DOS и Windows NT но они немного отстают по возможностям от оригинала, рожденного в недрах Unix.

Пример 1.
Введите в файл test1.pl следующие строки:

        #!/usr/local/bin/perl
        # Содержимое файла test1.pl
        print "Наше Вам с кисточкой!\n";
А теперь подробно разберем каждую строку.
#!/usr/local/bin/perl

Данная строка должна быть первой в любой Perl-программе. Она указывает системному интерпретатору что данный файл - это Perl-программа.

# Содержимое файла test1.pl
Эта строка называется комментарием. Она всегда начинается символом '#' и заканчивается таким объяснением что как говорил великий Ходжа Насреддин "это тонкий философский вопрос", а говоря простым языком здесь можно писать все что угодно. Даже пожелание руководству. Уж здесь оно точно до него не дойдет.

print "Наше Вам с кисточкой!\n";

Самая последняя ну и конечно главная. Она просто выводит на экран надпись "Наше Вам с кисточкой!".

Здесь слово print - это команда "вывести". Все что в кавычках - это символы, \n - перевод строки и ';' - признак конца команды. Он обязателен. В одной строке может быть несколько команд и все они должны завершаться символом ';'. После него может быть символ '#' - это значит остаток строки считается комментарием.

Над этой строкой автору пришлось больше всего поломать голову так как в нее постоянно лезли какие то странные "hello", "hello all", "Построимся и спасемся", "Строй наше спасение" и т. д. и т.п.

Если вы никогда не работали с Perl, то бьюсь на спор в 10$, что данная программа сразу у вас не заработает! Не потому что она не верна, а потому что "Нельзя объять необъятное". Сразу, потом можно, да и то частями. Сначала сделайте ваш файл test1.pl исполняемым. Для этого введите команду:

    chmod +x test1.pl
Затем проверьте где у вас Perl. Для этого введите:
    which perl
Система вам выдаст что то вроде: /usr/bin/perl
Если:
perl: Command not found.
То тогда закройте книжку и ложитесь спать. У вас просто нет Perl или он не установлен. А мне остается послать вас к системному администратору или к man (для переводчиков- man сокращение от manual а не то что вы подумали).

Теперь проверьте что бы строка 01 содержала то что выдала команда which. Если совпало то введите:

    test1.pl
и бьюсь на 50$, что и теперь программа не заработает, так как правильней ввести:
    ./test1.pl

Если я проиграл, то не радуйтесь. Да же если вам удалось запустить программу как test1.pl это значит, что у вас будут неприятности в будущем.

Пример 2.
Данная программа выводит на экран все ваши секреты. А именно файл /etc/passwd.

    #!/usr/local/bin/perl
    open(PASS, "</etc/passwd") || die "Файл не найден!";
    while(<PASS>)
        {
        print;
        }
    close(PASS);
Пояснения:
open(PASS, "</etc/passwd") || die "Файл не найден!";

"Открыть" файл, т.е. создать указатель файла PASS, и в случае ошибки выдать "Файл не найден!" и закончить программу.

while(<PASS>)
Читать по одной строке файла в переменную по умолчанию $_.
  {
Открыть блок операторов.
  print;
Вывести на экран переменную по умолчанию $_
   }
Конец блока.
close(PASS);
Закрыть файл. Этого можно и не делать, т. к. файл автоматически закроется после окончания программы.

Результат работы этой программы тот же что и команды cat /etc/passwd. По экрану пробежали непонятные строки но зато теперь перед вами открыты горизонты Perl программирования! Все последующие примеры будут развитием этой программы и она превратится из гадкого утенка в прекрасного лебедя (не генерала).

Пример 3.
Разделение полей.

      #!/usr/local/bin/perl
      open(PASS, "</etc/passwd") || die "Файл не найден!";
      while(<PASS>)
          {
        ($login, $pass, $uid, $gid, $name, $home_dir, $shell) = split(':');
        print "$login \t $name\n";
          }
      close(PASS);
Пояснение:
($login, $pass, $uid, $gid, $name, $home_dir, $shell) = split(':');
Присвоить указанным переменным поля входной строки, считая разделителем символ ':'.
print "$login \t $name\n";
Вывести login - имя пользователя и его описание. Поля разделены символом '\t' - табуляции.

Пример 4.
Вывести имена пользователей, отсортированных по группам.

    #!/usr/local/bin/perl
    open(PASS, "sort -n -t : +3 -4 +0 /etc/passwd|") || die "Файл не найден!";
    while(<PASS>)
        {
        ($login, $pass, $uid, $gid, $name, $home_dir, $shell) = split(':');
        print "$login \t $gid \t $name\n";
        }
    close(PASS);
Пояснения:
open(PASS, "sort -n -t : +3 -4 +0 /etc/passwd|") || die "Файл не найден!";

В данной строке весь фокус! Входным файлом для нашей программы стал выход команды sort которая и отсортирует входные данные.

Форматированный вывод.

Ну а теперь напечатаем на экране все наши данные в удобной форме.

#!/usr/local/bin/perl
open(PASS, "sort -n -t : +3 -4 +0 /etc/passwd|") || die "Файл не найден!";
while(<PASS>)
    {
    ($login, $pass, $uid, $gid, $name, $home_dir, $shell) = split(':');
    write();	# Форматированный вывод данных.
    }
close(PASS);
exit 0;		# Завершение программы
############ Описание формы вывода ##################
format STDOUT =
Пользователь: ^<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
                $name
              ^<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
                                $name
              ^<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
                                $name
----------------------------------------------------------------------
Login:@<<<<<<<<   Uid:@<<<  Gid:@<<<  Home dir:@<<<<<<<<<<<<<<<<<<<<<
      $login,         $uid,     $gid,          $home_dir
----------------------------------------------------------------------
.	# Это последняя строка программы

Фрагмент результата:

Пользователь: Калужский ликероводочный завод. Лучшие водки и
              настойки. Звонить только перед праздником Кострикову
              Анатолию т. 2-23-06,,,
----------------------------------------------------------------------
Login:uucryst     Uid:1055  Gid:66    Home dir:/var/spool/uucppublic/
----------------------------------------------------------------------
Пользователь: Торговый Дом Дилен,,,
----------------------------------------------------------------------
Login:uudilen     Uid:1075  Gid:66    Home dir:/var/spool/uucppublic
----------------------------------------------------------------------

Если вам интересно узнать как работает эта программа, то переверните страницу и начините свое путешествие в мире Perl. Желаю удачи!

[Содержание] [Вперед]


Отладка Perl программ

E-mail: info@citforum.ru
Сервер Информационных Технологий содержит море(!) аналитической информации

Отладка Perl программ.

В Perl реализован превосходный механизм отладки программ. Вам достаточно запустить программу с ключом '-d' и вы начнете работать с интерактивным отладчиком. Вам становятся доступны все переменные и массивы, вы можете вводить выражения и операторы, трассировать, исследовать работу программы в пошаговом режиме и многое другое. Ниже перечислены команды отладчика которые вы можете вводить на его подсказку.

Команды отладчика.

  • h - Получить справку по командам.
  • T - Просмотреть стек программы
  • s - Выполнить одну команду и остановиться.
  • n - Выполнить подпрограмму и остановиться.
  • r - Выполнить текущую подпрограмму и остановиться.
  • c - Продолжить выполнение до следующей точки остановки.
  • c номер - Продолжить выполнение до строки с данным номером.
  • - Повторить последнюю команду n или s.
  • l min+incr - Вывести incr+1 строк программы начиная со строки min.
  • l min-max - Вывести строки начиная с min до max.
  • l номер - Вывести строку с указанным номером.
  • l - Вывести следующий экран строк.
  • - - Вывести предыдущий экран строк.
  • w строк - Вывести экран строк. Текущая в середине.
  • l подпрограмма - Вывести строки указанной подпрограммы.
  • /шаблон/ - Найти строку в тексте программы.
  • ?шаблон? - Обратный поиск строки в тексте программы.
  • L - Вывести строки с точками останова и активами.
  • S - Вывести имена всех подпрограмм.
  • t - Включить или выключить трассировку.
  • b строка [ условие] - Установить точку остановки.
  • b подпрограмма [ условие ] - Установить точку остановки в начале указанной подпрограммы и если указано при данном условии.
  • d - Убрать точку остановки.
  • D - Убрать все точки остановки.
  • a строка команда - Установить актив (команду которая выполнится вместе с указанной строкой. "команда" - обычная команда Perl.
  • A - Стереть все активы.
  • < команда - Выполнять команду перед каждой остановкой.
  • > команда - Выполнить команду после остановки отладчика.
  • V модуль [имена] - Вывести значение всех или указанных имен в модуле. Внимание! Символ '$' не вводится.
  • X [имена] - То же что и V , но только для текущего модуля.
  • ! номер - Выполнить одну строку программы.
  • ! -номер - Выполнить одну команду с номером предшествующим текущей строке.
  • H - n - Вывести n последних выполненных команд.
  • q или ^D - Выход из программы.
  • команда - Выполнить команду Perl.
  • p выражение - Вывести значение выражения.

Конструктор BEGIN не отслеживается отладчиком, но можно в теле конструктора указать:

  • $DB::single =1;
и отладчик остановится. Данная команда не вызовет ошибку при работе без отладчика.


Переменные

E-mail: info@citforum.ru
Сервер Информационных Технологий содержит море(!) аналитической информации

Переменные.

  • Контекст
  • Скалярные значения
  • Конструкторы скаляров
  • Конструкторы списков
  • Тип typeglobs

В Perl существует три типа структур данных: скаляры, массивы скаляров и хеши (hashes) - ассоциативные массивы скаляров. Обычно элементы массивов индексируются целыми числами, первый элемент - нулевой. Отрицательное значение индекса обозначает номер позиции элемента с конца. Хеши индексируются строками символов.

Имена скалярных переменных всегда начинаются с символа '$' даже когда обозначают элемент массива.

Пример:

    $var1		# Простой скаляр 'var1'
    $var1[0]	# Первый элемент массива 'var1'
    $var1{'first'}	# Элемент с индексом 'first'

В случае использования имени массива "целиком" или его "среза" перед именем массива ставится символ '@'.

Пример:

    @var1		# Все элементы массива var1 ( $var1[0], $var1[1], ... $var1[n])
    @var1[1,3,10]	# Элементы $var1[1], $var1[3], $var1[10]
    @var1{'first','last'} # то же что и ( $var1{'first'}, $var1{'last'} )

Хеш "целиком" начинается с символа '%'.

Пример:

    %var, %key, %years

Имена подпрограмм начинаются символом '&', если из контекста не видно, что это подпрограмма.

Пример:

    &sub1, &test_prog, test(12)

Имена таблиц символов всегда начинаются символом '*'.

Каждый тип переменных имеет свою область памяти поэтому $var1 и $var1[0] совершенно разные переменные, хотя $var1[0] часть массива @var1. Так же @var1 и %var1 - разные массивы переменных.

Имена переменных могут содержать любые буквенно-цифровые символы за исключением пробела и табуляции. Эти символы используются в качестве разделителей. Большие и малые буквы различаются поэтому $var1 и $Var1 - разные переменные. В Perl по умолчанию имена меток и указателей файлов пишут большими буквами.

Контекст.

Большое значение для правильного употребления встроенных функций имеет контекст использования результата этих функций, т.к. в противном случае они возвращают совершенно "непонятный" результат. В Perl имеется два главных контекста: скалярный и список (list). Проще говоря, если в левой части выражения имеется ввиду одно единственное значение, то это скалярный контекст. Если множество значений - список.

Пример:

    $var1 = <>;	# Прочитать одну строку файла
    @var1 = <>;	# Прочитать все строки файла в массив @var1
    $var1 = (1,2,3); # $var = 3 - количество элементов
    @var1 = (1,2,3); # Создание массива @var1 с элементами 1,2,3

Скалярные значения.

Все данные в Perl это скаляры, массивы скаляров и хеши скаляров. Скалярные переменные могут содержать числа, строки и ссылки. Преобразование числа - строки происходит автоматически по умолчанию. Скаляр может иметь только одно единственное значение, хотя это может быть ссылка на массив скаляров. Так как Perl сам преобразовывает числа в строки и наоборот, то программисту нет необходимости думать о том, что возвращает функция.

В Perl не существует типов "строка" или "число" или "файл" или что-то еще. Это контекстно зависимый полиморфный язык для работы с текстами.

Скаляр имеет логическое значение "TRUE" (истина), если это не нулевая строка или число не равное 0.

В Perl существует два типа нулевых (null) скаляров - определенные (defined) и неопределенные (undefined). Неопределенное значение возвращается, когда что-то не существует. Например, неизвестная переменная, конец файла или ошибка. С помощью функции defined() вы можете заранее обнаружить подобное состояние.

Количество элементов массива так же является скаляром и начинается символами $# подобно интерпретатору csh. Фактически $#var1 - это индекс последнего элемента массива. Нужно помнить, что первый элемент имеет индекс 0, поэтому количество элементов определяется как $#var1+1 . Присвоение значения $#var1 изменит длину массива и разрушит "оставленные" значения. Присвоение значения элементу массива с индексом больше чем $#var1 увеличит размер массива, а присвоение ему нулевого списка -обнулит.

В скалярном контексте имя массива возвращает его длину (для списка возвращается последний элемент).

Пример:

    @var1 = (4, 3, 2, 1);	# Присвоение значения элементам массива
    $i = @var1;		# Использование скалярного контекста
    print $i;		# Печать результата 4 - кол-во элементов
    print @var1;		# Списковый контекст, печать всех элементов.

Для принудительного получения скалярного значения удобно применять функцию scalar().

Пример:

    print scalar(@var1);	# Вывод длины массива а не его значений

Хеш в скалярном контексте возвращает "true", если существует хотя бы одна пара "ключ-значение". Фактически возвращается строка типа 2/8 где 8 - количество выделенных "ячеек" памяти, а 2 - количество использованных.

Конструкторы скаляров.

Числа пишутся стандартно:

    123
    123.123
    0.12
    .12E-10
    0xABCD		# Шестнадцатиричная запись
    0377		# Если 0 в начале - восьмеричная
    123_456_123	# Так тоже можно для удобства чтения.
Строки ограничиваются одинарными (') или двойными (") кавычками:
    'Равняйсь, смирно!'
    "Построимся и спасемся."

Способов обозначения строк очень много. Смотрите описание оператора qq.

В хеше можно опускать кавычки, если индекс не содержит пробелов.

Пример:

    $var1{first} то же что и $var1{'first'}

Обратите внимание на то, что перед первой одинарной кавычкой должен стоять пробел, иначе строка воспримется как имя переменной, т. к. в именах разрешено использование одинарных кавычек. Запрещается в кавычках применять зарезервированные литералы __LINE__ (номер текущей строки программы), __FILE__ (текущий файл). Для обозначения конца программы можно применять литерал __END__ Весь последующий текст игнорируется, но его можно прочитать используя указатель файла DATA.

Слова в программе, не поддающиеся никакой интерпретации, воспринимаются как строки в кавычках, поэтому рекомендуется имена меток и указателей файлов писать большими буквами во избежание возможного "конфликта" с зарезервированными словами.

В Perl есть возможность вставлять текст документа прямо в программу. Так называемый "here-doc" (здесь текст) метод. Обозначается символами << за которыми идет слово-ограничитель.

Пример:

    print <<EOF;	# Все строки до EOF - текст для печати.
    Эй вы трое, идите двое сюда!
    Что стоишь! Я тебе говорю!!
        Полковник Савонькин.
    EOF

Конструкторы списков.

Список - множество значений, перечисленных через запятую и заключенных в круглые скобки. В списковом контексте список возвращает последний элемент списка.

Пример:

    @var1 = (1, 2, 'привет', 1.2); # Присвоить значение элементам.
где
        $var1[0] = 1,
        $var1[1] = 2,
        $var1[2] = 'привет'
        $var1[3] = 1.2
    $var1 = (1, 2, 'привет', 1.2);
а здесь $var1 = 1.2 т.е. последнее значение списка.

Допускается применять в списке другие списки, но в полученном списке уже невозможно различить начало и конец включенных списков.

Пример:

    @s1 = (1, 2, 3); # 	Первый список
    @s2 = (6, 7, 8);	# Второй
    @s = (0, @s1, 4, 5, @s2, 9, 10); # Включаем списки @s1 и @s2
    print @s;	# Результат: 012345678910  - значения без пробелов.

Список без элементов обозначается как () и называется нуль-списком. Списковое выражение можно употреблять как имя массива, но при этом его нужно брать в круглые скобки.

Пример:

    print ('январь','февраль','март')[1];
Результат: февраль

Список может быть присвоен списку только если каждый элемент в списке в левой части выражения допустим по типу списку в правой части.

Пример:

    ($a, $b, $c) = (1, 2, 3); # $a = 1, $b = 2, $c = 3

Присваивание списков в скалярном контексте возвращает количество присвоенных элементов.

Пример:

    $x = (($a, $b, $c) = (1,2));  # Результат $x=2

В случае присваивания списка хешу, список рассматривается как пары: ключ-значение.

Пример:

    %дни_месяца = ('январь', 31, 'февраль', 30);
Результат: $дни_месяца{январь} = 31, $дни_месяца{февраль} = 30

Для удобства записи можно использовать выражение с => .

Пример:

    %дни_месяца = (
            январь => 31,
            февраль => 30,
    );

Тип typeglobs

В Perl используется специальный внутренний тип typeglog для записи массива всех переменных. Такие массивы начинаются с символа '*'. Их удобно применять для передачи ссылок на массивы и хеши, но в данной версии Perl уже есть возможность применять ссылки, поэтому это делается очень редко. Единственно где это необходимо, так это для работы со ссылками на файлы. Например, если вам нужно создать локальную ссылку на файл в процедуре, то это лучше сделать так:

sub new_sub
{ local *IN; # Ссылка на файл
open (IN, "test") || return undef;  # Открыть файл. Возврат при ошибке.
.........
return;
}
Более подробно это описано в главе Ссылки.


Подпрограммы

E-mail: info@citforum.ru
Сервер Информационных Технологий содержит море(!) аналитической информации

Подпрограммы.

  • Private переменные
  • Переменные типа local
  • Прототипы (prototypes)
  • Ссылка как параметр
  • Переопределение встроенных функций
  • Автозагрузка

Для применения подпрограммы ее необходимо определить либо в текущем модуле (файле), либо во внешнем модуле (файле). Подпрограммы определяются и декларируются следующим образом:

  • sub имя; - Только декларация. Определение ниже.
  • sub имя (прототипы); - То же но с декларацией параметров.
  • sub имя блок; - Декларация и определение.
  • sub имя (прототипы) блок; - То же, но с параметрами.
Для определения динамической анонимной подпрограммы можно указать:
  • $переменная = sub блок;
Для импортирования подпрограмм из других модулей используйте:
  • use модуль qw(подпрограмма1 подпрограмма2 );
Вызов подпрограммы:
     имя(список параметров); # символ '&' можно не указывать.
     имя список;             # Если подпрограмма уже декларирована.
     &имя;                   # Параметры в @_

Все параметры передаются подпрограмме как массив @_. Соответственно $_[0] - первый параметр, $_[1] - второй и т.д. Массив @_ - локальный, но он содержит адреса параметров, поэтому можно изменять значение параметров. Возвращаемое значение подпрограммы - результат последнего оператора. Это может быть как скаляр так и массив. Можно принудительно возвращать результат используя функцию return().

Подпрограмму можно вызвать, используя префикс '&' перед именем подпрограммы. Если подпрограмма предварительно продекларирована, то префикс и скобки можно опустить.

Private переменные.

Для применения переменных доступных только внутри блока или подпрограммы необходимо определить их с помощью функции my(список).
Если переменная одна, то скобки можно опустить.

my() декларирует private переменные в пределах текущей подпрограммы, блока, функции eval() или do/require/use файлов. Private переменные аналогичны auto переменным в С.

Пример:

    # Программа вычисления факториала.
    print fact(3);  # вычислить факториал 3*2*1
    sub fact	# Определяем подпрограмму.
    { my $m;                # private переменная но не local !
    $m = $_[0];
    return 1 if $m <= 1;
    return($m * fact($m -1));
    }

Можно указывать начальные значения private переменных как:

  • my(список) = выражение;
Так для вышеприведенного примера лучше было написать:
  • my($m) = $_[0];

Переменные типа local.

В общем лучше использовать private переменные, т. к. это надежней и быстрее. private переменные обеспечивают лексическую область применения (видимости), а local - динамическую. Обычно это переменные форматов, значение которых должно быть видимо из вызываемых подпрограмм. Применение функции local() нецелесообразно в циклах, так как она вызывается каждый раз и таким образом заметно увеличивает время выполнения цикла.

Прототипы (prototypes).

Для краткого описания типа передаваемых подпрограмме параметров можно применять прототипы. В Perl существуют следующие прототипы:
Декларация | Пример вызова
sub mylink($$) | mylink $old, $new
sub myvec($$$) | myvec $var, $offset, 1
sub myindex($$;$) | myindex &getstring, "substr"
sub myreverse(@) | myreverse $a, $b, $c
sub myjoin($@) | myjoin ":",$a,$b,$c
sub mypop(\@) | mypop @array
sub mysplice(\@$$@) | mysplice @array, @array, 0, @pushme
sub mykeys(\%) | mykeys %{$hashref}
sub myopen(*;$) | myopen HANDLE, $name
sub mypipe(**) | mypipe READHANDLE, WRITEHANDLE
sub mygrep(&@) | mygrep { /foo/ } $a, $b, $c
sub myrand($) | myrand 42
sub mytime() | mytime
Здесь:

  • \'символ' - параметр с типом 'символ'
  • '@' или '%' - все оставшиеся параметры как список
  • '$' - скаляр
  • '&' - безымянная подпрограмма
  • '*' - ссылка на таблицу имен
  • ';' - разграничитель обязательных и не обязательных параметров.

Ссылка как параметр.

Иногда нужно в качестве параметра передать подпрограмме не значение элемента массива, а ссылку на него, чтобы подпрограмма могла изменить значение элемента. Для этого в Perl к имени переменной добавляется символ '*' Подобное выражение называют 'type glob' так же как в Unix символом '*' обозначают "все возможные значения". Поэтому '*' для массива означает "все элементы массива". Для скаляров употреблять '*' не имеет смысла, т.к. они и так передаются ссылкой и вы можете изменять значение параметра, изменяя, например, переменную $_[0].

Переопределение встроенных функций.

Большинство встроенных функций Perl можно переопределить своими собственными. Обычно это делают для удобства совместимости Perl для разных платформ систем.
Для этого нужно перечислить имена этих функций в виде:

  • use subs 'функция1', 'функция2' ....;
и далее в модуле определить сами функции.

Автозагрузка.

Если вы попытаетесь вызвать несуществующую функцию, то Perl немедленно выдаст сообщение об ошибке. Но если вы определите подпрограмму с именем 'AUTOLOAD', то она будет вызвана с теми же параметрами, а переменная $AUTOLOAD будет содержать имя несуществующей подпрограммы. Данный механизм очень удобен для средств отладки.


Регулярные выражения (шаблоны)

E-mail: info@citforum.ru
Сервер Информационных Технологий содержит море(!) аналитической информации

Регулярные выражения (шаблоны).

В данной главе описывается синтаксис регулярных выражений. Чаще всего в Perl они используются в операторах поиска и замены таких как s//, m/, операторах связки =~ или != и т.д. Как правило все эти операторы имеют схожие опции такие как:
i | - не различать строчные и заглавные буквы.
m | - считать строку многострочной.
s | - однострочная строка.
x | - расширенный синтаксис ( использование пробелов и комментариев)

Обычно все эти опции обозначают как '/x'. Их можно использовать даже внутри шаблонов, используя новую конструкцию (?...)

Регулярные выражения или шаблоны (pattern) то же самое, что и regexp процедуры в Unix. Выражения и синтаксис заимствованы из свободно распространяемых процедур V8 Генри Спенсера (Henry Spencer), там же они подробно и описаны.

В шаблонах используются следующие метасимволы (символы обозначающие группы других символов) часто называемые egrep - стандартом:
\ | - считать следующий метасимвол как обычный символ.
^ | - начало строки
. | - один произвольный символ. Кроме '\n' - конец строки.
$ | - конец строки
| | - альтернатива (или)
() | - группировка
[] | - класс символов

Метасимволы имеют модификаторы (пишутся после метасимвола):
* | - повторяется 0 или большее число раз
+ | - -//- 1 или большее число раз
? | - 1 или 0 раз
{n} | - точно n раз
{n,} | - по меньшей мере раз
{n,m} | - не меньше n, но и не больше m

Во все других случаях фигурные скобки считаются обычными (регулярными) символами. Таким образом '*' эквивалентна {0,} , '+' - {1,} и '?' - {0,1}. n и m не могут быть больше 65536.

По умолчанию действие метасимволов "жадно" (greedy). Совпадение распространяется столько раз, сколько возможно, не учитывая результат действия следующих метасимволов. Если вы хотите "уменьшить их аппетит", то используйте символ '?'. Это не изменяет значение метасимволов, просто уменьшает распространение. Таким образом:
*? | - станет 0 и более
+? | - 1 и более
?? | - 0 или 1 раз
{n}? | - точно n раз
{n,}? | - не меньше n раз
{n,m}? | - больше или равно n и меньше m раз

Шаблоны работают так же, как и двойные кавычки, поэтому в них можно использовать `\` - символы (бэкслэш-символы):
\t | - символ табуляции
\n | - новая строка
\r | - перевод каретки
\а | - перевод формата
\v | - вертикальная табуляция
\a | - звонок
\e | - escape
\033 | - восьмеричная запись символа
\x1A | - шестнадцатеричная
\c[ | - control символ
\l | - нижний регистр следующего символа
\u | - верхний регистр -//-
\L | - все символы в нижнем регистре до \E
\U | - в верхнем -//-
\E | - ограничитель смены регистра
\Q | - отмена действия как метасимвола

Дополнительно в Perl добавлены следующие метасимволы:
\w | - алфавитно-цифровой или '_' символ
\W | - не -//-
\s | - один пробел
\S | - один не пробел
\d | - одна цифра
\D | - одна не цифра

Обратите внимание, что все это "один" символ. Для обозначения последовательности применяйте модификаторы. Так:
\w+ | - слово
\d+ | - целое число
[+-]?\d+ | - целое со знаком
[+-]?\d+\.?\d* | - число с точкой
Кроме того существуют мнимые метасимволы. Обозначающие не существующие символы в месте смены значения. Такие как:
\b | - граница слова
\B | - не граница слова
\A | - начало строки
\Z | - конец строки
\G | - конец действия m//g

Граница слова (\b) - это мнимая точка между символами \w и \W. Внутри класса символов '\b' обозначает символ backspace (стирания). Метасимволы \A и \Z - аналогичны '^' и '$', но если начало строки '^' и конец строки '$' действуют для каждой строки в многострочной строке, то \A и \Z обозначают начало и конец всей многострочной строки.

Если внутри шаблона применяется группировка (круглые скобки), то номер подстроки группы обозначается как '\цифра'. Заметьте, что за шаблоном в пределах выражения или блока эти группы обозначаются как '$цифра'. Кроме этого существуют дополнительные переменные:
$+ | - обозначает последнее совпадение
$& | - все совпадение
$` | - все до совпадения
$' | - все после совпадения

Пример:

$s = "Один 1 два 2 и три 3";
if ($s =~ /(\d+)\D+(\d+)/)
    {
        print "$1\n";    # Результат '1'
        print "$2\n";    # '2'
        print "$+\n";    # '2'
        print "$&\n";    # '1 два 2'
        print "$`\n";    # 'Один '
        print "$'\n";    # ' и три 3'
   }

Perl версии 5 содержит дополнительные конструкции шаблонов:
(?#комментарий) | - комментарий в теле шаблона.
(?:шаблон) | - группировка как и '( )', но без обратной ссылки
(?=шаблон) | - "заглядывание" вперед. Например /\w+(?=\t)/ соответствует слову, за которым идет табуляция, но символ '\t' не включается в результат.

Пример:

$s = "1+2-3*4";
if ($s =~ /(\d)(?=-)/)  # Найти цифру за которой стоит '-'
    {
        print "$1\n";   # Результат '2'
   }
else { print "ошибка поиска\n";}

        (?!шаблон)         - "заглядывание" вперед по отрицанию.

Пример:

$s = "1+2-3*4";
if ($s =~ /(\d)(?!\+)/) # Найти цифру за которой не стоит '+'
    {
        print "$1\n";   # Результат '2'
   }
else { print "ошибка поиска\n";}

(?ismx)- "внутренние" модификаторы. Удобно применять в шаблонах, где например нужно внутри шаблона указать модификатор.

Правила регулярного выражения. (regex)

  1. Любой символ обозначает себя самого, если это не метасимвол. Если вам нужно отменить действие метасимвола, то поставьте перед ним '\'.
  2. Строка символов обозначает строку этих символов.
  3. Множество возможных символов (класс) заключается в квадратные скобки '[]', это значит, что в данном месте может стоять один из указанных в скобках символов. Если первый символ в скобках это '^' - значит ни один из указанных символов не может стоять в данном месте выражения. Внутри класса можно употреблять символ '-', обозначающий диапазон символов. Например, a-z - один из малых букв латинского алфавита, 0-9 - цифра и т.д.
  4. Все символы, включая специальные, можно обозначать с помощью '\' как в языке С.
  5. Альтернативные последовательности разделяются символом '|' Заметьте что внутри квадратных скобок это обычный символ.
  6. Внутри регулярного выражения можно указывать "подшаблоны" заключая их в круглые скобки и ссылаться на них как '\номер' Первая скобка обозначается как '\1'.


Синтаксис

E-mail: info@citforum.ru
Сервер Информационных Технологий содержит море(!) аналитической информации

Синтаксис.

  • Декларации (объявления)
  • Простое предложение
  • Сложные предложения
  • Циклы
    • while
    • Операторы управления циклом
      • next
      • last
      • redo
    • for
    • foreach
  • Блоки и оператор switch
  • Оператор goto
  • POD операторы. Документирование программ

Perl программа (скрипт) состоит из последовательности деклараций и предложений. Единственно что должно быть обязательно декларировано, это форматы отчетов и подпрограммы (функции). Все необъявленные переменные, массивы имеют значение 0 или null.

Декларации (объявления).

Perl имеет свободный формат. Комментарии начинаются с символа '#' и продолжаются до конца строки. Декларации могут использоваться в любом месте программы так же как и предложения (statements), но действуют они только в фазе компиляции программы. Обычно их помещают или в начале или в конце программы. Декларация подпрограмм позволяет использовать имя подпрограммы как списковый оператор, начиная с момента декларирования.
Пример:

    sub test;	# Декларация подпрограммы test
    $var1 = test $0; # Использование как оператора списка.

Декларации подпрограмм могут быть загружены из отдельного файла предложением require или загружены и импортированы в текущую область имен предложением use. Подробно см. главу Модули.

Простое предложение.

Простое предложение обязательно заканчивается символом ';' если только это не последнее предложение в блоке где ';' можно опустить. Заметьте, что существуют операторы такие как eval{} и do{}, которые выглядят как сложные предложения, но на самом деле это термы и требуют обязательного указания конца предложения.

Любое простое предложение может содержать single модификатор перед ';'. Существуют следующие single модификаторы:

    if EXPR
    unless EXPR
    while EXPR
    until EXPR
где EXPR - выражение, возвращающее логическое значение true или false. Модификаторы while и until вычисляются в начале предложения кроме блока do, который выполняется первым.

if EXPR- Модификатор "если". Предложение выполняется, если EXPR возвращает true.

Пример:

    $var = 1;
    $var2 = 3 if $var > 0; # Результат: $var2 = 3

while EXPR - Модификатор "пока". Предложение выполняется пока EXPR = true

Пример:

    $var = 1;
    print $var++ while $var < 5; # Печать $var с инкрементом
Результат: 1234

until EXPR- Модификатор "до ". Предложение выполняется до тех пор пока EXPR = false

Пример:

    $var = 1;
    print $var++ until $var > 5; # Печать $var с инкрементом
Результат: 12345

unless EXPR - Модификатор "если не" . Обратный к if. Выражение выполняется если EXPR = false.

Пример:

    $var = 1;
    print $var++ unless $var > 5; # Печать $var с инкрементом
Результат: 1

Сложные предложения.

Последовательность простых предложений, ограниченная функциональными ограничителями, называется блоком. В Perl это может быть целый файл, последовательность предложений в операторе eval{} или чаще всего это множество простых предложений, ограниченных круглыми скобками '{}'.

Существуют следующие виды сложных предложений:

    if (EXPR) BLOCK
    if (EXPR) BLOCK else BLOCK
    if (EXPR) BLOCK elsif (EXPR) BLOCK ... else BLOCK

    LABEL while (EXPR) BLOCK
    LABEL while (EXPR) BLOCK continue BLOCK
    LABEL for (EXPR; EXPR; EXPR) BLOCK
    LABEL foreach VAR (LIST) BLOCK
    LABEL BLOCK continue BLOCK

Обратите внимание, что сложные предложения описаны в термах блоков, а не предложений, как в языках C или Pascal. Поэтому необходимо всегда использовать круглые скобки для обозначения блока.

if (EXPR) BLOCK - Вычисляется логическое выражение EXPR и если true блок выполняется.
Пример:

    $var =1;
    if ($var == 1)
       { print $var,"\n";
       }
Результат: 1

if (EXPR) BLOCK else BLOCK2 - Если EXPR=true выполняется BLOCK иначе BLOCK2.
Пример:

    $var =2;
    if ($var == 1)
       { print "\$var = 1\n";
       }
    else
       { print "\$var не равно 1\n";
       }
Результат: $var не равно 1

if (EXPR1) BLOCK1 elsif (EXPR2) BLOCK2 ... else BLOCK - Если EXPR1=true выполняется BLOCK1 иначе если EXPR2=true выполняется BLOCK2 иначе ... иначе BLOCK.
Пример:

    $var = 1;
    if ($var == 0)
       { print "\$var = 0\n";
       }
    elsif ($var == 1)
       { print "\$var = 1\n";
       }
    else
       { print "Не известное \$var\n";
       }
Результат: $var = 1

Цикл While

Цикл while выполняет BLOCK до тех пор пока EXPR = true. Метка LABEL не обязательна и состоит из идентификатора, завершающегося символом ':'. Метка необходима при использовании внутри блока цикла управляющих операторов next, last и redo. Если метка все же отсутствует, то эти операторы ссылаются к началу ближайшего цикла. Блок после continue выполняется всегда перед тем как вычисляется логическое выражение EXPR. Это подобно EXPR3 в предложении for, поэтому в этом блоке удобно изменять счетчики и флаги цикла даже если применяется оператор next.

Операторы управления циклом.

next - подобен continue в С. Переходит к началу текущего цикла т.е. повторяет итерацию.

Пример:

    M1:
    while ($i < 6)
        {
        ++$i;	# Увеличиваем счетчик на 1
        next M1 if $i < 3; # Переходим в начало если $i < 3
        ++$i;	# иначе увеличиваем счетчик еще раз на 1
        }
    continue
        {
        print "$i "; # Печатаем $i
        }
Результат: 1 2 4 6

last - подобен оператору break в языке С. Немедленно прерывает цикл. Блок continue пропускается.

Пример:

        M1:
        while ($i < 6)
            {
            ++$i;       # Увеличиваем счетчик на 1
            last M1 if $i > 3; # Выход из цикла если $i > 3
            ++$i;       # иначе увеличиваем счетчик еще раз на 1
            }
continue {
            print "$i "; # Печатаем $i
}
Результат: 2 4

redo - начать новый цикл не вычисляя EXPR и не выполняя continue блок.

Пример:

        M1:
        while ($i < 6)
            {
            ++$i;       # Увеличиваем счетчик на 1
            redo M1 if $i == 3; # Далее пропустить для $i = 3
            ++$i;       # иначе увеличиваем счетчик еще раз на 1
            }
continue {
            print "$i "; # Печатаем $i
}
Результат: 2 5 7

Цикл for.

LABEL for (EXPR1; EXPR2; EXPR3) BLOCK
Оператор for полностью аналогичен оператору for в С. В перед началом цикла выполняется EXPR1, если EXPR2 = true выполняется блок, затем выполняется EXPR3.

Пример:

    for ($i = 2; $i < 5; ++$i)
           {
           print $i, " ";
           }
        print "\nПосле цикла i = $i\n";
Результат:
    2 3 4
    После цикла i = 5

Цикл foreach.

LABEL foreach VAR (LIST) BLOCK
Переменной VAR присваивается поочередно каждый элемент списка LIST и выполняется блок. Если VAR опущено, то элементы присваиваются встроенной переменной $_. Если в теле блока изменять значение VAR то это вызовет изменение и элементов списка т.к. VAR фактически указывает на текущий элемент списка. Вместо слова foreach можно писать просто for - это слова синонимы.

Пример:

        @месяц = ("январь","февраль","март");  # Создали массив
        foreach $i (@месяц)
            {
            print $i," ";       # Печать $i
            }
Результат: январь февраль март

Пример:

        @месяц = ("январь","февраль","март");  # Создали массив
        foreach $i (@месяц)
            {
            $i = uc($i); # Перевели в верхний регистр
            }
        print @месяц;
Результат: ЯНВАРЬФЕВРАЛЬМАРТ

Пример:

    for $i (3,5,7)
        {
        print "$i ";
        }
Результат: 3 5 7

Блоки и оператор switch.

Блок не зависимо от того имеет он метку или нет семантически представляет собой цикл который выполняется один раз. Поэтому действие операторов цикла next, last, redo - аналогично описанному выше. Блоки удобны для построения switch (переключатель) структур. В Perl нет специального оператора switch подобного языку С поэтому вы сами можете создавать удобные для вас конструкции. Опыт автора показывает что для простоты написания лучше всего подходит конструкция вида if ... elsif ... else ... хотя можно сочинить и нечто подобное:

    SWITCH:
    {
    if ($i ==1 ) { .....; last SWITCH; }
    if ($i ==2 ) { .....; last SWITCH; }
    if ($i ==3 ) { .....; last SWITCH; }
    $default = 13;
    }
Выбирайте сами по своему вкусу.

Оператор goto.

В Perl существует оператор goto хотя где , как и когда его применять как говорил Ходжа Насреддин "Тонкий философский вопрос". Для начинающих программистов которым от так "нужен" я бы вообще посоветовал "забыть" о его существовании. Однако при создании больших производственных задач на последнем этапе особенно при отработке "отвальных" ошибочных ситуаций конечно goto нужен.

В Perl реализовано три формы goto. goto - метка, goto - выражение и goto - подпрограмма.
goto | метка выполняет непосредственный переход на указанную метку.
goto - выражениеВычисляет имя метки и делает соответствующий переход. Например если мы хотим сделать переход на одну из трех меток "M1:", "M2:" или "M3:" в зависимости от значений переменной $i равной 0, 1 или 2 то это лучше сделать следующим образом:
    goto ("M1", "M2", "M3")[$i];
здесь $i используется как индекс массива указанного непосредственно в выражении.
goto подпрограмма | довольно редкий случай т.к. всегда проще и надежней вызвать подпрограмму "естественным" образом.

POD операторы. Документирование программ.

В Perl реализован очень удобный механизм для написания документации в момент создания программы. Для этого применяются специальные POD операторы. Если в теле программы интерпретатор встречает оператор начинающийся с символа '=' например:

    = head Набор стандартных процедур
то пропускается все до слова '=cut'. Это удобно для включения длинных на несколько строк или страниц комментариев. Затем с помощью специальной программы pod можно отделить текст документации от текста программы.


Содержание

E-mail: info@citforum.ru
Сервер Информационных Технологий содержит море(!) аналитической информации

Введение в Perl

В книге приводятся начальные сведения по новому языку программирования Perl. Данный язык получил широкое распространение в связи с развитием компьютерной сети Интернет. Все примеры в книге проверены для Perl версии 5.003 операционной системы Unix FreeBSD 2.1.0.

Для программистов, системных администраторов и пользователей компьютеров.
© Маслов Владимир Викторович.

Содержание

  • От простого к сложному
  • Запуск Perl - программы
  • Синтаксис
    • Декларации (объявления)
    • Простое предложение
    • Сложные предложения
    • Циклы
      • while
      • Операторы управления циклом
        • next
        • last
        • redo
      • for
      • foreach
    • Блоки и оператор switch
    • Оператор goto
    • POD операторы. Документирование программ
  • Переменные
    • Контекст
    • Скалярные значения
    • Конструкторы скаляров
    • Конструкторы списков
    • Тип typeglobs
  • Встроенные переменные
  • Регулярные выражения (шаблоны)
  • Операторы и приоритеты
    • Термы и левосторонние списковые операторы
    • Унарные операторы
    • Операторы "привязки" =~ и !=
    • Мультипликативные операторы
    • Аддитивные операторы
    • Операторы сдвига
    • Именованные унарные операторы
    • Операторы отношений
    • Операторы равенства
    • Операторы работы с битами
    • Логические операторы && (AND) и || (OR)
    • Оператор диапазона '..'
    • Условный оператор '?:'
    • Операторы присваивания
    • Оператор ',' (запятая)
    • Логические not, and, or, xor
    • Операторы ограничители строк
    • Операторы ввода-вывода
    • Слияние констант
    • Целочисленная арифметика
  • Встроенные функции
  • Подпрограммы
    • Private переменные
    • Переменные типа local
    • Прототипы (prototypes)
    • Ссылка как параметр
    • Переопределение встроенных функций
    • Автозагрузка
  • Модули
    • Таблицы имен
    • Конструкторы и деструкторы
    • Классы
    • Создание библиотеки
    • Pragma библиотеки
    • Стандартные библиотеки
    • CPAN
  • Форматы отчетов
  • Отладка
  • Интернет - ссылки и литература

Все замечания и предложения направляйте по адресу:
maslov@klgtts.kaluga.su
maslov@news.kaluga.rosmail.com


Форматы

E-mail: info@citforum.ru
Сервер Информационных Технологий содержит море(!) аналитической информации

Форматы.

В Perl реализован удобный метод создания форматированных отчетов. С помощью оператора format вы описываете заголовки, размеры полей, указываете положение данных на листе в удобной текстовой форме. Затем выполняете команду write(файл), которая выводит отформатированные данные в указанный файл.

Оператор format имеет следующий синтаксис:

    format имя =
    FORMLIST
    .

Обратите внимание на то, что описание формата идет после строки format и заканчивается символом '.' в начале строки.

Здесь 'имя' - это имя формата, такое же как и имя указателя выходного файла. Если 'имя' отсутствует то значение по умолчанию - STDOUT.

FORMLIST - это строки формата. Они бывают трех типов:

  1. Комментарий. Строка начинается символом '#'.
  2. Описатель полей данных (picture).
  3. Строка аргументов используемых описателем.

Описатель - это строка, которая выводится в виде "как есть" за исключением специально обозначенных форматов полей данных. Каждое поле начинается либо символом '@', либо '^'. В описательной строке указывается только положение и вид выводимых данных, но не имена полей и переменных. Для этого предназначена следующая строка аргументов которая следует всегда после описателя и содержит имена переменных или целые выражения в порядке указанном описателем.

Размер и вид поля в описателе обозначается следующими символами:
"<<<<" | - выравнить значение по правому краю.
">>>>" | - -//- по левому.
"||||" | - -//- по центру.
"####.###" | - формат числа с точкой.
"@*" | - многострочная строка. Данные выводятся в колонку.
Размер поля равен количеству указанных символов.
Символ '^' в начале поля имеет специальное значение.
Так:

  • "^####" - пусто если переменная не определена.
для строчного скаляра:
  • "^<<<<<" - Выводится сколько возможно символов, а значение переменной меняется на остаток, вывод которого можно продолжить на следующих строках, которые могут иметь свои поля.

Пример:

#!/usr/local/bin/perl
#
#	Программа печати пригласительного билета
#
$кому = "Чапаеву Василию Ивановичу";
$от_кого = "Компания МММ";
$адрес = "Москва, ул. Петровка, д 38";
$текст = "Уважаемый Василий Иванович! Компания МММ имеет честь пригласить
Вас и Ваших близких на презентацию наших новых хромовых сапог, сделанных
на уровне мировых стандартов качества и дизайна.";
format STDOUT =
    П Р И Г Л А С И Т Е Л Ь Н Ы Й      Б И Л Е Т
----------------------------------------------------------------------
Кому: @<<<<<<<<<<<<<<<<<<<<<<<<<<  | ^|||||||||||||||||||||||||||||||
      $кому,				$текст
                                   | ^|||||||||||||||||||||||||||||||
                          $текст
От кого: @<<<<<<<<<<<<<<<<<<<<<<<  | ^|||||||||||||||||||||||||||||||
      $от_кого,				$текст
                                   | ^|||||||||||||||||||||||||||||||
                          $текст
Адрес:@<<<<<<<<<<<<<<<<<<<<<<<<<<  | ^|||||||||||||||||||||||||||||||
      $адрес,				$текст
                                   | ^|||||||||||||||||||||||||||||||
                          $текст
                                   | ^|||||||||||||||||||||||||||||||
                          $текст
                                   | ^|||||||||||||||||||||||||||||||
                          $текст
----------------------------------------------------------------------
Отпечатано в типографии ИТУ 38
.
write();	# Вывод данных.
exit 0;		# Конец программы

Результат:

    П Р И Г Л А С И Т Е Л Ь Н Ы Й      Б И Л Е Т
----------------------------------------------------------------------
Кому: Чапаеву Василию Ивановичу    |   Уважаемый Василий Иванович!
                                   |     Компания МММ имеет честь
От кого: Компания МММ              |  пригласить Вас и Ваших близких
                                   |    на презентацию наших новых
Адрес:Москва, ул. Петровка, д 38   |   хромовых сапог, сделанных на
                                   |    уровне мировых стандартов
                                   |       качества и дизайна.
                                   |
----------------------------------------------------------------------
Отпечатано в типографии ИТУ 38
Специальные переменные:
  • $~ - построчный формат содержимого.
  • $^ - формат заголовка листа.
  • $% - номер листа.
  • $= - строк в листе.
Если вы хотите использовать одни и те же форматы для разных файлов, то самый простой путь:
    use FileHandle;                   # Указать в начале программы
    format_name файл имя_формата;     # Формат содержимого листа.
    format_top_name файл имя_формата; # Формат заголовка листа.
    write(файл);                      # вывод данных.

Здесь 'файл' имеется ввиду указатель файла полученный командой open();

Если вам нужно в теле листа выводить разного рода форматы (например заголовки групп или отбивку листа), то применяйте format_name.