Анимация сцен

Что можно оживить?

Метод ключевых кадров

Просмотр анимации

Просмотр треков

Режим правки ключей

Движение по заданному пути

Движение по поверхности

Принцип создания анимационных роликов был рассмотрен на первом занятии. Здесь мы изучим вопросы динамики сцены подробнее.

Что можно оживить?

Создавая ряд последовательных изображений, можно изменять положение объектов в пространстве, их геометрию, используя любого рода модификаторы, свойства материалов, такие как цвет, прозрачность, блеск, состояние окружающей среды, атмосферные эффекты. Можно имитировать движение не только отдельных элементов сцены, но и учитывать при этом их связь между собой, когда преобразования в движении одного объекта влекут за собой аналогичные преобразования других, связанных с ним объектов. К тому же существует возможность имитировать такие факторы движения, как сила трения, тяжести, давления, учитывать направление ветра, деформацию объектов при столкновении.

Метод ключевых кадров

Простейшая базовая анимация создается с помощью средств управления анимацией: ползунка таймера анимации, кнопок управления воспроизведением анимации, кнопки Animate (Анимация) и кнопки Degradation Override (Запрет деградации).

1. Создайте в окне Perspective (Перспектива) два объекта: сферу и прямоугольник.

Каждый объект становится начальным кадром анимации.

2. Определите и задайте число кадров анимации, исходя из ее продолжительности. С этой целью щелкните LM на кнопке Time Configuration (Настройка временных интервалов).

На экране появится диалоговое окно Time Configuration (Настройка временных интервалов), показанное на рис. 17.1. В нем можно указать общую продолжительность времени анимации, скорость ее воспроизведения и способ отображения отсчетов времени.

Рис. 17.1. Диалоговое окно настройки временных параметров

3. Задайте частоту кадров анимации, установив переключатель Frame Rate(Частота кадров) в одно из четырех положений:

· NTSC — стандарт телевизионного сигнала с частотой 30 кадров в секунду;

· PAL — телевизионный стандарт Phase Alternate Line с частотой 25 кадров в секунду;

· Film (Кино) — стандарт игрового кино с частотой 24 кадра в секунду;

· Custom (Специальная) — позволяет указать произвольную частоту кадров в счетчике FPS (FramesPerSecond).

4. Укажите, в какой форме будет отображаться время на ползунке таймера, установив переключатель Time Display (Отображение времени) в одно из четырех положений:

· Frames (Кадры) — время отображается в виде номера кадра;

· SMPTE — стандарт, в котором время отображается в формате минуты: секунды. кадр, где кадр — это число долей очередной секунды, выраженное в количестве кадров, прошедших с конца предыдущей секунды. Например, при частоте 30 кадров в секунду запись 0:2.29 означает кадр или момент времени, равный 2 и 29/30 секунды;

· FRAME: TICKS — время отображается в формате кадр:тик, где тик — внутренняя единица измерения времени, равная 1/4800 секунды;

· MM: SS: TICKS — время представляется в формате минуты:секунды:тики и позволяет отсчитывать время с интервалом в 1/4800 долю секунды.

5. Установите общую продолжительность анимации с помощью следующих параметров группы Animation (Анимация):

· Start Time (Время начала), End Time (Время окончания) — счетчики задают время начала и конца анимации, т. е. интервала, в пределах которого можно перемещаться по шкале времени при помощи ползунка таймера или кнопки управления анимацией;

· Length (Продолжительность) — счетчик задает продолжительность активного времени анимации. Этот параметр связан со счетчиком End Time (Время окончания). Когда изменяется время в одном из них, автоматически изменяется значение и в другом;

· Current Time (Текущее время) — счетчик позволяет установить текущее время анимации;

· Re- scale Time (Сменить масштаб времени) — кнопка вызывает диалоговое окно Re- scale Time (Смена масштаба времени), где можно изменить масштаб времени анимации, задав новые значения Start Time (Время начала), End Time (Время окончания) и Length (Продолжительность). Масштабирование шкалы времени производится за счет растяжения или сжатия интервалов между ключами анимации.

6. Щелкните на кнопке Animate (Анимация).

Активизируется режим анимации. Кнопка подсветится красным цветом, а вокруг активного окна проекции появится красная рамка.

7. Переместите ползунок таймера анимации на 10 кадров.

Вы создали первый ключевой кадр. В нем следует произвести какие-то изменения в сцене. В нашем анимационном ролике мы заставим сферу прыгать на плоскости.

8. Переместите сферу вверх над плоскостью прямоугольника.

В новом ключевом кадре будут сохраняться новые пространственные параметры сцены. Объект, которому назначен ключ анимации, заключается в габаритный контейнер.

9. Установите в качестве текущего новый ключевой кадр, передвинув ползунок еще на 10 кадров.

10. Переместите сферу на плоскость прямоугольника.

11. На следующем десятикадровом ключе разверните прямоугольник.

Для анимации простых видов равномерного изменения параметров, таких как перемещение, поворот объекта или уменьшение яркости освещения, достаточно установить два ключа: в начале и в конце анимации.

12. Таким же образом постройте остальные ключи анимации.

Базовая анимация создана. Основываясь на ключевых кадрах, программа сама рассчитывает значения параметров анимации для всех промежуточных кадров.

Просмотр анимации

Выполните следующие шаги:

1. Установите в качестве текущего начальный кадр анимации, пер.етащив ползунок таймера в крайнее левое положение или щелкните LM на кнопке Go to Start (Перейти в начало)

2. Щелкните LM на кнопке Play Animation (Воспроизведение анимации).

Можно просмотреть анимацию только выделенных объектов. Для этого задержите курсор мыши при нажатой LM на кнопке Play Animation (Воспроизведение анимации). Раскроется панель инструмента с дополнительной кнопкой Play Selected (Воспроизведение анимации выделенных объектов). Перетащите на нее курсор мыши и отпустите кнопку.

3. Для запрета ухудшения качества отображения сцены анимации щелкните на кнопке Degradation Override (Запрет деградации).

Ухудшение качества и снижение скорости анимации может происходить из-за низких параметров машины.

4. Для остановки воспроизведения анимации щелкните на кнопке Stop (Стоп), в которую превращается кнопка Play Animation(Воспроизведение анимации) после начала воспроизведения.

Самостоятельно создайте анимационный ролик, введя в сцену камеру и освещение.

Просмотр треков

Дальнейшая отладка базовой анимации заключается в редактировании, модификации, добавлении или удалении ключей анимации. Эти действия производятся с помощью окна диалога Trach View (Просмотр треков). Кроме того, указанное окно предоставляет полный перечень всех элементов сцены, озволяет добавлять к анимации звуковую дорожку, а также управлять видимостью объектов сцены.

Для открытия окна Trach View (Просмотр треков) щелкните LM на кнопке Open Track View (Открыть окно просмотра треков) панели инструментов.

Если открывается первое окно Trach View (Просмотр треков), то оно получает имя Untitled 1 (Без имени 1). Следующий выбор команды Open Track View (Открыть окно просмотра треков) открывает окно с именем Untitled 2 (Без имени 2) и т. д. Диалоговое окно Trach View (Просмотр треков) показано на рис. 17.2.

Рис. 17.2. Диалоговое окно просмотра треков

Окно дерева иерархии, расположенное слева, содержит список всех элементов сцены с их параметрами, включая объекты, материалы, звуки и эффекты внешней среды. Каждую из ветвей дерева можно развернуть, щелкнув LM на кружке со знаком + рядом с именем ветви.

Режим правки ключей

Для переключения окна Trach View (Просмотр треков) в режим правки ключей щелкните на кнопке Edit Keys (Правка ключей) на панели инструментов в диалоговом окне.

В режиме правки ключей обеспечиваются возможности редактирования числовых значений или положений на шкале времени для отдельных ключей или их выделенных наборов. Ниже мы рассмотрим назначение кнопок редактирования ключей.

· Add Visibility Track (Добавить трек видимости) — добавляет новый трек для выделенного объекта, управляющий видимостью объекта во времени. Ключи, вставляемые в этот трек, определяют видимость объекта либо в 0 (объект невидимый), либо в 1 (объект видим). Когда время анимации достигает позиции данного ключа, видимость объекта устанавливается в соответствии со значением ключа и остается в таком состоянии до момента появления следующего ключа видимости или до конца анимации. Значение ключа можно устанавливать с помощью окна свойств данного ключа, вызываемого кнопкой Properties (Свойства).

· Align Keys (Выровнять ключи) — позволяет привязать позицию всех выделенных ключей на оси времени к текущему кадру. Перемещая ползунок таймера анимации, установите в качестве текущего нужный кадр, выделите несколько ключей и щелкните на кнопке Align Keys (Выровнять ключи). Группа выделенных ключей переместится так, чтобы самый левый из них оказался на отметке текущего кадра

· Delete Keys (Удалить ключи) — позволяет удалять выделенные ключи. Для удаления одного или нескольких ключей выделите их, поочередно щелкая на ключах при удерживаемой клавише <Ctrl>, а затем щелкните на данной кнопке. Если перед щелчком на кнопке Delete Keys(Удалить ключи) будет выделена метка имени одного из объектов, обозначаемых в окне дерева иерархии значками в виде желтого куба, то программа потребует подтвердить, действительно ли вы хотите удалить все ключи анимации выделенного объекта. Если в ответ щелкнуть на кнопке Yes, то все ключи анимации объекта будут удалены. Если щелкнуть на кнопке No, то не будут удалены никакие ключи, даже те, которые были выделены.

· Move Keys (Переместить ключ) — позволяет перемещать выделенные ключи вдоль оси времени. Для перемещения одного или нескольких ключей выделите их, щелкните на кнопке Move Keys (Переместить ключ) и перетащите ключи влево или вправо по треку. Перемещение ключей не сказывается на их числовых значениях, меняются только связанные с ключами моменты времени. Для дублирования одного или нескольких ключей выделите их, щелкните на кнопке Move Keys(Переместить ключ) и перетащите ключи вправо или влево при удерживаемой клавише <Shift>. Как только кнопка мыши будет отпущена, создадутся копии всех выделенных ключей с теми же числовыми значениями, что и у оригиналов. При этом копии ключей будут смещены по времени относительно оригиналов настолько, насколько вы перетащите их мышью.

· Slide Keys (Сдвинуть ключи) — позволяет перемещать выделенные ключи вдоль трека, одновременно сдвигая ключи, предшествующие перемещаемым или следующие за ними. Чтобы сдвинуть группу ключей, выполните те же действия, что и при перемещении ключей, но используя кнопку Slide Keys (Сдвинуть ключи).

· Scale Keys (Масштабировать ключи) ~ позволяет перемещать все выделенные ключи, пропорционально изменяя расстояния на шкале от них до текущего кадра. Выделите несколько ключей, щелкните на кнопке Scale Keys (Масштабировать ключи) и перетащите один из выделенных ключей вправо или влево. По мере перемещения ключа будут сдвигаться и все остальные выделенные ключи, при этом интервалы времени между ними и текущим кадром станут изменяться в равной пропорции.

· Add Keys (Добавить ключи) — позволяет добавить ключ анимации к любому из треков. Для добавления ключа нажмите кнопку Add Keys (Добавить ключи), а затем щелкните в точке трека, соответствующей нужному моменту времени. Числовое значение параметра ключа рассчитывается путем интерполяции значений соседних ключей, если параметр подвергался анимации или принимается равным статическому значению, если анимация параметра отсутствовала.

· Modify Subtree (Модифицировать поддерево) — позволяет модифицировать не только ключи, принадлежащие выделенным объектам или относящиеся к выделенным трекам, но и ключи всех связанных с ним элементов, расположенных на более низких уровнях иерархии в левой части окна треков. Когда режим модификации поддеревьев включен, на каждом из родительских треков отображаются, помимо собственных, еще ключи анимации со всех дочерних треков.

Движение по заданному пути

Движение объекта можно определить, задав ему траекторию в виде сплайна. Такого рода анимация осуществляется методом настройки параметров контроллера Path Constraint (Путь).

1. Создайте сплайновую кривую и объект, который будет по ней двигаться (рис. 17.3),

Объект должен быть выделен.

2. На командной панели выберите вкладку Motion (Движение). Появятся свитки параметров, показанные на рис. 17.4.

3. В свитке Assign Controller (Назначить контроллер) выделите строку Position (Положение) и щелкните LM на кнопке Assign Controller(Назначить контроллер) над списком.

4. В открывшемся окне контроллеров выберите значение Path Constraint(Путь).

Рис. 17.3. Заготовка для движения объекта по пути

Рис. 17.4. Свитки параметров движения по пути

5. В свитке Path Parameters (Параметры пути) щелкните на кнопке Add Path(Добавить путь), а затем выделите в окне проекции траекторию, по которой будет происходить движение объекта.

Созданный объект переместится в начало пути (рис. 17.5).

6. В счетчике %Along Path (%Вдоль пути) группы Path Options (Свойства пути) установите начальное положение объекта в процентном отношении.

Значение, соответствующее началу пути равно 0, а концу пути — 100.

Рис. 17.5. Перемещения объекта в начало движения пути

7. Если вы хотите, чтобы объект менял свою ориентацию, отметьте флажок Follow (Следовать). Передвиньте ползунок таймера анимации на несколько кадров и проследите, как меняется ориентация объекта при перемещении по пути.

Изменение ориентации объекта показано на рис. 17.6. При перемещении по траектории в этом случае продольная ось объекта всегда будет направлена вдоль траектории. Переключатель Axis (Ось) в нижней части свитка определяет, какая из осей локальной системы координат объекта должна быть выровнена вдоль траектории, а также должна ли эта ось указывать вперед (флажок Flip (Перевернуть) сброшен) или назад (флажок установлен).

Рис. 17.6. Изменение ориентации объекта при установке параметра FIlow

8. Установите флажок Bank (Крениться). Передвиньте ползунок таймера анимации на несколько кадров и проследите, как меняется положение объекта.

Данная настройка заставит объект наклонятся на поворотах траектории. Если установлен режим крена, то можно задать величину крена в счетчике Bank Amount (Величина крена) и степень сглаженности в счетчике Smoothness (Гладкость). Изменение наклона объекта показано на рис. 17.7.

Рис. 17.7. Поворот объекта при движении в режиме крена

9. Установите флажок Constant Velocity (Постоянная скорость).

Положение объекта в последовательных кадрах станет равномерно распределяться по длине траектории

10. Включите режим анимации.

11. Самостоятельно осуществите просмотр через камеру созданного интерьера, задав ее движение по пути.

Движение по поверхности

Можно задать движение объекта по неровной поверхности другого объекта. При этом перемещаемый объект будет привязан к поверхности даже при ее деформации.

1. Постройте поверхность.

Неровную поверхность можно построить любым из известных вам способов. Например, с помощью модификатора Nois (Зашумление) (см. занятие 11) или используя один из видов объемной деформации (см. занятие 12).

2. Постройте сферу.

Она должна оставаться выделенной.

3. На командной панели выберите вкладку Motion (Движение).

В свитке Assign Controller (Назначить контроллер) выделите строку Position (Положение) и щелкните LM на кнопке Assign Controller (Назначить контроллер) над списком.

4. В открывшемся окне контроллеров выберите значение Attachment (Прикрепление).

5. В свитке Attachment Parameters (Параметры прикрепления) щелкните на кнопке Pick Object (Указать объект) и далее щелкните LM на поверхности.

Сфера, как ведомый объект, переберется теперь на поверхность в указанную точку. Если будет установлен флажок Align To Surface (Выровнять по поверхности), то локальная ось Z ведомого объекта будет выровнена вдоль нормали к поверхности ведущего объекта.

6. Чтобы задать место на поверхности ведущего объекта, к которому должна быть прикреплена сфера, щелкните на кнопке Set Position (Задать положение) в группе Position (Положение) свитка, а затем щелкните LM на сфере и перетащите курсор в нужное место.

7. Для анимации положения сферы на поверхности перейдите на другой кадр, передвинув ползунок анимации, снова щелкните на кнопке Set Position (Задать положение) и укажите новое место размещения сферы на поверхности.

Чтобы линия траектории движения сферы по поверхности была видна, щелкните на кнопке Trajectories (Траектория) в верхней части командной панели Motion (Движение).

На рис. 17.8 показана линия траектории движения сферы по поверхности.

Между двумя ключевыми точками объект будет двигаться по прямой, не следуя изгибам поверхности.

Рис. 17.8. Траектория перемещения объекта по неровной поверхности


Деформация

Силовая деформация

Деформация Gravity

Деформация Wind

Деформация РВотЬ

Деформация PathFollow

Деформация Push

Деформация Motor

Деформация отражения

Деформация Deflector

Деформация на базе модификаторов

Силовая деформация

Деформации раздела Forces (Силовые) оказывают силовое воздействие на системы частиц, изменяя их динамику. Они имитируют влияние природных явлений, таких как гравитация, ветер, или искусственно созданных силовых эффектов, например, взрыв или направленное давление.

Деформация Gravity

Выполните следующие шаги:

1. Создайте источник частиц типа Super Spray (Супербрызги).

Порядок создания источников частиц рассматривался на предыдущем занятии.

2. Щелкните LM на кнопке Space Warps (Объемные деформации) командной панели и выберите в списке категорий деформации значение Forces (Силовые).

3. В свитке Object Type (Тип объекта) нажмите кнопку Gravity (Гравитация).

4. В окне проекции щелкните в точке, где должен размещаться центр воздействия, и перетащите курсор по диагонали.

Появится прямоугольный значок с нормалью-стрелкой, указывающей направление воздействия. Стрелка значка Gravity (Гравитация) по умолчанию направлена вниз.

5. Разместите значок гравитации под системой частиц.

6. Свяжите источник деформации с системой частиц, которая должна находиться под влиянием силы тяжести, с помощью кнопки команды Bind to Space Warp (Связать с воздействием) панели инструментов

7. Перейдите на командную панель Modify (Изменить) и настройте параметры деформации гравитации в свитке Parameters (Параметры):

· Strength (Сила) — счетчик задает силу гравитации на частицы (параметр может быть как больше, так и меньше нуля);

· Decay (Затухание) — счетчик определяет степень уменьшения силы воздействия по мере удаления от источника;

· Planar (Плоский фронт) — переключатель устанавливает плоскую форму фронта поля силы тяжести, при котором воздействие происходит только в направлении стрелки значка;

· Spherical (Сферический фронт) — переключатель задает сферическую форму фронта поля силы тяжести, при котором воздействие происходит в радиальных направлениях.

На рис. 19.1 показан пример воздействия силы тяжести на систему частиц.

Рис. 19.1. Воздействие силы тяжести на систему частиц

Деформация Wind

Порядок построения и параметры настройки деформации типа Wind (Ветер) аналогичны рассмотренным выше. Сцену воздействия ветра на систему частиц постройте самостоятельно.

Для деформации Wind (Ветер) дополнительно настройте следующие параметры:

· Turbulence (Турбулентность) — счетчик указывает степень турбулентности;

· Frequency (Частота) — счетчик устанавливает частоту, с которой будет производиться изменение положения частиц под действием турбулентности в ходе анимации;

· Scale (Масштаб) — счетчик задает масштаб проявления турбулентного поведения частиц под действием ветра. Когда масштаб возрастает, случайное поведение частиц становится более выраженным.

На рис. 19.2 показана система частиц, сдуваемая ветром.

Рис. 19.2. Системы частиц сдуваются ветром

Деформация РВотЬ

Деформация типа PBomb (Бомба для частиц) создает взрывную волну, разбрасывающую частицы.

1. Создайте источник частиц PCloud (Облако частиц) и сферу, которая станет объектом-источником частиц.

2. Выделите источник частиц. Перейдите на командную панель Modify(Изменить) и щелкните LM на кнопке Pick Object (Указать объект) в свитке Basic Parameters (Основные параметры). Далее, переведя курсор на рабочее поле, щелкните LM на сфере.

Теперь сфера стала источником частиц, на которые будет воздействовать деформация. Это легко проверить, передвинув ползунок таймера анимации.

3. В свитке типов объектов командной панели Create (Создать) при нажатой кнопке Space Warps (Объемная деформация) щелкните по кнопке PBomb (Бомба для частиц).

4. Щелкните LM в нужной точке окна проекции и перетащите курсор, растягивая изображение значка деформации.

По умолчанию значок имеет вид сферической бомбы, расположенной в центре сферы, обозначающей пределы зоны действия деформации (рис. 19.3).

5. Свяжите источник деформации с системой частиц, на которую должна воздействовать взрывная волна с помощью кнопки команды Bind to Space Warps (Связать с воздействием) панели инструментов.

6. Выделите источник деформации и, перейдя на командную панель Modify(Изменить), настройте параметры деформации в свитке Basic Parameters(Основные параметры). В группе Blast Symmetry (Симметрия взрывной волны) установите переключатель формы силового поля в одно из положений:

· Spherical (Сферическая) — ударная волна распространяется во все стороны от источника;

Рис. 19.3. Сфера как источник частиц и значок деформации типа PBomb

· Cylindrical (Цилиндрическая) — ударная волна распространяется в радиальных направлениях перпендикулярно вертикальной оси значка источника;

· Planar (Плоская) — ударная волна распространяется вверх и вниз перпендикулярно плоскости значка источника.

7. Для придания картине взрыва случайного характера, укажите в счетчике Chaos (Хаос) процент изменения силы взрывной волны для каждой частицы в каждом кадре.

8. В группе Explosion Parameters (Параметры взрыва) задайте характер ослабления силы взрыва, выбрав один из переключателей: Unlimited Range(Неограниченный диапазон). Linear (Линейный спад) или Exponential(Спад по экспоненте).

9. Укажите значения в счетчиках:

· Start Time (Время начала) — номер кадра начала воздействия;

· Duration (Продолжительность) — продолжительности действия деформации;

· Strength (Сила) — изменение скорости разлета частиц, выраженное в единицах длины на кадр и характеризующее силу взрыва.

На рис. 19.4 показано воздействие ударной волны на систему частиц. Параметры PBomb (Бомба для частиц) приведены на рис. 19.5.

Рис. 19.4. Модель частиц, отброшенных взрывом

Рис. 19.5. Значение параметров, построенной модели взрыва

Деформация PathFollow

Деформация типа Path Follow (Движение по траектории) заставляет частицы перемещаться по траектории, построенной как сплайн.

1. Создайте путь, состоящий из единого сплайна, и источник частиц типа SuperSpray (Супербрызги).

Этот путь будет играть роль траектории для частиц.

2. Нажмите кнопку Space Warps (Объемная деформация), а затем — кнопку Path Follow (Движение по траектории), щелкните в нужной точке окна проекции и перетащите курсор, растягивая изображение значка деформации.

3. В свитке Basic Parameters (Основные параметры) объемной деформации щелкните LM на кнопке Pick Shape Object (Указать объект-форму) и выделите построенный сплайн.

4. Свяжите источник деформации с источником частиц с помощью кнопки Bind to Space Warps (Связать с воздействием) панели инструментов.

5. Переместите ползунок таймера анимации.

Вы можете наблюдать, как частицы передвигаются по заданной траектории (рис. 19.6).

Рис. 19.6. Модель движения частиц по заданной траектории

Деформация Push

Деформация типа Push (Давление) оказывает направленное давление на поток частиц. Воздействие можно сделать периодическим или со случайным характером.

1. Установите объемную деформацию типа Push (Давление).

2. Свяжите источник деформации с источником частиц и настройте параметры деформации, перейдя на командную-панель Modify (Изменить):

· On Time (Время включено) и Off Time (Время выключено) — счетчики номера кадров, соответствующих моментам начала и окончания действия деформации;

· Basic Force (Базовое усилие) — сила давления, задаваемая либо в Ньютонах (Newtones), либо в единицах, либо в единицах, соответствующих весу тела массой в один фунт ( Pounds);

· Feedback On (Обратная связь включена) — при установке этого флажка сила воздействия убывает по мере приближения скорости частиц к пороговому значению, задаваемому в счетчике Target Speed (Предел скорости);

· Reversible (Обратимо) — если этот флажок установлен, то при превышении предела скорости частицами, находящимися под воздействием деформации, направление действия силы давления меняется на обратное;

· Gain (Усиление) — счетчик задает степень быстроты реакции обратной связи на достижение пороговой скорости. При 100% реакция наступает мгновенно.

3. В разделе Periodic Variations (Периодические изменения) установите флажок Enable (Разрешить), чтобы обеспечить пульсирующий характер давления.

Рис. 19.7. Пример деформации типа Push

Рис. 19.8. Параметры смоделированной деформации давления

4. Задайте нужные значения параметров двух суммирующихся колебаний в счетчиках Period 1 (Период 1), Period 2 (Период 2), Amplitude 1 (Амплитуда 1), Amplitude 2 (Амплитуда 2), Phase 1 (Фаза 1), Phase 2 (Фаза 2).

Это обеспечит псевдослучайный характер пульсации. Если обнулить период или амплитуду одного из двух колебаний, то пульсации будут иметь периодический характер. Этот вариант показан на рис. 19.7. Параметры деформации показаны на рис. 19.8.

Деформация Motor

Деформация типа Motor (Мотор) действует подобно рассмотренной выше деформации типа Push (Давление), но оказывает на поток частиц силовое воздействие, придающее им вращающий момент. При деформации потока частиц имеет значение как положение, так и ориентация значка деформации.

1. Создайте источник частиц и значок деформации типа Motor (Мотор).

2. Измените положение и ориентацию значка деформации, учитывая, что сила воздействия направлена вокруг оси мотора.

3. Свяжите источник деформации с источником частиц.

4. Перейдя на командную панель Modify (Изменить), выполните настройку деформации в свитке Parameters (Параметры).

Представленные здесь параметры в основном аналогичны соответствующим параметрам деформации Push (Давление), за исключением следующих:

· Basic Torque (Базовый момент) — вращающий момент, задаваемый в Ньтон-метрах (N-m), фунт-футах ( Lb- ft) или фунт-дюймах ( Lb- in);

· Target Revs (Предел вращения) — пороговое значение скорости вращения частиц, после которого вступает в действие обратная связь с источником деформации. Задается в оборотах в час ( RPH), в минуту ( RPM) или в секунду ( RPS).

На рис. 19.9 показан пример деформации типа Motor (Мотор).

Рис. 19.9. Пример деформации типа Motor

Деформация отражения

Объемная деформация типа Deflectors (Отражатели) используется как отражатель потока частиц для изменения направления их движения.

Деформация Deflector

Деформация такого вида представляется в виде щита, от которого отражаются потоки частиц.

1. Создайте источник частиц.

2. После нажатия кнопки Space Warps(Объемная деформация) в списке укажите значение Deflectors (Отражатели) и нажмите кнопку Deflector(Отражатель), щелчком LM в окне проекции разместите значок отражателя и, перетаскивая курсор, растяните его до нужных размеров.

3. Свяжите источник деформации с источником частиц.

4. Перейдите на командную панель Modify (Изменить) и настройте параметры деформации в свитке Parameters (Параметры):

· Bounce (Отскок) — счетчик определяет силу отскока частицы от отражателя. Величина 1 означает, что отраженная частица сохраняет скорость, с которой она ударилась об отражатель. При значении 0 вся энергия гасится отражателем и частицы прилипают к нему.

· Width (Ширина) и Height (Высота) — счетчики задают размеры значка отражателя.

5. Переместите ползунок таймера анимации, чтобы увидеть действие отражателя на поток частиц.

Пример работы отражателя показан на рис. 19.10.

Рис. 19.10. Модель отражения частиц от препятствия

Отражать частицы может любой объект сцены. С этой целью используется деформация типа UDeflector (U-отражатель).

6. Замените деформацию Deflector (Отражатель) на деформацию типа UDeflector (U-отражатель) и постройте в качестве отражателя частиц тороидальный узел ( Torus Knot).

7. В свитке Basic Parameters (Основные параметры) объемной деформации щелкните LM на кнопке Pick Object (Указать объект) и выделите тороидальный узел ( Torus Knot) как объект-отражатель.

8. Свяжите источник деформации с источником частиц.

9. Перейдя на командную панель Modify (Изменить), настройте параметры деформации в свитке Basic Parameters (Основные параметры):

· Bounce (Отскок) — имеет тот же смысл, что и у рассмотренной выше деформации Deflector (Отражатель);

· Variation (Вариации) — степень изменений параметра Bounce (Отскок) для каждой Отдельной частицы;

· Chaos (Хаос) — степень изменения угла отскока;

· Friction (Трение) — задает степень "прилипания" частиц к поверхности объекта в момент отскока;

· Inherit Vel (Наследование скорости) — при значении, большем 0, движение отражателя будет сказываться на движении частиц.

На рис. 19.11 показано отражение частиц от объекта произвольной геометрии.

Рис. 19.11. Отражение частиц от тороидального узла

Остальные виды отражателей похожи по своему воздействию на рассмотренные выше.

Деформация на базе модификаторов

Объемную деформацию раздела Modifier- Based (На базе модификаторов) повторяют модификаторы формы объектов, представленные в группе Parametric Modifiers (Параметрические модификаторы) командной панели Modify (Изменить). Отличие состоит в том, что если к объекту применен модификатор формы, то при изменении положения или поворота объекта модификация формы сохраняется. После применения объемной деформации на базе модификатора действие распространяется только на определенную область пространства. При смене положения или ориентации объекта действие деформации меняется, причем объект может вообще выйти за пределы "силового поля" деформации.


Деформация моделей, построенных методом лофтинга

Кривые деформации

Кнопки управления панелью кривой деформации

Редактирование масштаба

Деформация скрутки

Деформация качки

Деформация скоса

Деформация подгонки

Дополнения к сцене интерьера

Присоединение файла к сцене

Стандартный метод лофтинга более эффективен при моделировании объектов со сложной геометрией. Но даже полностью смоделированная оболочка часто требует различного рода редактирования. На этом занятии мы рассмотрим способы модификации лофтинг-оболочки, которые сведены в пять разделов:

Scale (Масштаб), Twist (Скрутка),. Teeter (Качка), Bevel (Скос), Fit (Подгонка).

1. Загрузите объект, созданный ранее методом лофтинга. Для этого в меню File (Файл) выберите команду Open (Открыть).

В появившемся диалоговом окне укажите требуемый файл и нажмите кнопку Open (Открыть).

После выполнения команды на рабочем экране появится созданная вами модель.

Рис. 9.1. Свиток инструментов информации

2. В окне Perspective (Перспектива) выделите лофтинг-модель и перейдите на командную панель Modify (Изменить).

3. Разверните свиток Deformation (Деформация), расположенный в самом низу командной панели и щелкните LM на любой из кнопок инструментов деформации, показанных на рис. 9.1.

На экране появится диалоговое окно Deformation (Деформация), подобное приведенному на рис. 9.2. Прежде, чем перейти к изучению способов деформации, рассмотрим содержимое этого окна.

Рис. 9.2. Диалоговое окно деформации

Кривые деформации

На сетке диаграммы деформации находится линия красного цвета. Эта линия, называемая кривой деформации, является графиком величины деформации сечения в зависимости от координат пути, вдоль которого строится оболочка объекта. Кривая имеет на концах два маркера, называемых управляющими точками. На кривой деформации можно создать любое количество управляющих точек или удалить лишние. Каждая точка позволяет регулировать величину деформации в сечении, расположенном на заданном расстоянии от начала пути. Управляющие точки можно перемещать, используя инструменты панели управления окна диаграммы деформации, чтобы придать кривой ту форму, которая необходима.

Сверху над сеткой диаграммы находится относительная шкала расстояния. Координаты положения управляющих точек вдоль линии пути, на котором размещаются сечения, указываются на диаграмме в процентах расстояния от начала этого пути.

Слева от сетки диаграммы находится шкала значений. Градуировка этой шкалы зависит от типа деформации и позволяет оценить степень деформации сечения в любой точке вдоль размещения сечений.

Кнопки управления панелью кривой деформации

В верхней части окна расположены следующие кнопки.

Make Symmetrical (Симметрично по Х и Y). Инструменты деформации могут применяться как относительно оси X, так и Y (считается, что оси Х и Y направлены перпендикулярно линии пути, в направлении которой ориентирована ось Z). Щелчок LM на данной кнопке заставляет одну и ту же деформацию действовать относительно обеих осей.

Display Х /Y/XY Axis (Показать деформации по Х /Y/XY). При нажатии одной из этих кнопок в сетке диаграммы изображается кривая деформации относительно оси Х (линией красного цвета), оси Y (зеленого цвета) или обе кривые одновременно.

Swap deform Curves (Поменять кривые деформации). Щелчок LM на данной кнопке меняет местами кривые деформации по осям Х и Y. Эта кнопка доступна только тогда, когда выключен режим Make Symmetrical (Симметрично по Х и Y).

Move Control Point (Переместить управляющую точку). Позволяет переместить управляющую точку кривой деформации в другое место на диаграмме. На раскрывающейся панели данной кнопки находятся два дополнительных инструмента, которые позволяют перемещать управляющие точки только по горизонтали или только по вертикали.

Scale Control Point (Пропорциональное управление). Включает режим пропорционального перемещения управляющей точки, при котором она перемещается на меньшее расстояние, чем курсор мыши, для обеспечения большей точности настройки кривой деформации.

Insert Corner Point (Вставить угловую точку). Позволяет вставить новую точку излома в любом месте кривой деформации. На раскрывающейся панели инструментов есть кнопка Insert Bezier Point (Вставить точку Безье). Управляющая точка Безье позволяет контролировать кривизну линии деформации в окрестности данной точки.

Delete Control Point (Удалить управляющую точку). Позволяет удалить любые управляющие точки кривой деформации, кроме первой и последней. Сначала следует выделить управляющую точку, а затем щелкнуть LM на данной кнопке.

Reset Curve (Исходная кривая). Возвращает кривую деформации к исходному виду, принятому по умолчанию для кривых данного типа. В нижней части окна расположены следующие кнопки, используемые для управления видом диаграммы.

Pan (Прокрутка). Позволяет выполнять прокрутку изображения кривой деформации в окне диаграммы.

Zoom extends (Кривая целиком), Zoom Horizontal/Vertical Extents (Целиком по горизонтали/По вертикали). Изменяют масштаб в окне диаграммы, подгоняя его под границы кривой деформации по обеим осям либо только по горизонтали или вертикали.

Zoom Horizontally/Vertically (Масштаб по горизонтали/По вертикали). Позволяют сжать или растянуть горизонтальную (вертикальную) шкалу окна диаграммы так, чтобы в окне наблюдалась часть кривой деформации. Для изменения масштаба после щелчка на кнопке в окне диаграммы щелкните в окне диаграммы и перетаскивайте мышь вправо или влево (вверх или вниз).

Zoom (Масштаб), Zoom Region (Масштаб области). Кнопки изменения масштаба изображения в окне диаграммы, действующие аналогично таким же кнопкам управления окнами проекции.

Редактирование масштаба

Выполните следующие шаги:

1. В развернутом свитке Deformation (Деформация), расположенном в самом низу командной панели, выберите кнопку Scale (Масштаб).

На экране появится окно диаграммы деформации масштаба. Деформация масштаба позволяет менять размер сечения в зависимости от координаты пути, вдоль которого строится оболочка объекта.

Кривая деформации масштаба представляет собой линию продольного сечения объекта.

Рис. 9.3. Кривая деформации с дополнительными точками

2. С помощью кнопки Insert Corner Point (Вставить угловую точку) вставьте простые дополнительные точки и точки Безье, как показано на рис. 9.3. |
3. Используя кнопку Move Control Point (Переместить управляющую точку), измените кривую масштаба. | *

Закройте окно диалога, щелкнув LM на пиктограмме "крест" в правом верхнем углу. Результаты редактирования размеров сечения показаны на рис. 9.4.

Рис. 9.4. Результат деформации масштаба объекта

Деформация скрутки

Деформация скрутки заставляет форму-сечение разворачиваться в плоскости, перпендикулярной линии пути, вдоль которого строится трехмерная оболочка.

1. Щелкните LM на кнопке Twist (Скрутка). Вставьте дополнительные точки деформации, как показано на рис. 9.5.

Рис. 9.5. Кривая скрутки

2. Используя кнопку Move Control Point (Переместить управляющую точку), разверните сечение.

Результат поворота сечения показан на рис. 9.6.

Рис. 9.6. Деформация объекта, соответствующая кривой скрутки

Деформация качки

Деформация качки (Teeter) вызывает поворот формы-сечения относительно осей, перпендикулярных линии пути, либо наклоняя сечение вперед или назад, либо поворачивая его вперед левым или правым боком.

1. Щелкните LM на кнопке Teeter (Качка). Вставьте дополнительную точку Безье, как показано на рис. 9.7.

Рис. 9.7. Кривая деформации качки

2. Активизируйте кнопку, позволяющую показать деформацию по X, и измените кривую деформации.

Результат поворота сечения показан на рис. 9.8.

Рис. 9.8. Объект, подвергнутый деформации качки

Деформация скоса

Деформация скоса (Bevel) как и деформация масштаба вызывает изменение размеров сечений по мере продвижения вдоль линии пути. Однако, в отличие от деформации масштаба, деформация скоса оказывает противоположное действие на внешние и внутренние контуры форм-сечений, имеющих отверстия: если внешний контур уменьшается, то внутренний увеличивается, и наоборот.

Построим лофтинг-объект с помощью сечения, имеющего внешний и внутренний контур.

1. На командной панели Create (Создать) нажмите кнопку Shapes (Формы), а затем нажмите кнопку Text (Текст) и в качестве формы-сечения создайте букву О. Для указания пути создайте отрезок прямой.

Построенный с таким сечением лофтинг-объект показан на рис. 9.9.

Рис. 9.9. Исходный лофтинг-объект

2. Перейдите на панель Modify (Изменить) и щелкните на кнопке Bevel (Скос).

3. Переместите конечные маркеры кривой деформации, как показано на рис. 9.10.

Рис. 9.10. Кривая деформаций скоса

Блокировка параметров Make Symmetrical (Симметрично по Х и Y) и Display Х/Y/XY Axis (Показать деформации по Х /Y/XY) необходима, т. к. эта деформация по определению применяется симметрично по отношению к обеим осям деформации. Данный тип деформации очень чувствителен к величине скоса: чрезмерно большие значения этого параметра ведут к искажению формы объекта. Результат использования деформации скоса показан на рис. 9.11.

Рис. 9.11. Результат деформации скоса лофтинг-объекта

Деформация подгонки

Деформация Fit (Подгонка) позволяет редактировать лофтинг-модель таким образом, чтобы ее проекции соответствовали заданным плоским формам.

Рассмотрим сначала назначения нескольких дополнительных кнопок на панели инструментов окна диалога Fit Deformation (Деформация подгонки):

Mirror HorizontaIl/Vertically (Отразить по горизонтали/вертикали) — зеркально отражает профиль проекции в окне диаграммы деформации на 90° по часовой стрелке (против часовой стрелки);

Rotate 90 CW/CCW (Повернуть на 90° по часовой стрелке/против часовой стрелки) — поворачивает профиль проекции в окне диаграммы деформации;

Delete Curve (Удалить кривую) — удаляет выделенный профиль проекции в окне диаграммы деформации;

Get Shape (Взять форму) — позволяет выбрать замкнутую двумерную кривую в качестве профиля для подгонки формы сечения трехмерного объекта в направлении выбранной оси локальной системы координат;

Generate Path (Создать путь) — автоматически выполняет генерацию нового пути, вдоль которого будет построена оболочка объекта, таким образом, чтобы этот путь в большей мере соответствовал заданным профилям проекции.

В нижней части окна диалога Fit Deformation (Деформация подгонки) появилась новая кнопка Lock Aspect (Сохранить пропорции). Она поддерживает правильные пропорции формы-профиля при изменении масштаба изображения в окне диаграммы деформации. Если этот режим не включен, то вертикальная шкала окна градуируется в абсолютных единицах размера формы, а горизонтальная — в процентах расстояния от начала пути, вдоль которого строится оболочка объекта. В результате пропорции формы-профиля могут быть нарушены.

Рассмотрим моделирование корпуса скрипки методом деформации подгонки.

1. Перейдите в окно проекции Тор (Вид сверху).

Здесь будут создаваться заготовки для метода подгонки: контуры продольного и поперечных сечений. Продольное — вдоль плоскости XY и поперечные — по осям Х и Y. Контуры сечений можно строить с помощью сплайнов или NURBS-кривых.

2. На командной панели Create (Создать) нажмите кнопку Shapes (Формы), а затем нажмите кнопку Splines (Сплайны) и постройте контуры сечений и путь, как показано на рис. 9.12.

Проверьте замкнутость контуров форм-сечений.

Постройте основу методом лофтинга, взяв в качестве формы продольное сечение (рис. 9.13).

Рис. 9.12. Формы-сечения и путь для моделирования объекта методом подгонки

Рис. 9.13. Основа, созданная методом лофтинга

3. Щелкните на кнопке Fit (Подгонка) в свитке Deformation (Деформация)

4. В появившемся окне диалога отключите режим "симметрично по Х и Y", щелкнув LM на кнопке Make Symmetrical (Симметрично по Х и Y).

5. Щелкните LM на кнопке Display Х Axis (Показать деформацию по X).

6. Щелкните LM на кнопке Get Shape (Взять форму) и выделите контур поперечного сечения.

Используя кнопки отражения и поворота, придайте форме нужное положение. Следите за изменением объекта в окнах проекции.

7. Пользуясь инструментами окна деформации подгонки, скорректируйте форму контура сечения.

Готовая форма сечения показана на рис. 9.14, окончательно смоделированный объект — на рис. 9.15.

Рис. 9.14. Кривая деформации подгонки поперечного сечения

Рис. 9.15. Окончательно смоделированный методом подгонки объект

Дополнения к сцене интерьера

Используя метод лофтинга и рассмотренные выше средства модификации, смоделируйте водопроводный кран для сцены интерьера, созданной в разделах четвертого занятия.

1. На командной панели Create (Создать) нажмите кнопку Shapes (Формы), а затем нажмите кнопку Donut (Кольцо). Постройте кольцо в окне проекции Тор (Вид сверху).

Создана форма-сечение для крана (рис. 9.16, а).

2. Таким же образом создайте:

· Ngon (Многоугольник), как путь для ручки (рис. 9.16, б);

· Circle (Окружность), как форму-сечение для ручки (рис. 9.16, в).

Рис. 9.16. Заготовки для лофтинг-моделей

3. На командной панели Create (Создать) нажмите кнопку Shapes (Формы), нажмите кнопку NURBS Curves (NURBS-кривые), а затем — Point Curve (Точечная кривая) и создайте путь для крана (рис. 9.16, г).

4. Создайте лофтинг-модель крана, установив значение счетчика Path Steps (Шагов пути) в разделе Options (Параметры) не менее 24.

Напомним, что величина этого параметра влияет на степень сглаженности оболочки.

5. Выберите на командной панели Modify (Изменить) элемент Deformation (Деформации), а затем Scale (Масштаб).

Настроенная кривая масштаба для крана показана на рис. 9.17. Готовая модель крана — на рис. 9.18.

6. Создайте лофтинг-модель ручки, выбрав пятиугольник в качестве пути и окружность в качестве формы-сечения.

7. Кнопку для ручки можно создать из конуса, использовав команду неравномерного масштабирования.

Готовая модель ручки показана на рис. 9.19.

Рис. 9.17. Кривая масштаба для крана

Рис. 9.18. Лофтинг-модель крана

Рис. 9.19. Лофтинг-модель ручки

8. Отмасштабируйте пропорционально оба объекта и создайте дубликат ручки.

Скомпонуйте построенные объекты в созданном ранее интерьере.

Присоединение файла к сцене

Выполните шаги:

1. Выберите в меню File (Файл) команду Merge (Присоединить).

Появится диалоговое окно Merge File (Присоединение файла), не отличающееся от типового окна открытия файла.

Рис. 9.20. Диалоговое окно команды присоединения

2. Укажите файл интерьера и нажмите кнопку Open (Открыть).

Появится диалоговое окно Merge (Присоединить), показанное на рис. 9.20.

3. Выделите в списке окна объекты сцены, требующие присоединения и щелкните на кнопке ОК.

К текущей сцене с деталями крана присоединятся объекты интерьера.

4. Скомпонуйте в интерьере детали крана..


Имитация внешней среды

Настройка цвета фона

Подбор текстуры в качестве фона сцены

Общая освещенность сцены

Выбор эффектов атмосферных явлений

Габаритные контейнеры для атмосферных эффектов

Эффект горения

Объемное освещение

В этом занятии мы рассмотрим возможности создания фона сцены, имитирующего реальную внешнюю среду: пейзаж, архитектурный ландшафт. Ее можно приправить свойственными природе явлениями, такими как дымка, туман. Имитация природных эффектов дает реальное ощущение пространства и правдоподобия сцены.

Выберите в меню Rendering (Визуализация) команду Environment (Окружение). Появится диалоговое окно Environment (Окружение), которое содержит два свитка: Common Parameters (Общие параметры) с группами Background (Фон) и Global Lighting (Общая освещенность), и Atmosphere (Атмосфера).

Настройка цвета фона

Для настройки цвета фона выполните следующие шаги:

1. Щелкните LM в области Color (Цвет) группы Background (Фон).

2. В появившемся окне Color Selector: Background Color (Выбор цвета: Фон) задайте цвет фона.

3. Выполните визуализацию сцены.

Фон сцены будет окрашен в выбранный цвет.

4. Вернитесь в группу Background (Фон) и отметьте флажок Use Map (Использовать карту текстур).

Подбор текстуры в качестве фона сцены

Применение карт текстур позволяет создать практически любой фон сцены. Для имитации фона сцены можно использовать такие карты текстур, как Bitmap (Растровая карта), Gradient (Градиентная), Mask (Маска) и т. п.

Выбор типа карты текстур и ее применение можно провести двумя способами. Первый способ предполагает использование редактора материалов.

1. Раскройте окно редактора материалов и щелкните LM на кнопке Get Material (Получить материал).

2. В появившемся окне диалога Material/ Map Browser (Просмотр материалов и карт текстур) щелкните два раза LM на наименовании нужного типа карты текстуры.

В результате карта текстуры будет загружена в ячейку образца.

3. Настройте характеристики выбранной текстуры.

Настройка параметров карт текстуры внешней среды производится так же, как и любые другие типы карт.

4. Перетащите текстуру из ячейки образца в диалоговое окно Environment(Окружение) и положите поверх кнопки Environment Map (Карта текстуры фона).

Как только кнопка мыши будет отпущена, появится диалоговое окно Instance ( Copy) Map (Создать образец (копию) карты).

5. Установите переключатель Method (Метод) в положение Instance (Образец) и щелкните на кнопке ОК.

Второй способ начинается с окна диалога Environment (Окружение).

1. Щелкните LM на кнопке Environment Map (Карта текстуры фона) в группе Background (Фон).

Появится диалоговое окно Material/ Map Browser (Просмотр материалов и карт текстур).

2. Щелкните дважды LM на наименовании нужного типа карты.

Наименование типа карты появится на кнопке Environment Map (Карта текстуры фона).

Для настройки текстурной карты или для выбора файла растрового изображения при использовании карты типа Bitmap (Растровая карта) загрузите выбранную карту в одну из ячеек образцов окна редактора материалов.

3. С этой целью снова щелкните на кнопке Environment Map (Карта текстуры фона) с надписью, указывающей на тип выбранной текстуры, и перетащите курсор в свободную ячейку образца редактора материалов.

Как только кнопка мыши будет отпущена, появится диалоговое окно Instance ( Copy) Map (Создать образец (копию) карты), в которой следует установить переключатель Method (Метод) в положение Instance (Образец).

Для проецирования текстур на фон сцены необходимо установить переключатель варианта использования проекционных координат, расположенный в верхней части свитка Coordinates (Координаты) редактора материалов, в положение Environ (Фоновые) и выбрать один из четырех типов фоновых проекционных координат в раскрывшемся списке Mapping (Проекция):

· Spherical (Сферические) — обеспечивает нанесение карты растровой текстуры фона на внутреннюю поверхность воображаемой сферы бесконечно большого радиуса;

· Cylindrical (Цилиндрические) — обеспечивает проецирование карты текстуры фона на внутреннюю поверхность охватывающего сцену воображаемого цилиндра бесконечно больших размеров;

· Shrink Wrap (Обтягивающая) — обеспечивает проецирование карты текстуры фона на внутреннюю поверхность воображаемой сферы бесконечно большого радиуса. При этом в отличие от сферического проецирования все четыре угла текстуры карты стягиваются к одному из полюсов сферы;

· Screen (Экранная) — позволяет использовать текстуру в качестве обычного плоского фона, привязанного к окну проекции. При переключении окна на другую проекцию сцены фон в окне не меняется. Данная система координат удобна только для визуализации неподвижных кадров. Пример использования растровой текстуры в качестве фона в экранной системе координат приведен на рис. 16.1.

Рис. 16.1. Растровая текстура фона В экранной системе координат

После того как тип системы проекционных координат выбран, установка текстуры фона закончена. Созданный фон станет использоваться при визуализации до тех пор, пока не будет сброшен флажок Use Map (Использовать карту текстур) в группе Background (Фон) диалогового окна Environment (Окружение).

4. Чтобы растровая текстура, выбранная в качестве фона сцены, была видна в окнах проекции, выберите в меню Views (Проекции) команду Viewport Background (Фон окна проекции) и установите флажок Use Environment Background (Использовать фон внешней среды) в группе Background Source (Источник фона) диалогового окна Viewport Background (Фон окна проекции).

Общая освещенность сцены

Группа Global Lighting (Общая освещенность) диалогового окна Environment

(Окружение) содержит элементы управления освещенностью.

1. Щелкните LM в области Ambient (Подсветка), чтобы вызвать диалоговое окно Color Selector: Ambient Light (Выбор цвета: Подсветка), и настройте цвет и интенсивность подсветки.

2. Щелкните LM в области Tint (Оттенок), чтобы вызвать диалоговое окно Color Selector: Global Tint (Выбор цвета: Оттенок) и настройте цвет и интенсивность оттенка.

Цвет оттенка подкрашивает все огни сцены, за исключением подсветки. Этот параметр допускает анимацию. По умолчанию цвет Tint (Оттенок) — белый.

3. Установите значение счетчика Level (Уровень).

Этот параметр действует как усилитель по отношению ко всем источникам света, кроме подсветки. Значение 1 в счетчике сохраняет нормальные уровни всех огней. Более высокие — усиливают освещение.

Выбор эффектов атмосферных явлений

Параметры свитка Atmosphere (Атмосфера) диалогового окна Environment

(Окружение) позволяют выбирать типы атмосферных явлений и управлять их визуализацией.

1. Для выбора атмосферных явлений щелкните LM на кнопке Add (Добавит) свитка Atmosphere (Атмосфера) окна диалога Environment (Окружение).

Появится диалоговое окно Add Atmospheric Effects (Добавление атмосферного эффекта), в котором перечислены все типы атмосферных явлений, реализуемые пакетом. Стандартные модули позволяют имитировать четыре типа атмосферных явлений: горение ( Fire Effect), однородный туман или дымку (Fog), объемный туман ( Volume Fog) и объемное освещение ( Volume Light).

2. Выделите строку атмосферного явления нужного типа и щелкните LM на кнопке ОК.

Наименование выбранного эффекта добавится в список Effects (Эффекты) свитка Atmosphere (Атмосфера), а в нижней части окна диалога Environment (Окружение) появится свиток параметров эффекта.

3. Аналогичным способом добавьте в список эффектов другие типы атмосферных явлений.

Все включенные в список эффекты будут добавлены на этапе визуализации сцены в порядке очередности, сверху вниз по списку.

Для управления составом атмосферных явлений в свитке Atmosphere (Атмосфера) представлены следующие элементы управления:

· Delete (Удалить) — кнопка удаляет выделенные атмосферные эффекты из списка;

· Active (Активен) — флажок позволяет включать и выключать действие каждого отдельного эффекта списка. Исключенный эффект не будет визуализироваться;

· Move Up (Переместить вверх) и Move Down (Переместить вниз) — кнопки перемещают строку выделенного эффекта вверх или вниз по списку, изменяя порядок визуализации эффектов;

· Merge (Присоединить) — кнопка дает возможность присоединить к текущей сцене атмосферные эффекты из других сцен, вызывая диалоговое окно Merge Atmospheric Effects (Присоединение атмосферных эффектов);

· Name (Имя) — текстовое поле, позволяющее переименовывать любой эффект в списке.

· Для наблюдения атмосферного эффекта любого типа сцена должна визуализироваться в окне проекций Perspective (Перспектива) или Camera (Камера).

Габаритные контейнеры для атмосферных эффектов

Для некоторых типов атмосферных эффектов, таких как туман, горение, требуется задать границы пространства, в которых этот эффект проявляется. В этом случае используется специальный габаритный контейнер. Он представляет собой вспомогательный объект сцены, не участвующий в визуализации.

1. На командной панели Create (Создать) щелкните LM на кнопке Helpers(Вспомогательные объекты) и выберите в списке разновидностей объектов вариант Atmospheric Apparatus (Атмосферная оснастка).

Набор элементов управления свитка Object Type (Тип объекта) состоит из трех кнопок типов габаритных контейнеров: в виде параллелепипеда ( BoxGizmo), цилиндра ( CylGizmo) и сферы ( SphereGizmo) (рис. 16.2).

2. Создайте габаритный контейнер любого из приведенных типов. Они формируются так же, как аналогичные фигуры из раздела геометрии.

Свитки параметров всех трех типов контейнеров содержат счетчики задания их геометрических размеров, как и аналогичные примитивы из раздела геометрия, а так же два дополнительных параметра:

· Seed (Номер выборки) — счетчик задает номер случайной выборки параметров объемного тумана или горения. Разным номерам выборок соответствуют различные на вид проявления атмосферных эффектов;

· New Seed (Новая выборка) — кнопка генерирует случайное значение параметра Seed (Номер выборки).

Рис. 16.2. Типы габаритных контейнеров

3. Создав габаритный контейнер, примените к нему при необходимости требуемые преобразования (перемещение, поворот и т. д.).

Осуществляя преобразование неравномерного масштабирования для контейнера, можно сжать или растянуть область проявления атмосферного эффекта.

Эффект горения

Для создания эффекта горения можно применить габаритный контейнер атмосферного эффекта.

1. Создайте габаритный контейнер формы, показанной на рис. 16.3.

2. Вызовите диалоговое окно Environment (Окружение), щелкните LM на кнопке Add (Добавить) свитка Atmosphere (Атмосфера) и выберите строку Fire Effect (Горение) в окне диалога Add Atmospheric Effect (Добавление атмосферного эффекта).

В нижней части диалогового окна диалог Environment (Окружение) появятся параметры настройки эффекта горения.

3. Щелкните LM на кнопке Pick Gizmo (Указать контейнер).

После этого включается режим выбора габаритного контейнера.

4. Щелкните LM на построенном габаритном контейнере.

Один и тот же атмосферный эффект может быть применен к различным габаритным контейнерам. Кроме того, одному и тому же габаритному контейнеру могут быть назначены различные типы атмосферных эффектов.

Рис. 16.3. Габаритный контейнер для эффекта горения

5. Чтобы указать несколько габаритных контейнеров, следует щелкнуть LM на кнопке Pick Gizmo (Указать контейнер), а затем нажать клавишу <Н>.

Появится диалоговое окно Pick Object (Выделение объекта) (рис. 16.4), с помощью которого можно выбрать любое количество созданных габаритных контейнеров.

Рис. 16.4. Диалоговое окно для выделения группы объектов

6. Настройте цвета компонентов пламени в группе Colors (Цвета):

· Inner Color (Внутренний цвет) — образец цвета внутренней части пламени;

· Outer Color (Наружный цвет) — образец цвета наружной части пламени;

· Smoke Color (Цвет дыма) — образец цвета дыма при имитации вспышки взрыва.

7. Установите переключатель Flame Type (Тип пламени) в разделе Shape(Форма) в одно из двух положений:

· Tendril (Язык) — генерирует языки пламени, заостренные на концах;

· FireBall (Огненный шар) — моделирует округлые области огня.

8. Настройте параметры типа пламени в группе Shape (Фигура):

· Stretch (Растяжение) — счетчик задает длину отдельных языков пламени;

· Regularity (Регулярность) — счетчик определяет, в какой степени область горения будет заполнять габаритный контейнер. Уменьшение величины параметра заставляет пламя отодвигаться от краев контейнера.

9. Настройте характеристики пламени в группе Characteristics (Характеристики):

· Flame Size (Размер пламени) — счетчик задает размер отдельных вихрей пламени в пределах габаритного контейнера. Этот параметр не влияет на общий размер области эффекта, определяемый габаритами контейнера;

· Flame Detail (Детализация пламени) — счетчик определяет крутизну перепадов между участками различного цвета в пределах области горения;

Рис. 16.5. Имитация эффекта горения

· Density (Плотность) — счетчик задает степень непрозрачности и общую яркость пламени;

· Samples (Частота выборки) — счетчик задает частоту дискрета области горения. Большие значения частоты выборки обеспечивают более высокую точность эффекта горения, но ведут к увеличению времени визуализации.

10. При анимации горения следует выставить ненулевые значения счетчиков Drift (Дрейф) и Phase (Фаза).

Пример эффекта горения приведен на рис. 16.5.

Объемное освещение

Имитация объемного освещения создается при прохождении света через атмосферу тумана. Пример объемного освещения показан на рис. 16.6. Для создания эффекта объемного освещения построим объект, расставим источники света и зададим режим объемного освещения в свитке Atmosphere(Атмосфера).

1. Создайте несколько текстовых символов, нажав на командной панели Create (Создать) кнопку Shapes (Форма), выбрав в списке вариант Splines(Сплайны) и нажав кнопку Text (Текст).

2. Созданные символы сделайте объемными, воспользовавшись методом лофтинга.

Рис. 16.6. Пример объемного освещения

3. С помощью булевской операции вычитания сделайте вырез на плоскости прямоугольника по контурам букв, как показано на рис. 16.7.

Рис. 16.7. Заготовка для моделирования объемного освещения

4. Создайте источник направленного света и задайте параметры Cast Shadows(Отбрасывать тень) и Shadow Maps (Применять параметры тени).

5. Вызовите окно Environment (Окружение), разверните свиток Atmosphere(Атмосфера), щелкните LM на кнопке Add (Добавить) и выберите строку Volume Light (Объемное освещение) в диалоговом окне Add Atmospheric Effect (Добавление атмосферного эффекта).

В нижней части диалогового окна Environment (Окружение) появится свиток Volume Light Parameters (Параметры объемного освещения), подобный представленному на рис. 16.8.

6. Для добавления эффекта объемного освещения, в разделе Lights (Источники света) свитка щелкните LM на кнопке Pick Light (Указать источник) и выделите источник света.

Выбранные источники света будут занесены в раскрывающийся список справа от кнопки Pick Light (Указать источник).

Один и тот же эффект объемного освещения можно применить к нескольким источникам света. Чтобы указать несколько источников света, щелкните на кнопке Pick Light (Указать источник), а затем нажмите клавишу <Н>. Появится диалоговое окно Pick Object (Выделение объекта), с помощью которого можно выбрать несколько источников света.

Чтобы удалить источник света из списка, выделите его и щелкните на кнопке Remove Light (Удалить источник). Источник света останется в сцене, но не будет при визуализации демонстрировать эффект объемного освещения.

7. Задайте цвет и плотность имитации тумана, а также максимальную и минимальную яркость света и уровень качества фильтра полутонов объемного освещения с помощью следующих параметров группы Volume(Объем):

· Fog Color (Цвет тумана) — образец цвета тумана выбирается после щелчка LM на цветовой области в диалоговом окне Color Selector: Fog Color (Выбор цвета: Туман);

Рис. 16.8. Свиток параметров объемного освещения

· Attenuation Color (Цвет затухания) — образец цвета, который будет приобретать туман по мере затухания света;

· Exponential (Экспоненциально) — если флажок установлен, плотность тумана экспоненциально увеличивается по мере удаления от источника света. При сброшенном флажке плотность возрастает по линейному закону. Если в сцене использованы прозрачные объекты, то установка флажка улучшает результат их визуализации;

· Density (Плотность) — счетчик задает плотность тумана, которая указывается в процентах от той, при которой туман становится полностью непрозрачным;

· Max Light % (Максимальная яркость) — чем дальше туман от источника света, тем он плотнее и тем ярче выглядит в луче объемного света. Этот счетчик позволяет ограничить яркость тумана, чтобы он не возрастал бесконечно по мере удаления от источника света. По умолчанию принимается величина 90%;

· Min Light % (Минимальная яркость) — установкой ненулевой величины этого счетчика можно обеспечить светимость тумана за пределами конуса луча света;

· Filter Shadows (Качество фильтров полутонов) — набор переключателей, позволяющий улучшить качество визуализации объемных пучков света. Для окончательной визуализации сцены следует выбрать фильтр High (Высокое). Это позволит обеспечить плавные перепады тонов объемного света.

8. В разделе Attenuation (Затухание) задайте характеристики затухания световых лучей, определяющие, насколько далеко от источника света простирается действие световых пучков.


Лофтинговое моделирование каркасных объектов

Лофтинг-моделирование рамы

Настройка параметров поверхности

Настройка параметров пути

Первая вершина сечения

Настройка параметров сетчатой оболочки

Метод лофтинга предназначен для преобразования сплайновых кривых в каркасные трехмерные объекты. Если рассечь трехмерный объект плоскостью, то контуром этого сечения будет кривая, т. е. набор вершин, соединенных отрезками линий. Примем сплайновую кривую за основу и соединим отрезками прямых вершины нескольких сплайнов. Получим набор граней, образующих каркас некоторого трехмерного тела, поперечными сечениями которого являются сплайновые кривые. Теперь, если сечения в виде сплайнов разместим вдоль некоторой кривой ортогонально к ней, то полностью определим форму создаваемого трехмерного объекта в пространстве. Таким образом, для создания каркасного трехмерного объекта методом лофтинга потребуется, как минимум, одна форма-сечение и одна форма-путь, вдоль которой это сечение будет расставляться. Используя множество различных форм-сечений, методом лофтинга можно построить трехмерный объект практически любой сложности. Рассмотрим этот метод на примере.

Лофтинг-моделирование рамы

Для нашего примера потребуется две сплайновые формы, такие как представлены на рис. 8.1. Перейдем к их созданию.

1. Сделайте активным окно проекции Тор (Вид сверху).

2. Создайте форму-путь в виде правильного шестиугольника. Для этого нажмите на командной панели Create (Создать) кнопку Shapes (Формы), в списке выберите вариант Splines (Сплайны) и нажмите кнопку Ngon (Многоугольник).

3. Задайте число сторон в счетчике Sides (Стороны) и постройте шестиугольник.

4. На командной панели Create (Создать) при нажатой кнопке Shapes (Формы) и выбранном в списке варианте Splines (Сплайны) нажмите кнопку Line (Линия) и постройте форму сечения.

Рис. 8.1. Заготовка для лофтинг-модели

5. Нажав кнопку Geomety (Геометрия) на командной панели Create (Создать), щелкните по кнопке мыши Loft Object (Объект по сечению).

В свитке Object Type (Тип объекта) расположена кнопка Loft (Создать по сечению). Чтобы кнопка была доступна, должна быть выделена одна из форм.

6. Выделите форму-путь и щелкните LM на кнопке Loft (Создать по сечению).

Открылся доступ к свиткам Creation Method (Метод создания). Surface Parameters (Параметры поверхности), Path Parameters (Параметры пути) и Skin Parameters (Параметры оболочки).

7. Из двух появившихся в свитке Creation Method (Метод создания) кнопок Get Path (Выбрать путь) и Get Shape (Выбрать форму) щелкните LM на кнопке Get Shape (Выбрать форму).

Если кнопка Get Shape (Выбрать форму) не активна, то это означает, что выбранная форма не может использоваться как путь, а только как сечение. Форма-путь может быть забракована программой, если она состоит более, чем из одного сплайна или NURBS-кривой.

8. Переведите курсор на сечение и, когда курсор примет специальный вид, щелкните LM.

В окнах, где установлен режим тонирования, появится объект, созданный методом лофтинга (рис 8.2).

В примерном построении модели назначался сперва путь, а потом выбиралось сечение. При такой последовательности сечение прикреплялось к пути, ориентируясь ортогонально ему. Если выбрать сначала сечение, а потом, после нажатия кнопки Get Path (Выбрать путь), назначить путь, то путь будет прикреплен к сечению (рис. 8.3).

Рис. 8.2. Рамка, созданная методом лофтинга

В рассмотренном примере мы воспользовались необходимыми для лофтинга командами, оставляя значения параметров, в указанных выше свитках, установленными по умолчанию. Эти параметры можно настраивать, исходя из требований к моделируемой поверхности.

Рис. 8.3. Вариант прикрепления пути к сечению при лофтинге

Настройка параметров поверхности

Выполните следующие шаги:

1. Для настройки параметров следует раскрыть свиток Surface Parameters (Параметры поверхности).

2. В группе Smoothing (Сглаживание) следует установить следующие два флажка:

· Smooth Length (Сгладить вдоль) — обеспечивает сглаживание изломов граней поверхности вдоль линии пути;

· Smooth Width (Сгладить поперек) — обеспечивает сглаживание по периметру опорных сечений.

При необходимости применения к объекту, созданному методом лофтинга, материалов на основе текстурных карт отметьте параметр Apply Mapping (Применить проецирование) в группе Mapping (Проецирование). После этого становится возможным задание параметров кратности повторения карты текстуры по координатам вдоль и поперек линий в счетчиках Length Repeat (Кратность вдоль) и Width Repeat (Кратность поперек).

Настройка параметров пути

Параметры свитка Path Parameters (Параметры пути) позволяют расставить несколько форм-сечений в разных точках пути. Это дает возможность формировать оболочку тела с переменным сечением.

1. Перейдите в окно проекции Тор (Вид сверху) и отключите там заливку.

2. Создайте несколько сплайнов для форм-сечений и путь, например, как на рис. 8.4.

Рис. 8.4. Заготовки для лофтинга с двумя сечениями

3. Выделите путь и в раскрывающемся меню Geomety (Геометрия) выберите Loft Object (Объект по сечению).

4. Щелкните LM на кнопке Loft (Лофтинг).

5. Разверните свиток Path Parameters (Параметры пути) и установите переключатель Distance (Расстояние). В этом случае расстояние между различными сечениями будет определяться в единицах длины.

Если установить переключатель Percentage (Процент), то расстояние между сечениями будет измеряться в процентах от длины пути.

Если же установить переключатель Path Steps (Шаги пути), то сечения будут размещаться в точках, соответствующих концам линейных сегментов кривой пути. Общее число таких точек появится в скобках правее счетчика Path (Путь).

6. В счетчике Path (Путь) задайте положение точки на пути, в которой будет размещено первое сечение.

7. Щелкните на кнопке Get Shape (Взять форму) и выберите первую форму-сечение.

В заданной точке пути появится проекция выбранного сечения (рис. 8.5).

Рис. 8.5. Проекция первоначального сечения на пути

8. Задайте точку положения нового сечения, изменив значение счетчика Path (Путь).

Эта точка помечается на линии пути маркером в виде желтого крестика.

В нижней части свитка Path Parameters (Параметры пути) имеются три кнопки. Они служат для выбора активного сечения, указываемого крестиком:

  • Pick Level (Указать уровень) — позволяет сделать любое сечение активным, щелкнув LM на нем;

  • Previous Shape (Предыдущее сечение) — делает активным предыдущее сечение;

  • Next Shape (Следующее сечение) — делает активным следующее вдоль пути сечение.

9. Лофтинг-модель построена. Чтобы увидеть ее, включите заливку.

На рис. 8.6 показан конечный результат моделирования объекта при помощи нескольких сечений.

Сохраните построенный объект, выбрав в меню File (Файл) команду Save As (Сохранить как). В следующем уроке он будет использован для изучения способов деформации.

Рис. 8.6. Построенная лофтинг-модель

Первая вершина сечения

Все вершины сплайнов имеют внутреннюю нумерацию. При использовании сплайнов в качестве сечений трехмерных объектов линии контура объекта формируются путем соединения вершин с одинаковыми номерами.

Рис. 8.7. Скручивание лофтинг-объекта

Сдвинув нумерацию вершин у полигонов одинаковой геометрической формы и используя их в качестве сечений на разных уровнях пути, можно получить перекручивание конечного объекта, как на рис. 8.7. Здесь в качестве сечений выбраны два одинаковых многоугольника, но с измененным порядком вершин.

Для изменения нумерации вершин в разделе редактирования сплайнов на уровне вершин (см. Занятие 6) есть кнопка Make First (Сделать первой). С ее помощью можно установить требуемую нумерацию вершин сечения, назначив выбранную вершину первой.

Создайте самостоятельно объект, показанный на рис. 8.8, используя прием "скрутки".

Рис. 8.8. Объект, построенный с помощью изменения порядка нумерации вершин

Настройка параметров сетчатой оболочки

Для построенного ранее объекта настройте параметры сетчатой оболочки.

1. Разверните свиток Skin Parameters (Параметры оболочки).

Представленные там параметры управляют процессом построения оболочки по опорным сечениям.

2. В группе Capping (Накрытие) настройте следующие параметры:

  • Cap Start (Начальное основание) и Cap End (Конечное основание) — флажки определяют, создавать ли поверхности на торцах трехмерной модели. На рис. 8.9 показан объект с закрытыми торцами и тот же объект с открытыми торцами;
  • Morph (Морфинг) — переключатель устанавливается, если требуется, чтобы поверхности на торцах могли быть преобразованы методом морфинга;
  • Grid (Сетка) — при установке переключателя торцевые поверхности формируются в виде сетки с одинаковыми ячейками, что дает возможность применять различные модификаторы.

Рис. 8.9. Объект, построенный с помощью изменения порядка нумерации вершин

3. В группе Options (Параметры) настройте параметры, определяющие степень сложности создаваемой оболочки объекта:

· Shape Steps (Шагов формы) — счетчик управляет числом шагов (линейных сегментов) между соседними вершинами форм-сечений. Чем больше шагов формы, тем более гладкой будет оболочка объекта по периметру форм-сечений;

· Path Steps (Шагов пути) — счетчик управляет числом шагов (линейных сегментов) между вершинами линии пути. Опорное сечение помещается на конце каждого линейного сегмента, так что увеличение этого параметра ведет к созданию оболочек, более гладких вдоль линии пути;

· Optimize shapes (Оптимальные формы) — флажок минимизирует число шагов в линейных сегментах форм-сечений перед построением оболочки объекта, тем самым снижая ее сложность;

· Adaptive Path Steps (Адаптивные шаги пути) — флажок добавляет дополнительные шаги между вершинами пути с тем, чтобы создать наилучшую возможную оболочку объекта. Шаги добавляются там, где находятся контрольные точки кривой деформации;

· Contour (Контур) — флажок заставляет форму-сечение постоянно располагаться перпендикулярно линии пути. Если параметр не отмечен, сечение размещается вдоль пути параллельно своему начальному положению;

· Banking (Крен) — флажок заставляет форму-сечение вращаться вместе с кривой пути. Например, при использовании спирали в качестве пути нужно отметить параметр, чтобы объект сформировался должным образом. В противном случае сечение не будет правильно располагаться относительно пути во всех трех измерениях;

· Constant Cross Section (Постоянное сечение) — при установке этого флажка происходит увеличение размеров сечения в местах изломов линии пути, чтобы обеспечить постоянную толщину объекта, созданного методом лофтинга. В противном случае форма-сечение сохраняет свои размеры, и объект в местах изломов пути становится утонченным;

· Linear Interpolation (Линейная интерполяция) — флажок определяет, будет программа интерполировать оболочку трехмерного объекта в промежутках между сечениями по линейному закону или со сглаживанием изломов. По умолчанию параметр отменен, т. е. используется сглаженная интерполяция, что выражается в формировании более гладкого объекта. Линейная интерполяция создает оболочку, в которой промежутки между сечениями соединяются отрезками прямых линий. В результате получается ребристый объект упрощенной формы.

4. Установите при необходимости следующие параметры в группе Display (Отображение):

· Skin (Оболочка) — флажок обеспечивает показ оболочки объекта, сформированного методом лофтинга, в окнах с каркасным режимом отображения;

· Skin in Shaded (Тонированная оболочка) — флажок обеспечивает показ оболочки объекта только в окнах с тонированным режимом отображения.


Моделирование динамики с помощью систем частиц

Создание систем частиц

Настройка параметров частиц

Генерация частиц

Тип частиц

Вращение частиц

Наследование движения объекта

Пузырьковый тип движения

Дробление частиц

Сохранение заготовок и их загрузка

Под системой частиц понимается совокупность управляемых с помощью параметров малоразмерных объектов. Они способны принимать форму различных объектов и позволяют моделировать снег, дождь, стаю птиц, фейерверк и т. д. В зависимости от вида источника программой генерируются различные типы систем частиц. Остается выбрать, какой из предлагаемых типов более всего подходит для моделирования конкретного эффекта.

Создание систем частиц

Выполните следующие шаги:

1. Щелкните LM на кнопке Geometry (Геометрия) командной панели Create(Создать) и в раскрывающемся списке разновидностей объектов выберите Particle Systems (Системы частиц).

В свитке Object Type (Типы объектов) появятся шесть кнопок с названиями типов систем частиц:

· Spray (Брызги) — эффект водяных брызг, дождя;

· Show (Снег) — эффект падающего снега;

· Super Spray (Супербрызги) — тип частиц для создания более сложных эффектов. Частицам можно придавать форму различных объектов;

· Blizzard (Метель) — усовершенствованная версия частиц типа снег;

· PCloud (Облако частиц) — облако частиц. Частицам можно придавать форму различных объектов;

· РАггау (Массив частиц) — произвольное множество частиц, пригодных для моделирования различных эффектов. Частицам можно придавать форму различных объектов.

Перечисленные источники систем частиц показаны на рис. 18.1.

2. Нажмите кнопку Super Spray (Супербрызги), щелкните LM в окне проекции и, перетаскивая курсор, создайте источник частиц.

Источник частиц представляет собой объект, не подлежащий визуализации и служащий для определения местоположения и ориентации частиц.

3. Передвиньте ползунок анимации.

Рис. 18.1. Источники систем частиц типа Blizzard (a), Super Spray (б), Parray (в), Pcloud (a)

При передвижении ползунка анимации частицы начинают перемещаться. Момент перемещения показан на рис. 18.2. Для получения требуемого эффекта следует настроить параметры частиц.

Рис. 18.2. Генерация частиц источником Super Spray

Настройка параметров частиц

1. Раскройте свиток Basic Parameters (Базовые параметры).

Параметры этого свитка позволяют задать геометрию пучка частиц в целом, размеры значка источника и геометрический вид частицы.

2. Укажите значения счетчиков в группе Particle Formation (Формирование частиц):

· Off Axis (Отклонение от оси), Spread (Расстояние) — угол отклонения пучка частиц от оси Z источника и ширина пучка в этой плоскости;

· Off Plane (Отклонение от плоскости), Spread (Расстояние) — угол поворота пучка частиц в плоскости XY источника и ширина пучка в направлении отклонения.

3. В группе Display Icon (Отображение значка) задайте значения в счетчике Icon Size (Размеры значка) и отметьте флажок Emitter Hidden (Скрытый значок).

При установленном флажке Emitter Hidden (Скрытый значок) источник становится невидимым в проекциях окон.

4. Задайте геометрический вид частицы в группе Viewport Display (Вид), отметив одно из положений: Dots (Точки), Tics (Штрихи), Mesh (Сетка) или ВВох (Габаритный контейнер). Счетчик Percentage of Particles(Процент частиц) позволяет задать долю общего числа частиц, которая будет отображаться в окнах проекции в ходе работы.

Генерация частиц

Выполните следующие шаги:

1. Раскройте свиток Particle Generation (Генерация частиц).

Параметры этого свитка позволяют задать количество, время существования, период роста и спада частиц и т. д.

2. Задайте среднюю начальную скорость частиц в момент испускания в счетчике Speed (Скорость) и предел ее вариаций в счетчике Variation (Вариации).

3. Задайте продолжительность существования частиц в группе параметров Particle Timing (Время жизни частиц):

· Emit Start (Начальная генерация), Emit Stop (Конец генерации) — но-' мера кадров, в которых начинается и заканчивается испускание частиц;

· Display Until (Отображать до) — время (номер кадра) исчезновения всех частиц независимо от их параметров;

· Life (Время жизни) и Variation (Вариации) — среднее время жизни частицы с момента ее испускания и число кадров, на которое время жизни частицы может отличаться от среднего.

4. Задайте размеры частиц в группе параметров Particle Size (Размеры частиц):

· Size (Размер) и Variation (Вариации) — средний размер всех частиц и процент возможных отклонений размеров каждой частицы от среднего;

· Grow For (Период роста) — число кадров, за которое частица вырастает от 10 до 100% окончательного размера;

· Fade For (Период спада) — число кадров, за которое частица уменьшается от полного размера до 10% этого размера перед полным исчезновением.

5. В группе Uniqueness (Уникальность) укажите в счетчике Seed (Номер выборки) число, которое служит для запуска генератора случайных чисел, используемых при расчете вариаций параметров частиц.

Чтобы сгенерировать такое число случайным образом, щелкните LM .на кнопке New (Новый).

Тип частиц

Выполните следующие шаги:

1. Раскройте свиток Particle Type (Тип частиц)-

Параметры этого свитка позволяют задать тип частиц и настроить их для выбранного типа.

2. Можно назначить один из трех типов частиц с помощью переключателя Particles Types (Тип частиц). Выберите Standard Particles (Стандартные частицы).

Параметр Standard Particles (Стандартные частицы) позволяет указать форму стандартных частиц.

3. Выберите форму стандартных частиц, установив переключатель в группе Standard Particles (Стандартные частицы) в одно из положений: Triangle(Треугольник), Cub (Куб), Facing (Лицом к зрителю), Sphere (Сфера), Tetra (Тетраэдр), SixPoint (Шестиконечная звезда), Constant (Постоянного размера) и Special (Специального размера). Визуализированная система стандартных частиц в виде сферы показана на рис. 18.3. Создайте сцену с любой из указанных форм.

4. Теперь выберите MetaParticles (Метачастицы) в свитке Particles Types(Тип частиц). Создайте сцену с помощью этого типа частиц.

Указанием этого типа каждая частица при визуализации заменяется мета-сферой (metaball) с имитацией поверхностного натяжения, позволяющего частицам сливаться друг с другом подобно реальным водяным каплям.

5. Настройте параметры метачастиц в группе MetaParticle Parameters(Параметры метачастиц):

· Tention (Натяжение), Variation (Вариации) — степень стремления частиц к слиянию с другими частицами и процент случайного отклонения этого параметра от среднего значения для каждой частицы;

· Evaluation Coarseness (Загрубление расчетов) — задает степень упрощения расчетов поведения метачастиц на этапах визуализации (счетчик Render). Установка флажка Automatic Coarseness (Автозагрубле-ние) обеспечивает автоматический выбор степени упрощения расчетов.

Визуализированная система метачастиц показана на рис. 18.4. Параметры ее настройки представлены на рис. 18.5.

Рис. 18.3. Визуализированная система частиц в виде сферы

Рис. 18.4. Система метачастиц

Рис. 18.5. Параметры системы метачастиц

6. Выберите последний в списке тип частиц: Instanced Geometry (Образцы моделей). Этот тип частиц позволяет моделировать, например, падение листьев, полет стаи птиц и т. д.

Здесь каждая частица в системе заменяется образцом выделенной геометрической модели.

7. Вспомните занятие 5 и в качестве образца создайте с помощью сплайна лист. Попробуйте смоделировать листопад.

8. Настройте параметры образца частиц в группе Instancing Parameters(Параметры образцов):

· Pick Object (Указать образец) — после щелчка LM на этой кнопке следует выделить объект-образец частицы;

· Use Subtree Also (Использовать поддерево) — флажок обеспечивает выделение вместе с объектом-образцом всех его потомков;

· Animation Offset Keying (Сдвиги ключей анимации) — при использовании объекта с анимацией данный набор переключателей позволяет задать, будет ли анимация всех частиц происходить синхронно (None), начинаться с той фазы, которая совпала с моментом рождения первой частицы ( Birth), или иметь случайный сдвиг по времени от этой фазы ( Random).

Вращение частиц

Выполните следующие шаги:

1. Раскройте свиток Rotation and Collision (Вращение и столкновение).

Параметры этого свитка позволяют определить скорость и направление вращения частиц.

2. Задайте скорость вращения частиц в группе параметров Spin Speed Controls (Управление скоростью вращения):

· Spin Time (Период вращения). Variation (Вариации) — счетчики определяют средний период вращения частицы (в кадрах) и процент случайного отклонения периода вращения каждой частицы от среднего значения;

· Phase (Фаза), Variation (Вариации) — счетчики задают начальный угол поворота частицы в градусах и процент случайного отклонения фазы вращения каждой частицы от среднего значения.

3. Задайте ориентацию осей, вокруг которых будут вращаться частицы, в группе параметров Spin Axis Controls (Управление осями вращения):

· Random (Случайное) — переключатель случайной ориентации осей вращения отдельных частиц;

· Direction of Travel/ Mblnr (В направлении движения/Размытие) — вращение вокруг вектора движения каждой частицы. Счетчик Stretch (Растяжение) задает степень размывания изображений частиц за счет их движения. На рис. 18.7 показан пример движения частиц с размытием;

Рис. 18.7. Система частиц с заданным параметром размытия

· User Defined (Заданное пользователем) — переключатель позволяет задать ориентацию осей вращения в счетчиках Х Axis (Ось X), Y Axis(Ось Y), Z Axis (Ось Z) и отклонения от средней ориентации для каждой отдельной частицы в счетчике Variation (Вариации).

Для созданной системы частиц визуализируйте ( Render) сцену и проследите, как влияют на динамику частиц параметры этого свитка.

Наследование движения объекта

Выполните следующие шаги:

1. Разверните свиток Object Motion Inheritance (Наследование движения объекта).

Представленные в нем параметры позволяют задать степень влияния движения источника частиц на движение самих частиц.

2. В счетчике Influence (Влияние) задайте долю частиц, наследующих движение источника.

3. Укажите значение счетчиков Multiplier (Усилитель) и Variation (Вариации).

Первый параметр позволяет модифицировать степень влияния в сторону увеличения или уменьшения, а второй определяет степень отклонения величины, указанной в счетчике Multiplier (Усилитель), от среднего значения для каждой из частиц.

Пузырьковый тип движения

Выполните следующие шаги:

1. Разверните свиток Bubble Motion (Пузырьковый тип движения).

Его параметры позволяют придать движению частиц некоторую периодическую неустойчивость, напоминающую движение пузырьков воздуха под водой.

2. Задайте параметры периода колебаний частиц в счетчиках Amplitude (Амплитуда), Period (Период), Phase (Фаза) и случайные вариации соответствующих параметров для каждой из частиц в счетчиках Variation (Вариации).

Установленное по умолчанию очень большое значение периода колебаний означает фактическое отсутствие пузырькового эффекта.

3. Создайте новый источник частиц типа Super Spray (Супербрызги). Назначьте в качестве образца модели сферу и, выбирая различные параметры, проследите их влияние на эффект пузырькового движения.

На рис. 18.8 показан эффект пузырькового движения.

Рис. 18.8. Пример пузырькового эффекта

Дробление частиц

Выполните следующие шаги:

1. Разверните свиток Particle Spawn (Дробление частиц).

Параметры этого свитка отвечают за поведение частиц в момент истечения срока жизни и при столкновении с отражателем.

2. Задайте тип эффекта дробления с помощью одного из переключателей в группе Particle Spawning Effects (Эффект дробления частиц):

· None (Отсутствует) — нет дробления. В момент столкновения с преградой частица или отскакивает, или прилипает, в зависимости от параметров отражателя, а при "умирании" — исчезает;

· Die After Collision (Исчезновение после столкновения) — частицы при столкновении с преградой исчезают;

· Spawn on Collision (Дробление при столкновении) — частицы при столкновении с преградой дробятся;

· Spawn on Death (Дробление в конце жизни) — частицы распадаются на осколки в конце срока жизни;

· Spawn Trails (Шлейфы осколков) — частицы дробятся на осколки в каждом кадре своего срока жизни. Базовое направление движения осколков противоположно направлению движения частиц.

3. Задайте число осколков при любом типе эффекта в счетчике Spawns (Осколков), а долю распадающихся частиц — в счетчике Affects (Влияние).

Счетчик Multiplier (Умножитель) позволяет изменять число осколков, а параметр Variation (Вариации) определяет степень отклонения величины, указанной в счетчике Multiplier (Умножитель), от среднего значения для каждой из частиц.

Сохранение заготовок и их загрузка

Команды свитка Load/ Save Presets (Загрузить/сохранить заготовки) позволяют сохранять наборы сформированных параметров и использовать их в других сценах. Для этого используются кнопки Save (Сохранить) и Load(Загрузить). Имена сохраненных заготовок добавляются в список Saved Presets (Сохраненные заготовки). Для удаления набора из списка служит кнопка Delete (Удалить).


Моделирование освещения

Создание источников света

Настройка параметров теней

Всенаправленный источник света

Свободнонаправленный источник света и свободный прожектор

Нацеленнонаправленный источник света

Исключение объектов из освещения

Настройка подсветки

Созданная сцена должна быть освещена, иначе объекты этой сцены будут не видны. В предыдущих занятиях вопрос освещения не стоял, поскольку все построенные объекты были видны. Их освещали два источника света, установленных по умолчанию. Свет от одного из них падает на объекты спереди из левого верхнего угла сцены, а другого — сзади из правого нижнего угла. Оба источника света отключаются, если появляется созданный источник света, а при удалении всех созданных источников света восстанавливаются. Этот урок будет посвящен моделированию освещения, созданию различных источников света и настройке их параметров.

Создание источников света

При создании освещения сцены используют пять типов источников света:

· всенаправленный (Опии), излучающий свет равномерно во все стороны;

· свободно направленный источник (Free Direct);

· нацеленный источник ( Target Direct);

· нацеленный прожектор (Free Spot);

· свободный прожектор ( Target Spot). Перед тем как создать источник света, постройте на экране сферу.

1. На командной панели Create (Создать) нажмите кнопку Lights(Источники света).

В свитке Object Type (Тип объекта) появятся кнопки для создания различных источников света (рис. 12.1).

Рис. 12.1. Набор кнопок с различными типами источников света

2. Щелкните LM на кнопке Target Spot (Нацеленный прожектор).

3. Щелкните LM в окне перспективы и, не отпуская кнопку мыши, наведите появившийся конус на существующий объект.

На рис. 12.2 показан вариант построения направленного освещения.

Рис. 12.2. Пример построения направленного источника света

4. Раскройте свиток General Parameters (Общие параметры).

В нем производится настройка общих свойств параметров света, одинаковых для всех типов освещения.

Замечание

Помните, что построенный источник света можно настраивать с помощью указанных ниже параметров, если не снимался его выбор, и не использовались операции перемещения и поворота. В противном случае параметры можно выставить только в разделе Modify (Изменить).

5. Первым отметьте флажок On (Включение).

Если параметр On (Включение) не отмечен, то источник света будет отключен.

При включенном источнике необходимо определить следующие параметры:

· Exclude (Исключение) — кнопка позволяет выбирать объекты сцены, на которые падает освещение от данного источника. Поле с образцом цвета справа от флажка On (Включение) дает возможность настраивать цвет света. Для вызова цветовой палитры Color Selector (Выбор цвета) достаточно щелкнуть LM в окне с образцом;

· Multiplier (Усилитель) — счетчик регулирует общий уровень интенсивности света;

· Contrast (Контраст) — счетчик регулирует контрасты света и тени;

· счетчики Soften Diff. Edge (Размытие краев диффузного цвета) и Affect Specular (Влиять на зеркальный цвет) — управляют воздействием света соответственно на диффузное и на зеркальное отражения.

6. В свитке Attenuation Parameters (Затухание) установите параметры затухания света на расстоянии:

· Start (Начало) и End (Конец) — счетчики задают интервалы действия затухания в ближней зоне, где интенсивность света будет нарастать от нуля до постоянной величины (параметры группы Near Attenuation), и в дальней зоне, где интенсивность света будет спадать до нуля (параметры группы Far Attenuation);

· Use (Применить) и Show (Показать) — флажки включают эффекты затухания и обозначают граничные сферы зон затухания в окнах проекций (рис. 12.3 — в группе Near Attenuation и рис. 12.4 — в группе Far Attenuation);

Рис. 12.3. Эффект затухания в ближней зоне

Рис. 12.4. Эффект затухания в дальней зоне

· значение None (Отсутствует) раскрывающегося списка Type (Тип) группы Decay (Ослабление) — интенсивность света остается постоянной на всем интервале его действия;

· значение Inverse (Обратная пропорция) раскрывающегося списка Type(Тип) группы Decay (Ослабление) — свет ослабевает обратно пропорционально расстоянию от источника, т. е. искусственно занижается его ослабление;

· значение Inverse Square (Обратный квадрат) раскрывающегося списка Type (Тип) группы Decay (Ослабление) — свет ослабевает обратно пропорционально квадрату расстояния, что приблизительно соответствует реальному эффекту.

Настройка параметров теней

В свитке Shadow Parameters (Параметры тени) настраиваются параметры теней, одинаковые для всех источников света.

1. Настройте режимы параметров теней:

· On (Отбрасывать тени) — флажок включает режим воспроизведения теней от источника света;

· Use Global Settings (Применить глобальные настройки) — флажок приводит все остальные параметры свитка в соответствие со значениями аналогичных параметров других источников света, у которых установлен параметр глобальных настроек;

· Shadow Maps (Применять карты тени) — режим построения теней с размытыми краями задается в раскрывающемся списке окне;

· Ray Traced Shadows (Применять трассированные тени) — режим используется для имитации точных по форме теней с резко очерченными краями задается в раскрывающемся списке;

· Color (Цвет) — поле для задания цвета тени, при щелчке LM по которому вызывается палитра;

· Dens (Плотность) — счетчик задает плотность тени;

2. В свитке Shadow Maps Params (Параметры карт теней) настройте параметры:

· Bias (Смещение карты) — счетчик определяет, на каком расстоянии от объекта будет появляться его тень. По умолчанию смещение задается в 4 единицы. Если требуется, чтобы тень была прижата к краю объекта, то следует задать параметр равным 1;

· Size (Размер) — счетчик определяет размер карты теней в пикселах. Принятое по умолчанию значение — 256;

· Sample Range (Диапазон усреднения) — счетчик указывает количество усреднений карт теней.

3. Для просмотра тени с заданными параметрами выберите в меню Rendering (Визуализация) команду Render (Визуализировать).

Не вдаваясь в подробности режимов тонирования (они будут рассмотрены позже) щелкните LM на кнопке Render (Визуализировать) в появившемся окне Render Scene (Визуализация сцены).

Всенаправленный источник света

Всенаправленный источник света равномерно освещает объекты во всех направлениях.

1. Нажмите на командной панели Create (Создать) кнопку Lights (Источник света), а затем — кнопку Omni (Всенаправленный).

2. Щелкните LM в проекции окна в той точке, где должен располагаться источник света. Не отпуская кнопку мыши, можно передвинуть появившийся значок источника света, уточняя его положение в пространстве сцены.

Примечание

Всенаправленный источник света можно использовать в качестве проектора растрового изображения на поверхность растрового изображения.

3. Включите режим проецирования растрового изображения в свитке Projector Parameters (Параметры проектирования). Для этого щелкните LM на кнопке Map (Карта). Появится окно диалога Material/ Map Browser

(Просмотр материалов и карт текстур).

4. Выберите карту текстуры и нажмите кнопку ОК.

Проецирование выбранной текстуры можно наблюдать в режиме Render(Тонировать).

Свободнонаправленный источник света и свободный прожектор

Выполните следующие шаги:

1. На командной панели Create (Создать) нажмите кнопку Lights (Источник света), а затем — кнопку Free Direct (Свободнонаправленный).

Выставьте источник света в окно проекции, щелкнув LM. Вид его показан на рис. 12.5

2. Для корректировки его положения были использованы преобразования поворота и перемещения. Теперь, чтобы настроить параметры источника света, следует перейти на командную панель Modify (Изменить).

3. Помимо общих для всех типов освещения параметров, рассмотренных выше ранее в этом занятии, следует настроить еще параметры свитка Directional Parameters(Параметры направленного света):

· Hotspot (Яркое пятно) — счет определяет размер области, в пределах которой интенсивность падающего света остается постоянной и равной значению, заданному для источника в счетчике Multiplier (Усилитель). Границы области отмечены голубой линией;

Рис. 12.5. Свободнонаправленный источник света

· Falloff (Край пятна) — счетчик задает размер кольцевой области по краю светового пятна, в пределах которой интенсивность света спадает от максимального значения до нуля;

· Show Cone (Показать конус) — флажок включает режим постоянного показа цилиндрических границ яркого пятна и края светового пятна;

· Circle (Круг) и Rectangle (Прямоугольник) — переключатели определяют форму направленного пучка света;

· Aspect (Пропорции формы) — счетчик регулирует пропорции формы пучка света в случае прямоугольной его формы;

· Overshoot (Рассеивание) — установка флажка заставляет направленный источник света освещать по типу всенаправленного;

· Bitmap Fit (Подогнать под карту) — кнопка позволяет подогнать пропорции пятна под пропорции растровой карты в случае использования источника света как прожектора;

· Target Distance (Расстояние до мишени) — счетчик задает расстояние от источника света до мишени, вокруг которой источник света можно поворачивать с помощью инструмента Orbit Light (Облет источником света) из группы инструментов управления окнами проекции.

Элементы группы Progector Map (Карта проектора) свободно-направленного источника света аналогичны параметрам всенаправленного источника света.

Самостоятельно создайте источник света типа Free Spot (Свободный прожектор), который приведен на рис. 12.6. Параметры этого источника света аналогичны параметрам Free Direct (Свободнонаправленный).

Рис. 12.6. Освещение объекта свободным прожектором

Нацеленнонаправленный источник света

Нацеленонаправленный источник света внешне похож на свободнонаправленный, но имеет мишень, на которую и направлен постоянно (рис. 12.7).

1. Щелкните LM на кнопке Target Direct (Нацеленнонаправленный) и установите его в требуемой точке окна проекции.

2. Наведите источник света на цель, перемещая его мишень.

Если щелкнуть LM на линии, соединяющей мишень с источником света, то можно одновременно перемещать и мишень, и источник света.

3. Настройте параметры источника света, перейдя на командную панель Modify (Изменить).

Рис. 12. 7 . Пример освещения нацеленнонаправленным источником света

Нацеленнонаправленный источник света и нацеленный прожектор, рассмотренный ранее в этом занятии, имеют те же параметры, что и свободно направленный источник. Отличие состоит только в том, что вместо счетчика Target Distance (Расстояние до мишени) представлена текстовая строка, указывающая расстояние и предназначенная только для чтения. Это обусловлено тем, что расстояние до мишени у нацеленных источников является величиной переменной и изменяется при перемещении либо источника, либо цели.

Исключение объектов из освещения

Все объекты сцены освещаются установленными источниками. Однако есть возможность регулировать освещение сцены, исключая источники света из любого набора объектов сцены.

1. Постройте сцену с несколькими объектами и источником света.

2. Выделите источник света, перейдите на командную панель Modify(Изменить) и щелкните LM на кнопке Exclude (Исключение) в свитке General Parameters (Общие параметры).

Появится окно диалога Exclude/ Include (Включить/Исключить) (рис. 12.8).

Рис. 12. 8 . Диалоговое окно исключения объектов из освещения

3. В верхней части окна установите переключатель Exclude (Исключить) и отметьте переключатель Both (Оба).

Режим Exclude (Исключить) позволяет исключить источник света, а параметр Both (Оба) указывает, что исключение источника влияет на освещение (переключатель Illumination) и на отбрасывание теней (переключатель Shadow Casting) выбранных объектов.

4. Выделите имена объектов в левой части окна, которые не должны освещаться, и щелкните LM на кнопке ».

Выделенные имена объектов переместятся в список справа. Нажатие кнопки Clear (Очистить) позволит вернуть правый список имен обратно.

Для включения источника света следует выбрать переключатель Include(Включить).

Примечание

Влияние исключения объектов из освещения можно наблюдать при визуализации сцены.

Настройка подсветки

Подсветка создает равномерное распределение света на все объекты сцены. Чем выше уровень подсветки, тем ярче становятся цвета поверхностей объектов.

1. Выберите в меню Rendering (Визуализация) команду Environment (Окружение).

Появится диалоговое окно Environment (Окружение), показанное на рис. 12.9.

2. Щелкните в области выбора цвета Ambient (Подсветка), расположенном в правой части группы Global Lighting (Общая освещенность) свитка Common Parameters (Общие параметры).

Появится типовое окно диалога Color Selector: Ambient Light (Выбор цвета: Окружающая подсветка). По умолчанию подсветка имеет серый цвет с RGB-компонентами 11, 11, 11.

3. После подборки цвета закройте окно диалога Environment (Окружение).

4. Самостоятельно расставьте освещение в сцене интерьера и в светильнике. На рис. 12.10 изображен светильник с поставленными источниками света.

Рис. 12. 9 . Диалоговое окно настройки внешней среды


Моделирование сцены

Основные установки параметров

Создание стен

Создание раковины

Создание швабры

Имитация щетины

Конструирование вешалки

Создание ведра

Изучая эту тему, вы будете моделировать сцену с помощью команд, рассмотренных на предыдущих занятиях, и новых команд по созданию составных объектов. Сцена, которую вы будете создавать, показана на рис. 4.1. Она представляет собой интерьер, оборудованный несколькими предметами, каждый из которых, так или иначе, составлен из нескольких геометрических примитивов с помощью команд раздела Compound Objects (Составные объекты) свитка Object Type (Тип объекта).

Рис. 4.1. Пример для моделирования сцены

Основные установки параметров

Перед созданием сцены проведем установку единиц измерения и привязок.

1. Выберите в меню Customize (Специальные) команду Units Setup (Единицы измерения) и установите переключатель Metric (Метрические) — метрические единицы измерения.

2. Раскройте список и выберите там единицу измерения Meters (Метры).

3. Выберите в меню Customize (Специальные) команду Preferences (Параметры), щелкните LM на корешке вкладки General (Общие) диалогового окна и задайте количество знаков после запятой в счетчике Spinner Precision Decimals (Точность счетчиков ...разрядов), равной 2.

4. Выберите в меню Customize (Специальные) команду Grid and Snap Settings (Настройка сетки и привязок).

5. На вкладке Snaps отметьте флажок Grid Lines (Линии сетки) — привязка к линиям координатной сетки.

6. Щелкните LM на корешке Home Grid (Исходная сетка) и проверьте величину шага между вспомогательными линиями в счетчике Grid Spacing(Шаг сетки). По умолчанию она принимается равным 10 текущим единицам измерения.

Создание стен

Стены в 3D StudioMAX можно создать несколькими способами. Здесь мы применим команду L Extrusion (L-тело экструзии).

1. Активизируйте окно Perspective (Перспектива) и щелкните LM на кнопке Min/Max Togget (Развернуть/Восстановить) панели управления окнами проекции.

Окно проекции Perspective (Перспектива) развернется во весь рабочий экран.

2. Выберите в списке командной панели Create (Создать) вариант Extended Primitives (Улучшенные примитивы) и щелкните на кнопке L- Ext (L-тело экструзии).

Эта кнопка позволяет строить стены в форме буквы L. Вторая подобная команда C- Ext (С-экструзия) позволяет строить стены в виде буквы С.

3. Установите переключатель свитка Creation Method (Метод создания) в положение Corners (Углы), чтобы построить сечение тела от угла.

Вариант установки переключателя в положение Center (Центр) дает возможность строить сечение от центра.

4. Щелкните LM на рабочем поле экрана и, не отпуская кнопку мыши, перетащите курсор в любом направлении по диагонали.

Создавая стены, следите за изменением величин параметров Side Length(Длина боковой стены), Front Length (Длина фронтальной стены) и Side Width (Толщина боковой стены), Front Width (Толщина фронтальной стены).

5. Отпустите кнопку мыши, когда создаваемый объект будет построен.

Не сбрасывая выбор объекта, выставьте точные значения длины и толщины стен в соответствующих счетчиках.

Теперь созданный объект можно установить в нужное место рабочего экрана, используя инструмент Move (Переместить).

Создание раковины

Создавать раковину мы будем способом исключения одного стандартного примитива из другого с помощью булевской операции.

1. Там же, в разделе Extended Primitives (Улучшенные примитивы), нажмите кнопку Oil Tank (Цистерна).

2. Установите переключатель свитка Creation Method (Метод создания) в положение Edge (От края), чтобы построить сечение цистерны от одного края к другому, растягивая его по диаметру, а в разделе Parameters (Параметры) установите режим Overall (Полная). Растяните основание цистерны на величину радиуса, равную 12, установив это значение в счетчике Radius (Радиус).

Можно построить сечение от центра, растягивая радиус. Для этого следует установить переключатель Center (Центр). Режим Overall (Полная) позволяет изменять высоту сферических сегментов при сохранении общей высоты объекта. .

3. После щелчка LM, фиксирующего высоту объекта, дополнительно переместите курсор вверх, чтобы задать высоту сферических сегментов, лежащих в основаниях цистерны.

Правильно построенная заготовка для раковины должна иметь вид, приведенный на рис. 4.2

Рис. 4.2. Первая заготовка для раковины

4. Теперь постройте сферу, выбрав раздел Standard Primitives (Стандартные примитивы) и нажав кнопку Shpere (Сфера).

Количество сегментов сферы должно быть не менее 36, иначе внутренние края раковины будут неровными.

Обе заготовки построены. Осталось сконструировать раковину.

5. Выделите сферу и активизируйте кнопку Align (Выравнивание).

6. Установите значок курсора на цистерне и щелкните LM.

7. В появившейся панели отметьте Х Position (Положение по X), Y Position(Положение по Y) и выставьте Center (Центр) в разделах Current Object(Текущий объект) и Target Object (Опорный Объект).

8. Выделите сферу, щелкните LM на кнопке Move (Переместить) и на кнопке Restrict to Z (Ограничение перемещения по Z) командной панели.

9. Погрузите сферу в цистерну, как показано на рис. 4.3. Осталось исключить сферу.

Рис. 4.3. Сфера, погруженная в цистерну

10. Сбросьте выбор, сферы и выберите цистерну с помощью команды выделения объекта.

11. Выберете в списке командной панели Create (Создать) вариант Compound Objects (Составные объекты) и нажмите кнопку Boolean (Булевские).

В нижней части панели появятся несколько свитков параметров: Pick Boolean (Задать операнд), Parameters (Параметры) и Display/ Update (Показать/Обновить).

12. Установите переключатель свитка Pick Boolean (Задать операнд) в положение Move (Переместить).

13. В свитке Parameters (Параметры) отметьте переключатель Subtraction (А-В) (Исключение (А-В)).

14. Щелкните LM на кнопке Pick Operand В (Указать операнд В) и затем выделите сферу.

Сфера будет исключена. Результат работы булевской операции показан на рис. 4.4.

Рис. 4.4. Результат исключения сферы

15. Переместите раковину к стене в окне Тор (Верх) с помощью команды Move (Переместить).

Создание швабры

Швабра будет составляться из нескольких примитивных геометрических объектов с использованием уже известных вам преобразований и вспомогательных объектов.

1. Вы уже смоделировали часть сцены и ее следует сохранить. Выберите в меню File (Файл) команду SaveAs (Сохранить как).

2. В появившемся окне диалога введите имя файла и нажмите кнопку Save(Сохранить).

Ваша сцена запишется под указанным именем.

3. Создайте ручку для швабры, выбрав в списке командной панели Create(Создать) значение Extended Primitives (Улучшенные примитивы), затем нажав кнопку Oil Tank (Цистерна).

4. Поверните ручку на -20° вокруг оси Y. Для этого щелкните LM на кнопке Select and Rotate (Выделить и повернуть) и затем на этой же кнопке щелкните RM.

Появится диалоговое окно команды поворота.

5. Щелкните на панели ограничений перемещения кнопку Restrict to Y(Ограничение по оси Y) и введите в диалоговом окне угол поворота по оси Y.

6. Переместите построенную ручку к стене с помощью действий кнопки Move (Переместить).

Перейдем к построению основы швабры.

7. В окне Perspective (Перспектива) создайте объекты Capsule (Капсула) и Box (Параллелепипед).

Эти заготовки показаны на рис. 4.5.

Рис. 4.5. Капсула и параллелепипед

8. Выровняйте капсулу по нормали к плоскости параллелепипеда, переключив предварительно видовое окно на Front (Вид спереди).

Используйте для этого инструмент Normal Align (Выровнять нормали). Результат выравнивания показан на рис. 4.6.

9. Щелкните LM на кнопке Restrict to Y (Ограничение по оси Y) и погрузите капсулу до середины в параллелепипед, как показано на рис. 4.7.

10. Выделите капсулу и нажмите на командной панели Create (Создать) кнопку Geometry (Геометрия), в списке укажите вариант Compound Objects (Составные объекты) и нажмите кнопку Boolean (Булевский).

11. В свитке Operation (Тип операции) отметьте переключатель Subtraction (А-В) (Исключение (А-В)), нажмите кнопку Pick Operand В (Указать операнд В) и щелкните LM на параллелепипеде.

Рис. 4.6. Капсула выровнена по нормали к прямоугольнику

Рис. 4.7. Вид построения в четырех рабочих проекциях

Результат булевской операции исключения показан на рис. 4.8.

Рис. 4.8. Результат вычитания параллелепипеда

Имитация щетины

Для имитации щетины швабры выполните следующие шаги:

1. Постройте конус, направленный вершиной вниз.

2. Щелкните LM на кнопке Array (Массив).

Для задания параметров массива раскроется окно диалога Array (Массив).

3. В разделе Array Transformation (Преобразование массива) щелкните на кнопке > в строке Move (Переместить), направленной на раздел Totals(Пределы) и задайте значение координаты Y.

Конус будет распределен массивом равномерно по оси Y.

4. Задайте тип дубликатов, помещаемых в массив, поставив переключатель Type of Object (Тип объекта) в положение Instance (Образец).

Определите размерность массива, установив переключатель группы Array Dimensions (Размерность массива) в положение ID, и задайте число элементов в счетчике этой строки.

5. Для имитации щетины достаточно ограничиться двенадцатью элементами.

6. Установите переключатель в положение 2 D, введите значение 2 в счетчик размерности и задайте отклонения по координатам Х и Y. Проверьте введенные значения и нажмите кнопку ОК.

Задан двумерный массив: 2 ряда по 12 элементов. Результат построения приведен на рис. 4.9, а на рис. 4.10 — параметры массива в диалоговом окне.

7. Сгруппируйте созданный массив.

8. Объедините полученное основание со щетиной, используя способ выравнивания по нормали. Результат объединения показан на рис. 4.11.

Рис. 4.9. Массив из конусов

Рис. 4.10. Диалоговое окно Array с параметрами массива

9. Отмасштабируйте, если в этом есть необходимость, скомпонованный объект и объедините его с ручкой, используя инструменты перемещения и выравнивания.

Готовый для использования в интерьере объект показан на рис. 4.12.

10. Сохраните созданный объект. С этой целью выберите в меню File(Файл) команду Save As (Сохранить как).

11. В появившемся диалоговом окне задайте имя для сохраняемого файла и нажмите кнопку Save (Сохранить).

Рис. 4.11. Готовое основание швабры

Рис. 4.12. Основание швабры, объединенное с ручкой

Конструирование вешалки

Вешалку будем строить, используя стандартную геометрию и команду Scatter (Распределенные), позволяющую распределять дубликаты одного объекта по поверхности другого.

1. Построим подставку вешалки. На командной панели Create (Создать) нажмите кнопку Geometry (Геометрия), в списке укажите вариант Standard

Primitives (Стандартные примитивы), а затем нажмите кнопку Cone (Конус) и постройте усеченный конус.

2. Раскройте панель масштабирования, выберите кнопку Select and Squash (Выделить и сжать) и сожмите конус.

Результат трансформации конуса показан на рис. 4.13.

Рис. 4.13. Подставка для вешалки

3. Там же, в разделе стандартных примитивов, нажмите кнопку Cylinder(Цилиндр) и постройте основание вешалки.

4. Если основание вешалки осталось выделенным, то на панели инструментов активизируйте кнопку Align (Выровнять) и выделите появившимся курсором подставку вешалки.

5. В появившемся диалоговом окне отметьте координаты Х и Y в группе Align Position (Выравнивание положения) и Center (Центр) в группах Current Object (Текущий объект) и Target Object (Опорный объект).

Основание вешалки совместится с центром подставки (рис. 4.14).

6. Постройте еще один цилиндр и оставьте его выделенным.

Замечание

Напомним, что пока объект остается выделенным, его параметры можно менять с помощью счетчиков в свитке параметров.

7. На командной панели Create (Создать) в списке Object Type (Тип объекта) выберите вариант Compound Objects (Составные объекты) и нажмите кнопку Scatter (Распределенный).

Эта кнопка позволяет распределять дубликаты одного объекта по поверхности другого. Она может использоваться для имитации травы, листьев на дереве и т. д. Распределяемый объект носит название объекта-источника, а объект, на котором распределяются дубликаты — объекта базы. Распределение дубликатов происходит произвольным образом с помощью генератора случайных чисел. Поменять расположение дубликатов можно, изменив числовое значение счетчика, инициирующее работу генератора случайных чисел.

Рис. 4.14. Основа вешалки, выровненная относительно подставки

8. В свитке Pick Distribution Object (Задание базы распределения) отметьте режим Move (Переместить).

При этом режиме объект-база при назначении базы распределения будет перемещен в составной объект.

9. Щелкните LMна кнопке Pick Distribution Object (Указать базу распределения) и выделите цилиндр — основу вешалки.

Цилиндр переместится и окажется прикрепленным к цилиндру — основе вешалки (рис. 4.15).

10. В счетчик Duplicates (Дубликаты) введите число 6.

Значение счетчика определяет число распределяемых объектов. Этот параметр игнорируется, если дубликаты объекта-источника распределяются по центрам граней или вершинам поверхности объекта-базы. Указанные режимы будут рассмотрены ниже.

11. В разделе Distribution Object Parameters (Параметры объекта-базы) отметьте флажок Perpendicular (Перпендикулярно).

В этом случае дубликаты будут распределяться перпендикулярно поверхностям граней объекта-базы.

Рис. 4.15. Цилиндр прикрепился к основе вешалки

12. Задайте вариант распределения дубликатов по поверхности объекта базы, отметив переключатель Area (По площади) в разделе Distribute Using(Распределять).

Произошло равномерное случайное распределение дубликатов по поверхности базы. Остальные варианты этого раздела означают следующее:

· Even (Равномерно) — число граней объекта делится на количество дубликатов;

· Skip N (Пропуская N граней) — при распределении дубликатов будет пропускаться N граней объекта-базы;

· Random Faces (Случайные грани) — дубликаты распределяются случайным образом;

· Along Edges (Вдоль ребер) — дубликаты случайным образом распределяются вдоль ребер объекта-базы;

· All Vertices (По всем вершинам) — дубликаты помещаются в каждую вершину объекта-базы, при этом заданное число дубликатов игнорируется;

· All Edge Midpoints (По серединам всех ребер) — дубликаты помещаются в середины каждого ребра объекта-базы;

· All Face Centers (По центрам всех граней) — дубликаты помещаются в центры каждой грани объекта-базы.

13. В свитке Display (Отражение) отметьте переключатель Mesh (Сетка).

Этот вариант дает точное отображение дубликата. Если используется большое количество дубликатов, то удобнее выбрать вариант Proxy(Приближенное). В целях ускоренной прорисовки в этом варианте будут выдаваться приближенные макеты дубликатов.

14. В счетчике Display (Показывать) устанавливается доля общего количества дубликатов, которое будет отображаться в окне проекции. Попытайтесь, изменяя значения этого счетчика, визуально по рисунку выбрать подходящий вариант.

Замечание

Если выбранный вариант построения не устраивает, и вы хотите вернуться к предыдущему, то для отмены последней команды щелкните LM на кнопке Undo (Отменить) панели инструментов. Вторая кнопка в этой группе Redo (Повторить) повторит отмененную команду.

15. В счетчике Seed (Номер) измените число, инициирующее работу генератора случайных чисел, и проследите за изменением объекта.

Мы решили остановиться на варианте, показанном на рис. 4.16.

16. Сохраните построенный объект.

Рис. 4.16. Вариант распределения дубликатов по цилиндру основания вешалки

Создание ведра

Ведро строится по той же схеме, что и раковина.

1. Постройте усеченных конус и сделайте его копию.

2. С помощью инструмента выравнивания поместите один конус в другой, как показано на рис. 4.17.

Рис. 4.17. Заготовка построения ведра

3. С помощью булевской операции исключите внутренний цилиндр из внешнего (рис. 4.18).

4. Сохраните созданный объект на диске.

5. Расставьте созданные объекты в интерьере и сохраните полученную сцену.

Рис. 4.18. Результат булевского исключения одного цилиндра из другого


Объемная деформация объектов

Контейнерная деформация

Волнообразные деформации

Деформация смещения

Деформация взрыва

Объемная деформация объектов создается на основе построения дополнительной деформирующей геометрии, которая как бы оказывает на объект силовое воздействие. Объекты, к которым применяются объемные деформации, должны иметь достаточно много граней для качественного произведения эффекта воздействия. Объекты деформирующей геометрии представлены пятью типами: Forces (Силовые воздействия), Deflectors (Отражатели), Geometric/ Defonnable (Деформирующая геометрия), Particles & Dinamics (Частицы и динамика) и Modifier- Based (На базе модификаторов). Здесь мы рассмотрим деформацию типа Geometric/ Defonnable (Деформирующая геометрия), а остальные типы деформации — в занятиях, посвященных анимации.

Контейнерная деформация

Деформирующая геометрия здесь представляется в виде прямоугольной или цилиндрической пространственной решетки с управляющими узлами.

1. Создайте сферу как объект деформации

2. Щелкните LM на кнопке Space Warps (Объемные деформации) командной панели. Выберите в раскрывающемся списке вариант Geometric/ Defonnable (Деформирующая геометрия), а в свитке Object Type (Тип объекта) нажмите кнопку FFD ( Box) (FFD-контейнер (прямоугольный)).

3. Щелкните LM в окне проекции и, протягивая курсор, постройте прямоугольный контейнер в виде параллелепипеда.

Контейнер может охватывать деформируемый объект, как показано на рис. 11.1, или находиться рядом с ним.

4. Свяжите сферу с параллелепипедом, для чего нажмите кнопку Bind to Space Warp (Связать с воздействием) на панели инструментов, щелкните LM на сфере и перетащите курсор на контейнер. Отпустите кнопку, как только курсор примет вид значка, изображенного на кнопке инструмента.

Теперь оба объекта связаны. С одним источником объемной деформации можно связать множество объектов деформации

Рис. 11.1. Контейнер объемной деформации вокруг деформируемого объекта

5. Настройте параметры контейнера объемной деформации, перейдя на панель Modify (Изменить):

· Set Number of Points (Задание числа точек) — устанавливает количество управляющих точек по трем измерениям контейнера;

· Lattice (Решетка) — устанавливает либо отображение решетки деформации, либо только управляющих точек;

· Source Volume (Исходный контейнер) — если установлен, то отображается исходный вид недеформированного контейнера;

· Only In Volume (Только в контейнере) — перемещение управляющих точек будет влиять только на вершины объекта, лежащие внутри контейнера деформации;

· All Vertices (Все вершины) — перемещение управляющих точек будет влиять на все вершины объекта, лежащие как внутри контейнера, так и вне его. При этом в счетчике Falloff (Спад) задается расстояние (в долях размера контейнера), за пределами которого влияние деформирующего фактора спадает до нуля;

· Tension/ Continuity (Натяжение/Непрерывность) — параметры, влияющие на форму сплайнов, аппроксимирующих деформируемую поверхность объекта. Изменяя эти параметры, лучше всего подбирать оптимальные значения, наблюдая деформацию объекта;

· All X/ Y/ Z (Все по X/Y/Z) — при выборе управляющей точки выделятся и все остальные, расположенные с ней в одном ряду по соответствующей координате.

6. После настройки параметров щелкните LM в списке Modify Stack (Стек модификаторов) на названии модификатора.

7. Начните редактирование сферы, перемещая с помощью мыши вершины контейнера.

На рис. 11.2 показан результат редактирования, полученный перемещением нескольких управляющих вершин. Способ создания объемной деформации с помощью цилиндрического контейнера ( FFD (Су1) аналогичен способу, приведенному выше для прямоугольного контейнера.

Рис. 11.2. Результат деформации сферы при деформации решетки

Волнообразные деформации

К волнообразным относятся деформирующие геометрии типа Wave (Волна) и Ripple (Рябь). Они используются для создания волнообразного эффекта на поверхности деформируемого объекта. Пример воздействия деформации типа Wave (Волна) приведен на рис. 11.3, а деформации типа Ripple (Рябь) — на рис. 11.4.

1. В свитке типов объектов объемной деформации нажмите кнопку Ripple(Рябь).

2. Щелкните LM в окне проекции и создайте подобно цилиндру деформирующую геометрию Ripple (Рябь).

3. Перейдите на командную панель Modify (Изменить) и настройте параметры:

· Amplitude 1 (Амплитуда 1) — амплитуда синусоидальной волны, ориентированной в направлении оси Y локальной системы координат источника деформации типа Wave (Волна), и оси Х локальной системы координат источника деформации типа Ripple (Рябь);

· Amplitude 2 (Амплитуда 2) — амплитуда параболической волны, ориентированной в направлении оси Х локальной системы координат источника информации типа Wave (Волна), и синусоидальной волны, ориентированной в направлении оси Y локальной системы координат источника деформации типа Ripple (Рябь);

Рис. 11.3. Пример использования деформатора типа Wave

Рис. 11.4. Пример использования деформатора типа Ripple

· Wave Length(Длина волны) — пространственный период обеих волн, т. е. расстояние между их гребнями;

· Phase (Фаза) — сдвиг гребня волны в направлении, перпендикулярном гребням. Чем меньше фаза, тем меньше радиус первого кольца ряби;

· Decay (Затухание)— ограничение области распространения эффекта волновой деформации за счет уменьшения амплитуды волны по мере удаления от источника. Отрицательное затухание создает волны с нарастающей амплитудой;

· Circles (Круги) — число кругов в значке ряби;

· Segments (Сегменты) — число сегментов в значке волны в направлении оси Y системы координат и в значке ряби — по периметру окружности;

· Divisions (Сечения) — параметр, определяющий число сегментов (кругов), приходящихся на один период волны. Влияет на размер значка волновой деформации, но не сказывается на ее действии на объект.

4. Создайте объект деформации в виде параллелепипеда и свяжите источник деформации с объектом (кнопка Bind to Space Warp (Связать с воздействием)) на панели инструментов.

5. Настройте параметр Flexibility (Гибкость) на командной панели Modify(Изменить).

Этот параметр определяет чувствительность объекта к воздействию деформации.

Деформация смещения

Источник деформации смещения оказывает прямое силовое воздействие на объект, вызывая изменение его формы. В одном случае происходит прямая деформация с учетом величины параметра силы. В другом случае степень деформации определяется цветом растровой маски: черные области маски не деформируются, а светлые заставляют поверхность вспучиваться пропорционально цветовой интенсивности.

1. В свитке типов объектов Object Type (Тип объекта) нажмите кнопку Displace (Смещение).

2. Щелкните LM в окне проекции и перетащите курсор, растягивая по диагонали значок источника деформации, имеющий вид прямоугольника.

3. Постройте объект деформации в виде сферы, задайте ей количество сегментов не менее 56 и расположите его в направлении действия силы (рис. 11.5).

Эффект силового воздействия будет значительнее при большом количестве сегментов.

4. Свяжите источник деформации с объектом. На рис. 11.6 показан эффект силового воздействия на сферу.

5. Перейдите на панель Modify (Изменить) и настройте параметры:

· Strength (Сила) — влияет на величину смещения объекта, если не задана растровая карта смещения;

· Decay (Затухание) — позволяет ввести в действие смещения затухание по мере удаления от центра воздействия.

Теперь настроим деформацию смещения по растровой маске. В группе Image (Маска) выберите материал на основе карты текстур для использования в качестве маски смещения.

Рис. 11.5. Положение сферы перед воздействием деформации типа Displace

Рис. 11.6. Силовое воздействие на сферу деформации Displace

6. Щелкните LM на кнопке None (Отсутствует), относящейся к разделу Bitmap (Растровая карта).

7. В появившемся окне диалога Select Displacement Image (Выбор карты смещения) укажите файл растрового изображения и щелкните на кнопке Open (Открыть).

Имя файла отобразится на кнопке.

8. Щелкните LM на кнопке None (Отсутствует), относящейся к разделу Map(Карта текстур), и в появившемся окне Material/ Map Browser (Просмотр материалов и карт текстур) выберите текстуру. Имя карты отобразится на кнопке.

Для удаления карты текстуры щелкните на кнопке Remove Map(Удалить карту).

9. Задайте значение счетчика Blur (Размытие), который позволяет определить степень размытия изображения карты.

10. Задайте сферическую систему координат в группе Map (Проекция), установив переключатель в положение Spherical (Сферические).

Пример использования растровой маски для смещения в сферических координатах приведен на рис. 11.7.

Рис. 11.7. Деформация смещения по растровой маске

Деформация взрыва

Источник объемной деформации типа Bomb (Бомба) разбрасывает деформируемый объект на отдельные составляющие, имитируя взрыв бомбы.

1. Создайте деформируемый объект в виде сферы.

Позаботьтесь, чтобы сфера имела достаточное число сегментов.

2. Нажмите кнопку Bomb (Бомба) в свитке Object Type (Тип объекта) при нажатой кнопке Space Warps (Объемная деформация) на командной панели Create (Создать).

3. Щелкните LM в окне проекции, где должна располагаться бомба. Значок деформации имеет вид пирамиды (рис. 11.8).

Рис. 11.8. Сфера, подготовленная к взрыву

4. Свяжите сферу с источником деформации и перейдите на командную панель Modify (Изменить) для настройки параметров бомбы (рис. 11.9):

· Strength (Мощность) — чем больше значение параметра, тем дальше разлетаются осколки;

· Spin (Вращение) — скорость вращения осколков в оборотах в секунду;

· Falloff (Спад) — расстояние от бомбы, на которое распространяется ее действие.

Рис. 11.9. Параметры деформации взрыва

5. Задайте в группе Fragment Size (Размер фрагментов) пределы числа граней, приходящихся на каждый из фрагментов, на которые распадается взрываемый объект, используя счетчики Min (Минимум) и Мах (Максимум).

6. Настройте параметры взрыва в группе General (Общие параметры):

· Gravity (Гравитация) — задает влияние силы тяжести на осколки объекта;

· Chaos (Хаос) —задает степень случайности параметров взрыва;

· Detonation (Детонация) — определяет номер кадра, в котором произойдет взрыв;

· Seed (Номер выборки) — определяет число, задающее работу генератора случайных чисел.

7. Чтобы увидеть результат взрыва, переместите ползунок таймера анимации. На рис. 11.10 показан результат взрыва сферы.

Рис. 11.10. Взорванная сфера


Первое знакомство

Создание объектов

Параллелепипед

Цилиндр с фаской

Тороидальный узел

Преобразование объектов

Назначение материалов

Создание источников света

Установка параметров света

Установка камер

Настройка параметров камеры

Визуализация изображения

Анимация

Позиционные ключи анимации

Ключ поворота

Предварительный просмотр ролика

Начнем нашу работу с запуска программы, построения простых геометрий, назначим материалы для их поверхностей, применим освещение и камеры и создадим простой анимационный ролик. Это позволит на первом же уроке широко окинуть взглядом основные возможности 3D Studio MAX и почувствовать программу.

1. Для запуска программы щелкните левой кнопкой мыши на кнопке Start (Пуск) системы Windows.

2. Отыщите ярлык 3dsmax (рис. 1.1) и щелкните на нем левой кнопкой мыши.

Рис. 1.1. Ярлык для запуска 3D МАХ

В дальнейшем для сокращения записи мы будем использовать обозначение LM для левой кнопки мыши. Программа запущена. После ее загрузки на экране появится интерфейс 3D МАХ. Рабочее поле программы разделено на окна проекций. По умолчанию на экране располагаются четыре окна проекции — Тор (Вид сверху), Front (Вид спереди), Left (Вид слева) и окно центральной проекции Perspecntive (Перспектива). Единовременно только одно из окон проекции является активным, т. е. выделенным для построений. Активное окно отмечено рамкой белого цвета.

Создание объектов

Здесь вы познакомитесь с построением стандартных геометрических примитивов.

Параллелепипед

Построим каркасный параллелепипед.

1. Щелкните LM на кнопке Geometry (Геометрия) (рис. 1.2) и выберете в списке разновидностей объектов — Extended Primitives (Улучшенные примитивы). В свитке Object Type (Тип объекта) появятся кнопки с надписями, соответствующими типам стандартных примитивов.

Рис. 1.2. Панель инструментов с выделенной кнопкой Geometry

2. Щелкните LM на кнопке Chamfer Box (Параллелепипед с фаской).

В нижней части командной панели появятся три свитка: Creation Method (Метод создания), Keyboard Entry (Клавиатурный ввод) и Parameters (Параметры).

3. Щелкните LM в окне проекции Perspective (Перспектива) и, не отпуская кнопку, перетащите курсор по диагонали, растягивая основание.

Следите за изменением величин параметров Length (Длина) и Width (Ширина) в свитке Parameters (Параметры).

4. Отпустите кнопку мыши для фиксации длины и ширины основания.

5. Переместите курсор при отпущенной кнопке мыши вверх или вниз, чтобы задать высоту параллелепипеда.

Следите за значением параметра Height (Высота) в свитке параметров.

6. Щелкните LM для фиксации высоты. После щелчка мыши, фиксирующего высоту, передвиньте курсор еще на некоторое расстояние вверх и щелкните LM. Расстояние, которое вы отмерили сейчас, будет равно ширине фаски, срезаемой под углом в 45°.

Задать высоту фаски можно также с помощью параметра Fillet (Фаска).

7. Включите режим сглаживания поверхности фаски Smooth (Сглаживание).

В результате построенный параллелепипед должен иметь вид, показанный на рис. 1.3.

Мы получили параллелепипед с числом сегментов равным 1 (следует по умолчанию). Для изменения количества сегментов надо выставить параметры Lengt Segs (Сегментов по длине) и Width Segs (Сегментов по ширине). Увеличение числа сегментов бывает необходимо для последующего редактирования сетчатой оболочки объекта. Число сегментов в пределах фаски можно задать с помощью переменной Fillet Segs (Сегментов по фаске).

Рис. 1.3. Параллелепипед с фаской

Цилиндр с фаской

1. Нажмите на командной панели Create (Создать) кнопку Geometry (Геометрия), в списке выберите вариант Extended Primitives (Улучшенные примитивы) и нажмите кнопку Chamfer Cyl (Цилиндр с фаской).

С помощью этих действий можно создать цилиндр, цилиндрический сектор и многогранную призму.

2. Установите переключатель свитка Creation Metod (Метод создания) в положение Edge (От края) для построения основания цилиндра от одного края к другому, растягивая его по диаметру.

При построении основания от центра по величине радиуса, нужно установить переключатель Center (От центра).

3. Щелкните LM в той точке любого из окон проекции, где будет располагаться начальная точка основания цилиндра, и, не отпуская ее, перетяните курсор, растягивая основание. Отпустите кнопку мыши, зафиксировав тем самым радиус основания.

Величина параметра Radius (Радиус) в свитке Parameters (Параметры) отражает изменение радиуса основания.

4. Переместите курсор при отпущенной кнопке мыши вверх или вниз, задавая тем самым высоту цилиндра. Щелкните LM для фиксации высоты. После щелчка мыши, фиксирующего высоту, передвиньте курсор еще на некоторое расстояние вверх и щелкните LM. Расстояние, которое вы отмерили сейчас, будет равно ширине фаски, срезаемой под углом в 45°.

5. Задайте значения следующих параметров в свитке Parameters (Параметры):

· Height (Высота) — высота цилиндра;

· Height Segments (Сегментов по высоте) — количество сегментов поверхности;

· Cap Segments (Колец основания) — количество сегментов по радиусу;

· Fillet (Фаска) — величина фаски;

· Fillet Segs (Сегментов по фаске) — число сегментов по фаске. Результат построения цилиндра показан на рис. 1.4.

Рис. 1.4. Цилиндр с фаской

Тороидальный узел

1. Нажмите на командной панели Create (Создать) кнопку Geometry (Геометрия), в списке выберите вариант Extended Primitives (Улучшенные примитивы) и нажмите кнопку Torus Knot (Тороидальный узел).

С помощью этих действий можно построить целое семейство тел, варьируя их в пространстве и меняя форму и размер поперечного сечения трубы.

2. Установите переключатель свитка Creation Metod (Метод создания) в положение Diameter (Диаметр) для построения тороидального узла, растянутого по диаметру.

Чтобы построить тороидальный узел по радиусу, установите переключатель Radius (Радиус).

3. Установите переключатель Circle (Окружность) в разделе Base Curve (Базовая кривая), чтобы базовая кривая имела форму окружности.

4. Задайте значения параметров Warp Count (Число изломов) равным 3 и Warp Heigh (Высота изломов) равным 0,8.

Величина этих значений задается в долях радиуса базовой кривой.

5. Щелкните LM в той точке любого из окон проекции Perspective (Перспектива), где будет располагаться начальная точка узла, и передвиньте курсор, растягивая базовую кривую. Отпустите LM, зафиксировав таким образом радиус окружности. После щелчка мыши, фиксирующего радиус, передвиньте курсор еще на некоторое расстояние к центру или от центра базовой кривой и щелкните LM. Тем самым вы зададите радиус поперечного сечения трубки узла.

Величина параметра Radius (Радиус) в разделе Base Curve (Базовая кривая) отражает изменение радиуса окружности базовой кривой, а параметр Radius (Радиус) в разделе Cross Section (Сечение) — радиус сечения трубки узла.

6. Измените форму поперечного сечения трубки узла с круглой на эллиптическую. Для этого настройте величину Eccentricity (Эксцентриситет) в разделе Cross Section (Сечение), управляющую соотношением большой и малой полуосей эллипса (рис. 1.5).

Построенный тороидальный узел будет иметь вид, показанный на рис. 1.6.

Для того чтобы базовая кривая имела форму трехмерного узла, следует установить переключатель Knot (Узел) в разделе Base Curve (Базовая кривая).

Рис. 1.5. Таблица параметров сечения тороидального узла

7. Построим еще один узел с другой конфигурацией параметров. Установите переключатель Knot (Узел) и задайте, значения параметров Р==2, Q=3. Полученный при этом узел показан на рис. 1.7.

Параметры Р и Q управляют числом скруток трубки узла вокруг его центра и вдоль, продольной оси.

Можно и далее разнообразить формы узлов, настраивая параметры Twist (Скрутка), Lump Height (Высота выступа) и Lump Offset (Фаза выступа). Параметр Lump Height (Высота выступа) задается в долях радиуса сечения трубки узла, a Lump Offset (Фаза выступа) указывает положение выступа на окружности тора. Рис. 1.8 демонстрирует влияние этих параметров на форму тора.

Рис. 1.6. Тороидальный узел

Рис. 1.7. Тороидальный узел при Р=2 и Q=3

Рис. 1.8. Тороидальный узел, преобразованный с помощью параметров

Преобразование объектов

Для дальнейшей работы с построенными объектами разместим их в окне так, как показано на рис. 1.9. Для этого выполним преобразование перемещения.

1. Щелкните LM на кнопке Select and Move (Выделить и переместить).

2. Установите курсор над узлом в окне Perspective (Перспектива). Щелкните LM и, удерживая ее, переместите тороидальный узел, руководствуясь изображением на рис. 1.9. Для завершения перемещения отпустите кнопку мыши.

Команда, которой мы воспользовались для переноса тороидального узла, позволяет перемещать фигуру в любом направлении. Далее для переноса мы воспользуемся другой группой команд (рис. 1.10), позволяющих ограничивать свободу перемещения по координатным осям.

3. Щелкните LM на кнопке Х (Перемещение по оси X). Установите курсор над тороидальным узлом в окне Тор (Верх). Щелкните LM и, удерживая ее, переместите узел по оси X.

4. Щелкните LM на кнопке Y (Перемещение по оси Y). Переместите узел внутрь другого узла.

Рис. 1.9. Объекты, скомпонованные путем перемещения

Рис. 1.10. Кнопки ограничений по координатным осям

5. Щелкните LM на кнопке XY (Свободное перемещение) и переместите объекты в окне Perspective (Перспектива).

Если построенные вами объекты оказались громоздкими или, наоборот, слишком мелкими — отмасштабируйте их.

6. Щелкните LM на кнопке Select and Scale (Выделить и равномерно масштабировать панели инструментов).

7. Установите курсор на тороидальном узле, щелкните LM и, не отпуская ее, перетяните курсор вниз.

Уменьшение размеров объекта будет происходить равномерно в направлении всех трех осей глобальной системы координат.

8. Установите курсор на узел, щелкните LM и, не отпуская ее, перетяните курсор вверх.

В этом случае размеры объекта пропорционально увеличатся.

Назначение материалов

В этом разделе мы будем заниматься покраской созданных выше объектов и подбором требуемой фактуры для их поверхности. С помощью специального программного модуля Material Editor (Редактор материалов) можно подобрать готовый материал из существующих образцов или создать материал самостоятельно.

1. Для вызова окна редактора материалов выберите в меню Rendering (Визуализация) команду Material Editor (Редактор материалов).

Основными элементами окна редактора материалов, показанного на рис. 1.11, являются ячейки образцов материалов, кнопки инструментов управления редактором материалов и свитки параметров. Ячейки образцов материалов предназначены для предварительного просмотра материала перед его назначением выбранному объекту.

Рис. 1.11. Диалоговое окно редактора материалов

2. Вызовите диалоговое окно Material/Map Browser (Просмотр материалов и карт текстур). Для этого щелкните LM по кнопке Type (Тип) в окне редактора материалов. Появится окно просмотра, как на рис. 1.12.

Рис. 1.12. Окно просмотра материалов и текстур

Вызвать окно просмотра можно, так же щелкнув на кнопке Get Material (Получить материал).

3. Щелкните LM переключатель Mtl Library (Библиотека материалов) группы Browse From (Источник).

Библиотека материалов позволяет просматривать и выбирать имеющиеся там материалы.

4. Щелкните LM флажок Root Only (Только результат) группы Show (Показать).

Этот флажок отображает только результирующий составной материал.

5. В списке наименований материалов выберете щелчком LM Wood (Дерево).

Выбранный материал появится в окне просмотра образцов, находящемся в левом верхнем углу карты Material/Map Browser (Просмотр материалов и карт текстур). Осталось назначить материал объекту.

6. Постройте параллелепипед в окне проекции. Перетяните выбранный материал в одну из ячеек образцов редактора материалов и щелкните LM на кнопке Assing Material to Selection (Назначить материал выделению).

Раскрашенный параллелепипед показан на рис. 1.13. Остальным объектам назначьте материал самостоятельно.

Рис. 1.13. Пример использования материала

Итак, мы рассмотрели один из способов выбора и назначения материала объекту. Возможности создавать и редактировать материалы достаточно велики и предоставляют широкое поле для творчества. Далее эти возможности мы рассмотрим более подробно.

Создание источников света

Теперь, когда мы наложили материал на созданные объекты, нам потребуется добавить источники света для качественной их визуализации. Моделирование света — одна из самых сложных задач при создании изображения. Особенно это важно при работе над интерьерами.

По умолчанию, или пока нет созданных источников света, сцену освещают два казенных светильника. Один располагается в левом верхнем углу сцены, а другой — в правом нижнем углу. Любой созданный источник света автоматически отключает их.

1. Щелкните LM на кнопке Lights (Источник света) командной панели Creat (Создать).

В раскрывающемся списке содержится всего один вариант — Standard (Стандартный). В свитке Object Type (Тип объекта) появятся кнопки создания различных типов источников света (рис. 1.14).

Рис. 1.14. Кнопки с типами источников света

2. Щелкните LM на кнопке Onini (Точечный).

В нижней части командной панели появятся три свитка: General Parameters (Общие параметры), Projector Parameters (Параметры направленного света) и Shadow Parameters (Параметры тени). К названию второго свитка добавляется тип источника света. Свитки General Parameters (Общие параметры) и Shadow Parameters (Параметры тени) одинаковы для всех источников света.

3. Щелкните LM в проекции Тор (Верх) в верхней части экрана.

В указанной точке возникнет значок источника света — маленький восьмигранник, показанный на рис. 1.15. Можно перетащить источник света в другую точку, следя за изменением освещения объектов сцены в окнах проекции и подбирая оптимальное положение источника.

Рис. 1.15. Освещение всенаправленным источником света

Установка параметров света

Для установки параметров света выполните следующие действия.

1. Настройте параметры света в свитке General Parameters (Общие параметры):

· Multiplier (Усилитель) позволяет регулировать общий уровень интен-сивости света;

· Contrast (Контраст) задает контраст между областями диффузионного цвета и цвета подсветки освещенной поверхности. По умолчанию устанавливается равным 0;

· Soften Diff. Edge (Размытие краев диффузионного света) позволяет размывать границу между областями диффузионного отражения и подсветки. Установка величины в 100% ведет к устранению резкой границы между областями диффузионного отражения и подсветки, но при этом снижается уровень освещенности поверхности;

· Affect Diffuse (Влияет на диффузный цвет) и Affect Specular (Влияет на зеркальный цвет). По умолчанию устанавливаются оба параметра, однако можно использовать один источник света для освещения только области диффузионного отражения, а другой — только зеркального отражения.

2. В свитке Attenuation (Затухание) настройте следующие параметры эффекта затухания света с расстоянием:

· Start (Начало) и End (Конец) задают интервалы действия затухания в ближней зоне, где интенсивность света будет нарастать от нуля до постоянной величины (группа счетчиков Near), и в дальней зоне, где интенсивность света будет спадать до нуля (группа счетчиков Far);

· User (Применить) и Show (Показать) позволяют включить эффект затухания и обозначить граничные сферы зон затухания;

· Decay: None (Ослабление: Отсутствует) — интенсивность света остается постоянной на всем интервале его действия;

· Decay: Inverse (Ослабление: Обратная пропорция) — свет ослабевает обратно пропорционально расстоянию от источника;

· Decay: Inverse Square (Ослабление: Обратный квадрат) — свет ослабевает обратно пропорционально квадрату расстояния.

3. Настройте параметры теней. Вы найдете их в свитке Shadow Parameters (Параметры теней):

· Cast Shadows (Отбрасывать тени) включает режим воспроизведения теней от помеченного источника света;

· Use Shadow Maps (Применить карты теней) указывает, что тени рассчитываются как проекции объектов на поверхности сцены, куда падают тени.

4. Щелкните LM в окне Perspective (Перспектива).

Вы установили на сцене один источник света. Второй источник задайте в правом нижнем углу окна и настройте его по той же схеме. Далее мы более подробно остановимся на моделировании света.

Установка камер

Выполните следующие шаги:

1. Щелкните LM на кнопке Cameras (Камеры) командной панели Create (Создать).

Раскрывающийся список содержит всего один вариант — Standard (Стандартные). В свитке Object Type (Тип объекта) появятся кнопки для создания двух типов камер — Target (Нацеленная) и Free (Свободная) (рис. 1.16).

Рис. 1.16. Кнопки с типами камер

2. Щелкните LM на кнопке камеры типа Free (Свободная).

В нижней части командной панели появится свиток Parameters (Параметры).

3. Для установки камеры щелкните LM в верхней части окна проекции Perspective (Перспектива). Вид свободной камеры показан на рис. 1.17.

Рис. 1.17. Вид свободной камеры

Перейдем к настройке параметров камеры. Это можно сделать сразу же после ее создания или позднее, выделив требуемую камеру и перейдя на панель Modify (Изменить).

Настройка параметров камеры

Настройка параметров камеры осуществляется в свитке Parameters (Параметры).

1. В поле счетчика Lens (Объектив) задайте фокусное расстояние объекта. Попробуйте несколько вариантов значений.

Чем больше фокусное расстояние, тем сильнее увеличение в окне камеры.

2. Установите размер поля зрения камеры. Выбор нужного значения производится щелчком LM на кнопке слева от счетчика FOV (Поле зрения), которая снабжена падающем меню с двумя дополнительными кнопками, как на рис. 1.18.

Рис. 1.18. Параметры для установки поля зрения камеры

3. Отметьте Show Con (Показать пирамиду видимости).

4. Щелкните правой кнопкой мыши (в дальнейшем для правой кнопки мыши мы будем использовать обозначение RM) на названии окна Perspective (Перспектива). В появившемся контекстном меню выберите команду View (Вид), а затем команду Camera 01.

Ваше окно проекции перспективы осталось активизированным из точки расположения камеры. Это дает возможность воспользоваться группой кнопочного меню для управления видом окна через камеру, расположенного в правой нижней части экрана. Оно представлено на рис. 1.19.

Рис. 1.19. Кнопки управления видом через камеру

5. Щелкните LM на кнопке Dolly Camera (Движение камеры) и передвигайте курсор в окне камеры. Установите выбранный вид.

6. Щелкните LM на кнопке Roll Camera (Крен камеры) и, передвигая курсор, установите поворот камеры

7. Измените ширину поля зрения. Для этого щелкните LM на кнопке Field of View (Поле зрения) и перемещайте курсор по вертикали в окне камеры.

8. Попробуйте перемещать камеру вправо-влево и вверх-вниз использовав кнопку Truck Camera (Сопровождение камерой). После щелчка LM по этой кнопке следует щелкнут LM в окне камеры и переместить курсор в нужном направлении.

Визуализация изображения

Теперь вы можете визуализировать полученную выше сцену. Посмотрим на нее из окна первой камеры.

1. Щелкните RM на названии окна Perspective (Перспектива). Выберите из появившегося меню команду View (Вид), а затем команду Camera 01.

2. В меню Rendering (Визуализация) выберите команду Render (Визуализировать). В диалоговом окне нажмите кнопку Render (Визуализировать).

Диалоговое окно исчезнет и на экран будет выведен освещенный вид сцены через указанную камеру. В диалоговом окне вы использовали только кнопку Render (Визуализация). Значение остальных параметров окна будет рассмотрено дальше. Для снятия визуализированной сцены щелкните LM на кнопке с крестом в правом верхнем углу экрана визуализации. Попробуйте самостоятельно вывести сцену визуализации, выбрав другую камеру и переместив источники света.

Анимация

До сих пор мы формировали статическую сцену. Теперь мы будем рассматривать ее, как первый статический кадр в анимации. Под анимацией понимается процесс создания последовательности изображений. Каждое изображение отражает некоторое изменение сцены. Изменения могут касаться положения объектов в пространстве, формы объектов, свойств материалов, состояния внешней среды и других атрибутов, допускающих анимацию. Иными словами, это автоматизированный процесс создания мультипликационного ролика. Приступим к его формированию. Для начала подготовим окна проекций.

1. Нажмите последовательные комбинации клавиш <Shift> + <С> и <Shift>+ +<L>. Этим вы скрыли камеры и источники света.

2. Сделайте активным окно перспективы.

3. Нажмите клавишу<С> и в появившемся меню выберете Camera 02.

В окно перспективы вы поместили вид через камеру, зарегистрированную в списке под номером 02.

4. Щелкните LM на кнопке Time Configuration (Настройка временных интервалов) панели управления анимацией.

5. На открывшейся панели выставите значение 0 в окне Start Time (Начало временного интервала) и значение 100 в окне End Time (Конец временного интервала).

Вы задали длительность периода анимации.

6. Щелкните LM на ползунке таймера анимации и, не отпуская кнопку, перетяните его влево на десять кадров. Количество кадров будет отражаться в счетчике ползунка.

Позиционные ключи анимации

1. Щелкните LM на кнопке Animate (Анимация), расположенной в группе управления анимацией (рис. 1.20).

Рис. 1.20. Кнопки управления анимацией

Кнопка Animate (Анимация) окрасится в красный цвет, и активное окно проекции будет обведено красной рамкой, что указывает на переход пакета в режим анимации.

2. Выберите цилиндр в окне проекции и с помощью кнопки переноса сместите его немного влево.

3. С помощью кнопки на панели управления анимацией переведите ползунок таймера анимации к кадру 20.

4. Переместите цилиндр еще немного в окне проекции.

Повторяя пп. 2 и 3, создайте еще несколько ключевых кадров. Теперь стало ясно, что только в отдельных установленных кадрах производят некоторое изменение в окне проекции. Эти кадры называются ключевыми.

Ключ поворота

Выполнить следующие действия.

1. Переведите ползунок таймера анимации на 100-й кадр.

2. Выделите параллелепипед и щелкните RM. В появившемся меню выберите команду поворота и используйте ее.

Данная команда создаст ключ поворота. Для простых видов модификации с равномерным изменением параметров достаточно создания одного ключа с учетом, что начальный кадр анимации фиксирован. К таким видам модификации относятся: равномерное перемещение, поворот, изменение яркости освещения.

Попробуйте самостоятельно создать ключи масштабирования для оставшихся объектов.

Предварительный просмотр ролика

Полученный анимационный ролик можно тотчас просмотреть.

1. Щелкните LM на кнопке воспроизведения анимации панели управления анимацией.

Если не отключить просмотр анимации, то ее воспроизведение будет циклически повторяться.

2. Для остановки просмотра анимации щелкните LM кнопку Stop (Стоп), которая будет расположена на месте кнопки воспроизведения анимации.

Самостоятельно создайте анимацию для камеры и источника света.


Работа с камерой

Создание камеры

Настройка параметров камеры

Просмотр сцены с определенной точки зрения можно обеспечить, настраивая окно проекции. Однако использовать для этих целей камеру гораздо удобнее. К тому же, при наличии камеры ее можно перемещать по сцене в режиме анимации.

Создание камеры

1. Создайте на экране один из геометрических объектов.

Нажмите на командной панели Create (Создать) кнопку Cameras (Камеры). В свитке Object Type (Тип объекта) появятся кнопки двух типов камер — Target (Нацеленная) и Free (Свободная) (рис. 13.1).

Рис. 13.1. Свиток Object Typeс кнопками типов камер

2. Щелкните LM на кнопке Target (Нацеленная).

В нижней части командной панели появится свиток Parameters (Параметры), одинаковый для обоих типов камер.

3. Щелкните LM в той точке окна проекции, откуда будете смотреть на объект.

Нацеленная камера создается точно так же, как и нацеленный прожектор. Линиями голубого цвета обозначаются границы поля зрения (пирамиды видимости) камеры. Вид нацеленной камеры показан на рис. 13.2.

Рис. 13.2. Вид нацеленной камеры

Настройка параметров камеры

Настроить параметры камеры можно как сразу же после ее создания, так и позднее, перейдя на командную панель Modify (Изменить). Настройка проводится в свитке Parameters (Параметры).

1. Задайте фокусное расстояние объектива камеры в счетчике Lens (Объектив). Чем больше фокусное расстояние, тем сильнее увеличение в окне камеры.

2. Установите размер поля зрения камеры, определяемый величиной угла при вершине пирамиды видимости, в счетчике FOV (Поле зрения).

Этот параметр напрямую связан с величиной фокусного расстояния объектива: чем больше фокусное расстояние линзы, тем меньше поле зрения, и наоборот. Можно задать размеры поля зрения по горизонтали, по вертикали или по диагонали. Выбор нужного варианта производится кнопкой слева от счетчика FOV (Поле зрения), которая устроена, как раскрывающаяся панель (рис. 13.3).

3. Установите режим Ortografphic Projection (Ортографическая проекция), чтобы представить изображение в окне камеры в виде ортографической, а не перспективной проекции.

4. Вместо настройки параметров Lens (Объектив) и FOV (Поле зрения) можете выбрать один из готовых объективов с заданным фокусным расстоянием и соответствующим полем зрения с помощью группы кнопок Stock Lenses (Сменные линзы), надписи на которых соответствуют фокусному расстоянию.

Щелчок на любой из кнопок меняет значения в полях обоих счетчиков — Lens (Объектив) и FOV (Поле зрения).

Рис. 13.3. Параметры установки поля зрения камеры и фокусного расстояния

5. Установите или сбросьте флажки:

· Show Cone (Показать пирамиду видимости) — обеспечивает показ пирамиды видимости камеры во всех окнах проекций, даже если значок камеры не выделен;

· Show Horizon (Показать горизонт) — позволяет изобразить в окне камеры линию горизонта, соответствующую настоящему положению камеры, что бывает необходимо в тех случаях, когда в качестве фона используется пейзаж, имеющий также линию горизонта.

6. Установите, на каком удалении от камеры начинается и где заканчивается действие эффектов окружающей среды, подобных туману, в группе Environment Ranges (Диапазон влияния среды):

· Near Range (Ближний край) — счетчик определяет минимальную дальность до области воздействия;

· Far Range (Дальний край) — счетчик определяет максимальную дальность;

· Show (Показать) — флажок включает режим показа двух плоскостей, демонстрирующих ближнюю и дальнюю границы зоны проявления эффектов окружающей среды (рис. 13.4).

7. Настройте параметры усечения изображения сцены в окне камеры плоскостями, установленными на заданном расстоянии от камеры, перпендикулярно линии взгляда, в группе Clipping Planes (Плоскости усечения).

В окне камеры будет отражаться только часть сцены между ближней и дальней плоскостями усечения.

8. Для задания расстояния до ближней (счетчик Near Clip) и дальней (счетчик Far Clip) плоскостей усечения установите флажок Clip Manually(Усечение вручную).

Плоскости усечения изображаются в виде диагонально перечеркнутых прямоугольников красного цвета в пределах пирамиды видимости (рис. 13.5).

Рис. 13.4. Режим показа ближней и дальней границ эффектов окружающей среды

Рис. 13.5. Режим включения плоскостей усечения

9. Проведите самостоятельно установку параметров для камеры типа Free(Свободная).


Редактирование и модификация сплайнов

Редактирование сплайнов на уровне форм

Редактирование сплайнов на уровне вершин

Редактирование сплайнов на уровне сегментов

Редактирование сплайнов на уровне сплайнов

Дополнительные модификаторы сплайнов

Модификатор Fillet/Chamfer

Модификатор Trim/Extend

Сплайны, как и любой другой тип объектов, допускают редактирование и модификацию. Их можно редактировать на уровне формы и на уровне ее подобъектов, таких как отдельные сплайны, их вершины и сегменты. Для каждого типа подобъектов имеются свои виды модификаторов. В режиме редактирования на уровне подобъектов могут быть выделены только соответствующие подобъекты сплайна. Инструменты преобразований тоже могут быть применены лишь к подобъектам. Средства редактирования и модификации сплайнов на различных уровнях позволяют создавать из сплайнов практически любые двумерные формы.

Редактирование сплайнов на уровне форм

Редактирование ,сплайновой формы позволяет присоединить к ней другие готовые сплайны, создать отрезки линий в качестве сегментов текущего сплайна, изменить параметры интерполяции криволинейных сегментов, заданных при его создании.

Перейдем к редактированию.

1. На командной панели Create (Создать) нажмите кнопку Shapes(Формы), в списке выберите значение Splines (Сплайны), нажмите кнопку Line (Линия) и постройте два отдельных сплайна, как показано на рис. 6.1.

2. Перейдите на командную панель Modify (Изменить).

Если последний построенный сплайн остался выделенным, то на командной панели сразу появятся свитки редактирования сплайнов.

3. Раскройте свиток Geometry (Геометрия) и выберите кнопку Attach (Присоединить).

Это действие позволяет присоединить к выделенной сплайновой форме готовый сплайн.

4. Переместите курсор в окно проекции и укажите на присоединяемый сплайн.

Рис. 6.1. Редактируемые сплайны

Когда курсор примет специальный вид, щелкните LM. Два сплайна будут соединены в одну форму. На это указывает раздвинувшаяся рамка выбора объектов. Результат присоединения показан на рис. 6.2

Рис. 6.2. Сплайны, объединенные в одну форму

5. Отметьте в свитке Geometry (Геометрия) флажок Reorient (Переориентировать).

Его установка вызовет переориентацию присоединяемого сплайна в соответствии с локальной системой координат редактируемого сплайна.

Создайте еще один сплайн следующим образом.

1. В свитке Geometry (Геометрия) нажмите кнопку Create Line (Создать линию).

Это позволит создавать новые линии, которые будут добавляться к текущей сплайновой форме.

2. Переместите курсор в окно проекции на один из концов созданного сплайна и начинайте рисовать.

Если перед началом рисования указать курсором на один из концов текущего сплайна, то курсор примет вид, соответствующий режиму присоединения создаваемой линии. В этом случае линия будет присоединена к текущему сплайну в качестве сегмента.

Теперь посмотрим, как расширить возможности редактирования сплайнов. С этой целью используем вариант редактирования с помощью кнопки Edit Spline (Редактирование сплайна).

3. Щелкните LM накнопке Configure Button Sets (Конфигурированиенаборовмодификаторов), воткрывшемсясвиткевыберетевариант Patch/Spline Editing (Путь/Редактируемыйсплайн) ивпоявившемсяменющелкнитенакнопке Edit Spline (Редактированиесплайна) (рис. 6.3).

Рис. 6.3. Меню правки стека

Список свитка Geometry (Геометрия) пополнился новыми элементами.

4. Нажмите кнопку Attach Multiple (Присоединить несколько), которая позволит присоединить к выделенной сплайновой форме несколько новых форм. После этого появится одноименное диалоговое окно (рис. 6.4).

5. Выделите в списке окна имя первой созданной формы. По умолчанию ей было присвоено имя Line01. Щелкните LM на кнопке Attach (Присоединить) в правом нижнем углу окна.

Выделенный в списке объект будет присоединен к ранее указанной сплайновой форме. В списке можно выделить любое число ранее созданных форм. В нашем случае список состоит из одной формы.

Кнопки свитка Interpolation (Интерполяция) управляют интерполяцией криволинейных сегментов сплайна. Ее параметры: Steps (Шаги), Optimize(Оптимальная) и Adaptive (Адаптивная).

Рис. 6.4. Диалоговое окно присоединения нескольких форм

Использование настроек свитка Rendering (Визуализация) позволяет сделать сплайн визуализированным объектом. Параметры визуализации: Renderable(Визуализируемый), Generate Mapping Coords (Проекционные координаты) и Thickness (Толщина).

Редактирование сплайнов на уровне вершин

Редактирование сплайнов на уровне вершин позволяет из простого сплайна создать сплайн практически любой конфигурации.

1. Отмените команды предыдущего редактирования с помощью инструмента Undo (Предыдущий).

При этом один из сплайнов должен остаться выделенным.

2. В свитке Selection (Выбор) щелкните LM на левой из пиктограмм, показанных на рис. 6.5.

Рис. 6.5. Пиктограммы выбора подобъектов редактирования

Вами выбран режим редактирования вершин. В выделенном сплайне все вершины обозначатся крестиками, а первая вершина — квадратиком.

3. Для изменения типа вершины выделите одну или несколько вершин любым известным способом (например, прямоугольной рамкой), укажите курсором на одну из них и щелкните RM.

В нижней части появившегося меню Tools 1 (рис. 6.6) приведен перечень четырех типов вершин. Текущий тип будет помечен галочкой.

Рис. 6.6. Контекстное меню преобразований

4. Выберите нужный тип вершины из предложенного списка и щелкните LM.

Остальные команды редактирования вершин будем выбирать в свитке Geometry (Геометрия).

5. Задайте параметр Connect (Соединить), который позволяет соединять две вершины на концах разомкнутого сплайна отрезком прямой.

6. Установите курсор на один из концов ломаной и, нажав LM, перетащите курсор ко второму концу ломаной. Когда курсор примет специальный вид, отпустите кнопку.

Пример соединения вершин показан на рис. 6.7.

Используем теперь кнопку Break (Разбить). Она позволяет разбить любую, кроме концевых, вершину сплайна на две совпадающие, но не соединяющиеся вершины.

7. Выделите предназначенную для разбиения вершину и щелкните LM на кнопке Break (Разбить).

Вновь добавленная в месте разрыва вершина становится первой и обозначается квадратиком.

8. Нажмите кнопку Refine (Уточнить).

Данное действие позволяет вставить дополнительную вершину в произвольной точке сплайна без изменения его формы. Такая вершина может понадобиться, например, для разрыва в этом месте сплайна.

Рис. 6.7. Пример соединения двух вершин сплайна

9. Установите курсор на линию сплайна и, когда курсор примет специальный вид, щелкните LM.

Примечание

При активизированной кнопке Refine (Уточнить) можно вставить неограниченное число уточняющих вершин.

10. Нажмите кнопку Insert (Вставить), которая дает возможность вставить вершину в любой точке сплайна, сразу же переместить ее и продолжить добавление новых вершин и сегментов сплайна.

11. Установите курсор на линию сплайна и, когда курсор примет специальный вид, щелкните LM, перетащите курсор в нужное место и щелкните LM еще раз.

Возможность добавлять вершины при выбранной команде не ограничена. Для завершения команды щелкните RM.

12. Нажмите кнопку Weld (Слить), позволяющую слить две концевые или совпадающие вершины в одну.

13. Подведите одну концевую вершину к другой с помощью инструмента Move (Переместить) и, если расстояние между вершинами окажется меньше, чем указанное в счетчике Weld Threshold (Порог слияния), то появится сообщение "WeldCoincidentendpoint?" (Слить совпадающие вершины). Щелкните на кнопке Yes.

Таким способом можно получить замкнутую форму из любого незамкнутого сплайна. Пример слияния вершин показан на рис. 6.8.

Рис. 6.8. Пример слияния вершин сплайна

14. Для удаления вершин выделите их любым из способов и нажмите кнопку Delete (Удалить).

Данное действие не только удалит вершины, но и объединит сегменты, на стыке которых они располагались, в один сегмент. Результат удаления вершины приведен на рис. 6.9.

Рис. 6.9. Пример удаления выделенной вершины сплайна

Рассмотрим режим, при котором можно синхронно перемещать маркеры всех касательных векторов вершин типа Безье.

1. Постройте сплайн-окружность, нажав в свитке Object Type (Тип объекта) кнопку Circle (Окружность). Выберите все вершины сплайн-формы способом прямоугольной рамки.

2. Установите курсор на одну из вершин и щелкните RM.

3. Выберите в открывшемся списке вершину Безье.

Выделенные вершины обозначены теперь красными крестиками, а концы касательных векторов вершин Безье — зелеными прямоугольниками.

4. В свитке Selection (Выбор) отметьте флажок Lock Handles (Блокировать маркеры) и установите переключатель All (Все).

5. Выберите инструмент Move (Переместить) и переместите любой из маркеров касательного вектора.

Перемещение любого из маркеров заставляет синхронно перемещаться и все остальные маркеры. На рис. 6.10 показаны исходная сплайн-окружность и сплайн, полученный из нее путем синхронного перемещения вершин.

Рис. 6.10. Пример синхронного перемещения вершин сплайн-окружности

6. Установите переключатель Alike (Подобные) и в этом режиме переместите любой из маркеров касательного вектора.

Обратите внимание, что теперь перемещаются не все маркеры, а только соответствующие выбранному. То есть, если выбран входящий маркер, то перемещаются только входящие маркеры остальных касательных векторов.

Редактирование сплайнов на уровне сегментов

Редактирование сплайнов на уровне сегментов позволяет разбивать сплайн на отдельные части, добавлять новые вершины к существующим сегментам, отделять сегменты, преобразуя их в самостоятельные формы и удалять сегменты.

1. Сбросьте выбор вершин, щелкнув LM в любой точке экрана.

2. В свитке Selection (Выбор) щелкните на кнопке с пиктограммой Segment (Сегмент).

Вы перешли в режим редактирования сплайнов на уровне сегментов.

3. Для изменения типа сегмента выделите один или несколько сегментов. Выделенные сегменты отличаются красным цветом.

4. Выставьте курсор на любой из них и щелкните RM.

Появится контекстное меню сегментов, показанное на рис. 6.11. В нижней части меню приведен перечень типов сегментов: Curve (Кривая) и Line (Линия). Текущий тип отмечен галочкой.

Рис. 6.11. Меню преобразования с разделом типов сегментов

5. Назначьте для выбранного сегмента тип Line (Линия).

6. Нажмите кнопку Break (Разбить) в свитке Geometry (Геометрия).

Это действие позволяет разбить сплайн на два отдельных сплайна путем вставки вершины в указанной точке.

7. Наведите на сегмент курсор сплайна и, когда он примет специальный вид, щелкните LM.

В указанной точке на сегменте появится прямоугольник, обозначающий начало сегмента. Сам же исходный сегмент будет разорван в этой точке. Чтобы убедиться в этом, достаточно переместить его с помощью инструмента Move (Переместить).

8. Нажмите кнопку Refine (Уточнить) в свитке Geometry (Геометрия), которая позволяет вставить вершину в произвольной точке сплайна, не разбивая сплайн и не меняя его формы.

9. Укажите курсором на сегмент сплайна и, когда курсор примет вид, показанный на рис. 6.12, щелкните LM.

Новая вершина будет отмечена крестиком.

Рис. 6.12. Пример разбиения сегмента сплайна

10. Выделите сегмент и нажмите кнопку Detach (Отделить) в свитке Geometry (Геометрия).

Это позволит отделить сегмент сплайна, превратив его в самостоятельный объект.

Установка флажка Same Shape (Та же форма) заставляет отдельный сегмент стать частью той же формы, к которой относится сплайн. Установленный флажок Reorient (Исходная ориентация) позволяет привести ориентацию локальных осей координат отделяемого сегмента в соответствие с ориентацией осей координат активного окна проекции, а флажок Copy (Копия) отделяет копию сегмента.

11. Если не отмечен параметр Same Shape (Та, же форма), появится одноименное диалоговое окно. Введите имя создаваемой формы и подтвердите нажатием кнопки ОК.

Отделенный сегмент окрасится в другой цвет.

12. Выделите сегмент, выставьте в счетчике Divisions (Деления) число разбиений и щелкните на кнопке Divide (Разделить) в свитке Geometry (Геометрия).

Это действие, позволяющее равномерно разбить выделенный сегмент на более мелкие сегменты за счет размещения равноудаленных вершин по всей длине сегмента. Число добавляемых сегментов задается в счетчике Divisions (Деления). На рис. 6.13 показан вариант разбиения сегмента.

13. Кнопка Delete (Удалить) позволяет удалять выделенный сегмент сплайна, а кнопка Insert (Вставить) выполняет ту же операцию, что и аналогичная команда редактирования вершин.

Рис. 6.13. Сегмент сплайна, разбитый на части

Редактирование сплайнов на уровне сплайнов

Данный вид редактирования позволяет объединять, замыкать, выполнять булевские и другие операции над сплайнами.

1. Выделите для редактирования один из построенных сплайнов. В свитке Selection (Выбор) щелкните на кнопке с пиктограммой Spline (Сплайн).

Выделенный сплайн приобретет красный цвет в окнах проекций.

2. Если выбранный вами сплайн не замкнут, то замкните его, нажав кнопку Close (Замкнуть) в свитке Geometry (Геометрия).

Начальная и конечная точки вашего сплайна соединятся отрезком прямой. На рис. 6.14 показано замыкание ранее созданного сплайна.

Рис. 6.14. Пример замыкания сплайна

3. Нажмите кнопку Outline (Контур).

Выполненное действие позволяет построить контур любой ширины выделенного сплайна. Он представляет собой замкнутый сплайн. Пример построения контура приведен на рис. 6.15.

Рис. 6.15. Пример создания контура сплайна

4. Укажите курсором на редактируемый сплайн. Когда курсор примет специальный вид, щелкните LM и перетащите курсор на требуемое расстояние, создавая контур.

Второй способ построения контура состоит в том, чтобы выделить исходный сплайн, задать расстояние между ним и линией контура в счетчике Outline Width (Ширина контура) и щелкнуть на кнопке Outline (Контур). Если флажок Center (От центра) не отмечен, то исходный сплайн остается на месте, а контур обводки создается от него на расстоянии, заданном в счетчике. Если отметить флажок Center (От центра), то исходный сплайн и линия контура смещаются в противоположных направлениях на половину величины, указанной в счетчике.

Рассмотрим варианты выполнения булевской операции над сплайнами. Здесь понадобятся оба построенных сплайна. И они должны быть составными частями одной двумерной формы (см. разд. "Редактирование сплайнов на уровне форм" ранее в этом занятии).

1. Переместите один из сплайнов с помощью инструмента Move(Переместить) до пересечения с другим, как на рис. 6.16, и оставьте его выделенным (красного цвета).

2. Объедините оба сплайна, щелкнув LM на кнопке Attach (Присоединить) в свитке Geometry (Геометрия), и далее щелкните на присоединяемом сплайне.

Рис. 6.16. Сплайны, подготовленные для Объединения

3. Щелкните LM последовательно на кнопках Union (Объединение) и Boolean (Булевские). Наведите на второй сплайн курсор и, когда он примет специальный вид, щелкните LM.

Пример объединения двух сплайнов показан на рис. 6.17. Две оставшиеся логические операции: Intersection (Пересечение) и Subtraction (Исключение) выполните самостоятельно.

Рис. 6.17. Результат булевского объединения двух сплайнов

4. Для работы с командой Mirror (Отразить) назначьте один из вариантов зеркального отражения и щелкните на кнопке Mirror (Отразить). Выделенный сплайн зеркально отразится в соответствии с пиктограммой на кнопке группы вариантов. Флажок Copy (Копия) позволяет создать зеркальную копию выделенного сплайна.

Нажатие кнопки Reverse (Обратить) ведет к обращению порядка следования вершин выделенного сплайна.

Дополнительные модификаторы сплайнов

В дополнение к стандартным способам редактирования предлагаются специальные модификаторы сплайнов. Рассмотрим работу двух модификаторов:

Fillet/ Chamfer (Закругление/Срез) и Trim/ Extend (Подрезание/Наращивание).

В свитке Modifiers (Модификаторы) командной панели Modify (Изменить) может размещаться до 32 кнопок модификаторов. Добавим в свиток модификаторов требуемые модификаторы.

1. В свитке Modifiers (Модификаторы) щелкните на кнопке Configure Modifiers Sets (Конфигурирование наборов модификаторов).

Появится диалоговое окно Configure Modifiers Sets (Конфигурирование наборов модификаторов).

2. В появившемся окне диалога увеличьте значение в счетчике Total Buttons(Всего кнопок) до требуемой величины, но не превышающей 32.

Ниже появится запрошенное число новых кнопок без надписей

3. Выделите в списке Modifiers (Модификаторы) имя нужного модификатора и перетащите его на новую кнопку.

Наименование модификатора появится на выбранной кнопке.

4. Закончив настройку состава кнопок в окне диалога, щелкните на кнопке ОК.

Модификатор Fillet/Chamfer

Выполните следующие шаги:

1. Постройте сплайн в виде стандартного многоугольника для редактирования его с помощью модификатора Fillet/ Chamfer (Закругление/Срез) и оставьте его выделенным.

Необходимым условием использования данного модификатора является наличие у сплайна вершин типа Corner (С изломом) или Bezier Corner(Безье с изломом). Применительно к вершинам типа Smooth (Сглаженная) и Bczie (Безье) данный модификатор работать не будет.

2. Выделите строку модификатора Fillet/ Chamfer (Закругление/Срез) в окне диалога Modifiers (Модификаторы). Щелкните на кнопке ОК.

На командной панели Modify (Изменить) установится режим правки вершин и появится свиток Edit Vertex (Правка вершин).

3. Выделите любую вершину многоугольника и задайте радиус закругления в счетчике Radius (Радиус). Щелкните LM на кнопке Apply (Применить).

4. Для среза угла установите в счетчике группы Chamfer (Срез) расстояние новых вершин от срезаемой вершины сплайна и щелкните LM на кнопке Apply (Применить).

Модифицированный с помощью команды Fillet/ Chamfer (Закругление/Срез) многоугольник и показан на рис. 6.18.

Рис. 6.18. Пример использования модификаторов закругления и среза

Модификатор Trim/Extend

Модификатор Trim/ Extend (Подрезание/Наращивание) применяется к формам, состоящим, по крайней мере, из двух пересекающихся сплайнов. Первый — подрезает сегмент сплайна до точки пересечения его с другим сплайном, а второй — дотягивает сегмент первого сплайна до пересечения со вторым.

1. Постройте два пересекающихся сплайна, выделите всю форму и нажмите кнопку Trim/ Extend (Подрезание/Наращивание) в свитке Modifiers (Модификаторы).

В нижней части командной панели Modify (Изменить) появится свиток Trim/ Extend (Подрезание/Наращивание).

2. Установите переключатель в группе Operation (Операция) в положение Trim Only (Только подрезание).

Установка флажка Infinite Boundaries (Неограниченная протяженность) позволяет при расчете точек пересечения рассматривать открытые сплайны как имеющие неограниченную протяженность. Это, например, позволяет подрезать линию, пересекающуюся с воображаемым продолжением другой линии.

3. Установите переключатель группы Intersection Projection (Проекция пересечения) в положение View (Проекция).

При установке переключателя в положение View (Проекция) или Construction Plane (Конструкционная плоскость) ищется пересечение проекций линий соответственно с плоскостью активного окна или с текущей конструкционной плоскостью. При установке переключателя в положение Non (3D) (Без проекции (3D)) ищется истинное пересечение линий в трехмерном пространстве, а не пересечение проекций линий.

4. Для подрезания сегментов нажмите кнопку Pick Locations (Укажите места), затем укажите на сегмент сплайна, который требуется подрезать. Когда курсор примет вид, соответствующий режиму подрезания, щелкните LM.

Формы до модификации и после выполнения действия Trim (Подрезание) показаны на рис. 6.19.

Рис. 6.19. Пример использования модификатора подрезания

5. Для наращивания сплайна установите переключатель в группе Operation(Операция) в положение Extend Only (Только наращивание) и нажмите кнопку Pick Locations (Укажите места), затем щелкните на сегментах разомкнутого сплайна, который следует дотянуть.

На рис. 6.20 представлены сплайны до и после выполнения операции наращивания.

Самостоятельно постройте заготовку для корпуса скрипки, как на рис. 2.21.

При построении используйте сплайн-эллипс, две сплайн-окружности и модификатор Trim (Подрезание).

Рис. 6.20. Пример выполнения операции наращивания

Рис. 6.21. Пример конструирования объекта с использованием стандартных сплайнов и модификатора подрезания


Редактирование произвольных объектов

Назначение свитка Modifiers

Изменение и дополнение списка модификаторов

Назначение кнопок ModifierStack

Скрутка объекта

Изгиб объекта

Заострение

Зашумление

Выдавливание

Вращение

Мебель для интерьера

До сих пор мы обращались к командной панели Modify (Изменить) для редактирования геометрии сплайнов, сетчатых оболочек и объектов, созданных методом лофтинга. Ниже будут рассматриваться возможности редактирования характеристик любых других объектов.

Назначение свитка Modifiers

При обращении к командной панели Modify (Изменить) самый верхний свиток Modifier list (Список модификаторов) содержит кнопки, соответствующие различным модификаторам (рис. 10.1). Для применения модификатора к выделенному объекту достаточно щелкнуть LM на соответствующей кнопке, чтобы получить доступ к параметрам модификатора. Если какая-либо кнопка модификатора не активна (название модификатора обозначено серым цветом), то это означает, что данный модификатор не может быть применен к выбранному объекту.

Рис. 10.1. Свиток с раскрывающимся списком и кнопками модификаторов

Изменение и дополнение списка модификаторов

Требуемый стандартный набор модификаторов можно выбрать из списка, дополнить и сохранить под заданным именем.

1. Щелкнем LM на кнопке Configure Modifier Sets (Конфигурирование наборов модификаторов), находящейся в ряду кнопок под стеком • модификаторов

Появится список наборов модификаторов, показанный на рис. 10.2.

Рис. 10.2. Список наборов модификаторов

2. Выберем щелчком LM из этого списка команду Parametric Modifiers(Параметрические модификаторы).

Указанный набор будет помечен знаком >. Добавим в появившийся список модификатор Bend (Изгиб).

3. С этой целью вызовем еще раз список наборов модификаторов и выберем в нем команду Configure Modifier Sets (Конфигурирование наборов модификаторов).

Появится диалоговое окно Configure Modifier Sets (Конфигурирование наборов модификаторов), показанное на рис. 10.3.

4. Увеличим значение в счетчике Total Buttons (Количество кнопок) на 1 для добавления еще одной кнопки.

В группе Modifiers (Модификаторы) появится дополнительная кнопка без надписи.

Замечание

Общее количество кнопок модификаторов в свитке не должно превышать 32.

Рис. 10.3. Окно конфигурации набора кнопок

5. Выделим модификатор Bend (Изгиб) в списке левой части окна и перетащите его, не отпуская LM, на добавленную свободную кнопку. Имя выбранного модификатора появится на указанной кнопке.

Для удаления какого-либо модификатора из группы щелкнем на соответствующей кнопке и перетащим курсор в область списка в левой части окна. После чего выбранная кнопка "очистится".

6. Для сохранения нового набора кнопок введем для него имя в текстовом поле раскрывающегося списка Sets (Наборы) и щелкнем LM на кнопке Save (Сохранить).

7. Закончив составление нового списка кнопок, нажмем кнопку ОК.

Назначение кнопок ModifierStack

При редактировании сплайнов и сетей вы уже сталкивались с использованием стека модификаторов. Рассмотрим подробнее назначения кнопок стека.

При использовании какого-либо модификатора (количество модификаторов, применяемых к одному и тому же объекту, не ограничено), он помещается в стек объекта. Под стеком имеется в виду список всех модификаторов, примененных к объекту, в хронологическом порядке (рис. 10.4). Управление стеком модификаторов осуществляется с помощью кнопок свитка.

Рис. 10.4. Список стека модификаторов

Pin Stack (Закрепить стек) — закрепляет отображение стека модификаторов текущего объекта вне зависимости от того, какие объекты будут выделены в дальнейшем.

Show End Result On/ Off Toggle (Показать конечный результат: включить/выключить) — кнопка-переключатель, по умолчанию устанавливающая режим демонстрации объекта в том виде, который он приобретает после применения всех модификаторов. Если кнопка нажата, на экране не отображаются результаты действия на объект модификаторов, расположенных в стеке выше (примененных позднее) текущего

Make Unique (Сделать уникальным) — при выделении нескольких объектов и применении модификаторов к выбранному набору в стек каждого объекта помещается образец модификатора. Щелчок LM на данной кнопке преобразует образец в независимую копию модификатора.

Remove Modifier from Stack (Удалить модификатор из стека) — служит для удаления текущего модификатора из стека. При этом устраняются и результаты его воздействия на объект.

Скрутка объекта

Модификатор Twist (Скрутка) используется для скручивания объекта относительно любой выбранной оси координат.

1. На командной панели Create (Создать) нажмите кнопку Geometry (Геометрия), в списке выберите вариант Extended Primitives (Улучшенные примитивы) и нажмите кнопку Gengon (Многогранная призма).

2. Введите значение 7 в счетчик Sides (Стороны) числа боковых сторон призмы и постройте объект.

3. Перейдите на командную панель Modify (Изменить) и нажмите кнопку Twist (Скрутка).

4. Настройте величину скрутки в группе Twist (Скрутка) используя параметры:

· Angle (Угол) — задает угол скрутки в градусах относительно оси, выбранной в разделе Twist Axis (Ось скрутки);

· Bias (Смещение) — меняется в диапазоне от —100 до 100 и определяет, будет ли скрутка смещена от центра и на сколько.

5. Выберите координатную ось скрутки в группе Twist Axis (Ось скрутки).

6. В группе Limits (Пределы) можно ограничить применение модификатора скрутки только теми вершинами объекта, которые лежат вдоль выбранной оси между отсчетами координат, заданными в счетчиках Upper limit(Верхний предел) и Lower Limit (Нижний предел). Действие ограничений включается установкой параметра Limit Effect (Ограничить эффект).

На рис. 10.5 показан эффект использования модификатора Twist (Скрутка) вокруг оси Z.

Рис. 10.5. Пример скрутки объекта

Изгиб объекта

Модификатор Bend (Изгиб) используется для изгиба объекта относительно заданной оси (рис. 10.6).

Параметры модификатора изгиба не отличаются от параметров модификатора скрутки за исключением одного: счетчик Direction (Направление) группы Bend (Изгиб) задает направление изгиба в плоскости, перпендикулярной выбранной оси изгиба.

Для создания изгиба объекта выберите модификатор Bend (Изгиб) и деформируйте созданный объект, задавая необходимые параметры.

Рис. 10.6. Пример изгиба объекта

Заострение

Действие модификатора Taper (Заострение) показано на рис. 10.7.

1. На командной панели Create (Создать) нажмите кнопку Geometry(Геометрия), в списке укажите вариант Standard Primitives (Стандартные примитивы), нажмите кнопку Teapot (Чайник) и постройте объект.

2. Перейдите на командную панель Modify (Изменить) и щелкните на кнопке Taper (Заострение).

В нижней части командной панели Modify (Изменить) появятся параметры, часть которых была рассмотрена ранее. Дополнительно появятся следующие параметры:

· Curve (Кривизна) — счетчик позволяет выгнуть стороны заостренного объекта внутрь или наружу;

· Primary (Первичная ось) — переключатель выбора основной оси, вдоль которой происходит заострение;

· Effect (Ось эффекта) — переключатель выбора оси заострения в плоскости, перпендикулярной выбранной оси;

· Symmetry (Симметрично) — флажок включения режима симметричного заострения относительно первой оси.

Значения параметров заострения приведены на рис. 10.8.

Рис. 10.7. Пример использования модификатора заострения

Рис. 10.8. Свиток параметров заострения объекта

Зашумление

С помощью модификатора Noise (Зашумление) строятся случайные шумовые возмущения поверхности геометрической модели. Эффект зашумления зависит от количества сегментов сетчатой оболочки объекта. На рис. 10.9 показан пример зашумления параллелепипеда.

1. Постройте параллелепипед, задав значения сегментов не менее 10.

2. На командной панели Modify (Изменить) щелкните LM на кнопке Noise(Зашумление).

Рис. 10.9. Зашумление параллелепипеда

3. В нижней части командной панели настройте следующие параметры зашумления:

· Seed(Номер выборки) — натуральное число, инициирующее работу генератора случайных чисел;

· Scale (Масштаб) — задает пространственный масштаб шумовых возмущений вдоль поверхности. Большие величины ведут к более гладким на вид возмущениям, малые — к более неровным.

· Fractal (Фрактал) — включает фрактальный алгоритм генерации возмущений, позволяющий имитировать поверхности, похожие на природные объекты;

· Roughness (Шероховатость) — позволяет управлять размерами фракталов (степенью шероховатости) поверхности. Допустимые значения лежат в пределах от 0 до 1;

· Iterations (Итерации) — определяет число вычислительных циклов фрактального алгоритма в процессе генерации возмущений. Большие значения ведут к более аккуратному рельефу;

· Strength (Амплитуда) — счетчики X, Y и Z задают амплитуду шумовых возмущений в направлении отдельных осей координат. Если параметр Scale (Масштаб) определяет размер неровностей вдоль поверхности, то амплитуда задает характерный размер неровностей в направлении, перпендикулярном поверхности;

· Animate Noise (Анимация возмущений) — включает режим анимации зашумления, которое начинает случайным образом меняться от кадра к кадру;

· Frequensy (Частота) — задает скорость флуктуации поверхности во времени;

· Phase (Фаза) — позволяет управлять анимацией возмущений. Различные значения фазы ведут к различающимся на вид анимациям возмущений.

Выдавливание

Модификатор Extrude (Выдавливание) предназначен для преобразования плоских объектов в трехмерные путем задания им высоты. Пример использования выдавливания приведен на рис. 10.10. Здесь плоский контур букв вытянут по оси Z.

1. На командной панели Create (Создать) нажмите кнопку Shapes (Формы), в списке укажите вариант Splines (Сплайны), нажмите кнопку Text(Текст) и создайте форму-текст.

2. Перейдите на командную панель Modify (Изменить) и щелкните LM на кнопке Extrude (Выдавливание).

3. Задайте высоту текста в счетчике Amount (Значение) и определите число сегментов поверхности объекта по высоте в счетчике Segments (Сегментов).

4. В группе Capping (Накрытие) отметьте флажки Cap Start (Накрыть снизу) и Cap End (Накрыть сверху).

Если эти параметры не отмечены, то будет сформирована только боковая поверхность.

5. Задайте тип поверхности оснований, отметив один из переключателей:

Moriing (Морфинг) или Grid (Сетка).

Морфинговый тип основания применяется, если впоследствии предполагается использовать объект в преобразованиях пошагового превращения (морфинга) в качестве либо исходного, либо опорного объекта.

6. Определите тип поверхности тела экструзии, установив параметр Mesh (Сетка) — будет создана сеть с треугольными гранями.

Рис. 10.10. Пример выдавливания плоской формы

Установка параметра Patch (Кусок) дает возможность создать сеть кусков Безье, а установка параметра NURBS — поверхность типа NURBS.

Последние два параметра на командной панели выполняют следующие функции:

· Generate Mapping Coords (Проекционные координаты) — включает режим генерации проекционных координат тела экструзии1 с целью применения к нему материала на основе текстурных карт (назначение и применение текстурных карт будет рассмотрено ниже при назначении объектам материалов);

· Generate Material IDs (Идентификаторы материала) — включает режим присвоения различных идентификаторов материала боковой поверхности и основаниям тела экструзии, что обеспечивает возможность применения к объекту многокомпонентного материала.

Вращение

Модификатор Lathe (Вращение) создает трехмерное тело вращения, используя образующую и одну из трех координатных осей в качестве оси вращения.

1. На командной панели Create (Создать) нажмите кнопку Shapes (Формы), в списке укажите вариант NURBS Curves (NURBS-кривые), нажмите кнопку Point Curve (Точечная кривая) и создайте образующую, как на рис. 10.11.

Рис. 10.11. Сплайновая заготовка для модификатора вращения

2. Перейдите на командную панель Modify (Редактировать) и щелкните LM на кнопке Lathe (Вращение).

Появился свиток параметров модификатора вращения.

3. Задайте величину угла поворота формы в счетчике Degrees (Градусов). В нашем случае образующая вращается на 360°.

Замечание

Значение счетчика Degrees (Градусов) может быть задано в пределах от 0° до 360°. Это позволяет создавать тела в форме цилиндрических секторов.

4. Задайте число сегментов по периметру вращения в счетчике Segments(Сегментов).

Таким образом определяется число сегментов по периметру сектора вращения формы.

5. Установите следующие параметры:

· Weld Core (Слияние на оси) — включает и выключает режим объединения всех вершин, совмещенных на оси тела вращения;

· Flip Normals (Перевернуть нормали) — позволяет изменить направление нормалей граней.

6. В группе Direction (Направление) укажите ось, относительно которой будет происходить вращение. Используйте для этого кнопки X, Y, и Z.

7. Задайте способ выравнивания формы относительно выбранной оси вращения с помощью кнопок раздела Align (Выравнивание).

Рис. 10.12. Пример построения тела вращения

В зависимости от выбора способа выравнивания можно получить различные тела вращения из одной и той же формы. Можно использовать следующие способы:

· Min (Минимум) — совмещает ось вращения с левым краем габаритного контейнера формы;

· Center (Центр) — форма будет вращаться относительно оси, проходящей через центр ее габаритного контейнера;

· Мах (Максимум) — совмещает ось вращения с правым краем габаритного контейнера формы.

На рис. 10.12 показан результат применения модификатора вращения к образующей, представленной на рис. 10.11.

Мебель для интерьера

Создайте самостоятельно стол и стул и дополните мебелью ваш интерьер. Далее будут показаны только основные элементы конструкций и указаны способы их создания.

1. Для создания ножки стола можно использовать комбинацию сплайн-форм, приведенных на рис. 10.13 и действие Trim (Подрезание).

Рис. 10.13. Сплайн-форма для ножки стола

2. С помощью модификатора Extrude (Выдавливание) задайте толщину ножки, сделайте с нее копии и скомпонуйте их в окне Тор (Вид сверху), как показано на рис. 10.14.

3. Столешницу можно создать с помощью сплайн-эллиппса и модификатора Extrude (Выдавливание).

Рис. 10.14. Скомпонованные ножки стола

4. Скомпонуйте столешницу и ножки, используя кнопки раздела Align(Выравнивание).

Законченный объект показан на рис. 10.15.

Рис. 10.15. Столешница, выровненная относительно ножек

5. Сидение для стула, приведенное на рис. 10.16, можно создать с помощью модификатора Lathe (Вращение).

6. Винтовая основа для стула, представленная на рис. 10.17, формировалась из сплайн-звезды с помощью модификаторов Extrude (Выдавливание) и Twist (Скрутка).

7. Ножка для стула создавалась методом лофтинга.

8. Скомпонованный из созданных элементов стул показан на рис. 10.18.

9. Добавьте созданную мебель в интерьер с помощью команды Merge (Присоединить).

Рис. 10.16. Сидение для стула

Рис. 10.17. Сплайн-форма и полученная из нее основа для ножки стула

Рис. 10.18. Стул, скомпонованный из основных элементов


Редактирование сетчатых оболочек

Преобразование сетчатых оболочек в редактируемую сеть

Редактирование сетей на уровне объектов

Редактирование сетей на уровне вершин

Пример использования редактора вершин

Подготовка к редактированию граней

Выделение граней

Выдавливание граней

Разбиение граней

Взрыв граней

Дополнительные инструменты редактирования граней

Редактирование ребер

Подготовка к редактированию ребер

Разрезание и рассечение ребер

Другие команды раздела редактирования ребер

Использование редактора ребер при моделировании составных объектов

Для редактирования сетчатых оболочек таких объектов, как геометрические примитивы, их необходимо преобразовать к типу Editable Mesh (Редактируемая сеть).

Преобразование сетчатых оболочек в редактируемую сеть

1. Очистите экран от лишних объектов, выбрав в меню Edit (Редактировать) команду Select All (Выделить все) и нажав клавишу <Delete>.

2. На командной панели Create (Создать) нажмите кнопку Geometry (Геометрия), в списке выберите вариант Standard Primitives (Стандартные примитивы), нажмите кнопку Sphere (Сфера) и постройте в окне Perspective (Перспектива) сферу. Там же постройте конус.

3. Оставьте конус выделенным и перейдите на командную панель Modify (Изменить). Щелкните LM на кнопке ConHgure Buttons Sets(Конфигурирование наборов кнопок) и выберите в появившемся свитке команду преобразования Mesh Editing (Редактируемая сеть).

4. В списке модификаторов щелкните на кнопке Edite Mesh (Редактирование сети).

Конус теперь будет рассматриваться программой как редактируемая сеть.

Редактирование сетей на уровне объектов

После преобразования примитива в редактируемую сеть в нижней части командной панели раскройте свиток Edit Geometry (Редактируемая геометрия).

В этом свитке размещены основные команды редактирования сети.

Прикрепим сферу к конусу. Для этого нажмите кнопку Attach (Прикрепить), а затем щелкните на сфере. Сфера окажется прикрепленной к конусу, станет одного с ним цвета и будет рассматриваться командами стандартного преобразования (перемещение, поворот, масштабирование), как единый примитив.

Редактирование сетей на уровне вершин

Редактирование сетей на уровне вершин позволяет изменить свойства отдельных вершин или их групп и выполнить над ними ряд различных операций. К выделенным вершинам можно применять и стандартные преобразования с целью корректировки формы объекта. Рассмотрим команды редактирования.

После команды прикрепления мы имеем два объекта с редактируемой сетчатой оболочкой: сфера и конус.

1. Щелкните RM на названии Perspective (Перспектива) окна проекции и на появившейся панели меню отметьте строку Wireframe (Каркасное изображение).

Изображение объекта стало каркасным, удобным для редактирования вершин, ребер и граней.

2. В свитке Selection (Выбор) щелкните LM на левой из пиктограмм, показанных на рис. 7.1.

Рис. 7.1- Пиктограммы выбора уровней редактирования

Вами задан режим редактирования вершин. При этом строка Edit Mesh(Редактирование сети) в списке стека модификаторов станет желтого цвета. В свитке Edit Geometry (Редактируемая геометрия) высветятся дополнительные команды, а все вершины выделенных объектов обозначатся крестиками, как показано на рис. 7.2.

Выделенным наборам вершин сети можно присваивать имена. Для этого достаточно ввести имя выделенного набора в раскрывающемся списке Named Selection Sets (Именованные выделенные наборы), расположенного на панели инструментов, и нажать клавишу <Enter>. С помощью же кнопок Copy (Копировать) и Paste (Вставить) из раздела Named Selections (Именованные наборы) можно выполнять копирование и вставку выделенных наборов вершин.

Для слияния или разбиения вершин сети используются команды из группы Weld (Слить) свитка Edit Geometry (Редактируемая геометрия).

1. Выберите команду Target (С выбранной).

Эта команда позволяет слить две любые вершины.

Рис. 7.2. Объекты в режиме редактирования

2. Щелчком LM выделите какую-нибудь вершину на сфере и перетащите ее к другой вершине.

Курсор при этом имеет вид курсора перемещения. В момент, когда курсор приблизится к другой вершине на расстояние, допускающее слияние (оно указано в счетчике Target (Порог выбора)), он принимает вид креста. Если в этот момент отпустить кнопку мыши, произойдет слияние вершин.

Команда Selected (Выделенные) используется для слияния группы выделенных вершин, удаленных друг от друга на расстояние, меньшее указанного в счетчике Weld Selected (Порог слияния). При этом все сегменты освободившихся ребер соединятся с итоговой вершиной.

Активизация режима Use Soft Selection (Использовать дополнительный выбор) в свитке Soft Selection (Дополнительный выбор) открывает доступ к параметру Falloff (Следовать за выбранной), позволяющему задать область влияния. При преобразовании одной или нескольких вершин эффект преобразования распространяется на прилегающие вершины, попавшие в заданную область.

3. В свитке Soft Selection (Дополнительный выбор) задайте режим Use Soft Selection (Использовать дополнительный выбор), потом — величину параметра Falloff (Следовать за выбранной) и переместите с помощью инструмента Move (Перемещение) одну из вершин.

Результат действия параметра области влияния показан на рис. 7.3. Перемещение той же вершины при обнуленном параметре показано на рис. 7.4.

Рис. 7.3. Результат действия параметра области влияния

Рис. 7.4. Перемещение вершины при отключенной области влияния

Установка другого параметра Affect Backfacing (Без обратной ориентации) предохраняет от влияния преобразуемой вершины те вершины, нормали которых обращены в сторону, противоположную направлению усредненной нормали выделенных вершин. Он доступен только при включенном параметре Use Soft Selection (Использовать дополнительный выбор).

Параметр Edge Distance (Расстояние в ребрах) определяет размер области влияния, исходя из значения счетчика итераций.

4. Переместите одну из вершин сферы при значении 1 счетчика итераций. Далее, отменив операцию перемещения с помощью команды Undo (Отменить), повторить ее при значении счетчика равном 8.

Внизу свитка Soft Selection (Дополнительный выбор) размещено окно для редактирования кривой влияния на область (рис. 7.5). С помощью параметров здесь можно задать форму кривой воздействия преобразуемой вершины на окружающую область сети. Изображенный в поле просмотра график показывает зависимость силы воздействия преобразования вершины на окружающую область. На форму графика зависимости влияют следующие параметры:

· Falloff (Следовать за выбранной) — задает общий размер области влияния;

· Pinch (Сужение) — определяет форму кривой в районе пика;

· Bubble (Выпуклость) — влияет на крутизну спада кривой на краях.

Рис. 7.5. Свиток редактирования кривой влияния

5. Настройте визуально форму кривой и щелкните LM на кнопке ОК.

6. Перемещайте одну и ту же вершину сферы при различных значениях параметров кривой, отменяя предыдущее перемещение инструментом Undo(Отменить). Проследите фактическое влияние параметров на форму области.

Перейдем опять к свитку Edit Geometry (Редактируемая геометрия).

7. Выберите часть вершин сферы и нажмите кнопку Detach (Отделить).

Это действие позволит отделить выделенную вершину или группу вершин вместе с гранями, принадлежащими данной вершине, и превратить их в отдельный объект,

8. В появившемся диалоговом окне Detach (Отделить) укажите имя отделяемого объекта и щелкните LM на кнопке ОК.

9. Для перемещения отделенной части сети следует выйти из режима редактирования. Результат использования действия Detach (Отделить) показан на рис. 7.6. Часть сети отделена от объекта и перемещена.

Рис. 7.6. Пример отделения и перемещения нескольких вершин вместе с гранями

Остальные команды раздела Edit Geometry (Редактируемая геометрия) перечислены ниже:

· Create (Создать) — позволяет создать вершину в любой части пространства, относящегося к редактируемому объекту;

· Delete (Удалить) — удаляет выделенную вершину или группу вершин. При удалении вершин все грани, которым она принадлежала, также удаляются;

· Collapse (Свернуть) — свертывает группу выделенных вершин. При этом все сворачиваемые вершины сходятся в одну, которая размещается в центре выделенного набора вершин. Пример сворачивания вершин показан на рис. 7.7.

В свитке Selection (Выбор) рассмотрите действия элементов:

· Hide (Скрыть) — скрывает выделенные вершины; скрытую вершину нельзя редактировать;

· Unhide All (Показать все) — вызывает действие, обратное к действию элемента Hide (Скрыть); показывает все скрытые вершины;

· Remove Isolated (Удалить изолированные) — удаляет все изолированные вершины в составе объекта вне зависимости от текущего выделения.

Рис. 7.7. Пример сворачивания группы вершин

Пример использования редактора вершин

Теперь отложим на время формальное изучение команд и проверим свои творческие способности. Создадим из сферы голову медведя, такую как на рис. 7.8, или даже лучше, используя только возможности редактирования вершин сети.

1. Для начала очистите рабочий экран, выбрав в меню Edit (Редактировать) команду Select All (Выделить все) и нажав клавишу <Delete>.

2. Сделайте окно проекции Perspective (Перспектива) активным и разверните его во весь экран, щелкнув LM на кнопке Min/ Max Toggle(Развернуть/Восстановить) панели управления окном проекции.

3. Нажмите на командной панели Create (Создать) кнопку Geometry (Геометрия), в списке выберите вариант Standard Primitives (Стандартные примитивы) и нажмите кнопку Sphere (Сфера).

4. Для более точного моделирования в свитке Parameters -(Параметры) увеличьте значение счетчика Segments (Сегменты) до 56.

5. Постройте сферу.

6. Перейдите на командную панель Modify (Изменить), щелкните LM на кнопке Edit Mesh (Редактирование сети) и в свитке Selection (Выбор) щелкните на пиктограмме "вершины".

Сфера преобразована в объект типа "редактируемая сеть".

Все вершины сферы обозначались крестиками. Объект готов для редактирования на уровне вершин.

Рис. 7.8. Пример преобразования сферы с помощью редактора вершин

Подготовка к редактированию граней

Прежде, чем перейти к работе с гранями, сохраните созданную вами геометрию и подготовьте рабочий экран.

1. Выберите из меню File (Файл) команду SaveAs (Сохранить как). После чего задайте имя файла в открывшемся диалоговом окне и подтвердите сохранение.

2. Очистите рабочий экран, выбрав из меню Edit (Редактировать) команду Select All (Выделить все) и нажав клавишу <Delete>.

3. Создайте сферу, нажав на командной панели Create (Создать) кнопку Geometry (Геометрия), а затем выбрав в списке вариант Standard Primitives (Стандартные примитивы) и нажав кнопку Sphere (Сфера).

4. Отключите заливку сферы. Для этого щелкните RM, выставив курсор на имя активного окна, и в открывшемся меню укажите команду Wireframe(Каркасное изображение).\

5. Перейдите на командную панель Modify (Изменить), щелкните LM на кнопке Edit Mesh (Редактирование сети) и в свитке Selection (Выбор) щелкните на пиктограмме "грань". В свитке Edit Geometry (Редактируемая геометрия) высветятся команды редактирования на уровне граней.

Замечание

Для применения преобразований к граням следует предварительно выделить их любым известным методом.

Выделение граней

Опции свитка Selection (Выделение) позволяют контролировать процесс выделения граней. Чтобы задать тип выделяемых элементов, следует выбрать одну из трех кнопок с пиктограммами:

· Face (Грань) — позволяет выделять отдельные грани;

· Polygon (Многоугольник) — опция обеспечивает выбор сразу же всех граней, угол отклонения которых от общей плоскости не превышает значения, заданного в счетчике Planar Thresh (Порог пла-нарности) при условии установки флажка Ignore Visible Edges(Игнорировать видимые ребра). Если этот параметр не установлен, то выделение многоугольников ограничивается только видимыми ребрами сети;

· Element (Элемент) — выделяет одним выбором все смежные грани объекта.

· Установка флажка Ignore Backfacuig (Без обратной ориентации) обеспечивает выделение только тех граней, нормали которых видны в окне проекции. Число выделенных граней указывается в самом низу свитка Selection (Выделение).

Выдавливание граней

Кнопка Extrude (Выдавливание) свитка Edit Geometry (Редактируемая геометрия) позволяет выдавливать выделенные грани. Глубина выдавливания задается в счетчике Amount (Глубина).

1. Проверьте, активна ли пиктограмма "грань" свитка Selection (Выбор)

2. и выделите часть граней на построенной сфере.

Выделенные грани окрасятся в красный цвет.

Рис. 7.9. Пример выдавливания граней

3. Щелкните LM на кнопке Extrude (Выдавливание) и задайте глубину выдавливания в счетчике Amount (Глубина).

Пример выдавливания граней показан на рис. 7.9.

Разбиение граней

Разбиение выделенной грани на более мелкие части задается щелчком LM на кнопке Tessellate (Разбиение) в свитке Edit Geometry (Редактируемая геометрия) после предварительной установки одного из методов разбиения.

· Edge (От ребра) — помещает дополнительные вершины в середину каждого из трех ребер грани и соединяет их отрезками, заменяя, таким образом, одну грань четырьмя новыми. Пример разбиения граней от ребра показан на рис. 7.10.

Рис. 7.10. Пример разбиения граней методом "от ребра"

Рис. 7.11. Пример разбиения граней методом "от ребра" при отрицательном значении счетчика натяжения

При выборе этого метода можно задать степень натяжения оболочки в области дополнительно созданных граней с помощью счетчика Tension(Натяжение). Положительное значение параметра ведет к выдвижению новых вершин наружу, создавая впечатление выпуклости оболочки. Отрицательное значение перемещает вершины внутрь, делая оболочку в районе созданных граней вогнутой. Пример задания отрицательного значения счетчика натяжения показан на рис. 7.11, при положительном значении — на рис. 7.12.

· Face- Center (От центра) — помещает новую вершину в центр грани и соединяет ее линиями с существующими тремя вершинами, разбивая грань на три новых.

Рис. 7.12. Пример разбиения граней методом "от ребра" при положительном значении счетчика натяжения

Взрыв граней

Опции группы, в которой размещена кнопка Explode (Взорвать) в свитке Edit Geometry (Редактируемая геометрия), предлагают несколько вариантов для отделения выделенных граней и превращения их в самостоятельные объекты. При анимации это производит впечатление взрыва объекта.

Предварительно выберите один из переключателей:

· Objects (Объекты) — позволяет установить, будут ли грани выделяться в самостоятельные объекты.

· Elements (Элементы) — указывает, станут ли грани преобразовываться в элементы исходного объекта.

Значение счетчика Angle Thresh (Порог по углу) определяет, какие из граней окажутся разбитыми на отдельные объекты. Любые две смежные грани, угол между которыми превышает величину порога, разбиваются на отдельные объекты.

Дополнительные инструменты редактирования граней

Перечислим кнопки, предназначенные для выполнения дополнительных операций над гранями в свитке Edit Geometry (Редактируемая геометрия):

· Detach (Отделить) — отделяет выделенные грани, превращая их в самостоятельный объект. На рис. 7.13. показаны отделенные от сферы и перемещенные грани;

· Collapse (Свернуть) — сворачивает выделенные грани, объединяя их вершины в одну центральную вершину;

· Make Planar (Привести к плоскости) — превращает поверхность, состоящую из выделенных граней, в плоскость (рис. 7.14);

· Delete (Удалить) — удаляет выделенные грани.

Рис. 7.13. Выделенные грани отделены и перемещены

Рис. 7.14. Выделенные грани приведены к плоскости

В свитке Selection (Выбор) помещены следующие кнопки:

· Hide (Скрыть) — скрывает выделенные грани так, что их нельзя редактировать (рис. 7.15);

· Unhide All (Показать все) — делает все ранее скрытые грани вновь видимыми и доступными для редактирования.

Рис. 7.15. Выделенные грани скрыты

Редактирование ребер

Подготовка к редактированию ребер

Здесь мы рассмотрим ряд преобразований сети на уровне ребер.

1. В качестве объекта выберите из набора геометрических примитивов цилиндр и постройте его, увеличив значения параметров Height Segments(Сегментов по высоте) и Cap Segments (Колец донца) до 5.

2. Для редактирования ребер отключите заливку цилиндра, перейдите на командную панель Modify (Изменить) и преобразуйте его в редактируемую сеть путем выбора кнопки Edit Metch (Редактируемая сеть).

3. В свитке Selection (Выбор) щелкните LM на пиктограмме "ребро".

Для применения преобразований потребуется выделить редактируемые ребра. После выделения они будут окрашены в красный цвет. Число выделенных ребер указывается в низу свитка Selection (Выбор).

Для разрезания существующих и создания новых ребер вручную или по линии сечения объекта плоскостью перейдем к командам группы Cut and Slice(Разрезание и рассечение) в свитке Edit Geometry (Редактируемая геометрия).

Разрезание и рассечение ребер

Выполните следующие шаги:

1. Щелкните LM на кнопке Slice Plan (Плоскость сечения) и после — в окне проекции.

С помощью этой кнопки вызывается на экран плоскость сечения в виде прямоугольника желтого цвета, который можно масштабировать, перемещать и поворачивать, подбирая нужное положение линии сечения сети.'

2. После установки сечения щелкните LM на кнопке Slice (Рассечь). Ребра сети вдоль линии сечения будут рассечены.

3. Рассечение ребер плоскостью показано на рис. 7.16.

Рис. 7.16. Рассечение ребер сети плоскостью

4. Отмените команду рассечения с помощью инструмента Undo (Отменить) и нажмите кнопку Cut (Разрезать) в свитке Edit Geometry (Редактируемая геометрия).

Кнопка включает режим ручного разрезания существующих и создание новых ребер.'

5. Щелкните LM на любом ребре, переместите курсор к другому ребру (за курсором потянется пунктирная линия) и щелкните LM еще раз, чтобы создалось новое ребро.

Повторяя эти действия, можно создать любое количество ребер. Для завершения команды щелкните RM. На рис. 7.17 показаны новые ребра на сети цилиндра.

Рис. 7.17. Рассечение и создание ребер

Если отмечен флажок Split (Расщепить), то использование кнопок Cut(Разрезать) и Splice (Рассечь) ведет к созданию пары вершин по обе стороны от точки рассечения ребра. Это позволяет разрезать сеть на независимые элементы или вырезать в ней отверстия.

На рис. 7.18 показан цилиндр с вырезанным отверстием.

Если флажок Refin Ends (Уточнить концы) отмечен, то грани, примыкающие к концам вновь добавленного ребра, также разбиваются на дополнительные грани, чтобы обеспечить неразрывность поверхности.

Рис. 7.18. Цилиндр с рассеченными и удаленными ребрами

Другие команды раздела редактирования ребер

Кнопка Extrude (Выдавливание) работает аналогично кнопке выдавливания для граней.

Другие инструменты операций над ребрами свитка Edit Geometry (Редактируемая геометрия) приведены ниже:

· Divide (Разделить) — после нажатия этой кнопки ребро в указанной щелчком LM точке разделится на два отдельных ребра;

· Turn (Повернуть) — поворачивает выделенное ребро на 90°;

· Delete (Удалить) — удаляет выделенное ребро;

· Collapse (Свернуть) — удаляет выделенное ребро и соединяет воедино его концевые вершины;

· Create Shape (Создать форму) — создает сплайн, повторяющий форму выделенных ребер (рис. 7.19);

· Select Open Edges (Выделить открытые ребра) — выделяет все ребра, к которым примыкает только одна грань.

Рис. 7.19. Очерчивающий сплайн повторяет форму выделенных ребер.

Кнопка Visibility (Видимость) в свитке Surface Properties (Свойства поверхности), предназначенная для скрытия видимости ребер имеет следующие параметры:

· Visible (Видимо), Invisible (Невидимо) — параметры, делающие выделенные ребра видимыми или невидимыми;

· Auto Edge (Автоотбор) — установка этого параметра делает невидимыми все ребра между смежными гранями, угол между которыми меньше значения, указанного в счетчике Angle Thresh (Порог по углу).

Использование редактора ребер при моделировании составных объектов

Смоделируем объект, показанный на рис. 7.20.

1. Перед началом работы очистите экран, выбрав в меню Edit (Редактировать) команду Select All (Выделить все) и нажав клавишу <Delete>.

2. Разверните окно проекции Perspective (Перспектива) во весь экран, щелкнув LM на кнопке Min/ Max Toggle (Развернуть/Восстановить) панели управления окном проекции.

3. Нажмите на командной панели Create (Создать) кнопку Geometry(Геометрия), выберите в списке вариант Standard Primitives (Стандартные примитивы) и нажмите кнопку Sphere (Сфера).

4. Чтобы создать объект более гладким, увеличьте в свитке Parameters (Параметры) значение счетчика Segments (Сегменты) до 24 и постройте сферу.

Рис. 7.20. Объект, смоделированный с использованием редактора ребер

5. Для редактирования ребер перейдите на командную панель Modify (Изменить) и преобразуйте объект в редактируемую сеть путем нажатия кнопки Edit Metch (Редактируемая сеть). Сфера преобразована в объект типа "редактируемая сеть".

6. В свитке Selection (Выбор) щелкните LM на пиктограмме "ребро".

7. Отключите заливку сферы. Для этого щелкните RM, выставив курсор на имя активного окна, и в контекстном меню укажите команду Wireframe (Каркасное изображение).

8. Выберите ребро и удалите его с помощью кнопки Delete (Удалить) свитка Edit Geometry (Редактируемая геометрия). Результат представлен на рис. 7.21.

Рис. 7.21. Заготовка для составного объекта

9. Перейдите на командную панель Create (Создать).

10. Создайте дубликат сделанной заготовки. С этой целью назначьте любую из команд преобразования (например, поворот), нажмите клавишу <Shift> и, удерживая ее, щелкните LM на сфере.

До сих пор вы создавали дубликаты, выбирая команду Clone (Дублировать) из меню Edit (Редактирование). Этот способ позволяет дублировать объекты в процессе преобразования.

11. В появившемся окне диалога Clone Options (Параметры дублирования) установите переключатель для указания типа дубликата в значение Instance (Образец) и нажмите кнопку ОК.

Появившееся диалоговое окно параметров дублирования отличается от выбранного в меню только наличием счетчика дубликатов. В этом случае нас устраивает его значение по умолчанию.

12. Переместите дубликат, установив ограничения по оси X.

13. Разверните обе сферы вырезанными отверстиями друг к другу, как показано на рис. 7.22. Для этого выберите левую сферу, активизируйте кнопку Rotate (Повернут) и щелкните RM на ней.

Рис. 7.22. Заготовки, развернутые друг к другу вырезанными отверстиями

14. В появившемся диалоговом окне задайте угол поворота 90° вокруг оси Z.

15. Правую сферу поверните вокруг оси Z на 90°.

16. Для создания составного объекта нажмите на командной панели Create(Создать) кнопку Geometry (Геометрия), в списке выберите вариант Compound Objects (Составные объекты) и нажмите кнопку Connect (Соединяющиеся).

17. В разделе Interpolation (Приближение) свитка Pick Operand (Назначение операнда) задайте следующие значения параметров:

· Segment (Количество сегментов) — 38;

· Tension (Натяжение) — 0,6.

18. В разделе Smoothing (Сглаживание) отметьте параметр Bridge (Туннель), обеспечивающий сглаживание граней оболочки соединяющего туннеля

19. Щелкните на кнопке Pick Operand (Указать операнд) и на второй сфере. Отверстия двух сфер соединятся "туннелем".


Редактор материалов

Как редактировать материалы

Горячие и холодные материалы

Инструменты редактирования материалов

Назначение и отмена назначенных материалов

Для достижения визуальных сходств построенных объектов с реальными им назначаются соответствующие материалы. Под материалом понимается совокупность цвета, фактуры, свойств отражения. Каждый объект должен быть наделен собственным материалом с учетом освещенности, местоположения, своего назначения, геометрии и т. д. Для создания материалов предназначен специальный программный модуль — Material Editor (Редактор материалов).

Как редактировать материалы

Выполните следующие шаги:

1. Для вызова редактора материалов выберите в меню Rendering (Визуализация) команду Material Editor (Редактор материалов).

Панель редактирования материалов показана на рис. 14.1. Ячейки образцов дают возможность увидеть материал, который будет назначен объекту. По умолчанию на панели редактирования материалов указано 6 ячеек образцов, но можно настроить редактор на большее число ячеек.

Текущий образец выделяется белой рамкой вокруг ячейки. Сделать текущей можно любую ячейку, щелкнув на ней LM.

2. Для управления образцом материала щелкните RM на выделенной рамке.

Появится контекстное меню настройки ячейки образца, показанное на рис. 14.2. Это меню содержит следующие команды:

· Drag/ Copy (Перетащить/Копировать) — позволяет перетаскивать образец текущего материала и укладывать его в ячейку другого образца для создания копии материала. Этой же командой можно перетащить образец материала и уложить его поверх объекта сцены.

· Drag/ Rotate (Перетащить/Вращать) — позволяет применить инструмент поворота в окне ячейки образца. Поворот осуществляется следующим путем: щелчок LM, удерживание кнопки, перемещение курсора;

· Reset Rotation (Сбросить поворот) — дает возможность восстановить образец в первоначальном состоянии, отказавшись от поворота;

Рис. 14.1. Панель редактирования материалов

· Render Map (Визуализировать карту) — команда становится доступной только в меню той ячейки образца, материал которой основан на карте текстуры. При назначении команды появляется окно диалога Render Map (Визуализация карты). Для визуализации карты щелкните на кнопке Render (Визуализировать). Результат визуализации демонстрируется в окне виртуального буфера кадров;

· Options (Параметры) — позволяет выполнять настройку параметров редактора материалов, вызывая окно диалога Material Editor Options(Параметры редактора материалов);

· Magnify (Увеличить) — вызывает окно диалога, показанное на рис. 14.3, представляющее увеличенный вариант образца материала. Для дополнительного увеличения изображения в окне следует растянуть его рамку. Установка флажка Auto (Авто) обеспечивает автоматическое обновление изображения материала при изменении его характеристик. Кнопка Update (Обновить), которая становится доступной после сброса флажка Auto (Авто), служит для обновления внешнего вида материала вручную;

· 3х2 / 5х3 / 6х4 Sample Windows (3х2 /5х3 /6х4 ячейки образцов) — команды выбора режимов показа 6, 15 или 24 ячеек образцов материалов).

Рис. 14.2. Меню настройки ячейки образцов

Рис. 14.3. Окно увеличенного образца материала

Горячие и холодные материалы

Материал, назначенный объекту сцены, считается "горячим" и по углам его ячейки появляются белые треугольники. Редактирование горячего материала отражается на объекте сцены автоматически. В отличие от "горячего" материала редактирование "холодного" материала (не назначенного объектам сцены) никак не влияет на внешний вид сцены. На рис. 14.4 показаны образцы "горячего" и "холодных" материалов. Один и тот же материал может быт m загружен в несколько ячеек, но только одна из них способна быть "горячей".

1. Создайте геометрический примитив в окне Perspective (Перспектива).

2. Выберите в меню Rendering (Визуализация) команду Material Editor(Редактор материалов).

3. Щелкните LM в одной из ячеек образцов материала. Вокруг выделенной ячейки появится белая рамка.

4. Перетащите, не отпуская кнопку мыши, материал из выбранной ячейки на построенный примитив.

Рис. 14.4. Образцы "горячего" и "холодного" материалов

Теперь выбранная ячейка стала "горячей", и в ее углах появились белые треугольники.

Иногда необходимо отредактировать материал в горячей ячейке, не вызывая изменений на объектах сцены, т. е. сделать горячую ячейку холодной. С этой целью следует активизировать ее и щелкнуть на кнопке Make Material Copy(Копировать материал), расположенной в группе инструментов окна редактора материалов. В результате создается копия материала, которая помещается в ту же ячейку образца, но этот материал уже не является "горячим".

Инструменты редактирования материалов

Перейдем теперь к возможностям редактирования материалов и рассмотрим инструменты, размещенные на панели окна редактора материалов.

Get Material (Получить материал) — позволяет загрузить готовый материал или создать новый. Нажатие кнопки вызывает появление окна диалога Material/ Map Browser (Просмотр материалов и карт текстур);

Put Material to Scene (Поместить материал на сцену) — позволяет обновить материал в составе сцены, который является копией "горячего" материала, созданной с помощью кнопки Make Material Copy(Копировать материал);

Assign Material to Selection (Назначить материал выделению) — позволяет назначить материал из активной ячейки образца всем выделенным объектам сцены, при этом материал из данной ячейки становится горячим;

Reset Map/ Mtl to Default Settings (Установить исходный материал/карту текстуры) — возвращает материалу из активной ячейки образца исходные значения параметров, принимаемые по умолчанию. При этом все цвета компонентов материалов заменяются градациями серого тона;

Make Material Copy (Копировать материал) — позволяет снять копию с "горячего" материала. Копия помещается в ту же ячейку образца и не помечается как "горячая", хотя сохраняет все свойства и имя оригинала. Правка свойств копии не вызывает немедленных изменений в материалах объектов сцены. Для обновления "холодной" копии "горячего" материала в составе сцены служит кнопка Put Material to Scene (Поместить материал на сцену);

Put to Library (Поместить в библиотеку) — служит для помещения материала из активной ячейки образца в библиотеку материалов

Поле этого библиотеку следует сохранить на диске с помощью окна диалога Material/ Map Browser (Просмотр материалов и карт текстур);

Material Effects Channel (Канал эффектов монтажа) — позволяет связать материал с одним из 16 каналов графических эффектов, используемых в процессах видеомонтажа (кнопка выбора номера канала на раскрывающейся панели);

Show Map in Viewport (Показать текстуру в окне проекции) — позволяет увидеть, как будет выглядеть растровая структура материала непосредственно на поверхности объекта в окне проекции при визуализации. Командная кнопка доступна только в случае, когда активная ячейка содержит растровую текстуру;

Show End Result (Показать конечный результат) — включает режим итогового вида комбинированного материала;

Go to Parent (Перейти к основному материалу) — позволяет перейти с уровня правки компонентов — материала или текстуры — на более высокий уровень работы с составным материалом, объединяющим эти компоненты;

Go to Sibling (Перейти к компоненту) — позволяет перейти к редактированию следующего материала или текстуры, входящих в основной материал в качестве компонентов, не поднимаясь на уровень составного материала;

Material/ Map Navigator (Путеводитель по материалам/картам текстур) — вызывает окно диалога Material/ Map Navigator, позволяющее определить, какие текстуры и материалы применяются в сцене. В этом окне используются те же инструменты просмотра материалов и текстур, что и в окне Material/ Map Browser (Просмотр материалов и карт текстур);

Select by Material (Выделить по материалу) — позволяет выделить объекты сцены по признаку используемых в их составе материалов. Для этого выводится окно диалога Select Entities (Выделение по материалу). Все объекты, использующие текущий активный материал, выделяются в списке окна;

Options (Параметры) — позволяет перейти к настройке параметров редактора материалов, вызывая окно диалога Material Editor Options (Параметры редактора материалов);

Make Preview (Создать эскиз) — позволяет просмотреть эскиз анимации материала в ячейке образца в реальном масштабе времени;

Background (Фон) — позволяет изменить фон в ячейке образца, который по умолчанию является черным. Если кнопка нажата, в ячейке образца изображается клетчатый фон;

Backlight (Подсветка сзади) — помещает дополнительный источник света позади образца материала, вызывая его заднюю подсветку;

SampleType (Тип образца) — позволяет выбрать тип образца материала. Меню состоит из трех образцов, расположенных на раскрывающейся панели;

Pick Material from Object (Взять образец материала с объекта) — кнопка, позволяющая загрузить в ячейку образец материала, взятого с объекта сцены. Следует активизировать ячейку и, нажав кнопку, переместить курсор в окно проекции и щелкнуть на объекте с нужным материалом.

Назначение и отмена назначенных материалов

Для назначения материала объекту выполните следующие шаги:

1. Постройте геометрический объект.

2. Укажите в меню Rendering (Визуализация) команду Material Editor (Редактор материалов).

3. Выберите ячейку материала и, щелкнув на ней LM, перетащите и оставьте образец материала на объекте, не отпуская кнопку мыши.

Способ перетаскивания материала подходит для индивидуального назначения материала.

4. Для назначения материала группе объектов следует выделить эти объекты и щелкнуть LM на кнопке Assign Material to Selection (Назначить материал выделению).

Для отмены материала, назначенного объекту, необходимо:

1. Вызвать окно диалога Material/ Map Browser (Просмотр материалов и карт текстур), щелкнув LM на кнопке Get Material (Получить материал).

2. Щелкнуть в окне Material/ Map Browser (Просмотр материалов и карт текстур) на строке Non (Отсутствует), перетащить ее в любое окно проекции и положить на нужный объект, отпустив кнопку мыши.


Связанные конструкции

Связанные объекты

Преобразования связанных объектов

Опорные точки связанных объектов

Графическое отображение связей объектов

Метод обратной кинематики

Режим показа двойников

Связанная конструкция состоит из отдельных объектов и иерархических связей между ними. В таких конструкциях преобразование одного объекта при анимации влечет за собой аналогичные преобразования других, связанных с ним объектов. Подобного рода динамические отношения между объектами часто встречаются при моделировании движений человека, животных, механизмов.

Связанные объекты

При связывании объектов между ними создаются определенные иерархические взаимоотношения. Эти отношения базируются на понятиях родительского объекта (объекта-предка) и дочернего объекта (объекта-потомка). Анимация преобразования может строиться, соответственно, в двух направлениях: от предков к потомкам (метод прямой кинематики) и от потомков к предкам (метод обратной кинематики).

1. Создайте группу объектов и расположите их в окне проекции, как показано на рис. 20.1.

Рис. 20.1. Заготовка для создания связанных объектов

Щелкните LM на кнопке Select and Link (Выделить и связать) панели инструментов.

Связывание следует проводить от дочерних объектов к родительским. В нашем случае начнем с крайнего правого объекта.

2. Щелкните LM на крайнем правом объекте и, удерживая кнопку мыши, перетяните курсор до следующего в связке объекта.

Очередной объект в связке станет объектом-предком. Над ним курсор снова примет вид значка с кнопки панели инструментов.

3. Отпустите кнопку мыши.

Оба объекта выделятся белым цветом, а затем приобретут обычный вид.

Для того чтобы разорвать ошибочно созданную связь, выделите связанные объекты и щелкните LM на кнопке Unlink Selection(Разорвать связь с выделенным объектом).

4. Последовательно свяжите все объекты.

Преобразования связанных объектов

При преобразовании перемещения или поворота любого из объектов связанной конструкции действуют следующие правила, определенные для метода прямой кинематики:

· преобразование родительского объекта распространяется на все его дочерние объекты, но не касается объектов-предков преобразуемого объекта;

· самый младший объект-потомок наследует преобразования всех объектов-предков, но преобразование его самого не влияет ни на один элемент конструкции.

1. Переместите средний объект, как показано на рис. 20.2.

Вместе с ним переместятся только дочерние элементы конструкции. Вся конструкция разделилась на две части.

Рис. 20.2. Преобразование родительского объекта распространяется на дочерние объекты

2. Переместите теперь крайний левый рычаг конструкции.

Вы убедитесь, что связь распавшейся конструкции сохраняется, и вся конструкция будет повторять перемещения предка.

3. Убедитесь, что преобразования младшего объекта-потомка никак не влияют на всю конструкцию.

Опорные точки связанных объектов

При преобразовании связанной конструкции важное значение приобретает место расположения опорных точек. Опорная точка объекта при его создании помещается обычно или в центр основания, или в геометрический центр габаритного контейнера объекта. Размещение опорных точек построенной конструкции показано на рис. 20.3. Особенно важно нахождение опорных точек при повороте конструкции. В этом легко убедиться.

1. Выделите средний рычаг конструкции и поверните его.

Конструкция разрушится (рис. 20.4), т. к. опорная точка рычага расположена посередине, и вращение происходит вокруг нее. Чтобы конструкция не распадалась, достаточно переместить опорную точку рычага.

2. Доступ к средствам управления опорными точками можно получить, обратившись к командной панели Hierarchy (Иерархия).

Рис. 20.3. Расположение опорных точек объектов

3. Восстановите конструкцию в прежнее положение.

4. Выделите средний рычаг и щелкните LM на вкладке Hierarchy(Иерархия).

В верхней части командной панели Hierarchy (Иерархия), показанной на рис. 20.5, имеются три кнопки: Pivot (Опора), IK (Обратная кинематика) и Link Info (Данные о связях).

Рис. 20.4. Разрушение конструкции при повороте

Рис. 20.5. Командная панель Hierarchy

5. Щелкните LM на кнопке Pivot (Опора).

Появятся два свитка: Adjust Pivot (Настройка опорной точки), который дает возможность управлять расположением и ориентацией опорной точки объекта, и Adjust Transform (Настройка преобразования), позволяющий выравнивать объект относительно системы координат.

6. Нажмите кнопку Affect Pivot Only (Только опора) группы Move/ Rotate/

· Scale (Перемещение/Поворот/Масштаб).

Данное действие обеспечивает возможность перемещать или поворачивать только опорную точку объекта. При этом преобразование не будет касаться ни самого объекта, ни его дочерних объектов.

7. Используя инструменты перемещения, выставьте опорную точку рычага, как показано на рис. 20.6.

Теперь при повороте среднего рычага конструкция не будет разваливаться.

Рис. 20.6. Новая опорная точка рычага

Чтобы восстановить исходное положения и ориентацию опорной точки, которые она имела на момент создания объекта, щелкните на кнопке Reset Pivot (Восстановить опору).

Другие кнопки в свитке Adjust Pivot (Настройка опорной точки) задают следующие режимы преобразования:

· Affect Object Only (Только объект) — обеспечивает возможность перемещать, поворачивать или масштабировать только геометрическую модель объекта. При этом положение и ориентация опорной точки объекта и его дочерних объектов не изменяются;

· Affect Hierarchy Only (Только дочерние объекты) — обеспечивает возможность перемещать, поворачивать или масштабировать любой дочерний объект текущего выделенного объекта по отношению к его опорной точке. Ни на геометрическую модель этого объекта, ни на его опорную точку эти преобразования не распространяются.

Для выравнивания положения опорной точки используются кнопки группы Alignment (Выравнивание), которые становятся доступными, если нажата одна из кнопок: Affect Pivot Only (Только опора) или Affect Object Only(Только объект), и меняют свои названия в зависимости от того, какая из этих кнопок нажата:

· Center to Object (Центрировать по объекту), Center to Pivot (Центрировать по опоре) — сдвигает опорную точку в центр объекта или перемещает объект так, чтобы опорная точка оказалась в его центре;

· Align to Object(Выровнять по объекту), Align to Pivot (Выровнять по опоре) — выравнивает направление осей координатной системы опорной точки по осям системы координат неподвижного объекта или ориентацию объекта относительно осей координат неподвижной опорной точки;

· Align to World (Выровнять глобально) — выравнивает направление осей координатной системы опорной точки или объекта по осям глобальной системы координат.

Графическое отображение связей объектов

Графическое отображение существующих связей между объектами конструкции можно задать с помощью установок в командной панели Display (Дисплей).

1. Щелкните LM на вкладке командной панели Display (Дисплей) и выделите связанную конструкцию.

2. Раскройте свиток Link Display (Показ связей), находящийся в нижней части командной панели.

3. Отметьте флажок Display Links (Показывать связи).

Включился режим отображения структуры связей объектов конструкции (рис. 20.7).

4. Выставьте флажок Link Replaces Object (Связь заменяет объект).

В результате останутся видимыми только связи объектов конструкции, показанные на рис. 20.8.

Рис. 20.7. Отображение связей объектов

Рис. 20.8. Отображение в режиме замены объекта связями

Метод обратной кинематики

При анимации связанной конструкции по методу обратной кинематики преобразования применяются к самому младшему объекту-потомку, и действия этого преобразования распространяются на всех предков в иерархической цепочке данной конструкции. Метод обратной кинематики позволяет:

· реализовывать два типа сочленений объектов: вращающийся и скользящий;

· офаничивать диапазон действия сочленений объектов осями координат, размером углового сектора или расстоянием;

· задать приоритетность, силу трения и другие параметры сочленений.

1. Для существующей конструкции постройте любой объект, который будет играть роль направляющего при анимации конструкции.

В качестве направляющего объекта можно использовать вспомогательный объект-пустышку. Для этого на командной панели Create (Создать) нажмите кнопку Helpers (Вспомогательные объекты), щелкните по кнопке Dummy (Пустышка) и создайте объект-пустышку в рабочем окне.

2. Создайте анимацию для вспомогательного объекта.

3. Выделите крайний правый объект, который является самым младшим потомком, перейдите на командную панель Hierarchy (Иерархия) и щелкните LM на кнопке IK (Обратная кинематика).

Появятся свитки параметров обратной кинематики.

4. Привяжите выделенный объект к направляющему объекту. Для этого щелкните LM на кнопке Bind (Привязать) в свитке Object Parameters(Параметры объекта).

Кнопка зафиксируется в нажатом положении.

5. Щелкните LM на выделенном объекте и перетащите курсор к направляющему объекту.

6. Отпустите кнопку мыши, когда курсор окажется над направляющим объектом и примет вид кнопки.

7. Настройте параметры свитка Inverse Kinematics (Обратная кинематика). Свиток содержит следующие параметры:

· Apply IK (Применить IK) — кнопка, щелчок на которой запускает процесс расчета IK-решения. То есть связывает кинематику конструкции с заданной кинематикой направляющего объекта. Этой кнопкой нужно воспользоваться после того, как будут заданы все параметры и ограничения обратной кинематики;

· Apply Only To- Keys (Применять только к ключам) — если этот флажок отмечен, то IK-решение станет рассчитываться только для ключевых кадров. В противном случае ключи будут рассчитываться для всех кадров анимации;

· Update Viewports (Обновить окна) — установка данного флажка параметра обеспечивает покадровое обновление изображений в окнах проекции по мере IK-решения;

· Clear Keys (Удалить ключи) — отмеченный флажок ведет к удалению всех ключей кинематической цепочки до начала IK-расчетов;

· Start (Начало), End (Конец) — счетчики, позволяющие задать интервал анимации, для которого будет рассчитываться задача кинематики.

8. В свитке Object Parameters (Параметры объекта) установите ограничитель, задайте степень привязки объектов к их исходным положениям и ориентации. Для этого используются следующие параметры:

· Terminator (Ограничитель) — если выделить объект в конструкции и установить этот флажок, то анимация будет действовать только на объекты, являющиеся дочерними по отношению к выделенному объекту-ограничителю;

· Bind Position (Привязать к положению) — установка этого флажка привязывает объект к его текущему положению в глобальной системе координат, чтобы объект стремился, по возможности, сохранить свое положение, или к положению направляющего объекта, если он назначен. Щелчок на кнопке R (от англ. relatively — относительно) справа от флажка заставляет выделенный объект сохранять свое положение относительно направляющего объекта. Если кнопка R не нажата, то объект конструкции будет стремиться переместиться в положение, занимаемое направляющим объектом;

· Bind Orientation (Привязать к ориентации) — установка данного флажка привязывает выделенный объект к его текущей ориентации или к ориентации направляющего объекта. Щелчок LM на кнопке R справа от флажка заставляет выделенный объект сохранить свою ориентацию относительно направляющего объекта. Если кнопка R не нажата, то объект иерархической цепочки будет стремиться повернуться так, чтобы соответствовать ориентации направляющего объекта;

· Axis (Ось) — набор флажков задает оси координат, на которые распространяется привязка;

· Weight (Вес) — счетчик позволяет задать степень влияния направляющего объекта на связанный с ним объект цепочки, при этом значение О устраняет привязку;

· Precedence (Приоритетность) — счетчик дает возможность установить приоритеты объектов в конструкции. Этот параметр определяет степень влияния объекта на результат расчетов при вычислении IK-решения. Чем выше значение параметра, тем сильнее влияние объекта на результат;

· Child-> Parent (Потомок-> Предок) — устанавливает для всей цепочки более высокий приоритет объектов-потомков по отношению к предкам. Если эта кнопка нажата, то все объекты-потомки имеют приоритет выше, чем их предки;

· Parent-> Child (Предок->Потомок) — устанавливает для всей цепочки более высокий приоритет объектов-предков по отношению к потомкам. Если эта кнопка нажата, то все объекты-предки имеют приоритет выше, чем их потомки;

· Copy (Копировать), Paste (Вставить) — кнопки позволяют копировать параметры скользящих и вращающихся сочленений от одного объекта к другому. Выделите объект с настроенными параметрами сочленения и щелкните LM на кнопке Copy (Копировать), затем выделите другой объект и щелкните на кнопке Paste (Вставить);

· Mirror Paste (Вставить зеркально) — группа переключателей используется для зеркального отражения параметров сочленений IK-цепочки при вставке относительно выбранной оси координат.

9. В свитке Auto Termination (Автоограничение) установите флажок Auto Termination (Автоограничение), чтобы IK-решение ограничивалось автоматически. Счетчик # of Links Up (Число связей вверх) задает, насколько близко к началу цепочки будет размещаться ограничитель.

10. Присвойте сочленению тип скользящего или вращающегося и определите, как это сочленение должно функционировать в ходе расчета решения обратной кинематики, используя три однотипные группы параметров: Х Axis (Ось X), Y Axis (Ось Y) и Z Axis (Ось Z) свитков Sliding Joints(Скользящие сочленения) и Rotational Joints (Вращающиеся сочленения). Выделите отдельный объект конструкции и для него настройте следующие параметры:

· Active (Активно) — флажок, разрешающий выделенному объекту скользить вдоль данной оси координат (имеется в виду локальная система координат объекта-предка);

· Limited (Ограниченно) — флажок включает режим ограничения движения относительно выбранной оси координат. Допустимые верхний и нижний пределы движения сочленения вдоль заданных осей определяются счетчиками From (От) и То (До). Для вращающихся сочленений значения данных параметров измеряются в градусах;

· Ease (Плавно) — флажок включает режим плавного замедления скольжения по мере приближения к границам допустимого диапазона;

· Spring Back (Пружинный буфер) — если флажок установлен, то сила упругости воображаемой буферной пружины, заставляющей объект возвращаться назад после того, как он минует точку равновесного состояния, будет возрастать по мере удаления объекта от этой точки. Положение точки равновесного состояния задается в счетчике справа от флажка;

· Spring Tension (Натяжение пружины) — счетчик задает силу натяжения воображаемой буферной пружины;

· Damping (Демпфирование) — счетчик позволяет успокаивать движение объекта в сочленении, увеличивая сопротивление силам обратной кинематики. Допустимые значения параметра лежат в диапазоне от 0 до 1, где 1 соответствует наибольшей демпфирующей силе. Успокоение движения позволяет имитировать реальные процессы типа действия сил трения или инерции.

11. После настройки параметров запустите процесс расчета динамики, щелкнув LM на кнопке Apply IK (Применить IK). По окончании расчета воспроизведите анимацию.

При изменении параметров настройки процесс IK-расчета следует запустить заново.

Анимация связанных конструкций по методу прямой кинематики аналогична процессу анимации отдельных объектов. Выполните анимацию прямым методом самостоятельно.

Режим показа двойников

Двойники при отладке процесса анимации представляют собой каркасные или тонированные копии изображений выделенных объектов нескольких кадров анимации до и после текущего кадра. На рис. 20.9 показан фрагмент анимации при включенном режиме показа двойников, который часто полезен при создании анимации.

1. Выделите те объекты, для которых будет осуществляться показ двойников.

2. Выберите в меню Views (Проекции) команду Show Ghosting (Показать двойники).

Рис. 20.9. Фрагмент анимации объекта в режиме показа двойников


Содержание

3D Studio MAX

ЗАНЯТИЕ 1. Первое знакомство

ЗАНЯТИЕ 2. Сопутствующие команды преобразования

ЗАНЯТИЕ 3. Точность моделирования

ЗАНЯТИЕ 4. Моделирование сцены

ЗАНЯТИЕ 5. Сплайны

ЗАНЯТИЕ 6. Редактирование и модификация сплайнов

ЗАНЯТИЕ 7. Редактирование сетчатых оболочек

ЗАНЯТИЕ 8. Лофтинговое моделирование каркасных объектов

ЗАНЯТИЕ 9. Деформация моделей, построенных методом лофтинга

ЗАНЯТИЕ 10. Редактирование произвольных объектов

ЗАНЯТИЕ 11. Объемная деформация объектов

ЗАНЯТИЕ 12. Моделирование освещения

ЗАНЯТИЕ 13. Работа с камерой

ЗАНЯТИЕ 14. Редактор материалов

ЗАНЯТИЕ 15. Создание различных типов материалов

ЗАНЯТИЕ 16. Имитация внешней среды

ЗАНЯТИЕ 17. Анимация сцен

ЗАНЯТИЕ 18. Моделирование динамики с помощью систем частиц

ЗАНЯТИЕ 19. Деформация

ЗАНЯТИЕ 20. Связанные конструкции


Создание различных типов материалов

Параметры стандартных материалов

Базовые параметры

Дополнительные параметры

Карты текстур

Динамические свойства

Составные материалы

Материалы на основе карт текстур

Карта отражения

Влияние карты текстур на характеристики материала

Система проекционных координат

Настройка параметров растровой текстуры

В 3D StudioMAX материалы подразделяются на стандартные и составные. Сходство с реальными объектами стандартным материалам обеспечивает введение характеристик диффузного рассеивания, зеркального отражения, степень блеска поверхности, степень прозрачности и т. д. Помимо стандартных материалов в 3D МАХ используются составные материалы, такие как:

· Blend (Смесь) — материал, представляющий собой смесь двух других типов материалов;

· Double Sided (Двусторонний) — материал, состоящий из двух частей, одна из которых предназначена для лицевой, а другая для изнаночной поверхности;

· Matte/ Shadow (Матовый/Затеняемый) — материал, являющийся прозрачным для фона сцены, но способный воспринимать тени от объектов;

· Multi/ Sub- Object (Многокомпонентный) — материал, состоящий из многих материалов;

· Reytraced (Трассируемый) — материал, подобный стандартному материалу, но обеспечивающий формирование эффектов отражения и преломления методом трассировки световых лучей;

· Top/ Bottom (Верх/Низ) — материал, состоящий из двух материалов, один из которых назначается граням объекта с нормалями, направленными вверх, а другой — граням, нормали которых направлены вниз.

Параметры стандартных материалов

Для создания и настройки характеристик стандартных материалов предназначены свитки редактора материалов (рис. 15.1):Shader Basic Parameters(Базовые параметры раскраски), Blinn Basic Parameters (Базовые параметры тонирования), Extended Parameters (Дополнительные параметры), SuperSampling (Сверхразрешение), Maps (Карты текстур) и Dynamics Properties(Динамические свойства). Опробуем возможности влияния содержащихся там параметров на свойства материалов.

1. Постройте сферу в окне Perspective (Перспектива). Ей в последствии будет назначен созданный материал.

2. Вызовите на экран окно диалога Material Editor (Редактор материалов), выбрав в меню Rendering (Визуализация) команду Material Editor (Редактор материалов).

Рис. 15.1. Свитки параметров редактора материалов

Базовые параметры

При раскрытии окна редактора материалов свиток Blinn Basic Parameters

(Базовые параметры тонирования) появится по умолчанию в раскрытом виде.

1. Раскройте свиток Shader Basic Parameters (Базовые параметры раскраски). Параметры свитков показаны на рис. 15.2.

Рис. 15.2. Свитки базовых параметров

2. Выберите метод тонированной раскраски поверхностей геометрической модели в ходе визуализации материала с помощью раскрывающегося списка Shading (Раскраска), содержащего несколько вариантов раскраски:

· Constant (Постоянный) — метод тонированной раскраски, параметры которой остаются неизменными в пределах каждой отдельной грани поверхности. После визуализации при таком методе раскраски объект имеет граненую ребристую поверхность, как на рис. 15.3;

Рис. 15.3. Пример закраски объекта при постоянном методе тонирования

· Phong (По Фонгу) — метод тонированной раскраски объектов, обеспечивающий сглаживание ребер между гранями и добавляющий блики (рис. 15.4);

Рис 15.4. Пример тонирования в режиме Phong

· Blinn (По Блинну) — метод тонированной раскраски, обеспечивающий сглаживание ребер между гранями и отображение зеркальных бликов (рис. 15.5);

Рис. 15.5. Пример тонирования в режиме Blinn

· Metall (Металл) — метод тонированной раскраски объектов, имитирующий зеркальный блеск и другие характеристики отражения полированной металлической поверхности (рис. 15.6).

Рис. 15.6. Пример тонирования по методу Metall

3. Проследите на образце материала влияние следующих параметров (см. рис. 15.1):

· Wire (Каркас) — флажок обеспечивает визуализацию объекта в каркасном виде с использованием текущего материала. В свитке Extended Parameters (Расширенные параметры) можно задать толщину линии каркаса в счетчике Size (Размер);

· Fase Map (Карта грани) — установка этого флажка обеспечивает проецирование материала на каждую из граней объекта, которому данный материал назначен. Обычно этот параметр используется для материалов, создаваемых на основе карт текстур.

4. Настройте цветовые оттенки трех компонентов цвета материала — Ambient(Подсветка), Diffuse (Диффузионный) и Specular (Зеркальный). Используйте при этом группу элементов управления в средней части свитка.

Справа от образцов цвета располагаются квадратные кнопки без надписи. Назначение данных кнопок аналогично назначению кнопок свитка Maps(Карты текстур) — щелчок LM на любой из них раскрывает окно Material/ Map Browser (Просмотр материалов и карт текстур).

5. Настройте характеристики зеркальности в группе Specular Highlinghts(Степень зеркальности): Specular Level (Уровень зеркальности), Glosiness(Глянцевитость) и Soften (Размытость).

Справа от счетчиков располагаются кнопки без надписи, позволяющие выбрать и назначить данной характеристике материала карту текстур.

6. Щелкните LM на кнопке без надписи. В появившемся окне Material/ Map Browser (Просмотр материалов и карт текстур) выберите текстуру и нажмите кнопку ОК. После выбора текстуры на кнопке появится буква М.

Для настройки самосвечения и непрозрачности можно использовать параметры групп Self Illumination (Самосвечение) и Opacity (Непрозрачность).

7. Задайте параметры, назначьте карты текстур, перенесите на объект полученный образец материала и визуализируйте его.

На рис. 15.7 показан вариант образца с наложенными картами текстур при глянцевитости, равной 49.

Рис. 15.7. Образец наложения материала с заданным параметром глянцевитости

Дополнительные параметры

Следующим в перечне идет свиток Extended Parameters (Дополнительные параметры), определяющий свойства прозрачности, характеристики каркаса и ослабление блеска.

1. Разверните свиток Extended Parameters (Дополнительные параметры) и исследуйте влияние следующих параметров:

· Falloff (Край) — определяет характер изменения прозрачности в пределах поперечного сечения объекта. В положении In (Внутрь) непрозрачность объекта будет спадать от наружных кромок к центру, а в положении Out (Наружу) непрозрачность будет спадать от центра к наружным краям объекта;

· Amt (Степень) — счетчик, определяющий степень изменения непрозрачности объекта на его краях или в центре;

· Type (Тип) — переключатель, позволяющий задать три типа прозрачности: Filter (Фильтрующая), Subtractive (Вычитающая) и Additive(Аддитивная);

· Size (Размер) — в группе Wire (Каркас) устанавливает ширину линии каркаса при условии, что в свитке базовых параметров установлен флажок Wire (Каркас). Каркасный вариант приведен на рис. 15.8.

Характеристики ослабления блеска для карт зеркального отражения, находящихся в тени, устанавливаются в группе Reflection Dimming (Ослабление зеркального отражения) параметрами Apply (Применить), Dim Level (Уровень ослабления) и Refl. Level (Уровень отражения).

Рис. 15.8. Каркасный вид объекта с заданной толщиной

Карты текстур

В свитке Maps (Карты текстур) расположены параметры редактирования материалов, создаваемых с помощью карт текстур.

1. Для применения карты текстуры к текущему материалу нажмите кнопку None (Отсутствует) справа от наименования характеристики материала, с которой может быть связана текстура материала.

Появится окно диалога Material/ Map Browser (Просмотр материалов и карт текстур).

2. Дважды щелкните LM на имени нужной текстуры из списка окна просмотра.

Появится новый набор свитков параметров управления выбранной карты текстур. С этого момента материал в активной ячейке становится составным. Имя компонента отражается в ячейке окна под панелью образцов.

Для возврата назад к параметрам составного материала достаточно щелкнуть LM на кнопке Go to Parent (Перейти к составному материалу).

3. После возврата к составному материалу откройте опять свиток Maps(Карты текстур) и отрегулируйте долю вклада текстуры в счетчике Amount(Доля вклада).

Для включения или отключения действия карты текстур установите или сбросьте флажок в левой части соответствующей строки параметров свитка Maps (Карты текстур).

Для отмены карты текстуры щелкните LM на кнопке выбранной карты в свитке Maps (Карты текстур). Щелкните LM на кнопке Type (Тип) в окне редактора материалов, на которой должен читаться "тип выбранной карты текстур, и дважды щелкните на строке None (Отсутствует) в появившемся окне диалога Material/ Map Browser (Просмотр материалов и карт текстур). Подробнее о настройке параметров свитка Maps (Карты текстур) будет рассказано в разд. "Материалы на основе карт текстур".

Динамические свойства

В свитке Dinamics Properties (Динамические свойства) дается возможность настроить динамические свойства объектов, использующих данный материал. Эти свойства в дальнейшем могут быть использованы при анимации объектов, имитирующих силы упругости при соударениях объектов или силы трения при их скольжении. Свиток содержит следующие параметры:

· Bounce Coefficient (Коэффициент упругости) — указывает, насколько сильно объект будет отскакивать при соударении с другим объектом. Например, шар из свинца и шар из дерева будут иметь разные коэффициенты упругости;

· Static Friction (Статическое трение) — определяет, насколько трудно сдвинуть с места неподвижный объект;

· Sliding Friction (Трение скольжения) — указывает, какая сила требуется для поддержания движения перемещающегося объекта.

Составные материалы

Составные материалы — это комбинация двух и более материалов.

Double Sided

Материал Double Sided (Двусторонний) применяется в случаях, когда визуализация объекта производится в режиме Force 2- Sided (Изображать обе стороны). При этом визуализируются обе стороны граней — лицевая и обратная.

1. Создайте объект, показанный на рис. 15.9, используя лофтинг-моделирование и модификатор Scale (Масштабирование).

Рис. 15.9. Пример наложения на объект двустороннего материала

2. Для создания материала типа Double Sided (Двусторонний) щелкните. LM на кнопке Get Material (Получить материал) или на кнопке Type (Тип) в окне редактора материалов.

3. В появившемся окне Material/ Map Browser (Просмотр материалов и карт текстур) дважды щелкните LM на строке Double Sided (Двусторонний) в списке материалов и карт текстур.

В результате в редакторе материалов появится свиток Basic Parameters(Базовые параметры) двустороннего материала.

4. Настройте следующие параметры двустороннего материала:

· Facing Material (Лицевой материал), Back Material (Оборотный материал) — кнопки настройки параметров компонентов, в качестве которых по умолчанию принимаются стандартные материалы, но могут использоваться и материалы любых других типов. С помощью флажков справа от кнопки можно активизировать или отключить любой из двух компонентов двустороннего материала;

· Translucency (Просвечивание) — счетчик, позволяющий регулировать прозрачность лицевого материала грани, обеспечивая оборотному материалу возможность просвечивать наружу.

5. Щелкните LM на кнопке Facing, Material (Лицевой материал). Появятся раскрытые свитки базовых параметров.

6. Назначьте компоненту Diffuse (Диффузный) стандартный материал с текстурой Wood (Дерево), щелкнув LM на кнопке справа от образца.

7. Щелкните LM на кнопке Go to Parent (Перейти к составному материалу) панели управления материалами.

Появится свиток базовых параметров двустороннего материала.

8. Щелкните LM на кнопке Back Material(Оборотный материал) и появившемся свитке настройте параметры для внутренней стороны объекта.

9. Перенесите образец материала на объект и при визуализации установите режим Force 2- Sided (Отображать обе стороны) в окне диалога Render Scene (Визуализировать сцену).

Blend

Blend (Смесь) — тип материала, позволяющий смешивать два различных материала. Процентное соотношение смешиваемых материалов позволяет одному материалу просвечивать сквозь другой.

1. Постройте сферу.

2. Для создания материала типа Blend (Смесь) щелкните LM на кнопке Get Material (Получить материал) или на кнопке Type (Тип) в окне редактора материалов.

3. В появившемся окне Material/ Map Browser (Просмотр материалов и карт текстур) дважды щелкните LM в окне Blend (Смесь) в списке материалов и карт текстур.

В результате в редакторе материалов появится свиток Basic Parameters(Базовые параметры) материала-смеси.

4. Щелкните LM на кнопке Material 1 (Материал 1).

После этого в редакторе материалов появится свиток Basic Parameters(Базовые параметры) настройки стандартного материала.

5. Назначьте стандартный материал для первого компонента и настройте параметры.

6. Вернитесь к базовым параметрам материала-смеси, щелкнув на кнопке Go to Parent (Перейти к составному материалу) панели управления материалами.

7. Щелкните LM на кнопке Material 2 (Материал 2) и проведите настройку параметров для второго материала.

8. Вернитесь к базовым параметрам материала-смеси, щелкнув на кнопке Go to Parent (Перейти к составному материалу) панели управления материалами.

9. Настройте следующие параметры этого свитка:

· Interactive (Интерактивный) — переключатель дает возможность указывать, какой из компонентов материала-смеси будет отображаться при визуализации;

· Mask (Маска) — кнопка, позволяющая задать растровое изображение, которое будет играть роль карты-маски между двумя смешиваемыми материалами;

Рис. 15.10. Пример наложения смеси материалов с маской и без маски

· Mix Amount (Доля в смеси) — счетчик определяет процентное соотношение материалов в смеси. При значении счетчика, равном 0, видимым является только Material 1 (Материал 1). При значении счетчика, равном 100, виден только Material 2 (Материал 2);

· Mixing curve (Кривая смешивания) — группа параметров, позволяющих при наличии маски настроить ширину зоны перехода от одного материала к другому на границах резких перепадов интенсивности цвета маски.

10. Перенесите образец составного материала на сферу и визуализируйте изображение.

Пример наложения смешанного материала с маской и без маски приведен на рис. 15.10.

Multi/Sub-Object

Multi/ Sub- Object (Многокомпонентный) — тип составного материала, позволяющий назначать разные материалы различным частям объекта.

1. Для создания материала типа Multi/Sub-Object (Многокомпонентный) щелкните LM на кнопке Get Material (Получить материал) или на кнопке Type (Тип) в окне редактора материалов.

2. В появившемся окне Material/ Map Browser (Просмотр материалов и карт текстур) дважды щелкните LM в окне Multi/Sub-Object (Многокомпонентный) в списке материалов и карт текстур.

В результате в редакторе материалов появится свиток Basic Parameters(Базовые параметры) многокомпонентного материала.

3. Задайте число компонентов материала, щелкнув на кнопке Set Number(Задать число).

По умолчанию материал данного типа включает 10 компонентов.

4. Настройте параметры компонентного материала:

· текстовое поле справа отводится под имя компонента;

· кнопка с надписью Material # ( Standard) позволяет настроить параметры компонентов материала. Щелчок на этой кнопке дает возможность перейти в свиток параметров стандартного материала;

· поле цветового образца позволяет изменить цвет компонента материала;

· флажок в правой части группы параметров компонента позволяет включать и выключать данный материал в состав многокомпонентного материала.

5. Постройте сферу, перейдите на командную панель Modify (Изменить) и преобразуйте ее с помощью модификатора Edit Mesh (Редактируемая сеть).

6. Щелкните LM на пиктограмме Face (Грань).

7. Выделите грани на сфере, которым будет назначен первый материал.

8. В свитке Surface Properties (Свойства поверхности) командной панели Modify (Изменить) задайте 1 в окне параметра Material ID (Идентификатор материала). Затем выделите грани, которым будет назначен второй материал и введите 2 и т. д., пока не будут заданы материалы для всех граней

9. Перенесите образец материала из ячейки на сферу и визуализируйте изображение. Пример наложения многокомпонентного материала показан на рис. 15.11.

Рис. 15.11. Использование многокомпонентного материала

Raytrace

Raytrace (Трассируемый) — тип составного материала, позволяющего накладывать материал и карты текстур с учетом их отражения от объектов сцены и преломления в прозрачных средах.

1. Создайте сцену, как показано на рис. 15.12.

2. Для создания материала типа Raytrace (Трассируемый) щелкните LM на кнопке Get Material (Получить материал) или на кнопке Type (Тип) в окне редактора материалов:

3. В появившемся окне Material/ Map Browser (Просмотр материалов и карт текстур) дважды щелкните LM в окне Raytrace (Трассируемый) в списке материалов и карт текстур.

В результате в редакторе материалов появятся свитки параметров трассируемого материала: Basic Parameters (Базовые параметры), Extended Parameters (Расширенные параметры), Raytracer Controls (Управление трассировщиком), Maps (Карты текстур), Dynamics Properties (Динамические свойства) и About Raytrace Material (0 трассируемом материале).

Рис. 15.12. Заготовки для наложения трассируемого материала

4. Настройте параметры свитка Basic Parameters (Базовые параметры), как показано на рис. 15.13.

Рис. 15.13. Значение базовых параметров для сферы

Здесь настраиваются следующие параметры:

· Ambient (Подсветка) — характеризует степень диффузионного восприятия подсветки трассируемым материалом;

· Diffuse (Диффузия) — позволяет задать цвет световых лучей, рассеиваемых материалом. Эффекты зеркального отражения помещаются трассировщиком поверх цвета диффузионного отражения, поэтому данный цвет перестает быть видимым, если цвет Reflect (Отраженный) задан белым;

· Reflect (Отраженный) — цвет зеркального отражения. Белый цвет отражения обеспечивает полную зеркальность материала (на рис. 15.14 показано отражение шара в зеркале). Если цвет зеркального отражения сделать черным, то отражения объектов на поверхности трассируемого материала формироваться не будут (рис. 15.15);

Рис. 15.14. Отражение шара в зеркале

Рис. 15.15. Отсутствие зеркальности при задании черного цвета зеркального отражения

· Luminosity (Светимость) — параметр, подобный комбинации параметров Filter (Пропущенный) и Opactiy (Непрозрачность) стандартного материала. Черный цвет обеспечивает полную непрозрачность, а белый — полную прозрачность. Index of Refr. (Коэффициент преломления) — параметр, позволяющий воспроизводить явление преломления световых лучей в толще материала. На рис. 15.16 показано преломление при коэффициенте, равном 1.3;

Рис. 15.16. Эффект преломления плоскости подставки в шаре

· Specular Highights (Зеркальные блики) — группа параметров, которые управляют характеристиками световых бликов на поверхности материала;

· Environnement (Внешняя среда) — флажок дает возможность задать карту текстуры окружающей среды, которая учитывается при формировании цвета зеркального отражения и цвета прозрачности;

· Bump (Рельефность) — флажок, позволяющий придавать неровность поверхности объекта;

5. Настройте параметры свитка Extended Parameters (Дополнительные параметры), задав значения, показанные на рис. 15.17.

Рис. 15.17. Значения дополнительных параметров для сферы

Здесь настраиваются следующие параметры:

· Extra Lighting (Дополнительное освещение) — позволяет учитывать дополнительное освещение, отраженное от других материалов;

· Translucency (Просвечивание) — разрешает имитировать цвет света, проходящего сквозь материал и являющегося результатом диффузионного рассеивания. Эффект подобен пятну света, направленного со стороны, противоположной наблюдению;

· Fluorescence (Флуоресценция), Fluor. Bias (Флуоресцентное смещение) — позволяют задать цвет, создающий эффект флуоресцентного свечения. Если задан черный цвет, то флуоресценция отсутствует. Если свет не черный, то степень проявления флуоресценции определяется значением параметра Fluor. Bias (Флуоресцентное смещение);

· Transp. Environment (Окружающая среда для прозрачности) — флажок и кнопка позволяют заместить глобальную карту текстуры окружающей среды только применительно к эффекту преломления фона в прозрачном материале;

· Density (Плотность) — две группы параметров, позволяющих настроить свойства цвета в толще прозрачного объекта ( Color) и тумана, наполняющего прозрачный объект (Fog). Каждая группа включает флажок активизации эффекта, счетчики Start (Начало) и End (Конец) выбора начала и конца проявления эффекта внутри объекта, счетчик Amount (Степень) степени проявления эффекта, поле образца цвета и кнопку выбора карты текстуры;

· Type (Тип) — переключатель, позволяющий выбрать один из двух типов эффекта отражения: Default (По умолчанию) — цвет зеркального отражения накладывается поверх цвета диффузионного отражения. Additive (Суммарный) — цвет зеркального отражения суммируется с цветом диффузионного отражения;

· Gain (Поглощение) — управляет яркостью зеркальных отражений: чем меньше поглощение, тем ярче отражение. При значении параметра, равном 1, отражения не видны.

6. Перенесите созданный образец материала на сферу.

7. Создайте материал типа Reytrace (Трассируемый) для зеркала. Для этого настройте параметры свитка Basic Parameters (Базовые параметры) и Extended Parameters (Дополнительные параметры) в соответствии со значениями, приведенными на рис. 15.18 и 15.19.

8. Перенесите созданный материал на зеркало.

9. Создайте и наложите материал на подставку. Для этого раскройте свиток Basic Parameters (Базовые параметры) и щелкните LM на кнопке справа от образца Diffuse (Диффузный).

Рис. 15.18. Базовые параметры трассируемого материала для зеркала

Рис. 15.19. Дополнительные параметры трассируемого материала для зеркала

Рис. 15.20. Трассируемый материал имитирует прозрачный шар, отраженный в зеркале

10. В раскрывшемся окне Material/ Map Browser (Просмотр материалов и карт текстур) щелкните LM на текстурной карте Pelin Marble (Перламутровый мрамор).

На кнопке появится буква М. Это означает, что карта текстуры назначена и активна. Осталось перенести полученный образец материала на подставку.

Визуализированная сцена показана на рис. 15.20.

Материалы на основе карт текстур

Разнообразие способов достижения достоверности объектов существенно расширяется возможностью использования карт текстур, которые представляют собой готовые изображения. Настройка выбранной текстуры на требуемые свойства материала такие как блики, глянцевитость, блеск и т. д., производятся с помощью установки соответствующих параметров в свитке Maps (Карты текстур).

Карта отражения

Выполните следующие шаги:

1. Постройте сферу.

2. Для наложения на построенный объект карты текстур с разнообразными характеристиками стандартных материалов раскройте свиток Maps (Карты текстур) в окне Material Editor (Редактор материалов).

Первый из параметров этого свитка — Ambient (Подсветка) — блокируется с параметром Diffuse (Диффузное отражение) и не изменяется самостоятельно. Чтобы активизировать кнопку карты текстуры при параметре, необходимо нажать кнопку с изображением замка.

3. Отметьте параметр Diffuse (Диффузное отражение) в окошке слева от названия параметра.

Отмеченный флажком параметр является активным и влияет на результирующий материал. В счетчике влияния справа от названия параметра устанавливается процент вклада карты в результирующий материал.

4. Щелкните на кнопке выбора карты текстуры.

На кнопке имеется надпись None (Отсутствует), если карта текстуры не выбрана.

Появится диалоговое окно Material/ Map Browser (Просмотр материалов и карт текстур).

Карту текстуры можно выбрать из представленного набора текстур или из файла.

5. Чтобы выбрать карту текстуры из файла, дважды щелкните LM в окне Bitmap (Растровая).

На экране появится набор свитков, позволяющих загрузить файл с растровой текстурой и настроить параметры использования карты текстуры в составе материала.

6. Откройте свиток Bitmap Parameters (Параметры растровых текстур). Параметры этого свитка показаны на рис. 15.21.

Рис. 15.21. Параметры растровых текстур

7. Щелкните LM на кнопке Bitmap (Растровая карта).

Появится окно диалога Select Bitmap Image File (Выбрать файл растрового изображения). На рис. 15.22. представлен перечень графических стандартов файлов, которые можно использовать.

Рис. 15.22. Перечень допустимых форматов графических файлов растровой структуры

8. Выберите и загрузите требуемый файл растрового формата.

После загрузки файла его имя окажется на кнопке выбора текстуры.

9. Щелкните на кнопке Go to Parent (Перейти к составному материалу).

В свитке Maps (Карты текстур) на кнопке выбора текстуры так же появится имя выбранного файла.

10. Перенесите полученный материал на сферу и визуализируйте изображение.

Пример наложения карты текстуры диффузного отражения показан на рис. 15.23. Такое отражение равноценно нанесению рисунка на поверхность объекта.

Рис. 15.23. Пример использования карты диффузного отражения

Влияние карты текстур на характеристики материала

Рассмотрим на примерах, как карты текстур дополняют оптические эффекты, применяемые к материалам.

1. В свитке Maps (Карты текстур) отключите влияние Diffuse (Диффузного отражения), убрав флажок слева от параметра, и активизируйте параметр Specular (Зеркальный блик). Задайте карту текстуры, щелкнув на кнопке None (Отсутствует).

Параметр Specular (Зеркальный блик) позволяет применить карту текстуры в области зеркального блика на материале. Пример материала с текстурой зеркального блика показан на рис. 15.24.

Рис. 15.24. Материал с текстурой зеркального блика

2. Последовательно активизируя параметры в списке свитка Maps (Карты текстур) и, задавая им карты текстур, проследите их влияние на характеристики материала:

· Self- Illumination (Самосвечение) — позволяет применять к материалу карту текстуры, задающую области самосвечения поверхности объекта. Яркость самосвечения увеличивается при переходе к светлым областям карты текстуры. Пример материала с текстурой самосвечения приведен на рис. 15.27;

Рис. 15.27. Материал с текстурой самосвечения

· Opacity (Непрозрачность) — позволяет применять к материалу карту текстуры непрозрачности. Это дает возможность формировать прозрачные и непрозрачные участки материала. Пример материала с текстурой непрозрачности приведен на рис. 15.28;

Рис. 15.28. Материал с текстурой непрозрачности

· Filter Color (Светофильтр) — позволяет использовать карту текстуры для имитации света, пропущенного материалом, и влияющей на цвет объектов позади прозрачного материала. Пример материала с текстурой светофильтра приведен на рис. 15.29;

Рис. 15.29. Материал с текстурой светофильтра

· Bump (Рельефность) — позволяет применять карту текстуры для придания поверхности объекта видимости трехмерных неровностей за счет варьирования направлениями нормалей. Кажущаяся рельефность управляется цветом текстурной карты: белый выступает на поверхность, а черный углубляется в нее. Пример материала с текстурой рельефности приведен на рис. 15.30;

Рис. 15.30. Материал с текстурой рельефности

· Reflection (Зеркальное отражение) — позволяет применить карту текстуры для отражения окружающих объектов на поверхности материала. Здесь допускается использование трех типов карт зеркального отражения: растровая карта дает впечатление хромированного материала, имитируя зеркальное отражение предметов, изображенных на растровой карте (рис. 15.31); карта типа Reflect/ Refract (Отражение/Преломление) обеспечивает отражение на поверхность объекта не текстуры, а проекции окружающих объектов в том виде, в каком они наблюдаются из центра зеркального объекта; карта типа Flat Mirror(Плоское зеркало) обеспечивает формирование зеркальной проекции окружающих объектов на плоскую поверхность;

· Refraction (Преломление) — позволяет применять карту растровой текстуры для имитации преломления световых лучей прозрачным объектом. Такая карта текстуры подобна карте отражения за исключением того, что она имитирует не отражение окружающих предметов, а их наблюдение сквозь поверхность прозрачного материала, как показано на рис. 15.32;

· Displacement (Смещение) — подобна карте рельефа, но изменяет геометрию поверхности пропорционально яркости цветов карты текстур. Карта смещения применима только к объектам, представленным сетками кусков Безье или NURBS-поверхностями. Визуализация материала с этой картой текстур требует большого количества времени и памяти.

Рис. 15.31. Материал с текстурой зеркального отражения

Рис. 15.32. Материал с текстурой преломления

Система проекционных координат

Карту текстуры невозможно спроецировать на поверхность объекта, если он не снабжен системой проекционных координат. Оси проекционных координат именуются U, V и W. Они аналогичны декартовым координатам X, Y и Z, но относятся к пространству изображения текстуры. Систему проекционных координат можно применить к объекту как при его создании, так и на этапе правки.

1. Постройте параллелепипед и цилиндр.

2. Для включения режима проекционных координат на этапе создания модели установите флажок Generate Mapping Coordinates (Проекционные координаты) в группе Parameters (Параметры).

Этот параметр имеется в свитке каждого из типов геометрических объектов.

3. Перейдите на командную панель Modify (Изменить) и щелкните LM на кнопке Configure Modifier Sets (Конфигурирование наборов модификаторов).

4. В появившемся списке наборов модификаторов выделите UV Coordinate Modifiers (UV Системы проекционных координат).

5. В наборе модификаторов укажите модификатор UVW Map (UVW-проекция).

Проекционные координаты генерируются автоматически, а в окнах проекций появляется изображение габаритного контейнера модификатора. Значок проекционной системы координат соответствует одной копии изображения карты текстуры, проецируемого на поверхность объекта.

6. Выберите в группе Mapping (Проекционные координаты) тип Planar(Плоские координаты).

Координаты данного типа служат для проецирования растровых текстур на ровные плоские поверхности объектов.

7. Задайте карту текстуры, развернув свиток Maps (Карты текстур) и нажав кнопку None (Отсутствует) параметра Diffuse (Диффузионное отражение).

8. Перенесите текстуру на созданные объекты и визуализируйте сцену.

На тех гранях объектов, которые расположены перпендикулярно плоскости проекции, изображение текстуры растягивается и искажается, как показано на рис. 15.33.

Рис. 15.33. Пример проецирования текстуры в координатах Planer

9. Выделите цилиндр, выберите в разделе Mapping (Проекционные координаты) тип Cylindrical (Цилиндрические) и установите флажок параметра Cap (Торец).

Координаты типа Cylindrical (Цилиндрические) применяются к объектам цилиндрической формы (рис. 15.34). При установке флажка Cap (Торец) на торцовую поверхность объекта тоже наносится текстура.

Рис. 15.34. Пример использования цилиндрических координат на цилиндре

Самостоятельно рассмотрите использование других типов координат:

  1. Spherical (Сферические) — используется применительно к объектам, имеющим округлую или сферическую форму;
  2. Shrink Wrap (Обтягивающие) — специальная система координат, применяемая для проецирования текстур на объекты сложной формы. Она является сферической, но обеспечивает усечение углов карты текстуры и соединение их в двух диаметрально противоположных точках-полюсах, что дает минимальное искажение рисунка;
  3. Box (Прямоугольные трехмерные) — применяются для отображения текстур на объекты типа прямоугольных параллелепипедов. Если использовать для подобных объектов плоскую систему координат, то на каких-то гранях всегда будет наблюдаться растяжение рисунка текстуры. В случае координат типа Box (Прямоугольные трехмерные) растяжение исключается;
  4. Face (Координаты граней) — обеспечивает размещение отдельных копий текстурной карты в центре каждой грани объекта. На рис. 15.35 показаны две сферы с различным количеством граней, на каждую из которых наложена копия текстуры.

Положением текстуры в пределах поверхности объекта можно управлять.

10. В стеке модификаторов выберите уровень Gizmo (Габаритный контейнер).

В этом режиме можно перемещать, поворачивать и масштабировать значок проекционных координат.

Рис. 15.35. Пример размещения текстуры с использованием координат граней объектов

11. Закончив преобразования значка, щелкните на строке Gizmo (Габаритный контейнер) в стеке модификаторов, чтобы выключить режим работы с габаритным контейнером.

12. Установите нужные размеры габаритного контейнера с помощью счетчиков Length (Длина), Width (Ширина) и Height (Высота).

Настройка параметров растровой текстуры

До сих пор, применяя карты текстур, мы использовали параметры, заданные по умолчанию. Ниже будет рассмотрено назначение основных параметров настройки растровой карты текстуры. Они содержатся в следующих свитках редактора материалов: Coordinates (Координаты), Noise (Зашумление), Bitmap Parameters (Параметры растровых текстур), Output (Результат) и Time(Время). Эти свитки, за исключением Bitmap Parameters (Параметры растровых текстур), являются типовыми и используются для настройки других видов текстур.

1. Назначьте в свитке Maps (Карты текстур) растровую карту текстуры параметру Diffuse (Диффузионное отражение).

Первый свиток параметров Coordinates (Координаты) появится в развернутом виде. Он содержит следующие параметры задания способа преобразования карты текстур:

· Texture (Текстурные) — используется для проекции карты текстуры на поверхность объектов сцены;

· Environ (Фоновые) — назначается в случае, если карта текстуры будет использована в качестве фона сцены или для имитации эффектов окружающей среды;

· Offset (Смещение) — используется для задания величины смещения по осям U и V;

· Tiling (Кратность) — счетчик для задания количества копий карты текстуры по каждой из осей проекционных координат. На рис. 15.36 показаны материалы с разной кратностью текстуры;

Рис. 15.36. Пример материала с разной кратностью текстуры

·
Mirror (Отражение) — включает режим зеркального отражения карты текстуры;

· Angle (Угол) — используется для изменения угла поворота карты текстуры по каждой из трех осей;

· Blur (Размытие) — применяется для задания размытия, которое имитирует расплывчатость текстуры.

2. Раскройте свиток Noise Parameters (Параметры зашумления).

Его параметры позволяют применять к растровой текстуре эффект "зашумления" путем настройки следующих параметров:

· On (Включено) — разрешает включать и выключать режим "зашумления" карты текстуры;

· Amount (Степень) — счетчик, устанавливающий степень зашумления;

· Levels (Уровень) — счетчик, задающий количество циклов случайного зашумления;

· Size (Размер) — счетчик, задающий размер неоднородностей, вызванных зашумлением;

· Animate (Анимация) — включает режим зашумления во времени;

· Phase (Фаза) — управляет скоростью изменения зашумления.

3. Раскройте свиток Bitmap Parameters (Параметры растровых текстур).

Параметры этого свитка позволяют загрузить требуемый графический файл и настроить режимы его использования в составе материала с помощью следующих параметров:

· Bitmap (Растровая карта) — позволяет выбрать файл растрового изображения;

· Piramidal (Пирамидальная) — метод усреднения, применяемый для больших по размеру карт текстур;

· Summed Area (Усреднение по площади) — метод усреднения, применяемый к малым по размеру картам текстур;

· None (Отсутствует) — отключает сглаживание кромок однородных цветовых областей текстуры;

· Cropping/ Placement (Обрезка/Размещение) — параметры этой группы позволяют обрезать края изображения. Для этого следует установить переключатель типа операции в положение Crop (Обрезка) или Place(Разместить) и щелкнуть на кнопке ViewImage (Показ изображения). В появившемся редакторе можно производить масштабирование и обрезку изображения. Чтобы применить результаты обрезки или масштабирования к материалу, следует установить флажок Apply (Применить).

Свиток Output (Результат) дает возможность задать степень влияния текстуры на вид. результирующего изображения.

Свиток Time (Время) управляет изменением материала в процессе анимации сцены.


Сопутствующие команды преобразования

Выделение единичных объектов

Изменение режимов выделения объектов

Выделение объекта с помощью рамки

Выделение объектов по цвету

Выделение всех существующих на экране объектов

Инверсия выбранных объектов

Блокировка набора выделенных объектов

Группы объектов

Перемещение объектов

Дублирование объектов

Поворот объекта

Масштабирование объекта

Использование контекстного преобразования

Назначение центров преобразования

Ограничение осей преобразования

Задание точных значений параметров преобразования

Сейчас мы будем работать с командами, осуществляющими простейшие преобразования геометрических объектов. К ним относятся различные способы выделения объектов, группировка объектов, создание копий, экземпляров и эталонов, перемещение, поворот и масштабирование, выравнивание и др. Эти команды выполняются так или иначе при создании любых геометрических моделей.

Выделение единичных объектов

Выделение объекта может выполняться с помощью кнопок панели инструментов и меню Edit (Редактировать). Для работы с этими командами создадим несколько геометрических объектов так, как мы делали на первом занятии.

1. Щелкните LM в окне проекции Perspective (Перспектива), сделав его активным.

2. На командной панели Create (Создать) нажмите кнопку Geometry (Геометрия), в списке укажите вариант Standard Primitives (Стандартные примитивы), нажмите кнопку Shere (Сфера) и постройте сферу в окне Perspective (Перспектива).

3. Постройте тем же способом конус, при нажатой кнопке Geometry (Геометрия), выбранном варианте Standard Primitives (Стандартные примитивы) и нажатой кнопке Cone (Конус).

Теперь обратите внимание на панель инструментов, показанную на рис. 2.1. Все находящиеся на рисунке кнопки связаны с выделением объектов.

 | Рис. 2.1. Инструменты выделения
4. Щелкните LM на кнопке Select Object (Выделить объект) и передвиньте стрелку курсора на сферу. Когда стрелка курсора превратится в крестик, щелкните LM.

Сфера примет вид, как на рис. 2.2. Вы выделили один объект. Теперь добавьте к нему еще конус.

Рис. 2.2. Выделенный объект помещен в габаритный контейнер

5. Нажмите клавишу <Ctrl> и, удерживая ее, щелкните LM на конусе.

Рамки условного контейнера расширились. Теперь к выделенной прежде сфере добавился конус (рис. 2.3). Действие клавиши <Ctrl> позволяет добавлять любое количество объектов к уже выделенным. Если из группы выделенных объектов вам надо исключит отдельные объекты, используйте клавишу <Alt>.

Рис. 2.3. Выделение группы объектов

6. Нажмите клавишу <Alt> и, удерживая ее, щелкните на сфере.

7. Сфера будет исключена из выделенной группы. Если вы желаете отказаться от выбора всех выделенных объектов, то достаточно щелкнуть LM в любой точке окна вне габаритного контейнера.

8. Щелкните LM в любом месте окна, снимая этим выделение объектов.

Изменение режимов выделения объектов

Кнопка смены режимов выделения объектов позволяет назначить два режима: Window (Окно) и Crossing Selection (Пересекающее выделение). Смена режимов производится щелчком LM на кнопке, расположенной в нижней части экрана в строке сообщений.

Если режим определен кнопкой Crossing Selection (Пересекающее выделение), то объект будет выделен, когда хотя бы одна точка его попадет в область выделения.

Если режим определен кнопкой Window (Окно), то объект будет выделен в случае, если целиком попадет в область выделения.

Выделение объекта с помощью рамки

Инструмент "рамка" предназначен для выделения группы объектов. Он используется в случае, когда на сцене имеется много объектов, которые надо выделить.

1. Щелкните LM на кнопке Select Object (Выделить объект) и установите режим Crossing Selection (Пересекающее выделение).

2. Щелкните LM в окне проекции и перетащите курсор, не отпуская кнопки мыши, по диагонали так, чтобы требуемая группа объектов попала в прямоугольник выбора (рис. 2.4).

3. Отпустите кнопку мыши.

Рис. 2.4. Пересекающее выделение объектов

Будут выбраны все объекты, попавшие хотя бы одной точкой в прямоугольную рамку. Вы использовали прямоугольную рамку.

Существуют и другие ее формы. Например для выбора объектов служит кнопка Rectangular Selection Region (Прямоугольная область выделения).

4. Щелкните LM на кнопке Select Object (Выделить объект) и далее нажмите кнопку Rectangular Selection Region (Прямоугольная область выделения), немного задержав кнопку мыши.

В результате появится падающее меню, которое содержит кнопки выбора еще двух типов рамок, показанных на рис. 2.5.

Рис. 2.5. Кнопки выбора типов рамки

5. Щелкните LM на кнопке Circular Selection Region (Круглая область выделения) и затем в окне проекции. Растяните окружность так, чтобы выделяемые объекты попали в нее хотя бы одной своей точкой.

Центр окружности будет располагаться в выбранной точке окна проекции. Круглая область выделения показана на рис. 2.6.

Рис. 2.6. Круглая область выделения объектов

6. Откажитесь от выделенных объектов и щелкните на кнопке Fence Selection Region (Произвольная область выделения)..

7. Щелкните LM вне объектов и перетащите курсор, рисуя первый сегмент рамки. Отпустите кнопку мыши, фиксируя первый сегмент. Переместите курсор в точку, где должен оканчиваться второй сегмент рамки и щелкните LM.

8. Продолжайте построение, обводя сегментами требуемую область.

Для замыкания рамки переместите курсор в точку начала первого сегмента. Курсор примет вид тонкого перекрестья, указывая на возможность замыкания. Щелкните LM, и рамка будет замкнута.

9. Область произвольной формы показана на рис. 2.7. Для отмены режима рисования рамки щелкните RM или нажмите клавишу <Esc>.

Рис. 2.7. Произвольная область выделения объектов

10. Измените режим выбора с Crossing Selection (Пересекающее выделение) на Window (Окно) и постройте для него различные формы выделяющей рамки.

Выделение объектов по цвету

По умолчанию всем объектам при их создании назначаются различные цвета, случайным образом выбираемые из цветовой палитры. Если требуется выбрать все объекты одного цвета, то для этого следует обратиться в пункт Edit (Редактирование) основного меню.

1. Постройте сферу того же цвета, что и конус.

2. Выберите в меню Edit (Редактирование) команду Select By (Выделить по), а затем команду Color (Цвет) (рис. 2.8).

3. Укажите на один из объектов, по цвету которого будут выделяться другие объекты и щелкните LM.

Рис. 2.8. Строка меню выбора по признакам

Будут выделены объекты того же цвета, что и указанный объект

Выделение всех существующих на экране объектов

1. Для выбора всех объектов сразу укажите в меню Edit (Редактирование) команду Select All (Выделить все).

Все объекты сцены будут выделены.

2. Для продолжения работы откажитесь от выбора, щелкнув мышью в любой точке окна.

Инверсия выбранных объектов

Иногда необходимо выделить все объекты сцены вместо тех, которые выбраны в настоящий момент. Это удобно сделать, применив команду инверсии выбора.

1. Выделите сферу.

2. В меню Edit (Редактирование) укажите команду Select Invert (Выполнить инверсию).

Выделение сферы будет снято, а два других объекта окажутся выделенными.

Блокировка набора выделенных объектов

Выделив группу объектов, вы можете заблокировать выбор. Это делается для того, чтобы, например, случайно не сбросить выбор.

1. Выделите конус и сферу одним из указанных ранее способов.

2. Щелкните LM на кнопке Lock Selection Set (Блокировка выделенной группы) с пиктограммой замка, находящейся в строке состояния в нижней части экрана.

После включения блокировки кнопка становится желтой. До тех пор, пока блокировка не будет снята, нельзя ни выбрать новый объект, ни сбросить выделение. Блокировка снимается повторным нажатием на ту же кнопку.

3. Щелкните LM на кнопке Lock Selection Set (Блокировка выделенной группы) и снимите блокировку объектов.

Группы объектов

Группа — это совокупность объектов, которые после группирования составляют единый объект. Все преобразования, которые можно выполнить для одного объекта, будут осуществляться для группы. В составе сцены может быть создано произвольное количество групп объектов. Можно также организовывать вложенные группы, т. е. группу в группе с неограниченным уровнем вложенности.

1. Выделите все три объекта сцены одним из указанных выше способов и выберете в меню Draw (Рисовать) команду Group (Группа), а затем команду Create (Сгруппировать).

Появится диалоговое окно с текстовым полем (рис. 2.9), в котором можно задать имя группы. По умолчанию группы именуются Group I, Group2 и т. д.

Рис. 2.9. Окно диалога группировки объектов

2. Щелкните LM на кнопке ОК.

Теперь при выборе любого объекта группы вся группа выделится как одно целое. Если появится необходимость работы с отдельными элементами группы, то ее можно разгруппировать.

3. В меню Group (Группа) укажите команду Open (Открыть).

Все три объекта будут разблокированы. Проверьте это самостоятельно, проделав любое из преобразований над объектами, и опять закройте группу.

4. В меню Group (Группа) выберите команду Close (Закрыть).

Перемещение объектов

Для перемещения объектов выполните следующие действия:

1. Щелкните LM на кнопке Select and Move (Выделить и переместить) панели инструментов.

2. Установите курсор на конусе и щелкните LM.

3. Курсор примет вид значка, изображенного на кнопке Select and Move (Выделить и переместить).

4. Не отпуская кнопки, перетащите объект.

Результат перемещения показан на рис. 2.10. После перемещения объект остается выделенным. Можно перейти в другое окно проекции и продолжить перемещение.

Рис. 2.10. Пример перемещения объекта

Дублирование объектов

В процессе создания сцены может возникнуть необходимость создать однотипные объекты. Программа позволяет формулировать три вида дубликатов с различными свойствами: копии, образцы и экземпляры.

1. Выделите конус.

2. Выберете в меню Edit (Редактирование) команду Clone (Дублировать).

Появится диалоговое окно Clone Options (Параметры дублирования), показанное на рис. 2.11.

3. Подтвердите выбор, щелкнув LM по кнопкеOК.

Копия конуса создана.

Рис. 2.11. Диалоговое окно копирования

4. С помощью команды Select and Move (Выделить и переместить) переместите ее.

5. Аналогично команде Copy (Копия) создайте Instance (Образец) и, Reference (Экземпляр).

· Instance (Образец) — это дубликат объекта, сохраняющий все связи с материнским объектом. Изменение свойств материнского объекта влечет изменения во всех образцах. А изменение в любом образце влечет изменения как в оригинале, так и в других образцах.

· Reference (Экземпляр) — подобен образцу, но имеет одностороннюю связь с оригиналом: изменения в материнском объекте приводят к изменениям в экземпляре, но изменения в экземпляре не повлекут изменений в материнском объекте. Клон объекта пространственно совпадает с оригиналом.

Поворот объекта

Для поворота объекта выполните следующие шаги.

1. Щелкните LM на кнопке Select and Rotate (Выделить и повернуть) панели инструментов. Выделите конус. Курсор над конусом примет вид значка кнопки поворота.

2. Щелкните LM и, удерживая кнопку, перетаскивайте курсор вверх или вниз. Результат поворота объекта показан на рис. 2.12.

По умолчанию поворот будет происходить вокруг оси, перпендикулярной координатной плоскости. В качестве центра поворота отдельного объекта принимается его опорная точка, а в качестве центра преобразования совокупности объектов — геометрический центр воображаемого параллелепипеда. Опорной точкой принято считать точку, по которой определяются координаты положения объекта в пространстве. Можно выбрать и другие точки преобразования. При движении курсора вверх поворот происходит по часовой стрелке, при движении вниз — против часовой стрелки.

Рис. 2.12. Поворот объекта

Масштабирование объекта

Команда может выполнить три разновидности масштабирования: равномерное, неравномерное и сжатие.

1. Щелкните LM на кнопке Select and Uniform Scale (Выделить и равномерно масштабировать) панели инструментов. Переместите курсор в окно проекции и выделите конус.

2. Курсор над объектом примет вид значка кнопки масштабирования.

3. Щелкните LM и перетаскивайте курсор вверх и вниз.

При равномерном масштабировании изменение размеров объекта будет происходить одновременно в направлении всех трех осей глобальной системы координат (рис. 2.13). Увеличение размеров объекта происходит при движении курсора вверх. При движении вниз — уменьшение. При этом курсор может выходить за пределы окна проекции. Центр преобразования назначается так же, как и при повороте объекта.

4. Щелкните LM на кнопкеSelectandUniformScale (Выделить и равномерно масштабировать) и немного задержите ее.

Раскроется панель инструментов неравномерного масштабирования и сжатия, показанная на рис. 2.14

Рис. 2.13. Пример равномерного масштабирования

Рис. 2.14. Панель инструментов неравномерного масштабирования

5. Щелкните LM на кнопке Select and Non-uniform Scale (Выделить и неравномерно масштабировать).

На экране появится предупреждение о том, что неравномерное масштабирование или сжатие на уровне объектов ведет к помещению преобразования в стек после всех модификаторов. Это может привести к неожиданным результатам. Чтобы избежать неопределенности, рекомендуется применить к выделенным объектам модификатор Xfonn (Преобразование), а затем осуществить нужное преобразование для габаритного контейнера модификатора как подобъекта.

6. Щелкните LM на кнопке Yes и переместите курсор на сферу. Неравномерное масштабирование выполнять так же, как и равномерное.

Пример неравномерного масштабирования приведен на рис. 2.15. В этом варианте масштабирования изменение геометрических размеров объекта будет происходить равномерно только в направлениях, параллельных координатной плоскости окна проекции. В направлении, перпендикулярном плоскости окна, размер объекта меняться не будет.

Рис. 2.15. Результат неравномерного масштабирования сферы

7. Щелкните LM на кнопке Select and Squash (Выделить и сжать) и проведите сжатие конуса.

Преобразование сжатия при равномерном увеличении размеров объекта в направлениях, параллельных координатной плоскости окна проекции, осуществляется перпендикулярно координатной плоскости.

На рис. 2.16 представлен результат масштабирования типа "сжатие", примененный к одному из двух одинаковых конусов.

Рис. 2.16. Пример масштабирования типа "сжатие"

Использование контекстного преобразования

Преобразования Move (Перемещение), Rotate (Поворот) и Scale (Масштабирование) можно выполнить с помощью контекстного меню. Для этого выделите сферу одним из способов, выставьте курсор на параллелепипед и щелкните RM. На экране появится меню с командами преобразования, (рис. 2.17), аналогичными кнопочным меню панели инструментов. При выборе команды Scale (Масштабирование) будет активизирован тот из способов масштабирования, кнопка которого представлена на панели инструментов. Для изменения способа надо обратиться к кнопочному меню. В остальном преобразования выполняются таким же образом, как и при использовании кнопочного меню.

Рис. 2.17. Контекстное меню преобразования

Назначение центров преобразования

Результаты поворота и масштабирования зависят от выбора центра преобразования, то есть точки в трехмерном пространстве, вокруг которой будет выполняться поворот, а также к которой будет происходить стягивание или растяжение при масштабировании.

Для выбора центра преобразования служит группа из трех кнопок панели инструментов, показанная на рис. 2.18.

1. Выделите конус. Щелкните LM по кнопке выбора центра преобразования и, задержав ее, откройте панель инструментов.

Рис. 2.18. Кнопочное меню выбора центра преобразования объектов

2. Нажмите кнопку Use Pivot Point Center (Использовать опорные точки объектов).

Тройка координатных осей окажется привязанной к опорной точке (рис. 2.19). Напомним, что это есть геометрический цент габаритного контейнера объекта.

Рис. 2.19. Координатные оси привязаны к опорной точке конуса

Если выделена группа объектов, то к каждому объекту будет привязана тройка координатных осей.

3. Выполните поворот относительно выбранного центра. Нажмите кнопку Use Selection Center (Использовать центр выделения).

4. В этом режиме преобразование производится относительно центра выделенного набора объектов. Координатная тройка переместится в центр условного параллелепипеда, описанного вокруг совокупности выделенных объектов (рис. 2.20).

5. Выполните поворот относительно выбранного центра.

Выберете кнопку Use Transform Coordinate Center (Использовать начало координат).

Центр координат переместился в начало текущей системы координат. По умолчанию используется система координат типа View (Оконная), при которой центр окна проекции является началом системы координат.

6. Выполните поворот относительно выбранного центра.

Ограничение осей преобразования

Команды ограничения осей преобразования размещены на основной панели инструментов (рис. 2.21). Данная группа кнопок действует как переключатель.На каждой кнопке указано, по какой оси или в какой плоскости происходит преобразование.

Рис. 2.20. Кнопки ограничения осей преобразования

1. Щелкните LM последовательно на кнопке Х и на кнопке перемещения.

2. Выделите сферу и переместите ее.

Обратите внимание на направление перемещения объекта. Оно стало возможно только по оси X.

3. На всех режимах ограничения опробуйте команды перемещения и поворота.

Задание точных значений параметров преобразования

До сих пор вы делали преобразования с помощью мыши, которая не давала возможности обеспечить требуемую точность. Существует средство задать преобразование с любой необходимой точностью.

1. Выберите объект преобразования и щелкните RM на кнопке Select and Move (Выделить и переместить).

Появится окно диалога для ввода данных того преобразования, которое назначено. В нашем случае — перемещения (рис. 2.22).

Рис. 2.22. Окно ввода координат перемещения

2. Введите числовые значения параметров преобразования по соответствующим координатным осям в группу Absolute: World (Абсолютные: Глобальные) и нажмите клавишу <Enter> или <Таb> для выполнения преобразования.

Вы задали параметры в глобальной системе координат, начало которой помещено в точку (0,0,0) пространства сцены.

3. Задайте параметры в группе Offset: World (Приращения: Глобальные) и нажмите клавишу <Enter> или <Таb> для выполнения преобразования.

Заданные параметры указывают приращения текущих значений параметров в экранной системе координат.

4. Используйте задание точных значений параметров для других видов преобразования.


Сплайны.

Общие сведения о сплайнах

Порядок создания сплайнов

Линия

Прямоугольник и эллипс

Многоугольник

Дуга и сектор

Спираль

Звезда

Текст

Сечение

NURBS-кривые

Если вам понадобится создать объекты более сложные, чем представленные в разделах стандартной геометрии, то придется научиться строить различного типа сплайны и уметь их редактировать. Они послужат в дальнейшем основой для создания сложных трехмерных моделей с помощью методов лофтинга, вращения и вытягивания. Кроме того, сплайны могут применяться в качестве линий траектории движения объектов при анимации.

Общие сведения о сплайнах

Пред тем, как приступить к созданию и редактированию конкретных сплайнов, определим основные понятия, связанные с особенностями их геометрии. Мы будем оперировать следующими понятиями:

· сегмент — это часть линии сплайна между двумя соседними вершинами;

· вершины — различаются по типу и определяют степень кривизны сегментов сплайна, прилегающих к этим вершинам. Первая вершина, обозначающая начало сплайна, в момент создания помечается квадратом белого цвета.

В программе используются четыре типа вершин:

· Corner (С изломом) — вершина, примыкающие сегменты к которой не имеют кривизны;

· Smooth (Сглаженная) — вершина, через которую кривая сплайна проводится с изгибом и имеет одинаковую кривизну сегментов с .обеих сторон от нее;

· Bezier (Безье) — вершина, подобная сглаженной, но позволяющая управлять кривизной сегментов сплайна с обеих сторон от вершины. Для этого вершина снабжается касательным отрезком с маркерами в виде квадратов зеленого цвета на концах. Перемещая маркеры касательных отрезков вокруг вершины, можно изменять направления, по которым сегменты сплайна входят в вершину и выходят из нее, а изменяя расстояние от маркера до вершины — регулировать кривизну сегментов сплайна;

· Bezier Corner (Безье с изломом) — вершина, которая, как и вершина типа Bezier, снабжена касательным вектором. Однако у вершин Bezier Corner(Безье с изломом) касательные не связаны друг с другом отрезком, и маркеры можно перемещать независимо.

Разновидностей вершин не случайно так много. Вершины делают сплайн, как короля его свита. Типы их показаны на рис. 5.1.

Рис. 5.1. Типы вершин

Доступ к редактированию сплайнов на уровне отдельных сегментов и вершин открывается с помощью кнопки Modify (Изменить) на командной панели.

Сплайны относятся к категории Shapes (Формы). Формы могут состоять из нескольких отдельных сплайнов. Если форма состоит более чем из одного сплайна, можно применять преобразования к сплайнам, как к набору объектов, либо объединить их в пределах формы в один, более сложный, сплайн.

Порядок создания сплайнов

Определимся с порядком создания сплайнов. Для этого:

1. Щелкните LM на кнопке Shapers (Формы) командной панели Create (Создать) и выберите в списке объектов Splines (Сплайны). В свитке Object Type (Тип объекта) появится набор стандартных примитивов

Над кнопками типов объектов в свитке Object Type (Тип объекта) размещена кнопка Start New Shape (Начать новую форму), которая по умолчанию заблокирована во включенном состоянии. Если разблокировать ее, сбросив расположенный справа флажок, то все вновь создаваемые сплайны будут принадлежать одной и той же форме. В этом случае, чтобы начать новую форму, придется щелкнуть на кнопке Start New Shape(Начать новую форму).

2. В свитке Object Type (Тип объекта) выберите объект требуемого типа.

В нижней части появятся свитки с параметрами выбранного объекта:

Rendering (Визуализация), Interpolation (Интерполяция), Creation Method(Метод создания), Keyboard Entry (Клавиатурный ввод), Parameters (Параметры).

3. В свитке Creation Method (Метод создания) отметьте Edge (От края) или Center (От центра) в зависимости от способа построения: от края или от центра.

Объекты Line (Линия) и Arc (Дуга) имеют иные свитки Creation Method(Метод создания). Они будут рассматриваться при построении соответствующих сплайнов.

4. Настройте параметры интерполяции криволинейных сегментов сплайна в группе Interpolation (Интерполяция) свитка General (Общие):

· задайте число точек излома криволинейных сегментов с помощью счетчика Steps (Шагов);

· установите параметры Optimize (Оптимальная), которые заставят программу оптимизировать сплайн путем сброса в ноль числа шагов для его линейных сегментов.

Линия

Выполните следующие шаги:

1. В свитке Creation Method (Метод создания) установите переключатель Initial Type (Начальный тип).

Этим вы определите тип вершины, которая будет создаваться при щелчке мыши: Corner (С изломом) или Smooth (Сглаженная).

2. Установите переключатель Drag Type (Вершина при перетаскивании) в одно из трех положений: Corner (С изломом), Smooth (Сглаженная) или Bezier (Безье).

Таким образом вы зададите тип вершины, которая будет создаваться при перетаскивании курсора после щелчка.

3. Щелкните в точке окна проекции, где будет располагаться первая вершина линии.

Создать очередную вершину можно прост sм щелчком кнопки мыши. В этом случае вершина приобретет тип, определяемый положением переключателя Initial Type(Начальный тип). По умолчанию это вершина типа Corner (С изломом). Если при создании очередной вершины щелкнуть кнопкой мыши и, удерживая ее, перетащить курсор, то будет создана вершина, тип которой определяется положением переключателя Drag Type (Вершина при перетаскивании). По умолчанию это вершина Bezier (Безье).

Прямоугольник и эллипс

Выполните следующие шаги:

1. На командной панели Create (Создать) нажмите кнопку Shapers (Формы), в списке объектов выберите вариант Splines (Сплайны), укажите Rectangle (Прямоугольник) и задайте способ создания "от края".

2. Щелкните LM в окне проекции и перетащите курсор по диагонали, следя за значением параметров Length (Длина) и Width (Ширина). Отпустите кнопку мыши, фиксируя прямоугольник.

3. Для закругления углов прямоугольника введите значение радиуса закругления в счетчике Corner Radius (Радиус закругления).

4. Тем же способом создайте эллипс с помощью кнопки Ellips (Эллипс).

Чтобы создать квадрат с помощью примитива Rectangle (Прямоугольник) или окружность — с помощью примитива Ellips (Эллипс), стройте объекты при нажатой клавише <Ctrl>. На рис. 5.2 показан прямоугольник и его модификация со скругленными углами.

Рис. 5.2. Прямоугольник и его модификация

Многоугольник

Многоугольник можно создать несколькими способами: с помощью команды Ngon (N-угольник) и вручную с помощью команды Line (Линия).

1. Для построения правильного многоугольника выберите способ создания — "от края" и задайте число сторон многоугольника в счетчике Sides(Стороны).

2. Щелкните LM в окне проекции и перетащите курсор, следя за параметром Radius (Радиус). Отпустите кнопку мыши, фиксируя объект.

Переключатель под счетчиком Radius (Радиус) фиксирует один из следующих способов построения:

· Inscribed (Описанный) — в счетчике фиксируется радиус окружности, описанной вокруг многоугольника;

· Circumscribed (Вписанный) — в счетчике фиксируется радиус окружности, вписанной в многоугольник.

3. При необходимости скруглить углы многоугольника задайте радиус закругления в счетчике Corner Radius (Радиус закругления), а установка параметра Circular (Круглый) превратит многоугольник с любым числом сторон в окружность.

Рассмотренные виды многоугольника представлены на рис. 5.3.

Рис. 5.3. Многоугольник и его модификация

4. Построим многоугольник с помощью примитива Line (Линия): установите переключатели Initial Type (Начальный тип) и Drag Type (Вершина при перетаскивании) в положение Corner (С изломом). После выбора команды каждый щелчок LM будет фиксировать отрезок ломаной линии. Закончить построение ломаной можно щелчком RM.

5. Для замыкания ломаной линии в очередной раз щелкните LM в точке начала ломаной, и когда появится запрос Close Spline (Замкнуть сплайн), нажмите кнопку Yes.

Вы получили ломаную линию, где вершины строились с изломом, а сегменты — как отрезки прямой. Теперь самостоятельно постройте сплайн, состоящий из нескольких сегментов, комбинируя параметры Corner (С изломом), Smooth (Сглаженная) и Bezier (Безье) в разделах Initial Type (Начальный тип) и Drag Type (Вершина при перетаскивании). Положение Initial Type (Начальный тип) определяет, какого типа вершины будут создаваться при щелчке LM, a Drag Type (Вершина при перетаскивании) — при перетаскивании после щелчка. Проанализируйте влияние различных комбинаций параметров на форму вершин и сегментов сплайна.

Пример создания сплайна произвольной формы с использованием различных вариантов построения вершин показан на рис. 5.4.

Рис. 5.4. Сплайны с различным способами построения вершин

Дуга и сектор

Для построения дуги и сектора выполните следующие шаги:

1. Выберите примитив Arc (Дуга).

Это позволит создавать сплайны в виде дуги и сектора, как показано на рис. 5.5.

2. Установите переключатель в свитке Creation Method (Метод создания) в одно из двух положений: End- End- Middle (Конец — Конец — Середина) или Center- End- End (Центр — Конец — Конец).

Рис. 5.5. Дуга и сектор

3. Если выбран метод End- End- Middle (Конец — Конец — Середина), щелкните в окне проекции, где должен располагаться один из концов дуги, и перетащите курсор до точки, в которой будет размещаться второй конец дуги.

За курсором будет тянуться прямая линия.

4. Отпустите кнопку мыши, фиксируя положение второго конца дуги. Переместите курсор, чтобы настроить радиус дуги.

Следите за значением параметра Radius (Радиус).

5. Щелкните LM, фиксируя дугу.

6. Установите нужные значения параметров в счетчиках From (От) и То (До), указывающих угловые значения начальной и конечной точек дуги на окружности, отсчитываемой от оси Х локальной системы координат сплайна.

7. Если выбран метод Center- End- End (Центр — Конец — Конец), щелкните LM в точке, где будет располагаться центр окружности, частью которой будет являться ваша дуга.

8. Перетяните курсор, настраивая радиус дуги и определяя точку ее начала. Отпустите кнопку мыши, фиксируя радиус и начало дуги.

9. Щелкните LM, фиксируя положение конца дуги.

10. Отметьте опцию Pie Slice (Сектор), чтобы создать замкнутый сплайн в виде сектора.

Чтобы поменять точки начала и конца дуги, достаточно отметить параметр Revers (Обратить).

Спираль

Спираль можно построить, воспользовавшись следующей инструкцией:

1. Выберите примитив Helix(Спираль).

Это позволит создать сплайн в виде трехмерной спирали с заданным числом витков, как на рис. 5.6.

Рис. 5.6. Спираль с заданным числом витков

2. Задайте способ создания спирали — от края или от центра, отметив позицию Edge (От края) или Center (От центра) в списке параметров.

3. Щелкните LM в окне проекции, где должна располагаться начальная точка спирали, перетащите курсор, чтобы задать радиус спирали у ее основания, и отпустите кнопку.

Радиус основания спирали фиксируется в окне параметра Radius1 (Радиус1), а опорная точка спирали разместится в центре ее основания.

4. Перетащите курсор вверх или вниз для задания высоты спирали и щелкните LM.

Высота спирали отразится в окне параметра Height (Высота).

5. Переместите курсор к центру или от центра спирали для задания радиуса ее витка у вершины и щелкните LM.

Радиус витка спирали у вершины фиксируется в окне параметра Radius2 (Радиус2).

6. Задайте в счетчике Turns (Витки) число витков спирали, т. е. количество полных витков от основания до вершины спирали.

7. Уменьшите шаг витков спирали к ее вершине. Используйте для этого параметр Bias (Смещение), установив его значение равным 1 (рис. 5.7).

Значения параметров Bias (Смещение) лежат в пределах от -1 до 1. Спираль с постоянным шагом строится при Bias равном 0. Уменьшение шага от вершины к основанию определяет знак "-" значения переменной Bias(Смещение).

Рис. 5.7. Спираль с равномерным изменением расстояния между витками

8. Поменяйте направление закрутки витков спирали с помощью параметров CW (По часовой стрелке) и CCW (Против часовой стрелки).

Звезда

Объекты такого вида представляют собой замкнутые сплайны в виде звезды с произвольным количеством лучей.

1. Выберите примитив Star (Звезда) в установленном свитке типов объектов, щелкните в точке окна, где будет располагаться центр звезды, и перетащите курсор, задавая параметр Radius 1 (Радиус1).

В зависимости от величины параметра Radius2 (Радиус2), который будет задан на следующем шаге, Radiusl (Радиус1) может быть радиусом как вписанной в звезду, так и описанной вокруг нее окружности.

2. Переместите курсор к центру или от центра, чтобы задать параметр Radius2 (Радиус2).

3. Укажите число лучей в счетчике Points (Лучи).

Стандартная звезда показа на рис. 5.8, а.

1. С помощью параметра Distoritions (Искажения) задайте угол смещения точек звезды, расположенных на окружности радиусом Radius2 (Радиус2) относительно точек окружности радиусом Radiusl (Радиус1).

В результате смещения получится звезда с косыми лучами, как на рис. 5.8, б.

2. Для закругления концов звезды (рис. 5.8, в) определите в счетчике Fillet Radiusl (Радиус! закругления) радиус их закругления.

3. Для закругления оснований лучей (рис. 5.8, г) укажите радиус закругления в счетчике параметра Fillet Radius2 (Радиус2 Закругления).

Рис. 5.8. Стандартная звезда (а), искаженная звезда (б), с закругленными концами (в), с закругленными углами у основания (г)

Текст

Если вы работали в текстовых редакторах, то для вас не составит труда создание текста в 3D StudioMAX. Примитив Text (Текст) позволяет создавать формы, состоящие из совокупности сплайнов в виде контуров текстовых символов. Для текста можно задавать размер символов, гарнитуру шрифта, режимы выравнивания строк текста, межсимвольные интервалы. Текст, как любая другая форма, может быть геометрически отредактирован.

1. Щелкните LM на кнопке Text (Текст) и в группе Parameters (Параметры) свитка выберите гарнитуру шрифта.

2. Укажите вариант начертания символов:

· I (Курсив);

· U (Подчеркнутый).

Полужирное начертание можно задать, выбрав в списке типов шрифт с пометкой Bold (Полужирный).

3. Задайте размер шрифта в счетчике Size (Размер), кернинг (межсимвольный интервал) — в счетчике Kerning (Кернинг) и межстрочный интервал — в счетчике Leading (Интерлиньяж).

4. После задания установок введите текст в поле Text (Текст).

Для выравнивания строк введенного текста используйте кнопки с пиктограммами выровненного текста.

5. Разместите текст в окне проекции, щелкнув LM.

Текст разместится в окне проекции так, что его опорная точка, находящаяся в центре основания первой строки, расположится в указанной щелчком кнопкой мыши точке. Если щелкнуть LM и перетаскивать курсор, то текстовая форма будет перемещаться вместе с курсором до момента, когда будет отпущена кнопка мыши. Пока текст остается выделенным, можно изменить любые его параметры. Образец текста приведен на рис. 5.9.

Рис. 5.9. Образцы текста

Сечение

Примитив Section (Сечение) создает специальный тип сплайна, представляющего собой сечение сетчатой оболочки трехмерного объекта произвольно ориентированной плоскостью. Создадим объект сложной конфигурации и построим для него сечение.

1. Нажмите кнопку Geometry (Геометрия) командной панели Create (Создать), в списке выберите вариант Standard Primitives (Стандартные примитивы), нажмите кнопку Sphere (Сфера) и создайте сферу. Там же выберите кнопку примитива Box (Параллелепипед) и постройте параллелепипед.

2. С помощью команды Move (Переместить) переместите параллелепипед до пересечения со сферой, сбросьте выбор параллелепипеда и выделите сферу.

3. Нажмите кнопку Geometry (Геометрия) командной панели Create(Создать), в списке выберите вариант Compound Objects (Составные объекты) и нажмите кнопку Boolean (Булевские).

4. В появившемся свитке параметров команды установите параметры Move(Переместить) и Subtraction (А-В) (Исключение (А-В)).

5. Щелкните LM на кнопке Pick Operand В (Указать операнд В) и выделите параллелепипед.

Объект, полученный после применения булевской операции исключения (рис. 5.10), будет использоваться при создании сечения.

Рис. 5.10. Объект для создания сечения

6. Выберите примитив Section (Сечение), щелкните LM в окне проекции, где будет размещено сечение, и растяните объект.

Сплайн-сечение создается в виде прямоугольной рамки, разбитой на четыре части. Он строится методом "от центра". В соответствии с принятой по умолчанию установкой параметра Section Extents (Протяженность сечения) прямоугольник только обозначает ориентацию плоскости сечения, а его размеры не имеют значения — плоскость сечения считается неограниченной в пространстве.

7. Переместите сечение с помощью кнопки Move (Переместить) до пересечения с построенным объектом, как показано на рис. 5.11.

Желтым цветом будет прорисована линия пересечения объекта с плоскостью.

8. Щелкните на кнопке Create Shape (Создать форму) в свитке Section Parameters (Параметры сечения).

В появившемся окне диалога Name Section Shape (Имя формы сечения) можно изменить имя сечения или оставить заданное по умолчанию. Щелкните LM на кнопке ОК. Линия сечения будет создана в виде редактируемого сплайна.

9. Переместите плоскость сечения с помощью кнопки Move (Переместить) так, чтобы было видно все сечение (рис. 5.12).

Рис. 5.11. Плоскость сечения, проходящая-сквозь объект

Рис. 5.12. Контур сечения в виде сплайна

Если есть необходимость изменить положение и ориентацию плоскости сечения, то следует обратиться к командной панели Modify (Изменить).

10. Выберите вкладку Modify (Изменить) на командной панели. В свитке Section Parameters (Параметры сечения) используйте для построения последовательно все три варианта раздела Update (Обновление):

· When Section Moves (При перемещении сечения) — линия сечения будет обновляться при перемещении или изменении размеров плоскости сечения;

· When Section Selected (При выделении сечения) — линия сечения будет обновляться после сброса и повторного выделения плоскости сечения;

11. Manually (Вручную) — для принудительного обновления линии щелкните LM на кнопке Update Section (Обновить сечение).

Для изменения размеров секущей плоскости используйте счетчики Length (Длина) и Width (Ширина) в свитке Section Size (Размеры плоскости сечения).

NURBS-кривые

NURBS-кривые — сплайн, при построении которого различают два типа кривых:

· Point Curve (Точечная кривая) — проходит через все контрольные точки, заданные в трехмерном пространстве;

· CV Curve (CV-кривая) — плавно огибает все контрольные точки, заданные в трехмерном пространстве и называемые управляющими вершинами.

1. Построение NURBS-кривой начнем, как всегда, с назначения команды. На командной панели Create (Создать) нажмите кнопку Shapes (Формы) и укажите NURBS Curves (NURBS-кривые).

В свитке Object Type (Тип объекта) появятся две кнопки с надписями, соответствующими двум типам кривых: Point Curve (Точечная кривая) и CV Curve (CV-кривая).

2. Щелкните LM на кнопке Point Curve (Точечная кривая).

В нижней части командной панели появятся два свитка: Keyboard Entry(Клавиатурный ввод) и Curve Approximation (Аппроксимация кривой). Параметры последнего свитка не отличаются от аналогичных параметров свитка General (Общие) форм-сплайнов.

3. Щелкните LM в окне проекции, переместите курсор в следующую точку и зафиксируйте ее щелчком LM.

Если после щелчка LM по кривой перетащить курсор, удерживая кнопку мыши, более чем на 5 пикселов, то в момент отпускания кнопки мыши будет создана дополнительная точка.

4. Для завершения создания кривой щелкните RM. Для создания замкнутой кривой щелкните LM в начальной точке.

Появится запрос Close Curve? (Замкнуть кривую?). Подтвердите запрос, нажав кнопку ОК. Пример кривой Point Curve (Точечная кривая) приведен на рис. 5.13.

5. Активизируйте теперь кнопку CV Curve (CV-кривая) и нарисуйте кривую.

При создании CV Curve (CV-кривая) наряду с управляющими вершинами отображается решетка деформации в виде пунктирных линий (рис. 5.14). Если после очередного щелчка LM удерживать кнопку мыши, то можно перетащить созданную вершину в другую точку окна.

Рис. 5.13. Пример точечной NURBS-кривой

Рис. 5.14. Пример CV-кривой с управляющими вершинами


Точность моделирования

Выбор единиц измерения

Установка общих привязок

Настройка координатной сетки

Назначение вспомогательных объектов

Применение вспомогательного объекта-сетки

Выравнивание обекта-сетки

Выравнивание положения и ориентации по опорному объекту

Выравнивание нормалей

Выравнивание источников света

Выравнивание камеры

Выравнивание локальных осей координат объекта по окну проекции

Измерение расстояния между объектами

Любое моделирование требует точности в той или иной мере. Чем выше возможность точного моделирования у графического пакета, тем более сложные задачи позволяет он решать. Для 3D Studio MAX разработан широкий набор средств, позволяющих точно выстраивать сцены.

Выбор единиц измерения

Перед началом работы требуется настроить систему измерения.

1. Выберите в меню Customize (Специальные) команду Units Setup (Единицы измерения).

Появится диалоговое окно Units Setup (Единицы измерения).

2. Установите Metric (Метрические) — метрические единицы измерения.

3. Раскройте список и выберите там единицу измерения Meters (Метры).

Список содержит четыре варианта: миллиметры, сантиметры, метры и километры. Выбор единицы измерения зависит от конкретной задачи, и отразиться в поле отсчета координат строки состояния (рис. 3.1).

Рис. 3.1. Поля отсчета координат

Выбрав вариант Custom (Пользовательский), можно задать собственную единицу измерения, например, 10 метров, при использовании которой одна единица системной шкалы будет соответствовать 10 метрам. По умолчанию в качестве специальной единицы предлагается единица FL, равная 660 футам, допустимая точность измерения предполагает три знака после запятой. Увеличим точность значений установки параметров.

4. Выберите в меню Customize (Специальный) команду Preferences (Параметры) и щелкните LM на корешке вкладки General (Общие) диалогового окна.

5. Задайте количество знаков после запятой в счетчике Spinner Precision Decimals (Точность счетчиков разрядов).

Установка общих привязок

Привязки позволяют размещать опорные точки создаваемых или редактируемых объектов в конкретных местах. Средства привязки заставляют курсор притягиваться к определенным точкам объектов сцены, таким как вершины, ребра, центры граней или точки опоры. Установка привязок подразумевает задание типов привязок и их активизацию.

1. Выберите в меню Customize (Специальный) команду Grid and Snap Settings (Настройка сетки и привязок).

Появится окно диалога настройки сетки и привязок, раскрытое по умолчанию на разделе Snaps (Привязки). Он содержит двенадцать видов привязки:

· Grid Points (Узлы сетки) — привязка к узлам сетки;

· Grid Lines (Линии сетки) — привязка к линиям координатной сетки;

· Pivot (Опора) — привязка к опорным точкам объектов;

· Bounding Box (Габаритный контейнер) — привязка сегментов текущего сплайна к точкам других сплайнов;

· Perpendicular (Перпендикуляр) — привязка сегментов текущего сплайна к точкам других сплайнов, в которых сегменты перпендикулярны этим сплайнам;

· Tangent (Касательная) — привязка сегментов текущего сплайна к точкам других сплайнов, в которых сегменты касательны к этим сплайнам;

· Vertex (Вершины) — привязка к вершинам объектов-сеток;

· Endpoint (Концевая точка) — привязка к концам ребер каркаса или сегментов сплайна;

· Edge (Ребро) — привязка к произвольным точкам в пределах видимых и невидимых ребер каркасов;

· Midpoint (Средняя точка) — привязка к серединам ребер каркасов или сегментов сплайнов;

· Face (Грань) — привязка к произвольным точкам в пределах граней;

· Center Face (Центр грани) — привязка к центральным точкам граней.

2. Установите привязки Grid Points (Узлы сетки) и Grid Lines (Линии сетки).

Ни одна из установленных привязок не будет действовать до тех пор, пока ее не активизировали. Активизация проводится с помощью панели кнопок привязок, расположенной справа в нижней части экрана (рис. 3.2).

Рис. 3.2. Панель кнопок привязок

Для активизации привязки:

1. Щелкните LM на левой кнопке панели и, удерживая кнопку мыши, выберите инструмент двумерной привязки.

2. Сделайте активным окно проекции Тор (Верх) и увеличьте изображение. Для этого щелкните LM на кнопке Zoom (Увеличить) панели управления окнами проекций (рис. 3.3), переместите курсор в окно Тор (Верх) и, нажав LM, протяните его вверх.

Рис. 3.3. Панель управления окнами проекции

Очистите экран, если в этом есть необходимость, выбрав в меню Edit (Редактировать) команду Select All (Выделить все) и нажав клавишу <Delete> (Удалить).

3. Создайте объект "чайник". Для этого на командной панели Create (Создать) нажмите кнопку Geometry (Геометрия), в списке выберите вариант Standard Primitives (Стандартные примитивы) и нажмите кнопку Teapot (Чайник).

4. Переместите объект с помощью инструмента Move (Переместить).

Обратите внимание, что движение объекта по экрану стало дискретно. Активизированная привязка позволяет перемещать опорную точку объекта только по узлам масштабной сетки. Действия остальных кнопок активизации привязок описаны ниже:

· 3D Snap (Трехмерная привязка) — действует во всех трех измерениях;

· 2.5D Snap (Полуобъемная привязка) — включает режим привязки в текущей плоскости;

· Angle Snap (Угловая привязка) — включает режим, ограничивающий возможность поворота;

· Percent Snap (Процентная привязка) — включает режим фиксированного процентного приращения параметров, например, при масштабировании объекта;

· Spinner Snap (Привязка приращения счетчиков) — обеспечивает режим фиксированного приращения счетчиков.

Настройка координатной сетки

Для изображения линий координатной сетки используются три различных оттенка цвета. Две наиболее темные и толстые линии — это координатные оси. Они соответствуют глобальной системе координат (World). Более светлые и тонкие линии сетки называются главными, а самые светлые и тонкие — вспомогательными. Перейдем к настройке параметров сетки.

1. Выберите команду Grid and Snap Settings (Настройка сетки и привязок) в меню Customize (Специальные) и щелкните LM на корешке вкладки Ноте Grid (Исходная сетка).

2. Измените величину шага между вспомогательными линиями с помощью счетчика Grid Spacing (Шаг сетки).

По умолчанию она принимается равной 10 текущим единицам измерения.

Текущий шаг сетки отображается в строке состояний экрана (рис. 3.4).

Рис. 3.4. Текущий шаг сетки

3. Установите интервал между главными линиями в счетчике Major Lines every Nth (Главные линии каждые N).

По умолчанию главной является каждая десятая линия сетки.

4. Укажите, в каких окнах будет производиться изменение частоты сетки при изменении масштаба изображения, используя переключатель Dynamic Update (Динамическое обновление). Для этого установите переключатель в одно из двух положений Active Viewport (Активное окно) или All Viewports (Все окна).

Назначение вспомогательных объектов

Вспомогательные объекты позволяют рисовать или выполнять анимацию, но не включаются в итоговую визуализацию. В свитке Helpers (Вспомогательные объекты) командной панели Create (Создать) (рис. 3.5) представлен весь перечень типов вспомогательных объектов.

Рис. 3.5. Кнопка вспомогательных объектов, выделенная на командной панели

Применение вспомогательного объекта-сетки

Объекты-сетки применяются в качестве конструкционных плоскостей, на которых строятся геометрические модели объектов сцены. После создания их можно перемещать и поворачивать, как и другие объекты сцены.

1. Щелкните LM на кнопке Helpers (Вспомогательные объекты) командной панели Create (Создать).

2. Щелкните LM на кнопке Grid (Сетка) в свитке Object Type (Тип объекта) вспомогательных объектов командной панели Create (Создать).

Появится свиток Parameters (Параметры) объекта сетки.

3. Задайте шаг, равный 10 линиям сетки, с помощью счетчика Grid (Размер сетки) раздела Spasing (Интервал).

Этот шаг целесообразно установить равным шагу исходной координатной сетки для согласования масштабов моделей.

4. Задайте цвет, который будет иметь сетка после активизации, с помощью переключателя Active Color (Активный цвет).

Для определенности выберите Home Color (Цвет исходной сетки). Линии объекта сетки будут иметь то же цвет, что и у исходной сетки.

5. В разделе Display (Показать) установите переключатель в положение ZX Plane (Плоскость ZX).

После построения объект-сетка появится в плоскости ZX.

6. Постройте объект-сетку в окне Perspective (Перспектива). Для этого щелкните LM в окне проекции, перетащите курсор по диагонали и щелкните на точке, где будет располагаться противоположный угол сетки.

При построении следите за размером сетки в счетчиках Length (Длина), Width (Ширина) раздела Gride Size (Размер сетки).

7. Поверните сетку на угол 45° и переместите на середину окна.

Объект-сетка готов. Осталось ее активизировать для того, чтобы создаваемые объекты размещались на поверхности построенной сетки.

8. Для активизации сетки выберите в меню Views (Виды) команду Grids (Координатные сетки), а затем команду Activate Grid Object (Активизировать объект-сетку).

Активизированная сетка показана на рис. 3.6. Осталось воспользоваться построенной сеткой и создать на ней объект.

Рис. 3.6. Активизированный объект-сетка

Рис. 3.7. Использование сетки для ориентации объекта

9. Накоманднойпанели Create (Создать) нажмитекнопку Geometry (Геометрия), вспискевыберитевариант Standard Primitives (Стандартныепримитивы), нажмитекнопку Teapot (Чайник), щелкнитеуказателеммышинаобъекте-сеткеипостройтечайник. Сцена должна выглядеть примерно так же, как на рис. 3.7.

Теперь, где бы ни был построен объект, он будет ориентирован по объекту-сетке до тех пор, пока последняя активизирована.

10. Отключите активизацию обекта-сетки. Выберите в меню Views (Виды) команду Grids (Координатные сетки), а затем команду Activate Home Grid (Отключить объект-сетку).

Выравнивание обекта-сетки

Объект-сетку можно выровнять по отношению к плоскости активного окна проекции.

1. Выровняйте объект-сетку по окну Front (Вид спереди). Щелкните LM в окне и сделайте его активным.

2. Выделите объект-сетку. Активизируйте ее и выберите в меню Tools (Сервис) команду Align to View (Выровнять по окну).

Объект-сетка примет вид, как указанно на рис. 3.8.

Рис. 3.8. Выравнивание объекта по окну проекции

Выравнивание положения и ориентации по опорному объекту

При моделировании сцен почти всегда возникает необходимость выравнивания объектов, источников света, камер, ориентации одного объекта относительно другого. Ниже мы рассмотрим способы выравнивания, предоставляемые 3D Studio MAX.

1. Для знакомства с методами выравнивания вам понадобится построить несколько объектов. На командной панели Create (Создать) нажмите кнопку Geometry (Геометрия), в списке укажите вариант Standard Primitives (Стандартные примитивы) и постройте в окне Perspective (Перспектива) сферу, конус и цилиндр.

2. Выделите сферу и щелкните LM на кнопке Align (Выравнивание) панели инструментов (рис. 3.9).

Рис. 3.9. Панель инструментов выравнивания объектов

3. Назначьте в качестве опорного объекта конус. Для чего установите на него курсор и щелкните LM. Появится окно диалога Align Selection (Выравнивание выделения) (рис. 3.10).

Рис. 3.10. Диалоговое окно выравнивания объектов

Исходное положение объектов до выравнивания показано на рис. 3.11.

Рис. 3.11. Расположение объектов до выравнивания

4. В разделе Align Position (World) (Выравнивание положения (По экрану)) укажите, по каким координатам будет происходить выравнивание. Отметьте поочередно каждую из координат и посмотрите в проекции Тор (Вид сверху), как происходит перемещение выравниваемого объекта.

Рис. 3.12. Пример выравнивания объектов по центру

Указание всех трех координат X, Y и Z приведет к выравниванию объектов по центру, как показано на рис. 3.12. Опорная точка текущего объекта (Сфера) совместилась с центром опорного объекта (Конус) по всем трем координатам. Остальные параметры выравнивания означают следующее:

1. Minimum (Минимум) — ближайшая крайняя точка габаритного контейнера объекта;

2. Maximum (Максимум) — дальняя крайняя точка габаритного контейнера объекта;

3. Pivot Point (Опорная точка) — опорная точка объекта.

4. Выровняйте цилиндр относительно конуса, установите переключатель Current Object (Текущий объект) в положение Pivot Point (Опорная точка) и Target Object (Опорный объект) в положение Center (Центр).

5. Результат выравнивания приведен на рис. 3.13.

Рис. 3.13. Результат выравнивания цилиндра относительно конуса

6. Определите требования по согласованию ориентации локальной системы координат сферы относительно конуса. Для этого отключите флажки по координатам X, Y и Z и отметьте флажки по координатам X, Y и Z Axis в разделе Align Orientation (Local) (Выровнять ориентацию (Локально)).

Сравните направления локальных осей двух объектов. Цилиндр стал ориентирован так же, как и конус. Ориентация не зависит от выравнивания по положению.

Раздел Match Scale (Согласование масштабов) позволяет согласовывать масштабы по соответствующим осям координат. Согласование масштабов не обязательно ведет к совпадению размеров выравниваемых объектов.

Выравнивание нормалей

Для каркасных объектов есть возможность выравнивания таким образом, чтобы нормаль к любой грани выравниваемого объекта совместилась с указанной опорной нормалью.

1. В окне Perspective (Перспектива) щелкните RM на названии окна и в появившемся меню окна проекции щелчком LM выберите команду Wireframe (Каркас).вместо закрашенных объектов в окне появятся их каркасные изображения, состоящие из граней.

2. Выделите сферу и на панели инструментов Align (Выравнивание) активизируйте кнопку Normal Align (Выравнивание нормали).

3. Укажите выравниваемую нормаль, наведите курсор на одну из граней сферы, и, когда курсор примет форму перекрестия, щелкните LM.

Нормаль грани изобразится в виде стрелки (рис. 3.14) синего цвета.

Рис. 3.14. Нормаль назначена для грани сферы

4. Установите курсор на одной из граней конуса и щелкните LM.

Когда кнопка мыши будет отпущена, сфера переместится и повернется так, чтобы выравниваемая нормаль исходила из той же точки, что и опорная, но в противоположном направлении (рис. 3.15). Одновременно с выравниванием нормали появится окно диалога Normal Align (Выравнивание нормали).

5. Для перемещения сферы в локальной системе координат, задайте величины смещения по осям X, Y и Z группы Position Offset (Приращение положения) диалогового окна.

6. Для поворота сферы вокруг направления нормали задайте величину угла поворота в счетчике Angle (Угол) группы Rotation Offset (Приращение поворота).

Пример поворота сферы вокруг нормали на 90° приведен на рис. 3.16.

7. Чтобы исходная и опорная нормали были направлены в одну сторону, отметьте Flip Normal (Перевернуть нормаль).

Если опция Flip Normal (Перевернуть нормаль) не отмечена, то нормали будут направлены в противоположные стороны. После задания требуемых параметров щелкните по кнопке ОК.

Рис. 3.15. Выравнивание сферы по нормали

Рис. 3.16. Поворот сферы вокруг нормали

8. Вернитесь к тонированному изображению. В окне Perspective (Перспектива) щелкните RM на названии окна и в появившемся меню окна проекции щелчком LM выберите команду Smooth + Highlights (Сглаживание + Блики). Для объектов, не имеющих граней, таких как вспомогательные объекты, габаритные контейнеры атмосферных эффектов, в качестве нормалей используются оси Z локальной системы координат.

Выравнивание источников света

3D Studio MAX позволяет точно разместить отражение и блики от источников света. С этой целью программа перемещает и поворачивает выделенные источники света или выделенный исходный объект так, чтобы они были ориентированы по направлению нормали в точке центра формируемого отражения на поверхности опорного объекта.

1. Создайте источник света в окне Perspective (Перспектива). Нажмите на командной панели Create (Создать) кнопку Lights (Источники света), далее укажите Опии (Всенаправленный) и щелкните мышью в окне Perspective (Перспектива).

2. Активизируйте кнопку Place Highlight (Поместить блик) панели инструментов Align (Выравнивание).

3. Выставьте курсор на сферу, щелкните LM и перетащите курсор до появления значка нормали (рис. 3.17).

Рис. 3.17. Назначение опорной нормали

Источник света переместится и будет оставаться в направлении нормали. При этом сохраняется исходное расстояние от источника света до объекта, на котором формируется блик. Результат выравнивания источника света показан на рис. 3.18.

Рис. 3.18. Размещение блика света в направлении нормали

Выравнивание камеры

Аналогично выравниванию источника света можно выровнять и камеру относительно определенной точки на поверхности объекта. В результате плоскость окна проекции камеры оказывается параллельной выбранной грани опорного объекта.

1. В сцене окна Perspective (Перспектива) установите камеру, нажав на командной панели Create (Создать) кнопку Cameras (Камеры), а далее указав Free (Свободная).

2. Так как камера после построения уже выделена, активизируйте кнопку Align Camera (Выровнять камеру) панели инструментов Align (Выравнивание).

3. Укажите курсором на нужную грань конуса, и, когда на изображении курсора появится перекрестие, щелкните LM и слегка перетащите курсор до появления значка нормали грани в виде синей стрелки, как показано на рис. 3.19.

Рис. 3.19. Расположение нормали, задающее направление камеры

Если продолжать перетаскивать курсор, то значок нормали будет перемещаться по поверхности конуса. Камера также будет сдвигаться, выравниваясь по нормали.

4. Установив нужное положение нормали, отпустите кнопку мыши.

Камера изменила положение и ориентацию так, чтобы линия визирования была направлена навстречу выбранной нормали конуса (рис. 3.20).

Рис. 3.20. Камера установлена в направление нормали

Выравнивание локальных осей координат объекта по окну проекции

Рассмотрим возможность выравнивания локальных осей координат выделенного объекта относительно оси Z активного окна проекции.

1. Выделите сферу в окне Left (Вид слева) и активизируйте кнопку Align to View (Выравнивание по проекции) панели инструментов Align (Выравнивание).

Рис. 3.21. Изменение ориентации оси Z

Появится окно диалога Align to View (Выравнивание по проекции), и одновременно сфера будет автоматически выровнена по умолчанию относительно оси Z (рис. 3.21).

2. В появившемся окне диалога выберите поочередно переключатели Align Х (Выровнять по X) и Align Y (Выровнять по Y).

Оси Х и Y сферы поочередно будут выравниваться относительно оси Z окна. Изменения ориентации оси Z сферы показаны на рис. 3.22. Они будут происходить сразу же после установок в окне диалога.

3. Отметьте флажок Flip (Повернуть).

Рис. 3.22. Выравнивание оси Y

Выравнивание выставленной локальной оси сферы произойдет в направлении, противоположном оси Z. Для фиксации новой ориентации объекта щелкните по кнопке ОК.

Измерение расстояния между объектами

Для измерения расстояния между двумя точками сцены можно использовать вспомогательный объект типа Таре (Рулетка). Он применяется в качестве мерной ленты.

1. В свитке Object Type (Тип объекта) вспомогательных объектов командной панели щелкните на кнопке Таре (Рулетка).

2. Для измерения расстояния между двумя точками щелкните LM в первой точке окна проекции и, не отпуская кнопку мыши, перетащите курсор во вторую точку.

На экране отобразится отрезок прямой, соединяющий две точки, а в поле Length (Длина) свитка параметров появится значение его длины.

3. При необходимости задать фиксированное значение рулетки, установите флажок Specify Length (Задать длину) и в поле Length (Длина) задайте требуемую длину.

В случае фиксированного значения рулетки мерный отрезок будет иметь постоянную величину при каждом использовании рулетки.

4. Для удаления объекта-рулетки требуется удалить любой из ее концов.

В разделе World Space Angles (Углы в глобальных координатах) можно определить ориентацию рулетки относительно осей глобальной системы координат.