Win2KFAQ -> Вступление

Вступление

Автор: Алексей Шашков
Последнее дополнение: от 26/06/2002
Версия: 6.0

Версия 6.0.0 W2k FAQ. Шестая версия текста появилась на свет благодаря объединению нашего W2kFAQ c версией Владимира Суворова и Романа Клина, ведущих свой вариант на основе материалов эхоконференции fido7.ru.windows.f2000. Также выражаем благодарность Александру Шейко и Тарасу Сороке, активным авторам fido7.ru.windows.f2000 FAQ. Посмотреть последний вариант их труда, и, заодно, ознакомиться с полным списком авторов, приложивших свои руки и знания к созданию этого замечательного документа, можно на http:// www.chem.univ.kiev.ua/~adsh/win2k/. Отдельное спасибо Дмитрию Чеканову за дополнения.

Вы столкнулись с интересной проблемой и успешно её разрешили? Поделитесь с нами! Возможно, это поможет ещё кому нибудь.

Файл справки *.chm создан Hawk-EYE'ем на основании статьи WinXP FAQ с сайта http://www.3dnews.ru/.


Win2KFAQ -> Вопросы

Общая информация

(1.1) | Что такое Windows 2000? updated
(1.2) | Какой build финальный? Как точно узнать версию W2k? Как отличить пиратский релиз от настоящего? updated
(1.3) | Какие виды поставки W2k бывают?
(1.4) | Какой компьютер небходимо иметь для нормальной работы W2k?
(1.5) | Как насчёт совместимости со старым программным обеспечением?
(1.6) | А что знаменитый DLL-hell?
(1.7) | Что такое Dynamic Disk?
(1.8) | Что такое Active Directory?
(1.9) | Что такое DFS?
(1.10) | Что такое Task Manager?
(1.11) | Какие отличия в интерфейсе между W9x и W2k?
(1.12) | Можно ли с одного взгляда на экран определить, что за ОС стоит, WinME или W2k? updated
(1.13) | Можно ли из W2kPro сделать W2kServer, и зачем это надо? new
(1.14) | Где скачать последние обновления? new
(1.15) | Как сохранить информацию из реестра в прежнем формате? new

Инсталляция

(2.1) | Как поставить W2k? updated
(2.2) | Стоит ли переходить с FAT32 на NTFS? updated
(2.3) | Что вообще такое NTFS, и как она работает?
(2.4) | Что нового в файловой системе NTFS5, и в чем её отличия от NTFS4?
(2.5) | Что такое кластер?
(2.6) | Как уменьшить занимаемый объем пpоинсталиpованной Win2000? updated
(2.7) | Можно ли отконвеpтировать диск FAT32 в NTFS без потеpи данных? updated
(2.8) | Как полностью выключить SFC (System Files Protection)?
(2.9) | После уменьшения размера занимаего W2k, при установке или удалении компонентов системы слишком часто приходится менять компакт диск, то с дистрибутивом W2k, то с Service Paclk. Как этого избежать?
(2.10) | Как интегрировать Service Pack 1 в дистрибутив W2k?
(2.11) | Как интегрировать SP2 в дистрибутив W2k?
(2.12) | Что такое есть Resource Kit для W2k и где его можно взять?
(2.13) | Hужно ли устанавливать Service Pack 1 перед установкой Service Pack 2? updated
(2.14) | Как перенести уже установленный W2k на другой винт (больший по pазмеpу), с сохранением всех настроек. Hе хочется все заново пеpеустанавливать... updated
(2.15) | Какие параметры можно менять в boot.ini? updated
(2.16) | Как мне поставить Win9x при уже установленном W2k? Win9x при инсталляции затирает загрузочный сектор W2k. updated
(2.17) | Как изменить букву системного /загрузочного диска в Windows 2000? updated
(2.18) | Как переименовать папку аккаунта Администратор? updated
(2.19) | Как выбрать нужную версию ядра и HAL ещё при инсталляции?
(2.20) | Какие файлы необходимы для успешной загрузки Windows 2000? new
(2.21) | Как организовать загрузку 3 ОС, например W2k, Win9x и Linux с помощью W2k загрузчика?
(2.22) | Как сохранить загрузочный сектор в файл (bootsect.xxx)?
(2.23) | Как отформатировать первый раздел диска, не потеряв возможность загрузки W2k установленной на другом?

Твики

(3.1) | Как удалить ненужные компоненты W2k? В Add/Remove programs почти ничего нет.
(3.2) | При запуске Windows Explorer открывается папка My Documents. Как сделать так, что бы открывался корневой каталог системного диска?
(3.3) | Когда открывается директория с большим количеством файлов, находящаяся на NTFS-разделе, например, WINNT, то это делается слишком долго. Можно ускорить этот процесс?
(3.4) | Как ускорить работу интерфейса W2k?
(3.5) | Как отключить Dr. Watson, встроенный дебагер? updated
(3.6) | Какие службы можно отключить, для ускорения работы системы? updated
(3.7) | Как настроить профиль пользователя, создаваемый системой по умолчанию
(3.8) | Как в W2k менять настройки групповой политики?
(3.9) | Как сделать загрузочный диск для W2k/NT4? updated
(3.10) | Некоторые программы при старте или инсталяции жалуются, что DirectX 5.0 не установлен, хотя в W2k входит Directx 7.0.
(3.11) | Как отключить автозапуск у привода компакт-дисков?
(3.12) | По какому принципу W2k присваивает буквы дискам?
(3.13) | Как перемонтировать дисковод (A:)? Через Disk Management не получается.
(3.14) | Существуют ли аналоги autoexec.bat и config.sys под W2k?
(3.15) | Что такое случилось с консольными приложениями? Взять тот же FAR - все работает, но у него слишком большой экран. Как это вылечить?
(3.16) | Как запустить программу как сервис?
(3.17) | Как сделать, чтобы пpи остановке/запyске стиpался/создавался новый файл подкачки pagefile.sys? updated
(3.18) | Как задать пpиоpитет пpоцесса еще пpи его запyске? Чтоб не лазить постоянно для этого в task manager? updated
(3.19) | После работы с Hyper Terminal в корневой директории появляются файлы, comreads.dbg и comused.dbg. Что это такое, и как их убрать?
(3.20) | W2k при загрузке проверяет на ошибки все дисковые разделы, даже если на них установлены другие ОС. Как это отключить?
(3.21) | Как ускорить работу с памятью? updated
(3.22) | У меня пусто в "Автозапуске", но некоторые программы продолжают стартовать при входе в Windows.
(3.23) | Отключение подсистем POSIX и OS2.
(3.24) | Почему у Вас нет совета по оптимизации размера L2 кэша? updated
(3.25) | Можно ли ввести машину в состояние hibernate, или выключить из командной строки? updated
(3.26) | Правда ли что W2k всегда загружает определённый набор DLL, даже если они не используются?
(3.27) | Как сделать что бы задачи которые повисли и перестали отвечать убивались автоматически?
(3.28) | Как поменять цвет, на который меняются буквы при наведении на них мышки в Windows Explorer, при включенной функции одного клика?
(3.29) | Как добавить содержимое рабочего стола в меню Start?
(3.30) | Как отключить (запретить) Task Manager? new
(3.31) | Можно ли на ноутбуке иметь несколько настроек сетевой карты? new
(3.32) | Как заставить службы (service) запускаться в определённом порядке? new
(3.33) | Компьютер выключается очень долго. Как это ускорить? new
(3.34) | Существуют ли аналоги autoexec.bat и config.sys под W2k? new
(3.35) | После изменения прав доступа к файлам (security permissions) на NTFS хочется вернуть все к тому виду, как было после установки. Возможно ли это? new
(3.36) | Диспетчер устройств показывает не все устройства :(. Как увидеть все установленные устройства (включая даже не подключенные в данный момент)? new
(3.37) | Как отключить требование ввода пароля при загрузке W2k? new

Восстановление

(4.1) | Система не загружается, что делать?
(4.2) | Как восстановить повреждённый загрузчик W2k?
(4.3) | Пропали куда-то системные шрифты под W2k, или вообще, система начала вести себя как то странно, перестали работать некоторые программы, появились глюки, которых раньше точно не было. Как это можно исправить?
(4.4) | У меня в Far-е почему-то отказывается работать мышь. В настройках фара она включена, но работать не хочет :(.
(4.5) | Как поменять ядро системы?
(4.6) | Как в Recovery Console получить доступ в папки, отличные от \WINNT?
(4.7) | Как создать диск аварийного восстановления (Emergency Repair Disk)?
(4.8) | Можно ли восстановить информацию из зашифрованного средствами W2k файла? updated
(4.9) | Как восстановить систему, если поставлено неправильное ядро? new

Шрифты

(5.1) | Вместо русских букв в некоторых программах показываются закорючки.
(5.2) | В DOS-приложениях не переключается раскладка клавиатуры на русскую, хотя русские буквы отображаются нормально. updated
(5.3) | При загрузке имя и пароль по умолчанию вводятся русскими буквами. Как это изменить?
(5.4) | В 1С Бухгалтерия 6 вместо русских букв показываются закорючки, что можно с этим сделать?
(5.5) | Региональные настройки настроил, но всё равно, в некоторых местах (например в Photoshop) показываются закорючки. updated
(5.6) | После перезагрузки исчезает (появляется) русский язык. Как исправить? new

Сеть

(6.1) | Как управлять пользователями, которым можно заходить на компьютер?
(6.2) | Как обеспечить доступ пользователям локальной сети к моим ресурсам?
(6.3) | Как настроить модемное соединение?
(6.4) | Если пытаться звонить в Инет сразу после старта W2k, то окно звонилки открывается не сразу, а через некоторое время.
(6.5) | А как отвечать человеку, который мне шлет с Вин98 по винпопапу всякие сообщения по сети?
(6.6) | Как включить роутинг в Windows 2000 Professional?
(6.7) | Как организовать удаленное управление под W2k? Radmin v.1.1 не pаботает.
(6.8) | Как сделать, чтобы DOS-программа, печатая на LPT1, на самом деле печатала на сетевой пpинтеp [\\server_name\printer_name]?
(6.9) | Слышал, что Terminal Server имеет ограниченый срок использования (потом его нужно будет лицензировать). Правда ли это, и какой срок?
(6.10) | Имеется смешанная сеть, NetWare и NT, клиенты W2kPro и W98. Машины с W98 не могут войти на машины с W2k. updated
(6.11) | На сервере имеется две сетевые карты, каждая из них смотрит в свой сегмент локальной сети. Роутинг включен. Компьютеры из одного сегмента не видят компьютеры из другого сегмента, хотя всё пингуется.
(6.12) | Как отключить датчик наличия сетевого соединения (Media Sense)? new
(6.13) | Как полностью отключить скрытые общие ресурсы (ADMIN$, C$, D$ и т.д.)? updated
(6.14) | Как настроить роутинг между двумя подсетями на W2kPro? new
(6.15) | Компьютеры с W98 по сети открываются очень медленно. Как это ускорить? new
(6.16) | Как запретить пользователю логинится локально? new
(6.17) | Как запретить пользователю логинится по сети? new
(6.18) | Как заставить W2k принимать входящие звонки? В Win9x был Сервер удаленного доступа, а под W2k не могу найти ничего подобного. new
(6.19) | Можно ли подключиться к серверу удаленного доступа на Win9x? new

Железо

(7.1) | Машина с ATX блоком питания не выключает питание самостоятельно.
(7.2) | Как получить поддержку функций управления питанием на SMP машинах?
(7.3) | Как мне включить ACPI? Смена ядра приводит к синему экрану с надписью "Inaccessible Boot device":(. БИОС ACPI поддерживает.
(7.4) | У меня есть Iomega Zip Drive. Он не определяется автоматически, надо ли скачивать для его драйвера?
(7.5) | После перезагрузки Win2k не находит внешний модем. Что делать
(7.6) | При работе полноэкраных Direct3D и OpenGL приложений, очень низкий refresh rate, как можно это исправить?
(7.7) | Как включить в W2k поддержку режимов Ultra DMA?
(7.8) | Как добавить в W2k поддеpжку Ultra DMA66, если она отсутствует?
(7.9) | При печати на принтере (подключен через LPT) загрузка процессора 100%. Все остальное, соответственно, притормаживает. Как можно побороть?
(7.10) | Можно ли на многопроцессорных системах ставить разные процессоры?
(7.11) | Как установить поддержку двух мониторов в W2k?
(7.12) | Как поменять IRQ используемые различными устройствами? В их Properties в Devise manager чекбокс Use automatic Settings затемнён, и снять его не удаётся.
(7.13) | На моём CD-ROM нет CD-CPDIF выхода, или, по какой то причине я не могу его использовать. Можно ли мне как-нибудь получить числовой звук для CD-Audio?
(7.14) | Как заставить работать под Win2K звуковую карту на Vortex 2?
(7.15) | Ничего не получается с hackmon.inf, чего делать?
(7.16) | Можно ли заставить работать Norton Speed Disk при запущенной службе терминал-севера? Надоело каждый раз её останавливать, а потом снова запускать.
(7.17) | Как заставить под W2k работать старые сканеры HP серий II, III, 4?
(7.18) | Как поставить драйвер сканера ScanJet 5p (чип от Symbios Logic 53C416) на win2000prof?
(7.19) | Как завести под W2k старый CD рекордер? Например, CD-recorder Yamaha CDR-100 (SCSI) определяется, но никаких драйверов на него не ставится.
(7.20) | Мой 12х CD Recorder записывает диск за 15 минут, а должен за 6. А везде пишется, что запись прошла на скорости 12x, почему так происходит и что делать?
(7.21) | В спящем режиме W2k не выключает вентиляторы. new
(7.22) | Как добиться, чтобы модем брал трубку с N-ного звонка? new
(7.23) | Как заменить материнскую плату без переустановки системы? new
(7.24) | Модем не хочет звонить в пульсовом режиме new

Проблемы

(8.1) | Что то не работает, как найти причину?
(8.2) | Почему некоторые программы не инсталлируются в W2k? Запускается инсталлятор, появляется окно, в нём закрашивается индикатор до 100%, но потом всё пропадает. Процесс висит в памяти, но инсталляция не продолжается.
(8.3) | Постоянно занято 30-50% системных ресурсов, даже когда никаких программ не запущенно.
(8.4) | После установки ATM Deluxe 4.0 for NT -- Win2k не "уходит" в Hibernate и Stand by.
(8.5) | Постоянно зависает Adobe Photoshop 5.5 при вставление из клипборда или импорте клипборда при переключении из другого софта.
(8.6) | В системном логе постояно появляются сообщения об ошибках. Как с этим бороться?
(8.7) | Под W2k не хотят работать некоторые программы, требующие интенсивного обращения к CD приводу, такие как Audiograbber, CDEx, программы для записи CD-RW, некоторые DVD декодеры, и т. д..
(8.8) | Как избавиться от сообщения:
(8.9) | С некотоpых поp пpи запyске ДОС-пpиложений появляеся сообщение, что "Virtual Device Driver format in the registry is invalid. Choose 'Close' to terminate the application". Если выбрать 'Ignore', все работает. Это лечится?
(8.10) | Моя любимая программа работает только под аккаунтом администратора :( Как сделать, чтобы она работала и под аккаунтом обычного пользователя?
(8.11) | После подключения дополнительного жесткого диска W2k перестал загружаться. После ввода пароля говорит, что "Your system has no paging file, or the paging file is too small" и снова выдает окно логона. Что делать?
(8.12) | При перезагрузке повреждается реестр, что приводит к синему экрану при загрузке.
(8.13) | Как справится с тормозами при работе антивируса Касперского? new
(8.14) | Компьютер перезагружается непонятно почему. new
(8.15) | Пропал файл подкачки, W2k при загрузке каждый раз создаёт временный на 20 мегабайт. Выставление файла вручную не помогает, после загрузки его опять нет. new
(8.16) | Как сделать что бы при загрузке всегда включался NumLock? new
(8.17) | Надоело стирать Temporary Internet Files каждый раз вручную. Можно автоматизировать этот процесс? new
(8.18) | Как узнать что означает та или иная ошибка в Event Viewer? new
(8.19) | Как мне удалить файл hiberfil.sys? new
(8.20) | Можно ли под W2k услышать звук в старой игрушке для DOS? new
(8.21) | Утерян пароль администратора. Что делать? Доступ к компьютеру полный. new
(8.22) | Почему локальные пользователи (в т.ч. Гости!) могут изменять локальную политику безопасности? Они могут даже запретить администратору вход в систему! new

Copyright (c) 1997-2002 3DNews
При цитировании документа ссылка на сайт с указанием автора обязательна. Полное заимствование документа является нарушением российского и международного законодательства и возможно только с согласия редакции 3DNews.


Win2KFAQ -> Общая информация

Общая информация
(1.1) | Что такое Windows 2000?
(1.2) | Какой build финальный? Как точно узнать версию W2k? Как отличить пиратский релиз от настоящего?
(1.3) | Какие виды поставки W2k бывают?
(1.4) | Какой компьютер небходимо иметь для нормальной работы W2k?
(1.5) | Как насчёт совместимости со старым программным обеспечением?
(1.6) | А что знаменитый DLL-hell?
(1.7) | Что такое Dynamic Disk?
(1.8) | Что такое Active Directory?
(1.9) | Что такое DFS?
(1.10) | Что такое Task Manager?
(1.11) | Какие отличия в интерфейсе между W9x и W2k?
(1.12) | Можно ли с одного взгляда на экран определить, что за ОС стоит, WinME или W2k?
(1.13) | Можно ли из W2kPro сделать W2kServer, и зачем это надо?
(1.14) | Где скачать последние обновления?
(1.15) | Как сохранить информацию из реестра в прежнем формате?
(1.1) Что такое Windows 2000?
Windows 2000 ака W2k - новая операционная система (ОС) Microsoft, основанная на технологии Windows NT, что отраженно в первоначальном названии проекта W2k - Windows NT 5.0. NT ака New Technology была создана группой разработчиков под руководством Дэйва Катлера, ранее работавшего в DEC над проектом VMS (кстати, довольно часто используемая аббревиатура WNT получается из VMS сдвигом букв V, M, S по алфавиту на одну: V->W, M->N, S->T). Дэйв Катлер пришёл в Microsoft в 1988 году специально для работы над проектом NT. NT, в отличии от остальных OC Microsoft, в некотором смысле проект одного человека, эта линейка ОС наиболее законченная и логичная из всего, что они выпускают.

Windows 2000 - полностью 32-разрядная ОС с приоритетной многозадачностью и улучшенной реализацией работы с памятью. В основе проекта W2k лежат те же принципы, которые когда-то обеспечили успех NT:

  1. Совместимость (Compatibility). Система имеет привычный интерфейс ОС семейства Windows, поддержку файловых систем NTFS5, NTFS4, FAT16 и FAT32. Большинство приложений, написанных под MSDOS, W9x, NT4, а также некоторые программы под OS/2 запускаются и функционируют без проблем. При проектировании NT учитывалась возможность работы системы в различных сетевых средах, поэтому в поставку входят средства для работы в Unix- и Novell-сетях.
  2. Переносимость (Portability). Система работает на различных процессорах семейства x86 производства Intel и AMD. Благодаря структуре ОС возможна реализация поддержки процессоров других архитектур, но это потребует некоторых усилий.
  3. Масштабируемость (Scalability). В W2k реализована поддержка технологий SMP и COW (Cluster Of Workstations). Количество процессоров при использовании SMP может достигать 32 (64 и более, при использовании ядра и HAL-а, написанного производителем компьютера).
  4. Система безопасности (Security) полностью удовлетворяет спецификации C2 по терминологии АНБ США. Правда, для полной поддержки потребуется оборудование, которое также удовлетворяет этой спецификации.
  5. Распределённая обработка (Distributed processing). W2k имеет встроенные в систему сетевые средства, что обеспечивает возможность связи с различными типами компьютеров-хостов благодаря наличию разнообразных транспортных протоколов и технологии "клиент-сервер".
  6. Надёжность и отказоустойчивость (Reliability and robustness). Архитектура ОС защищает приложения от повреждения друг другом и самой операционной системой. При этом используется отказоустойчивая структурированная обработка особых ситуаций на всех архитектурных уровнях, которая включает восстанавливаемую файловую систему NTFS и обеспечивает защиту с помощью встроенной системы безопасности и усовершенствованных методов управления памятью.
  7. Локализация (Localization). Система предоставляет возможности для работы во многих странах мира на национальных языках, что достигается применением стандарта ISO Unicode.
  8. Расширяемость (Extensibility). Благодаря модульному построению системы становится возможно добавление новых модулей на различные архитектурные уровни ОС.

наверх

(1.2) Какой build финальный? Как точно узнать версию W2k? Как отличить пиратский релиз от настоящего?

Финальный build - 2195. Вообще, существует несколько версий: 120-дневная (лимитированная) и нелимитированная. Отличить одну от другой несложно, достачно в Start -> Run набрать "winver". Если в открывшемся окошке Вы не увидите фраз типа "Evaluation copy, expires...", значит у вас нелимитированная версия. Более точно версию W2k можно определить по версии её ядра. Для этого достаточно посмотреть версию одного из компонентов ядра - "ntoskrnl.exe". В его Properties есть закладка Version, в которой можно увидеть что-нибудь вроде "File version 5.0.2195.1", где 5.0 - версия NT, 2195 - номер build-а, а 1 - версия build-а.

Отличить пиратский релиз можно по нескольким признакам. Во-первых, у пиратской поделки обычно отсутствует осмысленый Readme. В оригинале должны быть два файла, "Read1st.txt" и "Readme.doc", в которых описаны новые возможности системы, совместимость с железом и софтом. Во-вторых, в оригинале есть директория Valueadd, в которой содержатся дополнительные программы от Microsoft и сторонних производителей и директория Discover, в которой лежат файлы для программы Discover Windows 2000. Конечно, все эти признаки не дают 100% гарантии того, что Ваш дистрибутив индентичен тому, что выпускает Microsoft, но некоторую уверенность получить можно.

наверх

(1.3) Какие виды поставки W2k бывают?
Всего их четыре, Windows 2000 Professional, Windows 2000 Server, Windows 2000 Advanced Server и Windows 2000 DataCenter Server. Отличаются они друг от друга, во-первых, количеством служб и программ входящих в поставку, во-вторых, степенью поддержки аппаратного обеспечения. Например, W2k Pro не держит больше 2 процессоров, W2k Server держит уже 4 процессора, W2k AdvServer - 8 процессоров, а W2k DataCenter - 64. Кроме этого, они сильно различаются по цене. Для домашних пользователей, наиболее интересна W2k Pro, так как функции которые встроены в Server-а всех сортов, и, тем более в DataCenter не имеют почти никакого применения дома и будут только нещадно пожирать ресурсы.

наверх

(1.4) Какой компьютер небходимо иметь для нормальной работы W2k?

Как и в Unix, в NT наиболее критичным параметром является размер оперативной памяти. Можно, конечно, поставить W2kPro и на 32МБ, но для того, чтобы действительно нормально работать надо как минимум 64МБ, а лучше ещё больше. Со 128-ю мегами система будет работать очень приятно, а с 256МБ W2kPro заработает быстрее, чем любая W9x когда-либо сможет на любом количестве памяти. Кроме этого, для полной инсталяции W2kPro требуется не меньше 650 Мб свободного дискового пространства. На 32-х мегах и FAT32 W2kPro может работать, хотя и с большими тормозами. Правда уже есть живые примеры такой работы, когда секретарша пишет документы в Office 2000, получает почту, заходит в Интернет, и не сильно страдает при этом.

Для W2kServer требования гораздо выше. Минимальный процессор необходимый для успешной инсталяции остался таким же, не хуже чем Pentium133 Mhz, но свободного места на жестком диске надо не менее 1024 Мб, причем это требование может изменяться в большую сторону в зависимости от числа устанавливаемых компонент, типа файловой системы, а также типа инсталляции. Минимальный объем памяти - 64 Мб, рекомендуемый - 256 Мб. Но даже этого количества может не хватить дял нормальной работы системы, при большой нагрузке.

наверх

(1.5) Как насчёт совместимости со старым программным обеспечением?
W2k работает с большинством программ для W9x, кроме тех, которые используют слишком уж специфические функции OC, например, антивирусы. Старые программы под Windows 95 можно попробовать обмануть с помощью утилитки Application Compatibility, которая находится на СD с дистрибутивом в директории Support, но срабатывает это не всегда. DOS из NT исключён полностью в целях повышения безопасности и стабильности системы, его роль играет Console (запускается с помощью "cmd.exe"). Досовский Quake или Doom работать будет, но так как требует прямой работы с железом, то звук работать не будет (хотя можно достать утилитку, которая это фиксит, правда она не бесплатная). Однако, Norton Commander, Dos Navigator, Norton Disk Doctor (для DOS) и т.д. будут работать без проблем, до тех пор пока не будут пытаться напрямую обратится к железу.

наверх

(1.6) А что знаменитый DLL-hell?
Основная беда W9x, известная как DLL-hell, это когда приложение могло свободно переписывать файлы DLL, расположенные в системных директориях Windows, теперь вроде бы решена в W2k. Теперь приложениям просто запрещено менять какие бы то ни было файлы DLL в этих директориях. Если программист имеет настолько кривые руки, или слабо представляет себе правила корректного программирования под Windows, его приложение скорее всего просто не будет работать под W2k. И правильно. Те из старых приложений для W9x, которые написаны нормально, под W2k работают.

наверх

(1.7) Что такое Dynamic Disk?

Это физический диск, на котором могут быть созданы динамические разделы. Такой диск может быть доступен только из W2k. Динамические разделы могут быть следующих видов:

  1. Простые (simple). Простые разделы практически ни чем не отличаются от тех, к которым мы привыкли.
  2. Составные (spanned). Состоят из нескольких динамических дисков, которые представлены как один диск. Данные пишутся и читаются последовательно.
  3. Чередующиеся (stripped). Несколько динамических дисков, которые представленны как один диск. Данные пишутся и аются одновременно на несколько дисков. Это, теоретически, должно обеспечивать вдвое большую скорость на дисковых операциях. На практике, прирост хотя и значительный, но меньше, чем в два раза. Мы бы рекомендовали использовать этот режим только в том случае, если уже имеются два диска. В противном случае, гораздо выгоднее купить один винчестер, вдвое большего объёма, с отличными скоростными характеристиками (например, IBM DJNA Janus или IBM DPTA Pluto), чем два маленьких и более медленных, в расчёте на то, что они будут много быстрее. Конечно, если взять два IBM и объединить их в Stripped Volume, то они будут быстрее, чем один. Однако системный раздел не может быть Stripped Volume. В этом случае разумнее приобрести аппаратный IDE-RAID контроллер, например, Promise FastTrack66, который обеспечивает возможность работы с RAID даже из под ДОС; таким образом можно сделать системный раздел чередующимся.
  4. Зеркальные (mirrored). Эти разделы состоят из двух физических дисков. Данные записываемые на один из дисков автоматически дублируются на другом. Это не даёт никаких преимуществ в плане скорости, но зато обеспечивает вдвое большую степень надёжности сохранности данных.
  5. RAID5. Состоит из трёх, или более дисков. Представляет из себя stripped volume с контролём ошибок. То есть, данные пишутся на два диска, в два блока, а на третий диск, и в третий блок записывается ECC, код коррекции ошибок, с помощью которого, по информации любого из блоков можно востановить содержимое второго блока. Причём код ECC записыватеся попеременно, на каждый из входящих в массив дисков. Эта технология позволяет более экономно использовать дисковое пространство, чем mirrored volumes, но, работает медленее. Любой из этих разделов может быть отформатирован как под FAT32, так и под NTFS. Управление Dynamic disk осуществляется через раздел Disk Management окна Computer Management.

Примечание: Все эти разделы, кроме simple можно создавать только на динамических дисках.

Обычный диск может быть сконвертирован в динамический, из окна Disk Management, однако обратный процесс (сконвертировать динамический диск в простой) не всегда возможен. Например, если диск с самого начала создавался как динамический, то на нём отсуствует привычная таблица разделов, и что бы создать её, его придётся заново разбивать с помощью fdick и форматировать.
Кроме этого, если удалить на динамическом диске несколько партиций, то свободное место не объединяется и новая партиция, равная по размеру удаленным, будет состоят из нескольких мелких партиций объединненных в volume set под одной буквой.

наверх

(1.8) Что такое Active Directory?

Active Directory - это новое средство управления пользователями и сетевыми ресурсами. Оно призвано сильно облегчить жизнь администраторам больших сетей на базе W2k и вокруг него строится вся система управления сетью и её безопасности. Для установки Active Directory необходимо иметь W2k Server. W2kPro может работать в среде Active Directory, но не может создавать её. Active Directory строится на следующих принципах:

  1. Единая регистрация в сети. Благодаря технологии IntelliMirror, можно подойти к любому компьютеру в офисе, ввести свой пароль и перед Вами будет ваш рабочий стол, ваши документы, и ваши настройки.
  2. Безопасность информации. В службу Active Directorу встроены средства идентификации пользователя. Для каждого объекта в сети можно централизировано выставлять права доступа, в зависмости от групп и конкретных пользователей. Благодаря системе безопасности Kerberos, можно осуществлять защищённую связь даже по открытым сетям, таким как Интернет. При этом данные передаваемые по сети шифруются, а пароли не передаются и не хранятся на клиентских машинах. Система безопасности Kerberos (называется по имени мифического трёхголового пса, который, согласно греческой мифологии, охранял адские врата), известна довольно давно, но в ОС от Microsoft она используется впервые. Если не вдаваться в подробности, то работает эта система так:
    • Клиент посылает запрос серверу аутентификации на разрешения доступа к нужной информации.
    • Сервер проверяет права клиента и отсылает ему разрешение на получение требуемой информации, зашифрованое с помощью известного клиенту ключа и заодно отсылает временый ключ шифрования. С помощью этого ключа шифруется вся передаваемая информация, причём время жизни ключа ограничено, поэтому сервер аутентификации время от времени присылает новый ключ (естественно, новый ключ зашифрован с помощью текущего ключа), который неизвестен никому, кроме сервера и клиента. Регулярная смена ключей шифрования сильно затрудняет жизнь злоумышленикам, охотящимся за Вашими данными.

    Однако, как мы все помним, в греческом мифе Kerberos не смог противостоять могучему Гераклу. Так и в нашем случае, несмотря на все свои преимущества, система безопасности Kerberos не может противостоять всем видам атак. Например, можно засыпать приложение ложными запросами, так называемая атака "Deny of service", что может привести к тому, что приложение не будет использовать протокол Kerberos.

  3. Централизованное управление. При использовании службы Active Directory у администратора отпадает необходимость вручную конфигурировать каждую машину, если, к примеру, необходимо поменять права доступа к какому-либо одному объекту или установить новый сетевой принтер. Такие изменения можно производить сразу для всей сети.
  4. Гибкий интерфейс. Структуры каталогов меняются быстро и легко. Например, можно создать каталог своей фирмы, выделить в отдельные подкаталоги бугалтерию, отделы маркетинга, секретариат (или что там ещё), и представить всё это в виде древовидной структуры. Или, например, создать несколько деревьев, представляющих различные офисы в разных зданиях или регионах и с легкостью задать связь и права доступа между ними. Подключить сетевой принтер к директории бугалтеров одним движением мышки. (При этом драйвера поставятся на их компьютеры автоматически). Или мышью перетащить весь бугалтерский отдел с одного сервера на другой, со всеми их правами, папками и документами.
  5. Интеграция с DNS. Благодаря тесной интеграции с DNS, в Active Directory в локальной сети используются те же имена ресурсов, что и в Интернет, что приводит к меньшей путанице, и способствует более тесному взаимодейсвию локальной и глобальной сети.
  6. Масштабируемость. Несколько доменов Active Directory могут объеденены вместе под одним управлением.
  7. Простота поиска. В домене Active Directory различные объекты можно находить по самым различным признакам, таким как имя пользователя или компьютера, адрес электронной почты пользователя и т.д.

наверх

(1.9) Что такое DFS?

Distributed File System - один из инструментов Active Directory. Он позволяет создавать сетевые ресурсы, в которые могут входить множество файловых систем на различных машинах. Для пользователя Active Directory это абсолютно прозрачно и не имеет никакого значения, где и на каких машинах физически расположены те файлы, с которыми он работает - для него они все лежат в одном месте. Кроме этого, при использовании DFS и Active Directory упрощается управление такими ресурсами. Оно централизовано, можно просто и безболезнено добавлять новые ресурсы или удалять старые, менять физическое месторасположение файлов, входящих в DFS и т.д.

наверх

(1.10) Что такое Task Manager?

Task Manager - это один из самых мощных и удобных инструментов в NT, предназначенных для управления процессами. Вызывается он либо Ctrl+Shift+Esc, либо выбором в меню, появляющимся после нажатия правой кнопкой на Taskbar-е. Можно его выбрать и после Ctrl+Alt+Del.

Task manager состоит из трёх закладок - Performance, Processes, Applications. Начнём с Performance. На этой закладке показывается информация о загрузке процессора(ов) в реальном времени, показывается загрузка физической памяти, причём показано сколько занято/свободно оперативной памяти, и сколько занято системного Swap-а. Кроме этого, там же даётся другая дополнительная информация, например, Threads и Processes - количество нитей и процессов, исполняемых сейчас на машине, Peak - пиковый размер Swap-а в течении сессии, Nonpaged - количество памяти, отведённое под ядро. Эта информация может использоваться, когда надо будет ответить на вопрос, какой фактор в системе является "бутылочным горлышком", замедляющим работу (хотя для этих целей лучше использовать Performance Monitor).

Вторая закладка, Processes, содержит список процессов, активных в данный момент. Для каждого процесса можно узнать некоторую дополнительную информацию, как то: PID (Process ID), количество используемой оперативной памяти, количество нитей, сгенерированных процессом и многое другое. Добавить/удалить показываемые параметры можно через View -> Select Columns. Кроме этого, с любым из этих процессов можно произвести вполне определённые действия. Для этого надо просто нажать на нём правой кнопкой мыши, появится контекстное меню, через которое можно закончить, "убить" процесс, End Process, можно убить сам процесс, и все остальные, которые он "породил", End Process Tree. Можно выставить приоритет процессу, от высшего RealTime до самого низкого, Low. Если на машине установленно два процессора и многопроцессорное ядро, то в этом меню появляется ещё один пункт, Set Affinity, который позволяет перевести процесс на другой процесор, Cpu 0, Cpu1, и так далее до Cpu31.

Последняя закладка Task Manager - Applications, позволяет просмотреть список работающих приложений, и "убить" любое из них. Task Manager позволяет не только "убивать" приложения, он может также запускать новые приложения. File -> New task (Run..). Иногда это бывает очень полезно. Например, если по какой либо причине зависнет интерфейс пользователя, то его можно с лёгкостью "убить" (процесс explorer.exe), а после стартовать заново. Причём, это не обязательно должен быть explorer.exe. Можно, к примеру, запустить progman.exe, и получить интерфейс подобный интерфейсу W3.1, или же любой из внешних интерфейсов, которые в изобилии можно найти на просторах интернета.

наверх

(1.11) Какие отличия в интерфейсе между W9x и W2k?

В сумме, интерфейс W2k подобен интерфейсу Windows 98 с установленным IE 5.0. Однако некоторые детали мы всё-таки отметим.

Первое, что бросается в глаза, это изменившееся цветовая гамма, на наш взгляд в лучшую сторону. Теперь она напоминает одну из схем, используемых в десктопе KDE для Linux. Ещё одной заметной деталью является тень под курсором мыши, которая снимается/выставляется в Control Panel -> Mouse -> Pointers, галочкой на Enable pointer shadow. Кроме этого, добавлен новый эффект при появлении менюшек, теперь они постепенно проявляются из воздуха. Управляется из Properties Desktop-а, на закладке Effects галочкой Use transition effects for menu and tooltips.

В Start Menu введена функция знакомая нам по Office 2000, когда при открытии показываются только наиболее часто употребляемые пункты, остальные открываются если нажать стрелочку вниз. Управлять этим эффектом можно в Properties Taskbar-а, в закладке General галочкой Use Personalized Menus (аналогично, в IE5 данная опция отключается в Tools -> Internet Options -> Advanced -> Enable Personalized Favorites Menu). В Desktop Properties есть ещё несколько пунктов в том числе и Hide keyboard navigation indicators until I use the Alt key. Если он выбран, то убирается подчёркивание под буквами, которые означают Keyboard shortcut в программах Windows, до тех пор пока не нажат Alt.

На второй закладке Taskbar Properties, Advanced, находится окошко Start Menu Settings, которое позволяет добавить/удалить строки входящие в Start Menu и расширить некоторые пункты. Например, если отметить галочкой Expand Control Panel, то при наведении курсора мыши на Control Panel в Start Menu от него вправо откроется ещё одна менюшка, в которой будут все элементы входящие в Control Panel. Полезной функцией на этой закладке является кнопка Re-sort. W2k, по умолчанию, ставит папки с последними инсталированными программами в самом низу Start Menu, таким образом некоторые папки могут находиться ниже линков на файлы. Re-sort устраняет эту несправедливость и расставляет все папки сверху вниз по алфавиту. Впрочем, этого же эффекта можно добиться нажав правую кнопку мыши в Start Menu -> Programs, и выбрав Sort by name. Кроме этого, правой кнопкой можно "перетащить" (drag and drop) оттуда любые элементы в любое место.

Ещё одним отличием, часто подводящим людей ранее работавших с NT и W9x, как ни странно, является широкое применение Checkbox-ов. Особенно тех, которые представляют из себя просто квадратик на белом фоне. Так что если вы обнаружите, что не можете чего-то сделать, то просмотрите ещё раз все окна, возможно Вы просто не обратили внимания на такой Checkbox.

Дополнительно можно отметить проявившее меню Favorites в Regedit. С его помощью можно запоминать Ваше местоположение в реестре и, после, возвращаться к нему одним нажатием клавиши.

наверх

(1.12) Можно ли с одного взгляда на экран определить, что за ОС стоит, WinME или W2k?
Можно, если включен индикатор переключателя клавиатуры. В WinME (как и во всех W9x) на нём одна маленькая, одна большая буква (En, или Ru), в W2k (как и во всех NT) обе буквы большие (EN или RU).

наверх

(1.13) Можно ли из W2kPro сделать W2kServer, и зачем это надо?
Можно. Хотя и нельзя :-) Для этого служит программка под названием NTSwitch. Всё что она делает, это сохраняет копию вашего реестра, редактирует его, и восстанавливает его обратно. Благодаря тому, что различные версии микрософтовских ОС не имеют принципиальных отличий (кроме набора программного обеспечения, идущего с системой), этого достаточно для того что бы «обмануть» систему. В результате мы избавляемся от ограничений по железу, получаем возможность устанавливать серверный софт на W2kPro, и убираем ограничение на 10 одновременных сетевых подключений. Минусом этого решения является то, что никто не сможет вам гарантировать что переделанная таким образом система будет нормально работать. С другой стороны, эта же программка позволяет вернуть всё обратно, с Server на Professional (если вы не удалили бакап старого реестра). Взять эту программку можно здесь: http://www.3dnews.ru/documents/1143/ntswitch.zip. Она работает под NT, W2k. Сработает она и под XP, превратив её в что то непонятное, вроде CodenameWhistler Server но работа XP (или уже не ХР) после такой «трансформации» оставляет желать много лучшего.

наверх

(1.14) Где скачать последние обновления?

Можно воспользоваться встроенным в W2k Windows Update. Но это не всегда удобно, ведь сохранить полученные таким образом обновление совсем не просто. Кроме этого, есть информация что Microsoft собирается проверять номера лицензий у пользователей пользующихся Windows Update. Если вам не нравится качать обновления каждый раз заново, или вы не хотите что бы кто-либо проверял вашу лицензию, можете обратиться по этому адресу, и скачать обновления в виде отдельного файла: http://www.bugtrack.ru/club/boroda/.

наверх

(1.15) Как сохранить информацию из реестра в прежнем формате?
По умолчанию W2k сохраняет информацию из реестра в формате Unicode. Чтобы сохранить информацию в старом формате (ANSI), при экспорте в Редакторе реестра нужно указать тип файла "Файлы реестра Win95/NT (REGEDIT4)". При экcпорте из командной строки вместо ключа -e нужно использовать ключ -ea.

наверх


Win2KFAQ -> Инсталляция

Инсталляция

(2.1) | Как поставить W2k?
(2.2) | Стоит ли переходить с FAT32 на NTFS?
(2.3) | Что вообще такое NTFS, и как она работает?
(2.4) | Что нового в файловой системе NTFS5, и в чем её отличия от NTFS4?
(2.5) | Что такое кластер?
(2.6) | Как уменьшить занимаемый объем пpоинсталиpованной Win2000?
(2.7) | Можно ли отконвеpтировать диск FAT32 в NTFS без потеpи данных?
(2.8) | Как полностью выключить SFC (System Files Protection)?
(2.9) | После уменьшения размера занимаего W2k, при установке или удалении компонентов системы слишком часто приходится менять компакт диск, то с дистрибутивом W2k, то с Service Paclk. Как этого избежать?
(2.10) | Как интегрировать Service Pack 1 в дистрибутив W2k?
(2.11) | Как интегрировать SP2 в дистрибутив W2k?
(2.12) | Что такое есть Resource Kit для W2k и где его можно взять?
(2.13) | Hужно ли устанавливать Service Pack 1 перед установкой Service Pack 2?
(2.14) | Как перенести уже установленный W2k на другой винт (больший по pазмеpу), с сохранением всех настроек. Hе хочется все заново пеpеустанавливать...
(2.15) | Какие параметры можно менять в boot.ini?
(2.16) | Как мне поставить Win9x при уже установленном W2k? Win9x при инсталляции затирает загрузочный сектор W2k.
(2.17) | Как изменить букву системного /загрузочного диска в Windows 2000?
(2.18) | Как переименовать папку аккаунта Администратор?
(2.19) | Как выбрать нужную версию ядра и HAL ещё при инсталляции?
(2.20) | Какие файлы необходимы для успешной загрузки Windows 2000?
(2.21) | Как организовать загрузку 3 ОС, например W2k, Win9x и Linux с помощью W2k загрузчика?
(2.22) | Как сохранить загрузочный сектор в файл (bootsect.xxx)?
(2.23) | Как отформатировать первый раздел диска, не потеряв возможность загрузки W2k установленной на другом?
(2.1) Как поставить W2k?
Есть несколько способов. Наиболее правильным будет запустить инсталляцию с CD-ROM, для чего в BIOS-e параметр "Boot sequence" установить равным CD-ROM, вставить CD и перезагрузиться. После старта компьютера запустится программа установки. Дальше - просто следовать инструкциям. Если компьютер на хочет грузиться с CD-ROM, не смотря на правильный диск и правильные настройки в BIOS, попробуйте выставить в BIOS авто определение IDE устройства на том контролёре и канале, где установлен CD-ROM.

Если загрузиться с компакт диска не получается, то можно воспользоваться утилиткой "makeboot.exe" из директории BOOTDISK, которая создаст четыре бутовых дискеты, загружаясь с которых, вы окажетесь всё в той же программе инсталляции.

Если по каким то причинам ни один из вышеизложенных способов не подходит, можно загрузиться с DOS-овской системной дискеты с драйвером CD-ROM и запустить программу "winnt.exe" в директории i386 на диске с дистрибутивом.

Примечание: если Ваш винчестер подключен к внешнему контроллеру (SCSI или IDE), то не забудьте скачать новый W2k-драйвер для него и скинуть его на дискету. Он понадобится, если программа инсталляции не сможет правильно определить и установить устройство.

И, наконец, можно из под W9x или NT4 запустить программу "winnt32.exe", и апгрейднуть систему на W2k. Делает она это очень корректно и перед перезагрузкой выдаёт список программ и драйверов несовместимых с W2k. Однако, последний способ не является самым оптимальным. Несмотря на все усилия, W2k не в состоянии правильно определить несовместимые программы и драйвера во всех случаях. Поэтому во избежание проблем, я бы рекомендовал поставить систему заново.

Есть ещё более радикальный метод решения проблем с совместимостью. При инсталляции поверх существующей ОС, у вас будет возможность выбора ОС (Dual boot).

Примечание: Не смотря на принципиальную возможность установки W2k и W9х на один и тот же раздел, я бы не рекомендовал этого делать. Дело в том, что даже если поставить их в разные дирректории, они всё равно будут делить между собой директорию Program Files. Что может привести к проблемам. Если всё таки решитесь, о учтите, что после установки W2k как отдельной ОС на тот же раздел что и W9x, будет невозможна нормальная работа Outlook Express и Internet Explorer в Windows 9x, т.к. W2k заменит последние. Эту проблему можно решить, путём копирования некоторых DLL из WinNT\System32 в Windows\System. Для определения нужных библиотек можно воспользоваться программой ShowDep (http://www.showdep.com/) или аналогичные сведения показывает Outlook Express в окне "О программе". Кроме этого, многие программы придётся устанавливать по два раза, раз для W2k, и раз для W9x. Иногда, можно и в один и тот же каталог, например Office 2000 уже при установке способен понять, что он уже раз стоит, и в итоге устанавливает всего около 18 мег.

наверх

(2.2) Стоит ли переходить с FAT32 на NTFS?
Это зависит от того что за компьютер, как и для чего используется. Невозможно дать рекомендацию подходящую для всех пользователей и на все случаи жизни. Поэтому я просто перечислю основные достоинства и недостатки той и другой файловой системы, а дальше решайте сами.

Из основных недостатков NTFS, можно отметить:

  • Недоступность разделов отформатированных под NTFS из под Win9x и DOS.
  • Из за дополнительных сервисов загружаемых для поддержки NTFS и всех её возможностей, требуется больше оперативной памяти, по сравнению с FAT32.
  • На небольших (относительно) разделах с не очень большим количеством файлов NTFS работает медленнее чем FAT32.

К основным достоинствам NTFS относятся:

  • Надёжность. Это свойство можно описать одним ёмким словом: undestructable. На полном серьёзе, вышибить NTFS чрезвычайно сложно, хоть и возможно. Для опыта запускалась куча различных приложений, оптимизаторы диска, и в самые неподходящие моменты жалась кнопка reset. Повторение этого садизма добрый десяток раз никакого впечатления на систему не произвело, она продолжала работать без ошибок.
  • Поддержка шифрования на уровне файловой системы. Если планируется использовать эту функцию, то установите Windows 2000 strong security pack, с помощью которого можно получить 128 битное шифрование Найти его можно по адресу http://www.microsoft.com/windows2000/downloads/recommended/encryption/default.asp
  • Поддержка сжатия на уровне файловой системы.
  • Поддержка разграничения прав доступа к на уровне файловой системы.
  • На больших разделах с большим количеством файлов NTFS работает быстрее чем FAT32. Причём чем больше раздел и чем больше файлов, тем больше выигрыш.

Таким образом, форматировать системный раздел под FAT32 имеет смысл только в том случае, если обязательно требуется доступ к разделу из под Win9x или DOS, либо если компьютер слишком слабый. Например, если у вас 32МБ RAM, и вы решили поставить себе W2k, то вам однозначно нельзя ставить себе NTFS. Нет никакого смысла форматировать системный раздел под FAT32 если планируется использовать компьютер для серьёзной работы.

наверх

(2.3) Что вообще такое NTFS, и как она работает?
NTFS выросла из файловой системы HPFS, разрабатываемой совместно IBM и Microsoft для проекта OS/2. Она начала использоваться вместе с Windows NT 3.1 в 1993 году. Windows NT 3.1 должна была составить конкуренцию серверам на базе NetWare и Unix, поэтому NTFS вобрала в себя все тогдашние технологические достижения. Вот основные из них:
  1. Работа с большими дисками. NTFS имеет размер кластера 512 байт, что в принципе оптимально, но его можно менять до 64К. Более важно то, что NTFS способна теоретически работать с томами размером в 16,777,216 террабайт. Теоретически, потому что таких жестких дисков пока просто не существует, и появятся они весьма не скоро.
  2. Устойчивость. NTFS содержит две копии аналога FAT, которые называются MFT (Master File Table). В отличие от FAT MSDOS, MFT больше напоминает таблицу базы данных. Если оригинал MFT повреждён в случае аппаратной ошибки (например, появления bad-сектора), то система при следующей загрузке использует копию MFT, и автоматически создаёт новый оригинал, уже с учётом повреждений. Но это не самое главное. Главное, что NTFS использует систему транзакций при записи файлов на диск. Эта система пришла из СУБД, где защита целостности данных - жизненно важное дело. Уже это говорит о её эффективности. В упрощённом виде она работает так:
  • Драйвер ввода/вывода NTFS инициирует процесс записи, одновременно сообщая сервису Log File Service вести лог всего происходящего.
  • Данные пишутся в кэш, под управлением сервиса Cache Manager.
  • Cache Manager посылает данные Virtual Memory Manager-у (менеджеру виртуальной памяти), для записи на диск в фоновом режиме.
  • Virtual Memory Manager посылает данные драйверу диска, пропустив их через Fault Tolerant Driver (если у вас массив дисков RAID).
  • Драйвер диска шлёт их контроллеру, который уже пишет их либо в кэш, либо прямо на диск.
  • Если эта операция проходит без ошибок, запись лога удаляется.
  • Если происходит сбой, запись лога остается в таблице транзакций, и при следующем доступе к диску Log File Service обнаруживает эту запись, и просто восстанавливает всё как было до этой операции.
Такая система гарантирует абсолютную сохранность данных в случае копирования, перемещения и удаления файлов или директорий. При внесении изменений в файл, вы теряете те изменения, которые находились в момент сбоя в памяти или в кэше контроллера, и не успели записаться на диск.
  3. Защищенность. NTFS рассматривает файлы, как объекты. Каждый файловый объект обладает свойствами, такими как его имя, дата создания, дата последнего обновления, архивный статус, и дескриптор безопасности. Файловый объект также содержит набор методов, которые позволяют с ним работать, такие как open, close, read и write. Пользователи, включая сетевых, для обращения к файлу вызывают эти методы, а Security Reference Monitor определяет, имеет ли пользователь необходимые права для вызова какого-либо из этих методов. Кроме этого, файлы можно шифровать. Правда, с шифрованием стоит быть осторожнее. Если у Вас рухнет система, то с очень высокой долей вероятности Вы не сможете прочитать зашифрованые файлы.
  4. Компрессия данных. NTFS позволяет компрессировать отдельные каталоги и файлы, в отличие от DriveSpace, который позволял сжимать только диски целиком. Это очень удобно, для экономии пространства на диске, например можно сжимать "на лету" большие графические файлы формата BMP, или текстовые файлы, причём для пользователя всё это будет прозрачно.
  5. Поддержка формата ISO Unicode. Формат Unicode использует 16bit для кодировки каждого символа, в отличие от ASCII, который использовал 8bit, или ещё хуже - 7bit. Для простого пользователя это означает то, что теперь он может называть файлы на любом языке, хоть на китайском - система это будет поддерживать, не требуя изменить кодовую страницу, как это делал DOS и W9x.

наверх

(2.4) Что нового в файловой системе NTFS5, и в чем её отличия от NTFS4?
Самое главное, за что ругали NT4, и в чём она уступала NetWare, это за отсутствие квотирования. Квотирование - это ограничение максимального объёма дискового пространства для пользователя, которое он сможет использовать. Зачем это нужно? Ну, на компьютерах, работающих в больших сетях, в фирмах и организациях и без вопросов понятно зачем, ведь жесткие диски не резиновые. А на домашнем компьютере, можно например, выделить пользователю "жена" или "младший брат" не более 50МБ на винчестере, чтобы они не захламляли диск чем попало. Причём, вовсе не обязательно, чтобы все файлы пользователя хранились в одном месте, они вполне могут быть разбросаны по всем дискам. Устанавливаются квоты через Properties NTFS раздела, закладка Quota. Через Quota Entries... можно выставлять квоты для каждого отдельного пользователя.

Второе, достаточно важное отличие NTFS5 от старой версии - возможность поиска файла, по имени его владельца. Зачем это нужно? А вот зачем: например, вам нужно найти все файлы созданные в Word-е, каким-то одним пользователем, на диске, где этих файлов тысячи. В NT4 это было проблемой. С помощью Access Control List (Список управления доступом), можно легко проверить, какие файлы доступны пользователю, и установить права доступа к отдельным файлам или каталогам.

Кроме непосредственного изменения самой структуры NTFS, в W2k добавлен Microsoft Index Server, который значительно ускоряет поиск файлов, особенно по их содержимому, за счёт индексации содержимого дисков. Управляется эта служба через раздел Indexing Service окна Computer Management. В этом разделе можно просмотреть, какие директории индексируются, и, при желании, добавить новые или удалить старые. Работает это c любыми разделами, а не только NTFS.

В NTFS5 добавлена такая функция как точки монтирования или, по-другому, точки соединения (junction point). Функция эта давно знакома пользователям различных вариантов Unix/Linux, но в продуктах Microsoft она появилась впервые. С помощью этой технологии можно присоединить любой дисковый ресурс в любое место файловой системы. Например, можно присоединить жёсткий диск D: в любой из каталогов на диске C:, например, в C:games Теперь, зайдя в директорию C:games, можно будет видеть содержимое корневого каталога диска D:. Все изменения, которые будут произведены в этой директории, будут произведены на диске D:. После этого, можно в окне Computer management -> Disk Management убрать букву, присвоенную этому диску (Change disk letter and path), и пользователь даже не будет знать, что на компьютере установлено два диска! Он будет работать с одним диском C: и директория C:games для него ничем не будет отличаться от других. Смонтировать диск или раздел в директорию на NTFS разделе или диске, можно из уже знакомого нам меню Change disk letter and path, выбором пункта Add.. -> Mount in this Ntfs folder -> Browse… Управлять этой функцией можно и через командную строку, командой mountvol.

наверх

(2.5) Что такое кластер?
Кластер - минимальный размер места на диске, которое может быть выделено файловой системой для хранения одного файла. Определяется он, как правило, автоматически, при форматировании винчестера, по зависимости указанной в таблице:

Размер раздела | Секторов в кластере | Размер кластера
< 512mб | 1 | 512 байт
< 1024mб | 2 | 1K
< 2048mб | 4 | 2K
< 4096mб | 8 | 4K
< 8192mб | 16 | 8K
< 16384mб | 32 | 16K
< 32768mб | 64 | 32K
> 32768 MБ | 128 | 64K

Небольшое исключение для системного раздела: если он меньше 2048МБ, то размер кластера всегда 512 байт.

Узнать размер кластера в W2k можно несколькими способами. Во первых, можно зайти в Administrative Tools -> Computer Management -> Storage -> Disk Defragmenter. Выбрать нужный диск и нажать на Analyze. Через несколько секунд появится табличка, где есть три кнопки. Нажатие на View Report запускает окошко, в котором море информации про выбраный диск, в том числе и Cluster size.

Есть ещё один метод, который подходит не только для W2k. Создаётся, или берётся готовый, маленький файлик размером от 1 байта до 500 байт. Нажимается на нём правая кнопка мыши, выбирается Properties. Смотрим на два пункта, Size и Size on disk. Size должен быть чем-то вроде 10 байт (или какой там размер он реально имеет), а Size on disk будет, к примеру, 4096 байт, что соответствует настоящему размеру кластера, т.е. 4K.

Размер кластера можно выбрать и самому, вручную, правда, только при форматировании. Делается это так: "format d: /A:size", где size это размер кластера в байтах. Однако существуют некоторые правила, которых следует придерживаться: во-первых, размер кластера должен быть кратен размеру физического сектора, то есть 512 байтам в подавляющем большинстве случаев; во-вторых, есть ограничения по количеству кластеров на разделе.

наверх

(2.6) Как уменьшить занимаемый объем пpоинсталиpованной Win2000?
Можно удалить директории:
  • %SystemRoot%\Driver Cache\i386\
    Это можно сделать в том случае, если всё оборудование уже стоит и работает. При добавлении нового оборудования система будет запрашивать дистрибутив.
  • %SystemRoot%\system32\dllcache\
    Это кэш защищенных системных файлов, используемый для их автоматического восстановления в случае повреждения. Размер по умолчанию этой папки 400 Мб, и определяется он параметром SFCQuota (0xFFFFFFFF) в ключе реестра HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows NT \ CurrentVersion \ Winlogon Изменить размер кэша системных файлов можно помощью команды sfc: sfc /cachesize=0 (можно ввести другое значение, например, 3 Мб), а потом вручную удалить все файлы в указанной директории. Если не задать /cachesize=0, то при следующей проверке защищенных системных файлов система снова наполнит свой кэш до заданного объема.
  • Отключить Hibernate. Так называется технология, которая позволяет быстро выключать и включать компьютер. Основана она на сохранении содержимого оперативной памяти в виде файла на жёстком диске. Поэтому при её использовании в корне системного диска всегда присутствует файл под названием hiberfil.sys объёмом равным оперативной памяти. Стирать его вручную бесполезно, во первых сделать это можно только под другой ОС, во вторых при загрузке он будет создан заново, даже если компьютер не уходил в хибернейт. Сделано это для того, что бы не было ситуации, когда машина не может уйти в хибернейт только из за того, что на диске не хватает места для этого. Для того что бы убрать этот файл навсегда, требуется отключить хибернейт, что можно сделать в Control Panel – Power Options, закладка Hibernate, снять галочку с чекбокса Enable Hibernate.
  • Уменьшить размер Swap файла. По умолчанию W2k создаёт файл подкачки размером в полтора раза больше чем объём оперативной памяти. С современными объёмами RAM, которые даже в домашних машинах могут доходить до гигабайта, и файл подкачки того размера, что W2k выставит для такой машину по умолчанию, большинству пользователей не нужен. Поменять размер файла подкачки можно через System Properties – закладка Advanced, кнопка Settings раздела Performance. В открывшемся окне переходим на закладку Advanced и нажимаем на кнопку Change раздела Virtual Memory. В открывшемся окне выбираем диск или раздел, на котором требуется изменить размер файла подкачки, вводит нужные значения, и нажимаем на кнопку Set.

наверх

(2.7) Можно ли отконвеpтировать диск FAT32 в NTFS без потеpи данных?
  1. Можно воспользоваться командой CONVERT том: /FS:NTFS [/V] Преобразование произойдет при следующей перезагрузке. Потери информации не при этом не будет, но нужно иметь в виду, что размер кластера после конвертации составит 512 байт, что не очень хорошо на больших разделах, кроме того, диск после конвертации будет сильно фрагментирован. Обратное преобразование (NTFS -> FAT) без потери данных средствами Windows 2000 невозможно, потребуется отформатировать раздел заново.
  2. Выполнить конвертацию также сможет программа Partition Magic. Под W2k нормально работает, начиная с версии 6.0, а если использовать только загрузочную дискету, то подойдет и версия 5.01. Данная программа также позволяет выполнять обратное преобразование без потери данных и даже может менять размер кластера (к сожалению, только на FAT16 и FAT32). Partition Magic не работает с динамическими дисками, только с основными. Конвертируя файловую систему учтите, что сконвертированая файловая система это далеко не то же самое, что поставленная изначально. И дело даже не в размере кластера, что хоть и не приятно, но вполне можно пережить, а в том что права доступа на сконвертированой NTFS не выставлены, что в некоторых случаях не приемлемо.

наверх

(2.8) Как полностью выключить SFC (System Files Protection)?
Для этого необходимо поменять значение [HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows NT \ CurrentVersion \ Winlogon] "SfcDisable" на "dword:ffffff9d". Для того что бы включить его обратно, этот же ключ надо изменить на 0. Кроме этого, можно воспользоваться вот этой утилиткой (http://www.3dnews.ru/documents/1143/setsfc.zip), с помощью которой можно не только выключить sfc, но и изменить некоторые другие его параметры, причём делать это гораздо удобнее, чем копаться в дебрях реестра.

Однако, следует помнить, что сделав это, Вы рискуете испытать на себе все последствия Dll-hell, начиная от снижения общей производительности системы и заканчивая самыми разнообразными проблемами и глюками, вызванных заменой системных библиотек на несовместимые версии от сторонних производителей.

наверх

(2.9) После уменьшения размера занимаего W2k, при установке или удалении компонентов системы слишком часто приходится менять компакт диск, то с дистрибутивом W2k, то с Service Paclk. Как этого избежать?

Чтобы этого избежать, можно скопировать на жесткий диск папку i386 дистрибутива и папку i386 сервис-пака, поместив их в два разных каталога, например: "C:\Install\Sp1" и "C:\Install\W2k". В каталог W2k следует положить маркерные файлы CDROM_NT.5 и CDROM_IP.5, а в каталог Sp1 - файл CDROM_SP.TST. Затем следует подредактировать пути к этим каталогам в ключе реестра

HKEY_LOCAL_MACHINE \SOFTWARE \Microsoft \Windows \CurrentVersion \Setup
ServicePackSourcePath: REG_SZ: "C:\Install\Sp1\"
SourcePath: REG_SZ: "C:\Install\W2k\"

Если вы ставили W2k с компакт-диска, то в этом же ключе нужно установить в нуль параметр CDInstall: REG_DWORD: 0 , иначе система будет по-прежнему просить компакт-диск с дистрибутивом или сервис-паком.

Теперь, при добавлении или удалении компонентов системы или при некорректной установке программ, система будет использовать установочные файлы из созданных нами каталогов на жестком диске. При этом не будет нарушаться работа защиты системных файлов, не будет расходоваться лишнее место на диске под каталог dllcache, никогда не придётся использовать компакт-диски для восстановления системных файлов.

Второй путь решения проблемы - интегрировать сервис-пак в дистрибутив, записать его на CD-R, с возможностью загрузки, и пользоваться только им. При этом, если система ставилась не с него, во избежание проблем в ключе HKEY_LOCAL_MACHINE \SOFTWARE \Microsoft \Windows \CurrentVersion \Setup нужно привести к нужному виду указанные выше параметры.

наверх

(2.10) Как интегрировать Service Pack 1 в дистрибутив W2k?
Для этого вам потребуется папка i386 из дистрибутива на жестком диске и, конечно же, сам Service Pack. Интегрируется он командой sp1network -s [полный путь к дистрибутиву, в который надо интегрировать]. Кроме этого, можно сначала распаковать файлы относящиеся к Service Pack (sp1network -x), и запустить update -s [полный путь к дистрибутиву, в который надо интегрировать], из директории i386\update. И, наконец, можно попробовать сделать это вручную, переписав файлы из соответствующих директорий Service Pack в соответствующие директории дистрибутива.

наверх

(2.11) Как интегрировать SP2 в дистрибутив W2k?
Точно так же как и первый. Либо командой w2ksp2 –s:с:\distrib , где c:\distrib полный путь к дистрибутиву лежащему на жёстком диске (может быть любым), либо распокавав дистрибутив w2ksp2 –x, и запустив update –s:c:\distrib (путь к дистрибутиву на диске, может быть любым) из i386\update распакованного sp2.

наверх

(2.12) Что такое есть Resource Kit для W2k и где его можно взять?
Это набор утилит и документации, полезных как пользователю, так и разработчикам. Бесплатную версию лучше взять у Microsoft. Подробнее почитать про него можно по адрессу: http://www.microsoft.com/windows2000/library/resources/reskit/tools/default.asp

а скачать: ftp://ftp.microsoft.com/reskit/win2000/.

наверх

(2.13) Hужно ли устанавливать Service Pack 1 перед установкой Service Pack 2?
Hет, не нужно. Каждая последующая версия сервис-пака включает все апдейты и фиксы предыдущей версии, т.е. имеет накопительный (кумулятивный) характер. Таким образом, достаточно поставить только последнюю версию сервис-пака, а не устанавливать последовательно все выпущенные версии. В то же время, если у вас уже установлена более ранняя версия, деинсталлировать её перед установкой более поздней версии не нужно. Таковы официальные рекомендации Microsoft.

наверх

(2.14) Как перенести уже установленный W2k на другой винт (больший по pазмеpу), с сохранением всех настроек. Hе хочется все заново пеpеустанавливать...
Загружаемся со старого жесткого диска. Создаём на новом диске разделы нужного нам размера и форматируем их. Делаем загрузочный раздел активным. При этом не следует монтировать вновь созданные разделы и задавать им метку при форматировании. Если же это случайно произошло - удаляем БУКВЫ дисков и МЕТКИ томов свежесозданных разделов. Для этого заходим в Computer management -> Disk management -> клик правой кнопкой по диску -> Change drive letter and path -> дальше всё понятно. Метка тома удаляется там же - в свойствах раздела...
  1. Загружаемся с предварительно созданной дискеты Norton Ghost 2001. Выбираем копирование "partition to partition", исходный диск, раздел на нём; диск назначения, раздел на нём и запускаем сам процесс клонирования. (3 Гб клонируется примерно за 15 минут). По окончании процесса нажимаем кнопку "reset computer" в Norton Ghost 2001 и, в момент загрузки логотипа с версией BIOS, выключаем компьютер. Вынимаем старый диск и делаем загрузочным новый.

Если требуется клонирование ВСЕГО содержимого жёсткого диска на другой винчестер, операции удаления букв разделов и меток томов диска назначения делать не обязательно. При этом в качестве клонируемого объекта следует выбирать не "partition" а "disk". Аналогичным образом производится клонирование и при помощи Drive Image 4.

  2. Можно скопировать содержимое раздела в файл с целью бэкапа всей системы или для переноса её на другой винчестер. Эту операцию можно произвести тем же Norton Ghost 2001. Мы разберём этот процесс на примере Drive Image 4. Для наших целей удобно изготовить только загрузочные дискеты этой программы, устанавливать её на винчестер не обязательно. Грузимся в ДОС и запускаем Drive Image. Выбираем опцию создания образа раздела. Указываем раздел назначения и раздел, на котором будет располагаться наш образ. Указываем степень компрессии, если хотим сжать получающийся файл образа. При сжатии 3 Gb раздела с максимальной компрессией получается файл рамером 1.88 Gb. Процесс создания файла образа занимает в этом случае около часа.

Для восстановления содержимого файла-образа следует разбить новый диск так, как это описано выше. Затем, загрузившись в ДОС и запустив Drive Image, выбираем опцию "Restore", указывам расположение файла образа и раздел назначения. Если размер раздела, из которого делался файл образа превосходил размер созданного нами раздела назначения, но размер данных на исходном разделе укладывается в размер раздела назначения, то программа автоматически выполнит необходимые перерасчётные операции. Операция восстановления в вышеуказанном примере занимает 30 мин. При этом Drive Image корректно записывает загрузочный сектор в случае восстановления системного раздела.

(!) Если на перенесенном разделе была установлена "Recovery console", её придётся переустановить. В случае клонирования загрузочного раздела W2k на другой винчестер для возможности загрузки с последнего следует иметь в виду, что необходимый для загрузки системы загрузочный сектор может не переписаться на раздел назначения, т.к. он не является составной частью данных, находящихся на самом разделе. Это зависит от конкретного случая и программы клонирования (см. её документацию). Для записи загрузочного сектора при его отсутствии командой fixboot из Recovery Console.

Если не удалить БУКВЫ дисков и МЕТКИ томов диска назначения перед клонированием или, если загрузиться со старого диска при подключённом новом (с уже удалёнными буквами и метками или уже отклонированном), то мы можем столкнуться с проблемой загрузки W2k, когда система не находит swap файла, и уходит в бесконечный цикл с требованиями перезагрузки. Для решения этой проблемы придётся переставлять систему заново.

Дополнение: Если у вас два компьютера с Windows 2000, то можно поступить немного проще. Подключаете "старый" и "новый" жесткий диск ко второму компьютеру. Заходите администратором. Создаете раздел на "новом" диске и форматируете его в NTFS (диск рекомендуется не забыть определить через BIOS). А потом FARом копируете все файлы со "старого" диска на "новый". Не забудьте указать галочку копирования прав доступа. После копирования подключаете "новый" диск и работаете. Если у вас установлена Active Directory, то следует сначала зайти в "Directory recovery mode", чтобы она приняла ее как родную, а потом нормально загрузиться. Кстати, если вы сжимали некоторые файлы, то после копирования следует повторно их сжать.

наверх

(2.15) Какие параметры можно менять в boot.ini?
boot.ini отвечает за порядок загрузки ОС установленных в системе, и позволяет задать некоторые параметры загрузки этих систем.

Начинается этот файл разделом [boot loader] Здесь всего два параметра:

  • Timeout, определяет время в секундах, которое ждёт система прежде чем начать загружать ОС по умолчанию, если в системе установлено несколько ОС.
  • Default, определяет ОС и её параметры, которая грузится по умолчанию.

Второй раздел [operating system], в котором находится список возможных к загрузке ОС. Для каждой указывается её местоположение, с использованием имен ARC (Advanced RISC Computer).

  1. scsi(*) или multi(*) - элемент scsi(*) используется в случае контроллера SCSI с отключенным BIOS. Элемент multi(*) используется для дисков всех остальных типов, включая IDE, EIDE, ESDI и SCSI с включенным BIOS. (*) - номер адаптера, с которого осуществляется загрузка. Адаптеры нумеруются с нуля, начиная с контроллера, расположенного ближе к слоту 0 на мат. плате. От этой строки зависят значения disk(*) и rdisk(*).
  2. disk(*) - если (1) = scsi(*), то равен логическому номеру устройства (LUN), установленному для диска. Если (1) = multi(*), то всегда равен нулю.
  3. rdisk(*) - если (1) = scsi(*), то равен номеру диска в цепочке, счет дисков начинается с 0. Если (1) = multi(*), то всегда равен нулю
  4. partition(*) - определяет дисковый раздел, содержащий файлы ОС. В отличие от всех остальных элементов имен ARC нумерация разделов начинается с 1, т.е. первый раздел обозначается partition(1), второй - partition(2) и т.д.
  5. \path - определяет каталог (или подкаталог) раздела, в котором находятся файлы ОС. По умолчанию в Windows NT/2000 используется путь \winnt. Кроме этого, в кавычках прописывается текст, который будет виден в пункте выбора этой ОС в стартовом меню. После этого текста могут быть (а могут и не быть) ключи которые влияют на загрузку ОС.

Для W2k возможны следующие ключи:

  • /basevideo - с этим ключом система будет использовать только стандартный VGA драйвер. Этот параметр может пригодится если Вы на коротко время ставите другую видеокарту, и Вам не хочется мучаться с перестановкой драйверов.
  • /fastdetect - обычно ставится автоматически при инсталяции системы. При установке этого ключа система не определяет заново все Plug and Play устройства во время каждой загрузки.
  • /maxmem - определяет максимальный размер RAM, который может использоваться системой. Теоретически, может помочь если у Вас глючная оперативка.
  • /noguiboot - При использовании этого ключа не будет рисоваться цветная заставка при загрузке. Может использоваться теми кто не желает смотреть на эту картинку в 60 герцах. Но надо учесть, что кроме этого не будут рисоваться BSOD при загрузке. Но виснуть система, если что-нибудь не в порядке, естественно не перестанет.
    /noserialmice=[com 1,2,3] - при использовании этого параметра не будет определяться мышь подключенная к COM порту, для портов перечисленных в скобках. Если номера портов не указывать, то мышь не будет определяться на всех портах.
  • /bootlog - при задании этого параметра система будет писать лог загрузки в %SystemRoot%\Ntbtlog.txt Этот параметр можно использовать что найти причину посуму система может загрузится только в safe mode.
  • /safeboot - при его установке система загрузится в Safe mode. То же самое можно сделать нажав F8 в начале загрузки системы. Через двоеточие можно задать несколько параметров для /safeboot:
    • :Minimal - минимальная конфигурация.
    • :Network - с поддержкой сети.
    • :Dsrepair - доступна только в W2kServer и позволяет восстановить Active Directory с заблаговременно сделаной резервной копии.
    • :Alternateshell - позволяет использовать альтернативные графические облочки. По умолчанию с системой ставится только Explorer (стандартная оболочка) и Progman (осталась в наследство от Windows3.11 и NT 3.5).
  • /sos - отображает на экране список загружаемых драйверов. Может помочь выяснить, на чём система спотыкается при загрузке.
  • /baudrate - этот параметр указывает скорость с которой будет работать COM порт для отладки системы. Если не указать конкретную скорость, то будет 9600 для модема и 19200 для нуль-модемного кабеля. При включении этого параметра автоматически ставится параметр /debug
  • /crashdebug - с этим флагом загружается отладчик, но остаётся в неактивном состоянии до тех пор пока не произойдёт ошибка ядра. Может использоваться разработчиками програмного обеспечения.
  • /debugport=com* - указывает номер COM порта (* должна быть номером порта) используемого при отладчиком. Автоматически включает ключ /debug
  • /debug - загружается отладчик, который может быть активизирован другим компьютером подключенным через COM порт. Может использоваться разработчиками ПО.
  • /nodebug - на экран не выводится отладочная информация.
  • /hal - указывает имя файла, который должен использоваться как hal.dll после загрузки. Подробнее см. вопрос 4.5
  • /kernel - указывает имя файла, который должен использоваться как ntoskrnl.dll после загрузки. Подробнее см. вопрос 4.5

наверх

(2.16) Как мне поставить Win9x при уже установленном W2k? Win9x при инсталляции затирает загрузочный сектор W2k.
Win9x при инсталляции затирает загрузочный сектор W2k. Что бы этого не произошло, перед установкой Win9x нужно правильно сконфигурировать его инсталлятор. Для этого в файле MSBATCH.INF (если такого файла в вашем дистрибутиве нет, создайте его) нужно прописать следующие строки:

[Setup]
CleanBoot=0

После установки Win9x устанавливает загpyзкy по умолчанию на себя, но это легко меняется. Если дистрибутив Win9x находится на CD (как это обычно и бывает), то исправленный или новосозданный MSBATCH.INF можно использовать, запустив программу установки Win9x с параметром: setup.exe диск:\путь\MSBATCH.INF В данном случае файл можно назвать как угодно, а не только MSBATCH.INF. После установки, может понадобиться прописать W9x в стартовом меню XP. Для того что бы загрузиться в W9x, необходим файлик bootsect.dos в корне системного диска, который содержит загрузочный сектор W9x, и строка в boot.ini C:\="Microsoft Windows 98" Где текст в кавычках это то, что будет выводится в загрузочном меню выбора ОС.

Если файл с загрузочным сектором W9x (bootsect.dos) по какой то причине не создался, придётся пойти другим путём.

  • Устанавливаем W9x в нормальном режиме, что бы она перезаписала загрузочный сектор.
  • Сохраняем загрузочный сектор в файл, называем его bootsect.dos (см. вопрос 2.22).
  • Загружаемся в программу инсталляции W2k, выбираем там ремонтировать текущую инсталляцию с помощью Recovery Console.
  • Восстанавливаем загрузочный сектор W2k командой fixboot.
  • Загружаемся в W2k и прописываем загрузочный сектор W9x в boot.ini строкой C:\="Microsoft Windows 98"

наверх

(2.17) Как изменить букву системного /загрузочного диска в Windows 2000?
Изменение буквы может потребоваться в случае поломки зеркального тома или при изменении конфигурации дисковой подсистемы. Ниже рассмотрено, как поменять местами буквы для дисков С и D. Если вам не нужно менять буквы местами, просто измените значение \DosDevice\[буква]: на любую неиспользуемую букву. Имейте в виду, что при изменении буквы диска в нормально работающей системе перестанут работать программы, которые используют абсолютный метод адресации - придется переинсталлировать их или вручную изменять все неправильные пути в реестре.
  • Зайдите в систему как администратор и запустите Regedt32.exe.
  • Откройте ключ HKLM\SYSTEM\MountedDevices и разрешите администратору полный доступ к нему (меню Безопасность (Security) -> Разрешения (Permissions)).
  • Закройте Regedt32 и запустите regedit.exe. В указанном выше ключе найдите букву диска, которую вы хотите изменить, в нашем случае это "\DosDevices\C:".
  • Измените букву на любую неиспользуемую, например, "\DosDevices\Z:".
  • Выберите вторую изменяемую букву диска, т.е. "\DosDevices\D:", измените её на требуемую, в нашем случае будет "\DosDevices\C:"
  • Выберите значение \DosDevices\Z: и переименуйте его в "\DosDevices\D:".
  • Закройте regedit.exe и запустите Regedt32.exe. Верните разрешения для ключа HKLM\SYSTEM\MountedDevices в исходное состояние, т.е. "Read Only".
  • Перезагрузите компьютер.

Подробнее: http://support.microsoft.com/support/kb/articles/q223/1/88.asp

При смене буквы системного диска, проследите за тем, что бы swap файл оставался на диске буква которого не будет меняться. В противном случае, система после загрузки не сможет его найти, сообщит об этом после окна логона, и уйдёт на перезагрузку. При следующей загрузке произойдёт то же самое, и так до бесконечности. Для исправления этой ошибки придётся переустановить систему заново.

наверх

(2.18) Как переименовать папку аккаунта Администратор?
Заходим в систему под аккаунтом администратора, создаем папку с нужным именем в директории Documents and Settings. Затем - правый клик на иконке "Мой компьютер" -> Свойства -> Профили пользователей (User Profiles), нажимаем кнопку "Копировать ..." ("Copy To ...") и копируем профиль администратора в созданную папку. Запускаем regedit и находим ключ:

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

В этом ключе находим ветку, соответствующую профилю администратора и в ней исправляем параметр "ProfileImagePath" на нужный. Перелогиниваемся, если все прошло удачно, можно удалить старую папку - она больше не понадобится. Но прежде чем стирать проверьте, сохранилась ли ваша почта. Дело в том, что на разделе отформатированном под NTFS при такой процедуре не копируется папка Local settings, где и гранит свои файлы Outlook Express.

наверх

(2.19) Как выбрать нужную версию ядра и HAL ещё при инсталляции?
В поставку Windows 2000 включены следующие версии библиотеки HAL:
  • ACPI Multiprocessor PC - для ACPI-систем с несколькими процессорами.
  • ACPI Uniprocessor PC - используется для ACPI-систем с многопроцессорной системной платой и одним установленным процессором.
  • Advanced Configuration and Power Interface (ACPI) PC - используется для однопроцессорных ACPI-систем.
  • Compaq SystemPro Multiprocessor or 100% Compatible - для компьютеров Compaq SystemPro или полностью совместимых с ними.
  • MPS Uniprocessor PC - для систем без поддержки ACPI, с многопроцессорной системной платой и одним установленным процессором.
  • MPS Multiprocessor PC - для многопроцессорных систем без поддержки ACPI.
  • Standard PC - используется для любого стандартного компьютера, не многопроцессорного и без поддержки ACPI.
  • SGI mp - для графических станций Silicon Graphics.
  1. В самом начале текстового этапа установки Windows 2000 при появлении сообщения "Setup is inspecting your computer's hardware configuration" нажмите и удерживайте клавишу "F5". В появившемся на экране списке версий библиотек HAL выберите версию, соответствующую вашему компьютеру, или выберите позицию "Other" для того, чтобы указать файл библиотеки от производителя оборудования. Затем продолжите установку Windows.

В ответе использована статья R10894 с http://www.microsoft.ru/catalog/article.asp?article_ID={CE6FA144-3FC2-11D4-A6D1-00508B8B783F}

  2. Если вас интересует только включение/отключение ACPI, то в случае инсталляции системы с жесткого диска или с 4-х загрузочных дискет, можно изменить секцию ACPIOptions файла txtsetup.sif в каталоге I386 дистрибутива.

    По умолчанию эта секция имеет вид:

[ACPIOptions]
ACPIEnable = 2
ACPIBiosDate = 01,01,1999
,где параметр ACPIEnable может принимать одно из трех значений:

0 - ACPI будет игнорироваться при инсталляции в любом случае.
1 - ACPI будет включен при инсталляции, если BIOS поддерживает ACPI.
2 - ACPI будет включен, если BIOS материнской платы сертифицирован как GoodACPIBios ( т.е. присутствует в списке секции [NWACL]) или хотя бы выпущен после даты, указанной в параметре ACPIBiosDate = mm,dd,yyyy

В случае проблем с определением ACPI поставьте параметр ACPIEnable = 1. Если вы хотите отключить ACPI при инсталляции, поставьте ACPIEnable = 0.

наверх

(2.20) Какие файлы необходимы для успешной загрузки Windows 2000?
  • ntldr (загрузчик) - в корневой директории загрузочного диска.
  • boot.ini - конфигурационный файл загрузчика.
  • ntdetect.com - собирает информацию об устройствах.
  • ntbootdd.sys - нужен только при наличии SCSI.
  • bootfont.bin - фонт, только для локализованной версии.
  • ntoskrnl.exe - в %SystemRoot%\system32, ядро Windows 2000.
  • hal.dll - уровень аппаратных абстракций ядра.
  • Раздел реестра SYSTEM - %SystemRoot%\system32\config.
  • Драйверы устройств - %SystemRoot%\system32\drivers.
  • Для систем с двойной загрузкой, а именно для DOS, Win9x и WinME также нужен файл bootsect.dos - копия загрузочного сектора этих систем.

наверх

(2.21) Как организовать загрузку 3 ОС, например W2k, Win9x и Linux с помощью W2k загрузчика?
Самый простой способ, это ставить нужные ОС в правильном порядке. Сначала ставим любую ОС. Потом ставим W2k. При установке W2k сохранит загрузочный сектор в файл bootsect.dos. Переименовываем этот файл во что-нибудь, например bootsold.old, и ставим следующую ОС. После этого восстанавливаем загрузчик w2k (fixboot из recovery console или инсталлятором W2k, подробнее см вопросы 4.1, 4.2 и 2.16) и получите ещё один файл bootsect.dos с загрузчиком другой операционной системы. После этого останется только прописать эти файлы в boot.ini, например так:

C:\bootsect.dos="Windows 98"
C:\bootsect.lnx="Linux"

Приведённый порядок действий не обязателен, главное, что вам надо добиться, это получить загрузочные сектора от Linux и Win9x в отдельных файлах, и восстановить загрузчик W2k.

наверх

(2.22) Как сохранить загрузочный сектор в файл (bootsect.xxx)?
Ответ на этот вопрос зависит от того, под какой ОС всё это делается. Под Linux всё делается средствами самой ОС. Достаточно ввести и исполнить в командной строке:

dd if=/dev/раздел_с_Linux of=/bootsect.lnx bs=512 count=1

Для ОС от Microsoft придётся воспользоваться внешними программами. Например bootpart. Для того что бы сохранить нужный файл, введите bootpart с командной строки. В ответ вы получите список партиций с информацией о каждой. Запомните номер нужной (той где установлена ОС загрузочный сектор которой вы хотите сохранить). После этого исполните команду:

bootpart номер_партиции bootsect.dos

Кроме bootpart для сохранения загрузочного сектора можно воспользоваться DiskEdit. Вам нужен первый сектор (512 байт) нужного раздела.

наверх

(2.23) Как отформатировать первый раздел диска, не потеряв возможность загрузки W2k установленной на другом?
Не смотря на то, что вся необходимая информация уже есть в faq, проблема эта возникает снова и снова, поэтому я решил выделить ей отдельный вопрос. Перед форматированием раздела не забудьте сохранить файлы из корневого каталога первого раздела, нужные для загрузки W2k. Это:
  • ntldr – сам загрузчик.
  • boot.ini – конфигурационный файл загрузчика.
  • ntdetect.com – собирает информацию об устройствах.
  • ntbootdd.sys – нужен только при наличии SCSI.
  • bootfont.bin – шрифт, только для локализованной версии.
  • bootsect.dos – загрузочный сектор альтернативной ОС.

После форматирования раздела, просто скопируйте их обратно, загрузитесь в recovery console W2k, и восстановите загрузчик, командой fixboot.


Win2KFAQ -> Твики

Твики

(3.1) | Как удалить ненужные компоненты W2k? В Add/Remove programs почти ничего нет.
(3.2) | При запуске Windows Explorer открывается папка My Documents. Как сделать так, что бы открывался корневой каталог системного диска?
(3.3) | Когда открывается директория с большим количеством файлов, находящаяся на NTFS-разделе, например, WINNT, то это делается слишком долго. Можно ускорить этот процесс?
(3.4) | Как ускорить работу интерфейса W2k?
(3.5) | Как отключить Dr. Watson, встроенный дебагер?
(3.6) | Какие службы можно отключить, для ускорения работы системы?
(3.7) | Как настроить профиль пользователя, создаваемый системой по умолчанию
(3.8) | Как в W2k менять настройки групповой политики?
(3.9) | Как сделать загрузочный диск для W2k/NT4?
(3.10) | Некоторые программы при старте или инсталяции жалуются, что DirectX 5.0 не установлен, хотя в W2k входит Directx 7.0.
(3.11) | Как отключить автозапуск у привода компакт-дисков?
(3.12) | По какому принципу W2k присваивает буквы дискам?
(3.13) | Как перемонтировать дисковод (A:)? Через Disk Management не получается.
(3.14) | Существуют ли аналоги autoexec.bat и config.sys под W2k?
(3.15) | Что такое случилось с консольными приложениями? Взять тот же FAR - все работает, но у него слишком большой экран. Как это вылечить?
(3.16) | Как запустить программу как сервис?
(3.17) | Как сделать, чтобы пpи остановке/запyске стиpался/создавался новый файл подкачки pagefile.sys?
(3.18) | Как задать пpиоpитет пpоцесса еще пpи его запyске? Чтоб не лазить постоянно для этого в task manager?
(3.19) | После работы с Hyper Terminal в корневой директории появляются файлы, comreads.dbg и comused.dbg. Что это такое, и как их убрать?
(3.20) | W2k при загрузке проверяет на ошибки все дисковые разделы, даже если на них установлены другие ОС. Как это отключить?
(3.21) | Как ускорить работу с памятью?
(3.22) | У меня пусто в "Автозапуске", но некоторые программы продолжают стартовать при входе в Windows.
(3.23) | Отключение подсистем POSIX и OS2.
(3.24) | Почему у Вас нет совета по оптимизации размера L2 кэша?
(3.25) | Можно ли ввести машину в состояние hibernate, или выключить из командной строки?
(3.26) | Правда ли что W2k всегда загружает определённый набор DLL, даже если они не используются?
(3.27) | Как сделать что бы задачи которые повисли и перестали отвечать убивались автоматически?
(3.28) | Как поменять цвет, на который меняются буквы при наведении на них мышки в Windows Explorer, при включенной функции одного клика?
(3.29) | Как добавить содержимое рабочего стола в меню Start?
(3.30) | Как отключить (запретить) Task Manager?
(3.31) | Можно ли на ноутбуке иметь несколько настроек сетевой карты?
(3.32) | Как заставить службы (service) запускаться в определённом порядке?
(3.33) | Компьютер выключается очень долго. Как это ускорить?
(3.34) | Существуют ли аналоги autoexec.bat и config.sys под W2k?
(3.35) | После изменения прав доступа к файлам (security permissions) на NTFS хочется вернуть все к тому виду, как было после установки. Возможно ли это?
(3.36) | Диспетчер устройств показывает не все устройства :(. Как увидеть все установленные устройства (включая даже не подключенные в данный момент)?
(3.37) | Как отключить требование ввода пароля при загрузке W2k?
(3.1) Как удалить ненужные компоненты W2k? В Add/Remove programs почти ничего нет.
Чтобы в Add/Remove programs появились все компоненты, которые можно удалить, надо найти файлик sysoc.inf в WINNTINF и подредактировать его. Убрать слова HIDE или hide, везде где они встретятся. После этого, в Add/Remove Windows components появится множество новых пунктов. К сожалению, далеко не все из установленых компонентов поддаются удалению, несмотря на то, что они присуствуют в меню. Например, в Microsoft считают Fax Service настолько важной, что удалить её стандартными методами не представляется возможным.

наверх

(3.2) При запуске Windows Explorer открывается папка My Documents. Как сделать так, что бы открывался корневой каталог системного диска?
В Propreties shortcut'а на Explorer, меняем target %SystemRoot%explorer.exe на %SystemRoot%explorer.scf. После этого, открываться будет не My Documents, а корневой каталог системного диска. Кроме этого, можно запускать Explorer комбинацией клавиш Win+E, в этом случае он откроется в разделе My Computer. Кроме этого, можно в свойствах ярлыка для Explorer прописать в Target:

%SystemRoot%\explorer.exe /e,c:\ (вместо c:\ можно указать любой другой путь).

После этого открываться будет не My Documents, а корневой каталог диска С или указанная директория. Более подробно почитать про использование этого и других ключей в командной строке при запуске Windows NT Explorer можно здесь: http://support.microsoft.com/support/kb/articles/Q152/4/57.asp

наверх

(3.3) Когда открывается директория с большим количеством файлов, находящаяся на NTFS-разделе, например, WINNT, то это делается слишком долго. Можно ускорить этот процесс?
Когда открывается директория, то NTFS обновляет метку последнего доступа к файлам. Если файлов много и на всех надо метку обновить, то это занимает довольно много времени. Однако эту функцию можно отключить. Для этого запускаем Regеdit и по адресу HKEY_LOCAL_MACHINE -> SYSTEM -> CurrentControlSet -> Control -> FileSystem cоздаём ключ типа DWORD под названием NtfsDisableLastAccessUpdate, после чего ставим его в 1.

наверх

(3.4) Как ускорить работу интерфейса W2k?
Во-первых, нужно отключить все эффекты. Если это кажется недостаточным, то можно через Regedit отредактировать несколько ключей. По адресу HKEY_CURRENT_USER -> ControlPanel -> Desktop находится ключ MenuShowDelay. По умолчанию его значение равно 400, это значение задержки в миллисекундах, после которой появляются ракрывающиеся меню. Установите его в 0. Также по адресу HKEY_CURRENT_USER -> ControlPanel -> Desktop -> WindowsMetrics находится ключ MinAnimate (если его нет, то создайте его; тип String), по умолчанию он стоит 0. Если его поставить равным 1, то он уберёт эффект анимации при сворачивании/разворачивании.

наверх

(3.5) Как отключить Dr. Watson, встроенный дебагер?
Это не только позволит быстрее закрывать подвиснувшие приложения, но и позволит ускорить запуск программ и освободить пару мегабайт оперативной памяти. Сделать это можно выставив ключ Auto равным 0 по адресу HKEY_LOCAL_MACHINE -> SOFTWARE -> Microsoft -> Windows NT -> CurrentVersion -> AeDebug. В этом случае, если возникнут какие-либо сбои в работе приложения, то система предложит либо закрыть приложение, либо передать его отладчику для отладки. Если выбрать второе, то запустится Dr.Watson,и создаст лог-файл. Если вы уверены, что такая возможность вам ни к чему, то можете удалить папку AeDebug из реестра.

наверх

(3.6) Какие службы можно отключить, для ускорения работы системы?
Ускорить работу системы, попутно освободив немного памяти, можно запретив загрузку ненужных системных служб. Отключить (Disable) ненужные службы можно через раздел Services окна Computer Management. Здесь надо быть предельно осторожным, потому как последствия необдуманных действий могут быть непредсказуемы. Многие службы для своей работы требуют работы других служб, поэтому если вы поотключаете слишком много лишнего, то можете столкнуться с такой ситуацией, что не сможете включить всё обратно. Что бы этого избежать, мы бы советовали Вам перед тем как производить эксперементы с службами сохранить ветку реестра отвечающую за запуск системных служб. Для этого в regedit идите по адрессу HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services, и выбрать в меню Register пункт Export Registry Key. Тогда, в случае каких либо проблем Вы просто сможете применить полученный *.reg файлик и всё поправить. А вообще, мы бы настоятельно советовали бы Вам воспользоваться советом из вопроса 4.7, и сразу после инсталляции системы сохранить весь системный реестр. Это, в последствии, может помочь избежать Вам многих проблем. Ниже мы приведём несколько служб, которые могут быть отключены. Используйте эти советы на свой страх и риск, авторы не несут никакой ответственности за возможные последствия.
  • Print Spooler: Спулер печати, ускоряет печать; если принтера нет, то его можно отключить.
  • Task Scheduler: Отвечает за запуск определённых программ в определённое время. Например, можно настроить, чтобы каждый день в определённое время запускался "scandisk" или "defrag". Если подобные функции не нужны, то эту службу можно отключить.
  • Messenger: Принимает и отправляет сообщения, посланные администратором. Если нет сети и администратора, то можно отключить.
  • Protected Storage: Служит для защиты важных данных, ключей пользователей. Запрещает неавторизированный доступ. Если нет сети (в том числе Интернет), или безопасность не волнует, то данный сервис можно отключить.
  • Computer Browser: Обновляет список компьютеров в сети. Если у вас нет локальной сети, то можно отключить.
  • Event Log: Занимается тем, что ведет лог системных и программных событий, а также событий в системы безопасности. Если Вы уверены, что у вас всё уже настроено и нет желания шпионить за каким-либо пользователем, то можно отключить.
  • Server: Обеспечивает общий доступ к принтерам, папкам и файлам, а также обеспечивает поддержку Remote Procedure Call. В случае, если у вас нет ни сетевой карты, ни модема, он вам не нужен.
  • IPSEC Policy Agent: Сервис безопасности протокола TCP/IP. Если Вы не пользуетесь этим протоколом, то можно его выключить. Если Вы сами зашли на http://www.3dnews.ru/ с машины, на которой стоит W2k, то значит, что TCP/IP у Вас установлен, и Вы им пользуетесь.
  • Network Connections: Занимается управлением объектами в директории Network and Dial-Up Connections, то есть всеми сетевыми соединениями. Если нет сети, то он становится не нужным.
  • Remote Registry Service: Позволяет удалённые манипуляции с реестром. Скорее всего нужен только администраторам.
  • System Event Notification: Отслеживает системные события. Если вы уверены, что всё у вас уже работает, то можно отключить.
  • DHCP client: Отвечает за автоматическое распределение IP-адресов. Если нет сети (ни локальной, ни модема), то он не нужен.
  • Telephony: Работает с модемом. Если модема нет, то он не нужен.
  • Telnet: Обеспечивает возможность соединения и удалённой работы с хостами по протоколу telnet. Если уверены, что это не пригодится, то данный сервис можно отключить.
  • Uninterruptible power supply: Управляет работой бесперебойных источников питания (UPS). Если таковых нет, то можно отключить.

Этот список можно ещё продолжить, необходимость того или иного сервиса определяется задачами, которые выполняются на конкретной машине, и установленным аппаратным обеспечением. Поэтому, каждый должен сам решать, что можно отключить, а что нет.

наверх

(3.7) Как настроить профиль пользователя, создаваемый системой по умолчанию
Для этого следует создать временного пользователя, загрузиться в его профиль и выполнить все необходимые настройки. Затем, загрузившись под администраторским логином, следует скопировать содержимое папки этого пользователя взамен содержимого папки "Default User". При этом на эту вновь созданную директорию "Default User" следует выставить такие же права доступа, как и были раньше. Останется только удалить созданного нами временного пользователя и его профиль. Так как, при заходе под гостевым логином содержимое папки "Default User" копируется в свежесозданную папку "Guest", удаляемую при отлогинивании - все созданные нами настройки останутся в силе и на гостевом логине.

наверх

(3.8) Как в W2k менять настройки групповой политики?
Hабираем в командной строке gpedit.msc, жмем Enter, и редактируем настройки политики по своему желанию. Также можно запустить через Start -> Programs -> Administrative Tools -> Local Security Poliсy.

наверх

(3.9) Как сделать загрузочный диск для W2k/NT4?
Метод с использованием программы CDRWIN (http://www.goldenhawk.com/)
(См. также статью http://www.contamination.org/windows2000/burning_cds.html)
  1. Для записи необходим каталог \i386 дистрибутива, а в корне создаваемого диска должны лежать маркерные файлы (содержимое их значения не имеет):

    CDROM_NT.5 - для всех Windows 2000
    CDROM_SP.TST - если в дистрибутив интегрирован 1-й сервис-пак
    CDROMSP2.TST - если в дистрибутив интегрирован 2-й сервис-пак
    CDROM_IP.5 - Windows 2000 Professional
    CDROM_IS.5 - Windows 2000 Server
    CDROM_IA.5 - Windows 2000 Advanced Server CDROM_W.40 - Windows NT Workstation
    CDROM_S.40 - Windows NT Server

    Кроме того, для локализованных версий W2k в корень диска нужно добавить файл BOOTFONT.BIN (берется из каталога \i386 или с первого диска из комплекта инсталляционных дискет). В каталог \i386 NT 4.0 рекомендуется положить файл BOOTFIX.BIN из дистрибутива W2k - он предотвратит случайную загрузку с CD-R.

  2. выбираем в верхнем меню Backup/Tool Operation режим Build an ISO 9660 Image File
  3. в следующем пункте выбираем каталог, где подготовлены файлы для записи на CD (например, C:\W2kCD, в котором лежит каталог i386 дистрибутива и указанные выше файлы) и указываем имя файла образа диска, например, w2kboot.iso.
  4. убираем флажок в пункте Preserve Full Pathnames
  5. установливаем флажки в пунктах Recurse Subdirectories, Disable Version Numbers, Include System Files, Include Hidden Files и, если хотите использовать длинные имена, Long Filenames (Joliet)
  6. на закладке Advanced Option/Bootable Disk помечаем 'Make bootable disc', и заполняем следующие поля:

Media Emulation Type: Custom
Image File Name: boot.bin
Developer Name: Microsoft Corporation
Load Segment: оставляем как есть (07с0)
Load Sector Count: указываем 4

  7. там же в Advanced Option/Volume Descriptor прописываем Volume Label:

    для Windows 2000 Professional - W2PIS_EN,
    для Windows 2000 Server - W2SIS_EN,
    для Windows 2000 Advanced Server - W2AIS_EN.

    (!) Метки указаны для английских версий, для русских замените _EN на _RU.

  8. нажимаем кнопку Start. Полученный образ можно записать на диск, используя свою любимую CD-R программу (Easy CD Creator, Nero и т.д.) или с помощью пункта Record an ISO 9660 Image File в CDRWin-е.

Метод с использованием программы Nero - Burning Rom.

  1. создаём новую компиляцию ("New Compilation") типа CD-ROM (Boot)
  2. на вкладке Boot окна свойств компиляции указываем в качестве Image file файл boot2m.bin (у Nero свой формат; чтобы использовать boot.bin, необходимы дополнительные действия, см. пункт 3), включаем опцию "Enable expert settings (for advanced users only)" и в группе параметров "Expert settings" указываем:

    Kind of emulation: No Emulation
    Boot message: оставляем, как есть по умолчанию
    Load segment of sectors (hex): 07C0 (оставляем по умолчанию)
    Number of loaded sectors: указываем 4

  3. на вкладке "ISO" указываем:

    File/Directoryname length = ISO Level 1
    Format = Mode 1
    Character Set = ISO 9660 (или DOS - если нужны правильные имена файлов в DOS)
    Joliet - вкл.
    Relax ISO Restriction - обе опции: Allow pathdepth of more than 8 directories и Allow more than 255 characters in path - выкл.

    Если вы хотите использовать стандартный загрузочный сектор boot.bin, то опцию Don't add the ";1" ISO file version extension (для версий 5.5.7.8 и выше), нужно включить. В противном случае (если используется boot2m.bin), эту опцию оставляем выключенной. В версиях Nero старее 5.5.7.8, использовать boot.bin можно, если в разделе реестра HKCU\Software\ahead\Nero - Burning ROM\General значение параметра AddISOFileVersion:REG_DWORD изменить с "1" на "0".

  4. на вкладке "Label" оставляем по умолчанию ISO 9660, а метку тома (Volume label) указываем аналогично методу с CDRWin. Остальные поля оставляем по умолчанию. Опцию "Also use the ISO9660 text for Joliet" также оставляем включённой
  5. на вкладке "Dates" оставляем всё по умолчанию, т.е. "Use the date and time from the original file", на вкладке "Misc" - также по умолчанию
  6. на вкладке "Burn" включаем опцию "Finalize CD (No further writing possible)", в качестве "Write Method" выбираем "Disc-At-Once", остальные параметры (скорость записи, симуляция) - по желанию
  7. нажимаем на кнопку "New" и добавляем в корень компиляции папку \I386 и маркерные файлы, перечисленные в методе с CDRWin. Можно добавить и другие файлы и каталоги (по желанию пользователя). Все, теперь можно начинать запись диска.

Файлы boot.bin, boot2m.bin и упомянутые маркерные файлы: boot_cd_files.zip. Желающие создать мультизагрузочный диск, а также подробнее узнать о загрузке с CD, могут посетить следующие ресурсы: http://bootcd.narod.ru/ и http://nu2.nu/.

наверх

(3.10) Некоторые программы при старте или инсталяции жалуются, что DirectX 5.0 не установлен, хотя в W2k входит Directx 7.0.
Наличие DirectX 5.0 определяется несколько по-другому, чем наличие более поздних версий, поэтому некоторые старые програмы не находят DirectX вообще. Но их можно обмануть. Для этого, создаётся директория directx в Program Files. Потом в эту директорию с дистрибутива DirectX 5.0 переписываются несколько файлов: DXINFO.EXE, DXSETUP.EXE и DXTOOL.EXE. Там же создаётся линк на "dxdiag.exe" (Находится он в директории WINNTSystem32). И напоследок, в WINNTSystem32 переписывается файл ddhelp.exe, из дистрибутива DirectX 5.0. После этого запускаем упрямую программу и радуемся жизни.

Примечание: програмы требующие DX6.1 на эту уловку, к сожалению, не поддаются. Остаётся только надеятся, что производители знают (и работают) над этой проблемой.

наверх

(3.11) Как отключить автозапуск у привода компакт-дисков?
Можно нажать левый Shift во время загрузки компакт-диска. А можно поправить значение в реестре:
ключ: [HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ CDRom]
паpаметp: Autorun
тип: REG_DWORD
значение: (0=отключено, 1=включено)

наверх

(3.12) По какому принципу W2k присваивает буквы дискам?
В порядке подключения. Системному диску присваивается название С: и изменить его уже нельзя. После него идут все жёсткие диски, которые найдены в процесе инсталяции, потом CD-ROM’ы, и так далее. Но, если диск подключается после того как система установленна, то ему присваивается следующая свободная буква, буквы уже установленных дисков не меняются. Причём для системы нет никакой разницы, что это за диск: винчестер, CD-ROM, Zip или Jaz drive, или что-либо ещё. Таким образом, нередки ситуации, когда CD drive имеет букву меньшую, чем винчестер, или, если в системе установлено много дисков, они идут вперемешку, без всякой системы, что несколько смущает пользователей привыкших к тому, что W9x упорядочивает диски, меняя буквы, и установленный в W9x винчестер всегда получает букву меньшую, чем у CD-ROM, сдвигая последний. Впрочем, и в W2k можно привести нумерацию дисков в "привычный" вид, но делать это придётся вручную, через Disk Management.

наверх

(3.13) Как перемонтировать дисковод (A:)? Через Disk Management не получается.
mountvol (выдается список всех томов) >temp
mountvol A: /d
Создать c:winntfloppydisk-a
mountvol c:winntfloppydisk-a ?Volume{код_тома_А_из_файла_temp}

На c:winntfloppy назначить какие нужно права доступа.

наверх

(3.14) Существуют ли аналоги autoexec.bat и config.sys под W2k?
Посмотрите C:\WINNT\SYSTEM\autoexec.nt и C:\WINNT\SYSTEM\config.nt Hо под W2k эти файлы влияют только на процессы, работающие через NTVDM и на Win32 никакого эффекта не оказывают. Кроме того, при указании путей в autoexec.nt могут некорректно вести себя Win16-приложения. Поэтому рекомендуется прописывать пути в свойствах "Мой компьютер" на закладке Advanced -> Environment Variables.

наверх

(3.15) Что такое случилось с консольными приложениями? Взять тот же FAR - все работает, но у него слишком большой экран. Как это вылечить?
Это происходит из-за того, что в W2k высота окна консоли равна по умолчанию 300 строкам. Лечится так: создаете ярлык для FAR'a, щелкаете на нем правой кнопкой мыши, далее Properties -> Layout -> Height и вместо высоты экрана в 300 строк ставите 25. Также можно написать для запуска нужной программы cmd-файл, в начале которого будет добавлено mode con lines=25. Можно поставить по усмотрению любое число. Для того же Far-а можно сделать 100x38 шрифтом 10x18 (в разрешении 1024x768). Попробуйте, вдруг понравится.

наверх

(3.16) Как запустить программу как сервис?
  1. Лучше всего это делать под аккаyнтом админа, тогда пpи любом дpyгом аккаунте созданный сервис будет продолжать работать.
  2. Копиpyете файлы instsrv.exe и srvany.exe в какyю-нибyдь системнyю диpектоpию, напpимеp, в winnt\system32\ (Берутся из Resouce Kit \compmgmt.cab\srvany.exe, instsrv.exe. Ещё есть srvinstw - это GUI пошаговая оболочка делающая то же, что и instsrv, но ещё может ставить/сносить службы удаленно).
  3. Запyскаете из командной стpоки: instsrv MyService c:\полный_пyть\srvany.exe где MyService -- пpидyманное вами имя вновь созданного сеpвиса. Если в имени имеются пpобелы, то имя сеpвиса необходимо заключить в кавычки.
  4. Тепеpь надо сконфигypиpовать этот сеpвис. Идёте в: Start -> Settings -> Control Panel -> Services, находите свой новосозданный сеpвис и щёлкаете на нём 2 pаза левой кнопочкой мышки. В откpывшемся окошке отмечаете, каким способом ваш сеpвис бyдет запyскаться: Automatic - бyдет запyскаться автоматически пpи загpyзки компьютеpа, Manual - бyдет запyскаться только, когда вpyчнyю запyстите, Disabled - совсем не бyдет запyскаться. Если хотите видеть заппущенный сеpвис в виде окна на десктопе, то отметьте чек-бокс "Allow Service to Interact with Desktop".
  5. Запyскаете regedt32 и создаёте key "Parameters" (без кавычек) в: HKLM \ SYSTEM \ CurrentControlSet \ Service \ Имя_Вашего_сеpвиса \
  6. Создаёте под созданным вами ключом "Parameters" (без кавычек) value "Application" (без кавычек) тип -- REG_SZ: и пpописываете там полный пyть к исполняемомy файлy.
    Hапpимеp, Application: REG_SZ: c:\полный_пyть\t-mail.cmd
  7. Пеpезагpyжаете компьютеp или стартуете сервис вручную.

Выходить из таких сеpвисов лyчше по флагy.
Также можно воспользоваться программой AppToService (http://www.3dnews.ru/documents/1143/AppToService.zip) (бывший ServiceIt) от компании Basta Computing (http://www.basta.com/).

наверх

(3.17) Как сделать, чтобы пpи остановке/запyске стиpался/создавался новый файл подкачки pagefile.sys?
Это может пригодиться для повышения безопасности системы. Ведь в процессе работы в файле подкачки может оказаться всё что угодно, в том числе и информация к которой никто не должен иметь доступ. [HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Control \ Session Manager \ Memory Management] Параметр "ClearPageFileAtShutdown"=dword:00000001 Этот ключ не стирает пейджфайл с диска, а заполняет его весь нулями, т.е. очищает. Hо сам файл на диске остается. Тоже самое делается в апплете Local Secutity Policy в Administrative Tools, раздел Local Policies, Security Optinos, ключ Clear virtual memory pagefile when system shuts down. Делая это учтите, что очистка занимает время, и выставив эту опцию вы замедлите выключение компьютера.

наверх

(3.18) Как задать пpиоpитет пpоцесса еще пpи его запyске? Чтоб не лазить постоянно для этого в task manager?
Запуская с помощью консольной команды start можно запускать приложение с нужным приоритетом, указывать время, через которое приложение должно быть закрыто, и некоторые другие параметры. Для более подробной справки почитайте start /? Все эти команды можно прописать в *.bat файле и пользоваться им для запуска приложени. Что бы не писать *.bat файлы для каждой программы отдельно, и не набирать команду целиком, можно сделать файлик high.bat, с таким содержимым

echo off start
/high %1

и поместить его в директорию SendTo профиля вашего пользователя. Тогда, что бы запустить программу с более высоким приоритетом, достаточно просто переслать её на этот файлик через правую кнопку мыши. Но пересылать надо именно исполняемый файл, а не shortcut к нему. Конечно же, этот файлик можно и переделать и запускать программы с другим приоритетом.

Дополнение: Ускорение запуска программ
W2k может работать в двух режимах. Первый отводит больший приоритет запущенным пользователем приложениям (Optimize Performance for Applications), второй отводит больший приоритет на фоновые приложения и службы (Optimize Performance for Background). Настройку можно посмотреть, если выбрать значок System в Control panel, далее закладку Advanced и кнопку "Performance options". (В русской версии Панель управления/Система/Дополнительно/Параметры быстродействия). Первое значение (for Applications) выделяет программам приоритет в зависимости от их уровня приоритета (priority level). Если вы не знакомы с этим понятием, то вкратце поясним: по уровню компьютер решает, какие программы более важны и тратит на них больше процессорного времени. Уровень определяется двумя параметрами: классом приоритета (Priority Class) и приоритетом нити (thread priority). Классы бывают: реального времени (real-time), высокого (high), среднего (normal), близкого к нулю (idle) приоритетов. У нити выделяют следующие приоритеты: критичный ко времени (time critical), высокий (highest), выше среднего (above normal), средний (normal), ниже среднего (below normal), низкий (low) и близкий к нулю (idle).

В приведенной ниже таблице можно посмотреть, как эти два параметра влияют на выполнение задачи.

 | Priority Class
Thread Priority |  | Real-Time | High | Normal | Idle
 | Time Critical | 31 | 15 | 15 | 15
 | Highest | 26 | 15 | 10 | 6
 | Above Normal | 25 | 14 | 9 | 5
 | Normal | 24 | 13 | 8 | 4
 | Below Normal | 23 | 12 | 7 | 3
 | Lowest | 22 | 11 | 6 | 2
 | Idle | 16 | 1 | 1 | 1

Значение от 1 до 31 показывает, сколько компьютерного времени выделяется на каждый процесс. Пользователь может изменить класс приоритета программы, причем двумя способами. Первый - через Диспетчер задач (Task Manager). Он подходит, если программа уже запущена. Выбираем закладку "Процессы" (Processes), нажимаем правую клавишу мыши на нужном процессе, выбираем строчку "Приоритет" (Set Priority) и устанавливаем класс приоритета. Второй способ заключается в указании параметра при запуске программы, или создании командного (.CMD) файла в текстовом редакторе. Параметры:

start /<класс приоритета> [<путь>]<имя файла>

Например: start /high c:\windows\notepad.exe

Будьте осторожны в присваивании класса реального времени. Такая программа будет иметь очень высокий приоритет, что может сказаться на замедлении выполнения других программ. Более того, если у Вас не SMP система, то охочее до ресурсов приложение может просо ничего не оставить системе, и вы столкнётесь с ситуацией, когда компьютер не будет реагировать на Ваши действия, или будет реагировать с большим опозданием. В худшем случае, он может просто повиснуть.

наверх

(3.19) После работы с Hyper Terminal в корневой директории появляются файлы, comreads.dbg и comused.dbg. Что это такое, и как их убрать?
Эти два файла содержать представленные в шестнадцетиричном виде данные, которые передавались и принимались по порту модема. Если Вы считаете, что эта информация Вам не нужна (а в подавляющем большинстве случаев это так), то можно попробовать немного отредактировать %System_Root%\system32\hypertrm.dll (на свой страх и риск!):
hypertrm.dll | Было | Стало
0005EC40: | 63 | 4E
0005EC41: | 6F | 55
0005EC42: | 6D | 4C
0005EC43: | 75 | 00
0005EC7C: | 63 | 4E
0005EC7D: | 6F | 55
0005EC7E: | 6D | 4C
0005EC7F: | 72 | 00

Перед тем как править файл, не забудьте отключить sfc, иначе всё будет напрасно, W2k поменяет файл на исходный.

наверх

(3.20) W2k при загрузке проверяет на ошибки все дисковые разделы, даже если на них установлены другие ОС. Как это отключить?
Для этого необходимо в реестре по адресу [HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Control \ Session Manager] изменить ключ "BootExecute". По умолчанию там стоит "autocheck *", "*" можно попробовать поменять на букву раздела, который следует проверять. Впрочем, возможно это приведёт к тому, что никакие разделы не будут проверятся вообще, полной уверенности о работе этого ключа у меня нет.

наверх

(3.21) Как ускорить работу с памятью?
Можно регулировать несколько значений реестра для ускорения работы подсистемы памяти W2k. Но будьте осторожны, так как неправильные значения могу привести к неработоспособности системы. Вы можете изменить некоторые значения реестра в ветке [HKLM/System/CurrentControlSet/Control/Session Manager/Memory Management]:
  • DisablePagingExecutive - при включении этого параметра, ядро системы и драйвера не будут скидываться в файл подкачки (swap). Система и программы будут быстрее реагировать на действия пользователя. Параметр следует использовать только при большом объеме доступной памяти (>256 Мбайт). По умолчанию значение "0", включение - "1".
  • LargeSystemCache - при включении (по умолчанию включено на серверах W2k и Windows.NET) операционная система будет использовать всю оперативную память для кеша системных файлов, за исключением 4 мегабайт зарезервированых для дискового кеша. Для включения опции следует указать в качестве параметра "1". Установка опции в значение "0" рекомендуется для серверов использующих приложения со своими собственными функциями кэширования памяти, например Microsoft SQL Server или IIS.
  • IOPageLockLimit - сомнительная функция, если вы, конечно, не желаете организовать сервер из своей машины. Опция ускорит выполнение операций ввода/вывода при большом количестве передаваемых файлов или при подобных нагрузках. Не имеет ощутимого эффекта, если на вашем компьютере установлено менее 128 Мбайт памяти. Если памяти больше, то вы получите увеличение производительности при установке параметра в значение от 8 до 16 Мбайт. По умолчанию выставляется 512 кбайт. Вам следует указать параметр в байтах, поэтому умножьте требуемое число мегабайт два раза на 1024. Протестируйте несколько настроек и выберите наилучшую.

наверх

(3.22) У меня пусто в "Автозапуске", но некоторые программы продолжают стартовать при входе в Windows.
Проверьте следующую ветку реестра, используя regedit или regedt32: [HLKM \SOFTWARE \MICROSOFT \WINDOWS \CURRENTVERSION \RUN]. Там находятся значения, каждое из которых соответствует одной запускаемой при старте программе. Если вы не уверены, перед стиранием сохраните выбранные строчки.

наверх

(3.23) Отключение подсистем POSIX и OS2.
POSIX является стандартом взаимодействия операционных систем, он включен в Windows 2000 по требованию правительства США, а подсистема OS2 нужна для запуска соответствующих приложений. Обычные пользователи вряд ли когда будут задействовать эти подсистемы, поэтому их лучше убрать для освобождения лишней памяти. Microsoft не предусмотрела легального пути удаления этих подсистем, поэтому следует удалить или переименовать необходимые файлы. Причем перед удалением следует либо отключить защиту файлов (Windows File Protection), либо стереть файлы и из каталога /system32/dllcache, а последующий запрос системы вставить диск с дистрибутивом проигнорировать. Следует удалить/переименовать следующие файлы из каталога /system32: OS2.exe, OS2SRV.exe, PSXSS.exe, OS2SS.exe и POSIX.exe.

Предупреждение: подсистема POSIX может потребоваться для некоторых программ из Resource Kit, если вы им пользуетесь, то лучше оставьте POSIX.

наверх

(3.24) Почему у Вас нет совета по оптимизации размера L2 кэша?
Довольно давно по сети ходит совет по оптимизации L2 кэша. Для этого советуют по адресу HKEY_LOCAL_MACHINE \System \CurrentControlSet \Control \Session Manager добавить ключ SecondLevel DataCache, и присвоить ему значение равное количеству L2 кэша процессора. После этого, это значение загружается в переменную ядра MmSecondaryColors. По всей видимости, это подсказка алгоритму page coloring, который оптимизирует раздачу физических страниц процессам так, чтобы они не "толкались" в directly-mapped кэше. Однако, по информации Microsoft процессора P6 не имеют directly-mapped кэша, а значит, page coloring для них бессмыслен. Кроме этого, объём кеша легко узнаётся ОС по CPUID, для всех современных процессоров, так что практического смысла в выставлении этого параметра я не вижу никакого.

наверх

(3.25) Можно ли ввести машину в состояние hibernate, или выключить из командной строки?
  1. Переход в спящий режим (hibernate):
    %windir%\System32\rundll32.exe powrprof.dll,SetSuspendState
  2. Отключение: создаем в текстовом редакторе файл poweroff.vbs, содержащий:

    dim OpSysSet, obj
    Set OpSysSet = GetObject("winmgmts:{impersonationLevel=impersonate," & _
    "(Shutdown)}//./root/cimv2").ExecQuery _
    ("SELECT * FROM Win32_OperatingSystem" &_
    " WHERE Primary=true")

    For Each obj In OpSysSet
    obj.Win32Shutdown(8)
    Next

    В дальнейшем можно стартовать этот скрипт из командной строки или включить вызов в командный файл. Уже готовый скрипт при желании можно скачать здесь: http://www.chem.univ.kiev.ua/~adsh/win2k/soft/poweroff.php или здесь: http://www.adsh.kiev.ua/win2k/soft/poweroff.zip (Украина).

  3. Отключение, перезагрузка, разрыв модемного соединения, Log-off, Lock, Stand By, Hibernate - все это можно сделать с помощью утилиты Switch Off (http://yasoft.km.ru/rus/switchoff/). GUI, поддержка командной строки, конфигурационный файл, удаленное управление через web-интерфейс - в 64 Кб!
  4. Отключение, перезагрузку, Log-off, Hibernate, Suspend, пробуждение по таймеру - сделает для вас fShutdown ( http://confignt.ixbt.com/shutdown.htm ).

наверх

(3.26) Правда ли что W2k всегда загружает определённый набор DLL, даже если они не используются?
Правда. Список этих DLL находится здесь:
HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\KnownDLLs
Теоретически, если Вы уберёте из этого списка лишнее, это может освободить некоторое количество памяти и ускорить работу. Практически, я бы не советовал. Зато можно добавить в этот список библиотеки, которые часто используются используемым именно Вами.

наверх

(3.27) Как сделать что бы задачи которые повисли и перестали отвечать убивались автоматически?
За это отвечает ключ HungAppTimeout, находящийся по адресу HKCU\Control Panel\Desktop. Значение этого ключа определяет время в миллисекундах, через которое не отвечающее приложение считается зависшим. Кроме этого ключа, в той же ветке есть ключи WaitToKillServiceTimeout, который задаёт время ожидания перед «убийством» зависшей службы, и AutoEndTasks, присвоив которому значение 1, Вы разрешите системе убивать зависшие процессы самостоятельно. Не следует, только, ставить очень малые значения Timeout, иначе могут возникнуть проблемы с невовремя убитыми програмами и службами.

наверх

(3.28) Как поменять цвет, на который меняются буквы при наведении на них мышки в Windows Explorer, при включенной функции одного клика?
В реестре по адресу HKEY_CURRENT_USER\Control Panel\Appearance\Schemes в любой схеме изменяется значение по адресу 02BD (02B8 - in the 5th column) это и будет HotTrackingColor. Но при перезагрузке надо каждый раз выбирать эту схему в Display->Properties->Appearance, иначе HotTrackingColor == 0 0 - 255.

наверх

(3.29) Как добавить содержимое рабочего стола в меню Start?
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders value Desktop, default val is "%USERPROFILE%\Desktop" change to "%USERPROFILE%\Start Menu\Desktop" скопировать папку %USERPROFILE%\Desktop в %USERPROFILE%\Start Menu\Desktop
Перегрузится, после этого, при нажатии на Start там будет распахивающееся меню Desktop.

наверх

(3.30) Как отключить (запретить) Task Manager?
Для этого в реестре по адресу HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System создайте ключ типа DWORD под названием DisableTaskMgr, и присвойте ему значение 1. Удалив этот ключ, или присвоив ему 0, вы вновь разрешите Task Manager.

наверх

(3.31) Можно ли на ноутбуке иметь несколько настроек сетевой карты?
Штатными средствами W2k нельзя, но систему можно обмануть. К сожалению, есть определённые ограничения, поэтому этот «финт» нельзя применить всем читателям. Организовать быструю смену всех сетевых настроек на ноутбуке можно в том случае, когда LAN карта может вставляться в два разных PCMCI слота. В этом случае, вставляем карту в одни слот, конфигурируем её, потом извлекаем, и ту же самую карту вставляем в другой слот, и конфигурируем заново. В случае с PCMCI платками W2k запомнит настройки для каждого из слотов (которые могут не иметь ничего общего), останется только перетыкать платки из одного слота в другой по мере необходимости.

наверх

(3.32) Как заставить службы (service) запускаться в определённом порядке?
Для этого служит ключ в реестре под названием DependOnService. Найти его можно в ветке относящейся к службе HKLM\System\CurrentControlSet\Servises\Имя службы Присвойте этому ключу имя службы которая должна стартовать раньше. Если служба не должна стартовать каждый раз, и собственного ключа в реестре не достойна, запускайте службы через BAT или CMD файл примерно такого содержания:

net start service1
net start «service2 name»
net start service3

наверх

(3.33) Компьютер выключается очень долго. Как это ускорить?
Рецепт не универсальный, и не работающий во всех 100 процентах случаев, но помогающий достаточно часто. Причиной того что W2k долго выключается является, зачастую, то что не все процессы выгружаются правильно, и система ждёт, когда их можно будет убить. Регулируется это ключом WaitToKillServiceTimeout, расположенным по адресу HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control Значение этого ключа определяет время в милисекундах, которое система и выжидает. По умолчанию это 20000, что означает 20 секунд, которые прибавляются к времени затрачиваемому системой на выключение компьютера, если какая то служба или программа не выгружается по человечески. Измените его на 5000, и всё пойдёт гораздо быстрее. Но не ставьте слишком мало, потому что в этом случае вы можете столкнуться с ситуацией когда W2k будет убивать программы раньше, чем они будут успевать сохранить свои данные. Что тоже плохо.

наверх

(3.34) Существуют ли аналоги autoexec.bat и config.sys под W2k?
Посмотрите C:\WINNT\system32\autoexec.nt и C:\WINNT\system32\config.nt. Под W2k эти файлы влияют только на процессы, работающие через NTVDM и на Win32 никакого эффекта не оказывают. Кроме того, при указании путей в autoexec.nt могут некорректно вести себя Win16-приложения. Поэтому крайне рекомендуется прописывать пути в свойствах "Мой компьютер" ("My Computer") на закладке "Дополнительно" ("Advanced") -> "Переменные среды" ("Environment Variables").

(!) Если в момент загрузки W2k в корне системного раздела присутствовал файл autoexec.bat, то значения переменной path, определенные в нем, добавятся к путям, определенным в "Переменных среды". Если вы не хотите этого, в разделе реестра HKCU\Software\Microsoft\Windows NT\CurrentVersion\Winlogon значение параметра ParseAutoexec: REG_SZ: установите в 0.

наверх

(3.35) После изменения прав доступа к файлам (security permissions) на NTFS хочется вернуть все к тому виду, как было после установки. Возможно ли это?
Да, это возможно. Более того, это просто необходимо, если вы поставили W2k на FAT или FAT32, а затем отконвертировали файловую систему в NTFS (см. также вопрос 2.7). Для того, чтобы восстановить разрешения по умолчанию для NTFS, зайдите в систему под аккаунтом администратора, и введите в командной строке:

Secedit /configure /db C:\winnt\temp\temp.mdb /Cfg %Windir%\inf\defltwk.inf /areas filestore - для версии Professional

Secedit /configure /db c:\winnt\temp\tmp.mdb /Cfg %Windir%\inf\defltsv.inf /areas filestore - для версии Server

Данная процедура затронет все папки из %Windir% и "Program Files", а для папки "Documents and Settings" все же придется выставлять права доступа вручную.

Список разрешений по умолчанию, активизирующихся в результате команды, можно найти здесь: http://support.microsoft.com/default.aspx?scid=kb;EN-US;q244600

Замечание: после выполнения команды вы можете получить сообщение о том, что задача выполнена, но часть файлов отсутствует и для них операция не применима.

(!) Если вы запретили доступ к файлам аккаунту SYSTEM на загрузочном диске, то результатом будет невозможность загрузки системы. Для решения этой проблемы придется воспользоваться другой копией W2k (можно поставить вновь на другой диск или раздел) и с помощью Windows Explorer дать аккаунту SYSTEM полные права доступа на корневую папку и все системные файлы и папки. После этого, загрузившись в оригинальной версии W2k, восстановите разрешения по умолчанию. Подробнее: http://support.microsoft.com/default.aspx?scid=kb;EN-US;q237399

наверх

(3.36) Диспетчер устройств показывает не все устройства :(. Как увидеть все установленные устройства (включая даже не подключенные в данный момент)?
Установите в Диспетчере устройств опцию View/Show hidden devices, затем откройте окно консоли и выполните в нем следующие команды:

set devmgr_show_nonpresent_devices=1
cd %SystemRoot%\System32
start devmgmt.msc

Можно также с помощью Панели управления (окно System/Advanced/Environment Variables) создать системную переменную devmgr_show_nonpresent_devices и присвоить ей значение 1. Теперь Диспетчер будет показывать все устройства.

наверх

(3.37) Как отключить требование ввода пароля при загрузке W2k?
  1. Если машина не является членом домена, можно воспользоваться апплетом Пользователи и Пароли (User and Passwords) из Панели управления. Hа закладке Пользователи убрать галочку "Требовать ввод имени пользователя и пароля".
  2. В противном случае идем в Control Panel -> Administrative Tools. Далее - апплет Local Security Policy -> Security Options, опцию "Disable CTRL+ALT+ DEL requirement for logon" выставляем в Enable (не будет появляться окошко с предложением нажать "три заветные кнопки"). Проверяем, чтобы опция "Do not display last user name in logon screen" была выставлена в Disable. Запускаем regedit. Добавляем (если отсутствует) параметр AutoAdminLogon: REG_SZ: 1 в ветку HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon.
    Изменяем значение ключа DefaultUserName на имя нужного пользователя. Создаем ключ DefaultPassword (тип STRING) и присваиваем ему тот пароль, какой нужен. Закрываем regedit, делаем Log Off. Происходит выход из под вашего аккаунта и автоматический вход с именем пользователя, которое указано в DefaultUserName.
    Теперь при любой перезагрузке W2k всегда будет запускаться под этим аккаунтом. Если все же возникнет необходимость войти в систему под другим пользователем, можно во время логона держать нажатой клавишу SHIFT. Однако в следующий раз система загрузится под тем пользователем, который указан в DefaultUserName.
  3. Также можно воспользоваться утилитами TweakUI (версии не ниже 1.33.0.0) или ConfigNT (версии не ниже 1.4.5.314, сайт http://confignt.ixbt.com/).


Win2KFAQ -> Восстановление

Восстановление

(4.1) | Система не загружается, что делать?
(4.2) | Как восстановить повреждённый загрузчик W2k?
(4.3) | Пропали куда-то системные шрифты под W2k, или вообще, система начала вести себя как то странно, перестали работать некоторые программы, появились глюки, которых раньше точно не было. Как это можно исправить?
(4.4) | У меня в Far-е почему-то отказывается работать мышь. В настройках фара она включена, но работать не хочет :(.
(4.5) | Как поменять ядро системы?
(4.6) | Как в Recovery Console получить доступ в папки, отличные от \WINNT?
(4.7) | Как создать диск аварийного восстановления (Emergency Repair Disk)?
(4.8) | Можно ли восстановить информацию из зашифрованного средствами W2k файла?
(4.9) | Как восстановить систему, если поставлено неправильное ядро?
(4.1) Система не загружается, что делать?
Восстановить систему в W2k будет гораздо проще, если заранее об этом позаботиться. Наиболее радикальным методом будет сохранение всех основных системных файлов. Для этого, в Properties жёсткого диска выберите закладку Tools и нажмите на кнопку Backup now..., либо через Start -> Programs -> Accessories -> System Tools -> Backup. В открывшемся окне выбираем закладку Backup, и отмечаем галочкой System state. Далее остаётся только нажать на Start Backup. К недостаткам этого метода можно отнести то, что созданый файл с расширением *.bkf займёт около 200МБ места на диске, и для того чтобы воспользоваться им, необходимо иметь работающую систему. То есть, он не спасёт Вас от полной переустановки системы, он просто поможет востановить Вам все свои настройки и позволит не переустанавливать заново некоторые программы.

Поэтому мы предлагаем воспользоваться менее радикальным методом и сохранить только содержимое папки С:WINNTSystem32config: это займёт всего 10-30МБ. Причём для этой цели мы не рекомендуем пользоваться каким-либо дополнительным софтом, а просто скопируйте их в другое место. Файлы, содержащиеся в этой папке включают в себя весь реестр W2k, поэтому все проблемы связаные с реестром решаются просто перезаписыванием сбойного реестра старым, гарантированно работающим. Сделать это можно, например, загрузившись с любой досовской загрузочной дискеты.

Однако, если системный раздел отформатирован под NTFS, то Вы не сможете увидеть его, загрузившись с досовской дискеты. Для этого нужен загрузочный диск NT. Для его создания рекомендуем воспользоваться программкой makeboot.exe для DOS или makebt32.exe для Windows. Вам понадобятся 4 чистые дискеты. При загрузке системы с дискет запустится программа установки W2k, такая же как и при загрузке с оригинального CD, так что, если у Вас есть возможность загружаться с такого компакта, то эти четыре дискеты Вам не нужны. Далее Вам будет предложенно установить систему заново, восcтановить её с помощью Recovery Сonsole или с помощью Emergency Recovery Cоnsole. Выбрав пункт Recovery Сonsole нам предложат выбрать, какую из инсталяций W2k необходимо отремонтировать (если в системе их несколько), потом спросят пароль администратора. После этого Вы окажетесь в интерфейсе командной строки. Список поддерживаемых команд невелик: с ним можно ознакомиться командой "help". Для того, чтобы перезаписать реестр можно воспользоваться командой "copy". Кроме этого, стоит отметить ещё несколько команд. Во-первых, это команды "listsvc", "disable" и "enable". Первая выдаёт список системных служб и драйверов с информацией о способе старта. Вторая позволяет отключить службы, которые являются источником проблем. Ну, а третья позволит Вам, наоборот, включить службы или драйвера. Во-вторых, можно отметить команды "fixboot" и "fixmbr", которые восстанавливают загрузочные файлы и master boot record.

Для того, чтобы попасть в Recovery Соnsole вовсе не обязательно использовать загрузочный CD или флопы. Можно установить её на жёсткий диск, тогда каждый раз при загрузке Вы сможете выбирать нужное: загружать систему полностью или загружаться в Recovery Console. Чтобы установить Recovery Console нужно из командной строки в директории i386 дистрибутива W2k набрать winnt32.exe /cmdcons. Но, вообще-то, набор команд доступных с консоли весьма ограничен, и мы бы посоветовали Вам в случае каких-либо неприятностей ставить винт на другую машину, с установленной W2k, она увидит NTFS5 раздел и позволит с ним нормально работать. Если же такой возможности нет, и Вы склоны к экспериментам со своей машиной, то стоит системный раздел отформатировать под FAT32. В противном случае возможна ситуация, когда при крахе системы Вы не сможете добраться до своих данных.

Восстанавливать систему можно при помощи Emergency Recovery Disk. Для этого ERD-диск необходимо предварительно создать. Сделать это можно в окне Backup wizard-а нажатием на кнопку Emergency Repair Disk. При его создании также будет предложено сохранить реестр. Все файлы сохраняются в Winnt/repair. Чтобы использовать ERD, необходимо загрузиться либо с дистрибутивного CD-ROM, либо с четырёх загрузочных дискет, и выбрать пункт Emergency Recovery Console. После этого, восстановление системы будет произведено автоматически. Если системный раздел отформатирован под NTFS, то использование ERD это единственный способо переписать реестр системы без использования другой инсталяции ОС.

Если система загружается хотя бы в safe mode, можно попробовать загрузиться в safe mode с поддержкой командной строки и дать команду "chkdsk /r".

С помощью этих методик можно решить множество возникающих проблем, но далеко не все. Например, ни одна из них не поможет, если в системе установлено неверное ядро.

наверх

(4.2) Как восстановить повреждённый загрузчик W2k?
Загрузиться в Recovery Console и дать команду FIXBOOT. Ещё можно использовать программу Bootpart, загрузившись с досовской дискеты и дав команду "bootpart winnt boot:c:". Кроме того, при помощи этой программы легко конфигурируется загрузка любых ОС NT загрузчиком. Взять программу можно на http://www.winimage.com/ - это официальный сайт её автора.

Кроме этого, всегда можно воспользоваться более радикальным методом, и запустить заново инсталяционную програму W2k, и выбрать там отремонтировать текущую инсталяцию.

наверх

(4.3) Пропали куда-то системные шрифты под W2k, или вообще, система начала вести себя как то странно, перестали работать некоторые программы, появились глюки, которых раньше точно не было. Как это можно исправить?
В командной строке вводишь sfc.exe /scannow - проверить системные файлы (к ним относятся и шрифты) и поставит обратно (возможно, при этом попросит компакт-диск). Естественно, эта методика решит проблему с другими повреждениями системных файлов. Если это не помогает, то можно запустить инсталяцию W2k из под W2k, и выбрать пункт Upgrade to Windows 2000. Но после этого придётся Service Pack, если он не интегрирован в дистрибутив.

наверх

(4.4) У меня в Far-е почему-то отказывается работать мышь. В настройках фара она включена, но работать не хочет :(.
Посмотрите Properties -> Options -> Edit Options. Уберите галочки с пунктов [x] QuickEdit Mode и [x] Insert Mode

наверх

(4.5) Как поменять ядро системы?
В W2k этот процесс упрощён до предела. Больше не надо переставлять всю систему, или использовать внешние утилитки из Resource Kit-а. Ядро меняется в Device Manager -> Computer, как и любой другой драйвер. Но, это ИСКЛЮЧИТЕЛЬНО важно, НЕ СТАВЬТЕ ядро, которое не держится железом. Если не уверены, то лучше ничего не трогать, потому что последствия установки неправильного ядра непредсказуемы. Скорее всего машина просто перестанет загружаться, во всех режимах. (Предотвратить подобное можно подредактировав boot.ini. Нужно всего лишь продублировать рабочий пункт меню выбора ОС.

Например:
multi(0)disk(0)rdisk(0)partition(1)WINNT="Microsoft Windows 2000 Professional" /fastdetect и приписать после /fastdetect следующие опции: /kernel=ntoskchk.exe /hal=halchk.dll, а также в директории WINNTSystem32 сделать копии вашего ядра и HAL-а. Назвать их, конечно же, надо ntoskrnl.exe -> ntoskchk.exe и hal.dll -> halchk.dll).

наверх

(4.6) Как в Recovery Console получить доступ в папки, отличные от \WINNT?
Под аккаунтом администратора заходим в Control Panel -> Administrative Tools. Далее - запускаем апплет Local Security Policy -> Local Policies -> Security Options, опцию "Recovery Console: Allow floppy copy and access to all drives and folders" устанавливаем в Enable. После этого перегружаемся в режим Recovery Console и даем команду SET AllowAllPaths = TRUE.

наверх

(4.7) Как создать диск аварийного восстановления (Emergency Repair Disk)?
Заходим в меню Пуск -> Программы -> Служебные, запускаем программу Архивация данных, на закладке "Добро пожаловать!" нажимаем кнопку "Диск аварийного восстановления". При создании диска также будет предложено сохранить реестр. Сделайте это обязательно! Файлы, необходимые для восстановления, сохраняются в каталоге \WINNT\repair, для надежности их можно скопировать куда-нибудь ещё. Чтобы использовать полученный диск (ERD), необходимо загрузиться либо с дистрибутивного CD-ROM, либо с четырёх загрузочных дискет, и выбрать пункт Emergency Repair Disk. Восстановление будет произведено автоматически.

наверх

(4.8) Можно ли восстановить информацию из зашифрованного средствами W2k файла?
Если не позаботится об этом заранее, то нет (и это логично, ведь шифрование для этого и задумывалось). Ключ, с помощью которого шифруются данные в W2k уникален для каждого пользователя в каждой инсталляции. Он имеет длину до 128 байт, SFC работает на уровне драйверов непосредственно через ядро системы, а ключ хранится в профиле пользователя, поэтому после переустановки системы или удалении пользователя он теряется. Создание другого пользователя с таким же именем и паролем для входа в систему проблему абсолютно бесполезно, и проблему не решает. Одно из возможных решений, это создание ERD диска. Вся необходимая информация по существующим пользователям будет сохранена на диске, и после переинсталляции системы надо будет только восстановиться с ERD. Кроме этого, можно заранее сохранить нужные ключи, и воспользоваться ими. Подробнее про всё это можно почитать здесь http://www.3dnews.ru/reviews/software/win-xp-encrypting/

наверх

(4.9) Как восстановить систему, если поставлено неправильное ядро?
Так как система не загружается, придётся загрузиться либо с другой ОС, либо в recovery console от W2k. После этого останется извлечь нужное ядро из Windows\Driver Cache\i386\driver.cab, скопировать его с Windows\system32, и переименовать его в hal.dll, перезаписав им не правильное. А можно просто сослаться на него в boot.ini. С списком ядер можно ознакомиться здесь:
  • Standard PC - hal.dll
  • Advanced Configuration and Power Interface (ACPI) PC -halacpi.dll
  • ACPI Uniprocessor PC - halaacpi.dll ACPI Multiprocessor PC -halmacpi.dll
  • Compaq SystemPro Multiprocessor or 100% Compatible - halsp.dll
  • MPS Uniprocessor PC -halapic.dll
  • MPS Multiprocessor PC -halmps.dll

Если под рукой есть другой компьютер с W2k, где установлено нужное ядро, то hal.dll можно взять и оттуда.


Win2KFAQ -> Шрифты

Шрифты

(5.1) | Вместо русских букв в некоторых программах показываются закорючки.
(5.2) | В DOS-приложениях не переключается раскладка клавиатуры на русскую, хотя русские буквы отображаются нормально.
(5.3) | При загрузке имя и пароль по умолчанию вводятся русскими буквами. Как это изменить?
(5.4) | В 1С Бухгалтерия 6 вместо русских букв показываются закорючки, что можно с этим сделать?
(5.5) | Региональные настройки настроил, но всё равно, в некоторых местах (например в Photoshop) показываются закорючки.
(5.6) | После перезагрузки исчезает (появляется) русский язык. Как исправить?
(5.1) Вместо русских букв в некоторых программах показываются закорючки.
Запустите апплет Control Panel -> Regional Options. На закладке General есть два раздела, Settings for the current user и Language settings for the system. Первый раздел настраивает локаль для конкретного пользователя и отвечает за то, в каком виде и на каком языке пишется дата, время, какие меры длины используются и так далее. В нашем случае его лучше всего ставить Russian. Второй пункт отвечает, в том числе, и за системные шрифты, это как раз то, что нам и нужно. Необходимо убедиться, что там отмечен Cyrillic и выставить его как default. Откроется окно, Select System Locale, в котором необходимо выставить Russian. После этого, при отбражении всех менюшек и сообщений, W2k будет использовать русскую кодировку. Конечно же, это никак не повлияет на латинские буквы.

наверх

(5.2) В DOS-приложениях не переключается раскладка клавиатуры на русскую, хотя русские буквы отображаются нормально.
  1. средствами W2k. Откройте ключ реестра:

    HKLM\SYSTEM\CurrentControlSet\Control\Keyboard Layout\DosKeybCodes

    Измените значение строковой переменной 00000409 с "us" на "ru" В файле С:\WINNT\System32\autoexec.nt пpописываете следующую стpоку: lh %SystemRoot%\System32\kb16 ru. После перезагрузки системы переключение раскладки клавиатуры в DOS-приложениях будет производиться комбинациями Ctrl+Left Shift (английская) и Ctrl+Right Shift (русская).

  2. поставьте внешний русификатор, например, проверенный временем RKM v.3.0. Удобнее всего прописать его в файле autoexec.nt (аналогично kb16).
    Можно взять здесь: http://www.chem.univ.kiev.ua/~adsh/win2k/soft/rkm.php или
    здесь: http://www.adsh.kiev.ua/win2k/soft/rkm.zip (Украина).

наверх

(5.3) При загрузке имя и пароль по умолчанию вводятся русскими буквами. Как это изменить?
Вообще то, это изменяется во время установки системы, и после этого изменить стандартными методами это нельзя. Но немного отредактировав реестр, можно. Идём по адресу [HKEY_USERS\.DEFAULT\Keyboard Layout\Preload], и видим там в каком порядке переключается раскладка в окне логона, и меняем на то что нам надо. В случае с двумя установленными языками, русским и английским, всё должно выглядеть так:

"1"="00000409" - Английская (США), основная
"2"="00000419" - Русская, дополнительная

Если охота поменять сочетание клавиш, которые переключают раскладку, то и это можно сделать. Для этого идём по адресу [HKEY_USERS\.DEFAULT\Keyboard Layout\Toggle], и редактируем ключ Hotkey. Когда он имеет значение 1, язык переключается через левые Alt+Shift, когда 2, то через левые Crtl+Shift.

наверх

(5.4) В 1С Бухгалтерия 6 вместо русских букв показываются закорючки, что можно с этим сделать?
Это происходит потому, что Microsoft заменил название шрифта MS SANS SERIF на MICROSOFT SANS SERIF, в результате чего 1С Бухгалтерия не может его найти. Для решения проблемы достаточно поменять название шрифта в настройках программы.

наверх

(5.5) Региональные настройки настроил, но всё равно, в некоторых местах (например в Photoshop) показываются закорючки.

Можно, но этот метод не совсем корректен. В ключе реестра [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage] изменяем значение параметра "1252" на "c_1251.nls" Обычно этот метод применяют для Photoshop, но он применим и для некоторых других программ. Но, могут начаться проблемы с русскоязычными программами. Поэтому, мы бы советовали экспортировать этот ключ из реестра, и создать два *.reg файлика, один из которых будет учить такие программы русскому языку, а другой возвращать всё в прежнее состояние. В случае с Photoshop для кардинального решения проблемы следует воспользоваться вот этим (линк на ps601patch110.zip) патчем. Для его использования необходимо пропатчить Photoshop до версии 6.01, что можно сделать скачав патч отсюда ftp://ftp.adobe.com/pub/adobe/photoshop/win/6.x/ps601up.exe Еще одним решением, является использование Photoshop 7 версии, в нём (наконец то) нет проблем с национальными раскладками.

наверх

(5.6) После перезагрузки исчезает (появляется) русский язык. Как исправить?

Менять язык нужно из-под аккаунта администратора - тогда настройки сохранятся. Если вы добавляли (удаляли) язык (не обязательно русский) под пользовательским аккаунтом, то все изменения сохранятся лишь до завершения сеанса работы.


Win2KFAQ -> Сеть

Сеть

(6.1) | Как управлять пользователями, которым можно заходить на компьютер?
(6.2) | Как обеспечить доступ пользователям локальной сети к моим ресурсам?
(6.3) | Как настроить модемное соединение?
(6.4) | Если пытаться звонить в Инет сразу после старта W2k, то окно звонилки открывается не сразу, а через некоторое время.
(6.5) | А как отвечать человеку, который мне шлет с Вин98 по винпопапу всякие сообщения по сети?
(6.6) | Как включить роутинг в Windows 2000 Professional?
(6.7) | Как организовать удаленное управление под W2k? Radmin v.1.1 не pаботает.
(6.8) | Как сделать, чтобы DOS-программа, печатая на LPT1, на самом деле печатала на сетевой пpинтеp [\\server_name\printer_name]?
(6.9) | Слышал, что Terminal Server имеет ограниченый срок использования (потом его нужно будет лицензировать). Правда ли это, и какой срок?
(6.10) | Имеется смешанная сеть, NetWare и NT, клиенты W2kPro и W98. Машины с W98 не могут войти на машины с W2k.
(6.11) | На сервере имеется две сетевые карты, каждая из них смотрит в свой сегмент локальной сети. Роутинг включен. Компьютеры из одного сегмента не видят компьютеры из другого сегмента, хотя всё пингуется.
(6.12) | Как отключить датчик наличия сетевого соединения (Media Sense)?
(6.13) | Как полностью отключить скрытые общие ресурсы (ADMIN$, C$, D$ и т.д.)?
(6.14) | Как настроить роутинг между двумя подсетями на W2kPro?
(6.15) | Компьютеры с W98 по сети открываются очень медленно. Как это ускорить?
(6.16) | Как запретить пользователю логинится локально?
(6.17) | Как запретить пользователю логинится по сети?
(6.18) | Как заставить W2k принимать входящие звонки? В Win9x был Сервер удаленного доступа, а под W2k не могу найти ничего подобного.
(6.19) | Можно ли подключиться к серверу удаленного доступа на Win9x?
(6.1) Как управлять пользователями, которым можно заходить на компьютер?
В W2k есть механизм идентификации пользователей, при этом каждого пользователя можно ограничить в правах. Пользователей, на одной машине может быть множество, и что бы было проще ими управлять, пользователи разбиты на группы. Управление пользователями и пользовательскими группами осуществляется с помощью апплета Users and Passwords в Control Panel. После установки системы, образуется только два пользователя, Administrator и Guest, которые прописаны в закладке Users. Если вы обладаете правами администратора, то вы можете добавить или удалить пользователя в этом окне, можете отредактировать уже существующих, поменять им группу, и т.д. Здесь же можно снять галочку с Users must enter a user name and password to use this computer, что позволит заходить на вашу машину не набирая пароля. Перейдя на закладку Advanced, и нажав там на кнопку Advanced, можно попасть в окно Local users and Groups, которое расширяет возможности по управлению пользователями. В частности, здесь можно отключить (disable) отдельных пользователей, разрешить/запретить им менять свои пароли, и т.д.

наверх

(6.2) Как обеспечить доступ пользователям локальной сети к моим ресурсам?
Сделать это стало немного сложнее, чем в W9х, зато возможностей по настройке стало гораздо больше. Для начала, как и в W9x надо убедиться, что установлен File and Printer Sharing for Microsoft Networks. После этого, открываем Explorer, выбирам диск или директорию, которую хотим расшарить и нажимаем правую кнопку мыши. В открывшемся меню выбираем пункт Sharing. Ставим там Share this folder. Выбираем Share name - имя, под которым данный объект будет виден в сети, и Comment, комментарий, который будет виден там же. Ставим User Limit, количество пользователей которые могут одновременно иметь доступ к объекту.

Теперь осталось определить, кто именно сможет иметь доступ к Вашим файлам. Для этого жмём на кнопку Permissions, и оказываемся в соответствующем меню. После этого, кнопкой Add... добавляем того, кто должен иметь доступ, и выставляем им права доступа. Для домашней сети, где все свои, и прятать ничего не нужно, можно добавить в Share Permissions пользователей Everyone, Guest и группу Guests, а потом установить для них полномочия (При этом полномочия Guests и Guest определяются по Everyone).

После этого, все компьютеры в сети смогут заходить на вашу машину не используя пароля. Не надо забывать, что пользователь Guest по умолчанию, сразу после инсталяции, отключен (disabled). Если его не включить (в Local Users and Groups), то никто не сможет использовать ресурсы (диски, принтеры и т.д.) вашей машины. Вообще-то, политика безопасности для каждой конкретной системы дело весьма тонкое и вариантов здесь множество. Так что не следует принимать наш совет за единственно возможный. Например, если есть желание иметь больший уровень контроля за пользователями, то можно завести на машине нужное число локальных пользователей, имена которых должны совпадать с именами пользователей машин-клиентов. Причем, можно запретить им локальный вход в систему, разрешив только сетевой доступ. Для этого зайдите в Панель управления -> Администрирование -> Локальная политика безопасности -> Параметры безопасности -> Локальные политики -> Назначение прав пользователя, параметр "Локальный вход в систему" - уберите пользователя из списка или в параметре "Отклонить локальный вход" - внесите.

наверх

(6.3) Как настроить модемное соединение?
В W2k объединили Network и Dial-Up connections в одном месте, которое так и называется. Прямо оттуда можно сконфигурировать любое сетевое устройство, хоть модем, хоть сетевую карту. Новые соединения делаются так же как в W9x, с помощью wizard-а Make new connection. Также появились несколько новых функций для управления и настройки Dial-up соединения, которых не было в W9x. Ознакомиться с ними можно взглянув на Properties соединения.

На первой закладке, General, напротив Phone number появилась кнопка, Alternates. Нажав на неё, можно задать целый список телефонов, по которым модем будет звонить, если первый номер в списке занят. Очень полезная функция, когда у провайдера несколько номеров, по которым можно дозваниваться.

Во-вторых, в Configure можно настроить модем, не выходя в другие окна. В-третьих, в Options можно задать массу всяких вещей для звонилки, там же находятся настройки для X.25. В закладке Networking находятся настройки сети для Dial-up соединения. Некоторые из них могут помочь, если компьютер провайдера по непонятной причине разрывает соединение. Если такое случается, то необходимо убедиться, что в Type of dial-up server I calling, стоит PPP: Windows95/98/NT/2000, Internet. Сразу под ней есть кнопочка, Settings. За ней кроется меню из трёх пунктов.

Первый, Enable LCP extentions, которые используются для автоматической настройки некоторых параметров соединения, таких как максимальный и минимальный размеры пакетов, обнаруживает looped-back линки, и другие распространённые ошибки. Однако, Ваш провайдер может не поддерживать эти расширения, что иногда приводит к тому, что компьютер провайдера просто разрывает соединие. К такому же эффекту может привести и разрешение Negotiate Multi-link for single link connections. Эта опция позволяет одновременно использовать два модема и две телефоных линии, при работе с одним провайдером, что позволяет теоретически вдвое увеличить скорость соединения. Enable software compression разрешает сжатие передаваемых данных, поэтому её лучше всего разрешить.

Последняя закладка, Sharing. С помощью этой закладки можно позволить другим компьютерам в локальной сети пользоваться Вашим соединением. Для этого достаточно отметить галочкой Enable Internet Conection Sharing for this connection, а если выбрать Enable on-demand dialing, то от Вас не потребуется даже соединяться самому. Достаточно, что бы Ваш компьютер просто был включен. Когда Ваш коллега откроет у себя IE, то модем сам начнёт звонить. А когда дозвонится, то пользователь абсолютно не будет ощущать, что у него самого модема нет. Всё абсолютно прозрачно: не надо настраивать мэйлеры и броузеры для работы с proxy-сервером (достаточно, выставить LAN connection), ICQ, mIRC и даже BattleNet будут работать так, словно модем стоит у клиента, а не на другой машине в локальной сети. Если возникают сложности, то необходимую службу можно добавить вручную. Для этого нажимаем на кнопку Settings... и в открывшемся окне добавляем нужную службу или приложения. Для этого надо знать, по какому порту программа или служба будет принимать сообщения и по какому отправлять. Для того, что бы Connection Sharing заработал, необходимо выполнить ещё несколько условий. IP адрес машины с модемом для локальной сети (выставляется в Properties Local area network connection -> Properties для Internet Protocol (TCP/IP)), должен быть 192.168.0.1.

У клиентов же, надо просто поставить Internet Protocol (TCP/IP). Никаких адресов им присваивать не надо, нужно отметить Obtain IP adress automatically. Локальная сеть, естественно, тоже будет работать, просто клиент будет сам себе генерировать адрес из пространства 192.168.0.x. Причём, всё вышеперечисленное относится и к клиентам с W98.

Также нужно отметить, что изменился механизм хранения паролей. Если сохранить пароль для соединения с Интернет галочкой Remember password, то при следующем соединении вместо пароля нарисуются 16 звёздочек. Не надо впадать в панику, это просто механизм защиты пароля, сам пароль будет передан в том виде, в котором Вы его ввели. Правда некоторое, очень ограниченое число провайдеров, могут не поддерживать этот механизм. В этом случае, можно порекомендовать использовать скрипт, в котором пароль будет храниться и отсылаться в открытом виде. Но учтите, что любой, кто получит доступ к Вашей машине, сможет с лёгкостью узнать Ваш пароль.

наверх

(6.4) Если пытаться звонить в Инет сразу после старта W2k, то окно звонилки открывается не сразу, а через некоторое время.
Причина в том, что при запуске W2k не запускаются автоматически все необходимые для Dial Up службы. Для управления системными службами, запускаемыми при старте, служит апплет Control Panel -> Administrative Tools -> Services. При запуске Services увидите список служб, их текущее состояние, статус, и метод запуска, автоматически (Automatic), вручную (Manual), или не запускаются ни при каких обстоятельствах (Disabled). В Properties каждого процесса имеется возможность выставить метод старта для процесса, и некоторые параметры, которые будут переданы службе при её старте. Для нашего случая, необходимо убедиться, что бы в автоматическом режиме запускались следующие службы: Remote Access Connection Manager и Telephony. Однако, если вы не уверены в том что делаете, то лучше не трогать ничего остального - последствия могут быть довольно неприятны.

наверх

(6.5) А как отвечать человеку, который мне шлет с Вин98 по винпопапу всякие сообщения по сети?
Для этого можно воспользоваться кносольной командой net send. Для того что бы ознакомится с её возможностями, прочитайте справку: net send /? Кроме этого, можно в Computer Management выбрать Action -> All Tasks -> Send Console Message. А вообще, под W2k удобнее использовать для посылки сообщений друг другу программу winchat.

наверх

(6.6) Как включить роутинг в Windows 2000 Professional?
Придется заняться правкой реестра:

Раздел: SYSTEM \ CurrentControlSet \ Services \ Tcpip \ Parameters
Параметр 9
Hазвание: IPEnableRouter
Тип: REG_DWORD
Значение: 0
Вместо нуля прописываем "1".

наверх

(6.7) Как организовать удаленное управление под W2k? Radmin v.1.1 не pаботает.
  1. Используйте Radmin v.2.01 с http://www.famatech.com/russian/
  2. Terminal Service. Идет в стандартной поставке W2k Server.
  3. Remote Control - можно скачать с авторского сайта: http://www.dataset.fr/
  4. Georgia SoftWorks Telnet Server - http://www.georgiasoftworks.com/

наверх

(6.8) Как сделать, чтобы DOS-программа, печатая на LPT1, на самом деле печатала на сетевой пpинтеp [\\server_name\printer_name]?
Точно так же, как и в NT4. Вводим из консоли:

net use lpt1: [\\Server_Name\Printer_Name]

При завершении работы программы можно освободить порт:

net use lpt1: /d

наверх

(6.9) Слышал, что Terminal Server имеет ограниченый срок использования (потом его нужно будет лицензировать). Правда ли это, и какой срок?

Terminal Server может устанавливаться в двух вариантах - для удаленного администрирования и как сервер приложений (Application Server). Для первого варианта лицензия не требуется, а для второго существует ограничение в 90 дней, после чего нужно будет зарегистрироваться на сайте Microsoft: https://activate.microsoft.com/ и получить свой регистрационный код. Подробнее о лицензировании можно почитать там же, по адресу: https://activate.microsoft.com/faq.asp - Terminal Services License FAQ. Этот FAQ вообще полезно почитать, что бы знать, к чему следует готовиться. Что то мне кажется, что в будущем подобная система лицензирования будет использоваться не только для Terminal Server...

наверх

(6.10) Имеется смешанная сеть, NetWare и NT, клиенты W2kPro и W98. Машины с W98 не могут войти на машины с W2k.
Для решения этой проблемы необходимо сделать привязку по протоколам, IPX/SPX только к клиент Novell, TCP/IP только к клиенту Microsoft. Сделать это можно в свойствах сетевых подключений меню advanced закладка - advanced setting.

наверх

(6.11) На сервере имеется две сетевые карты, каждая из них смотрит в свой сегмент локальной сети. Роутинг включен. Компьютеры из одного сегмента не видят компьютеры из другого сегмента, хотя всё пингуется.
Для того что бы компьютеры из разных сегментов видели друг друга в Сетевом окружении, самое правильное WINS на сервере установить и настроить. Но можно попробовать просто прописать адреса и имена всех машин в сети в файлике hosts в %SystemRoot%.

наверх

(6.12) Как отключить датчик наличия сетевого соединения (Media Sense)?
Определение состояния сетевого соединения возможно при использовании протокола TCP/IP в сети на витой паре. При отсутствии соединения в тpее появляется значок "Network Cable Unplugged" и сетевое соединение отключается. После этого компьютер теряет свой сетевой адрес и отвечает только на адрес 127.0.0.1, что может повлиять на работоспособность многих сетевых программ. Для мобильных или домашних пользователей в таком случае будет полезно отключить эту возможность. Для этого в разделе HKLM\System\CurrentControlSet\Services\Tcpip\Parameters реестра параметр DisableDHCPMediaSense (тип REG_DWORD) нужно установить в "1". Более подробно почитать об этой проблеме можно здесь: http://support.microsoft.com/support/kb/articles/Q239/9/24.ASP?LN=EN-US

наверх

(6.13) Как полностью отключить скрытые общие ресурсы (ADMIN$, C$, D$ и т.д.)?
Данные скрытые ресурсы существуют по умолчанию. Доступ к ним возможен только из под аккаунта администратора, поэтому не рекомендуется задавать для этого аккаунта слишком простой пароль (например, Enter :)). Для увеличения степени секретности можно также изменить имя пользователя "Администратор" на другое. Если удалить эти ресурсы через "Управление компьютером" -> "Общие папки", то после перезагрузки они появятся снова. Полностью отключить скрытые ресурсы можно только с помощью правки реестра. Откройте раздел

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

Добавьте или измените следующие значения:

Операционная система | Параметр | Тип | Значение
Windows 2000 Server | AutoShareServer | REG_DWORD | 0
Windows 2000 Professional | AutoShareWks | REG_DWORD | 0

Однако, этот метод не уберёт sharing с IPC$. Для того что бы полностью избавиться от всех административных шарингов, создайте BAT или CMD файлик следующего содержания, и вставьте его в автозагрузку.

net share c$ /delete
net share d$ /delete
net share e$ /delete
.
.
net share admin$ /delete
net share ipc$ /delete

наверх

(6.14) Как настроить роутинг между двумя подсетями на W2kPro?
Это нужно когда на машине с W2k имеется две сетевые карты, одна из которых смотрит в одну подсеть, а другая в другую. Для того что бы компьютеры из разных подсетей могли видеть друг друга, на машине с W2k надо прописать маршруты роутинга, какие пакеты откуда и куда пересылать. Для этого в командной строке вводим:

route -p add subnet1 mask 255.255.255.0 interface1_ip IF 1

,где subnet1 – первая подсеть (например 192.168.1.0, если адреса в ней имеют вид 192.168.1.*)
interface1_ip – IP адрес сетевой карты смотрящей в первую подсеть.

и

route -p add sunbet2 mask 255.255.255.0 interface2_ip IF 2

,где subnet2 – вторая подсеть (например 192.168.2.0, если адреса в ней имеют вид 192.168.2.*)
interface2_ip – IP адрес сетевой карты смотрящей в вторую подсеть.

Маска подсети, конечно же, должна соответствовать реально используемой маске (255.255.255.0, это сеть класса С, наиболее часто используемая).

наверх

(6.15) Компьютеры с W98 по сети открываются очень медленно. Как это ускорить?
Происходит это из за того, что W2k каждый раз сканирует сеть на наличие сетевых принтеров и отложенных заданий (Scheduled Tasks). Для того что бы он этого не делал, достаточно удалить две папки из реестра. Находятся они по адресу HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/CurrentVersion/Explorer/Remote Computer/Name Space И называются {2227A280-3AEA-1069-A2DE-08002B30309D} для принтеров и {D6277990-4C6A-11CF-8D87-00AA0060F5BF} для отложенных заданий.

наверх

(6.16) Как запретить пользователю логинится локально?
Это может понадобиться, например, для пользователей которые пользуются ресурсами вашего компьютера только по сети. Что бы запретить такому пользователю логиниться локально, запускаем апплет Local Security Policy (Control panel – Administrative Tools), и переходим в рездел Local Polices – User Right Assignment. Находим здесь ключ Deny logon locally, дважды кликаем на нём, и добавляем (Add…) пользователей которым требуется запретить логинится локально.

наверх

(6.17) Как запретить пользователю логинится по сети?
Запускаем апплет Local Security Policy (Control panel – Administrative Tools), и переходим в рездел Local Polices – User Right Assignment. Находим здесь ключ Access this computer from the network, дважды кликаем на нём, и получаем возможность удалить группу, члены которой не должны иметь доступ к компьютеру из сети. Если вам понадобиться разрешить доступ члену удалённой группы, его придётся добавлять индивидуально, через кнопку Add…

наверх

(6.18) Как заставить W2k принимать входящие звонки? В Win9x был Сервер удаленного доступа, а под W2k не могу найти ничего подобного.
Заходим в меню Пуск (Start) -> Панель Управления (Control Panel) -> Сеть и удаленный доступ к сети (Network and Dial-up Connections) -> Файл (File) -> Hовое подключение (Make New Connection) -> Принимать входящие подключения (Accept Incoming Connections). Этот пункт активен только под логином администратора. В версии Professional возможно создать только одно входящее соединение, в версии Server их число ограничено числом установленных модемов.

наверх

(6.19) Можно ли подключиться к серверу удаленного доступа на Win9x?
Да, можно. Зайдите в Свойства соединения, закладка "Безопасность" -> "Дополнительные (особые параметры)" -> "Hастройка" -> "Разрешить следующие протоколы" -> опция "Разрешить старый протокол MS-CHAP для Windows 95".


Win2KFAQ -> Железо

Железо

(7.1) | Машина с ATX блоком питания не выключает питание самостоятельно.
(7.2) | Как получить поддержку функций управления питанием на SMP машинах?
(7.3) | Как мне включить ACPI? Смена ядра приводит к синему экрану с надписью "Inaccessible Boot device":(. БИОС ACPI поддерживает.
(7.4) | У меня есть Iomega Zip Drive. Он не определяется автоматически, надо ли скачивать для его драйвера?
(7.5) | После перезагрузки Win2k не находит внешний модем. Что делать
(7.6) | При работе полноэкраных Direct3D и OpenGL приложений, очень низкий refresh rate, как можно это исправить?
(7.7) | Как включить в W2k поддержку режимов Ultra DMA?
(7.8) | Как добавить в W2k поддеpжку Ultra DMA66, если она отсутствует?
(7.9) | При печати на принтере (подключен через LPT) загрузка процессора 100%. Все остальное, соответственно, притормаживает. Как можно побороть?
(7.10) | Можно ли на многопроцессорных системах ставить разные процессоры?
(7.11) | Как установить поддержку двух мониторов в W2k?
(7.12) | Как поменять IRQ используемые различными устройствами? В их Properties в Devise manager чекбокс Use automatic Settings затемнён, и снять его не удаётся.
(7.13) | На моём CD-ROM нет CD-CPDIF выхода, или, по какой то причине я не могу его использовать. Можно ли мне как-нибудь получить числовой звук для CD-Audio?
(7.14) | Как заставить работать под Win2K звуковую карту на Vortex 2?
(7.15) | Ничего не получается с hackmon.inf, чего делать?
(7.16) | Можно ли заставить работать Norton Speed Disk при запущенной службе терминал-севера? Надоело каждый раз её останавливать, а потом снова запускать.
(7.17) | Как заставить под W2k работать старые сканеры HP серий II, III, 4?
(7.18) | Как поставить драйвер сканера ScanJet 5p (чип от Symbios Logic 53C416) на win2000prof?
(7.19) | Как завести под W2k старый CD рекордер? Например, CD-recorder Yamaha CDR-100 (SCSI) определяется, но никаких драйверов на него не ставится.
(7.20) | Мой 12х CD Recorder записывает диск за 15 минут, а должен за 6. А везде пишется, что запись прошла на скорости 12x, почему так происходит и что делать?
(7.21) | В спящем режиме W2k не выключает вентиляторы.
(7.22) | Как добиться, чтобы модем брал трубку с N-ного звонка?
(7.23) | Как заменить материнскую плату без переустановки системы?
(7.24) | Модем не хочет звонить в пульсовом режиме new
(7.1) Машина с ATX блоком питания не выключает питание самостоятельно.
Основным режимом работы для W2k считается ACPI режим, и именно вокруг ACPI построено управление питанием. Проблема в том, что до выхода W2k все возможности ACPI нигде толком не использовались. Поэтому производители железок не сильно заморачивались с обеспечением нормальной поддержки оного. Что привело к проблемам с работой таких устройств под w2k. То есть, само устройство может работать нормально, но когда система пытается управлять питанием, например выключить компьютер, то проблемное устройство не даёт ей этого сделать. Для решения этих проблем в W2k предусмотрен APM режим, но даже он не всегда решает проблему. Но всё по порядку. Прежде всего необходимо выяснить, Ваша машина работает в ACPI режиме, или нет. Для этого можно обратиться в System Properties, но выяснить и через Control Panel - Power Options. При использовании стандартного ядра в этом окне не будет возможности запрограммировать кнопки питания на определённое действие. Кроме этого, в этом окне может присутствовать закладка APM. Если она есть, то надо убедиться что на параметре Enable Advanced Pоwer management support стоит галочка. Если ничего похожего нет, то Вам может помочь установка NT Apm/Legacy Support. Для того чтобы про проверить установлена ли она, необходимо в Device Manager выбрать меню View - Show hidden Devices. В списке добавившихся устройств Вы должны увидеть NT Apm/Legacy Interface Node. Если его нет, то установите его через Add New Hardware Wizard. После этого, взгляните в Device Manager ещё раз. Если NT Apm/Legacy Interface Node функционирует нормально, а компьютер всё равно не выключается, то попробуйте по адресу HKEY_LOCAL_MACHINE -> SOFTWARE -> Microsoft -> Windows NT -> CurrentVersion -> Winlogon выставить ключ PowerdownAfterShutdown равным 1. Если железо (ВСЁ железо) позволяет (строго соответствует требованиям стандарта) всё должно заработать.

Примечание: Нормальная работа компьютера под W9x ничего не гарантирует, у некоторых железок поддержка APM функций в её среде сделана не правильно, не через стандартные методы, а всевозможные «хаки», как аппаратные так и программные. Естественно, что такое оборудование не будет нормально работать с функциями управления питанием в среде W2k, и будет препятствовать выключению компьютера.

Если NT Apm/Legacy Interface Node появился в Device Manager, но не работает (обозначен жёлтым кружком с восклицательным знаком, или чем то вроде этого), это значит что Ваш компьютер не соответствует представлениям Microsoft о современном компьютере, и пока причина этого не устранена, увы, компьютер самостоятельно выключаться не будет. Причиной столь печального явления, обычно является материнская плата, и есть шанс, что обновлением Bios это можно решить. Более того, обновление Bios может сделать Вашу материнскую плату ACPI совместимой.

ACPI режим считается основным для W2k, поэтому проблемы с выключением при его использовании бывают гораздо реже. Если они всё-таки возникают, то причиной этого может быть как плохой Bios, так и не соответствующее требованиям ACPI устройство или драйвер (хотя в этом случае система чаще виснет при выключении, а не выкидывает окно с просьбой выключить компьютер вручную). Поэтому поиски решения стоит начинать, прежде всего, на сайте производителя Вашей материнской платы, в разделе биосов. Если это не поможет, то можете попробовать повытаскивать из компьютера все необязательные устройства, возможно что именно так удастся отловить проблему. Вообще, причины неправильной работы ACPI могут быть самыми разными, и найти что именно мешает бывает совсем не просто.

Наиболее часто встречаются следующие причины:

Не соответствие материнской платы требованиям ACPI. Хорошо если проблема кроется только в BIOS, что решается его обновлением, но иногда встречается и аппаратная несовместимость.

Не соответствие требованиям ACPI какого-либо устройства или его драйвера. Опять же, хорошо если проблема только в неправильно написанном драйвере, тогда есть надежда что когда-нибудь будет написан нормальный драйвер, и всё заработает как следует. К сожалению, возможна ситуация когда несовместимость аппаратная.

Причиной сбоев в работе ACPI может быть и программное обеспечение установленное на компьютере. Причём проблемы могут вызывать самые различные программы, от программ для шифрования (вроде PGP), до программ для очистки реестра. Посоветовать можно использовать только протестированные и полностью совместимые с W2k или XP версии программ что, к сожалению, не всегда возможно. Кстати, несовместимость программного обеспечения может приводить не только к тому что компьютер не будет выключаться вообще, но и к тому что компьютер будет выключаться, но очень медленно (окно с надписью saving you settings может висеть 5, 10 или даже 30 минут).

наверх

(7.2) Как получить поддержку функций управления питанием на SMP машинах?
Как уже упоминалось выше, спецификации APM не предусматривают существования многопроцессорных систем поэтому бесполезно даже искать закладку APM в Control Panel -> Power Options если в системе установлено многопроцессорное ядро. Единственный выход - это использовать ACPI Multiprocessor ядро. Однако, для этого вы должны иметь ACPI совместимую систему. Если ваша система не соответствует, можно попробовать обратиться к производителю вашей материнской платы за обновлённым BIOS, зачастую это решает проблему. Если же ваша система успешно проходит эти тесты, можно попробовать поменять ядро на ACPI multiprocessor.

НО, НЕ СТАВЬТЕ ACPI ядро на машины BIOS или железо которых не поддерживает его, в этом случае компьютер гарантировано перестанет загружаться, и вам придётся переставлять всю систему. Если же, всё-таки, решились на такой эксперимент, то, по крайней мере, обеспечьте себе возможность альтернативной загрузки с другим ядром. Про то, как это сделать, написано в этом FAQ. Впрочем, даже соответствие материнской платы спецификациям ACPI не гарантирует нормальную загрузку системы после замены ядра. Однозначного рецепта здесь нет, но если система после замены ядра доходит до этапа графической загрузки (это когда рисуется цветная картинка), то это означает что, скорее всего, ваша машина сможет работать в ACPI режиме. Но, скорее всего, придётся переустановить всю систему. Кроме этого, даже если установка системы прошла удачно, это не гарантирует, что система будет полностью поддерживать ACPI (Hibernate, Stand-By, программирование Power button, и т.д.), более-менее уверенными вы можете быть только в том, что машина будет самостоятельно выключать питание. Для поддержки всего спектра возможностей ACPI необходима поддержка не только со стороны материнской платы, но и со стороны установленной на ней устройств и их драйверов. Например, поддержка Hibernate может пропасть после установки W2k драйвера для Voodoo3, или Sound Blaster128. Список этот гораздо длиннее, так что ничему не удивляйтесь после установки ACPI ядра.

наверх

(7.3) Как мне включить ACPI? Смена ядра приводит к синему экрану с надписью "Inaccessible Boot device":(. БИОС ACPI поддерживает.
Это происходит потому, что БИОС Вашей материнской платы не сертифицирован как GoodACPIBios, а именно этот режим требуется по умолчанию. Придется переустановить W2k с использованием 4-х загрузочных дискет (создаются с помощью makeboot.exe или makebt32.exe из каталога BOOTDISK) и исправлением txtsetup.sif как показано ниже:

[ACPIOptions]
This section lists options that affect the installation of ACPI on x86 ACPIEnable

0 - ACPI will be disabled at install time regardless of the BIOS
1 - ACPI will be enabled at install time if an ACPI BIOS is present
2 - ACPI will be enabled based on the GoodACPIBios list, the NWACL and ACPIBiosDate

ACPIBiosDate = mm,dd,yyyy Supplies the date that a BIOS must have to be considered good if it is not in the GoodACPIBios list. If a BIOS has a date greater than this and is not in the NWACL list, then it will be used unless ACPIEnable = 0

[ACPIOptions] ACPIEnable = 2 ^^^^^^^^^^^^^^вот здесь исправляем на ACPIEnable = 1 ACPIBiosDate = 01,01,1999

наверх

(7.4) У меня есть Iomega Zip Drive. Он не определяется автоматически, надо ли скачивать для его драйвера?
Драйвер для внешнего ZIP drive, подключаемого через порт принтера входит в саму операционную систему. Но, сам привод не определяется автоматически. Для решения этой проблемы необходимо зайти в Device Manager, выбрать там Properties порта принтера. На закладке Port Settings отметить галочкой Enable legacy Plug and Play detection. Теперь, если Zip drive включен, то он сам автоматически проинсталируется, как Generic volume в Storage volumes. Подобного эффекта можно добиться если скачать обновление с http://www.microsoft.com/windows2000/downloads/

Кроме этого, можно использовать драйвера производителя, с http://www.iomega.com/.

Если вы используете внутрений привод, то возможна ситуация, когда система будет упорно отказывать видеть диск в приводе, если его не было в момент загрузки. Для решения этой проблемы необходимо в BIOS принудительно поставить ZIP drive как винчестер. Правда, в этом случае, при загрузке с диском W2k может потребовать проверить диск на наличие сбойных блоков, но это можно проигнорировать, система будет работать нормально.

наверх

(7.5) После перезагрузки Win2k не находит внешний модем. Что делать?

Если не включить внешний модем перед загрузкой W2k, то система может и не найти его. Для того что бы «разбудить» его, достаточно зайти в Device Manager, и произвести поиск новых устройств (Scan for hardware changes), модем будет найден и включен. Что бы не приходилось этого делать каждый раз, когда Вы забудете включить модем перед загрузкой системы, придётся поставить не PnP версию драйвера для этого модема. Поискать её можно в *.inf файле для этого модема (для чего достаточно указать при установке что драйвера будут ставится вручную, и что надо показывать все устройства, а не только совместимые). Если там такой версии нет, то придётся ограничиться установкой какого-либо стандартного драйвера, например Standart Modem. Если Ваш модем соответствует понятиям системы о стандартном модеме (а это так и есть с большинством модемов для COM порта), то всё будет славно работать, вне зависимости от того, сколько раз и когда модем включался и выключался.

Недостатком этого метода является то, что для Standart Modem нельзя включить некоторые полезные настройки, например аппаратную компрессию данных. С другой стороны, для него всё равно можно задать строку инициализации, и если изучить инструкцию к модему, то в этой строке можно включить и настроить всё что угодно.

Ещё одним вариантом решения проблем с внешними устройствами является использование режима Hibernate вместо полноценной перезагрузки системы. Ну и, наконец, можно один и тот же модем установить два раза (можно даже оба раза PnP). Тогда, как ни странно, хоть система и не найдёт первый модем после загрузки, она сможет работать со вторым. Конечно же, второй можем должен быть указан в свойствах соединения.

наверх

(7.6) При работе полноэкраных Direct3D и OpenGL приложений, очень низкий refresh rate, как можно это исправить?
Сделать это можно, и связано это с тем КАК NT работает со своей графической подсистемой. Есть несколько способов. Если драйвера видеокарты позволяют, то делается это легко и красиво. На примере с референсными драйверами от nVidia, это делается так:

В архиве с драйверами есть файл nv4_displ.inf, а в нём раздел nv_SoftwareDeviceSettings. Ищите там раздел относящийся к вашей видеокарте, первая TNT, например, обозначается аббревиатурой NV4. В списке NV4_MODES просто удаляете ненужные значения. Например, оригинальная запись выглядит так:

HKR,, NV4_Modes, %REG_SZ_APPEND%, "16 640 480 60 70 72 75 85 100 120 0"

Приводим её в такой вид:

HKR,, NV4_Modes, %REG_SZ_APPEND%, "16 640 480 100 120 0"

И всё, теперь ваша видеокарта физически не сможет работать в разрешении 640*480 с глубиной цвета 16 бит с Refresh rate меньше, чем 100 герц в любых программах (Во всяком случае W2k именно так и считает, поэтому будет использовать для Refresh Rate цифры, которые здесь указаны). После этого нужно всего лишь переустановить драйверы с измененным nv4_displ.inf.

Естественно, цифры можно ставить любые, даже нестандартные. Однако, здесь надо соблюдать осторожность, потому что существует возможность испортить монитор слишкой высокой Refresh Rate либо после перезагрузки вы не увидите своего десктопа, вообще ничего. Эта методика подходит и для других драйверов не только от nVidia, например, SiS.

Однако, этот совет из не подходит для пользователей многих весьма популярных видеокарт, например таких как Voodoo, Matrox, или ATI. Однако, они тоже не хотят портить себе зрение смотря на 60 герцовую картинку в OpenGL, Direct3D, Glide или каких либо других приложениях. В этом случае, можно попытаться сказать XP, что ваш монитор не способен работать с refresh rate ниже той, что нам требуется. Для этого можно воспользоваться нашим "хакнутым" драйвером монитора http://www.3dnews.ru/documents/971/hackmon.zip.

Редактируя строки вроде: HKR,"MODES800,600",Mode1,,"35-90,85-100,+,+" можно добиться желаемого. Например, в нашем примере эта строка запрещает монитору работу в 800*600 с любыми рефрешами кроме 85 или 100 Hz, в ЛЮБЫХ режимах. Удостоверьтесь, только, что отмечен чекбокс "Hide modes that this monitor cannot display". Но, будьте осторожны, и используйте только те значения, которые реально поддерживаются вашим монитором, в противном случае последствия могут быть неприятными, вплоть до ПОЛНОГО ВЫХОДА МОНИТОРА ИЗ СТРОЯ.

Если у вас карта nVidia, то вы можете воспользоваться специальной утилитой Riva Tuner. Скачать можно здесь - http://www.3dnews.ru/download/tweak/video/rivatuner/

наверх

(7.7) Как включить в W2k поддержку режимов Ultra DMA?
Идем My Computer -> Properties -> Hardware -> Device Manager -> IDE ATA/ATAPI controllers -> Primary(Secondary) IDE Channel -> Properties -> Advanced Settings.

Там смотрим Current Transfer Mode. Если стоит "Ultra DMA Mode" - то все в порядке, если нет - выставляем в поле Transfer Mode "DMA, if available", и перезагружаемся. Если контроллер IDE и жесткий диск поддерживают режим UDMA, то после перезагрузки этот режим заработает.

И ещё - если у вас на каком-либо IDE канале из двух возможных устройств стоит только одно, то отключите автоопределение второго на закладке "Advanced settings" вкладки "Primary (secondary) IDE channel properties", находящейся в Device manager (поставьте Device Type в None). Это слегка ускорит процесс загрузки Windows.

наверх

(7.8) Как добавить в W2k поддеpжку Ultra DMA66, если она отсутствует?
Делается это очень просто - следует добавить в реестр параметр:

HKLM \ System \ CurrentControlSet \ Control \ Class \ {4D36E96A-E325-11CE-BFC1-08002BE10318} \ 0000 \ EnableUDMA66=1
Для того чтобы снова отключить - либо удалить параметр, либо поставить его в 0. Тип параметра DWORD.

наверх

(7.9) При печати на принтере (подключен через LPT) загрузка процессора 100%. Все остальное, соответственно, притормаживает. Как можно побороть?
Можно попытаться выставить галочку "Use any interrupt assigned to the port" на закладке Port Settings свойств LPT-порта.

наверх

(7.10) Можно ли на многопроцессорных системах ставить разные процессоры?
Можно. Причём как разные по частотам, так и разные по моделям, но одного семейства. Единственное условие, чтобы частота шины была одинаковой. К примеру, можно установить Celeron 300 и PII 450. Но оба процессора должны работать на одинаковой шине, то есть придётся либо опускать частоту PII до 300, либо разгонять Celeron 300 до 450. Более того, можно ставить процессоры с разными form-factor, например Slot 1 PIII500 и PPGA Celeron 333. Единственное условие, процессоры должны одинаково поддерживать некоторые функции, например:

- FXSR
- XMMI (наворочанные наборы команд по типу MMX)
- PAT
- MTRR (таблицы управления кэшированием областей памяти, вшитые в процессор)
- CMPXCHG8B
- global pages

Иначе ядро упадет при старте по MULTIPROCESSOR_CONFIGURATION_NOT_SUPPORTED, с субкодом ошибки – какая конкретно функция не совпала.

Также можно ставить процессоры с разными частотами, например, 366 и 466. Но, в этом случае, становятся неизбежны некоторых проблемы. Приложения чувствительные к скорости обработки команд процессором, например, некоторые игры, будут работать с рывками и станут абсолютно неиграбельными, хотя сама ОС не обратит на это никакого внимания.

наверх

(7.11) Как установить поддержку двух мониторов в W2k?
Мы не будем здесь раcсматривать технологии вроде Matrox’ского DualHead, а поговорим о более "народном" методе с двумя видеокартами. Для того, чтобы использовать две видеокарты необходимо в BIOS, в Integrated Peripherals выставить Init Dysplay First - PCI, потому что, если первой будет инициализироваться AGP видеокарта, то Windows не запустит PCI плату. Естественно это имеет значение, только если используются AGP и PCI видеокарты, в случае с двумя PCI платами таких проблем не возникает. После того, как система загрузится, будут установленны драйвера для каждой из видеокарт, и в Display Properties появятся два адаптера. Любой из них может быть выставлен основным адаптером (вне зависимости от того, какой инициализировался первым), и для каждого из них может быть выставленно своё разрешение и частора развёртки. И, конечно же, на каждый из мониторов может быть установлен наш хакнутый http://www.3dnews.ru/documents/971/hackmon.zip. :-). К сожалению, далеко не все програмы могут правильно разобраться на каком из видеоадаптеров стартовать (особенно это касается игрушек), что приводит либо к тому, что приложение зависает, либо загружается, висит в памяти, но не выводится ни на один из мониторов. Иногда такие програмы можно обмануть отключив один из мониторов (снятием галочки с Extend windows decktop on this monitor), и включив его после запуска программы. Но не всегда. То есть, программа, конечно же, запустится на одном мониторе (если она вообще может запускаться на вашей машине), но при включении второго монитора она может вылететь.

наверх

(7.12) Как поменять IRQ используемые различными устройствами? В их Properties в Devise manager чекбокс Use automatic Settings затемнён, и снять его не удаётся.
Для того, что бы появилась возможность вручную переназначать прерывания, необходимо выключить поддержку ACPI во всех видах. Для этого необходимо поменять ядро на Standart PC (или MPS multiprocessor в случае с SMP системой). Не будет лишним отключить ACPI контролёр в Bios, раздел Power management. Очевидным минусом этого метода является то, что с высокой долей вероятности машина перестанет самостоятельно выключаться. К сожалению, кроме как выключив режим ACPI добиться возможности вручную переназначать ресурсы нет, так что придётся делать выбор, либо компьютер выключается самостоятельно, либо ресурсы распределяются так, как Вам хочется.

наверх

(7.13) На моём CD-ROM нет CD-CPDIF выхода, или, по какой то причине я не могу его использовать. Можно ли мне как-нибудь получить числовой звук для CD-Audio?
Можно. W2k позволяет передавать audio информацию с AudioCD через IDE шлейф в числовом виде. Для того что бы задействовать эту функцию, достаточно в Device Manager на Properties CD привода на второй закладке выставить галочку в чекбоксе "Enable Digital CD-Audio for this CD-ROM device." Естественно, что после этого Вам не потребуется проводок который обычно подключают от CD-ROM к звуковой карте, всё будет идти через IDE шлейф.

наверх

(7.14) Как заставить работать под W2k звуковую карту на Vortex 2?
Некорректная работа звуковых карт на чипсете Vortex 2 и его разновидностях проявляется на материнских платах под процессоры AMD на чипсетах от VIA. Вероятнее всего, это аппаратная несовместимость, но может помочь и установка самых последних драйверов: wdm5_12_01_2559.exe (а может и не помочь :((). При установке драйверов внимательно следуйте инструкции (взято с сайта http://dac.hardware.ru/):

Для корректной установки новых драйверов необходимо сначала удалить старые. Так как драйвера не имеют цифровой подписи, придется сделать следующие шаги.

Удаление:

  1. В Settings->Control panel->system->Device manager сделать uninstall Aureal Vortex PCI adapter.
  2. Из директории c:\winnt\inf удалить следующие файлы: "wdma_aur.inf", "wdma_aur.pnf", "adm_mult.inf", "adm_mult.pnf", "adm_port.inf", "adm_port.pnf".
  3. В директории c:\winnt\driver cache\i386 переименовать "driver.cab", например, в "driver.cat".
  4. В меню "Tools" выбрать "View", установить флажок "Show all hidden files", убрать флажки "Hide file extensions for known file types" и "Hide protected operating system files".
  5. В появившейся директории c:\winnt\system32\dllcache удалить файлы "adm88xx.sys", "admjoy.sys".
  6. В директории c:\winnt\system32\drivers удалить те же файлы "adm88xx.sys", "admjoy.sys".

Установка:

  1. В процессе установки будут запрошены файлы, расположение которых нужно будет указать следующим образом: "ksuser.dll" -> c:\winnt\system32, "ks*.dll" -> c:\winnt\system32\drivers, "*.drv" -> c:\winnt\system32, "portcls.sys" -> c:\winnt\system32\drivers, "aurealgm.arl" -> выбрать директорию, из которой устанавливаются драйвера.
  2. По окончании процесса установки нужно переименовать "driver.cat" обратно в "driver.cab".Не забываем, также устанавливать движек аппаратного ускорения на максимум, чтобы работало A3D!

наверх

(7.15) Ничего не получается с hackmon.inf, чего делать?
Если hackmon.inf у Вас по какой то причине не работает, то можно попробовать отредактировать соответствующие значения реестра вручную. Для этого заходите в HKEY_LOCAL_MACHINE \SYSTEM \ControlSet \Enum \DISPLAY, и дальше на две папки вглубь (их название зависит от установленного у Вас монитора, поэтому я не привожу никакого). В этой папке должны быть несколько ключей, в том числе CalssGUID и Driver. Берём название драйвера (это будет 4D36E96E-E325-11CE-BFC1-08002BE10318, стандартное значение для мониторов), идём в начало реестра и делаем поиск на это значение. Оно встретится несколько раз, в HKEY_LOCAL_MACHINE \SYSTEM \ControlSet \Control \Class \4D36E96E-E325-11CE-BFC1-08002BE10318 \0000 (или 000х, если в системе стояло несколько мониторов, тот что Вам нужен прописывался в ключе Driver, в предыдущем абзаце), и его копиях, ControlSet00x. В этих разделах находим Modes, и видим папки для каждого из стандартных разрешений. В каждой из них имеется ключ Mode1, который и определяет значения Refresh Rate для этого разрешения. Ключ этот имеет значения "30-96, 60-120,+,+", или что-то похожее, где первые две цифры означают возможные значения вертикальной развёртки в килогерцах, а вторые две значение горизонтальной развёртки в герцах. Меняете на то, что по Вашему мнению (а лучше по паспорту монитора) правильно, и наслаждаетесь результатом. Если результатом является пропадание разрешения из Display properties, значит много поставили. Так что придётся либо снизить частоту горизонтальной, либо повысить верхний предел вертикальной развёртки. Только не перестарайтесь.

наверх

(7.16) Можно ли заставить работать Norton Speed Disk при запущенной службе терминал-севера? Надоело каждый раз её останавливать, а потом снова запускать.
Можно, но для этого потребуется изменение кода программы, а именно файла sdntc.exe (перед изменением на всякий случай сделайте его резервную копию). Возьмите любой шестнадцатиричный редактор и найдите следующую последовательность байт: 55 8b ec 81 ec bc 00 00 00 57. Затем замените 55 8b ec на 33 с0 с3. Сохраните изменения. Проделав все это, мы просто отключили проверку на наличие службы терминал-сервера. Никто не гарантирует вам работу Speed Disk из терминальной сессии, запускайте его только локально. Для версии 5.1.1 существует специальный патч, который можно взять здесь http://www.chem.univ.kiev.ua/~adsh/win2k/soft/.

наверх

(7.17) Как заставить под W2k работать старые сканеры HP серий II, III, 4?
Проблема состоит в том, что (по крайней мере, на момент написания этого материала) драйверов для ISA карт от Symbios Logic, которые поставлялись в комплектах с этими сканерами, не существует. Поэтому придется скачать с сайта Symbios Logic драйвера под WNT4 для ваших карт (Symxxx400A, Symxxx416A). Далее следуем инструкции:
  1. инсталлиpуем скачанный дpайвеp SCSI-карты и перезагружаемся;
  2. заходим в Recovery Console и выполняем команду LISTSVC, которая выдаcт список всех служб и драйверов, находим там свой дpайвеp. Флаг типа загрузки у него будет boot. Командой ENABLE меняем boot на system или demand;
  3. выходим из Recovery Console, перезагружаем систему. W2k обнаружит ваш сканер, и попросит перезагрузиться еще раз;
  4. после перезагрузки в "Scanners and Cameras" видим свой сканеp;
  5. Устанавливаем заранее скачанный с HP софт для сканера (HP ScanJet v.2.7 или 2.9 для WNT 4.0, т.к. под W2k нет и не будет, судя по всему).

Все!

наверх

(7.18) Как поставить драйвер сканера ScanJet 5p (чип от Symbios Logic 53C416) на win2000prof?
  1. идем на сайт hp.com и выкачиваем оттуда DeskScan II (4 метра)
  2. устанавливаем это все хозяйство (на ругань внимание не обращаем)
  3. выкачиваем файлик (ftp://ftp.lsil.com/pub/symchips/scsi/drivers/53C416_Drivers/Win2k/416w2k.zip)
  4. распаковываем его и в файле (SYM41650.INF) меняем строку Signature="$Windows NT$" на Signature="$CHICAGO$"
  5. заставляем систему найти новые устройства и подставляем ей каталог, куда мы распаковали zip-файл и все :)

наверх

(7.19) Как завести под W2k старый CD рекордер? Например, CD-recorder Yamaha CDR-100 (SCSI) определяется, но никаких драйверов на него не ставится.
Для этого достаточно выбрать драйвер вручную, из списка. Вполне подойдёт стандартный драйвер CD-ROM. Привод будет виден в Explorer, и записывающий CD-R софт увидит его как рекордер.

наверх

(7.20) Мой 12х CD Recorder записывает диск за 15 минут, а должен за 6. А везде пишется, что запись прошла на скорости 12x, почему так происходит и что делать?
Причина такого печального явления заключается в том, что в процессе записи опустошается буфер (что можно наблюдать в окне мониторинга записывающей программы), и привод, что бы не испортить записываемый диск сбрасывает скорость записи. Эта технология называется burnproof. Для борьбы с опустошением буфера прежде всего необходимо убедится, что установлен достаточно свежий aspi layer. Взять его можно здесь: http://www.3dnews.ru/documents/971/forceaspi17.zip.

Если проблема не исчезнет, значит привод не очень хорошо уживается с вашим IDE контролёром. Для устранения этого досадного недоразумения достаточно отключить в BIOS режим UDMA для IDE канала на котором висит рекордер. Это заставит его работать в режиме PIO4, что приведёт к несколько более высокой загрузке процессора при работе с приводом (что не совсем не критично при современных мощностях процессоров), зато избавит вас от проблем с опустошением буфера. DMA режим отключать надо только в BIOS, под Windows он может (и должен) быть включён. Если нет желания отключать UDMA, то можно попробовать выставить привод на отдельный шлейф в качестве Master устройства, в полном одиночестве (без Slave).

наверх

(7.21) В спящем режиме W2k не выключает вентиляторы.
Для решения этой проблемы, в BIOS в разделе Power Management (или что-нибудь вроде этого), выставьте режим ST3.

наверх

(7.22) Как добиться, чтобы модем брал трубку с N-ного звонка?
Запустите regedit. Добавьте (т.к. исправлять нечего) в секцию:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\Parameters

новую запись NumberOfRings типа REG_DWORD со значением N, где N может принимать значения из диапазона от 1 до 20. Пеpезапyстите слyжбy RRAS.

Если модем оснащен АОH и поднимает трубку для определения номера, можно в *.inf файле модема удалить или закомментировать строку АОH-а:

HKR, EnableCallerID, 1,, "at#cid=1" после чего переустановить *.inf.

наверх

(7.23) Как заменить материнскую плату без переустановки системы?

Перед сменой платы в Device Manager в разделе IDE ATA/ATAPI Controllers поменяйте Bus Master IDE контролёр установленный там на Standart Dual Channel PCI IDE Controller. Если этого не сделать, то при загрузке на новой материнской плате система может не найти жёсткого диска, и Вы получите сообщение про "inaccessible boot device".

наверх

(7.24) Модем не хочет звонить в пульсовом режиме.
На самом деле, чаще всего эта проблема возникает потому, что пользователь не может найти, где в W2k выставляется режим набора для соединения. В W2k для этого придётся:
  • В окне соединения нажать на Properties.
  • В открывшемся окне отметить галочку Use dialing rules из раздела Phone number, и нажать на кнопку Rules в том же разделе.
  • В вновь открывшемся выбираем текущее местоположение, нажимаем Edit.
  • И только в открывшемся после этого окне можно выставить режим набора, тоновый или импульсный. В этом же окне обратите внимание на номер вписанный под надписью Phone number will be dialed as:

Если это не помогло, то можно попробовать выставить режим набора принудительно, в строке инициализации модема. Например at&p1. Сделать это можно здесь: Control Panel – Phone and Modem options:

  • В открывшемся окне переходим на закладку Modems, в списке выбираем нужный, нажимаем на кнопку Properties.
  • В открывшемся окне выбираем закладку Advanced, и можем вводить дополнительные параметры в строке Extra initialization commands.
  • Кроме этого, если драйвера и сам модем позволяют, выставьте правильную страну в настройках модема.


Win2KFAQ -> Проблемы

Проблемы
    (8.1) | Что то не работает, как найти причину?
    (8.2) | Почему некоторые программы не инсталлируются в W2k? Запускается инсталлятор, появляется окно, в нём закрашивается индикатор до 100%, но потом всё пропадает. Процесс висит в памяти, но инсталляция не продолжается.
    (8.3) | Постоянно занято 30-50% системных ресурсов, даже когда никаких программ не запущенно.
    (8.4) | После установки ATM Deluxe 4.0 for NT -- Win2k не "уходит" в Hibernate и Stand by.
    (8.5) | Постоянно зависает Adobe Photoshop 5.5 при вставление из клипборда или импорте клипборда при переключении из другого софта.
    (8.6) | В системном логе постояно появляются сообщения об ошибках. Как с этим бороться?
    (8.7) | Под W2k не хотят работать некоторые программы, требующие интенсивного обращения к CD приводу, такие как Audiograbber, CDEx, программы для записи CD-RW, некоторые DVD декодеры, и т. д..
    (8.8) | Как избавиться от сообщения:
    (8.9) | С некотоpых поp пpи запyске ДОС-пpиложений появляеся сообщение, что "Virtual Device Driver format in the registry is invalid. Choose 'Close' to terminate the application". Если выбрать 'Ignore', все работает. Это лечится?
    (8.10) | Моя любимая программа работает только под аккаунтом администратора :( Как сделать, чтобы она работала и под аккаунтом обычного пользователя?
    (8.11) | После подключения дополнительного жесткого диска W2k перестал загружаться. После ввода пароля говорит, что "Your system has no paging file, or the paging file is too small" и снова выдает окно логона. Что делать?
    (8.12) | При перезагрузке повреждается реестр, что приводит к синему экрану при загрузке.
    (8.13) | Как справится с тормозами при работе антивируса Касперского?
    (8.14) | Компьютер перезагружается непонятно почему.
    (8.15) | Пропал файл подкачки, W2k при загрузке каждый раз создаёт временный на 20 мегабайт. Выставление файла вручную не помогает, после загрузки его опять нет.
    (8.16) | Как сделать что бы при загрузке всегда включался NumLock?
    (8.17) | Надоело стирать Temporary Internet Files каждый раз вручную. Можно автоматизировать этот процесс?
    (8.18) | Как узнать что означает та или иная ошибка в Event Viewer?
    (8.19) | Как мне удалить файл hiberfil.sys?
    (8.20) | Можно ли под W2k услышать звук в старой игрушке для DOS?
    (8.21) | Утерян пароль администратора. Что делать? Доступ к компьютеру полный.
    (8.22) | Почему локальные пользователи (в т.ч. Гости!) могут изменять локальную политику безопасности? Они могут даже запретить администратору вход в систему!
(8.1) Что то не работает, как найти причину?
Вообще-то, этот вопрос не относится к какой либо из конкретных операционных систем, и опытные пользователи прекрасно знают ответ на него, но анализируя ваши письма мы пришли к выводу, что лишним он не будет. Прежде всего, необходимо локализовать источник проблем. Поиски следут начать с ответа на вопрос: с чего всё началось? Было ли время, когда подобной проблемы не было? Что изменилось с тех пор? Для того, что бы было проще отвечать, можно посоветовать воспользоваться методикой используемой при администрировании больших серверов, и вести журнал изменений, в который записывать все изменения которые были сделаны в настройках системы, и когда что было инсталированно, но в домашних условиях даная методика вряд ли является оправданой. В любом случае, если когда-то проблемы не было, значит, она является решаемой, и не столь важно, даже если не удаётся сразу вспомнить, с чего всё это началось, это просто несколько удлинит дальнейшие поиски.

Для начала, попробуйте поставить последние драйвера на все установленые в системе устройства, особо обратив внимание на материнскую плату и видеокарту. Если и так стоят самые последние, можно попробовать сделать наоборот, и поставить те, что находятся на дисках, которые давались вместе с оборудованием при покупке.

  • В Device Manager посмотрите, нет ли IRQ или каких либо других конфликтов.
  • Выключите все Power Saving опции, в том числе и screen saver.
  • Попробуйте в BIOS установить более высокие значения таймингов памяти (то есть, замедлить её).
  • Ставим Video BIOS Casheable - Disabled, Video BIOS Shadow - Disabled.
  • Увеличиваем 8 и16 bit I/O Recovery Time
  • Удостоверяемся, что Assign IRQ for VGA - Yes
  • Уберите все разгоны (если у Вас что нибудь разогнано), можно попробовать поднять (НЕМНОГО, на 0.05 максимум на 0.1V) напряжение процессора.
Не будет лишним проверить работу всех вентиляторов, возможно, что какой нибудь из них неисправен, и система просто перегревается.

В BIOS отключаем AGP (AGP Aperture size - на минимум), выключаем AGP2x и AGP4x

Если вышеперечисленное не помогает, или по каким то причинам не подходит, то, предположив, что проблема имеет корни в каком либо неисправном устройстве, можно перейти к более решительным мерам.

Удаляем (физически) из системы все устройства, без которых система может работать (оставить только материнскую плату, память, винчестер, и видеокарту), в BIOS отключаем всё, что можно (COM и LPT порты, все Power Options, Assign IRQ for USB (не трогаем Assign IRQ for VGA!)).

Если есть вероятность что проблема с винчестером, в BIOS принудительно ставим ему PIO 4, или даже PIO 2 mode.

Если проблема не пропала, проверяем всё оставшиеся устройства (видеокарту - память - процессор - материнскую плату и винчестер). Наиболее простой способ - установить устройство на другую машину и посмотреть, как оно себя там поведёт.

Если же после удаления всех лишних устройств проблема пропала, то надо по очередиставить удалённые устройства на место, и после КАЖДОГО включать систему и проверять "самочуствие". Если проблема в неисправном оборудовании, то, как правило, таким методом её удаётся локализовать.

Впрочем, далеко не всегда приходится прибегать к столь радикальным методам, зачастую причина лежит на поверхности, и предположительно проблемнуое устройство удаётся вычислить сразу. Наилучшим, в этом случае, является проверить её на другой машине, а лучше и не на одной, крайне желательно, что бы их конфигурация отличалась от Вашей. Если выясниться, что железка всё-таки рабочая, то следует лучше изучить свою машину. Первое на что стоит обратить внимание, какие слоты с какими делят одно IRQ. Обычно, про это можно узнать из инструкции к материнской плате. Если инструкции нет, или лень копаться, то можно сразу попробовать плату в другом слоте (не сработает в случае с AGP видеокартой, в этом случае лучше всё-таки выяснить, какой из PCI слотов дели IRQ с AGP, и посмотреть что в нём стоит). Кстати, это поможет и в том случае, если у Вас неисправен один из слотов. Кроме этого, как это ни прискорбно, встречаются ситуации когда устройство А физически несовместимо с устройством В, например из за недостаточного питания. В большинстве случаев с этим ничего нельзя поделать, хотя бывают счастливые исключения, иногда всё приходит в норму после установки более мощного и качественного блока питания, или, как с некоторыми ASUS’скими матерями, на матери стоит джампер с помощью котрого можно принудительно увеличить питание AGP слота.

Если проблема уходит корнями в програмное обеспечение, то основные принципы решения такие же, удаление всего, что можно, и постепенная установка обратно с проверкой работоспособности системы после каждой инсталяции. Иногда таким методом выясняются очень интересные закономерности. Например, кто бы мог подумать, что установка PGP может привести к сообщению POWER_STAT_FAILURE при выключении машины? Ну и, конечно же, всегда остаётся радикальный метод - полное удаление старой ОС и чистая установка новой. В этом случае не забудьте очистить папку Documents and Settings, W2k не перезаписывает файлы в ней (хотя и грозится), а просто создаёт новые директории. Поэтому, если не чистить эту папку, то после неоднократной переустановки системы там можно будет найти такие папки как User1.USER.000, All Users.WINNT, Default User.001 и множество других. И разобраться, какие из них нужны, не всегда бывает просто.

В случае возникновения каких либо проблем с конкретным оборудованием или програмным обеспечением, лучшее место, откуда следует начинать поиски решения, это служба технической поддержки производителя. Можете быть уверены, они свой продукт знают гораздо лучше чем мы.

И последнее. Если Вы всё-таки решитесь разбирать свой компьютер, то будьте осторожны и внимательны. Не забывайте убедиться что в слоте, в который вы собираетесь что нибудь вставлять, ничего нет, включая пыли. И перед установкой убедитесь, в правильной ориентации вставляемой детали. Потому что пыль обладает определённой токопроводностью, и может вызвать короткое замыкание, да и засунуть DIMM не той стороной не так невозможно, как может показаться...

наверх

(8.2) Почему некоторые программы не инсталлируются в W2k? Запускается инсталлятор, появляется окно, в нём закрашивается индикатор до 100%, но потом всё пропадает. Процесс висит в памяти, но инсталляция не продолжается.

Это происходит когда временные папки в W2k помещены в профайлы пользователей. Временные папки используются инсталляторами для распаковки временных данных, необходимых для инсталляции. Но, когда временную папку помещают в директорию профайла пользователя, у ней получается очень длинное имя, и некоторые инсталляторы благополучно распаковав в её свои данные не могут их найти. Для решения этой проблемы достаточно просто поместить папку куда-нибудь повыше, чтобы путь был коротким, и, желательно, без русских символов. Делается это через System Properties, Advanced, Environment. Меняете пути к TEMP и TMP на C:\WINDOWS\TEMP, и всё. Осталось только стереть старые папки. Кроме этого, встречаются инсталляторы в которых прописаны абсолютные пути. Обычно этот путь выглядит как %windir%\Temp (или что-то вроде этого), и тогда никаких проблем не возникает, но иногда путь прописан более конкретно, обычно C:\Windows\Temp, и тогда инсталлятор может зависнуть не найдя этих директорий. К счастью, такие кривые инсталляторы попадаются очень редко, но если нужная программа не хочет инсталлироваться несмотря на все усилия, то можно попробовать создать указанный выше путь, может и поможет. Кроме всего вышеперечисленного, иногда помогает замена файла Setup.exe другим, из работающего инсталлятора.

наверх

(8.3) Постоянно занято 30-50% системных ресурсов, даже когда никаких программ не запущенно.
Это связанно с некорректной поддержкой режима ACPI Вашей материнской платой. Лечится это, обычно, обновлением BIOS, но, иногда, можно столкнуться с ситуацией, когда эта проблема присутствует даже с последним обновлением. В этом случае остаётся только отключить ACPI (поменять ядро на ядро без поддержки ACPI), и забрасывать письмами службу техподдержки производителя материнской платы, что бы они скорее выпустили очередное обновление BIOS в котором эта проблема решена.

наверх

(8.4) После установки ATM Deluxe 4.0 for NT -- Win2k не "уходит" в Hibernate и Stand by.
Решение проблемы было обнаружено в форуме необходимо в приведенном ключе Registry заменить "1" на "4": [HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Services \ATMhelpr] "Start"=dword:00000001 , Set the value to 4. после правочки все заработало нормально.

наверх

(8.5) Постоянно зависает Adobe Photoshop 5.5 при вставление из клипборда или импорте клипборда при переключении из другого софта.
Эта проблема встречается на ограниченном количестве материнских плат, и связанна с ошибкой реализации MMX в Ph5.5. Для решения проблемы достаточно удалить или переименовать файл MMXCore.8BX из Plug-Ins/Adobe Photoshop Only/Extensions/

наверх

(8.6) В системном логе постояно появляются сообщения об ошибках. Как с этим бороться?
Ошибки эти могут быть самые разнообразные, и причины их появления далеко не всегда очевидны. Иногда их причиной может являтся то, что не запущенны какие либо системные службы, к которым пытаются обратится другие службы, иногда причины кроются в чём то другом. Установить эту причину зачастую весьма не просто, тем более что зачастую эти ошибки мало на что влияют, и никак не мешают нормальной работе. Но, тем не менее, решение некоторых проблем нам известны.

Сообщение:

    Event Type: Error
    Event Source: WinMgmt
    Event Category: None
    Event ID: 43
    Date: 31.10.2000
    Time: 22:21:08
    User: N/A
    Computer: SPIDERCOMPUTER
    Description:
    WMI ADAP failed to connect to namespace \\.\root\cimv2\MS_419 with the following error: 0x8004100e
и сообщение:
    Event Type: Error
    Event Source: WinMgmt
    Event Category: None
    Event ID: 37
    Date: 31.10.2000
    Time: 22:21:57
    User: N/A
    Computer: SPIDERCOMPUTER
    Description: WMI ADAP was unable to load the perfproc.dll performance library due to an unknown problem within the library: 0x0
появляются когда в английской системе default languadge стоит русский. Для того чтобы избавиться от них можно либо переставить язык на английский, что неприемлемо во многих случаях. Тогда идём в System32\wbem.
Ищем там файлы: cimwin32.mfl, msi.mfl, ntevt.mfl, secrcw32.mfl.
Копируем их во временный каталог. Далее - редактируем в блокноте: 4 0 9 и меняем на 4 1 9. Это надо сделать в двух местах во всех четырёх файлах _в верхних 3-5 строчках_ (т.к. 4 0 9 встречается более чем в двух местах).
Помещаем туда же файл patch409.cmd:

@echo off
pushd %windir%\system32
copy perf?009.dat ??????1?.*
popd
mofcomp.exe cimwin32.mfl
mofcomp.exe msi.mfl
mofcomp.exe ntevt.mfl
mofcomp.exe secrcw32.mfl
winmgmt /clearadap
echo Please - reboot your computer!

запускаем его, перезагружаемся.
В следующий pаз после установки W2k достаточно пpосто запустить этот patch409.cmd. Все вылечит. Можешь конечно делать все вpучную, но использование cmd-файла куда проще и удобнее. Также можно использовать VB-script, который можно взять здесь: http://www.3dnews.ru/documents/971/419fix.zip.

Сообщение:

    Тип события: Ошибка
    Источник события: perfctrs
    Категоpия события: Отсyтствyет
    Код события: 3101
    Дата: 13.12.2000
    Вpемя: 11:28:16
    Пользователь: Hет данных
    Компьютеp: COMP1
    Описание: Hе yдается пpочитать сведения об yпpавлении вводом/выводом от yстpойства NBT.
возникает в результате того, что счетчики производительности протокола TCP/IP пытаются прочитать управляющую информацию ввода-вывода от сетевого устройства. При этом, ни одного коммутирующего устройства (сетевого адаптера, модема и т.п.) в системе не установлено. Существует несколько методов решения проблемы:
  1. Запустите exctrlst.exe из Resource Kit-а, выберите счетчик "Tcpip Perfctrs.dll" и снимите флажок "Performance counters enabled". Закройте окно "Extensible Counter List" и перегрузите компьютер. Утилиту exctrlst.exe также можно загрузить из сети Интернет: http://download.microsoft.com/download/win2000platform/exctrlst/1.00.0.1/NT5/EN-US/exctrlst_setup.exe.
  2. Откройте раздел системного реестра: HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \System \Tcpip \Performance
    Установите для параметра "Disable Performance Counter" значение "1". Чтобы изменения вошли в силу, перезагрузите компьютер.
  3. Установите эмулятор сетевой карты - Microsoft Loopback Adapter.
В ответе использована статья R11071 с http://www.microsoft.ru/catalog/

наверх

(8.7) Под W2k не хотят работать некоторые программы, требующие интенсивного обращения к CD приводу, такие как Audiograbber, CDEx, программы для записи CD-RW, некоторые DVD декодеры, и т. д..
Многие программы, требующие непрерывного потока данных идущих на или с CD/DVD привод, нуждаются в правильно установленном ASPI (Advanced SCSI Programming Interface) manager. Несмотря на своё название, ASPI manager с успехом используется IDE дисками. Для инсталляции ASPI можно воспользоваться универсальным пакетом: http://www.3dnews.ru/documents/971/forceaspi17.zip. Просто разархивируйте этот пакет, и запустите instaspi.bat. Или, если есть желание, можете изучить содержимое этого батника, и сделать всё самостоятельно, руками.

наверх

(8.8) Как избавиться от сообщения:
Event Type: Information
Event Source: Oakley
Event Category: None
Event ID: 542
Description: The IP Security policy for ISAKMP/Oakley specified an encryption algorithm that is invalid due to export cryptography restrictions. All 3DES encryption used by ISAKMP/Oakley is weakened to standard DES encyption. <...>

Данное сообщение возникает из-за существовавшего ранее экспортного ограничения на алгоритм 3DES со 128-битным ключем. Теперь это ограничение снято, и можно свободно скачать Windows 2000 High Encryption Pack с сайта Microsoft по этому адресу: http://www.microsoft.com/windows2000/downloads/recommended/encryption/default.asp, предварительно выбрав тип инсталляции и нужный язык обновления. Также 128-битное шифрование включено в пакет обновлений, начиная с SP2.

(!) Если вы установили High Encryption Pack, не устанавливайте сразу после этого Service Pack 1, сначала обязательно перегрузите систему. Иначе ваш компьютер может зависнуть на стадии "Preparing Network Connections". Подробнее об этом читайте http://support.microsoft.com/support/kb/articles/Q270/8/42.ASP

наверх

(8.9) С некотоpых поp пpи запyске ДОС-пpиложений появляеся сообщение, что "Virtual Device Driver format in the registry is invalid. Choose 'Close' to terminate the application". Если выбрать 'Ignore', все работает. Это лечится?
Полный текст сообщения может быть таким:

16 bit MS-DOS Subsystem
drive:\program path
XXXX. An installable Virtual Device Driver failed DLL initialization. Choose 'Close' to terminate the application.

или таким:

16 bit MS-DOS Subsystem
drive:\program path
SYSTEM\CurrentControlSet\Control\VirtualDeviceDrivers. VDD. Virtual DeviceDriver format in the registry is invalid. Choose 'Close' to terminate the application.

Эта ошибка обычно появляется после инсталляции 16-bit программ или программ, использующих 16-bit инсталляторы. Как правило, повреждается параметр VDD в разделе реестра HKLM\SYSTEM\CurrentControlSet\Control\VirtualDeviceDrivers. Для устранения ошибки запустите Regedt32.exe, найдите вышеуказанный параметр и удалите его. Затем добавьте новый параметр, назовите его VDD, и выберите тип данных REG_MULTI_SZ. Откроется редактор для ввода многострочного текста. Оставьте поле ввода пустым и нажмите "Ok". Подробнее можно почитать здесь: http://support.microsoft.com/support/kb/articles/Q254/9/14.ASP?LN=EN-US

наверх

(8.10) Моя любимая программа работает только под аккаунтом администратора :( Как сделать, чтобы она работала и под аккаунтом обычного пользователя?
  1. Входим в систему под аккаунтом администратора, запускаем regedt32.exe, в разделе HKLM/SOFTWARE находим подраздел нужной программы. Затем в меню Безопасность (Security) выставляем полный доступ на эту ветвь реестра для пользователя или группы пользователей, которые будут с ней работать.
  2. Если программа использует кроме раздела HKLM реестра ещё и раздел HKCU, нужно запустить под аккаунтом администратора Редактор реестра (regedit.exe). Hаходим ветку HKEY_CURRENT_USER\SOFTWARE\Имя_компании\Имя_программы (иногда встречатся только раздел Имя_компании, в котором хранятся параметры для нескольких программ этого производителя) и выбираем её. Затем с помощью меню "Реестр" ("Registry") экспортируем выбранную ветвь в файл. При выборе пути сохранения файла учтите его доступность для других пользователей. Перегрузившись под обычным пользователем, импортируйте полученный файл. Для достаточно дважды щелкнить по *.reg файлу в Проводнике и ответить "Да" ("Yes") на запрос об импорте файла в реестр, и подтвердить выполнение операции (Ok). После перезагрузки компьютера программа должна работать и под этим аккаунтом.
  3. Кроме того, некоторые программы (например, Windows Commander) создают свои *.ini-файлы. Обычные пользователи имеют разрешение "Read" на эти файлы. Для корректной работы программ нужно добавить разрешение "Modify" ("Изменение").
  4. Редко, но все же иногда требуется разрешение "Write" ("Запись") на *.exe файл программы. Этим отличилась, например, популярная программа ReGet.
  5. Популярная программа Nero будет работать под любым аккаунтом, если удалить файл wnaspi32.dll, отвечающий за ASPI, из её директории. Естественно, в системе должен быть установлен ASPI, напpимеp, от Adaptec (см. вопрос 7.20).
  6. В свойствах ярлыка программы можно выставить галочку "Запускать от имени другого пользователя". Тогда при запуске программы можно будет ввести логин и пароль администратора (правда, для этого их нужно знать ;))

Аналогичного эффекта можно добиться с помощью cmd-файла, в котором пишем: runas /profile /user:machinename\administrator [полный путь к *.exe файлу] где machinename - имя вашей машины; если в пути к файлу программы есть пробелы, то его необходимо заключить в кавычки. Теперь, при запуске этого cmd-файла, будет также спрашиваться пароль администратора.

наверх

(8.11) После подключения дополнительного жесткого диска W2k перестал загружаться. После ввода пароля говорит, что "Your system has no paging file, or the paging file is too small" и снова выдает окно логона. Что делать?
Данная проблема появляется, если буква загрузочного раздела не совпадает с буквой, назначенной при инсталляции системы. Обычно это происходит, если идентификатор (GUID - Globally Unique Identifiers) жесткого диска записанный в MBR, не совпадает со значением идентификатора в реестре, поэтому назначенная загрузочному разделу буква не может быть ему сопоставлена.

Если pagefile.sys находился не на системном или загрузочном разделе, сообщение об отсутствующем или слишком маленьком файле подкачки появляться не будет, но после сообщения "Loading your personal settings" снова появится окно логона.

Для решения этой проблемы можно использовать один из следующих методов:

  1. Если проблемный компьютер находится в сети, запустите редактор реестра на другом компьютере и воспользуйтесь ответом на вопрос 2.09. В одноранговой сети вам может понадобиться команда net use \\comp_name\IPC$ /user:administrator *
  2. Создайте в корне присоединяемого диска папку \WINNT\System32 и скопируйте туда разархивированный файл userinit.exe с дистрибутивного диска Win 2000. Если вы ранее следовали рекомендациям вопроса 11.07, то userinit.exe можно просто скопировать с загрузочного диска с помощью Recovery Console. Однако, после получения возможности логона, вы должны изменить букву загрузочного раздела с помощью рекомендаций ответа на вопрос 2.09, теперь уже локально. Загрузитесь с предварительно созданной DOS/Win9x дискеты и дайте команду fdisk /mbr (предварительно рекомендуется прочитать ответ на вопрос 11.06.2.) При этом сигнатура в MBR, ассоциированная с GUID загрузочного раздела будет стерта, и не обнаружив её при загрузке, система установит буквы по умолчанию.

Подробнее: http://support.microsoft.com/support/kb/articles/q249/3/21.asp

наверх

(8.12) При перезагрузке повреждается реестр, что приводит к синему экрану при загрузке.
Данная проблема встречается редко. Происходит это скорее всего потому, что данные из дискового кеша не успевают сбрасываться на жёсткий диск. Для решения этой проблемы необходимо. Установить последний Service Pack. Установить свежие драйвера на Ваш IDE или SCSI контролёр. Если эти меры не помогают, то можно включить обнуление файла подкачки при перезагрузке, это даст некоторую отсрочку, которая позволит сбросить необходимые файлы на жёсткий диск. Кроме этого, можно воспользоваться утилиткой под названием Sync, которая принудительно сбросит содержимое дискового кэша на диск. Взять эту замечательную программку можно здесь: http://www.sysinternals.com/ntw2k/source/misc.shtml

наверх

(8.13) Как справится с тормозами при работе антивируса Касперского?
Вообще то тормозит всё с благой целью, алгоритм проверки в KAV сейчас настолько крут, что пробраться мимо его всё сложнее. Побочным эффектом этого является что этот алгоритм способен поставить на колени, как кажется, компьютер любой мощности. К сожалению, Касперский не даёт пользователю выбрать что для него важнее, безопасность, пусть даже и за счёт скорости, или его вполне удовлетворит пусть и не такая навёрнутая защита, но нормальная скорость. Поэтому приходится бороться с Касперским не совсем честными методами. Для того что бы дать компьютеру вздохнуть по свободнее, просто уменьшите приоритет для всех его процессов.

наверх

(8.14) Компьютер перезагружается непонятно почему.
Скорее всего компьютер выбивает в BSOD, и он перезагружается. Для решения проблемы необходимо отключить автоматическую перезагрузку при сбое системы. Для этого открываем System Properties, переходим на закладку Advanced, нажимаем на кнопку Startup and Recovery в одноимённом разделе. Здесь требуется снять галочку с Automatically reboot в разделе System failure. Конечно же это не решит проблему с BSOD, но теперь компьютер не будет сразу же перезагружаться, и вы успеете прочитать содержимое экрана смерти, что может навести вас на путь решения этой проблемы.

наверх

(8.15) Пропал файл подкачки, W2k при загрузке каждый раз создаёт временный на 20 мегабайт. Выставление файла вручную не помогает, после загрузки его опять нет.
Это может произойти при повреждении системных файлов. Причина этого может быть разной, от не вовремя пропавшего электричества, до последствий атаки вируса. Для решения этой проблемы запустите проверку системных файлов (в командной строке sfc /scannow). Если это решение не подходит, остаётся только переустановить систему.

наверх

(8.16) Как сделать что бы при загрузке всегда включался NumLock?
Самый простой способ, это несколько раз выйти из системы с включенный NumLock, система должна запомнить это, и в будущем включать его при загрузке автоматически. Но можно добиться того же эффекта и быстрее. Идём в реестр, и по адресу HKEY_USERS\DEFAULT\Control Panel\Keyboard находим ключ InitialKeyboardIndicators. Меняем его значение на 2, и при загрузке NumLock будет всегда включен. Меняем на 0, и NumLock будет всегда выключен (полезно для ноутбуков, где нет вынесенного блока клавиш с цифрами).

наверх

(8.17) Надоело стирать Temporary Internet Files каждый раз вручную. Можно автоматизировать этот процесс?
Для этого запустите Internet Explorer, меню Tools, пункт Internet Options… В открывшемся окне переходим на закладку Advanced. Скролируем список до самого низа, раздела Security. Ставим чекбокс в пункте Empty Temporary Internet Files Folder When Browser is Closed.

наверх

(8.18) Как узнать что означает та или иная ошибка в Event Viewer?
Несмотря на то, что в окне с текстом ошибки W2k радостно сообщает, что по адресу: http://qo.microsoft.com/fwlink/events.asp можно найти дополнительную информацию, на самом деле через этот адрес просто отправляются сообщения об ошибках в Microsoft. Тем не менее, сделана попытка создать сайт с исчерпывающей информацией про ошибки. Находится он здесь: http://www.eventid.net/ . Автоматизировать поиск можно введя строку в броузере http://www.eventid.net/display.asp?eventid=<здесь введите нужный Event ID> Информация размещённая на нём не полна, и не всегда точна, но ведь он постоянно развивается. Зайдите на него, возможно именно в вашем случае он поможет. Кроме этого, кое-какая информация включена в поставку Windows 2000. Подробное описание всех системных сообщений находится в файле w2000msgs.chm дистрибутива, который в свою очередь находится в архиве \support\tools\support.cab. Последняя версия данного файла бесплатно доступна для скачивания на сайте Microsoft по адресу: http://www.microsoft.com/windows2000/techinfo/messages/default.asp.

наверх

(8.19) Как мне удалить файл hiberfil.sys?
Не смотря на то, что этот вопрос уже описан в факе, причём не однократно, он возникает снова и снова, с завидным постоянством. Поэтому, как мне кажется, стоит осветить его ещё раз. Этот файл является частью системы Hibernate, которая позволяет при выключении компьютера сбросить содержимое оперативной памяти на жёсткий диск, а при включении, просто загрузить этот файл в память. Это позволяет избежать достаточно долгого процесса загрузки, и сразу же после включения компьютера получить рабочий стол и открытые программы или документы точно в том виде, в котором они оставались когда компьютер выключался. Для того что бы обезопасить себя от ситуации, когда не удаться сбросить содержимое памяти просто из за того что на диске нет места, служба hibernate постоянно держит на диске файл hiberfil.sys размером равным объёму оперативной памяти. Этот файл нельзя стереть из под W2k, его бесполезно стирать из под соседней ОС, всё равно служба hibernate создаст его заново при первой же возможности. Единственны способ, это отключить саму службу hibernate. Сделать это можно через Control Panel – Power Options, закладка Hibernate. Снимаем галочку с чекбокса Enable hibernation, и служба будет отключена, а файл hiberfil.sys удалён.

наверх

(8.20) Можно ли под W2k услышать звук в старой игрушке для DOS?
Старые игры напрямую обращаются к звуковой карте, поэтому стандартными средствами получить звук под W2k не удастся. Hо можно попробовать один из специальных эмуляторов, выпускаемых сторонними производителями, например:

http://www.softsystem.co.uk/sndfx202.zip - SoundFX 2000 2.02. Эмулятор звуковой карты для DOS-программ, полностью эмулирует SoundBlaster 16. Для работы требуется W2k или WNT4 (SP3 или старше), процессор Pentium 90 и выше.

http://ntvdm.cjb.net/ - Проект VDMSound. Программа эмулирует MPU-401 интерфейс, SoundBlaster-совместимые звуковые карты (SB16, SBPro 2, SB2, SBPro, etc.) и стандартный интерфейс джойстика (game-port) для DOS-программ. Распространяеется с исходным текстом.

наверх

(8.21) Утерян пароль администратора. Что делать? Доступ к компьютеру полный.
  1. Удалите файлы %Windir%\system32\config\sam*. Если W2k установлен на FAT/FAT32, то из Win9x или с дискеты, если на NTFS - придется установить параллельную копию системы или снять жесткий диск и поставить его на другую машину с W2k. Если есть возможность, используйте NTFS for DOS. После удаления файлов возможен вход с логином Administrator/Администратор и пустым паролем.
  2. Другой способ - скачать с сайта http://home.eunet.no/~pnordahl/ntpasswd/ образ Linux-дискеты и программу для записи этого образа. Загрузившись с этой дискеты, с помощью записанной на неё программы Offline NT Password & Registry Editor можно установить новый пароль администратора, даже не зная старого.

наверх

(8.22) Почему локальные пользователи (в т.ч. Гости!) могут изменять локальную политику безопасности? Они могут даже запретить администратору вход в систему!
Это возможно только в том случае, если вы используете файловую систему FAT32. W2k хранит политику безопасноти не в реестре, а в обычном файле на диске, доступ к которому может быть ограничен только средствами NTFS. По умолчанию, если операционная система была сразу установлена на NTFS, менять локальную политику безопасности могут лишь члены группы администраторов.


Win2KFAQ -> Файлы

Файлы

По многчисленным просьбам открываем раздел с полезными файлами для W2k. Раздел состоит из двух частей, первая официальные патчи от Microsoft (не все, а только те, что кажутся нам наиболее важными), и вторая часть, куда войдут все файлы упоминавшиеся в FAQ, просто утилитки, показавшиеся нам полезными и интересными...

Патчи и программы от Microsoft

Windows 2000 Service Pack

http://www.microsoft.com/windows2000/downloads/servicepacks/default.asp

В комментариях не нуждается. На странице Microsoft можно выбрать любые из существующих на сегодня SP для W2k.

High encription pack
http://www.microsoft.com/windows2000/downloads/recommended/encryption/default.asp

Патч, долгое время бывший недоступным для жителей России из за ограничений в американском законодательстве. Позволяет получить 128 битное шифрование.

Сompatibility Pack
http://www.microsoft.com/windows2000/downloads/deployment/appcompat/default.asp

Устраняет проблемы несовместимости с различными программами. Частично входит в SP1, но эта версия более новая.

Via AGP chipset driver update.
http://www.microsoft.com/windows2000/downloads/recommended/q261606/default.asp

Патч выпущенный Microsoft для решения проблем низкой производительности систем на Via чипсетах. Кроме него, мы настоятельно рекомендуем ставить последние драйвера от Via, взять которые можно здесь: http://www.3dnews.ru/download/drivers/via/

Patch for AGP Application on Duron and Athlon
http://www.amd.com/us-en/Processors/TechnicalResources/0,,30_182_871,00.html

Небольшой патчик для исправления некоторых настроек реестра. По утверждению Microsoft, должен решить проблему низкой производительности AGP приложений на этих платформах. Отсюда же можно скачать и другие файлы для AMD процессоров и материнских плат.

ATA 100 support
http://support.microsoft.com/default.aspx?scid=http%3a%2f%2fwww.microsoft.com%2fdownloads%2frelease.asp%3fReleaseID%3d22161

Не совсем оффициальный патч от Microsoft, призванный обеспечить нормальную работу ATA 100 устройств под W2k. Оффициальную рекомендацию Microsoft по этому поводу можно почитать здесь: http://support.microsoft.com/support/kb/articles/Q260/2/33.ASP?LN=EN-US&SD=gn&FR=0&qry=ATA%20100&rnk=1&src=DHCS_MSPSS_gn_SRCH&SPR=WIN2000

DirectX 8a
http://www.microsoft.com/downloads/release.asp?ReleaseID=27742

Последняя (на сегодня) версия DirectX, вариант специально под W2k.

Resourse kit for Windows 2000
ftp://ftp.microsoft.com/reskit/win2000/

Набор утилиток от Microsoft, есть и полезные. Почитать про них можно здесь:

http://www.microsoft.com/windows2000/techinfo/reskit/tools/default.asp

Exctrlst

http://download.microsoft.com/download/win2000platform/exctrlst/1.00.0.1/NT5/EN-US/exctrlst_setup.exe

утилитка из resourse kit.

Утилиты и файлы из FAQ

ShowDep 4.0

http://www.showdep.com/download/sd40b1.zip

утилитка показывающая системные библиотеки используемые той или иной програмой.

SetSfc
http://www.3dnews.ru/documents/1143/setsfc.zip

Небольшая утилитка, используемая для простой манипуляции sfc.

СDRWin
http://www.3dnews.ru/documents/1143/cdr38a-e.exe

програмка для создания загрузочного image в W2k.

Boot.bin
Boot.bin

файл необходимый для cоздания загрузочного image с помощью CDRWin.

BootPart 2.20
BootPart 2.20

программа для добавления новых разделов в загрузочное меню W2k. Может использоваться для ремонта повреждённого загрузчика.

Radmin 2.01

http://www.famatech.com/radmin20.zip

програмка для удалённого aдминистрирования W2k.

Remote Control 1.7
http://www.dataset.fr/eng/download/download.asp?description=Remote+Control+(Client+%2B+Server)&url=/inter/download/rc/all.exe

программка для удалённого aдминистрирования W2k.

Georgia SoftWorks Telnet Server
http://www.georgiasoftworks.com/download_telnetserver.htm

программка для удалённого администрирования W2k.

Hackmon.zip

http://www.3dnews.ru/documents/971/hackmon.zip

reg-файл с помощью которого можно добиться высоких значений Refresh Rate в W2k везде и с любой видеокартой.

419fix.zip

http://www.3dnews.ru/documents/971/419fix.zip

vbs скрипт исправляющий одну из часто появляющихся ошибок.

Forceaspi.zip

http://www.3dnews.ru/documents/971/forceaspi17.zip

пакет для установки ASPI Manager.

Ntswitch

http://www.3dnews.ru/documents/1143/ntswitch.zip

Программка, позволяющая сделать из W2kPro W2kServer.


Win2KFAQ -> Благодарности

Благодарности

Этот FAQ никогда не стал бы тем, чем он является сегодня если бы сотни читателей не делились со мной своими проблемами, опытом, и находками. Людей, которые помогли сделать этот FAQ лучше множество, и их количество растёт каждый день. Вашу помощь трудно переоценить. Людей, которые помогли сделать этот FAQ лучше так много, что я чисто физически не могут привести здесь все их имена, не говоря уже про то, что установить первенство и авторство в том или ином вопросе не всегда возможно. Всё что я могу сделать - это постараться что бы знания и опыт, которыми со мной так щедро делятся читатели, не пропали, а нашли своё отражение на страницах этого труда. И пусть наградой вам будут те слова благодарности, которые присылают в мой адрес за поддержку этого документа.

От себя лично, и от лица всех читателей нашего FAQ, говорю вам:

Огромное Cпасибо!

Ведущий Win2K FAQ на http://www.3Dnews.ru/
Алексей Шашков ака Lehmen