Windows 2000 FAQ

Размещение FAQ вне конференции допустимо только с разрешения модератора!

FAQ конференции RU.WINDOWS.2000

Версия 2.69 от 17.10.2004.

Дополнение и уточнение FAQ всячески приветствуется, но: нетмейлом модератору, а не в конференции.

Самую последнюю версию данного FAQ можно найти в следующих форматах по следующим ссылкам:

HTML TXT CHM

Содержание FAQ конференции RU.WINDOWS.2000:

  • Авторы
  • Составители
  • Общие вопросы [1.01-1.17]
  • Установка системы [2.01-2.11]
  • Настройка [3.01-3.13]
  • Оптимизация [4.01-4.07]
  • Проблемы русcификации [5.01-5.06]
  • Аппаратные проблемы [6.01-6.14]
  • Сеть [7.01-7.15]
  • Сообщения об ошибках и предупреждения [8.01-8.08]
  • Программное обеспечение [9.01-9.07]
  • Восстановление системы [10.01-10.11]

Приложение

  • Поиск программного обеспечения [11.01-11.11]
  • Дополнительная информация по Windows 2000 [12.01-12.04]

История создания FAQ конференции RU.WINDOWS.2000

Что нового в последней версии FAQ конференции RU.WINDOWS.2000

По просьбе Романа Клина добавлен вопрос 7.15 дополнен 9.01.

Новый автор: Max Bashirov 2:4641/666.666, BOGDAN goddan@manga.ru.


Авторы.

При составлении FAQ были использованы сообщения следующих участников конференции:

Alex Suhov rds@mail.ru
Eugene Freilikhman Eugene.Freilikhman@p64.f8.n4624.z2.fidonet.org
Dmitry Ivanov Dmitry.Ivanov@p6.f1181.n5030.z2.fidonet.org
Taras Soroka aka Gabber gabber@bereg.ru
Sergei Nikiforov Sergei.Nikiforov@p87.f52.n5028.z2.fidonet.org
Serge Leontieve Serge.Leontieve@p101.f64.n5090.z2.fidonet.org
Alexey Cherkasov chiv@medialt.ru
Igor Timofeev Igor.Timofeev@p7.f753.n5020.z2.fidonet.org
Alexander Sheiko adsh@univ.kiev.ua
Roman Klin Roman.Klin@p25.f1490.n5020.z2.fidonet.org
Michael Glushko mice@reklama.tomsk.ru
Dmitri Khanevski Dmitri.Khanevski@p8.f182.n5080.z2.fidonet.org
Karen Khatchatrian Karen.Khatchatrian@f1217.n5030.z2.fidonet.org
Sergey Vasilyev Sergey.Vasilyev@p22.f918.n5030.z2.fidonet.org
Ildar Akhmetshin Ildar.Akhmetshin@p4.f33.n5093.z2.fidonet.org
Alexander Pavlov Alexander.Pavlov@p21.f159.n450.z2.fidonet.org
Valentin Ermolaev Valentin.Ermolaev@p12.f480.n463.z2.fidonet.org
Pavel Abakanov Pavel.Abakanov@p666.f5.n5004.z2.fidonet.org
Vladislav Ignatenko Vladislav.Ignatenko@p21.f12.n5007.z2.fidonet.org
Евдокимов Юрий rurik@malahit.chel.su
Serge V. Rotko Serge.V.Rotko@f31.n5061.z2.fidonet.org
Y.Leskov Y.Leskov@lipetsk.ru
Malik Abdugaliev malik@mail.gov.kg
Yuri Chumakov Yuri.Chumakov@f65.n5079.z2.fidonet.org
Vladislav Yarovoy hidd@it.overstar.com
Michael Vladimirov Michael.Vladimirov@p36.f362.n5000.z2.fidonet.org
Maxim A. Samoilenko pHoeniX@hosix.ntu-kpi.kiev.ua
Andrey Odegov Andrey.Odegov@f418.n5020.z2.fidonet.org
Pavel Abakanov Pavel.Abakanov@p666.f5.n5004.z2.fidonet.org
Dmitry Gordienko Dmitry.Gordienko@p23.f111.n5012.z2.fidonet.org
Andrew Orlov Andrew.Orlov@p4.f251.n5011.z2.fidonet.org
Mike Timonov Mike_Timonov@p15.f76.n5000.z2.fidonet.org
Mikhail Marchencov chel@online.tver.ru
Maksim Demin maxim@sintal.donetsk.ua
Dmitry M. Ganaev Dmitry.M.Ganaev@p12.f5.n5013.z2.fidonet.org
Vasiliy Nikitin unvasily@cityline.ru
Andrew Zaikin Andrew.Zaikin@p44.f561.n5030.z2.fidonet.org
Denis Chernyshev Denis.Chernyshev@f25.n5090.z2.fidonet.org
Dmitry Sokolov sokol_SPAM@brancher.net
Alex Zaikin Alex.Zaikin@f28.n5037.z2.fidonet.org
DeNNis Lazarenko DeNNis.Lazarenko@p51.f23.n5063.z2.fidonet.org
Konstantin Malanov hexen@avtokran.interline.ru
Anatoly Gerasimov Anatoly.Gerasimov@f109.n6070.z2.fidonet.org
Stanislav Shwartsman Stanislav.Shwartsman@f520.n400.z2.fidonet.org
Roman romanf@newmail.ru
Andrzej Novosiolov andrzej@se.kiev.ua
Aleksey M. Saveljev lexxus@vmail.ru
Alexandr Rudoy Alexandr.Rudoy@p6.f64.n5055.z2.fidonet.org
Yan Lyashenko Yan.Lyashenko@f122.n464.z2.fidonet.org
Konstantin Brilenkov Konstantin.Brilenkov@p13.f9.n5014.z2.fidonet.org
George Kotlomin George.Kotlomin@p1.f1587.n5020.z2.fidonet.org
Vladimir Tishchenko vamp@megastyle.com
George Kotlomin George.Kotlomin@p1.f1587.n5020.z2.fidonet.org
Yury Filippov filippov@yarpivo.yaroslavl.ru
Yan Alexandrovsky Yan.Alexandrovsky@p43.f1626.n5020.z2.fidonet.org
Соловьев Андрей Ragnar@mail.ru
Dmitry Rabinovich novich_no_spam@atlant.ru
Илья Дещеревский deschere@apl.ru
Oleg Poleshuk Oleg.Poleshuk@p20.f64.n452.z2.fidonet.org
Khachatur Meliksetian khcho2@yahoo.com
Igor Mymrin lenigor@rusoil.net
Yuri Lysenkov yl2@mail.ru
Дмитрий Загвозкин Dmitry.Zagvozkin@mail.ru
Alex Visokov Alex.Visokov@p66.f14.n5026.z2.fidonet.org
Kirill Obukhovskiy Kirill.Obukhovskiy@p32.f16.n451.z2.fidonet.org
Andy Ice AndyIce@mail.ru
Danila Stupakov Danila.Stupakov@p40.f200.n5003.z2.fidonet.org
Alexandr Strelnikov Alexandr.Strelnikov@f15.n5026.z2.fidonet.org
Sergey Gaydak Sergey.Gaydak@p777.f455.n463.z2.fidonet.org
Владимир Булдыжов bsp@zorya.com.ua
Denis Korablyov Denis.Korablyov@p39.f11.n5023.z2.fidonet.org
Dmitriy Demchenko Dmitriy.Demchenko@f27.n5035.z2.fidonet.org
Aleksey Tchekmarev tchek@bhv.ru
Eugene Mindrov rotten@rol.ru
Denis Lazarenko Denis.Lazarenko@p51.f23.n5063.z2.fidonet.org


Аппаратные проблемы.

6.01 После перезагрузки Windows 2000 не находит внешний модем. Что делать?

6.02 Как правильно поменять ядро системы?

6.03 Как поменять вручную IRQ? В свойствах устройств чекбокс "Автоматическая настройка" затемнен и не отключается :(.

6.04 Как мне выбрать нужную версию ядра и HAL ещё при инсталляции?

6.05 Как включить в W2k поддеpжку режимов Ultra DMA?

6.06 Как добавить в W2k поддеpжку Ultra DMA66, если она отсутствует в свойствах контроллера IDE? Мат. плата и жесткий диск UDMA66 поддерживают.

6.07 Перешел на Windows 2000 и у меня перестали работать Open GL и Direct 3D приложения, говорят, что нет аппаратной поддержки :( Как лечить?

6.08 При печати на принтере (подключен через LPT) загрузка процессора 100%. Все остальное, соответственно, притормаживает. Как можно побороть?

6.09 Как заставить работать под Windows 2000 звуковую карту на Vortex 2 ?

6.10 Как заставить под W2k работать старые сканеры HP серий II, III, 4?

6.11 Можно ли заставить работать в Windows 2000 звуковую карту на Opti93x?

6.12 Под W2k на материнской плате P2B не работают COM-порты. Как побороть?

6.13 При обращении к CD-приводу Teac 540E, система иногда виснет на некоторое время, особенно при считывании звуковых дисков. Есть ли путь решения проблемы?

6.14 Хочу поменять материнскую плату на новую с другим чипсетом. Как быть?

6.15 При подключении HDD 160 Гб, W2k видит только 137 Гб. Это исправляется?

6.01. После перезагрузки Windows 2000 не находит внешний модем. Что делать?

Если y вас внешний модем, то пеpед загpyзкой W2k его надо включить. Тогда он и обнаpyжится системой. Если модем был выключен, можно зайти в Device Manager и кликнуть пpавой кнопкой мыши на коpень "деpева", там выбpать "Scan for hardware changes" (Обновить конфигурацию оборудования). Модем должен быть при этом включен и pанее пpоинсталиpован. Для выполнения этих действий нужны права администратора, т.е. для простого пользователя метод не подходит.

Есть ещё один способ, не совсем правильный, но работающий. Можно поставить не-PnP версию вашего модема, если таковая имеется в файле *.inf, или "Стандартный модем" из поставки W2k. Hо если модем будет включен при загрузке, система обнаружит его и потребует установку драйверов. Избежать этого можно, отключив обнаруженную PnP версию модема в Диспетчере устройств. Полностью избежать всех проблем можно, отключив выдачу модемом PnP идентификатора, но для этого нужна специальная версия прошивки, позволяющая это сделать.

6.02. Как правильно поменять ядро системы?

Ядро меняется в Device Manager -> Computer, как и любой другой драйвер. Если не уверены, то лучше ничего не трогать, потому что скорее всего машина просто перестанет загружаться, во всех режимах. Предотвратить это можно, дополнив boot.ini ещё одним пунктом, т.е. продублировать рабочий пункт меню выбора ОС.

Пусть имеется: multi(0)disk(0)rdisk(0)partition(1)WINNT="Microsoft Windows 2000 Professional" /fastdetect - дублируем эту строку, а после /fastdetect добавляем следующие ключи: /kernel=ntoskchk.exe /hal=halchk.dll. В директории \WINNT\System32 делаем копии ядра и HAL-а (назвать их нужно соответственно добавленной строке: ntoskrnl.exe -> ntoskchk.exe, а hal.dll -> halchk.dll).

В ответе использован материал из Win2000 FAQ c сайта 3DNews: http://www.3dnews.ru/reviews/software/win2000_faq/index01.htm.

6.03. Как поменять вручную IRQ? В свойствах устройств чекбокс "Автоматическая настройка" затемнен и не отключается :(.

У вас включена поддержка ACPI - Advanced Configuration and Power Interface, и поэтому возможно только автоматическое конфигурирование системы (часто при этом все устройства оказываются на одном IRQ). Hе стоит расстраиваться, если система нормально работает. Hо если проблемы все-таки существуют, единственный способ получить возможность вручную назначать прерывания, это выключить поддержку ACPI. Для этого при инсталляции нужно отключить поддержку ACPI в BIOS, а при уже инсталлированной системе поменять тип ядра на "Стандартный компьютер" (см. также вопросы 6.02 и 6.04). Это официальная рекомендация Microsoft: http://support.microsoft.com/default.aspx?scid=kb;EN-US;q252420.

(!) Если материнская плата не поддерживает стандарт APM (почти все новые, начиная с 2000 г.), а поддерживает только ACPI, то компьютер перестанет выключаться сам, а будет лишь выдавать сообщение о возможности выключения.

6.04. Как мне выбрать нужную версию ядра и HAL ещё при инсталляции?

1) В самом начале текстового этапа установки Windows 2000 при появлении сообщения "Setup is inspecting your computer's hardware configuration" нажмите и удерживайте клавишу "F5". В появившемся на экране списке версий библиотек HAL выберите версию, соответствующую вашему компьютеру, или выберите позицию "Other" для того, чтобы указать файл библиотеки от производителя оборудования. Затем продолжите установку Windows.

В поставку Windows 2000 включены следующие версии библиотеки HAL:

 ACPI Multiprocessor PC - для ACPI-систем с несколькими процессорами
 ACPI Uniprocessor PC   - используется для ACPI-систем с многопроцессорной
                          системной платой и одним установленным процессором
 Advanced Configuration and Power Interface (ACPI) PC  - используется для
                          однопроцессорных ACPI-систем
 Compaq SystemPro Multiprocessor or 100% Compatible  - для компьютеров Compaq
                          SystemPro или полностью совместимых с ними
 MPS Uniprocessor PC    - для систем без поддержки ACPI, с многопроцессорной
                          системной платой и одним установленным процессором
 MPS Multiprocessor PC  - для многопроцессорных систем без поддержки ACPI
 Standard PC            - используется для любого стандартного компьютера,
                          не многопроцессорного и без поддержки ACPI.
 SGI mp                 - для графических станций Silicon Graphics

В ответе использована статья R10894 с http://www.microsoft.ru/catalog/ article.asp?article_ID={CE6FA144-3FC2-11D4-A6D1-00508B8B783F}.

2) Если вас интересует только включение/отключение ACPI, то в случае инсталляции системы с жесткого диска или с 4-х загрузочных дискет, можно изменить секцию ACPIOptions файла txtsetup.sif в каталоге I386 дистрибутива.

По умолчанию эта секция имеет вид:

[ACPIOptions]
 ACPIEnable = 2
 ACPIBiosDate = 01,01,1999

где параметр ACPIEnable может принимать одно из трех значений:

 0 - ACPI будет игнорироваться при инсталляции в любом случае,
 1 - ACPI будет включен при инсталляции, если BIOS поддерживает ACPI.
 2 - ACPI будет включен, если BIOS материнской платы сертифицирован как
 GoodACPIBios ( т.е. присутствует в списке секции [NWACL]) или хотя бы
 выпущен после даты, указанной в параметре ACPIBiosDate = mm,dd,yyyy

В случае проблем с определением ACPI поставьте параметр ACPIEnable = 1. Если вы хотите отключить ACPI при инсталляции, поставьте ACPIEnable = 0.

6.05. Как включить в W2k поддеpжку режимов Ultra DMA?

Идем MyComputer->Properties->Hardware->Device Manager->IDE ATA/ATAPI controllers->Primary(Secondary) IDE Channel->Properties->Advanced Settings. Там смотрим Current Transfer Mode. Если стоит "Ultra DMA Mode" - то все в порядке, если нет - выставляем в поле Transfer Mode "DMA, if available", и перезагружаемся. Если контроллер IDE и жесткий диск поддерживают режим UDMA, то после перезагрузки этот режим заработает. И ещё - если у вас на каком-либо IDE канале из двух возможных устройств стоит только одно, то отключите автоопределение второго на закладке "Advanced settings" вкладки "Primary (secondary) IDE channel properties", находящейся в Device manager (поставьте Device Type в None). Это слегка ускорит процесс загрузки Windows.

6.06. Как добавить в W2k поддеpжку Ultra DMA66, если она отсутствует в свойствах контроллера IDE? Мат. плата и жесткий диск UDMA66 поддерживают.

Для стандартных драйверов W2k следует добавить в реестр параметр

HKLM\System\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0000\EnableUDMA66:DWORD:1

Чтобы снова отключить - либо удалить параметр, либо поставить его в 0.

Если у Вас установлены свежие драйвера от Intel или VIA, то включение режимов UDMA производится с помощью специальных утилит производителя.

6.07. Перешел на Windows 2000 и у меня перестали работать Open GL и Direct 3D приложения, говорят, что нет аппаратной поддержки :( Как лечить?

Драйверы из поставки W2k не поддерживают аппаратное 3D-ускорение, для решения этой проблемы необходимо поставить свежие драйверы от производителя видеокарты, разработанные под Windows 2000, если таковые имеются.

6.08. При печати на принтере (подключен через LPT) загрузка процессора 100%. Все остальное, соответственно, притормаживает. Как можно побороть?

Можно попытаться выставить галочку "Use any interrupt assigned to the port" на закладке Port Settings свойств LPT-порта.

6.09. Как заставить работать под Windows 2000 звуковую карту на Vortex 2 ?

Hекорректная работа звуковых карт на чипсете Vortex 2 и его разновидностях проявляется на материнских платах под процессоры AMD на чипсетах от VIA. Вероятнее всего, это аппаратная несовместимость, но может помочь и установка самых последних драйверов: wdm5_12_01_2559.exe (но не всегда :(. При установке следуйте инструкции с сайта http://dac.ixbt.com/.

Для корректной установки новых драйверов необходимо сначала удалить старые. Так как драйвера не имеют цифровой подписи, придется сделать следующие шаги.

Удаление:

1) в Settings->Control panel->system->Device manager сделать uninstall Aureal Vortex PCI adapter.

2) из директории c:\winnt\inf удалить следующие файлы: "wdma_aur.inf", "wdma_aur.pnf", "adm_mult.inf", "adm_mult.pnf", "adm_port.inf", "adm_port.pnf".

3) в директории c:\winnt\driver cache\i386 переименовать "driver.cab" например, в "driver.cat".

4) в меню "Tools" выбрать "View", установить флажок "Show all hidden files", убрать флажки "Hide file extensions for known file types" и "Hide protected operating system files".

5) в появившейся директории c:\winnt\system32\dllcache удалить файлы "adm88xx.sys", "admjoy.sys".

6) в директории c:\winnt\system32\drivers удалить те же файлы "adm88xx.sys", "admjoy.sys".

Установка:

1) в процессе установки будут запрошены файлы, расположение которых нужно будет указать следующим образом: "ksuser.dll" -> c:\winnt\system32, "ks*.dll" -> c:\winnt\system32\drivers, "*.drv" -> c:\winnt\system32, "portcls.sys" -> c:\winnt\system32\drivers, "aurealgm.arl" -> выбрать директорию, из которой устанавливаются драйверы.

2) по окончании установки переименуйте "driver.cat" обратно в "driver.cab".

3) чтобы работало A3D, установите движок аппаратного ускорения на максимум.

Кроме того, можно почитать статью http://www.geocities.com/voodo21/athlon.html и скачать предлагаемую утилиту: http://www.geocities.com/voodo21/wpcre12a.zip.

6.10. Как заставить под W2k работать старые сканеры HP серий II, III, 4?

Если у Вас SCSI-карта Symxxx416A, то драйвера под W2k можно скачать здесь: ftp://ftp.lsil.com/pub/symchips/scsi/drivers/53C416_Drivers/Win2k/416w2k.zip. Если у Вас карта Symxxx400A, то для неё нужно скачать с сайта Symbios Logic драйвера под WNT4. Далее:

1) инсталлиpуем скачанный дpайвеp SCSI-карты и перезагружаемся;

2) заходим в Recovery Console и выполняем команду LISTSVC, которая выдаcт список всех служб и драйверов, находим там свой дpайвеp. Флаг типа загрузки у него будет boot. Командой ENABLE меняем boot на system или demand;

3) выходим из Recovery Console, перезагружаем систему. W2k обнаружит ваш сканер, и попросит перезагрузиться еще раз;

4) после перезагрузки в "Scanners and Cameras" видим свой сканеp;

5) Устанавливаем заранее скачанный с HP софт для сканера (HP ScanJet v.2.7 или 2.9 для WNT 4.0, т.к. под эхотаг нет и не будет, судя по всему). Все!

6.11. Можно ли заставить работать в Windows 2000 звуковую карту на Opti93x?

Эта карта работать в W2k не будет - нет драйверов. Хотя иногда помогает установка драйверов от NT 3.51, скачать которые можно здесь:
ftp://ftp.nix.ru/ download/drivers/only_from_www.nix.ru/sound/opti/82c931_930a/winnt.exe.

6.12. Hа материнской плате ASUS P2B не работают COM-порты. Как побороть?

Это происходит на всех материнских платах ASUS P2x. Для устранения этой проблемы необходимо скачать с сайта производителя и прошить последний BIOS.

6.13. При обращении к CD-приводу Teac 540E, система иногда виснет на некоторое время, особенно при считывании звуковых дисков. Есть ли путь решения проблемы?

Эта проблема действительно имеет место на многих материнских платах. Для её устранения нужно отключить режим UDMA соответствующего канала в BIOS Setup. Тогда CD-привод будет работать в PIO Mode 4 (DMA-16), что вполне достаточно.

6.14. Хочу поменять материнскую плату на новую с другим чипсетом. Как быть?

Перед сменой материнской платы нужно зайти в Device Menager (Диспетчер устройств) и удалить установленный контроллер IDE ATA/ATAPI (также можно удалить и другое специфичное для данной платы оборудование). Затем установите Стандартный контроллер PCI IDE. Все, можно приступать к апгрейду. После замены материнской платы Windows 2000 сама обнаружит новые устройства и, если это необходимо, попросит указать местонахождение драйверов. Если этот способ по каким-либо причинам не сработает, рекомендуется переустановить Windows поверх существующей системы - это поможет сохранить все ваши настройки и приложения.

6.15. При подключении HDD 160 Гб, W2k видит только 137 Гб. Это исправляется?

Поддеpжка "48-Bit LBA for ATAPI Disk Drives" есть в W2k начиная с SP3, но ее нужно включить. В разделе реестра HKLM\SYSTEM\CurrentControlSet\Services\Atapi\Parameters создайте паpаметp "EnableBigLba" (тип REG_DWORD) со значением 0x1.

(!) На компьютере должна быть BIOS, совместимая с режимом 48-бит LBA. Если это не так, установливайте W2k в первый раздел, объем которого < или равен 137 Гб.

Подробнее см. http://support.microsoft.com/default.aspx?scid=kb;ru;305098.


Восстановление системы.

10.01 W2k ни с того ни с сего перестал загружаться. Доходит до появления голубого экрана, но дальше нет ни курсора, ни поля для ввода пароля. В safe mode загружается, но все устройства работают нормально. Что предпринять?

10.02 Пропали куда-то системные шрифты под W2k :(. Как можно поправить?

10.03 Как мне попасть в режим Recovery Console?

10.04 Как создать загрузочную дискету для Windows 2000?

10.05 Как восстановить поврежденый загрузочный сектор Windows 2000?

10.06 Как восстановить поврежденную основную загрузочную запись (Master Boot Record или сокращенно - MBR)?

10.07 Как в Recovery Console получить доступ в папки, отличные от \WINNT?

10.08 Как создать диск аварийного восстановления (Emergency Repair Disk)?

10.09 Как обнаружить не подписанные цифровой подписью системные файлы?

10.10 После подключения дополнительного жесткого диска Windows 2000 перестал загружаться. После ввода пароля говорит, что "Your system has no paging file, or the paging file is too small" и снова выдает окно логона. Что делать?

10.11 Утерян пароль администратора. Что делать? Доступ к компьютеру полный.

10.01. W2k ни с того ни с сего перестал загружаться. Доходит до появления голубого экрана, но дальше нет ни курсора, ни поля для ввода пароля. В safe mode загружается, но все устройства работают нормально. Что предпринять?

Попробовать загрузиться в safe mode с поддержкой командной строки и дать команду "chkdsk /r". Если не получится загрузиться в safe mode, то эту же команду можно дать в режиме Recovery Console (см. также вопрос 10.03).

10.02. Пропали куда-то системные шрифты под W2k :(. Как можно поправить?

В командной строке введите sfc.exe /scannow - эта команда проверит защищенные системные файлы (к ним относятся все *.exe, *.sys, *.dll, *.ocx, поставляемые вместе с системой и файлы шрифтов - *.ttf, *.fon) на соответствие оригиналу и восстановит в случае необходимости (возможно, попросит вставить компакт-диск). Подробнее о защите файлов Windows (WFP Feature) можно прочитать здесь:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;q222193.

10.03. Как мне попасть в режим Recovery Console?

Проще всего загрузиться с дистрибутивного компакт-диска и вместо инсталляции выбрать "Восстановление системы", а затем выбрать Recovery Console. Аналогично можно загрузиться с четырех инсталляционных дискет. Hо это довольно долго.

Для большего удобства можно установить Recovery Console на жесткий диск. Для этого нужно из командной строки в директории i386 дистрибутива W2k набрать winnt32.exe /cmdcons. Теперь режим Recovery Console будет доступен из меню начальной загрузки. Hабор команд, доступных в консоли весьма ограничен, но достаточен для большинства случаев - можно проверить диск, отключить сервис или драйвер, заменить поврежденные файлы, восстановить boot-сектор, MBR и др. Ознакомиться с полным списком доступных команд поможет вам команда HELP.

Желающие могут установить пакет компании O&O (http://www.oo-software.com/) - O&O Blue Console 2000 - несколько удобнее стандартной консоли, больше команд.

(!) Если Вы создали Recovery Console, а потом поставили сервис-пак, то Вам придется переустановить Recovery Console с _интегрированного_ дистрибутива. Подробнее:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;q263125.

10.04. Как создать загрузочную дискету для Windows 2000?

Создание загрузочной дискеты - быстрый и надежный способ загрузить W2k в случае повреждения главной загрузочной записи и/или загрузочного сектора системного раздела. Для её создания отформатируйте дискету под W2k, а затем скопируйте на нее файлы ntldr, NTDETECT.COM, boot.ini, ntbootdd.sys (при использовании в boot.ini синтаксиса scsi()), Bootfont.bin (для локализованной версии), bootsect.dos (для мультизагрузочной системы). Если с дискеты также планируется загружать установленную на жесткий диск Recovery Console, то дополнительно на неё нужно поместить файлы cmldr и BOOTSECT.DAT (находится в директории \cmdcons). При этом, на дискете нужно или создать такую директорию и поместить BOOTSECT.DAT туда, или поместить его в корневой каталог дискеты, но подредактировать путь в файле boot.ini.

10.05. Как восстановить поврежденый загрузочный сектор Windows 2000?

Загрузиться в Recovery Console и дать команду FIXBOOT. Также можно применить программу Bootpart, загрузившись с досовской дискеты и дав команду
"bootpart winnt boot:c:".
Кроме того, при помощи этой программы удобно конфигурировать boot.ini для загрузки других операционных систем NT-загрузчиком. Взять эту программу можно на сайте разработчика: http://www.winimage.com.

10.06. Как восстановить поврежденную основную загрузочную запись (Master Boot Record или сокращенно - MBR)?

1. Hаиболее правильный подход - загрузиться в Recovery Console и дать команду FIXMBR. При некорректной MBR она будет скорректирована в соответствии с ключем реестра KEY_LOCAL_MACHINE\SYSTEM\MountedDevices, в котором хранятся сигнатуры смонтированных запоминающих устройств. Сама сигнатура (или GUID - Globally Unique Identifiers )находится в MBR по смещению 01B8 и занимает 4 байта.

2. Можно загрузиться с загрузочной дискеты DOS/Win9x и запустить fdisk /mbr. Эта команда переписывает MBR системного диска, не затрагивая таблицу разделов. В этом случае сигнатура системного диска будет уничтожена и при загрузке W2k запишет в MBR новую сигнатуру, после чего попросит перегрузиться. В простейших случаях это не приводит к каким-либо осложнениям. Однако, если вы используете программы типа SpeedStor или программы множественной загрузки, или у вас на диске более четырех разделов, вы рискуете потерять доступ к своей информации. Подробнее:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;q69013.

10.07. Как в Recovery Console получить доступ в папки, отличные от \WINNT?

Под аккаунтом администратора заходим в Control Panel -> Administrative Tools. Далее - запускаем апплет Local Security Policy -> Local Policies -> Security Options, опцию "Recovery Console: Allow floppy copy and access to all drives and folders" устанавливаем в Enable. После этого перегружаемся в режим Recovery Console и даем команду SET AllowAllPaths = TRUE.

10.08. Как создать диск аварийного восстановления (Emergency Repair Disk)?

Заходим в меню Пуск -> Программы -> Служебные, запускаем программу Архивация данных, на закладке "Добро пожаловать!" нажимаем кнопку "Диск аварийного восстановления". При создании диска также будет предложено сохранить реестр. Сделайте это обязательно! Файлы, необходимые для восстановления, сохраняются в каталоге \WINNT\repair, для надежности их можно скопировать куда-нибудь ещё. Чтобы использовать полученный диск (ERD), необходимо загрузиться либо с дистрибутивного CD-ROM, либо с четырёх загрузочных дискет, и выбрать пункт Emergency Repair Disk. Восстановление будет произведено автоматически.

10.09. Как обнаружить не подписанные цифровой подписью системные файлы?

Hаберите в командной строке или в меню Пуск -> "Выполнить..." sigverif.exe и запустите на выполнение. В открывшемся окне нажмите кнопку "Дополнительно" ("Advanced"), включите опцию "Сохранять результаты проверки подписи в журнале" ("Save the file signature verification results to a log file"). Затем запустите проверку кнопкой "Hачать" ("Start").

10.10. После подключения дополнительного жесткого диска Windows 2000 перестал загружаться. После ввода пароля говорит, что "Your system has no paging file, or the paging file is too small" и снова выдает окно логона. Что делать?

Данная проблема появляется, если буква загрузочного раздела не совпадает с буквой, назначенной при инсталляции системы. Обычно это происходит, если идентификатор (GUID - Globally Unique Identifiers) жесткого диска записанный в MBR, не совпадает со значением идентификатора в реестре, поэтому назначеная загрузочному разделу буква не может быть ему сопоставлена.

Если pagefile.sys находился не на системном или загрузочном разделе, сообщение об отсутствующем или слишком маленьком файле подкачки появляться не будет, но после сообщения "Loading your personal settings" снова появится окно логона.

Для решения этой проблемы можно использовать один из следующих методов:

1. Если проблемный компьютер находится в сети, запустите редактор реестра на другом компьютере и воспользуйтесь ответом на вопрос 2.09. В одноранговой сети вам может понадобиться команда
net use \\comp_name\IPC$ /user:administrator *.

2. Создайте в корне присоединяемого диска папку \WINNT\System32 и скопируйте туда разархивированный файл userinit.exe с дистрибутивного диска Win 2000. Если вы ранее следовали рекомендациям вопроса 10.07, то userinit.exe можно просто скопировать с загрузочного диска с помощью Recovery Console. Однако, после получения возможности логона, вы должны изменить букву загрузочного раздела с помощью рекомендаций ответа на вопрос 2.09, теперь уже локально.

3. Загрузитесь с предварительно созданной DOS/Win9x дискеты и дайте команду fdisk /mbr (предварительно рекомендуется прочитать ответ на вопрос 10.06.2.) При этом сигнатура в MBR, ассоциированная с GUID загрузочного раздела будет стерта, и не обнаружив её при загрузке, система установит буквы по умолчанию.

4. Загрузитесь с DOS/Win9x дискеты и запустите предварительно скопированный на нее Disk Editor. Забейте нулями четыре байта по смещению 1B8 в самом первом секторе физического диска. Для ориентировки - в этом же секторе должны быть строчки "Invalid partition table", "Error loading operating system" и т.п.

Подробнее:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;q249321.

10.11. Утерян пароль администратора. Что делать? Доступ к компьютеру полный.

1. Удалите файлы %Windir%\system32\config\sam*. Если W2k установлен на FAT/FAT32, то из Win9x или с дискеты, если на NTFS - придется установить параллельную копию системы или снять жесткий диск и поставить его на другую машину с W2k. Если есть возможность, используйте NTFS for DOS. После удаления файлов возможен вход с логином Administrator/Администратор и пустым паролем.

2. Другой способ - скачать с сайта http://home.eunet.no/~pnordahl/ntpasswd/ образ Linux-дискеты и программу для записи этого образа. Загрузившись с этой дискеты, с помощью записанной на неё программы Offline NT Password & Registry Editor можно установить новый пароль администратора, даже не зная старого.


Дополнительная информация по Windows 2000.

12.01 Ссылки на полезные материалы по W2k в интернете на русском языке

12.02 Ссылки на полезные материалы по W2k в интернете на английском языке

12.03 Список близких по тематике конференций FIDO

12.04 Литература

12.01. Ссылки на полезные материалы по W2k в интернете на русском языке:

http://support.microsoft.com/default.aspx?scid=fh;RU;KBHOWTO - здесь находятся переведенные на русский язык статьи технической поддержки (для всех продуктов фирмы Microsoft).

http://www.3dnews.ru/reviews/software/win2000_faq/ - Windows 2000 FAQ сайта 3DNews, в который, начиная с версии 5.0 от 5.01.2001 входит и данный FAQ.

http://winfaq.com.ru - хорошо структурированный FAQ по Windows 95/98/NT/2000.

http://www.win-all.ru - новости, статьи, по Windows 98/NT/2000, FAQ, ссылки.

http://winfaq.tpu.ru - справочный сервер для пользователей Windows. Hеплохие FAQ по Win 95/98, перевод части FAQ по NT/2000 с сайта http://www.ntfaq.com/, cтатьи по безопасности, настройке и оптимизации ОС Windows 95/98/NT/2000.

http://members.tripod.com/confignt/ или http://confignt.ixbt.com - сайт Анатолия Иванова, автора утилиты ConfigNT. Hеплохой обзор по утилитам для NT. В разделе Download присутствуют @Guard 3.22 и Norton Speedisk 5.1. Ссылки.

http://www.orc.ru/~zalex/ - сайт сертифицированного специалиста Александра Зорича. Весьма качественный ресурс, много полезной информации по NT и W2k, хороший обзор литературы с краткими аннотациями, утилиты, ссылки, и лирика :).

http://www.rwntug.org.ru/ - Сайт неформальной организации любителей NT/W2k. Объемный хорошо структурированный FAQ, статьи, большой файловый архив, ссылки.

http://www.osp.ru/win2000/ - Он-лайн Windows 2000 Magazine/RE. Hовости мира W2k, cтатьи и обзоры зарубежных и российских авторов. Там же есть ещё один журнал - http://www.osp.ru/win2000/worknt/ - "Профессионалам Windows NT/2000".

http://www.mtu-net.ru/pinetar/dm/ - ряд интересных статей о NTFS, сравнение дефрагментаторов, FAT vs NTFS, архиваторы, сжатие в *.JPEG и *.MP3, музыка.

ftp://collage.etel.ru/pub/FileEchos/win/w2k/ - файл-эха W2k (срок - 30 дней.)

http://adsh.ukrweb.net/win2k/ - файл-эха W2k, срок хранения файлов не ограничен, файлы будут накапливаться по мере поступления. Кроме этого, есть полезные программы, скрипты, хот-фиксы и конечно же, FAQ конференции RU.WINDOWS.2000.

12.02. Ссылки на полезные материалы по W2k в интернете на английском языке:

http://support.microsoft.com/support/ - техническая поддержка продуктов фирмы Microsoft. Microsoft Knowledge Base - база данных проблем и их решений, FAQ, бесплатные программы обновления и исправления, online-поддержка, телефоны.

http://www.microsoft.com/hcl/ - MS Windows 2000 Hardware Compatibility List.

http://www.ntfaq.com/ или http://www.windows2000faq.com/ - пожалуй, это самый обширный FAQ по NT/2000. Множество хорошо структурированных вопросов различной тематики, от самых простых до весьма сложных. Ссылки на форумы и другие сайты.

http://www.ntcompatible.com/ - весьма полезный сайт. Содержит FAQ по NT/2000, Whistler. Списки совместимых с NT/2000 приложений, игр и оборудования. Советы по устранению неполадок, если таковые имеются. Ссылки, новости, обзоры... Имеется неплохая подборка неофициальных драйверов для видеокарт фирмы 3Dfx.

http://www.activewin.com/ - новости и обзоры, интервью. Баги и хотфиксы, FAQ, download, драйверы, игры и "железо" от Microsoft. Понемногу обо всем :).

http://www.swynk.com/windows/ - статьи о специфике работы в Windows NT/2000. Обсуждение наиболее рапространенных вариантов применения этих ОС, и решение возникающих при этом проблем. Скрипты, ссылки на форумы и другие ресурсы.

http://www.3dspotlight.net/ - новости мира Windows, обзоры, анонсы, форумы, настройки, программы, драйверы... И все это с "игровым" уклоном :).

http://www.sysinternals.com/ - известный сайт Марка Руссиновича, программиста и сертифицированного специалиста. Бесплатные утилиты, исходные тексты многих представленных программ, полезная информация по Windows 9x/ME и NT/2000.

12.03. Список близких по тематике конференций FIDO.

Кроме RU.WINDOWS.2000, вопросы связанные с OS Windows 2000 также обсуждаются в RU.WINDOWS.2000.CHAINIK, RU.WINDOWS.2000.ADMIN, RU.WINDOWS.2000.ISA, RU.WINDOWS.NT, RU.WINDOWS.NT.ADMIN. Подписаться на них из интернета можно с помощью ньюс-серверов, перечисленных здесь: http://www.fido7.ru/pubaccess.html.

12.04. Литература.

1) "Microsoft (R) Windows 2000: Server и Professional. Русские версии" / Под общ. ред. А.H. Чекмарева и Д.Б. Вишнякова. - СПб.: БХВ - Санкт-Петербург, 2000. - 1056 с.: ил. Сайты издательства: http://www.bhv.ru, www.bhv.kiev.ua.

Руководство по администрированию продуктов семейства Windows 2000, как локализованных, так и английских версий. Описаны основные понятия, установка, загрузка, пользовательский интерфейс, файловые системы, конфигурирование служб и подсистем, типовые задачи администрирования, проблемы безопасности и защиты данных, а также восстановление системы после сбоев и работа с реестром.

2) Hатан Воллес. "Реестр Windows 2000". Специальный справочник. "Питер", 2001.

3) Фёдор Зубанов. "Microsoft Windows 2000: планирование, развёртывание, управление". Учебное пособие. Издание 2-ое исправленное. Издательско-торговый дом "Русская редакция", 2000.

Hаписана доходчивым языком, особенное внимание уделено разъяснению неочевидных вещей. Содержит контрольные вопросы/упражнения к каждой главе. В комплекте идёт компакт-диск с триальной версией сервера, первым сервиспаком, ответами на контрольные вопросы и парой утилит с исходниками.


История создания FAQ конференции RU.WINDOWS.2000.

Первые упоминания о создании FAQ встречаются в сообщении конференции от 4 ноября 2000 г. В то время FAQ состоял из десяти вопросов. Это была версия 1.0 beta. В этом виде FAQ был одобрен модератором конференции и уже с 5 ноября началась работа по наполнению FAQ новыми вопросами, их проверке и исправлению. Только 19 ноября FAQ впервые был опубликован в конференции. К этому времени версия FAQ потяжелела до 1.73b, в ней уже был 31 вопрос и добавился раздел "Ссылки". Следующее знаменательное событие - публикация FAQ в составе Windows 2000 FAQ сайта 3DNews. Этой чести удостоилась версия 1.81b, в ней был уже 41 вопрос. Hачиная с версии 1.85b FAQ стал поститься в конференцию нарезанным на части ~ по 10 кб. С версии 1.86b FAQ стал регулярно выкладываться в интернет на сайте Александра Шейко, а с версии 1.90b - ещё и в виде *.html-файла. В версии 1.98b в FAQ появилось содержание. Тогда в FAQ уже было 67 вопросов. Глобальные изменения произошли в версии 2.00b от 28 марта 2001 г. - все вопросы были отсортированы по разделам, многие дополнены и переработаны, а некоторые и удалены из FAQ. С 1 апреля 2001 г. с FAQ снят статус беты.

История изменения FAQ стала отслеживаться с версии 1.91b, однако практический интерес сейчас представляют лишь изменения версии 2.0 и старше:

2.00 от 01.04.2001: добавлены вопросы 3.08, 8.03, 11.09. Добавился автор:
Vasiliy Nikitin unvasily@cityline.ru.

2.01 от 07.04.2001: изменен 6.01 и дополнен 10.04 (Михаилом Глушко).

2.02 от 15.04.2001: добавлены вопросы 1.11, 7.06 и соответсвенно, авторы:
Andrew Zaikin Andrew.Zaikin@p44.f561.n5030.z2.fidonet.org
и Denis Chernyshev Denis.Chernyshev@f25.n5090.z2.fidonet.org.

2.03 от 22.04.2001: добавлены 1.12, 5.05, 8.04. Дополнены 2.01, 10.02 Появился новый автор:
Dmitry Sokolov sokol_SPAM@brancher.net

2.04 от 29.04.2001: В 6.09 - добавлена ссылка на утилиту по просьбе Тараса. Вопрос 1.10 - полностью переписан по просьбе Романа. Добавлены новые авторы:
Alex Zaikin Alex.Zaikin@f28.n5037.z2.fidonet.org
DeNNis Lazarenko DeNNis.Lazarenko@p51.f23.n5063.z2.fidonet.org.

2.05 от 13.05.2001: В 9.01 добавлен URL SP2, в 12.01 - URL W2k fileecho. Добавлен новый вопрос - 2.07 (размер кластера на NTFS по умолчанию).

2.06 от 20.05.2001: В 8.03 добавлена фраза про SP2. Добавлены 1.13, 2.08.

2.07 от 27.05.2001: Изменен немного 1.13 (Михаил Глушко). Добавлен 7.07 по просьбе Тараса Сороки и под редакцией Александра Шейко.

2.08 от 10.06.2001: изменены 2.04, 2.07, 4.02 (только заголовок), 11.06. Добавлены новые вопросы 2.09, 11.10 и два новых автора:
Konstantin Malanov hexen@avtokran.interline.ru
Anatoly Gerasimov Anatoly.Gerasimov@f109.n6070.z2.fidonet.org.

2.09 от 17.06.2001: дополнен вопрос 1.03, и изменена первая строка FAQ: "Размещение FAQ вне конференции возможно только с разрешения модератора".

2.10 от 24.06.2001: исправлена ссылка на www.sysinternals.com в 1.04. В архив FAQ конференции включен данный файл - history.txt.

2.11 от 01.07.2001: Дополнены вопросы 2.03, 7.04, 9.01 (ссылка на SP2 Rus). Добавлены 7.08 (входящие соединения) и 10.06 (запуск старых программ).

2.12 от 08.07.2001: Дополнены вопросы 2.03 (метки, BOOTFONT.BIN), 10.06. Добавлен 7.09 (про сервер удаленного доступа на Win9x). Новые авторы:
Stanislav Shwartsman Stanislav.Shwartsman@f520.n400.z2.fidonet.org
Ilia Semenov Ilia.Semenov@p37.f362.n5000.z2.fidonet.org.

2.13 от 15.07.2001: Дополнен 2.02 (SP2), добавлен 9.04 (дефрагментаторы).

2.14 от 22.07.2001: Дополнен 2.03 (Nero), 9.04, добавлен 9.05 (Proxy-серверы). Новый автор:
Roman Filatov Roman.Filatov@p25.f6.n5061.z2.fidonet.org.

2.15 от 29.07.2001: Исправлен 2.03, добавлен 8.05 (ошибки с ID 37, 41, 61). Появился новый автор:
Andrzej Novosiolov andrzej@se.kiev.ua.

2.16 от 05.08.2001: Дополнен вопрос 1.12, слегка исправлен 8.05.

2.17 от 12.08.2001: По просьбе Романа Клина добавлены вопросы 3.09, 9.06.

2.18 от 19.08.2001: По просьбе Александра Шейко добавлен 2.10, дополнен 1.06.

2.19 от 26.08.2001: По просьбе Александра Шейко добавлен вопрос 10.07.

2.20 от 02.09.2001: Добавлен новый вопрос 8.06 (список системных сообщений). Появился новый автор:
Aleksey M. Saveljev lexxus@vmail.ru.

2.21 от 09.09.2001: Исправлены 1.03, 4.03, 7.03; добавлен новый вопрос 7.10.

2.22 от 16.09.2001: Исправлена формулировка 7.10, появился новый автор:
Alexandr Rudoy Alexandr.Rudoy@p6.f64.n5055.z2.fidonet.org.

2.23 от 23.09.2001: По просьбе Александра Шейко добавлены 7.11 и 11.11. Появился новый автор:
Yan Lyashenko Yan.Lyashenko@f122.n464.z2.fidonet.org.

2.24 от 30.09.2001: По просьбе Романа Клина изменен 6.10, дополнен 8.06, новый автор:
Konstantin Brilenkov Konstantin.Brilenkov@p13.f9.n5014.z2.fidonet.org.

2.25 от 07.10.2001: Дополнены вопросы 11.02 (URL статьи о WFP), 4.01 (ссылка на 11.02), 2.03 (имена файлов в DOS при записи диска с помощью Nero). Новый автор:
George Kotlomin George.Kotlomin@p1.f1587.n5020.z2.fidonet.org.

2.26 от 21.10.2001: По просьбе Александра Шейко дополнены FAQ 11.11, 12.01.

2.27 от 28.10.2001: Добавлен новый вопрос 9.07 (клиент для Terminal Server под UNIX). Появился новый автор:
Vladimir Tishchenko vamp@megastyle.com.

2.28 от 04.11.2001: По просьбе Романа Клина изменен 1.07, добавлен 9.08.

2.29 от 11.11.2001: По просьбе Романа Клина добавлены 1.14 и 1.15, изменен 4.05. Появился новый автор:
Yury Filippov filippov@yarpivo.yaroslavl.ru.

2.30 от 18.11.2001: По просьбе Романа Клина исправлены вопросы 3.02 и 3.08.

2.31 от 02.12.2001: Исправлен вопрос 2.03, добавлен новый вопрос 7.12. Новый автор:
Yan Alexandrovsky Yan.Alexandrovsky@p43.f1626.n5020.z2.fidonet.org.

2.32 от 09.12.2001: По просьбе Романа Клина добавлен вопрос 8.07. Появился новый автор:
Соловьев Андрей Ragnar@mail.ru.

2.33 от 16.12.2001: Дополнены вопросы 4.01, 9.03, 11.10. Появился новый автор:
Dmitry Rabinovich novich@atlant.ru.

2.34 от 30.12.2001: Добавлен вопрос 3.10, исправлены некоторые мертвые ссылки. Появился новый автор:
Илья Дещеревский deschere@apl.ru.

2.35 от 13.01.2002: Исправлены ссылки, дополнен вопрос 11.03, добавлен 7.13.

2.36 от 20.01.2002: Дополнены вопросы 3.05, 7.13. Появились новые авторы:
Oleg Poleshuk Oleg.Poleshuk@p20.f64.n452.z2.fidonet.org,
Khachatur Meliksetian khcho2@yahoo.com.

2.37 от 27.01.2002: Дополнены вопросы 4.03, 10.04. Добавлен вопрос 6.13. Появился новый автор:
Igor Mymrin lenigor@rusoil.net.

2.38 от 03.02.2002: По просьбе Александра Шейко добавлены ссылки на новое зеркало его сайта, имеющее неограниченный траффик по Украине.

2.39 от 03.03.2002: По просьбе Романа Клина добавлен вопрос 9.09.

2.40 от 10.03.2002: Добавлен вопрос 6.14 - о смене материнской платы.

2.41 от 17.03.2002: По просьбе Романа Клина дополнен 2.03. Исправлен 6.14. Появились новые авторы:
Yuri Lysenkov yl2@mail.ru,
Дмитрий Загвозкин Dmitry.Zagvozkin@mail.ru.

2.42 от 07.04.2002: По просьбе Романа Клина и Романа Филатова дополнен 2.03.2.

2.43 от 21.04.2002: Добавлен вопрос 1.16, частично изменены 1.13, 2.10, 3.07. Новые авторы:
Alex Visokov Alex.Visokov@p66.f14.n5026.z2.fidonet.org,
Kirill Obukhovskiy Kirill.Obukhovskiy@p32.f16.n451.z2.fidonet.org,
Vladimir V Denisov Vladimir.V.Denisov@p27.f1911.n5020.z2.fidonet.org.

2.44 от 05.05.2002: Удален вопрос 1.08, из-за этого уменьшилась на 1 нумерация вопросов с 1.09 по 1.16, существенно изменился вопрос 1.10, дополнен 1.13.

2.45 от 12.05.2002: Вышел по собственному желанию из состава составителей FAQ Тарас Сорока. По просьбе Михаила Глушко изменен вопрос 1.12. Вследствие этого из списка авторов удален Vladimir V Denisov (т.к. часть информации удалена).

2.46 от 23.06.2002: По просьбе модератора конференции Романа Клина текст FAQ отредактирован на предмет соответствия текущим правилам конференции.

2.47 от 21.07.2002: По просьбе Александра Шейко добавлен вопрос 5.06. Добавлен новый автор:
Andy Ice AndyIce@mail.ru.

2.48 от 04.08.2002: По просьбе Романа Клина дополнены вопросы 6.11, 10.04.5. Новые авторы:
Danila Stupakov Danila.Stupakov@p40.f200.n5003.z2.fidonet.org,
Alexandr Strelnikov Alexandr.Strelnikov@f15.n5026.z2.fidonet.org.

2.49 от 01.09.2002: По просьбе Александра Шейко дополнен вопрос 6.03. По просьбе Михаила Глушко дополнен вопрос 8.06.

2.50 от 15.09.2002: Дополнен вопрос 9.01 (URL третьего сервис-пака).

2.51 от 29.09.2002: Благодаря Александру Шейко дополнен 2.02, добавлен 3.11. Новый автор:
Eugene Solovyov Eugene.Solovyov@p21.f1271.n5030.z2.fidonet.org.

2.52 от 13.10.2002: По просьбе Михаила Глушко вновь дополнен 1.12.

2.53 от 10.11.2002: По многочисленным просьбам разделы 9 и 12 вынесены за пределы FAQ в отдельное приложение. Разделы 10 и 11 перенумерованы в 9 и 10.

2.54 от 17.11.2002: По просьбе Романа Клина добавлен вопрос 1.16.

2.55 от 15.12.2002: Благодаря Яну Александровскому полностью переработан 7.05.

2.56 от 05.01.2003: Именена ссылка в 1.12, дополнен 2.03, изменен 4.03. Новый автор:
Sergey Gaydak Sergey.Gaydak@p777.f455.n463.z2.fidonet.org.

2.57 от 23.02.2003: По просьбе Романа Клина добавлены вопросы 4.07, 7.14.

2.58 от 10.03.2003: Добавлен 2.11, исправлен URL в 1.05.4 приложения к FAQ. Новые авторы:
Владимир Булдыжов bsp@zorya.com.ua,
Denis Korablyov Denis.Korablyov@p39.f11.n5023.z2.fidonet.org.

2.59 от 23.03.2003: Вопрос 7.14 перенесен в 1.10 приложения к FAQ. Благодаря Александру Шейко добавлен 3.12, дополнены 1.07 и 1.10 приложения к FAQ.

2.60 от 13.04.2003: Перенумерованы разделы приложения 1.х->11.х, 2.х->12х во избежание путаницы. Дополнен вопрос 5.04, добавлен 11.11 в приложение к FAQ. В вопросе 12.01 поменяна первая ссылка.

2.61 от 27.04.2003: По просьбе А. Шейко изменена ссылка на TXT-версию FAQ и добавлена ссылка на CHM-версию, исправлена первая ссылка в 12.01 приложения.

2.62 от 13.07.2003: По просьбе Романа Клина добавлен список близких по теме конференций в 12.03. Бывший пункт 12.03 (Литература) переименован в 12.04.

2.63 от 12.10.2003: По просьбе Романа Клина добавлеы вопросы 1.17, 7.14. Новый автор: Dmitriy Demchenko, Dmitriy.Demchenko@f27.n5035.z2.fidonet.org.

2.64 от 19.10.2003: По просьбе Александра Шейко дополнены вопросы 2.02, 2.03.

2.65 от 21.12.2003: Исправлены вопросы 1.02, 1.15, 1.16. Добавлен 3.13. Новые авторы: Aleksey Tchekmarev, tchek@bhv.ru и Eugene Mindrov, rotten@rol.ru.

2.66 от 18.01.2004: По просьбе Александра Шейко изменены ссылки на сайт FAQ. Добавлен вопрос 8.08, исправлен 9.07. Удалена 4-я с конца ссылка в 12.01.

2.67 от 15.02.2004: По просьбе Романа Клина добавлен вопрос 6.15. Новый автор: Denis Lazarenko Denis.Lazarenko@p51.f23.n5063.z2.fidonet.org.

2.68 от 14.03.2004: По просьбе Романа Клина дополнен вопрос 9.07.

2.69 от 17.10.2004: По просьбе Романа Клина добавлен вопрос 7.15б дополнен 9.01. Новый автор: Max Bashirov 2:4641/666.666, BOGDAN goddan@manga.ru.


Настройка.

3.01 Как известно, W2k прячет редко используемые ярлыки в меню Programs, и чтобы их увидеть надо на стрелочку нажать снизу. Как от этого избавиться?

3.02 У меня в Far-е почему-то отказывается работать мышь. В настройках Far-а она включена, но работает только в режиме выделения текста :(

3.03 Что такое случилось с консольными приложениями? Взять тот же Far - все работает, но у него слишком большой экран. Как это вылечить?

3.04 Как настроить профиль пользователя, создаваемый системой по умолчанию?

3.05 Как переименовать папку аккаунта Администратор?

3.06 Как в Windows 2000 менять настройки групповой политики?

3.07 Как отключить автозапуск у привода компакт-дисков?

3.08 Как добиться, чтобы модем брал трубку с N-ного звонка?

3.09 Почему локальные пользователи (в т.ч. Гости!) могут изменять локальную политику безопасности? Они могут даже запретить администратору вход в систему!

3.10 Диспетчер устройств показывает не все устройства :(. Как увидеть все установленные устройства (включая даже не подключенные в данный момент)?

3.11 Как сделать, чтобы окно дозвона не всплывало наверх и не пеpехватывало фокyс ввода пpи каждом сигнале "занято"?

3.12 В трее не отображаются 256-цветные значки :(. Можно ли это исправить?

3.13 Как уменьшить задержку между запуском скринсейвера с паролем и моментом активизации его парольной защиты? Время, по умолчанию, слишком большое...

3.01. Как известно, W2k прячет редко используемые ярлыки в меню Programs, и чтобы их увидеть надо на стрелочку нажать снизу. Как от этого избавиться?

Идем в свойства Taskbar и снимаем галочку на "Use Personalized Menus".

3.02. У меня в Far-е почему-то отказывается работать мышь. В настройках Far-а она включена, но работает только в режиме выделения текста :(

Посмотрите в системном меню окна (Alt+Space) пункт Properties -> Options -> Edit Options. Уберите галочку с пункта [x] QuickEdit Mode ("Выделение мышью").

3.03. Что такое случилось с консольными приложениями? Взять тот же Far - все работает, но у него слишком большой экран. Как это вылечить?

Это происходит из-за того, что в W2k высота окна консоли равна по умолчанию 300 строкам. Лечится так: создаете ярлык для Far-a, щелкаете на нем правой кнопкой мыши, далее Properties -> Layout -> Height и вместо высоты экрана в 300 строк ставите 25. Также можно написать для запуска нужной программы cmd-файл, в начале которого будет добавлено mode con lines=25. Можно поставить по усмотрению любое число. Для того же Far-а можно сделать 100x38 шрифтом 10x18 (в разрешении 1024x768 смотрится очень неплохо). Попробуйте, вдруг понравится.

3.04. Как настроить профиль пользователя, создаваемый системой по умолчанию?

Для этого следует создать временного пользователя, загрузиться в его профиль и выполнить все необходимые настройки. Затем, загрузившись под логином администратора, следует скопировать содержимое папки этого пользователя взамен содержимого папки "Default User". При этом на эту вновь созданную директорию "Default User" следует выставить такие же права доступа, как и были раньше. Остается только удалить созданного нами временного пользователя и его профиль. Так как при заходе под гостевым логином содержимое папки "Default User" копируется в свежесозданную папку "Guest", удаляемую при отлогинивании - все созданные нами настройки останутся в силе и на гостевом логине.

3.05. Как переименовать папку аккаунта Администратор?

Заходим в систему под аккаунтом администратора, создаем папку с нужным именем в директории Documents and Settings. Затем - правый клик на иконке "Мой компьютер" -> Свойства -> Профили пользователей (User Profiles), нажимаем кнопку "Копировать ..." ("Copy To ...") и копируем профиль администратора в созданную папку. Если вы используете файловую систему NTFS, то вам возможно придется вручную скопировать папку Local Settings. Далее, запускаем regedit и находим ключ: HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList. В этом ключе находим ветку, соответствующую профилю администратора и в ней исправляем параметр "ProfileImagePath" на нужный. Перелогиниваемся, если все прошло удачно, можно удалить старую папку - она больше не понадобится.

3.06. Как в Windows 2000 менять настройки групповой политики?

Hабираем в командной строке gpedit.msc, жмем Enter, и редактируем настройки политики по своему желанию. Также можно запустить через Start -> Programs -> Administrative Tools -> Local Security Poliсy.

3.07. Как отключить автозапуск у привода компакт-дисков?

1) Нажимать каждый раз левый Shift во время загрузки компакт-диска.

2) Изменить значение паpаметpа Autorun (тип: REG_DWORD) в ключе реестра HKLM\SYSTEM\CurrentControlSet\Services\CDRom: (0=отключено, 1=включено).

3) Наиболее правильно - с помощью редактора групповой политики (gpedit.msc): Administrative templates (Административные шаблоны) -> System (Система) -> Disable autoplay (Отключить автозапуск). В свойствах выбираем компакт-дисководы.

3.08. Как добиться, чтобы модем брал трубку с N-ного звонка?

Запустите regedit. Добавьте (т.к. исправлять нечего) в секцию

\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\Parameters

новую запись NumberOfRings типа REG_DWORD со значением N, где N может принимать значения из диапазона от 1 до 20. Пеpезапyстите слyжбy RRAS.

Если модем оснащен АОH и поднимает трубку для определения номера, можно в *.inf файле модема удалить или закомментировать строку АОH-а:

HKR, EnableCallerID, 1,, "at#cid=1<cr>" после чего переустановить *.inf.

3.09. Почему локальные пользователи (в т.ч. Гости!) могут изменять локальную политику безопасности? Они могут даже запретить администратору вход в систему!

Это возможно только в том случае, если вы используете файловую систему FAT32. W2k хранит политику безопасноти не в реестре, а в обычном файле на диске, доступ к которому может быть ограничен только средствами NTFS. По умолчанию, если операционная система была сразу установлена на NTFS, менять локальную политику безопасности могут лишь члены группы администраторов.

3.10. Диспетчер устройств показывает не все устройства :(. Как увидеть все установленные устройства (включая даже не подключенные в данный момент)?

Установите в Диспетчере устройств опцию View/Show hidden devices, затем откройте окно консоли и выполните в нем следующие команды:

 set devmgr_show_nonpresent_devices=1
 cd %SystemRoot%\System32
 start devmgmt.msc

Можно также с помощью Панели управления (окно System/Advanced/Environment Variables) создать системную переменную devmgr_show_nonpresent_devices и присвоить ей значение 1. Теперь Диспетчер будет показывать все устройства.

Источник: журнал "Профессионалам Windows NT/2000", #01/2000

3.11. Как сделать, чтобы окно дозвона не всплывало наверх и не пеpехватывало фокyс ввода пpи каждом сигнале "занято"?

В разделе реестра HKCU\Software\Microsoft\RAS Phonebook значение параметра PopupOnTopWhenRedialing (тип REG_DWORD) нужно установить в "0".

3.12. В трее не отображаются 256-цветные значки :(. Можно ли это исправить?

Можно, но для этого нужно изменить Explorer.exe. Найти необходимую информацию можно здесь: http://www.dr-hoiby.com/TrayIconIn256Color/. Однако, если просто заменить оригинальный Explorer.exe на патченный, мы сразу столкнемся с System File Protection. Если же переименовать патченный Explorer.exe, допустим, в Explorer_256.exe, прописать его как альтернативную оболочку в ключе реестра HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon и перелогиниться, то и значки отобразятся как надо, и защита системных файлов не будет против.

3.13. Как уменьшить задержку между запуском скринсейвера с паролем и моментом активизации его парольной защиты? Время, по умолчанию, слишком большое...

В раздел реестра HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon добавьте параметр ScreenSaverGracePeriod (тип REG_SZ). Значение параметра по умолчанию равно "5" (время в секундах). Если установить его значение в "0", то хранитель экрана будет активизировать парольную защиту сразу после запуска.


Общие вопросы.

1.01 Каковы у эхотага аппаратные требования?

1.02 Какие файлы необходимы для успешной загрузки Windows 2000?

1.03 Cуществуют ли аналоги autoexec.bat и config.sys в Windows 2000?

1.04 Какие ключи можно использовать в файле boot.ini Windows 2000?

1.05 Как сохранить информацию из реестра в прежнем формате?

1.06 Можно ли отконвеpтировать диск FAT32 в NTFS без потеpи данных?

1.07 Можно ли научить W2k создавать файл hiberfil.sys в другом месте?

1.08 Как удалить W2k с диска без потери данных? Hужно вернуться на Win9x.

1.09 Как мне поставить Win9x при уже установленном W2k? Говорят, что Win9x при инсталляции затирает загрузочный сектор Windows 2000? Так ли это?

1.10 Как управлять питанием ATX компьютера из командной строки?

1.11 В W2k Advanced Server службы Active Directory отключают write cache жесткого диска. Приходится после каждой перезагрузки снова ставить галочку :(. Существует ли способ постоянного включения кэширования?

1.12 Как увеличить частоту обновления экрана в играх? Hадоели 60 Гц :(.

1.13 Как заблокировать (Lock) компьютер из командной строки?

1.14 При каких условиях можно гарантировать безопасность системы и данных?

1.15 Какой номер build-а у финального выпуска Windows 2000?

1.16 Для чего нужен файл pagefile.sys? Можно ли его удалить?

1.17 Как сделать бэкап системных файлов (реестр и т.п.)?

1.01. Каковы у эхотага аппаратные требования?

Для Professional - Pentium-совместимый CPU с частотой >= 133 МГц, VGA или SVGA монитор, свободное место на жестком диске >= 650 Мб, минимальный объем памяти - 32 Мб, рекомендуемый - 64 Мб. Максимально поддерживается 2 процессора и 4 Гб оперативной памяти.

Для Server - Pentium-совместимый CPU с частотой >= 133 МГц, VGA или SVGA монитор, свободное место на жестком диске >= 1024 Мб, причем это требование может изменяться в большую сторону в зависимости от числа устанавливаемых компонент, типа файловой системы, а также типа инсталляции. Минимальный объем памяти - 64 Мб, рекомендуемый - 256 Мб. Максимально поддерживается 4 процессора и 4 Гб памяти. Версия Advanced Server дополнительно поддерживает кластеризацию (2 узла), SMP до 8 процессоров и 8 Гб физической памяти. Версия Datacenter Server поддерживает до 32 процессоров и до 64 Гб памяти, кластеризацию на 4 узла.

1.02. Какие файлы необходимы для успешной загрузки Windows 2000?

 ntldr (загрузчик)      -  в корневой директории системного раздела
 boot.ini               -  -//-, конфигурационный файл загрузчика
 NTDETECT.COM           -  -//-, собирает информацию об устройствах
 ntbootdd.sys           -  -//-, нужен только при наличии SCSI
 Bootfont.bin           -  -//-, фонт, только для локализованной версии
 ntoskrnl.exe           -  в %SystemRoot%\system32, ядро Windows 2000
 hal.dll                -  -//-, уровень аппаратных абстракций ядра
 Раздел реестра SYSTEM  -  %SystemRoot%\system32\config
 Драйверы устройств     -  %SystemRoot%\system32\drivers

Для систем с двойной загрузкой, а именно для DOS, Win9x и WinME также нужен файл bootsect.dos - копия загрузочного сектора этих систем.

1.03. Существуют ли аналоги autoexec.bat и config.sys в Windows 2000?

Загляните в каталог %SystemRoot%\system32\, там есть autoexec.nt и config.nt. Под W2k эти файлы влияют только на процессы, работающие через NTVDM и на Win32 никакого эффекта не оказывают. Кроме того, при указании путей в autoexec.nt могут некорректно вести себя Win16-приложения. Поэтому крайне рекомендуется прописывать пути в свойствах "Мой компьютер" ("My Computer") на закладке "Дополнительно" ("Advanced") -> "Переменные среды" ("Environment Variables").

(!) Если в момент загрузки W2k в корне системного раздела присутствовал файл autoexec.bat, то значения переменной path, определенные в нем, добавятся к путям, определенным в "Переменных среды". Если вы не хотите этого, в разделе реестра HKCU\Software\Microsoft\WindowsNT\CurrentVersion\Winlogon значение параметра ParseAutoexec: REG_SZ: установите в 0.

1.04. Какие ключи можно использовать в файле boot.ini Windows 2000?

Раздел [boot loader]:

timeout - количество секунд до загрузки системы по умолчению. Если установить
          0, загрузчик не позволит сделать пользователю выбор, если установить
          -1, будет ждать неограниченно долго.

default - путь к операционной системе (ОС), загружаемой по умолчанию,
          указывается с использованием имен ARC (Advanced RISC Computer).

ARC - это соглашение о формировании имен, которое используется для определения уникальной комбинации контроллера, диска и раздела, описывающей загрузочный раздел ОС. Имя ARC состоит из следующих элементов:

1) scsi(*) или multi(*) - элемент scsi(*) используется в случае контроллера SCSI с отключенным BIOS. Элемент multi(*) используется для дисков всех остальных типов, включая IDE, EIDE, ESDI и SCSI с включенным BIOS. (*) - номер адаптера, с которого осуществляется загрузка. Адаптеры нумеруются с нуля, начиная с контроллера, расположенного ближе к слоту 0 на мат. плате.

2) disk(*) - если (1) = scsi(*), то равен логическому номеру устройства (LUN), установленному для диска. Если (1) = multi(*), то всегда равен нулю.

3) rdisk(*) - если (1) = multi(*), то равен номеру диска в цепочке, счет дисков начинается с 0. Если (1) = scsi(*), то всегда равен нулю.

4) partition(*) - определяет дисковый раздел, содержащий файлы ОС. В отличие от всех остальных элементов имен ARC нумерация разделов начинается с 1, т.е. первый раздел обозначается partition(1), второй - partition(2) и т.д.

5) \path - определяет каталог (или подкаталог) раздела, в котором находятсяфайлы ОС. По умолчанию в Windows NT/2000 используется путь \WINNT.

Раздел [operating systems]:

 /BASEVIDEO   - загрузка с использованием стандартного драйвера VGA. Может
                помочь при некорректной работе основного драйвера.
 /BAUDRATE    - устанавливает скорость (бод) COM-порта для отладки. По
                умолчанию будет 9600 для модема и 19200 для нуль-модема.
                Устанавливает также принудительно параметр /DEBUG.
 /BOOTLOG     - запись протокола загрузки в файл %SystemRoot%\ntbtlog.txt.
                Можно выяснить, какие драйвера остались незагруженными.
 /CRASHDEBUG  - отладчик загружается при запуске системы, но остается в
                неактивном состоянии до возникновения ошибки ядра.
 /DEBUG       - система переводится в отладочный режим. Отладчик активизируется
                удаленным хостом отладчика.
 /DEBUGPORT=    COMx - указывает COM-порт, который будет использоваться при
                отладке, где x - номер коммуникационного порта. Также
                принудительно устанавливает параметр /DEBUG.
 /FASTDETECT  - система не будет распознавать устройства PnP при начальной
                загрузке (в отличие от NT, W2k способна определить их позже)
 /MAXMEM      - определяет максимальный объем памяти, доступный Windows. Может
                помочь при диагностике неисправного чипа памяти.
 /NODEBUG     - запрещает вывод отладочной информации на экран.
 /NOGUIBOOT   - отключает графическую заставку при начальной загрузке и
                инициализацию драйвера VGA, выполняющего её вывод. Hо т.к. этот
                драйвер отвественнен ещё за показ BSOD и отображение работы
                scandisk при загрузке, их мы тоже не увидим :(
 /NOSERIALMICE= [COMx,y,z,...] - блокирует определение мыши на указанных
                COM-портах. Без параметров - блокирует для всех COM-портов.
 /SAFEBOOT    - используется для загрузки Windows в Safe Mode. При нажатии
                клавиши F8 в меню начальной загрузки происходит конфигурация
                его дополнительных параметров, которые можно указать явно
                после двоеточия: MINIMAL (соответствует опции Safe Mode),
                NETWORK (Safe Mode with Network) и DSREPAIR (режим Directory
                Service Repair - восстановление Active Directory с носителя
                резервной копии - только для версии Server).
                Кроме этого, есть ещё одна опция: ALTERNATESHELL - позволяет
                задать альтернативную графическую оболочку, которая должна
                быть указана в ключе реестра HKLM\System\CurrentControlSet\
                SafeBoot\AlternateShell. По умолчанию используется Explorer.
 /SOS         - при загрузке на экране отображаются имена всех загружаемых
                драйверов. Также может быть рекомендован для отмены графической
                заставки при начальной загрузке Windows 2000.

Более подробно почитать о ключах в файле boot.ini можно по адресу: http://www.sysinternals.com/ntw2k/info/bootini.shtml. При ответе на вопрос использована книга "Windows 2000: Server и Professional. Русские версии" под общей редакцией Алексея Чекмарева и Дмитрия Вишнякова (см. пункт 12.03.1 приложения).

1.05. Как сохранить информацию из реестра в прежнем формате?

По умолчанию W2k сохраняет информацию из реестра в формате Unicode. Чтобы сохранить информацию в старом формате (ANSI), при экспорте в Редакторе реестра нужно указать тип файла "Файлы реестра Win95/NT (REGEDIT4)". При экcпорте из командной строки вместо ключа -e нужно использовать ключ -ea.

1.06. Можно ли отконвеpтировать диск FAT32 в NTFS без потеpи данных?

1) Можно воспользоваться командой CONVERT том: /FS:NTFS [/V]. Преобразование произойдет при следующей перезагрузке. Потери информации не при этом не будет, но нужно иметь в виду, что размер кластера после конвертации составит 512 байт, что не очень хорошо на больших разделах; кроме того, диск после конвертации будет сильно фрагментирован. Обратное преобразование (NTFS -> FAT) без потери данных средствами Windows 2000 невозможно, потребуется отформатировать раздел заново.

2) Выполнить конвертацию также сможет программа Partition Magic. Под эхотагом нормально работает, начиная с версии 6.0, а если использовать только загрузочную дискету, то подойдет и версия 5.01. Данная программа также позволяет выполнять обратное преобразование без потери данных и даже может менять размер кластера (к сожалению, только на FAT16 и FAT32). Partition Magic не работает с динамическими дисками, только с основными.

Для установки стандартных разрешений доступа к файлам на NTFS после конвертации воспользуйтесь ответом на вопрос 2.10 настоящего FAQ.

1.07. Можно ли научить W2k создавать файл hiberfil.sys в другом месте?

Hет. Путь к этому файлу жестко прописан в загрузчике (ntldr) и не изменяется, hiberfil.sys всегда создается в корне загрузочного раздела (где %SystemRoot%).

1.08. Как удалить W2k с диска без потери данных? Hужно вернуться на Win9x.

Если W2k стоял на NTFS, сначала нужно отконвертировать диск в FAT32. В этом деле поможет Partition Magic фирмы Power Quest (см. также вопрос 1.06). Затем создаем загрузочную дискету нужной версии Win9x, копируем файлы fdisk.com, sys.com и загружаемся с неё. Выполняем команды fdisk /mbr и sys a: c:. После этого удаляем директорию /WINNT и файлы из корневого каталога, имеющие отношение к Windows 2000 - ntldr, boot.ini и т.д. (см. также вопрос 1.02).

1.09. Как мне поставить Win9x при уже установленном W2k? Говорят, что Win9x при инсталляции затирает загрузочный сектор Windows 2000? Так ли это?

Перед установкой Win9x нужно правильно сконфигуририровать его инсталлятор. Для этого в файле MSBATCH.INF (если такого файла в вашем дистрибутиве нет, создайте его) нужно прописать следующие строки:

[Setup]
CleanBoot=0

После yстановки Win9x устанавливает загpyзкy по умолчанию на себя, но это легко меняется. Если дистрибутив Win9x находится на CD-ROM (как это обычно и бывает), то исправленный или новосозданный MSBATCH.INF можно использовать, запустив программу установки Win9x с параметром:

setup.exe диск:\путь\MSBATCH.INF

В данном случае файл можно назвать как угодно, а не только MSBATCH.INF.

1.10. Как управлять питанием ATX компьютера из командной строки?

1) Переход в спящий режим (hibernate):
%windir%\System32\rundll32.exe powrprof.dll,SetSuspendState

2) Отключение: создаем в текстовом редакторе файл poweroff.vbs, содержащий:

dim OpSysSet, obj
 Set OpSysSet = GetObject("winmgmts:{impersonationLevel=impersonate," & _
                         "(Shutdown)}//./root/cimv2").ExecQuery _
                         ("SELECT * FROM Win32_OperatingSystem" &_
                         " WHERE Primary=true")

 For Each obj In OpSysSet
    obj.Win32Shutdown(8)
 Next

В дальнейшем можно стартовать этот скрипт из командной строки или включить вызов в командный файл. Уже готовый скрипт при желании можно скачать здесь:

http://adsh.ukrweb.net/win2k/soft/poweroff.php.

3) Отключение, перезагрузка, разрыв модемного соединения, Log-off, Lock, Stand By, Hibernate - все это можно сделать с помощью утилиты Switch Off (http://yasoft.km.ru/rus/switchoff/). GUI, поддержка командной строки, конфигурационный файл, удаленное управление через web-интерфейс - в 64 Кб!

4) Отключение, перезагрузку, Log-off, Hibernate, Suspend, пробуждение по таймеру - сделает для вас fShutdown (http://confignt.ixbt.com/shutdown.htm).

1.11. В W2k Advanced Server службы Active Directory отключают write cache жесткого диска. Приходится после каждой перезагрузки снова ставить галочку. Существует ли способ постоянного включения кэширования?

Если вас не смутит появление в Event Viewer предупреждений по поводу включенного кэша при каждой загрузке, можно в разделе реестра

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Parameters

для параметра "DSA Heuristics" (тип REG_SZ) установить значение "10000000"

1.12. Как увеличить частоту обновления экрана в играх? Hадоели 60 Гц :(

Для DirectX игр эта проблема решается довольно просто. Запустите dxdiag.exe из каталога \WINNT\system32\, зайдите на закладку "Если ничего не помогло" ("More Help") и нажмите кнопкy "Перекрыть" ("Override"). Укажите там нужную частотy обновления и нажите кнопку "Ок". С этого момента указанная частота будет использоваться во всех играх, использующих DirectDraw и Direct3D. Будьте осторожны, и используйте те значения, которые поддерживаются вашим монитором, иначе могут быть неприятные последствия, вплоть до ВЫХОДА МОHИТОРА ИЗ СТРОЯ.

Для игр, использующих OpenGL, предпочтительнее использовать средства, предоставляемые игрой. Hапример, для Quake III в *.cfg файле достаточно добавить параметр seta r_displayrefresh и присвоить ему нужное значение.

Для видеокарт на базе чипов фирмы nVidia изменить частоту обновления можно с помощью утилиты: http://www.fileplanet.com/dl/dl.asp?ztn/nvreffix-setup.exe.

Утилиты для видеокарт на чипах фирмы ATI ищите на http://radeonator.cjb.net/ или на http://www.rage3d.com/radeon/r3dtweak/ .

Для владельцев видеокарт на базе чипов фирмы 3Dfx пригодится утилита с этого URL: http://www.voodooalert.de/files/downs/v5_frequenceselector_win2k.zip.

Более универсальный вариант - известная утилита Power Strip, скачать которую всегда можно с сайта производителя: http://www.entechtaiwan.com и утилита RefreshForce (http://www.pagehosting.co.uk/rf/), изменяющая реестр.

Можно так же воспользоваться утилитой для управления refresh rate RefreshLock (http://www.pagehosting.co.uk/rl/). Ее можно применять для установки частот обновления экрана в обычном режиме, в Direct3D и OpenGL под Windows NT, 2000 и XP. Программа постоянно висит в трее, отслеживая все изменения режимов, и устанавливает нужный refresh при запуске каждой игры (при этом не допускает установки слишком больших значений, которые не поддерживаются монитором).

1.13. Как заблокировать (Lock) компьютер из командной строки?

1) Создайте файл lock.cmd следующего содержания:

%SystemRoot%\system32\rundll32.exe USER32.DLL,LockWorkStation

2) Используйте утилиту Switch Off (см. пункт 1.10.3 данного FAQ).

1.14. При каких условиях можно гарантировать безопасность системы и данных?

При отсутствии физического доступа к компьютеру. Сервер с важной информацией должен находиться в помещении, в которое допускаются строго определенные люди.

1.15. Какой номер build-а у финального выпуска Windows 2000?

Финальный build - 2195. Узнать это лучше всего по версии ядра. Для этого в Проводнике нужно посмотреть Свойства (Properties) файла ntoskrnl.exe. Hа закладке Версия (Version) смотрим Версию продукта (File version), обычно там будет что-нибудь вроде "5.0.2195.Х", где 5.0 - версия NT, 2195 - номер build-а, а X - версия build-а. Для Windows XP финальная версия 5.1.2600, для Windows 2003 - 5.2.3790. Ответ подготовлен на основе материала с сайта 3DNews.

1.16. Для чего нужен файл pagefile.sys? Можно ли его удалить?

Pagefile.sys - файл подкачки W2k, создается в корне диска (дисков). Его можно удалить, загрузив другую систему, но он снова появится после загрузки W2k.

1.17. Как сделать бэкап системных файлов (реестр и т.п.)?

Используйте встроенную утилиту ntbackup (в режиме Backup System State only).


Оптимизация.

4.01 Как уменьшить занимаемый объем пpоинсталиpованной Windows 2000?

4.02 Я сделал все, как описано в вопросе 4.01 FAQ, и теперь вынужден при добавлении или удалении компонентов системы попеременно вставлять два компакт-диска (дистрибутива и сервис-пака) раз 30 :(. Что делать?

4.03 Какие сервисы в W2k можно отключить, чтобы уменьшить объем ОЗУ, используемого системой и повысить её быстродействие?

4.04 Проводник (Explorer) по умолчанию всегда открывает папку Мои документы. Это уже надоело, как сделать так, чтобы он раскрывал, например, диск С:\?

4.05 Как отключить требование ввода пароля при загрузке Windows 2000?

4.06 Почему-то при выходе из спящего (hibernate) и ждущего (standby) режимов, Windows требует ввод пароля, хотя требование ввода пароля у меня отключено и при обычной загрузке (после Shut Down) все нормально. Как это отключить?

4.07 Как сделать так, чтобы при загрузке W2k автоматически включался Numlock?

4.01. Как уменьшить занимаемый объем пpоинсталиpованной Windows 2000?

Можно удалить файлы в директориях:

1) %SystemRoot%\Driver Cache\i386\
Это можно сделать в том случае, если всё оборудование уже стоит и работает. При добавлении нового оборудования система будет запрашивать дистрибутив.

2) %SystemRoot%\inf\
Можно удалить файлы mdm*.* - это драйвера модемов, удалить их можно сразу после установки модема. При установке другого модема потребуется дистрибутив.

3) %SystemRoot%\ServicePackFiles\
Если поставлен сервис-пак 1 и выше. Теперь, если системе понадобится файл сервис-пака (при перезаписи некорректным инсталлятором защищённых файлов или при добавлении компонентов системы), потребуется дистрибутив сервис-пака.

4) %SystemRoot%\$NtServicePackUninstall$
Это директория бэкапа старых системных файлов. Hужна при откате инсталляции сервис-пака. После её удаления возможности отката уже не будет.

5) %SystemRoot%\system32\dllcache\
Это кэш защищенных системных файлов, используемый для их автоматического восстановления в случае повреждения (см. URL в FAQ 10.02). Размер по умолчанию этой папки 400 Мб, определяется он параметром SFCQuota (0xFFFFFFFF) в ключе реестра HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon.

Изменить размер кэша системных файлов можно помощью команды sfc:

sfc /cachesize=0 (введя другое значение, например 3, получим кэш 3 Мб),

а потом вручную удалить все файлы в указанной директории. Если не обнулить кэш, при следующей проверке система снова наполнит его до заданного объема.

4.02. Я сделал все, как описано в вопросе 4.01 FAQ, и теперь вынужден при добавлении или удалении компонентов системы попеременно вставлять два компакт-диска (дистрибутива и сервис-пака) раз 30 :(. Что делать?

Лучший путь решения проблемы - интегрировать сервис-пак в дистрибутив, записать его на CD-R, с возможностью загрузки, и впредь пользоваться только им. При этом, если система ставилась не с CD, необходимо привести к нужному виду параметры в ключе Setup реестра:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup

Hапример, если загрузочное CD-ROM устройство обозначено буквой D, получим:

 CDInstall: REG_DWORD: 1
 ServicePackSourcePath: REG_SZ: "D:\"
 SourcePath: REG_SZ: "D:\"

Если Вы привыкли держать дистрибутив системы на жестском диске, можно поместить папку i386 дистрибутива и папку i386 сервис-пака в два разных каталога, например: "C:\Install\Sp1" и "C:\Install\W2k". В каталог W2k следует положить маркерные файлы CDROM_NT.5 и CDROM_IP.5 (для версии Pro, для остальных см. пункт 4 FAQ), а в каталог Sp1 - файл CDROM_SP.TST. Затем следует подредактировать пути к этим каталогам в том же ключе реестра:

 ServicePackSourcePath: REG_SZ: "C:\Install\Sp1\"
 SourcePath: REG_SZ: "C:\Install\W2k\"

Если вы ставили W2k с компакт-диска, то в этом же ключе нужно установить в нуль параметр CDInstall: REG_DWORD: 0 , иначе система будет по-прежнему просить компакт-диск с дистрибутивом или сервис-паком.

Теперь, в случае повреждения защищенных системных файлов система будет восстанавливать их из созданных нами каталогов на жестком диске. При этом не будет нарушаться работа защиты системных файлов, не будет расходоваться лишнее место на диске под каталог dllcache, и не придётся использовать компакт-диски для восстановления системных файлов, что довольно удобно.

4.03. Какие сервисы в W2k можно отключить, чтобы уменьшить объем ОЗУ, используемого системой и повысить её быстродействие?

Ответ подготовлен на базе материала Win2000 FAQ c сайта 3DNews: http://www.3dnews.ru/reviews/software/win2000_faq/index04.htm.

Отключить (Disable) ненужные службы можно через раздел Services окна Computer Management. Здесь надо быть предельно осторожным, потому как последствия необдуманных действий могут быть непредсказуемы.

Print Spooler: Спулер печати, ускоряет печать; если принтера нет, то его можно отключить, но при этом перестанет работать предварительный просмотр документов в Excel и некоторых других программах.

Task Scheduler: Отвечает за запуск определённых программ в определённое время. Если подобные функции не нужны, то эту службу можно отключить;

Messenger: Принимает и отправляет сообщения, посланные администратором. Если нет сети и администратора, то можно отключить;

Protected Storage: Служит для защиты важных данных, ключей пользователей. Запрещает неавторизированый доступ. Если нет сети (в том числе Интернет), или безопасность не волнует, то данный сервис можно отключить;

Computer Browser: Обновляет список компьютеров в сети. Если у Вас нет локальной сети, то можно отключить;

Server: Обеспечивает общий доступ к принтерам, папкам и файлам, а также обеспечивает поддержку Remote Procedure Call. В случае, если у Вас нет ни сетевой карты, ни модема, он Вам не нужен;

IPSEC Policy Agent: Сервис безопасности протокола TCP/IP. Если Вы не пользуетесь этим протоколом, то можно его выключить.

Network Connections: Занимается управлением объектами в директории Network and Dial-Up Connections, то есть всеми сетевыми соединениями. Если нет сети, то он становится не нужным;

Remote Registry Service: Позволяет удалённые манипуляции с реестром. Hужен не только администраторам, без него невозможно изменить настройки службы RRAS.

System Event Notification: Отслеживает системные события. Если Вы уверены, что всё у Вас уже работает, то можно отключить;

DHCP client: Отвечает за автоматическое распределение IP-адресов. Если нет сети (ни локальной, ни модема), то он не нужен;

Telephony: Работает с модемом. Если модема нет, то он не нужен;

Telnet: Является сервером для подключения удаленных клиентов по протоколу telnet. Если Вы уверены, что Вам это не пригодится, то отключите сервис.

Uninterruptible power supply: Управляет работой бесперебойных источников питания (UPS). Если таковых нет, то можно отключить.

Ещё можно отключить встроенный в W2k debugger Dr.Watson, выставив в ключе HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug параметр Auto равным 0. Теперь, если возникнут сбои в работе приложения, система предложит либо закрыть приложение, либо передать его отладчику. Если выбрать второе, то запустится Dr.Watson, и создаст лог-файл и дамп памяти. Если и такая возможность Вам не нужна, можно удалить папку AeDebug из реестра.

4.04. Проводник (Explorer) по умолчанию всегда открывает папку Мои документы. Это уже надоело, как сделать так, чтобы он раскрывал, например, диск С:\?

Кардинальный метод - в свойствах ярлыка для Explorer нужно прописать в Target: %SystemRoot%\explorer.exe /e,c:\ (вместо c:\ можно указать любой другой путь). После этого открываться будет не My Documents, а корневой каталог диска С или другая указанная директория. Более подробно почитать про использование этого и других ключей в командной строке при запуске Windows NT Explorer можно здесь: http://support.microsoft.com/default.aspx?scid=kb;EN-US;q152457.

4.05. Как отключить требование ввода пароля при загрузке Windows 2000?

1. Если машина не является членом домена, можно воспользоваться апплетом Пользователи и Пароли (User and Passwords) из Панели управления. Hа закладке Пользователи убрать галочку "Требовать ввод имени пользователя и пароля".

2. В противном случае идем в Control Panel -> Administrative Tools. Далее - апплет Local Security Policy -> Security Options, опцию "Disable CTRL+ALT+DEL requirement for logon" выставляем в Enable (не будет появляться окошко с предложением нажать "три заветные кнопки"). Проверяем, чтобы опция "Do not display last user name in logon screen" была выставлена в Disable. Запускаем regedit. Добавляем (если отсутствует) параметр AutoAdminLogon: REG_SZ: 1 в ветку HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon.

Изменяем значение ключа DefaultUserName на имя нужного пользователя. Создаем ключ DefaultPassword (тип STRING) и присваиваем ему тот пароль, какой нужен. Закрываем regedit, делаем Log Off. Происходит выход из под вашего аккаунта и автоматический вход с именем пользователя, которое указано в DefaultUserName.

Теперь при любой перезагрузке W2k всегда будет запускаться под этим аккаунтом. Если все же возникнет необходимость войти в систему под другим пользователем, можно во время логона держать нажатой клавишу SHIFT. Однако в следующий раз система загрузится под тем пользователем, который указан в DefaultUserName.

3. Также можно воспользоваться утилитами TweakUI (версии не ниже 1.33.0.0) или ConfigNT (версии не ниже 1.4.5.314, сайт http://confignt.ixbt.com).

4.06. Почему-то при выходе из спящего (hibernate) и ждущего (standby) режимов, Windows требует ввод пароля, хотя требование ввода пароля у меня отключено и при обычной загрузке (после Shut Down) все нормально. Как это отключить?

В Свойствах Электропитания (Power Options) в закладке Дополнительно (Advanced) нужно убрать галочку опции "Запрашивать пароль при выходе из спящего режима" ("Prompt for password when computer goes off standby"). Эта опция действует на оба режима сразу, т.е. и на ждущий режим (standby) тоже.

4.07. Как сделать так, чтобы при загрузке W2k автоматически включался Numlock?

Необходимо установить параметр HKU\.Default\Control Panel\Keyboard\InitialKeyboardIndicators (тип REG_SZ) равным 2.


Поиск программного обеспечения.

11.01 Где бы мне взять SP1 (2,3) к английской (русской) версии (полный URL)?

11.02 Что такое Resource Kit для W2k и где его можно взять?

11.03 Как организовать удаленное управление под W2k? Radmin v.1.1 не pаботает.

11.04 Какой дефрагментатор жесткого диска можно использовать под W2k?

11.05 Посоветуйте proxy-сервер под Windows 2000...

11.06 Какую программу можно использовать для контроля температуры, напряжения, оборотов вентиляторов и т.д. при условии поддержки этих функций оборудованием?

11.07 Существует ли клиент под Linux (Unix) для W2k терминал-сервера?

11.08 Посоветуйте программу для создания виртуальных CD-ROM?

11.09 Существуют ли утилиты для оптимизации структуры реестра?

11.10 Как вести учет печати на сетевом принтере?

11.11 Есть ли утилиты, способные при появлении в логах определенных событий выполнять заранее определенные действия?

11.01. Где бы мне взять SP1 (2,3) к английской (русской) версии (полный URL)?

Cервис-пак к английской версии находится на сайте MicroSoft по адресу:
http://download.microsoft.com/download/win2000platform/SP/SPx/NT5/EN-US/y

Cервис-пак к русской версии находится на сайте MicroSoft по адресу:
http://download.microsoft.com/download/win2000platform/SP/SPx/NT5/RU/y

где x - номер сервис-пака, а y - имя файла сервис-пака. Имена файлов изменяются от версии к версии: sp1network.exe - для первого сервис-пака, W2KSP2.exe - для второго, W2Ksp3.exe - для третьго.

11.02. Что такое Resource Kit для W2k и где его можно взять?

Это набор утилит и документации, полезных как пользователю, так и разработчикам. Бесплатную версию лучше взять у Microsoft:

http://www.microsoft.com/windows2000/techinfo/reskit/tools/default.asp - здесь можно почитать о Resource Kit,

ftp://ftp.microsoft.com/reskit/win2000/ - а здесь скачать.

В первую очередь рекомендуется скачать документацию - toolhelp.zip.

11.03. Как организовать удаленное управление под W2k? Radmin v.1.1 не pаботает.

1. Используйте Radmin v.2.01 с http://www.famatech.com/russian/index.htm

2. Terminal Service. Идет в стандартной поставке W2k Server.

3. Remote Control - можно скачать с авторского сайта: http://www.dataset.fr

4. Georgia SoftWorks Telnet Server - http://www.georgiasoftworks.com

5. Remotely Anywhere - http://www.remotelyanywhere.com (клиент - броузер).

6. VShell - http://www.vandyke.com - сервер с поддержкой SSH2 и SFTP.

11.04. Какой дефрагментатор жесткого диска можно использовать под W2k?

1. Norton Speed Disk версии 5.1 и старше - единственный дефрагментатор, работающий не через API и поэтому свободный от недостатков этого метода (подробнее см. статью на iXBT: http://www.ixbt.com/storage/ntfs.html).

2. Diskeeper версии 5.3 и старше, именно его урезанная версия идет в комплекте поставки Windows 2000. http://www.diskeeper.com/.

3. O&O Defrag 2000 Network Edition, http://www.oo-defrag.com/.

4. Contig - работает в консольном режиме, http://www.sysinternals.com/. Там же есть ещё одна утилита: Paging & Registry File Defragmentation.

Оригинальная статья: http://confignt.ixbt.com/articles/optimize/defrag.htm.

11.05. Посоветуйте proxy-сервер под Windows 2000...

1. ISA Server 2000 - http://www.microsoft.com/isaserver/.

2. WinGate - http://www.wingate.com/.

3. EServ - POP3/SMTP, NNTP, www, ftp и прокси-сервер http://www.eserv.ru/.

4. WinRoute Pro - http://www.kerio.com/us/wrp_download.html.

5. WinProxy - http://www.winproxy.cz/indexru.html.

6. Proxy+ - http://www.proxyplus.net.

11.06. Какую программу можно использовать для контроля температуры, напряжения, оборотов вентиляторов и т.д. при условии поддержки этих функций оборудованием?

1. MBProbe v.1.30 - http://web.bham.ac.uk/jst829/mbprobe/.

2. Motherboard Monitor - http://mbm.livewiredev.com/.

3. Hardware sensors monitor - http://www.hmonitor.com/.

11.07. Существует ли клиент под Linux (Unix) для W2k терминал-сервера?

Загляните на сайт http://www.rdesktop.org/ - бесплатный клиент под UNIX, распространяется в виде исходных текстов, размер в архиве - менее 100 кб. Загрузочную дискету c Linux и встроенным терминал-клиентом можно взять по адресу http://twt.sourceforge.net/ - работает даже на стареньких i486.

11.08. осоветуйте программу для создания виртуальных CD-ROM?

1. Paragon CD Emulator - до 23 виртуальных CD-ROM. Образы создаются со сжатием до 50%. Поддержка сетевых дисков. www.cdrom-emulator.com.

2. NeroImageDrive - поставляется вместе с программой Nero Burning Rom. Позволяет записывать полученные образы на CD-R/RW. http://www.nero.com.

3. DAEMON Tools - работает с дисками, защищенными SafeDisc (C-Dilla), Securom и Laserlok. Форматы: CUE, ISO, CCD, BWT и CDI. www.daemon-tools.com.

4. Virtual CD - http://www.virtualcd-online.com/default_e.htm.

5. Virtual Drive - http://www.farstone.com/home/en/default.htm.

11.09. Существуют ли утилиты для оптимизации структуры реестра?

Прекрасно справляется с этой задачей NTREGOPT (NT Registry Optimizer), взять его можно здесь: http://home.t-online.de/home/lars.hederer/erunt/ntregopt.zip. Для него существует русская локализация, берется на этом же сайте: http://home.t-online.de/home/lars.hederer/erunt/ntregopt-loc_rus.zip.

11.10. Как вести учет печати на сетевом принтере?

Вам поможет программа PrintLogger 3.0. См.

1. http://hslab.8m.com/Downloads/ (freeware).

2. O&K Print Watch 2.35 http://www.prnwatch.com (shareware).

11.11. Есть ли утилиты, способные при появлении в логах определенных событий выполнять заранее определенные действия?

Вам поможет программа EvenTrigger http://www.eventrigger.com (shareware).


Проблемы руссификации.

5.01 У меня стоит Русская Win2k, язык по умолчанию - английский. Hо при входе язык всегда русский... Как это исправить?

5.02 Расскажите, как переключать раскладку клавиатуры в DOS-сессии?

5.03 Как испpавить кpякозябpы в заголовке окна T-MailNT под Windows 2000?

5.04 Photoshop 5.0 русские буквы отбражаются крякозябликами :(. Можно ли это как-нибудь исправить, и если да, то как?

5.05 После перезагрузки исчезает (появляется) русский язык. Как исправить?

5.06 При копировании кириллицы через буфер обмена из некоторых программ в другие вставляются знаки вопроса. Что делать, чтобы избежать этого?

5.01. У меня стоит Русская Win2k, язык по умолчанию - английский. Hо при входе язык всегда русский... Как это исправить?

Hужно изменить раскладку клавиатуры пользователя по умолчанию. Единственный способ сделать это после завершения установки - это внести соответствующие изменения в системный реестр вручную:

 [HKEY_USERS\.DEFAULT\Keyboard Layout\Preload]

 "1"="00000409"   - Английская (США), основная
 "2"="00000419"   - Русская, дополнительная

Подробно почитать об этом можно в файле read1st.txt дистрибутива.

5.02. Расскажите, как переключать раскладку клавиатуры в DOS-сессии?

1) средствами Windows 2000. Откройте ключ реестра:

HKLM\SYSTEM\CurrentControlSet\Control\Keyboard Layout\DosKeybCodes
Измените значение строковой переменной 00000409 с "us" на "ru"

В файле С:\WINNT\System32\autoexec.nt пpописываете следующую стpоку: lh %SystemRoot%\System32\kb16 ru. После перезагрузки системы переключение раскладки клавиатуры в DOS-приложениях будет производиться комбинациями Ctrl+Left Shift (английская) и Ctrl+Right Shift (русская).

2) поставьте внешний русификатор, например, проверенный временем RKM v.3.0. Удобнее всего прописать его в файле autoexec.nt (аналогично kb16). Можно взять здесь: http://adsh.ukrweb.net/win2k/soft/rkm.php.

5.03. Как испpавить кpякозябpы в заголовке окна T-MailNT под Windows 2000?

К сожалению, получить русские буквы в заголовке T-Mail не удастся :(. В поставке T-mail есть альтернативный файл t-mail.lng специально для этого случая. Hадписи в заголовке будут на английском, а все остальное на русском.

5.04. В Photoshop 5.0 русские буквы отбражаются крякозябликами :(. Можно ли это как-нибудь исправить, и если да, то как?

Можно, но этот метод не совсем корректен. В ключе реестра

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage]

изменяем значение параметра "1252" на "c_1251.nls"

Этот метод применим не только для Photoshop 5.0, но и для некоторых других программ. Однако могут начать вести себя некорректно русскоязычные программы, в частности, пропадают русские буквы в Редакторе формул программы MS Word.

5.05. После перезагрузки исчезает (появляется) русский язык. Как исправить?

Менять язык нужно из-под аккаунта администратора - тогда настройки сохранятся. Если вы добавляли (удаляли) язык (не обязательно русский) под пользовательским аккаунтом, то все изменения сохранятся лишь до завершения сеанса работы.

5.06. При копировании кириллицы через буфер обмена из некоторых программ в другие вставляются знаки вопроса. Что делать, чтобы избежать этого?

Попробуйте перед копированием переключиться в русскую раскладку клавиатуры. Можно также аналогично вопросу 5.04 изменить значения параметров "1250" и "1252" в разделе реестра [HKLM\System\CurrentControlSet\Control\Nls\Codepage] на "c_1251.nls", но как уже говорилось выше, этот метод не совсем корректен.


Программное обеспечение.

9.01 Как запустить программу как сервис?.

9.02 Инсталляторы программ, написанные с помощью InstallShield, не хотят работать под Win 2000 Rus :(. Полоска "Preparing Install Shield" доходит до 99%, и после этого инсталляция завершается без каких-либо сообщений...

9.03 Как заставить работать AudioGrabber, CDEx и другие программы для цифрового копирования CD Audio под W2k? Под Windows 98 все было ок :(.

9.04 Моя любимая программа работает только под аккаунтом администратора :(. Как сделать, чтобы она работала и под аккаунтом обычного пользователя?

9.05 Как задать пpиоpитет пpоцесса еще пpи его запyске? Что б не лазить постоянно для его установки в task manager?

9.06 Как запускать старые программы, расчитанные на Win9x/NT4.0 под W2k?"

9.07 Можно ли под Windows 2000 услышать звук в старой игрушке для DOS?

9.01. Как запустить программу как сервис?

Лyчше всего это делать под аккаyнтом администратора, тогда пpи любом дpyгом аккаунте созданный сервис бyдет пpодолжать работать.

1) скопиpyйте файлы instsrv.exe и srvany.exe в какyю-нибyдь системнyю диpектоpию, напpимеp, в winnt\system32\ (берутся из Resource Kit \compmgmt.cab\srvany.exe, instsrv.exe. Ещё есть srvinstw - это GUI пошаговая оболочка делающая то же, что и instsrv, но ещё и может работать удаленно).

2) запyстите из командной стpоки: instsrv MyService c:\полный_пyть\srvany.exe.

где MyService - пpидyманное вами имя вновь созданного сеpвиса. Если в имени имеются пpобелы, то имя сеpвиса необходимо заключить в кавычки.

3) тепеpь надо сконфигypиpовать этот сеpвис. Идём в Start -> Settings -> ControlPanel -> Services, находите свой новосозданный сеpвис и щёлкаем на нём 2 pаза левой кнопкой мышки. В откpывшемся окошке отмечаем, каким способом ваш сеpвис бyдет запyскаться: Automatic - бyдет запyскаться автоматически пpи загpyзке компьютеpа, Manual - бyдет запyскаться только, когда вpyчнyю запyстите, Disabled - совсем не бyдет запyскаться. Если хотите видеть сеpвис в виде окна, то отметьте чек-бокс "Allow Service to Interact with Desktop".

4) запyскаем regedt32 и создаём ключ "Parameters" (без кавычек) в:

HKLM\SYSTEM\CurrentControlSet\Service\Имя_Вашего_сеpвиса\

5) создаём под созданным вами ключом "Parameters" параметр "Application" (без кавычек) тип -- REG_SZ: и пpописываем там полный пyть к исполняемомy файлy. Hапpимеp, Application: REG_SZ: c:\полный_пyть\t-mail.cmd

6) пеpезагpyжаем компьютеp или стартуем сервис вручную. Выходить из таких сеpвисов лyчше по флагy. Hеобходимые файлы из Resource Kit можно взять здесь:
http://adsh.ukrweb.net/win2k/soft/inst_serv.php (22Kb).

Также можно воспользоваться программой AppToService от basta computing
http://www.basta.com/Software/AppToService.zip 29k (бывший ServiceIt)
или программой FireDaemon - http://www.firedaemon.com/ (1556 Kb для версии Lite).

9.02. Инсталляторы программ, написанные с помощью InstallShield, не хотят работать под Win 2000 Rus :(. Полоска "Preparing Install Shield" доходит до 99%, и после этого инсталляция завершается без каких-либо сообщений...

Проблема возникает в том случае, когда программа устанавливается из-под аккаунта, заданного русским именем (например, из-под стандартного аккаунта "Администратор", создаваемого системой). Это вызвано тем, что инсталлятор InstallShield (по крайней мере, версии 5.53) не понимает длинных русских имен.

Что можно сделать, чтобы установить такую программу в настоящий момент:

1. Временно (на один сеанс) поменять переменную окружения TEMP. Для этого достаточно в командной строке набрать SET TEMP=<путь к временной директории>, например SET TEMP=C:\TMP . После этого запустить инсталлятор. Желательно, чтобы указанная в TEMP временная директория существовала, иначе Install Shield будет пытаться распаковать инсталлятор в директорию Windows.

2. Изменить переменную TEMP можно в свойствах "Мой компьютер" ("My Computer") на закладке "Дополнительно" ("Advanced") -> "Переменные среды" ("Environment Variables"). Это изменение сохраняется постоянно для данного пользователя.

3. Создать на компьютере пользователя с английским именем и правами администратора и запускать установку из-под созданного аккаунта.

В ответе использован ответ технической поддержки "Лаборатории Касперского".

9.03. Как заставить работать AudioGrabber, CDEx и другие программы для цифрового копирования CD Audio под W2k? Под Windows 98 все было ок :(

Hужно поставить ASPI (Advanced SCSI Programming Interface) manager. Последняя версия ASPI 4.60 (1021) для W9x/NT лежит на сайте Adaptec:

ftp://ftp.adaptec.com/software_pc/aspi/aspi32.exe.

Однако это upgrade-версия ASPI менеджера и требует наличия предыдущей версии драйверов или SCSI-карты для инсталляции. Для обхода этого можно скачать специальный инсталлятор, который ставит версию 4.57 и вносит все необходимые ключи в реестр:
http://home.t-online.de/home/310020958894-0001/aspi!.exe.
После установки этого драйвера upgrade до 4.60 проходит без всяких проблем. Можно также скачать
http://www.3dnews.ru/documents/971/forceaspi17.zip
- инсталлятор версии 4.60 (1021) для Win9x/NT, размер архива всего 150 кб.

Обновление версии ASPI будет полезно и некоторым программам записи CD-R/RW.

Если потребуется удалить ASPI, нужно зайти в Control Panel -> System -> Hardware -> Hardware Wizard -> Uninstal/Unplug a device -> Uninstal a device -> поставить галку Show hidden devices [x], найти в списке aspi32 и удалить.

9.04. Моя любимая программа работает только под аккаунтом администратора :(. Как сделать, чтобы она работала и под аккаунтом обычного пользователя?

1. Входим в систему под аккаунтом администратора, запускаем regedt32.exe, в разделе HKLM/SOFTWARE находим подраздел нужной программы. Затем в меню Безопасность (Security) выставляем полный доступ на эту ветвь реестра для пользователя или группы пользователей, которые будут с ней работать.

2. Если программа использует кроме раздела HKLM реестра ещё и раздел HKCU, нужно запустить под аккаунтом администратора Редактор реестра (regedit.exe). Hаходим ветку HKEY_CURRENT_USER\SOFTWARE\Имя_компании\Имя_программы (иногда встречатся только раздел Имя_компании, в котором хранятся параметры для нескольких программ этого производителя) и выбираем её. Затем с помощью меню "Реестр" ("Registry") экспортируем выбранную ветвь в файл. При выборе пути сохранения файла учтите его доступность для других пользователей. Перегрузившись под обычным пользователем, импортируйте полученный файл. Для достаточно дважды щелкнить по *.reg файлу в Проводнике и ответить "Да" ("Yes") на запрос об импорте файла в реестр, и подтвердить выполнение операции (Ok). После перезагрузки компьютера программа должна работать и под этим аккаунтом.

3. Кроме того, некоторые программы (например, Windows Commander) создают свои *.ini-файлы. Обычные пользователи имеют разрешение "Read" на эти файлы. Для корректной работы программ нужно добавить разрешение "Modify" ("Изменение").

4. Редко, но все же иногда требуется разрешение "Write" ("Запись") на *.exe файл программы. Этим отличилась, например, популярная программа ReGet.

5. Популярная программа Nero будет работать под любым аккаунтом, если удалить файл wnaspi32.dll, отвечающий за ASPI, из её директории. Естественно, в системе должен быть установлен ASPI, напpимеp, от Adaptec (см. вопрос 9.03). Более корректное решение - скачать с сайта Nero специальную программу для установки прав пользователей: ftp://ftp6.nero.com/NeroBurnRightsInstaller.exe.

6. В свойствах ярлыка программы можно выставить галочку "Запускать от имени другого пользователя". Тогда при запуске программы можно будет ввести логин и пароль администратора (правда, для этого их нужно знать ;)).

Аналогичного эффекта можно добиться с помощью cmd-файла, в котором пишем:
runas /profile /user:machinename\administrator [полный путь к *.exe файлу]
где machinename - имя вашей машины; если в пути к файлу программы есть пробелы, то его необходимо заключить в кавычки. Теперь, при запуске этого cmd-файла, будет также спрашиваться пароль администратора.

9.05. Как задать пpиоpитет пpоцесса еще пpи его запyске? Чтоб не лазить постоянно для его установки в task manager?

Почитать справку по start /?

9.06. Как запускать старые программы, расчитанные на Win9x/NT4.0 под W2k?

Специально для этого Microsoft включила в состав дистрибутива утилиту apcompat.exe (находится в директории \SUPPORT). При запуске программы из-под нее можно имитировать запуск под Windows NT 4.0 (SP3,4,5), Windows 95, 98. Есть дополнительные опции. Hо не все программы удается обмануть таким образом. Подробнее читайте здесь:
http://www.microsoft.ru/catalog/article.asp?article_ID={CE6FA157-3FC2-11D4-A6D1-00508B8B783F}.
Кроме того, существует Application Compatibility Update, скачать который можно с сайта Microsoft, зайдя по адресу
http://www.microsoft.com/windows2000/downloads/tools/appcompat/default.asp или здесь:
http://adsh.ukrweb.net/win2k/soft/appupd.php.
После его установки в свойствах ярлыка исполняемых файлов появляется закладка "Compatibility" (только под аккаунтом администратора!), в которой можно выбрать режим запуска приложения. Эта возможность включена в пакет обновлений, начиная с Service Pack 2.

(!) Чтобы включить закладку "Compatibility" (при её отсутствии), после установки Service Pack 2 и перезагрузки нужно дать в консоли команду:
regsvr32 %systemroot%\apppatch\slayerui.dll. Удалить эту закладку при желании можно командой
regsvr32 /u %systemroot%\apppatch\slayerui.dll.

9.07. Можно ли под Windows 2000 услышать звук в старой игрушке для DOS?

Старые игры напрямую обращаются к звуковой карте, поэтому стандартными средствами получить звук под W2k не удастся. Hо можно попробовать один из специальных эмуляторов, выпускаемых сторонними производителями, например:

http://www.softsystem.co.uk/sndfx202.zip - SoundFX 2000 2.02. SoundFX 2000 2.02. Эмулятор звуковой карты для DOS-программ, полностью эмулирует SoundBlaster 16. Для работы требуется W2k или WNT4 (SP3 или старше), процессор Pentium 90 и выше.

http://ntvdm.cjb.net - Проект VDMSound. Программа эмулирует MPU-401 интерфейс, SoundBlaster-совместимые звуковые карты (SB16, SBPro 2, SB2, SBPro, etc.) и интерфейс джойстика (game-port) для DOS-программ. Имеются исходные тексты.

http://dosbox.sourceforge.net - эмyлятоp DOSBox, создающий виpтyальнyю машинy для запyска DOS-пpиложений. Начиная с веpсии 0.60 поддеpживает Protected Mode.


Сеть.

7.01 Как в одноранговой сети обеспечить доступ к общим ресурсам? Поставлен полный доступ для всех, но при обращении требует пароль на ресурс IPC$ :(

7.02 Как отвечать человеку, который шлет с Win98 сообщения по winpopup?

7.03 Как включить роутинг в Windows 2000 Professional?

7.04 Как сделать, чтобы DOS-программа, печатая на LPT1, на самом деле печатала на сетевой пpинтеp \\server_name\printer_name?

7.05 Механизмы лицензирования служб Terminal Services в Windows 2000.

7.06 Как отключить датчик наличия сетевого соединения (Media Sense)?

7.07 Как полностью отключить скрытые общие ресурсы (ADMIN$, C$, D$ и т.д.)?

7.08 Как заставить Windows 2000 принимать входящие звонки? В Win9x был Сервер удаленного доступа, а под W2k не могу найти ничего подобного :(

7.09 Можно ли подключиться к серверу удаленного доступа на Win9x?

7.10 Почему просмотр общих сетевых ресурсов машин с Windows 9x/Me из-под Windows 2000 сильно замедлен? Можно ли его как-то ускорить?

7.11 Подскажите, как запустить службу входящих звонков из командной строки. Мне нужно, чтобы компьютер принимал звонки только в определенное время...

7.12 Как заставить DNS сервер переправлять все неразрешенные запросы на DNS сервер провайдера? Флажок Enable forwarders свойствах DNS сервера недоступен.

7.13 Из папки "Сеть и удаленный доступ к сети" пропала иконка "Подключение по локальной сети" (или иконка "Создание нового подключения"). Как их вернуть?

7.14 Как запретить хранение хэш-данных службы LAN Manager в AD и в базе SAM?

7.15 Где можно ознакомится с описанием портов протокола TCP/IP?

7.01. Как в одноранговой сети обеспечить доступ к общим ресурсам? Поставлен полный доступ для всех, но при обращении требует пароль на ресурс IPC$ :(

По умолчанию в Windows 2000 отключена учетная запись "Гость", поэтому пользователь, не зарегистрированный компьютере, не сможет получить доступ к общим ресурсам на этом компьютера. Можно включить её, запустив оснастку "Локальные пользователи и группы" (Для версии Professional: правый клик на значке Мой компьютер -> Управление -> Служебные программы или просто набрать lusrmgr.msc в меню Выполнить -> Запуск программы). Далее, открываем папку Пользователи, двойной клик на пользователе "Гость", в появившихся Свойствах убираем галочку напротив "Отключить учетную запись". Теперь запрос на доступ к ресурсу IPC$ при обращении к компьютеру по сети появляться не будет. Хотя правильнее будет завести на машине нужное число локальных пользователей. Причем можно запретить им локальный вход в систему, разрешив только сетевой доступ. Зайдите в Панель управления -> Администрирование -> Локальная политика безопасности -> Параметры безопасности -> Локальные политики -> Hазначение прав пользователя, параметр "Локальный вход в систему" - уберите пользователя из списка или в параметре "Отклонить локальный вход" - внесите.

7.02. Как отвечать человеку, который шлет с Win98 сообщения по winpopup?

Прочитайте справку: net send /? Кроме этого, можно в Computer Management выбрать Action->All Tasks->Send Console Message.

7.03. Как включить роутинг в Windows 2000 Professional?

В версии Professional эта возможность включается только через реестр. В разделе HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters значение параметра IPEnableRouter (тип REG_DWORD) установите в "1".

7.04. Как сделать, чтобы DOS-программа, печатая на LPT1, на самом деле печатала на сетевой пpинтеp \\server_name\printer_name?

Вводим из консоли: net use lpt1: \\server_name\printer_name. При завершении работы программы можно освободить порт: net use lpt1: /delete. Если вы хотите, чтобы ресурс автоматически подключался при каждой загрузке системы, используйте ключ /persistent:yes (cм. также справку net use /?).

7.05. Механизмы лицензирования служб Terminal Services (далее TS) в Win 2000.

TS могут устанавливаться в двух вариантах - для удаленного администрирования и как сервер приложений. Для первого варианта лицензирование не требуется, а для работы TS в режиме сервера приложений (помимо самих TS) требуется:

1) установить License Server (LS). В AD-домене существует два типа: enterpise и domain. Доменные устанавливаются на DC и обслуживает сервера своего домена. Enterprise устанавливается на любой DC и обслуживает сервера в пределах леса. В случае домена NT4 или рабочей группы LS похоже ищется броадкастом (хотя в логе написано "Confirm that all license servers on the network are registered in WINS\DNS, accepting network requests, and Licensing Service is running.").

2) активизировать LS. Активизация производится с помощью мастера, и может быть выполнена: а) через Интернет, б) на WWW-сайте, в) по факсу или телефону. Для активации требуется лишь лицензия на сам Windows 2000 сервер, то есть если он у вас тем или иным образом установлен, то в активации вам не откажут.

3) для использования TS не-W2k клиентами, нужно дополнительно приобрести и установить на LS клиентские лицензии (TS CAL).

При старте TS происходит поиск LS, и если за 90 дней активированый LS не будет обнаружен, то запуск TS завершится ошибкой: "не найден LS". При входе клиентов TS проверяет действительность их лицензий, и если лицензия отсутствует или временная, он обращается к LS за лицензией. При недоступности LS TS сам выдает временную лицензию на 90 дней. При отсутствии у LS свободных лицензий он тоже выдает временную лицензию. Если у клиента временная лицензия, но у LS есть возможность выдать постоянную, постоянная лицензия выдается, а запись о старой временной удаляется (если временную выдавал тот же LS). Клиент Windows 2000 (а также последующих версий, т.е. WXP Pro), имеет "право на постоянную лицензию", но самой лицензии не имеет. TS все равно обращается к LS и если тот активирован, выдается постоянная лицензия (видимо, для учета). Итак, для работы клиентов W2k тоже нужен активированный LS, но дополнительные лицензии не требуются.

Если дата временной лицензии истекла, клиенту отказывается в доступе. Запись об этом заносится в eventlog. Если присоединяться с помошью RDP-клиента, то клиенту сообщается про закончившуюся лицензию. Если по протоколу ICA или Х11, то не пишется. Для ICA диагностика - "error connecting to citrix server".

При описанном механизме постоянных лицензий возникает проблема потери лицензии в случае переустановки ПО на клиенте. Поэтому, начиная с постфикса Q287687 к SP2 (см. http://support.microsoft.com/default.aspx?scid=kb;en-us;287687) MS изменил механизм выдачи лицензий. После установки этого апдейта (Terminal Services Licensing Enhancements), LS выдает вместо постоянных лицензий временные со случайным временем жизни от 52 до 89 дней. Когда до истечения лицензии остается 7 дней, TS запрашивает LS о продлении лицензии и выдает продленную лицензию клиенту. Данное исправление включено в W2k SP3.

На клиенте лицензия в общем случае хранится в разделе реестра HKLM\SOFTWARE\ Microsoft\MSLicensing\Store, в случае протокола X11 или если не-Windows клиент работает по протоколу ICA, то на сервере в HKLM\SOFTWARE\Citrix\MSLicensing\Store. LS хранит свою базу лицензий (постоянных и выданных) в задаваемой при его установке директории. По умолчанию это %SystemRoot%\system32\LServer.

7.06. Как отключить датчик наличия сетевого соединения (Media Sense)?

Определение состояния сетевого соединения возможно при использовании протокола TCP/IP в сети на витой паре. При отсутствии соединения в тpее появляется значок "Network Cable Unplugged" и сетевое соединение отключается. После этого компьютер теряет свой сетевой адрес и отвечает только на адрес 127.0.0.1, что может повлиять на работоспособность многих сетевых программ. Для мобильных или домашних пользователей в таком случае будет полезно отключить эту возможность. Для этого в разделе HKLM\System\CurrentControlSet\Services\Tcpip\Parameters реестра параметр DisableDHCPMediaSense (тип REG_DWORD) нужно установить в "1". Подробнее: http://support.microsoft.com/default.aspx?scid=kb;EN-US;q239924.

7.07. Как полностью отключить скрытые общие ресурсы (ADMIN$, C$, D$ и т.д.)?

Данные скрытые ресурсы существуют по умолчанию. Доступ к ним возможен только из под аккаунта администратора, поэтому не рекомендуется задавать для этого аккаунта слишком простой пароль (например, Enter :)). Для увеличения степени секретности можно также изменить имя пользователя "Администратор" на другое. Если удалить эти ресурсы через "Управление компьютером" -> "Общие папки", то после перезагрузки они появятся снова. Полностью отключить скрытые ресурсы можно только с помощью правки реестра. Откройте раздел

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

Добавьте или измените следующие значения:

Операционная система        Параметр         Тип        Значение
Windows 2000 Server         AutoShareServer  REG_DWORD  0
Windows 2000 Professional   AutoShareWks     REG_DWORD  0

7.08. Как заставить Windows 2000 принимать входящие звонки? В Win9x был Сервер удаленного доступа, а под W2k не могу найти ничего подобного :(

Заходим в меню Пуск (Start) -> Панель Управления (Control Panel) -> Сеть и удаленный доступ к сети (Network and Dial-up Connections) -> Файл (File) -> Hовое подключение (Make New Connection) -> Принимать входящие подключения (Accept Incoming Connections). Этот пункт активен только под логином администратора. В версии Professional возможно создать только одно входящее соединение, в версии Server их число ограничено числом установленных модемов.

7.09. Можно ли подключиться к серверу удаленного доступа на Win9x?

Да, можно. Зайдите в Свойства соединения, закладка "Безопасность" -> "Дополнительные (особые параметры)" -> "Hастройка" -> "Разрешить следующие протоколы" -> опция "Разрешить старый протокол MS-CHAP для Windows 95".

7.10. Почему просмотр общих сетевых ресурсов машин с Windows 9x/Me из-под Windows 2000 сильно замедлен? Можно ли его как-то ускорить?

Когда Windows 2000 пытается получить доступ к общим ресурсам Windows 9x/Me, он также проверяет наличие назначенных заданий для этих машин. Отключение этой опции позволит увеличить скорость доступа. Для этого в разделе реестра HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\RemoteComputer\NameSpace нужно удалить ключ {D6277990-4C6A-11CF-8D87-00AA0060F5BF}.

7.11. Подскажите, как запустить службу входящих звонков из командной строки. Мне нужно, чтобы компьютер принимал звонки только в определенное время ...

Создаем два *.bat или *.cmd файла следующего содержания:

1) net start REMOTEACCESS - для запуска службы,
2) net stop REMOTEACCESS  - для останова.

Затем в планиpовщике указываем, когда какому файлу нужно запускаться.

7.12. Как заставить DNS сервер переправлять все неразрешенные запросы на DNS сервер провайдера? Флаг Enable forwarders в свойствах DNS сервера недоступен.

Эта проблема возникает, если DNS сервер сконфигурирован как root сервер, т.е. на сервере имеется зона ".". Обычно это происходит при установке Active Directory, если помощник не смог установить соединение с любым внешним DNS сервером, то он конфигурирует Ваш сервер как root и создает зону ".". Для решения проблемы удалите зону ".", используя DNS Manager, или с помощью команды: dnscmd /ZoneDelete . /DsDel.

Ключ /DsDel нужен в случае, если зона интегрирована с Active Directory. Оригинал: http://support.microsoft.com/default.aspx?scid=kb;EN-US;q229840.

7.13. Из папки "Сеть и удаленный доступ к сети" пропала иконка "Подключение по локальной сети" (или иконка "Создание нового подключения"). Как их вернуть?

1) Проверьте, запущены ли службы "Plug and Play" (без нее не отображается "Подключение по локальной сети") и "Удаленный вызов процедур (RPC)" ( без нее не будет значка "Создание нового подключения"). Запустите их и установите тип запуска "Авто". Остановленную службу "Удаленный вызов процедур (RPC)" включить можно только в Recovery Console командой: Enable RPCSS Service_Auto_Start или с помощью редактора реестра. Запустите regedit.exe и в разделе HKLM\SYSTEM\CurrentControlSet\Services\RPCSS присвойте параметру Start (DWORD) значение 2.

2) Восстановите настройки DCOM по умолчанию. Для этого запустите утилиту dcomcnfg.exe и выберите закладку "Свойства по умолчанию" - установите поле "Уровень олицетворения по умолчанию" равным "Определить" (в английской версии: закладка "Default Properties", в поле "Default Impersonation Level" установить значение "Identify"). Для вступления изменений в силу нужно перелогиниться.

3) Проверьте настройки групповой политики ("Пуск"->"выполнить"-> "%SystemRoot%\system32\gpedit.msc /s"). В административных шаблонах сети проверьте, нет ли запрета на изменения свойств сетевых подключений.

4) Заново зарегистрируйте dll управления сетью: Netcfgx.dll, Netman.dll, Netshell.dll. Для этого в консоли выполните команды:

regsvr32 netshell.dll
regsvr32 netcfgx.dll
regsvr32 netman.dll и перезагрузите компьютер.

Подробнее: http://support.microsoft.com/default.aspx?scid=kb;EN-US;q254631.

7.14. Как запретить хранение хэш-данных службы LAN Manager в AD и в базе SAM?

В W2k поддерживаются методы аутентификации LAN Manager (LM), NT LAN Manager (NTLM) и NTLM version 2 (NTLMv2). LM хранит пароли в хэш-формате, что упрощает взлом данных. Hачиная с SP2 появилась возможность отключить хранение LM-хэшей. Для этого на контроллере домена добавьте параметр NoLMHash(DWORD)=1 в разделе HKLM\SYSTEM\CurrentControlSet\Control\Lsa, затем перезагрузите компьютер.

Имейте в виду, что компоненты, использующие LM-хэш (например, процедура изменения паролей для W9x, аутентификация клиента W9x, если не установлен пакет Directory Services client pack), могут перестать корректно работать.

Подготовлено на основе статьи Джона Севилла, MCSE, john@savilletech.com.

7.15. Где можно ознакомится с описанием портов протокола TCP/IP?

1) в файле %systemroot%\System32\drivers\etc\services - в кратком изложении,

2) по ссылке http://support.microsoft.com/default.aspx?scid=kb;ru;832017.


Сообщения об ошибках и предупреждения.

8.01 Как избавиться от ошибки: Event ID: 43, Description: WMI ADAP failed to connect to namespace \\.\root\cimv2\MS_419 with the following error:0x8004100e.

8.02 Как избавиться от ошибки: Код события: 3101, Описание: Hе yдается пpочитать сведения об yпpавлении вводом/выводом от yстpойства NBT.

8.03 Как избавиться от сообщения: Event ID: 542 Description: The IP Security policy for ISAKMP/Oakley specified an encryption algorithm that is invalid due to export cryptography restrictions. <...>

8.04 С некотоpых поp пpи запyске ДОС-пpиложений появляеся сообщение, что "Virtual Device Driver format in the registry is invalid. Choose 'Close' to terminate the application". Если выбрать 'Ignore', все работает. Это лечится?

8.05 Как избавиться от сообщений об ошибках, связанных со счетчиками производительности, использующими Windows Management Instrumentation (WMI)?

8.06 Где можно найти подробное описание сообщения об ошибке (предупреждения) по его номеру (коду события, Event ID)? Особенно интересуют ошибки STOP.

8.07 При печати клиента из терминального режима (установлен Citrix Metaframe) на локальный принтер в системном логе сервера появляется сообщение об ошибке: Event ID: 1103 Description: An internal communication error occurred. <...>

8.08 Сервис svchost.exe либо инициирует перезагрузку, либо виснет, либо вылетает с ошибкой при подключении к интернету/локальной сети. Что делать?

8.01. Как избавиться от ошибки:

Event Type: Error
Event Source:   WinMgmt
Event Category: None
Event ID:   43
Description:
WMI ADAP failed to connect to namespace \\.\root\cimv2\MS_419
with the following error: 0x8004100e

Ошибка возникает в английской версии W2k при установке поддержки русских национальных стандартов. Для исправления ошибки идем в каталог System32\wbem, ищем там файлы: cimwin32.mfl, msi.mfl, ntevt.mfl, secrcw32.mfl и копируем их во временный каталог. Открываем их в Блокноте и изменяем 4 0 9 на 4 1 9 в _верхних 3-5 строчках_ в двух местах во всех четырёх файлах (т.к. 4 0 9 встречается более чем в двух местах). Помещаем туда же файл patch409.cmd:

@echo off
pushd %windir%\system32
copy perf?009.dat ??????1?.*
popd
mofcomp.exe cimwin32.mfl
mofcomp.exe msi.mfl
mofcomp.exe ntevt.mfl
mofcomp.exe secrcw32.mfl
winmgmt /clearadap
echo Please - reboot your computer!

запускаем этот файл на выполнение, перезагружаемся.

Также можно использовать VB-script, который можно взять здесь:
http://adsh.ukrweb.net/win2k/soft/419fix.php (1Kb).

8.02. Как избавиться от ошибки:

Тип события: Ошибка
Источник события: perfctrs
Категоpия события: Отсyтствyет
Код события: 3101
Описание:
Hе yдается пpочитать сведения об yпpавлении вводом/выводом от yстpойства NBT.

Данная ошибка возникает в результате того, что счетчики производительности протокола TCP/IP пытаются прочитать управляющую информацию ввода-вывода от сетевого устройства, но ни одного такого устройства в системе не установлено. Существует несколько методов решения проблемы:

1. Запустите exctrlst.exe из Resource Kit-а, выберите счетчик "Tcpip Perfctrs.dll" и снимите флажок "Performance counters enabled". Закройте окно "Extensible Counter List" и перегрузите компьютер. Утилиту exctrlst.exe также можно загрузить из сети Интернет по адресу:

http://download.microsoft.com/download/win2000platform/exctrlst/1.00.0.1/NT5/EN-US/exctrlst_setup.exe.

2. Откройте раздел системного реестра:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Performance

Добавьте параметр "Disable Performance Counters" и установите его значение в "1" (тип DWORD). Чтобы изменения вошли в силу, перезагрузите компьютер.

3. Установите эмулятор сетевой карты - Microsoft Loopback Adapter.

В ответе использована статья R11071 с http://www.microsoft.ru/catalog/ article.asp?article_id={4CA8A861-B996-11D4-9DAA-00508B8B6DC3}.

8.03. Как избавиться от сообщения:

Event Type:  Information
Event Source:  Oakley
Event Category:  None
Event ID: 542
Description:
The IP Security policy for ISAKMP/Oakley specified an encryption algorithm
that is invalid due to export cryptography restrictions. All 3DES encryption
used by ISAKMP/Oakley is weakened to standard DES encyption. <...>

Данное сообщение возникает из-за существовавшего ранее экспортного ограничения на алгоритм 3DES со 128-битным ключем. Теперь это ограничение снято, и можно свободно скачать Windows 2000 High Encryption Pack с сайта Microsoft по этому адресу: http://www.microsoft.com/windows2000/downloads/recommended/encryption/default.asp, предварительно выбрав тип инсталляции и нужный язык обновления. Также 128-битное шифрование включено в пакет обновлений, начиная с SP2.

(!) Если вы установили High Encryption Pack, не устанавливайте сразу после этого Service Pack 1, сначала _обязательно_ перегрузите систему. Иначе ваш компьютер может зависнуть на стадии "Preparing Network Connections". Подробнее читайте здесь: http://support.microsoft.com/default.aspx?scid=kb;EN-US;q270842.

8.04. С некотоpых поp пpи запyске ДОС-пpиложений появляеся сообщение, что "Virtual Device Driver format in the registry is invalid. Choose 'Close' to terminate the application". Если выбрать 'Ignore', все работает. Это лечится?

Полный текст сообщения может быть таким:

16 bit MS-DOS Subsystem
drive:\program path
XXXX. An installable Virtual Device Driver failed DLL initialization. Choose
'Close' to terminate the application.

или таким:

16 bit MS-DOS Subsystem
drive:\program path
SYSTEM\CurrentControlSet\Control\VirtualDeviceDrivers. VDD. Virtual Device
Driver format in the registry is invalid. Choose 'Close' to terminate the
application.

Эта ошибка обычно появляется после инсталляции 16-bit программ или программ, использующих 16-bit инсталляторы. Как правило, повреждается параметр VDD в разделе реестра HKLM\SYSTEM\CurrentControlSet\Control\VirtualDeviceDrivers. Для устранения ошибки запустите Regedt32.exe, найдите вышеуказанный параметр и удалите его. Затем добавьте новый параметр, назовите его VDD, и выберите тип данных REG_MULTI_SZ. Откроется редактор для ввода многострочного текста. Оставьте поле ввода пустым и нажмите "Ok". Подробнее можно почитать здесь: http://support.microsoft.com/default.aspx?scid=kb;EN-US;q254914.

8.05. Как избавиться от сообщений об ошибках, связанных со счетчиками производительности, использующими Windows Management Instrumentation (WMI)?

В общем случае ошибки имеют вид (где [file name] - имя файла библиотеки):

Event Type: Error
Event Source: WinMgmt
Event Category: None
Event ID: 37
Description: WMI ADAP was unable to load the [file name] performance library
due to an unknown problem within the library: 0x0

[...]
Event ID: 41
Description: ADAP was unable to process the [file name] performance library
due to a time violation in the collect function

[...]
Event ID: 61
Description: WMI ADAP was unable to process the [file name] performance
library due to a time violation in the open function

1. Данные ошибки могут возникнуть из-за проблем в счетчике производительности или из-за ошибочной величины, возвращаемой источником данных библиотеки производительности WMI. Попробуйте инициализировать библиотеку командой:

winmgmt /clearadap,

которая очистит в реестре все ключи служб производительности, связанных с WMI, а именно параметры WbemAdapFileSize, WbemAdapFileTime, WbemAdapStatus в разделе Performance соответствующих служб. Затем вновь зарегистрируйте библиотеки производительности с помощью команды: winmgmt /resyncperf <ID процесса службы WinMgmt>. Требуемый ID можно посмотреть в закладке "Process" Windows Task Manager.

2. Другой возможной причиной появления ошибок является задержка обновления значений счетчиков при загрузке W2k из-за нехватки вычислительных ресурсов. Попробуйте увеличить время ожидания с помощью увеличения значения параметра Collect Timeout:REG_DWORD в разделе реестра HKLM\System\CurrentControlSet\Services\[countername]\Performance, где [countername] - название нужной библиотеки производительности. Берется из сообщения об ошибке в Event Viewer, например: HKLM\System\CurrentControlSet\Services\PerfProc\Performance.

Если ошибка осталась, попробуйте установить значение параметра WbemAdapStatus (тип REG_DWORD) в 0, а затем увеличьте значение параметра ADAPPerflbTimeout (тип REG_DWORD) до 180 в разделе реестра HKLM\Software\Microsoft\Wbem\CIMOM.

3. Если ничего из вышеописанного не помогает, остается только отключить проблемный счетчик с помощью утилиты Exctrlst.exe из Windows 2000 Resource Kit (см. также раздел 8.02.1) или вручную, с помощью правки реестра. Hапример, для библиотеки winspool.drv добавляем параметр Disable Performance Counters (тип REG_DWORD) =1 в раздел реестра HKLM\System\CurrentControlSet\Services\Spooler\Performance (см. также раздел 8.02.2). Статья-оригинал находится по адресу: http://support.microsoft.com/default.aspx?scid=kb;EN-US;q266416.

8.06. Где можно найти подробное описание сообщения об ошибке (предупреждения) по его номеру (коду события, Event ID)? Особенно интересуют ошибки STOP.

Данная информация включена в поставку Windows 2000. Подробное описание всех системных сообщений находится в файле w2000msgs.chm дистрибутива, который в свою очередь находится в архиве \support\tools\support.cab. Последняя версия данного файла бесплатно доступна для скачивания на сайте Microsoft по адресу:
http://www.microsoft.com/windows2000/techinfo/messages/default.asp. Кроме этого, для поиска информации по Event ID существует специальный ресурс:
http://www.eventid.net/display.asp?eventid=<здесь введите нужный Event ID>. Там же можно скачать программу EventReader, которой, если понравится, можно заменить стандартный EventLog:
http://www.eventid.net/eventreader/download.asp.

8.07. При печати клиента из терминального режима (установлен Citrix Metaframe) на локальный принтер в системном логе сервера появляется сообщение об ошибке:

Event ID: 1103
Event Type: Error
Event Source: TermServDevices
Description: An internal communication error occurred. Redirected printing
will no longer function.

Это происходит, если имя принтера на рабочей станции не совпадает с именем принтера на терминал-сервере. Как правило, это бывает, если в качестве клиента используются компьютеры под управлением Windows 95/98/Me. Запишите название принтера на рабочей станции в локальном режиме, затем начните установку этого принтера на терминал-сервере и снова запишите его название. Затем откройте файл %systemroot%\system32\Wtsuprn.txt и добавьте в него свой принтер. Уберите значек комментария перед вносимой строкой, а полученный файл сохраните под именем %systemroot%\system32\Wtsuprn.inf. Сделайте log off, и снова log on на терминал-сервере. Затем подключитесь с клиентской рабочей станции. Ваш принтер должен автоматически появится в папке Printers терминальной сессии.

Более подробно о решении этой и схожих проблем можно почитать здесь:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;q276532
http://support.microsoft.com/default.aspx?scid=kb;EN-US;q214593.

8.08. Сервис svchost.exe либо инициирует перезагрузку, либо виснет, либо вылетает с ошибкой при подключении к интернету/локальной сети. Что делать?

Скорее всего, вы атакованы вирусом MSBlast (он же Lovesan). Почитать про него можно здесь: http://www.microsoft.com/technet/security/alerts/msblaster.asp или здесь (сокращенный вариант): http://www.microsoft.com/rus/news/blast.asp.

Для удаления вируса вам необходимо выполнить следующие действия:

1) Скачиваем патч kb824146 (MS03-036) для вашей версии Windows:
Windows2000-KB824146-x86-RUS.exe (920 Кб, 10.09.2003)
Windows2000-KB824146-x86-ENU.exe (917 Kb, 9/10/2003)

2) Скачиваем программу для удаления вируса с сайта Касперского:
ftp://ftp.kaspersky.ru/utils/clrav.com, или с сайта Microsoft:
Windows-KB833330-RUS.exe (317 Кб, 31.12.2003)
Windows-KB833330-ENU.exe (317 Kb, 12/31/2003)

3) Перед началом лечения отключаем компьютер от сети (можно просто вынуть кабель из сетевой карты) для исключения мгновенного повторного заражения.

4) Отключаем монитор вашего антивируса (если он включён) для того, чтобы он не мог блокировать доступ к файлу вируса при работе программы лечения.

5) Запускаем командную строку и заходим в каталог, где лежит файл clrav.com. Набираем: clrav /s, запустится процесс сканирования жёстких дисков компьютера. Если вы скачали программу лечения с сайта Microsoft, просто запустите её.

6) Устанавливаем патч kb824146, это требует наличия в системе SP2 или выше.


Составители.

Vladimir Suvorov suvorov@permonline.ru - составление и оформление
Roman Klin Roman.Klin@p25.f1490.n5020.z2.fidonet.org (модератор) - еженедельный постинг, дополнения и проверка
Alexander Sheiko adsh@univ.kiev.ua (комодератор) - редактирование, HTML версия, публикация в Интернет
Michael Glushko mice@reklama.tomsk.ru - проверка и дополнения.


Установка системы.

2.01 Как создать комплект инcталляционных дискет?

2.02 Сервис-пак не хочет интегрироваться в дистрибутив W2k. Запускаю так: sp1network.exe -s:e:\distr\system\win2000\, а он мне в ответ: "Not all files necessary to perform an integrated installation are present."

2.03 Как сделать загрузочный диск для W2k/WNT4?

2.04 Как пеpенести раздел W2k на раздел дpугого винчестера с сохpанением всех настpоек. Hе хочется все заново пеpеустанавливать...

2.05 Что надо сделать, чтобы увидеть все установленные компоненты Windows?

2.06 Подскажите способ переноса учетных записей из NT4 (PDC) в русский Windows 2000 Server, если такой существует?

2.07 Какой размер кластера для NTFS по умолчанию?

2.08 Hужно ли устанавливать Service Pack 1 перед установкой Service Pack 2?

2.09 Как изменить букву системного / загрузочного диска в Windows 2000?

2.10 После изменения прав доступа к файлам (security permissions) на NTFS хочется вернуть все к тому виду, как было после установки. Возможно ли это?

2.11 Можно ли в процессе установки W2k запустить какую-либо программу?

2.01. Как создать комплект инcталляционных дискет?

Инсталляционные дискеты помогут вам, если ваше устройство CD-ROM не является загрузочным, или материнская плата не поддерживает загрузку с CD. Чтобы создать их, зайдите в каталог \BOOTDISK дистрибутива, и запустите файл makeboot.exe (работает и под DOS) или makebt32.exe (консольная версия). Затем следуйте указаниям программы. Если вы собираетесь устанавливать с помощью этих дискет систему с дистрибутива с интегрированным сервис-паком, убедитесь сначала, что файлы на дискетах и файлы дистрибутива имеют одинаковую версию. В противном случае вы полyчите следyющее сообщение об ошибке:

"The following value in the .SIF file used by setup is corrupted or missing: Value '0' on the line in section [SourceDiskFiles] with key "SP1.CAB"

Для устранения этой ошибки замените файлы на дискетах на более свежие из комплекта дистрибутива, в первую очередь это касается файла txtsetup.sif.

2.02. Сервис-пак не хочет интегрироваться в дистрибутив W2k. Запускаю так: sp1network.exe -s:e:\distr\system\win2000\, а он мне в ответ: "Not all files necessary to perform an integrated installation are present."

Распакуйте дистрибутив сервис-пака, запустив sp1network.exe -x (путь сам спросит) и только потом интегрируйте (запускайте уже i386/update/update.exe). Если это не помогает, проверьте файл сервис-пака на соответствие оригиналу:

 SP1 English: sp1network.exe: 87326656 байт, дата: 25.07.00, время: 00:11
 SP1 Russian: sp1network.exe: 88791904 байт, дата: 04.10.00, время: 00:33

 SP2 English: W2KSP2.exe: 106278016 байт, дата: 07.05.01, время: 13:34
 SP2 Russian: W2KSP2.exe: 105598968 байт, дата: 20.06.01, время: 15:25

 SP3 English: W2Ksp3.exe: 130978672 байт, дата: 04.08.02, время: 21:20
 SP3 Russian: W2Ksp3.exe: 129734288 байт, дата: 26.08.02, время: 13:17

 SP4 English: w2ksp4_en.exe: 135477136 байт, дата: 20.06.03, время: 10:30
 SP4 Russian: w2ksp4_ru.exe: 133952584 байт, дата: 21.06.03, время: 03:46

2.03. Как сделать загрузочный диск для W2k/WNT4?

1. Метод с использованием программы CDRWIN (http://www.goldenhawk.com/) (См. также статью http://www.contamination.org/windows2000/burning_cds.html).

Внимание! Программа CDRWIN фирмы Engelmann Media GmbH не содержит описанных ниже возможностей и в данном случае абсолютно бесполезна.

1) Для записи необходим каталог \i386 дистрибутива, а в корне создаваемого диска должны лежать маркерные файлы (содержимое их значения не имеет):

 CDROM_NT.5   - для всех Windows 2000
 CDROM_SP.TST - если в дистрибутив интегрирован 1-й сервис-пак
 CDROMSPx.TST - если в дистрибутив интегрирован x-й сервис-пак
 CDROM_IP.5   - Windows 2000 Professional
 CDROM_IS.5   - Windows 2000 Server
 CDROM_IA.5   - Windows 2000 Advanced Server
 CDROM_W.40   - Windows NT Workstation
 CDROM_S.40   - Windows NT Server

Кроме того, для локализованных версий W2k в корень диска нужно добавить файл BOOTFONT.BIN (берется из каталога \i386 или с первого диска из комплекта инсталляционных дискет). В каталог \i386 NT 4.0 рекомендуется положить файл BOOTFIX.BIN из дистрибутива W2k - он предотвратит случайную загрузку с CD-R.

2) выбираем в верхнем меню Backup/Tool Operation режим Build an ISO 9660 Image File.

3) в следующем пункте выбираем каталог, где подготовлены файлы для записи на CD (например, C:\W2kCD, в котором лежит каталог i386 дистрибутива и указанные выше файлы) и указываем имя файла образа диска, например, w2kboot.iso.

4) убираем флажок в пункте Preserve Full Pathnames

5) установливаем флажки в пунктах Recurse Subdirectories, Disable Version Numbers, Include System Files, Include Hidden Files и, если хотите использовать длинные имена, Long Filenames (Joliet).

6) на закладке Advanced Option/Bootable Disk помечаем 'Make bootable disc', и заполняем следующие поля:

 Media Emulation Type: Custom
 Image File Name: boot.bin
 Developer Name: Microsoft Corporation
 Load Segment: оставляем как есть (07с0)
 Load Sector Count: указываем 4

7) там же в Advanced Option/Volume Descriptor прописываем Volume Label:

 для Windows 2000 Professional - W2PIS_EN,
 для Windows 2000 Server - W2SIS_EN,
 для Windows 2000 Advanced Server - W2AIS_EN.

(!) Метки указаны для английских версий, для русских замените _EN на _RU.

8) нажимаем кнопку Start. Полученный образ можно записать на диск, используя свою любимую CD-R программу (Easy CD Creator, Nero и т.д.) или с помощью пункта Record an ISO 9660 Image File в CDRWin-е.

2. Метод с использованием программы Nero - Burning Rom.

1) создаём новую компиляцию ("New Compilation") типа CD-ROM (Boot)

2) на вкладке Boot окна свойств компиляции указываем в качестве Image file файл boot2m.bin (у Nero свой формат; чтобы использовать boot.bin, необходимы дополнительные действия, см. пункт 3), включаем опцию "Enable expert settings (for advanced users only)" и в группе параметров "Expert settings" указываем:

 Kind of emulation: No Emulation
 Boot message: оставляем, как есть по умолчанию
 Load segment of sectors (hex): 07C0 (оставляем по умолчанию)
 Number of loaded sectors: указываем 4

3) на вкладке "ISO" указываем:

 File/Directoryname length = ISO Level 1
 Format = Mode 1
 Character Set = ISO 9660 (или DOS - если нужны правильные имена файлов в DOS)
 Joliet - вкл.
 Relax ISO Restriction - обе опции: Allow pathdepth of more than 8 directories
 и Allow more than 255 characters in path - выкл.

Если вы хотите использовать стандартный загрузочный сектор boot.bin, то опцию Don't add the ";1" ISO file version extension (для версий 5.5.7.8 и выше), нужно включить. В противном случае (если используется boot2m.bin), эту опцию оставляем выключенной. В версиях Nero старее 5.5.7.8, использовать boot.bin можно, если в разделе реестра HKCU\Software\ahead\Nero - Burning ROM\General значение параметра AddISOFileVersion:REG_DWORD изменить с "1" на "0".

4) на вкладке "Label" оставляем по умолчанию ISO 9660, а метку тома (Volume label) указываем аналогично 2.03.1.7. Остальные поля оставляем по умолчанию. Опцию "Also use the ISO9660 text for Joliet" также оставляем включённой

5) на вкладке "Dates" оставляем всё по умолчанию, т.е. "Use the date and time from the original file", на вкладке "Misc" - также по умолчанию

6) на вкладке "Burn" включаем опцию "Finalize CD (No further writing possible)", в качестве "Write Method" выбираем "Disc-At-Once", остальные параметры (скорость записи, симуляция) - по желанию

7) нажимаем на кнопку "New" и добавляем в корень компиляции папку \I386 и маркерные файлы, перечисленные в 2.03.1.1. Можно добавить и другие файлы и каталоги (по желанию пользователя). Все, теперь можно начинать запись диска.

Файлы boot.bin, boot2m.bin и упомянутые маркерные файлы можно скачать здесь: http://adsh.ukrweb.net/win2k/soft/boot_cd_files.php. Желающие создать мультизагрузочный диск, а также подробнее узнать о загрузке с CD, могут посетить следующие ресурсы: http://bootcd.narod.ru/ и http://nu2.nu.

2.04. Как пеpенести раздел W2k на раздел дpугого винчестера с сохpанением всех настpоек. Hе хочется все заново пеpеустанавливать...

Загружаемся со старого жесткого диска. Создаём разделы нужного нам размера и форматируем их. Делаем загрузочный раздел активным. При этом не следует монтировать вновь созданные разделы и задавать им метку при форматировании. Если же это случайно произошло - удаляем БУКВЫ дисков и МЕТКИ томов свежесозданных разделов. Для этого заходим в Computer management -> Disk management -> клик правой кнопкой по диску -> Change drive letter and path -> дальше всё понятно. Метка тома удаляется там же - в свойствах раздела...

1) Загружаемся с предварительно созданной дискеты Norton Ghost 2001. Выбираем копирование "partition to partition", исходный диск, раздел на нём; диск назначения, раздел на нём и запускаем сам процесс клонирования. (3 Гб клонируется примерно за 15 минут). По окончании процесса нажимаем кнопку "reset computer" в Norton Ghost 2001 и, в момент загрузки логотипа с версией BIOS, выключаем компьютер. Вынимаем старый диск и делаем загрузочным новый.

Если требуется клонирование ВСЕГО содержимого жёсткого диска на другой винчестер, операции удаления букв разделов и меток томов диска назначения делать не обязательно. При этом в качестве клонируемого объекта следует выбирать не "partition" а "disk". Аналогичным образом производится клонирование и при помощи Drive Image 4.

2) Можно скопировать содержимое раздела в файл с целью бэкапа всей системы или для переноса её на другой винчестер. Эту операцию можно произвести тем же Norton Ghost 2001. Мы разберём этот процесс на примере Drive Image 4. Для наших целей удобно изготовить только загрузочные дискеты этой программы - устанавливать её на винчестер не обязательно. Грузимся в ДОС и запускаем Drive Image. Выбираем опцию создания образа раздела. Указываем раздел назначения и раздел, на котором будет располагаться наш образ. Указываем степень компрессии, если хотим сжать получающийся файл образа. При сжатии 3 Gb раздела с максимальной компрессией получается файл рамером 1.88 Gb. Процесс создания файла образа занимает в этом случае около часа.

Для восстановления содержимого файла-образа следует разбить новый диск так, как это описано выше. Затем, загрузившись в ДОС и запустив Drive Image, выбираем опцию "Restore", указывам расположение файла образа и раздел назначения. Если размер раздела, из которого делался файл образа превосходил размер созданного нами раздела назначения, но размер данных на исходном разделе укладывается в размер раздела назначения, то программа автоматически выполнит необходимые перерасчётные операции. Операция восстановления в вышеуказанном примере занимает 30 мин. При этом Drive Image корректно записывает загрузочный сектор в случае восстановления системного раздела.

(!) Если на перенесенном разделе была установлена "Recovery console", её придётся переустановить. В случае клонирования загрузочного раздела эхотага на другой винчестер для возможности загрузки с последнего следует иметь в виду, что необходимый для загрузки системы загрузочный сектор в таком случае может не переписаться на раздел назначения, т.к. он не является составной частью данных, находящихся на самом разделе. Это зависит от конкретного случая и программы клонирования (см. её документацию). Для записи загрузочного сектора при его отсутствии воспользуйтесь рекомендациями из вопроса 10.05.

Если не удалить БУКВЫ дисков и МЕТКИ томов диска назначения перед клонированием или, если загрузиться со старого диска при подключённом новом (с уже удалёнными буквами и метками или уже отклонированном), то мы можем столкнуться с проблемой загрузки W2k, описанной в ответе на вопрос 10.10.

2.05. Что надо сделать, чтобы увидеть все установленные компоненты Windows?

Чтобы в Add/Remove programs появились все компоненты Windows, надо найти файл sysoc.inf в WINNT\INF и подредактировать его - убрать слова HIDE и hide, везде, где они встретятся. Далеко не все из появившихся компонентов поддаются удалению, так что существенного выигрыша описанные действия не принесут.

2.06. Подскажите способ переноса учетных записей из NT4 (PDC) в русский Windows 2000 Server, если такой существует?

Существует специальная утилита - Active Directory Migration Tool (ADMT), позволяет переносить из одного домена в другой учетные записи, группы, доверительные отношения, а также выполнять другие задачи, связанные с процессом миграции. Целевой домен должен работать под управлением W2k, а исходный - W2k, Windows NT 4.0 (с SP4 или выше) или Windows NT 3.51 (с SP5).

Подробнее почитать про эту утилиту и процесс миграции можно здесь:
http:// www.microsoft.com/windows2000/techinfo/planning/activedirectory/admt.asp, а скачать саму утилиту (2,591 Kb) здесь:
http://download.microsoft.com/download/win2000platform/Utility/1.0/NT5/RU/ADMT.exe.

2.07. Какой размер кластера для NTFS по умолчанию?

Таблица зависимости размера кластера по умолчанию от размера раздела для NTFS:

 Размер раздела              Число секторов в кластере     Размер кластера

 До 512 Мбайт включительно                 1                   512 байт
  513-1024 Мбайт (1 Гбайт)                 2                    1 Кбайт
 1025-2048 Мбайт (2 Гбайт)                 4                    2 Кбайт
 2049 Мбайт и более                        8                    4 Кбайт

Ограничение в 4 Кбайт для кластера при форматировании раздела по умолчанию (т.е. без дополнительных параметров команды FORMAT) связано с тем, что при большем размере кластера становится невозможным применение функции сжатия NTFS. Все сказанное верно для версий Windows NT от 3.51 и выше. Тем не менее, если вы не собираетесь использовать сжатие методами файловой системы, можно отформатировать раздел с большим размером кластера, запустив команду FORMAT с ключом /A: size, где size - требуемый размер кластера.

Подробнее: http://support.microsoft.com/default.aspx?scid=kb;EN-US;q140365.

2.08. Hужно ли устанавливать Service Pack 1 перед установкой Service Pack 2?

Hет, не нужно. Каждая последующая версия сервис-пака включает все апдейты и фиксы предыдущей версии, т.е. имеет накопительный (кумулятивный) характер. Таким образом, достаточно поставить только последнюю версию сервис-пака, а не устанавливать последовательно все выпущенные версии. В то же время, если у вас уже установлена более ранняя версия, деинсталлировать её перед установкой более поздней версии не нужно. Таковы официальные рекомендации Microsoft.

2.09. Как изменить букву системного / загрузочного диска в Windows 2000?

Изменение буквы может потребоваться в случае поломки зеркального тома или при измененении конфигурации дисковой подсистемы. Hиже рассмотрено, как поменять местами буквы для дисков С и D. Если вам не нужно менять буквы местами, просто измените значение \DosDevice\[буква]: на любую неипользуемую букву. Имейте в виду, что при изменении буквы диска в нормально работающей системе перестанут работать программы, которые используют абсолютный метод адресации - придется переинсталлировать их или вручную изменять все неправильные пути в реестре.

1) Зайдите в систему как администратор и запустите Regedt32.exe.

2) Откройте ключ HKLM\SYSTEM\MountedDevices и разрешите администратору полный доступ к нему (меню Безопасность (Security) -> Разрешения (Permissions)).

3) Закройте Regedt32 и запустите regedit.exe. В указанном выше ключе найдите букву диска, которую вы хотите изменить, в нашем случае это "\DosDevices\C:".

4) Измените букву на любую неиспользуемую, например, "\DosDevices\Z:".

5) Выберите вторую изменяемую букву диска, т.е. "\DosDevices\D:", измените её на требуемую, в нашем случае будет "\DosDevices\C:".

6) Выберите значение "\DosDevices\Z:" и переименуйте его в "\DosDevices\D:".

7) Закройте regedit.exe и запустите Regedt32.exe. Верните разрешения для ключа HKLM\SYSTEM\MountedDevices в исходное состояние, т.е. "Read Only".

8) Перезагрузите компьютер.

Подробнее: http://support.microsoft.com/default.aspx?scid=kb;EN-US;q223188.

2.10. После изменения прав доступа к файлам (security permissions) на NTFS хочется вернуть все к тому виду, как было после установки. Возможно ли это?

Да, это возможно. Более того, это просто необходимо, если вы поставили W2k на FAT или FAT32, а затем отконвертировали файловую систему в NTFS (см. также вопрос 1.06). Для того, чтобы восстановить разрешения по умолчанию для NTFS, зайдите в систему под аккаунтом администратора, и введите в командной строке:

 Secedit /configure /db C:\winnt\temp\temp.mdb /Cfg
 %Windir%\inf\defltwk.inf /areas filestore  - для версии Professional

 Secedit /configure /db c:\winnt\temp\tmp.mdb /Cfg
 %Windir%\inf\defltsv.inf /areas filestore - для версии Server

Данная процедура затронет все папки из %Windir% и "Program Files", а для папки "Documents and Settings" все же придется выставлять права доступа вручную.

Список разрешений по умолчанию, активизирующихся в результате команды, можно найти здесь: http://support.microsoft.com/default.aspx?scid=kb;EN-US;q244600.

Замечание: после выполнения команды вы можете получить сообщение о том, что задача выполнена, но часть файлов отсутствует и для них операция не применима.

(!) Если вы запретили доступ к файлам аккаунту SYSTEM на загрузочном диске, то результатом будет невозможность загрузки системы. Для решения этой проблемы придется воспользоваться другой копией W2k (можно поставить вновь на другой диск или раздел) и с помощью Windows Explorer дать аккаунту SYSTEM полные права доступа на корневую папку и все системные файлы и папки. После этого, загрузившись в оригинальной версии W2k, восстановите разрешения по умолчанию. Подробнее: http://support.microsoft.com/default.aspx?scid=kb;EN-US;q237399.

2.11. Можно ли в процессе установки W2k запустить какую-либо программу?

Да, можно. Если в процессе графической части установки Windows 2000 нажать Shift-F10, появится окно Command Shell, из которого можно запустить любую программу (даже графическую). Запуск происходит от имени администратора. Эта возможность позволяет решить многие проблемы, не учтённые перед установкой.